Обучающий курс - ШЦСИО

О проекте

Настоящая система дистанционного обучения была разработана в 2001 году в Санкт-Петербургском Государственном Университете Телекоммуникаций им. проф. М.А.Бонч-Бруевича на кафедре ОПДС, в качестве дипломной работы студента Васильева Алексея Анатольевича по теме:
Разработка программных средств для дистанционного обучения на базе сети Internet по дисциплине ШЦСИО.

Система предназначена для использования в процессе обучения студентов дневного, вечернего и заочного обучения. Основой учебного материала данной работы является методическое пособие "ШЦСИО: структура и эталонная модель протоколов" М.В.Симонов, Н.С.Матемьянова Санкт-Петербург 1999.

Разработчик: Васильев Алексей Анатольевич.
Руководитель дипломной работы: аспирант Мартемьянова Наталья Сергеевна.

Design by Alex Vasilev


ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ

ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ

Общая характеристика
Простой протокол сетевого управления, как основа управления сетями АТМ
Базы данных управления сетями АТМ
Эксплуатация и техническое обслуживание

Общая характеристика

Плоскость менеджмента (Management Plane) охватывает функции менеджмента уровнями и плоскостями (рис. 10).Взаимосвязь между ними показана на рис. 51 [12].
Менеджмент плоскостями не имеет структуры. Его основными функциями является управление и обеспечение координации всеми уровнями и всеми плоскостями ШЦСИО. Менеджмент плоскостями сопрягается только с менеджментом уровнями, который обеспечивает стыки (интерфейсы) с плоскостями пользователя и управления. Стандарты этих интерфейсов определяются в настоящее время для телекоммуникационных систем СС МСЭ с помощью общего протокола информационного управления (CMIP - Common Management Information Protocol), а для оборудования передачи данных - группой инженерной поддержки сети Internet (IETF) с помощью простого протокола сетевого управления (SNMP - Simple Network Management Protocol).

Рис. 51. Взаимосвязь между уровнями и менеджментом уровнями и плоскостями

В ШЦСИО происходит расширение архитектуры и функции, но также и возможностей их реализации в интересах административного управления, эксплуатации и технического обслуживания телекоммуникационной сети менеджмента (TNN - Telecommunication Management Network). Менеджмент уровнями имеет четкую уровневую структуру и стыки с физическим уровнем, уровнем АТМ, уровнем адаптации АТМ и высшими уровнями как в плоскости контроля, так и в плоскости пользователя. Он осуществляет мониторинг этих уровней в целях поиска и локализации неисправностей, проверки соответствия параметров трафика пользователя и качества предоставляемого обслуживания; также он осуществляет реконфигурацию сети и т.п. в интересах динамического управления, административного управления, эксплуатации и технического обслуживания.
Основными уровнями системы управления сетями АТМ, как и любыми другими сетями, являются:
- уровень управления элементами сети;
- уровень, отвечающий за управление сетью в целом в обширной географической области и с оборудованием от различных поставщиков;
- уровень управления услугами, отвечающий за договорные аспекты качества предоставления услуг пользователям сети;
- уровень управления бизнесом.Международная организация стандартизации определила следующие функциональные сферы сетевого управления:
- управление восстановлением;
- управление производительностью;
- управление конфигурацией сети;
- организация сбора статистики и учета;
- управление безопасностью.


ОГЛАВЛЕНИЕ

ОГЛАВЛЕНИЕ

ПРИНЯТЫЕ СОКРАЩЕНИЯ
ПРЕДИСЛОВИЕ
СТРУКТУРА И ПРОТОКОЛЫ АТМ
Эталонная конфигурация ШЦСИО

Эталонная модель протоколов
ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ
Общие положения
Размещение ячеек АТМ
в кадрах систем синхронной цифровой иерархии
 Интерфейс на основе ячеек
Размещение ячеек в кадрах систем плезиохронной цифровой иерархии
Формирование поля контроля ошибок в заголовке, обнаружение и исправление ошибок
Разграничение ячеек
Согласование скоростей ячеек
УРОВЕНЬ АТМ
Структура ячеек
Виртуальные каналы и виртуальные пути
УРОВЕНЬ АДАПТАЦИИ АТМ
Структура протоколов уровня адаптации АТМ
Уровень адаптации АТМ 1-го типа
Уровень адаптации АТМ 2-го типа
Уровень адаптации АТМ 3/4-го типа
Уровень адаптации АТМ 5-го типа
ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ
Целевое назначение и функции
Принципы поддержки в сетях АТМ служб не ориентированных на соединение
Обеспечение функционирования высокоскоростных служб ПД, не ориентированных на соединение через АТМ
Обеспечение функционирования службы ретрансляции кадров через АТМ
TCP/IP через ШЦСИО
Эмуляция локальных вычислительных сетей
ПЛОСКОСТЬ УПРАВЛЕНИЯ И ЕЕ ФУНКЦИИ
Основные функции
Маршрутизация в ШЦСИО
Сигнализация в ШЦСИО
ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ
Общая характеристика
Простой протокол сетевого управления, как основа управления сетями АТМ
Базы данных управления сетями АТМ
Эксплуатация и техническое обслуживание
ЗАКЛЮЧЕНИЕ
ЛИТЕРАТУРА
Назад | Оглавление | Вперед
О проекте | Тест


ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ

Простой протокол сетевого управления,
как основа управления сетями АТМ

Простой протокол сетевого управления (SNMP- Simple Network Management Protocol) разработан группой инженерной поддержки сети Internet (IЕTF - Internet Engineering Task Force) для управления сетью Internet и де факто стал протоколом сетевого управления, эксплуатации и технического обслуживания сетей АТМ.
В архитектурной моделиSNMPподразумевается совокупность сетевых элементов и станций управления. Сетевые станции управления выполняют прикладные программы управления, которые контролируют и управляют сетевыми элементами. К сетевым элементам могут относиться различные сетевые устройства, в которые встроены так называемые агенты управления, ответственные за выполнение сетевых функций и управляемые со стороны сетевых станций управления.
SNMPпредназначен для передачи информации управления между сетевыми станциями управления и агентами в сетевых элементах.
Одной из основных целей, которая решалась при разработкеSNMP, являлась минимизация количества и сложности функций, реализуемых агентами самостоятельно. Это дает возможность:
- | уменьшить стоимость разработки программного обеспечения агента, необходимого для поддержки протокола;
- | наиболее полно использовать сетевые ресурсы за счет реализации наиболее сложных функций управления дистанционно;
- | упростить наборы функций управления и сделать их легко понимаемыми.
Второй целью являлось расширение возможностей протокола для решения сетевых задач, выявляемых уже в процессе эксплуатации сети.
И, наконец, третьей целью ставилось обеспечение независимости архитектуры протокола от архитектуры сети и специфики сетевых устройств.
ПротоколSNMPимеет только 5 типов сообщений:
- GET REQUEST (или просто GET - получить, читать);
- GET NEXT REQUEST (или просто GET NEXT);
- SET REQUEST (или просто SET - установить, изменить);
- RESPONSE (ответить);
- TRAP ("ловушка").
SNMPиспользует подмножество языка ASN.1 (Abstract Syntax Notation 1) для определения базы данных управления (MIB- Management Information Base) как для описания управляемых объектов, так и для описания протокольных блоков данных для управления этими объектами.
В моделиSNMPвсе функции агента сводятся, в принципе, к чтению или изменению переменной. Это ограничивает число функций управления, реализуемых агентом до двух: присвоение значения определенной конфигурации или другому параметру и чтение этого значения.
Сообщения GET, GET NEXT и SET получают в ответ сообщение RESPONSE.
Сообщение TRAP (ловушка) имеет существенное значение, так как оно является уведомлением о нестандартном событии, например, отказе (неисправности), перезапуске и т. п.
Стратегия протокола такова, что текущий контроль состояния сети выполняется на любом уровне, прежде всего путем опроса соответствующей информации со стороны центра мониторинга. Ограниченное число незапрашиваемых сообщений TRAPS ведется по таймеру и собирается в центре. Ограничение числа незапрашиваемых сообщений также преследует цель уменьшения трафика, генерируемого системой управления.
Обмен сообщениями происходит в дейтаграммном режиме согласно дейтаграммному протоколу пользователя (UDP- USER Datagram Protocol). Однако механизмыSNMPмогут применяться при широком спектре транспортных служб.
При использовании дейтаграммного протокола пользователя транспортный адрес состоит из адресаIPнаряду сUDPпортом. При использовании в качестве поддержки другого транспортного протокола назначение адреса должно выполняться в соответствии с требованиями выбранного протокола.
Ряд изменений в спецификации простого протокола сетевого управления определяет его вторую версию (SNMPv.2), которая обеспечивает более высокий уровень безопасности информации управления и характеризуется большей производительностью при увеличении количества управляемых объектов.
Большинство иностранных авторов считают, чтоSNMPи SNMPv.2 лучше соответствуют потребностям оборудования пользователей и оборудования ведомственных (частных) сетей, в то время как общий протокол информации управления (CMIP) - более подходит для обеспечения взаимодействия сетей общего пользования.
В настоящее время большинство выпускаемого коммутационного оборудования используетSNMP. В зарубежной литературе допускается возможность, что управление на основеSNMPможет стать де факто стандартом для сетей общего пользования, так как данный протокол широко используется в ведомственных (частных) сетях, абонентских сетях и оконечном оборудовании [4, 12, 19].


Обучающий курс ШЦСИО

ПРИНЯТЫЕ СОКРАЩЕНИЯ

ПРИНЯТЫЕ СОКРАЩЕНИЯ

русские
БЧХ | - код Боуза-Чоудхури-Хоквингема
ВК | - виртуальный канал (соответствует сокращению VC)
ВКМС | - виртуальный канал метасигнализации
ВОС | - взаимосвязь открытых систем (соответствует сокращению OSI)
ВП | - виртуальный путь (соответствует сокращению VP)
ИВК | - идентификатор виртуального канала (соответствует сокращению VCI)
ИВП | - идентификатор виртуального пути (соответствует сокращению VPI)
ИКМ | - импульсно кодовая модуляция (соответствует сокращению PCM)
ИСП | - службы с изменяющейся скоростью передачи (соответствует сокращению VBR)
ЛВС | - локальная вычислительная сеть (соответствует сокращению LAN)
МОС | - Международная организация по стандартизации (соответствует сокращению ISO)
ОКС | - общий канал сигнализации (соответствует сокращению CCS)
ОУП | - общее управление потоком (соответствует сокращению GFC)
ОШВКС | - общий широковещательный виртуальный канал сигнализации
ПД | - передача данных
ППЯ | - приоритет потери ячейки (соответствует сокращению CLP)
ПСП | - постоянная скорость передачи
ПЦИ | - плезиохронная цифровая иерархия (соответствует сокращению PDH)
СС МСЭ | - Сектор стандартизации Международного союза электросвязи
СЦИ | - синхронная цифровая иерархия (соответствует сокращению SDH)
СШВКС | - селективный широковещательный канал сигнализации
ТПН | - тип полезной нагрузки (соответствует сокращению PT)
УАА | - уровень адаптации АТМ (соответствует сокращению AAL)
УАТС | - учрежденческая автоматическая телефонная станция (соответствует сокращению PABX)
УПАТС | - учрежденческо-производственная автоматическая телефонная станция
УЦСИО | - узкополосная цифровая сеть интегрального обслуживания (N.ISDN)
ШВКС | - широкополосный виртуальных канал сигнализации
ШЦСИО | - широкополосная цифровая сеть интегрального обслуживания (B.ISDN)
ЭТО | - эксплуатация и техническое обслуживание (соответствует сокращению OAM)

английские
AAL (ATM Adaptation Layer) | - уровень адаптации АТМ
ABR (Available Bit Rate) | - доступная двоичная скорость
AFI (Authority and Format Identifier) | - идентификатор полномочий администрации и формата
AIS (Alarm Indication Signal) | - сигнал указания аварии
ANSI (A National Standard Institute) | - Американский национальный институт стандартизации
ARP (Address Resolution Protocol) | - протокол определения адреса
ARQ (Automatic Repeat Request) | - автоматический запрос повторной передачи
AOI (Asynchronous Transfer Mode) | - асинхронный режим переноса
AU (Administrative Unit) | - административный блок
AU Pointer | - указатель административной нагрузки
B-NT (Broadband Network Termination) | - широкополосное сетевое окончание
B-TA (Broadband Terminal Adapter) | - широкополосный терминальный адаптер
B-TE (Broadband Terminal Equipment) | - широкополосное оконечное оборудование
BCD (Binary Coded Decimal) | - десятичный номер, кодируемый в двоичной системе
BER (Bit Error Rate) | - коэффициент двоичных ошибок
BOM (Beginning of Message) | - начало сообщения
C-plane | - плоскость управления
CBDS (Connectionless Broadband Data Service) | - широкополосная служба данных без установления соединений
CBR (Constant Bit Rate) | - постоянная двоичная скорость
CCS (Common Channel Signaling) | - сигнализация по общему каналу
CLAI (Connectionless Access Interface) | - интерфейс доступа в сеть без установления соединения
CLFS (Connectionless Function Service) | - функции служб без установления соединений
CLNAP (Connectionless Network Access Protocol) | - протокол сетевого доступа без установления соединения
CLNI (Connectionless Network Interface) | - интерфейс сетевого узла без установления соединений
CLNIP (Connectionless Network Interface Protocol) | - протокол интерфейса сетевого узла без установления соединений
CLP (Cell Loss Priority) | - приоритет потери ячейки
CMIP (Common Management Information Protocol) | - общий протокол информации управления
CN (Customer Network) | - пользовательская (абонентская) сеть
COM (Continuation of Message) | - продолжение сообщения
CP (Common Part) | общая часть
CPCS (Common Part Convergence Sublayer ) | - общая часть подуровня конвергенции
CPI (Common Part Indicator) | - индикатор общей части
CPN (Customer Premises Network) | - абонентская сеть
CRC (Cyclic Redundancy Check) | - циклический контроль с избыточностью
CS (Convergence Sublayer) | - подуровень конвергенции (слияния)
CSI (Convergence Sublayer Indication) | - индикатор подуровня конвергенции
DCC (Data Country Code) | - код данных страны
DCE (Data Circuit terminating Equipment) | - оконечное оборудование канала данных
DE (Discard Eligibility) | - сброс кадра
DLCI (Data Link Connection Identifier) | - идентификатор соединения звена данных
DQDB (Distributed Queue Dual Bus) | - двойная шина с распределенной очередью
EOM (End of Message) | - завершение (окончание) сообщения
ES (End System) | - оконечная система
ESI (End System Identifier) | - идентификатор оконечной системы
FCS (Fast Circuit Switching) | - быстрая коммутация каналов
FDDI (Fiber Data Distributed Interface) | - распределенный интерфейс передачи данных по оптическому волокну
FERF (Far End Reporting Failure) | - сообщение удаленного терминала об отказе
FPS (Fast Packet Switching) | - быстрая коммутация пакетов
FR (Frame Relay) | - ретрансляция кадров (служба)
GAN (Global Area Network) | - глобальная сеть
GFC (Generic Flow Control) | - общее управление потоком
HDLC (High Level Date Link Control) | - высокоуровневый протокол управления звеном данных
HEC (Header Error Control) | - контроль ошибок в заголовке
IANA (Internet Assigned Numbers Authority) | - администрация назначения адресов Internet
ICD (International Code Designator) | -указатель международного кода
IDI (Initial Domain Identifier) | - идентификатор исходной зоны
IDU (Interface Date Unit) | - интерфейсный блок данных
IETF (Internet Engineering Task Force) | - рабочая группа инженеров Internet
IGMP (Internet Group Management Protocol ) | - протокол управления группами "Internet"
ILMI (Interim Local Management Interface) | - промежуточный интерфейс локального управления
IP (Internet Protocol) | - протокол Internet
IPX (Internet Packet Exchange) | - межсетевой пакетный обмен (протокол фирмы Novell)
IS (Intermediate System) | - промежуточная система
IT (Information Type) | - тип информации
LAN (Local Area Network) | - локальная сеть
LANE (LAN Emulation) | - эмуляция локальной сети
LATM (Local ATM) | - локальная вычислительная сеть АТМ
LECS (LAN Emulation Configuration Server) | - сервер конфигурации при эмуляции ЛВС
LES (LAN Emulation Server) | - сервер эмуляции ЛВС
LI (Length Indicator) | - индикатор длины
M-plane | - плоскость менеджмента
MAC (Media Access Control | - управление доступом к среде передачи
MAN (Metropolitan Area Network) | - городская сеть
MBS (Maximum Burst Size) | - максимальный размер (длина) пачки
MIB (Management Information Base) | - база данных информации управления
MID (Multiplexing Identifier) | - идентификатор мультиплексирования
MIR (Maximum Information Rate) | - максимальная информационная скорость
MPOA (Multiprotocol over ATM) | - многопротокольный режим передачи через АТМ
MSB (Most Significant Bit) | - наиболее значимый бит
MSOH (Multiplexing Section OverHead) | - служебная нагрузка мультиплексорной секции
MT (Message Type) | - тип сообщения
NDC (National Destination Code) | - национальный код места назначения
NNI (Network-to-Network Interface) | - сетевой интерфейс
NSAP (Network Service Access Point) | - точка доступа к сетевым услугам
NSN (Nationally Significant Number) | - национально значимый номер
OAM (Operation and Maintenance) | - эксплуатация и техническое обслуживание
OH (Over Head) | - служебная (избыточная) нагрузка
PAD | - информация заполнения
PD (Protocol Discriminator) | - дискриминатор протокола
PDU (Protocol Data Unit) | - протокольный блок данных
PER (Packet Error Rate) | - вероятность искажения пакета
PHY | - физический уровень
PIR (Packet Insertion Rate) | - вероятность доставки пакета не по адресу
PLCP (Physical Layer Convergence Protocol) | - протокол конвергенции (слияния) физического уровня
PLR (Packet Loss Rate) | - вероятность потери пакета
PM (Performance Measurement) | - измерение параметров
PMD (Physical Medium Dependent) | - подуровень, зависящий от среды
PNNI (Private Network Node Interface) | -частный сетевой интерфейс сетевого узла
POH (Path Over Head) | - служебная нагрузка тракта
PT (Payload Type) | - тип полезной нагрузки
QoS (Quality of Service) | - качество обслуживания
RAM (Random Access Memory) | - запоминающее устройство с произвольной выборкой
RARP (Reverse Address Resolution Protocol) | - протокол определения обратного адреса
RDI (Remote Defect Indication) | - указание об удаленном дефекте
RFC (Request for Comment) | - "запрос комментария" неформальные и формальные документы и стандарты IETF
RD (Routing Domain) | - маршрутная область
RIP (Routing Information Protocol) | - протокол данных маршрутизации
RM (Resource Management) | - управление ресурсами
RMON (Remote Monitoring) | - дистанционный мониторинг
RSOH (Regeneration Section OverHead) | - служебная нагрузка регенераторной секции
S-AAL (Signalling AAL) | - уровень адаптации АТМ для сигнализации
SAP (Service Access Point) | - точка доступа к услугам
SAR (Segmentation and Reassembly (sublayer) ) | - сегментация и сборка (подуровень)
SDH (Synchronous Digital Hierarchy) | - синхронная цифровая иерархия
SECB (Severely Errored Cell Block) | - блок ячеек с большим числом ошибок
SIR (Sustained Information Rate) | - поддерживаемая информационная скорость
SMDS (Switched Multimegabit Data Service) | - высокоскоростная служба передачи данных
SMTP (Simple Mail Transport Protocol) | - протокол электронной почты
SN (Subscriber Number) | - абонентский номер
SN (Sequence number) | - номер последовательности
SNMP (Simple Network Management Protocol) | - простой протокол управления сетью
SOH (Section Over Head) | - секционная служебная нагрузка
SPID (Service Profile Identifier) | - идентификатор профиля услуг
SPN (Subscriber Premises Network) | - пользовательская сеть
SSCF (Service Specific Coordination Functions) | - служебно- ориентированная функция координации
SSCOP (Service Specific Connection- Oriented Protocol) | - служебно- ориентированный протокол с установлением соединений
SSCS (Service Specific Convergence sublayer) | - служебно- ориентированный подуровень конвергенции
SSP (Service Specific Part) | - служебно- ориентированная часть
ST (Segment Type) | - тип сегмента
STM (Synchronous Transport Module) | - синхронный транспортный модуль
STM (Synchronous Transfer Mode) | - синхронный режим передачи
STP (Shielded Twisted Pair) | - экранированная витая пара
SVC (Signaling Virtual Channels) | - виртуальный канал сигнализации
TC (Transmission Convergence Sublayer) | - подуровень конвергенции с системой передачи
TIN (Telecommunication Management Network) | - сеть управления связью
U-plane | - плоскость пользователя
UDP (User Datagram Protocol) | - дейтаграммный протокол пользователя
UNI (User- Network Interface) | - интерфейс "пользователь
UTP (Unshielded Twisted Pair) | - неэкранированная витая пара
VBR (Variable bit rate) | - изменяющаяся скорость передачи
VC (Virtual Container) | - виртуальный контейнер
VCC (Virtual Channel Connection) | - соединение виртуального канала
VCI (Virtual Channel Identifier) | - идентификатор виртуального канала
VPC (Virtual Path Connection) | - соединение виртуальных путей
VPI (Virtual Path Identifier) | - идентификатор виртуального пути
WAN (Wide Area Network) | - национальная сеть

Назад | Оглавление | Вперед
О проекте | Тест


ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ

Базы данных управления сетями АТМ

Промежуточный интерфейс локального управления (ILMI)
Форума АТМ

На основе простого протокола сетевого управления (SNMP) до стандартизации интерфейса управления уровней АТМ Форумом АТМ разработан промежуточный интерфейс локального управления (ILMI). Для него по умолчанию были выбраны значения идентификатора виртуального пути VPI=0 или идентификатора виртуального канала VCI=16. Альтернативно на каждой стороне интерфейса "пользователь-сеть" можно вручную выбрать другие значения VPI или VCI для использования промежуточным интерфейсом локального управления, но использование этого метода рекомендовать нельзя, так как он не является автоматическим.
ILMI работает на уровне адаптации АТМ 3/4 или 5-го типа, поэтому для взаимодействия объектов управления интерфейса "пользователь-сеть" (UMEs) необходимо выбирать протокол уровня адаптации 3/4 (или 5-го) типа и более высокого уровня (UDP/IP или Q).

Рис. 52. Структура базы данных промежуточного интерфейса локального управления
Форума АТМ

На рис. 52 представлена структура базы данных управления (MIB) промежуточного интерфейса локального управления (ILMI). Каждый интерфейс имеет ряд групп объектов, показанных ответвлениями дерева. Так, группа физического уровня представлена двумя группами для общего и специальных объектов (атрибутов). Индекс интерфейса для доступа к данным, связанным с определенным интерфейсом "пользователь-сеть" (UNI), всегда является частью индекса объекта. Нулевой индекс по умолчанию означает, что команда SNMP относится к интерфейсу, по которому было получено сообщение SNMP. К другим интерфейсам нужно обращаться, пользуясь не нулевыми значениями индекса в запросах SNMP. Основной формой обеспечения безопасности доступа является гарантия использования только индексов интерфейса, назначенных определенному объекту управления интерфейса "пользователь-сеть" (UME).
Некоторые группы объектов (например, соединения виртуальных путей и соединения виртуальных каналов) имеют множество входов в интерфейс и, следовательно, должны иметь и дополнительные индексы, как это и показано на рис. 52.
Спецификацией Форума АТМ для ILMI определены 2 версии баз данных управления: 2.0 [8] и 3.0 [7].
База данных управления версии 3.0, которая будет кратко рассмотрена ниже, может работать совместно с базой данных управления версии 2.0.
ILMI использует стандартную группу функций, поддерживающих, например, идентификацию, стандартные ловушки для случаев перезапуска системы или обнаружения факта выхода из строя интерфейса и т. п.
Ниже дается краткое описание групп объектов дерева базы данных управления ILMI, детальное описание приведено в спецификациях Форума АТМ, версия 3.0:
- | в группе физического уровня - о типах портов (DS3, STS-3, волокно 150 Мбит/с, 100 Мбит/с и т. п.), типе среды (коаксиал, одно- или многомодовое волокно), информационный статус, а также другая специальная информация;
- | в группе уровня АТМ - о максимальном количестве виртуальных путей и виртуальных каналов, возможных на интерфейсе; о количестве сконфигурированных соединений виртуальных путей и виртуальных каналов и т. п.;
- | в группе соединений виртуальных путей - значение идентификатора виртуального пути для данного соединения виртуальных путей; информационный статус для этого соединения виртуальных путей; дескриптор трафика передачи и приема на этом соединении виртуальных путей; запрашиваемый класс качества обслуживания и т. п.;
- | в группе соединения виртуальных каналов - значения идентификатора виртуального канала для данного соединения виртуальных каналов; информационный статус для данного соединения виртуальных каналов; дескриптор трафика приема и передачи; запрашиваемое качество обслуживания передачи и приема;
- | в группе статистики уровня АТМ - общее число принятых и переданных ячеек на данном интерфейсе, а также общее количество стертых ячеек и причины (ошибки в заголовке, пришедшие не по адресу и другие причины);
- | в группе сетевого префикса - строка переменной длины (8-13 байт), определяющая сетевой префикс в формате NSAP или Е.164 спецификации UNIv.3.0 Форума АТМ; статус сетевого префикса;
- | в группе адресации АТМ средств пользователя - адресация АТМ из 8 байт, определяющая байты низшего порядка формата NSAP спецификации UNI v.3.0 форума АТМ; статус адреса АТМ.
На рис. 53 показан принцип обмена сообщениями SNMP при регистрации адреса MIB ILMI.

Рис. 53. Порядок обмена сообщениями при регистрации адреса

Группа объектов, в которых содержатся сетевые префиксы, постоянно находится в базе данных управления ILMI на стороне пользователя интерфейса "пользователь-сеть" (UNI), в то время как группа адресов находится на сетевой стороне интерфейса "пользователь-сеть". Группа адресации не используется при использовании формата Е.164, так как 8-байтовый сетевой префикс полностью определяет адрес. Регистрация осуществляется в момент инициализации или тогда, когда прибавляются или удаляются префикс или адрес. При инициализации адресные и префиксные таблицы инициализируются пустыми. Одна сторона регенерирует префикс или адрес другой при 1-й установке величины (значения) адреса и проверки его статуса. Другая сторона посылает сообщение RESPONSE, в котором содержится "NO ERROR" или "BAD VALUЕ", означающие успех или неудачу регистрации, соответственно. Если сообщение SET посылается, а в ответ сообщение RESPONSE не получено, то сообщение SET посылается заново. Если сообщение SET принимается снова, то сообщение RESPONSE при условии отсутствия ошибок принимается вторично. Если же вторично принимается сообщение SET, которое пытается принять статус незарегистрированного префикса или адреса, то посылается сообщение RESPONSE, в котором содержится информация "NoSuchName" - "такого имени нет".

Экспериментальная база данных управления сетями АТМ

Группа инженерной поддержки сети Internet (IETF) разрабатывает экспериментальную базу данных управления для сетей АТМ, получившую в технической литературе условное обозначение AToMMIB [8]. Сфера AToMMIB охватывает управление интерфейсами, оборудованием и предоставлением услуг в сетях АТМ на основе постоянных виртуальных соединений.
AToMMIB использует структуру групп во многом аналогичную ILMI. В базе данных управления AToMMIB определены следующие группы объектов:
- | конфигурации интерфейса АТМ;
- | подуровня конвергенции физического уровня;
- | конфигурации звена уровня виртуального пути или виртуального канала кроссового соединения виртуальных путей и виртуальных каналов;
- | статистики производительности соединения уровня адаптации АТМ 5-го типа (AAL5).
Группа конфигурации интерфейса АТМ содержит информацию уровня ячейки АТМ и конфигурацию локальных интерфейсов АТМ, в которую входят идентификатор порта, скорость интерфейса, количество ячеек, принятых с ошибками, типы физической среды и системы передачи, операционный и административной статусы, активное поле идентификаторов виртуальных путей и виртуальных каналов и максимально возможное их количество.
Группа подуровня конвергенции с системой передачи обеспечивает сбор статистики о производительности физического уровня для СЦИ. Сюда же входит сбор статистики частоты появления ошибок по битам и "ошибочным секундам" (интервалам времени работы цифрового тракта, во время которых частота появления ошибок превышает допустимую величину).
Группа кроссового соединения и виртуального звена АТМ позволяет осуществить управление звеньями виртуальных путей и виртуальных каналов уровней виртуального пути и виртуального канала соответственно, а также кроссовые соединения АТМ.
Управление виртуальными звеньями осуществляется в оконечных системах и коммутационном оборудовании, а управление кроссовыми соединениями - в коммутаторах сетей АТМ. В группу входит информация об операционном статусе, значениях идентификаторов виртуальных пути и канала соответственно, а также об идентификаторе физического порта другого конца кроссового соединения.
Группа статистики производительности соединения уровня адаптации АТМ 5-го типа основана на стандартном интерфейсе пакетов IP. Она предназначена для оконечного оборудования, коммутаторов или сетей, где завершается протокол уровня адаптации АТМ 5-го типа (AAL5). В эту группу входят такие объекты, как числа полученных и переданных октетов, октетов переданных через уровень адаптации пользователя, а также число ошибочных протокольных битов данных общей части подуровня конвергенции уровня адаптации АТМ 5-го типа (AAL5 CPCS PDUs).


ПРЕДИСЛОВИЕ

ПРЕДИСЛОВИЕ

Важнейшей национальной проблемой, без которой невозможно построение информационного общества и внедрение в сферы производства, бизнеса, науки, образования, медицины, культуры и развлечений новейших информационных технологий, является создание высоко эффективной телекоммуникационной среды. На пороге 21-го века именно информация становится стратегическим ресурсом, а наибольшие экономический и социальный успехи сопутствуют тем, кто наиболее активно использует современные средства информационных и телекоммуникационных технологий.
Развитие современных сетевых технологий, успехи в создании волоконно-оптических линий связи и сверхбольших интегральных схем с большой памятью и огромным быстродействием привели к разработке нового способа транспортирования информации, получившего наименование асинхронного режима переноса (Asynchronous Transfer Mode - ATM). Технология АТМ предоставляет операторам сетей следующие уникальные возможности:
  • обеспечивает высокую гибкость и адаптируемость сети как к изменению уровня требований пользователей к качеству обслуживания, так и к появлению новых служб, требования которых к семантической и временной прозрачности сети еще четко не определены;
  • резко повышает эффективность использования сетевых ресурсов;
  • снизить затраты на проектирование, строительство и эксплуатацию сети, а также на разработку сетевого оборудования, так как создается и эксплуатируется одна сеть вместо множества вторичных сетей.
Основной целью учебного пособия является ознакомление будущих инженеров-связистов с принципами построения ШЦСИО на технологии АТМ.


ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ

Эксплуатация и техническое обслуживание

Принципы эксплуатации и технического обслуживания

Основная задача эксплуатации и технического обслуживания (ЭТО) ШЦСИО на технологии АТМ состоит в обнаружении и локализации неисправностей и восстановлении нормальной работы сети. Эксплуатация и техническое обслуживание является одной из основных функций управления сетью. Подсистема ЭТО обеспечивает выполнение следующих функций:
- тестовый контроль параметров надежности;
- локализацию неисправностей;
- выработку решений по восстановлению отказов;
- автоматизированную настройку технических средств
связи после восстановления отказов;
- функции аварийной сигнализации;
- формирование служебных сообщений и передачу служебной
информации ЭТО в базы данных;
- отображение служебной информации ЭТО обслуживающему персоналу.

Уровни и потоки информации эксплуатации и технического обслуживания

Основную часть в инфраструктуре сетевого управления занимает информация эксплуатации и технического обслуживания (ОАМ - Operations and Maintenance). Эталонная архитектура потоков ЭТО АТМ (рис. 54) включает:
- | F1 - поток информации эксплуатации и технического обслуживания уровня регенерационной секции СЦИ;
- | F2 - поток информации эксплуатации и технического обслуживания уровня цифровой (мультиплексорной) секции СЦИ;
- | F3 - поток информации ЭТО уровня пути передачи СЦИ;
- | F4 - поток информации ЭТО виртуального пути уровня АТМ;
- | F5 - поток информации ЭТО виртуального канала уровня АТМ.
Таким образом, в сети АТМ к существующим потокам служебной информации СЦИ F1, F2 и F3 добавляются потоки информации F4 (для ВП) и F5 (для ВК). При этом потоки F4 или F5 могут быть прямыми или потоками "точка-точка", (т.е. между оконечными точками соединения ВП или соединения ВК), или сегментными (т.е. между точками звена ВП или звена ВК).
Прямые потоки информации F4 или F5 принимаются и анализируются только теми устройствами, которые образуют соединения виртуальных путей или каналов соответственно. Сетевые узлы принимают сегментные потоки и

Рис. 54 Эталонная архитектура потоков ЭТО АТМ

должны удалять их до того, как они достигнут устройства, образующего соединение виртуальных путей или каналов. Таким образом, потоки ЭТО в сетях АТМ могут быть типа "точка-точка" и циркулировать от одной оконечной точки соответствующего уровня до другой оконечной точки этого же уровня или иметь сегментный характер и циркулировать от одной точки соединения до другой. Уровневая архитектура потоков ЭТО между двумя оконечными системами приведена на рис. 55.

Между двумя оконечными системами АТМ циркулируют следующие потоки ЭТО [12]:
на физическом уровне:
- | потоки F1 уровня регенерационных секций циркулируют между оптическим оконечным устройством 2 и регенератором, а также между регенератором и оптическим оконечным устройством 3;
- | потоки F2 уровня цифровой секции циркулируют между оконечной системой 1 и оптическим оконечным устройством 1, между оптическим оконечным устройством 2 и оптическим оконечным устройством 3, между оптическим оконечным устройством 4 и сетевым окончанием 1-го типа (NT1) и наконец, между сетевым окончанием 1-го типа и оконечной системой 2;
- | потоки F3 уровня пути передачи циркулируют между оконечной системой 1 и оборудованием, выполняющим функции ретрансляции ячеек виртуального пути (VP CRF - Virtual Path Relaying Function) между оборудованием VP CRF и оборудованием, выполняющим функции ретрансляции ячеек виртуального канала (VC CRF - Virtual Channel Cell Relaying Function), а также между оборудованием VC CRF и оконечной системой 2.

Физический уровень

Уровень АТМ

Рис. 55. Пример уровневой архитектуры потоков информации ЭТО

на уровне АТМ:
- | потоки F4 уровня виртуального пути циркулируют между оконечной системой и оборудованием VC CRF, в котором происходит замена идентификатора виртуального пути, а также между оборудованием VC CRF и оконечной системой 2;
- | поток F5 уровня виртуального канала циркулирует между оконечными системами 1 и 2.

Типы и форматы ячеек управления и ЭТО

Потоки информации ЭТО F4 уровня виртуального пути для идентификации потока "точка-точка" используют значение идентификатора виртуального канала VCI=4, а для сегментных потоков значение VCI=3. (рис. 56).

VCI = 3 для сегм. потока
VCI = 4 для потока "точка-точка"
CFG - поле общего контроля потока
VPI - поле идентификатора виртуального пути
VCI - поле идентификатора виртуального канала
PT - поле типа полной нагрузки
CLP - поле признака приоритета потери ячейки
HEC- поле контроля ошибок в заголовке

Рис 56. Формат ячеек ЭТО

Для потока ячеек ЭТО F5 уровня виртуального канала специфические значения идентификаторов виртуальных путей не используются. Для потока ЭТО F5 типа "точка-точка" в поле полезной нагрузки записывается значение РТ=100, а для сегментных потоков соединения виртуальных каналов - РТ=101.(рис. 57).

Рис. 57. Формат ячеек ЭТО соединения виртуальных каналов F5

Информация, содержащаяся в ячейках ЭТО F4 и F5, может относиться к процессам обнаружения и локализации отказов в сетях АТМ, контролю параметров производительности сети и ее элементов, а также к активизации/дезактивизации процессов ЭТО [12,13]. В зависимости от вида ЭТО (отказы, производительность, активизация/дезактивизация процессов ЭТО) используются ячейки, предназначенные для выполнения различных функций.
Так, для обнаружения отказов, определения места их возникновения и принятия решения о локализации используются специальные ячейки, выполняющие функции:
- | сигналов указания аварии (AIS - Alarm Indication Signal);
- | указания об удаленном дефекте (RDI - Remote Defect Indication), которое в ряде источников также принято называть сообщением удаленного терминала об отказе (FERF - Far End Reporting Failure);
- | проверки непрерывности (Continuity Check);
- | проверки шлейфом (Loopback).
В целях проверки производительности сети АТМ или ее элементов используются ячейки, выполняющие функции:
- | прямого мониторинга (Forward Monitoring);
- | сообщения о результатах мониторинга (Backward Reporting);
- | мониторинга и сообщения о его результатах (Monitoring and Reporting).
Таблица 11
Вид ЭТО | Код поля | Выполняемые функции | Код поля
Обнаружение, определение места возникновения и локализация отказов (Fault Management) | 0001 | Указание аварии (AIS) Указание об удаленном дефекте (RDI/FERF) Проверка непрерывности (Continuity Check) Проверка шлейфом (Loopback) | 0000 0001 0100 1000
Контроль производительности | 0010 | Прямой мониторинг (Forward Monitoring) Сообщение о результатах мониторинга (Backward Reporting) Мониторинг и сообщение о результатах (Monitoring and Reporting) | 0000 0001 0010
Активизация/дезактивизация процессов ЭТО | 1000 | Мониторинг производительности (Performance Monitoring) Проверка непрерывности (Continuity Check) | 0000 0001

Для активизации/дезактивизации процессов ЭТО используются ячейки, выполняющие функции:
- мониторинга производительности (Performance Monitoring);
- проверки непрерывности (Continuity Check).
Значения соответствующих полей ячеек ЭТО F4 и F5 в зависимости от вида ЭТО и выполняемых функций приведены в табл. 11.
Форум АТМ рекомендует внедрение функций ЭТО в программное обеспечение при времени отклика на ее менее 1 с.


СТРУКТУРА И ПРОТОКОЛЫ АТМ

СТРУКТУРА И ПРОТОКОЛЫ АТМ

Эталонная конфигурация ШЦСИО
Эталонная модель протоколов

Асинхронный режим переноса (АТМ), предусматривая интегрированную передачу речи, данных, подвижных и неподвижных изображений методом статистического мультиплексирования в едином цифровом тракте, воплощает в жизнь лучшие мечты как сетевых операторов, так и пользователей связью.
Передача всех видов информации в виде пакетов фиксированной длины - ячеек позволяет отказаться от традиционной формы распределения ресурсов в виде каналов с постоянной полосой пропускания и перейти к распределению по потребности, когда каждый потребитель в любой момент времени получает тот сетевой ресурс, который ему необходим в виде виртуального канала с изменяющейся скоростью передачи. Таким образом, для технологии АТМ характерна одновременная реализация двух принципов: пакетной коммутации и установления виртуальных соединений.
Однако, чтобы все мечты о сетях 21-го века были реализованы в жизнь, необходимо пройти большой, но не обязательно долгий путь от момента зарождения идей, теоретических разработок, стандартов и спецификаций до момента создания аппаратно-программных комплексов, воплощающих все это в реальные информационные и телекоммуникационные системы.
Большая заслуга в быстром развитии технологии АТМ принадлежит сектора стандартизации электросвязи Международного союза электросвязи (СС МСЭ), Европейскому институту стандартов в области телекоммуникаций, Американскому национальному институту стандартов, Форуму АТМ и многим другим, проделавшим в сжатые сроки огромную работу по разработке архитектуры широкополосной цифровой сети интегрального обслуживания (ШЦСИО) на технологии АТМ, эталонной модели протоколов, определению функций физического уровня, уровня АТМ, уровня адаптации АТМ и высших уровней, а также взаимодействию с ШЦСИО ныне существующих сетей и служб. Именно этим вопросам и посвящен данный раздел.


ЗАКЛЮЧЕНИЕ

ЗАКЛЮЧЕНИЕ

Уровневая архитектура является одной из центральных идей создания ШЦСИО на технологии АТМ, а основой протокольной модели является уровень АТМ, обеспечивающий перенос всех видов информации единым способом в виде пакетов фиксированной длины - ячеек. Это дает уникальную возможность вместо большого количества вторичных сетей и разнообразного оборудования иметь одну сеть, построенную на единых принципах и одном виде телекоммуникационного оборудования. Но, надо помнить, что простота уровня АТМ во многом достигается за счет нижележащего и, особенно, за счет вышележащего уровня.
Физический уровень является нижним уровнем протокольного стыка АТМ. Даже на примере физического уровня видно, как ШЦСИО, с одной стороны, идет в ногу с новейшими достижениями науки и техники, разрабатывая сетевые интерфейсы на 2,5 и 10 Гбит/с, а с другой, снижая скорость интерфейса пользователь-сеть со 155 до 25 Мбит/с, 1,5/2 Мбит/с и даже до nx64 кбит/с для того, чтобы пользователь мог использовать существующую абонентскую проводку.
Определено, что оборудование СЦИ является основой физического уровня, но, учитывая, что в сетях электросвязи установлена и будет еще длительное время эксплуатироваться аппаратура плезиохронной цифровой иерархии, разработана процедура процесса размещения ячеек АТМ в кадре ПЦИ.
Необходимо помнить, что простота уровня АТМ во многом основана на высоком качестве цифровых трактов связи и реализации на физическом уровне механизмов проверки и исправления одиночных ошибок в заголовке ячеек, их разграничении и согласовании скорости ячеек с двоичной скоростью систем передачи. Это позволяет в сочетании с фиксированной длиной ячейки упростить процессы обработки ячеек в коммутационном оборудовании на уровне АТМ.
Основная тяжесть работы в сетях АТМ ложится на уровень адаптации АТМ, поскольку он обязан все разнообразие протоколов высших уровней, различных служб и требований пользователей к качеству обслуживания привести к ячейке АТМ, а потом снова собрать их и обеспечить обмен всеми видами информации. Этим объясняется, с одной стороны, деление уровня адаптации АТМ на различные типы, приспособленные к адаптации определенного вида трафика со своими специфическими характеристиками, а с другой стороны, деление на подуровни сегментации и сборки и конвергенции с выделением в некоторых случаях служебно-ориентированного подуровня конвергенции.
Центральной фигурой в эталонной модели протоколов ШЦСИО является плоскость пользователя, охватывающая все уровни. Именно она обязана предоставить пользователю все виды услуг по обмену всеми видами информации. Плоскости управления и менеджмента обязаны обеспечить поддержку плоскости пользователя.
Плоскость управления, которой принадлежат практически все функции сигнализации, обеспечивает установление, контроль и разъединение соединения.
Плоскость менеджмента объединяет все в единое целое и обеспечивает возможность динамического и административного управления сетями АТМ, а также их эксплуатации и технического обслуживания на сверхсовременном уровне.В этом учебном пособии совершена краткая экскурсии по всем уровням протокольной модели ШЦСИО.
Видно, что сделано очень много, чтобы ШЦСИО была в состоянии с первых дней существования обеспечить потребности пользователей существующих телекоммуникационных услуг и быть готовой без существенной перестройки обеспечить требования пользователей в новых услугах. Нужно также согласиться и с тем, что критика в адрес АТМ в чем-то оправдана [63]. Но эта критика сегодняшнего положения дел. Нельзя не отрицать того факта, что технология АТМ - это технология сетей 21-го века, а болезни роста бывают у каждого ребенка.
В [9] очень верно отмечено, что развитие телекоммуникации во многом повторяет развитие транспортных сетей, но, к сожалению, со значительным опозданием. В транспорте вместо узких дорог строятся широкие магистрали, а в сетях связи - это волоконно-оптические линии связи со скоростями 155 Мбит/с, 622 Мбит/с, 2,5 Гбит/с, 10 Гбит/с и более. В транспорте вместо многочисленных светофоров на пересечениях дорог - развязки на различных уровнях и съезды без остановок транспорта, а в связи - это асинхронный режим переноса (АТМ - Asynchronous Transfer Mode) и коммутаторы виртуальных путей и виртуальных каналов огромной производительности и с неблокируемыми полями, осуществляющими быструю коммутацию пакетов. В транспорте - вместо беспорядочной перевозки грузов организуются контейнерные перевозки, а в ШЦСИО на технологии АТМ - перенос всех видов информации ячейками.
Ячейки для переноса информации предоставляются пользователю по требованию в зависимости от его активности и имеющихся в наличие сетевых ресурсов, которые используются всеми службами, предоставляя возможность их оптимального распределения на статистической основе и, следовательно, обеспечения высокой эффективности функционирования сетей на технологии АТМ.
Основой развития телекоммуникационных систем является совпадение спроса на новые услуги с возможностями производства всего спектра телекоммуникационной техники и приемлемой для потребителя стоимостью услуг.
Сети АТМ нашли своего потребителя в лице локальных, городских, национальных и глобальных вычислительных сетей, пользователей с персональными компьютерами, любителей мультимедиа, видеотелефонии, видео по требованию, телевидения высокой четкости. Таким образом, в развитии ШЦСИО на технологии АТМ заинтересованы как деловой, так и домашний сектор.
Современный уровень науки, техники и технологий позволили обеспечить выпуск оборудования АТМ, которое начинает соперничать и вытеснять из рынка другое оборудование (объем продажи продуктов АТМ для ЛВС в 1996 г. по сравнению с 1995 г. по данным корпорации IDC, увеличился на 350 %. Это свыше 300 тыс. портов по сравнению с 67 тыс. в 1995 году или 3,75 % от общего числа проданных коммутационных портов). Стремительно расширяется ассортимент высокопроизводительных коммутаторов, оснащенных портом АТМ для подключения к магистралям. Если и существуют справедливые сомнения, что технология АТМ способна уже завтра вытеснить все остальные технологии в ЛВС, то никто не сомневается в ее превосходстве в магистральных сетях.
Разработка и внедрение новых информационных и телекоммуникационных технологий во многих странах мира объявлены национальной задачей и поддерживаются государственными программами.
Технологию АТМ называют технологией сетей 21-го века не только потому, что у нее есть огромное преимущество над другими телекоммуникационными технологиями, но и за то, что она позволяет решить многие проблемы телекоммуникаций практически сразу ("с колес"), не дожидаясь реализации целого ряда таких важных аспектов, как сигнализация, маршрутизация, адресация и т.п., развиваясь и предоставляя услуги в процессе своего развития.


ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ

ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ

Общие положения
Размещение ячеек АТМ
в кадрах систем синхронной цифровой иерархии
 Интерфейс на основе ячеек
Размещение ячеек в кадрах систем плезиохронной цифровой иерархии
Формирование поля контроля ошибок в заголовке, обнаружение и исправление ошибок
Разграничение ячеек
Согласование скоростей ячеек

Общие положения

Физический уровень является нижним уровнем протокольного стека АТМ, определяющим интерфейс между потоком ячеек АТМ и физической средой. Физический уровень состоит из подуровня, зависящего от физической среды, и подуровня конвергенции с системой передачи.
Подуровень, зависящий от физической среды, определяет скорость, с которой трафик АТМ транспортируется через физическую среду.
Подуровень конвергенции с системой передачи является частью физического уровня и определяет протокол размещения ячеек для передачи через физическую среду в кадрах различных цифровых систем передачи.
В данном подразделе основное внимание уделено подуровню конвергенции со средой передачи, а именно:
- размещению ячеек в кадрах систем СЦИ, ПЦИ и в системах передачи ячеечного типа;- формированию поля контроля ошибок в заголовке, обнаружению и исправлению ошибок;- разграничению ячеек;- согласованию скоростей ячеек.
СС МСЭ стандартизовал 2 типа интерфейса пользователь-сеть для ШЦСИО на технологии АТМ. Интерфейс 1-го типа организуется на скорости 155 Мбит/с и может быть реализован с помощью 2 коаксиальных кабелей или с использованием одного или двух оптических. Этот интерфейс, как правило, симметричен по скорости передачи битов в обоих направлениях. Интерфейс пользователь-сеть 2-го типа организуется на скорости 622,080 Мбит/с и может представлять собой объединение 4 интерфейсов 1-го типа и реализуется преимущественно на оптическом кабеле. Этот интерфейс может быть как симметричным, так и асимметричным.
Данные интерфейсы могут быть реализованы с использованием кадров синхронной цифровой иерархии или путем непрерывной передачи потока ячеек.
В 1993 г. в СС МСЭ от делегаций Германии, США, Канады и Южной Кореи [17] поступили предложения, касающиеся стандартизации интерфейсов пользователь-сеть с более низкими скоростями передачи пакетов АТМ. Целесообразность стандартизации новых интерфейсов на более низких скоростях объясняется следующими основными причинами:
- снижение скорости расширяет возможность использования существующих цифровых сетей и сетей доступа;- успехи в технике сжатия сигналов позволяет обеспечить большинство широкополосных услуг на более низких скоростях без заметного ухудшения качества передаваемой информации;- интерфейсы на более низких скоростях обеспечивают более экономичную реализацию терминального оборудования и линейных сооружений между сетевым окончанием и коммутатором доступа.
Интерфейсы пользователь-сеть со скоростями ниже 155 Мбит/с введены со следующими номиналами скоростей:
- 100 Мбит/с (для SB);- 51,84 Мбит/с (для SB);- 25 Мбит/с (для SB);- 34/45 Мбит/с, основанный на ПЦИ [18];- 1,5/2 Мбит/с, основанный на ПЦИ [18].
Причиной выбора терминального интерфейса на 51,84 Мбит/с и 25 Мбит/с является желание использовать относительно недорогую и уже существующую кабельную проводку в зданиях для ЛВС АТМ.
Фирма IBM разработала и продает набор микросхем для АТМ, обеспечивающих скорость передачи 25 Мбит/с. IBM утверждает, что это очень простой способ повысить скорость сетей Token Ring, которая ограничена 16 Мбит/с. Относительно низкая стоимость такой модификации особенно привлекательна т.к. ее можно реализовать на широко распространенных кабельных системах на основе витой пары категории 3 [19].
Интерфейсы АТМ на 1,5/2 Мбит/с могут работать на обычной телефонной проводке, используя протокол HDLC (High Level Data Link Control).


ЛИТЕРАТУРА

ЛИТЕРАТУРА

  1. ITU-T. Recommendation I.411. ISDN User-Network Interface- Reference Configurations. Rev.1. - Geneva, 1993.
  2. ITU-T. Recommendation I.413. Basic User-Network Interface. Rev. 1. - Geneva, 1993.
  3. ITU-T. Recommendation I.430. Basic User-Network Interface-Layer 1 Specification. Rev.1. - Geneva, 1993.
  4. Handel R., Huber M.N., Schroder S. ATM Networks. Concepts, Protocol, Applications. -Addison-Wesley, 1994.
  5. ITU-T. Recommendation I.432. B-ISDN User-Network Interface-Physical Layer Specification. Rev. 1. - Geneva, 1993.
  6. Боккер П. ISDN. Цифровая сеть с интеграцией служб. Понятия, методы, системы . -М.: Радио и связь, 1991.
  7. AOI Forum. ATM User-Network Interface Specification. Ver. 3.0, 1993.
  8. ATM Forum. ATM User Network Interface Specification. Ver. 2.0, 1992.
  9. Булгак В.Б. Концепция развития связи в Российской Федерации. - М.: Радио и связь, 1995.
  10. Шварц М. Сети связи: протоколы, моделирование и анализ. ч.1. -М.: Наука, 1992.
  11. Блэк Ю. Сети ЭВМ: протоколы, стандарты, интерфейсы. -М.: Мир, 1990.
  12. McDysan D. ATM: Theory and Application. McGraw-Hill, 1994.
  13. ITU-T. Recommendation I.320. ISDN Protocol Reference Model. Blue Book, Fascicle III.8. - Geneva, 1988.
  14. ITU-T. Recommendation I.321. B-ISDN Protocol Reference Model and its Application. - Geneva, 1991.
  15. ITU-T. Recommendation I.361. B-ISDN ATM Layer Specification. Rev.1. - Geneva, 1993.
  16. ITU-T. Recommendation I.362. B-ISDN ATM Adaptation Layer (AAL) Functional Description. Rev. 1. - Geneva, 1993.
  17. Соколов Н.А. Эволюция местных телефонных сетей. - Пермь: Книга, 1994.
  18. ITU-T. Recommendation G.702. Digital Hierarchy Bit Rates. Blue Book, Fascicle III. 4. - Geneva, 1988.
  19. Шатт С. Мир компьютерных сетей. - Киев: BHV, 1996.
  20. Ким Л.Т. Синхронная цифровая иерархия// Электросвязь. - 1991. - № 3.- С. 2-5.
  21. Ким Л.Т. Линейные тракты синхронной цифровой иерархии// Электросвязь.- 1991. - № 6. С. 5-6.
  22. Ким Л.Т. Создание транспортной системы на сети связи России// Электросвязь. - 1993. - № 11. - С.20-23.
  23. Нурмухамедов Л.Х. Создание систем передачи цифровой синхронной иерархии со скоростями 155,622 Мбит/с и 2,4 Гбит/с// Системы и средства телекоммуникации. - 1992. - № 4. - С. 3-8.
  24. ITU-T. Recommendation G.707. Synchronous Digital Hierarchy Bit Rates. Rev. 2. - Geneva, 1993.
  25. ITU-T. Recommendation G.708. Network Node Interface for Synchronous Digital Hierarchy. Rev.2. - Geneva, 1993.
  26. ITU-T. Recommendation G.709. Synchronous Multiplexing Structure. Rev. 2.- Geneva, 1993.
  27. ITU-T. Draft Recommendation G.804. ATM Cell Mapping into Plesiochronous Digital Hierarchy (PDH). - Geneva, 1993.
  28. ITU-T. Draft Recommendation G.832. Transport of SDH Elements on PDH Network : Frame and Multiplexing Structures. - Geneva, 1993.
  29. ITU-T. Recommendation G.652. Characteristics of a Single-Mode Optical Fiber Cable. Rev. 1. - Geneva, 1993.
  30. Martin de Prycker. Asynchronous transfer mode. Solution for broadband ISDN.- Ellis Harwood. - N. Y. etc., 1993.
  31. ITU-T. Recommendation I.150. B-ISDN ATM Functional Characteristics. Rev. 1. - Geneva, 1993.
  32. ITU-T. Recommendation I.113. Vocabulary of Terms for Broadband Aspects of ISDN. Rev.1. - Geneva, 1991.
  33. ITU-T. Recommendation I.363. B-ISDN ATM Adaptation Layer Specification. Rev. 1. - Geneva, 1993.
  34. Белман Б. АТМ. Борьба продолжается// Сети. - 1996. - №6. - С. 32-35.
  35. ITU-T. Recommendation I.211. B-ISDN Service Aspects. Rev. 1 - Geneva, 1993.
  36. ITU-T. Recommendation I.327. B-ISDN Functional Architecture. Rev. 1. - Geneva, 1993.
  37. Bellcore. Technical Advisory TA-TSV-000792. Generic System Requirements in Support of Switched Multi-Megabit Data Service. Issue 3, October, 1989.
  38. ITU-T. Recommendation E. 164. Numbering Plan for the ISDN Era. Rev. 1.- Geneva, 1991.
  39. ETSI. ETR DE/NA - 53203: Network Aspects (NA); CBDS over ATM, May, 1993.
  40. Кузнецов С.Б., Каплан В.В. Построение сети передачи данных на основе протокола Frame Relay// Сети. - 1996. - №6. - С. 46-50.
  41. Захаров Г.П., Симонов М.В., Яновский Г.Г. Службы и архитектура широкополосных цифровых сетей интегрального обслуживания. - М.: ЭкоТрендз. Технология электронных коммуникаций. - 1993. - т. 41.
  42. ITU-T. Recommendation Q.932. ISDN Data Link Layer Specification for Frame Mode Bearer Services. - Geneva, 1992.
  43. ITU-T. Draft Recommendation I.555. Frame Relay Bearer Service Interworking. - Geneva, 1993.
  44. Дубова М. Введение в ТСР/IP// Сети. - 1997. - №2. - С. 36-45.
  45. IETF. Multiprotocol Encapsulation over ATM Adaptation Layer 5 RFN 1483, July, 1993.
  46. IETF. TCP Extensions for High Performance RFC 1323, May, 1992.
  47. IEEE. IEEE Std 802.2-1989. Information Processing Systems - Local Area Networks - Part 2: Logical Link Control.
  48. Сатовский Б. Введение в эмуляцию ЛВС// Сети. - 1996. - №6. - С. 41-45.
  49. ATM Forum. ATM User-Network Interface Specification. Ver. 3.1. September, 1994.
  50. ITU-T. Recommendation I. 311. B-ISDN General Network Aspects. Rev. 1.- Geneva, 1993.
  51. . Бертсекас Д., Галлагер Р. Сети передачи данных. -М.: Мир. - 1989.
  52. Дэвис Д., Барбер Д., Прайс У., Соломонидес С. Вычислительные сети и сетевые протоколы. - М.: Мир, 1982.
  53. Даффи Д.IP коммутация прогревает мотор// Сети. - 1996. - №6. - С. 23-24.
  54. ITU-T. Recommendation Q.931. ISDN User -Network Interface Layer 3 Specification for Basic Call Control. Rev. 1. - Geneva, 1993.
  55. ITU-T. Recommendation Q.2110. B-ISDN ATM Adaptation Layer - Service Specific Connection Oriented Protocol (SSCOP). - Geneva, 1995.
  56. ITU-T. Recommendation Q.2120. B-ISDN Meta-Signaling Protocol.- Geneva, 1995.
  57. ITU-T Recommendation Q.2931. B-ISDN - Digital Subscriber Signaling System № 2 (DSS-2) User-Network Interface (UNI) Layer 3 Specification for Basic Call/Connection Control. - Geneva, 1995.
  58. ITU-T. Recommendation Q.2100. B-ISDN Signaling ATM Adaptation Layer (SAAL). Overview Description. - Geneva, 1995.
  59. ITU-T. Recommendation Q.2130. B-ISDN Signaling ATM Adaptation Layer (SAAL) - Service Specific Coordination Function for support of Signaling at the User-to-Network Interface (SSCF at UNI). - Geneva, 1995.
  60. ITU-T. Recommendation Q.2140. B-ISDN Signaling ATM Adaptation Layer (SAAL) - Service Specific Coordination Function for Support of Signaling at the User-to-Network Interface (SSCF at NNI). Geneva, 1995.
  61. Ahmed M., Tesnic K. ATM Managed Objects (AToMMIB), Ver. 4.00// IEFT, December 23, 1993.
  62. ANSI. B-ISDN Operations and Maintenance Principes and Functions (T1S1. 5/93 -00422), January, 1994.Александер. АТМ: Обещание пока не выполнено // Сети. - 1996. - №6.- С.30-31.
Назад | Оглавление | Вперед
О проекте | Тест


УРОВЕНЬ АТМ

УРОВЕНЬ АТМ

Структура ячеек
Виртуальные каналы и виртуальные пути

Структура ячеек

Функциональная характеристика уровня АТМ дана СС МСЭ в Рек. I.150 [31], а спецификация приведена в Рек. I. 361 [15]. Уровень АТМ на передающей стороне реализует механизм мультиплексирования ячеек, поступающих от различных источников, в единый поток пакетов АТМ. На приемной стороне механизм демультиплексирования разбивает поступающий поток на составляющие в соответствии с идентификаторами виртуальных путей и идентификаторами виртуальных каналов ячеек.
Базовым элементом уровня АТМ является ячейка. Общий вид формата пакета АТМ (ячейки), рекомендованного СС МСЭ для ШЦСИО, представлен на рис. 20. Заголовок ячейки занимает 5 октет, а информационное поле - 48.

Рис. 20. Общий вид пакета АТМ

Передача ячейки в соответствии с Рек. I.361 [15] осуществляется в следующей последовательности:
- октеты передаются в порядке возрастания, начиная с 1-го;
- биты внутри октета передаются в убывающем порядке, начиная с 8-го;
- для всех полей ячейки первый бит является наиболее значимым (MSB - Most Significant Bit).
Структура заголовка ячейки в интерфейсе пользователь-сеть приведена на рис. 21а.

8 7 6 5 4 3 2 1
УОП | ИВП
ИВП | ИВК
ИВК
ИВК | ТПН | ППЯ
КОЗ
8 7 6 5 4 3 2 1
ИВП
ИВП | ИВК
ИВК
ИВК | ТПН | ППЯ
КОЗ
a) | b)
Рис. 21. Структура заголовка пакета АТМ в интерфейсе:
а) "пользователь-сеть" | б) сетевом

Заголовок ячейки в интерфейсе пользователь-сеть имеет следующие поля:
- общее управление потоком (GFC - Generic Flow Control) длиной 4 бита;
- идентификатор виртуального пути (VPI - Virtual Path Identifier) длиной 8 бит;
- идентификатора виртуального канала (VCI - Virtual Channel Identifier) длиной 16 бит;
- типа полезной нагрузки (PT - Payload Type) длиной 4 бита;
- приоритета потери ячейки (CLP - Cell Loss Priority) длиной 1 бит;
- контроля ошибок в заголовке (HEC - Header Error Control) длиной 8 бит.
Структура заголовка ячейки в сетевом интерфейсе приведена на рис. 21б. Все различие состоит в том, что поле ОУП в сетевом интерфейсе не используется, а биты поля ОУП отдаются полю идентификатора виртуального канала, длина которого увеличивается с 8 до 12 бит.
Поле общего управления потоком (ОУП) состоит из 4 бит и предназначено [31] для управления нагрузкой в соединениях пользователь-сеть в целях защиты от перегрузок как в двухточечных, так и в многоточечных конфигурациях доступа. Поле ОУП используется для контроля нагрузки, создаваемой оконечными устройствами пользователя, но не используется для управления потоком, порождаемого сетью.
Поле идентификатора виртуального пути (ИВП) занимает 8 бит в интерфейсе пользователь-сеть и 12 бит в сетевом интерфейсе, что расширяет возможности маршрутизации.
Поле идентификатора виртуального канала (ИВК) вместе с полем ИВП составляет маршрутное поле ячейки. Поле ИВК занимает 16 бит как в интерфейсе пользователь-сеть, так и в сетевом интерфейсе.
Действительное число бит, используемых для маршрутизации, может устанавливаться по соглашению между пользователем и сетью. Для определения позиций, используемых для маршрутизации бит внутри полей ИВП и ИВК, СС МСЭ принял следующие правила:
- биты, используемые в поле ИВП или в поле ИВК, должны быть смежными;
- битовая комбинация всегда должны начинаться с младшего значащего бита соответствующего поля;
- биты, не используемые ни пользователем, ни сетью, должны устанавливаться на ноль.
Поле типа полезной нагрузки (ТПН) используется для идентификации пользовательских ячеек, ячеек ЭТО потока F5 и ячеек управления ресурсами. Для ячеек, несущих пользовательскую информацию, предусмотрена возможность индикации нагрузки, а также индикация "пользователь уровня АТМ - пользователю уровня АТМ" для протокола уровня адаптации АТМ 5-го типа.
Значения, которые может принимать поле типа полезной нагрузки, приведены в табл. 6.
При наличии перегрузки любой перегруженный сетевой узел может модифицировать значение бита индикации перегрузки с 0 на 1 внутри поля ТНП ячеек пользователя. Это дает возможность информировать получателя о возникновении в сети перегрузки. В свою очередь, получатель может информировать об этом пользователя, осуществляющего передачу информации, о необходимости снижения скорости генерации ячеек.
Поле приоритета потери ячейки (ППЯ) используется для указания явного приоритета потери ячейки. Если в поле приоритета потери ячейки записана 1 (CLP=1), то данная ячейка может быть сетевым узлом отброшена в случае возникновения перегрузок. Если в поле ППЯ записан 0 (CLP=0), то ячейка имеет высокий приоритет и должна быть сохранена.

Таблица 6
Код поля ТПН | Значение
000 | Ячейка пользователя Перегрузка отсутствует
001 | Ячейка пользователя Перегрузка отсутствует Пользователь уровня АТМ - пользователю уровня АТМ
010 | Ячейка пользователя Имеет место перегрузка
011 | Ячейка пользователя Имеет место перегрузка Пользователь уровня АТМ - пользователю уровня АТМ
100 | Ячейка ЭТО виртуального канала для сегментного потока F5
101 | Ячейка ЭТО виртуального канала для потока "точка-точка"
110 | Ячейка управления ресурсами
111 | Резерв

Приоритет потери ячейки устанавливается пользователем или провайдером услуг.
Ячейки, принадлежащие источникам с постоянной скоростью передачи, всегда должны иметь более высокий приоритет по отношению к источникам с изменяющейся скоростью передачи.
Однако, при передаче ячеек источника с изменяющейся скоростью передачи, части ячеек, определяющей качество обслуживания, может присваиваться CLP=1, а остальным, потеря которых некритична, назначается CLP=0.
На узлах доступа может осуществляться проверка параметров потока пользователя, а на транзитных узлах - параметров сетевой нагрузки. Если параметры потока будут превышать установленные соглашением, то у части ячеек значение поля приоритета потери ячейки может меняться с 0 на 1. При перегрузках на других узлах эти ячейки могут сбрасываться.
Поле контроля ошибок в заголовке на уровне АТМ не заполняется и не проверяется. Механизм контроля ошибок в заголовке определен Рек. I.432. Описание этого механизма приведено во второй главе.


УРОВЕНЬ АДАПТАЦИИ АТМ

УРОВЕНЬ АДАПТАЦИИ АТМ

Структура протоколов уровня адаптации АТМ
Уровень адаптации АТМ 1-го типа
Уровень адаптации АТМ 2-го типа
Уровень адаптации АТМ 3/4-го типа
Уровень адаптации АТМ 5-го типа

Структура протоколов уровня адаптации АТМ

В соответствии с эталонной моделью протоколов [14] уровень адаптации АТМ (УАА) расположен между уровнем АТМ и верхними уровнями. Уровень адаптации АТМ предназначен для преобразования трафика пользователя в протокольные блоки данных для их размещения в поле полезной нагрузки одного или нескольких смежных пакетов АТМ и наоборот. В качестве пользователя может также выступать система управления (С-plane) или менеджмента (М-plane).
На уровне АТМ все виды пользовательской информации мультиплексируются, демультиплексируются и транспортируются единым способом в виде 53-октетных пакетов АТМ, у которых заголовок занимает 5 октетов, а информационная часть - 48.
При этом каждый протокол уровня адаптации АТМ должен быть приспособлен к определенному классу трафика со своими специфическими характеристиками, определяющими уровень требований службы к временной и семантической прозрачности сети АТМ. Все функции уровня адаптации АТМ должны быть реализованы в терминальном оборудовании или в коммутаторе доступа.
Уровень адаптации АТМ принято в свою очередь делить на [16,33]:
- подуровень сегментации и сборки (SAR);
- подуровень конвергенции или слияния (CS).
Основными функциями подуровня сегментации и сборки являются:
    • на передающей стороне - сегментация протокольных блоков данных вышележащего уровня в 48 октетов информационного поля ячейки АТМ;
    • на приемной стороне - сборка информационных полей ячеек в протокольный блок данных более высокого уровня.В свою очередь подуровень конвергенции может делиться на две части:
  • общую (CPCS);
  • служебно-ориентированную (SSCS), которой может не быть.
Общая диаграмма уровня адаптации приведена на рис. 26.

Рис. 26. Диаграмма уровня адаптации АТМ

Термин уровень адаптации АТМ нулевого типа не является официальным, но он встречается в технической литературе [4]. Он означает, что в данном конкретном случае функции адаптации не требуются, а содержимое информационного поля ячейки непосредственно передается на более высокий уровень.


ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ

ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ

Целевое назначение и функции
Принципы поддержки в сетях АТМ служб не ориентированных на соединение
Обеспечение функционирования высокоскоростных служб ПД, не ориентированных на соединение через АТМ
Обеспечение функционирования службы ретрансляции кадров через АТМ
TCP/IP через ШЦСИО
Эмуляция локальных вычислительных сетей

Целевое назначение и функции

Модель протоколов ШЦСИО на технологии АТМ, представленная на рис. 10 в виде куба, показывает, что плоскость пользователя охватывает физический уровень, уровень АТМ, уровень адаптации АТМ и более высокие уровни и обязана предоставить пользователю все виды услуг по обмену всеми видами информации.
Плоскости управления и менеджмента обязаны обеспечивать поддержку плоскости пользователя. Так, плоскость управления в интересах пользователя должна поддерживать виртуальные соединения (ВС) следующих типов:
- коммутируемые;
- постоянные.
При этом коммутируемые и постоянные ВС должны быть соединениями виртуальных путей и виртуальных каналов типа "точка-точка", "точка-многоточка", "многоточка-точка" и "многоточка-многоточка".
Соединения ВП и ВК предоставляют пользователям требуемое качество обслуживания и полосу пропускания в соответствии с соглашением по параметрам трафика и требуемому качеству обслуживания между пользователем и сетью.
К высшим уровням плоскости пользователя относят также все служебно-ориентированные протоколы, необходимые для обеспечения связи от пользователя к пользователю.
Протоколы высших уровней должны быть независимы от протоколов, используемых нижележащими уровнями (уровнем адаптации АТМ и уровнем АТМ).
Рассматривая всю совокупность протоколов высших уровней с точки зрения технологии АТМ, всех их можно условно разбиты на три группы.
К первой группе можно отнести протоколы, которые могут быть пригодными для обмена информацией через АТМ без изменений.
Ко второй группе протоколов можно отнести те, которые могут быть упрощены, так как часть их функций может быть передана уровню АТМ или уровню адаптации АТМ.
К третей группе можно отнести протоколы верхних уровней, которые требуют существенного расширения.
Разработка оптимальных протоколов, обеспечивающих высокую эффективность ШЦСИО на технологии АТМ, находится в центре внимания СС МСЭ, Европейского института стандартов в области телекоммуникаций, Американского национального института стандартов, Форума АТМ, группы инженерной поддержки Internet, Форума Frame Relay и группы высокоскоростной ПД (SIG - SMDS Interest Group).
Всегда считалось, что сначала необходимо заложить прочный фундамент здания и подвести к нему дороги и инженерные коммуникации, а затем возводить стены. И если СС МСЭ основные усилия направляет на возведение всего здания АТМ как единого целого, то рабочие группы Форума АТМ основное внимание уделяют службам и пользователям.
Достаточно сказать, что к концу 1997 г. Форумом АТМ завершена разработка более 100 спецификаций, в том числе по интерфейсу пользователь-сеть, эмуляции локальных сетей, мультипротокольному режиму передачи по сетям АТМ и многим другим, направленным на создание оборудования и внедрение сетей АТМ.


ПЛОСКОСТЬ УПРАВЛЕНИЯ И ЕЕ ФУНКЦИИ

ПЛОСКОСТЬ УПРАВЛЕНИЯ И ЕЕ ФУНКЦИИ

Основные функции
Маршрутизация в ШЦСИО
Сигнализация в ШЦСИО

Основные функции

Плоскость управления (C-plane) обеспечивает установление, контроль и разъединение соединений. Ей принадлежат все функции сигнализации, кроме протоколов метасигнализации, а также выполнение функций адресации и маршрутизации.
Для того чтобы создать логическое соединение для передачи информации между источником и получателем, необходимо:
- иметь уникальные адреса источника и получателя;
- определить по тому или другому критерию маршрут составления логического соединения.
При построении системы адресации в сети АТМ необходимо, чтобы она удовлетворяла следующим основным требованиям:
- обеспечивала уникальность адреса;
- позволяла автоматизировать процессы распределения и назначения адресов;
- давала возможность эффективного использования адресного пространства;
- была проста в обращении и обеспечивала легкость внесения изменений в адреса;
- допускала расширение адресной схемы.

Планы адресации в ШЦСИО

Структура форматов адресов Форума АТМ согласно спецификации интерфейса пользователь-сеть 3-й версии [7] приведена на рис. 43. Все адреса с форматом точки доступа к сетевым услугам (NSAP - Network Service Access Point) состоят из следующих основных компонентов:
- идентификатора полномочий администрации и формата (AFI - Autority and Format Identifier), которая определяет тип и формат идентификатора исходной области (IDI - Initial Domain Identifier);
- в свою очередь, идентификатор исходной области (IDI) определяет размещение адресов и особой части области (DSP - Domain Specific Part), где содержится действующая маршрутная информация.

а) Формат DCC АТМ (с числовым кодом страны)
рис43а
б) Формат ICD АТМ (с указателем международного кода)
рис43б
в) Формат E.164 NSAP АТМ
(идентификатор исходной области является номером Е.164)
рис43в

Рис. 43. Структура адресных форматов Форума АТМ

Показанные на рис. 43 форматы отличаются по сути содержанием полей идентификатора полномочий администрации и формата (AFI) и идентификатора исходной области (IDI):
- в формате NSAP для Е.164 поле идентификатора исходной области (IDI) является номером Е.164;
- в формате кода данных страны (DCC - Date Country Code) поле идентификатора исходной области (IDI) является числовым кодом страны (DCC), который обозначает отдельные страны в соответствии со стандартом МОС 3166;
- в формате международного указателя кода (ICD - International Code Designator) поле идентификатора каждой области (IDI) является числовым кодом международных организаций (ICD).
Форум АТМ рекомендует владельцам ведомственных сетей или поставщикам сетевых услуг использовать форматы DCC или ICD для разработки собственных планов нумерации. Организациям, желающим получить адреса АТМ, следует обращаться в местные администрации связи. Полученные адреса могут быть использованы как для адресации АТМ, так и для адресации NSAP. В последнем случае, если над уровнем АТМ работает протокол без установления соединения, то одно и то же значение может использоваться как для идентификации адреса NSAP узла, так и для его адреса АТМ.
В реальных точках NSAP поле особой части области (DSP) обычно разделяется в соответствии с фиксированной иерархией на поля маршрутной области (RD - Routing Domain), идентификатора зоны (AREA) и идентификатора оконечной системы (ESI - End System Identifier).
Форум АТМ объединил поля RD и AREA в единое поле особой части области высокого порядка (НО -DSP).
В поле идентификатора оконечной системы (ESI) размещается 48-битовый адрес контроля доступа к среде передачи (MAC) по спецификациям IEEE.
Завершающее 1-октетное поле селектора (SEL) предусмотрено для возможной организации местного мультиплексирования в пределах станций доступа и сетевого значения не имеет.
В целях упрощения процедур администрирования и конфигурирования адресов через интерфейс пользователь-сеть Форумом АТМ разработан механизм регистрации адресов, основанный на промежуточном интерфейсе локального менеджмента (ILMI - Interim Local Management Interface). Это позволяет оконечной системе АТМ информировать через интерфейс пользователь-сеть коммутатор АТМ о своем уникальном номере МАС и получить в ответ адресный префикс полного узлового адреса АТМ.
Помимо решения вопроса об автоматическом назначении адресов АТМ, данный механизм может оказаться полезным и при автоконфигурировании других типов информации, например, адресов высоких уровней, серверов и т.п.
Необходимо отметить, что форматы адресов в соответствии со спецификациями Форума АТМ интерфейса пользователь-сеть версий 3.0 и 3.1 [7,49] предназначены для идентификации только одной оконечной точки. Они же могут быть использованы для пошагового установления соединений типа "точка-многоточка".
В спецификации Форума АТМ интерфейса пользователь-сеть версии 4.0 предусмотрена работа с групповыми адресами в режиме установления сразу нескольких соединений на один запрос.
Но форматы для групповых адресов еще должны быть окончательно отработаны, что связано, не в последнюю очередь, с приближающейся разработкой системы сигнализации для ШЦСИО в полном объеме.
Формат нумерации, рекомендуемый СС МСЭ [38] показан на рис. 44.

Рис. 44. Формат плана нумерации СС МСЭ

Международный десятичный номер кодируется в виде двоичного числа (BCD - Binary Coded Decimal) и в левой части заполняется нулями для получения постоянной длины из 15 чисел. Код страны (СС- Country Code) согласно Рек. Е.163 занимает от одной до трех цифр. Национально значимый номер (NSN - Nationably Significant Number) cостоит из национального кода назначения (NDC - National Dastination Code) и абонентского номера (SN - Subscriber Number).
Использование формата Е.164 для оконечного оборудования передачи данных и других приложений, таких как высокоскоростная ПД и т.д., находятся в стадии изучения.
Но можно сказать уже сейчас, что сети АТМ общего пользования будут поддерживать Рек. Е.164 [38], а частные (корпоративные) сети - форматы Форума АТМ.


ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ

Принципы управления техническим состоянием сети АТМ и ее элементов

Управление техническим состоянием сети АТМ и ее элементов должно позволить определить факт отказа, место отказа и произвести локализацию отказа. Для решения этих задач используются ячейки, выполняющие функции указания аварии (AIS), указания об удаленном дефекте (RDI/FERF), проверки непрерывности (Continuity Check) и проверки шлейфом (Loopback).
Поля специфических функций ячеек AIS и RDI (FERF) приведены на рис. 58.

* Кодирование по умолчанию="6А" Hex для всех октетов

Рис. 58. Поле специфических функций ячеек типа AIS и RDI/RERF

В поле типа отказа заносится информация о предполагаемом типе отказа, а в поле местонахождения отказа - указание о предполагаемом месте происшедшего отказа. В настоящее время спецификационные значения этих полей еще не стандартизованы.
Рассмотрим возможности использования ячеек AIS и RDI/FERD (рис. 59) на двух примерах [12]:
- | между сетевыми узлами 2 и 3 произошел отказ физического уровня (пути передачи) в обоих направлениях;
- | между сетевыми узлами 2 и 3 произошел отказ физического уровня в одном направлении.
В обоих случаях между узлами 1 и 4 существовало соединение виртуальных путей или виртуальных каналов.
Первый пример иллюстрирует характерную аварию цифрового тракта между узлами 2 и 3, приводящую к одновременному отказу виртуальных путей и виртуальных каналов, образованных в данном тракте. Обозначим отказы в каждом направлении передачи как "отказ-А" и "отказ-В". Не будем пока отвечать на вопрос, по каким признакам узел 3 обнаруживает факт "отказа-А", а сетевой узел 2 обнаруживает "отказ-В" соответственно. После обнаружения отказа узел 3 вырабатывает ячейку AIS и посылает ее "вниз по течению" в сторону сетевого узла 4, который, получив ячейку AIS с указанием предполагаемого характера (типа) и места отказа, формирует и посылает по течению в сторону сетевого узла 3 сообщение RDI или FERF об "отказе-А".

Отказ в обоих направлениях

рис59

Отказ в одном направлении

рис59

Рис. 59. Использование ячеек типа AIS и RDI/FERF
для обнаружения отказов и определения их местонахождения

Аналогично узел 2, обнаружив "отказ?В", посылает "вниз по течению" - узлу 1 ячейку AIS-B. Приняв ячейку AIS-B, сетевой узел 1 формирует и посылает сообщение RDI или FERF об "отказе?В".
Второй пример иллюстрирует случай отказа только в одном направлении. Узел 3, находящийся ниже по направлению места отказа, генерирует аварийный сигнал AIS-A, который распространяется к концу соединения. Сетевой узел 4 генерирует сигнал RDI или FERF, который распространяется к концу другого соединения, т. е. сетевому узлу 1.
Таким образом, методы обмена ячейками ЭТО типа AIS и RDI или FERF позволяют обнаружить факт и место возникновения как 2-сторонних, так и 1-сторонних отказов физического уровня и сообщить об этом в систему сетевого управления.
В общем случае можно сделать вывод, что один физический отказ может генерировать множество ячеек ЭТО. При обнаружении состояния отказа ячейка ЭТО посылается периодически.
Для ограничения числа ячеек ЭТО период генерации ячеек не должен превышать нескольких секунд. Кроме того, Форум АТМ не требует на обязательной основе генерации ячеек ЭТО уровня виртуального канала (VC-AIS и VC-RDI или VC-FERF). В спецификации Форума АТМ B-ICI указывается, что ячейки ЭТО уровня виртуального канала типа AIS и RDI/FERF могут использоваться только на селективной основе. Это существенно ограничивает количество обрабатываемых ячеек ЭТО и обеспечивает высокую эффективность решения задач, возложенных на ячейки типа AIS и RDI/FERF.
Использование ячеек ЭТО типа AIS и RDI/FERF позволяет выявить повреждения на физическом уровне типа выхода из строя цифрового тракта, которые приводят к разрыву соединений виртуальных путей и организуемых ими соединений виртуальных каналов. Однако ячейки ЭТО типа AIS и RDI/FERF не могут обнаружить случаи неправильного назначения или трансляции идентификаторов виртуальных путей или виртуальных каналов при составлении коммутационным оборудованием соединения виртуального пути или виртуального канала, что приводит к потере пакетов АТМ или к доставке их не по адресу.

Рис. 60. Поле специальных функций ячейки ЭТО типа "Loopback"

Операция проверки шлейфа, выполняемая с помощью ячеек ЭТО типа "Loopback" (рис. 60), позволяет достаточно просто выявить место возникновения таких неисправностей. Следует отметить, что проверка аппаратуры и каналов связи шлейфом или по малому и большому кольцам всегда использовалась в процессе эксплуатации телеграфной аппаратуры при ее работе как по проводным, так и по радиоканалам, и была регламентирована соответствующими инструкциями, когда по результатам замеров постоянных и переменных преобладаний и по частоте ошибок делалось заключение об исправности оконечной аппаратуры на ближнем и дальнем концах и соединяющего их составного канала связи.
Под поля специальных функций ячейки ЭТО отведено 26 байт:
- идентификатор шлейфа - 8 бит (из них семь бит
не используются и заполняются нулями);
- корреляционная метка - 1 байт;
- идентификатор места шлейфа - 12 байт;
- идентификатор источника - 12 байт.
Использование оставшихся байт пока не определено.
Поле идентификатора шлейфа имеет значение 1 при передаче источником и изменяется на 0 в точке приема, обеспечивающей отправку ячейки обратно к источнику, т. е. выполняющей операцию под условным названием "Loopback - шлейф". При получении отправленной ячейки с индикатором шлейфа, имеющим значение 0, источник стирает данную ячейку ЭТО, не допуская зацикливания.
Поле корреляционной метки заполняется источником и позволяет идентифицировать ячейку при ее возвращении среди других ячеек ЭТО.
Поле идентификатора места шлейфа показывает, в каком месте ячейка должна быть направлена обратно. По умолчанию принято, что если поле заполнено единицами, то операция "шлейфа" должна быть выполнена в оконечной точке.
Поле идентификатора источника служит для опознавания ячейки и ее удаления после возвращения к источнику, который ее генерировал.
Операция проверки шлейфа может выполняться как оконечными точками, так и сетевыми узлами.
Рассмотрим пример использования шлейфа для диагностирования отказов, которые невозможно обнаружить с помощью ячеек ЭТО типа AIS и RDI/FERF [12]. Пусть имеются две оконечные точки 1 и 2 (рис. 61), между которыми должно существовать соединение виртуального пути, проходящее через три сети (сети № 1 и 3 - ведомственные, а сеть № 2 - ОП). Каждая сеть имеет по 3 сетевых узла.
На рис. 61а показана проверка соединения виртуального пути путем прямого шлейфа между рассмотренными точками № 1 и 2. Если соединение нарушено, то любая сеть может путем последовательной организации сегментных шлейфов выявить место повреждения.
На рис. 61б показана проверка с помощью сегментного шлейфа исправности соединения между оконечной точкой № 1 и сетевым узлом № 1 ведомственной сети № 1. Если соединение исправно, то место повреждения может быть выявлено путем последовательного проведения операции сегментного шлейфа:
- | между сетевыми узлами № 1 и 3 ведомственной сети АТМ № 1 (рис. 61в) для проверки исправности соединения виртуального пути на участке ведомственной сети № 1;
- | между сетевым узлом № 1 ведомственной сети АТМ № 1 и сетевым узлом № 3 сети ОП (рис. 61г) для проверки исправности соединения виртуального пути на участках ведомственной сети № 1 и сети АТМ ОП;
- | между сетевым узлом № 1 ведомственной сети АТМ № 1 и сетевым узлом № 3 ведомственной сети № 2 (рис. 61д) для проверки исправности соединения виртуального пути на сетевом участке.

Рис. 61. Использование операции "шлейф" для диагностирования места отказа

Если операция сегментного шлейфа между сетевым узлом № 1 ведомственной сети АТМ № 1 и сетевым узлом № 3 ведомственной сети АТМ № 2 покажет неисправность соединения виртуального пути на сетевом участке, то неисправность на участке между сетевым узлом № 3 ведомственной сети № 2 и оконечной точкой № 2, в противном случае неисправность на участке ведомственной сети № 3, и место ее возникновения может быть установлено с помощью проведения операции сегментного шлейфа.
Приведенные примеры диагностирования повреждений с помощью ячеек ЭТО типа "Loopback" показывают высокую эффективность этого метода, позволяющего в сочетании с ячейками ЭТО типа AIS и RDI/FERF обеспечивать эффективное обнаружение факта отказа или неисправности и устанавливать место повреждения.
Для обнаружения факта отказа или неисправности и места повреждения возникла идея применения еще одной ячейки ЭТО, получившей имя "Continuity Check" - проверки непрерывности. Идея проверки непрерывности заключается в том, что оконечная точка периодически с заданным интервалом посылает ячейки ЭТО типа "Continuity Check", что позволяет всем промежуточным точкам соединения и оконечной точке обнаружить факт отказа. Американский институт стандартов (ANSI) в проектах документов [61] расширил эту идею, предписав при пропадании ячеек ЭТО типа "Continuity Check" в течение 2...20с генерировать в направлении вверх по виртуальному пути ячейки ЭТО типа RDI/FERF.
Пример использования ячеек ЭТО типа "Continuity Check" для обнаружения отказа, которые ячейки ЭТО типа AIS определить не в состоянии, приведен на рис. 62.

Рис. 62. Использование ячеек ОАМ типа "Continuity Check" для обнаружения отказа

На рис. 62а показано соединение виртуального пути, составленное 3 сетевыми узлами. На сетевом узле № 2 в маршрутной таблице произошел сбой, который прервал поток ячеек ЭТО типа "Continuity Check" (рис. 62б).
Рис. 62в показывает, что сетевой узел № 3, перестав получать ячейки ЭТО "Continuity Check", по истечении установленного времени посылает вверх оконечной точке № 1 ячейку ЭТО типа RDI/FERF с извещением об отказе.
Следует отметить, что для ячейки ЭТО типа "Continuity Check" значения полей специальных функций пока не стандартизированы, и Форум АТМ не определяет поддержку проверки непрерывности в интерфейсе "пользователь - сеть".
Имеющиеся на сегодня стандарты пока еще не определяют мер, которые следует предпринимать в ответ на отказ на уровне АТМ, но имеются стандарты СЦИ (SDH) и SONET, которые определяют концепцию защиты на физическом уровне для соединений типа "точка-точка" путем резервирования 1:N или использования кольцевой конфигурации. Также можно считать отработанной стратегию восстановления для сетей типа "решетка" или более сложной конфигурации, имеющей резервный сетевой ресурс, который можно использовать на реконфигурацию сети или изменение маршрутизации при выходе из строя по тем или другим причинам части сетевых узлов и цифровых трактов связи между ними. Следует отметить, что используемый в сетях АТМ единый способ переноса всех видов информации в виде пакетов АТМ фиксированной длины - ячеек методом статистического мультиплексирования в трактах синхронной цифровой иерархии, которую принято называть самовосстанавливающейся, обеспечивает очень высокую гибкость сети и потенциальную способность к восстановлению в высокоскоростных сетях.


ПЛОСКОСТЬ МЕНЕДЖМЕНТА И ЕЕ ФУНКЦИИ

Принципы измерения
параметров производительности на уровне АТМ

Основным принципом измерения сетевых параметров, характеризующих производительность сети и ее элементов и обеспечиваемое ими качество обслуживания, является правило, заключающееся в том, что измерение должно производиться без нарушения непрерывности соединений и без снижения качества обслуживания пользователей. Для запуска (активации) и остановки (дезактивации) процесса измерений тех или иных параметров, а также процесса проверки непрерывности, служит специальный тип ячеек ЭТО - "Activation/Deactivation".Структура поля специальных функций ячейки ЭТО типа "Activation/Deactivation", состоящего из 45 байт, включает (рис. 63):
- поле идентификатора сообщения - 6 бит;
- поле направления действия - 2 бит;
- поле корреляционной метки - 8 бит;
- поле размера блока измерений параметра производительности А->В - 4 бит;
- поле размера блока измерений параметра производительности В->А - 4 бит.
Использование оставшихся 42 октетов пока не определены. Поле идентификатора сообщения в зависимости от его заполнения означает:
000001 - активация (запрос);
000010 - подтверждение активации;
000011 - отрицание запроса активации;
000101 - дезактивация (запрос);
000110 - подтверждение дезактивации;
000111 - отрицание запроса дезактивации.
В поле направления действия записывается 10 при направлении активации от А к В или 01 при направлении активации от В к А.

Идентифи
-катор
сообщения 		Направление
действия 		Кореляционная
метка 		Блок РМ
Размер А-В** 		Блок РМ
Размер В-А** 		Неиспользуемые
октеты *
6 | 2 | 8 | 4 | 4 | 42x8 бит
* Кодирование по умолчанию ='6A' Hex | ** Кодирование по умолчанию ='0000'

Рис. 63. Структура поля специальных функций ячеек ОАМ
типа "Activation/Deactivation" (активации/дезактивации)

В поле размера блока измерений производительности от А к В заносится:
1000 - при длине блока 1024 ячеек;
0100 - при длине блока 512 ячеек;
0010 - при длине блока 256 ячеек;
0001 - при длине блока 128 ячеек.
Аналогичные значения поля размера блока ячеек для измерения производительности от В к А.
Размеры блоков от А к В и от В к А могут быть в общем случае разными.
На рис. 64 показана процедура активации и дезактивации измерения параметров производительности или проверки непрерывности.
Точка А может быть оконечной точкой или промежуточной. Она генерирует запрос активации/ дезактивации в направлении В, запрашивая действия мониторинга производительности или контроля направленности от А к В, от В к А или в обоих направлениях. Если точка В может исполнять все запросы, то она посылает сообщение с подтверждением запроса на активацию/дезактивацию соответственно. Если точка В не может исполнить запрос, то тогда посылается сообщение с отрицанием активации или дезактивации. Это может иметь место в случае, когда оборудование оконечной точки неспособно поддерживать функции контроля производительности или проверки непрерывности.
Если запрос дезактивации относится к единичной функции, которая в настоящее время в данной точке не поддерживается, то тогда также посылается сообщение с отрицанием дезактивации (нельзя прекратить процесс, которого нет). Если запрос дезактивации относится к обоим направлениям, и на одном из них операция по мониторингу производительности или по проверке непрерывности выполняется, то запрос подтверждается с указанием той стороны, где неподдерживаемая функция игнорируется.

Рис. 64. Процедура активации/дезактивации
параметров производительности или проверки непрерывности

Активация и дезактивация позволяют произвести измерение параметров производительности на выбранных соединениях виртуальных путей или виртуальных каналов. Это снижает общий объем нагрузки, который требуется для проведения измерений. Следует отметить еще одну важную особенность процедуры активации или дезактивации - возможность осуществления непрерывного или выборочного контроля.
Функция мониторинга производительности может осуществляться в общем случае от А к В, от В к А или в оба конца. Под поля специальных функций ячеек ЭТО типа РМ (Performance Measurement) отводится, как и для всех ячеек ЭТО, 45 байт (рис. 65).
Из них пока не определено использование 33 байт. Остальная часть поля определена следующим образом :
- | поле порядкового номера мониторинга (MSN - Monitoring Sequence Number) - 8 бит;
- | поле общего числа ячеек пользователя (TUC - Total User Cell) - 2 байта;
- | поле BIP -16 (Bit Interleaved Parity) - 2 байта;
- | поле отметки времени - 4 байта;
- | поле результата контроля ошибок в блоке - 1 байт;
- | поле подсчета потерянных пакетов и пакетов, пришедших не по адресу - 2 байта.
В поле порядкового номера мониторинга (MSN) записывается номер ячейки ЭТО типа РМ по модулю 256.

* Кодирование по умолчанию ='6A' Hex, когда нет прямого мониторинга
** Кодирование по умолчанию ='6A' Hex, когда нет обратного мониторинга
*** Кодирование по умолчанию =все 1, когда не используется временной ярлык

Рис. 65. Структура поля специальных функций ячеек ЭТО
типа "Performance Measurement" (измерение производительности)

В поле общего числа ячеек пользователя (TUC) записывается общее число ячеек пользователя, отправленных после последней ячейки ЭТО типа РМ. В поле BIP -16 записывается код для обнаружения ошибок в блоке ячеек пользователя, отправленных после последней ячейки ЭТО типа РМ.
Поле отметки времени используется в обратном направлении для определения времени задержки. Точность измерения составляет 1 мкс и менее.
На рис. 66 показан процесс вставки ячеек ЭТО и их обработки при измерении параметров производительности [12].
Точки А и В определяются с помощью процедуры активации и дезактивации. Это могут быть как оконечные, так и промежуточные точки.
В примере рассмотрена процедура передачи ячеек ЭТО типа РМ в обоих направлениях и с различными размерами блока ячеек пользователя в каждом направлении. На стороне передачи основными функциями оборудования по мониторингу параметров производительности являются:
- вставка ячеек ЭТО;
- подсчет ячеек пользователей;
- расчет BIP-16 на стороне передачи.
На стороне приема ячейки ЭТО удаляются. Выполняется подсчет ячеек пользователя. Пересчитывается BIP- 16 и сравнивается со значением, полученным на стороне передачи. При этом необходимо отметить, что ячейка ЭТО типа РМ содержит результаты мониторинга в предшествующем блоке.
Параметры качества обслуживания измеряются на основе оценок исхода транспортирования ячеек в сети АТМ.
В общем виде согласно Рек. I.356 могут быть определены следующие 4 исхода транспортирования ячеек в сети АТМ:
- | транспортирование ячейки является успешным (отсутствуют ошибки в информационном поле, заголовок получен без ошибок, время задержки не превышает нормативной);
- | ячейка принята с ошибками (время задержки не превышает нормативной, но содержание принятого информационного поля не соответствует переданному или ячейка принята с ошибками в заголовке после его проверки и исправления одиночных ошибок);
- | ячейка считается потерянной (время задержки превышает нормативное, или ячейка не поступила в точку приема вообще);
- | ячейка считается прибывшей не по адресу (прием ячейки не соответствует передаче).

Рис. 66. Процедура измерения параметров производительности уровня АТМ
с помощью ячеек ЭТО типа PM

Заключение об исходе выполняется также по каждому блоку ячеек. Исход мониторинга считается успешным, если в блоке из N ячеек общее количество ячеек, принятых с ошибками, потерянных и поступивших не по адресу, меньше или равно М. В противном случае исход транспортирования блока ячеек считается безуспешным, а такой блок принято называть блоком ячеек с серьезными ошибками (SECB - Severely Errored Cell Block).
В качестве параметров, характеризующих производительность уровня АТМ по транспортированию ячеек АТМ, принято использовать:
- коэффициент ошибочных ячеек;
- коэффициент потерянных ячеек;
- частоту появления ячеек, пришедших не по адресу;
- коэффициент ошибочных блоков;
- задержку ячеек;
- среднее значение задержки ячеек;
- среднее квадратическое отклонение задержки ячеек.
Коэффициент ошибочных ячеек для одного или нескольких соединений

(1)

где NPER - количество ячеек, принятых с ошибками в процессе мониторинга;

Ns - общее количество переданных ячеек в процессе мониторинга.
Из числа ячеек, принятых с ошибками, и из общего количества переданных ячеек в процессе мониторинга должны быть исключены ячейки, содержащиеся в блоках с серьезными ошибками. Число ячеек, принятых с ошибками, определяется путем подсчета числа ошибок М по четности (2<М<16, по умолчанию 4) в поле BIP-16. Общее количество переданных ячеек пользователя содержится в поле TUC ячейки ЭТО.
Коэффициент потерянных ячеек для одного или нескольких соединений

(2)

где NPLR - количество потерянных ячеек;

Ns - общее количество ячеек, переданных источником.При расчете коэффициента потерянных ячеек из NPLR и Ns также должны быть исключены потерянные и переданные ячейки, подсчитанные в блоках ячеек с большим количеством ошибок.
Общее количество потерянных ячеек определяется как разность между количеством переданных ячеек точкой А и количеством принятых ячеек в точке В при мониторинге из А в В и наоборот. Если количество переданных ячеек меньше количества принятых, то произошло событие прибытия ячейки не по адресу. При таком исходе потерянных ячеек нет.
К сожалению, необходимо отметить, что такая схема подсчета имеет логический дефект: считается, что потери ячеек нет, если количество потерянных ячеек равно количеству ячеек, пришедших не по адресу.
Частота прихода ячеек не по адресу определяется как отношение количества ячеек, пришедших не по адресу, к общему числу ячеек, принятых пользователем:

(3)

Блоки ячеек с большим количеством ошибок также следует исключать при расчете количества ячеек, пришедших не по адресу. Появление ячеек, пришедших не по адресу (их еще иногда называют побочными ячейками), чаще всего объясняется наличием в поле идентификатора виртуального пути или виртуального канала заголовка ячейки необнаруженной ошибки.
Этот параметр определяется как частота появления, а не как коэффициент, так как механизм возникновения побочных ячеек определяется числом принятых ячеек и не зависит от числа ячеек, переданных источником на контролируемом соединении.
Число ячеек, пришедших не по адресу, определяется как число ячеек, действительно полученных в блоке, минус число переданных ячеек. Если этот результат негативен, то число ячеек, пришедших не по адресу, равно нулю. При таком исходе имеет место потеря ячеек.
Коэффициент ошибочных блоков для одного или нескольких соединений может быть определен как отношение числа принятых блоков ячеек с большим количеством ошибок к общему количеству переданных блоков ячеек:

(4)

Под блоком ячеек понимается последовательность из N ячеек пользователей, передаваемых или принимаемых между двумя соседними ячейками ЭТО типа РМ.
Исход транспортирования блока безуспешным, если в принятом блоке количество ячеек с ошибками, потерянных ячеек и ячеек, пришедших не по адресу, превышает нормативное. Такой блок и называют блоком ячеек с большим количеством ошибок ( SECB - Severely Errored Cell Block).
В блоке ячеек с большим количеством ошибок количество ошибок в поле BIP-16 превышает М (2 <М <16, по умолчанию 4) или количество потерянных ячеек превышает k (2 Необходимо отметить, что при большом количестве замеров коэффициенты, характеризующие ошибочные, потерянные и пришедшие не по адресу ячейки, а также ошибочные блоки сходятся к вероятностям наличия ошибок в ячейке, потери ячейки, прихода ячейки не по адресу и получения ошибочного блока.


СТРУКТУРА И ПРОТОКОЛЫ АТМ

Эталонная конфигурация ШЦСИО

Интерфейс пользователь-сеть

Эталонная конфигурация УЦСИО , описанная в Рек. I.411 [1], с небольшими изменениями и дополнениями признана пригодной и для ШЦСИО, что нашло свое отражение в Рек. I.413 [2]. Эталонная конфигурация интерфейса пользователь-сеть (рис. 1.) содержит два элемента:
- функциональные группы;
- эталонные точки.
Одно или несколько стандартных широкополосных оконечных устройств пользователей (В-ТЕ1 - Broadband Terminal Equipment) подключается к широкополосному сетевому окончанию (B-NT - Broadband Network Termination). При этом оконечные устройства являются однотипными, либо представляют собой комбинацию разнотипных устройств.
Устройство B-NT обеспечивает подключение BT-E пользователя к сети АТМ, а также возможность совместного использования абонентской линии несколькими стандартными широкополосными оконечными устройствами. С учетом необходимости выполнения этих задач функциональная группа B-NT разделяется на две функциональные подгруппы:
- подгруппу 1-го типа B-NT1, выполняющую функции линейного окончания;
- подгруппу 2-го типа B-NT2, выполняющую функции подключения одного или нескольких оконечных устройств к одной линии доступа.

В-NT, В-NT1, В-NT2 | - широкополосные устройства сетевого окончания
В-ТЕ1 | - широкополосное оконечное устройство со стандартным стыком
В-ТЕ2 | - широкополосное оконечное устройство с нестандартным стыком
ТЕ2 | - узкополосное оконечное устройство с нестандартным стыком
В-TA | - широкополосный терминальный адаптер
R , SB , TB | - эталонные точки

Рис. 1. Эталонная конфигурация интерфейса пользователь-сеть

Между этими подгруппами определяются эталонные точки:
- точка Тв между B-NT1 и B-NT2;
- точка Sв между B-NT2 и B-TE1;
- точка R между ТЕ2 или В-ТЕ2 и В-ТА.
Устройство сетевого окончания 1-го типа B-NT1 осуществляет прямое и обратное преобразование сигналов в эталонной точке Тв в сигналы, соответствующие передаче по линии доступа, т.е. выполняет функции, сходные с функциями физического уровня эталонной модели протоколов взаимосвязи открытых систем (ВОС):
- образования линейного окончания;
- управления процессом передачи;
- эксплуатации и технического обслуживания (ОАМ - Operation and Maintenance).
С помощью B-NT1 обеспечивается независимость всех остальных функциональных групп B-NT2 и В-ТЕ1 или В-ТА и ТЕ2 (В-ТЕ2) от способа передачи сигналов по линии доступа.
Широкополосное устройство сетевого окончания 2-го типа B-NT2 выполняет функции как физического уровня так и более высоких уровней эталонной модели протоколов ВОС. Такими функциями широкополосного сетевого окончания 2-го типа B-NT2 могут быть:
- адаптация к различным интерфейсам физических сред и топологиям;
- мультиплексирование/демультиплексирование или
концентрация/деконцентрация трафика источников;
- распределение ресурсов;
- контроль параметров пользователя;
- управление протоколами сигнализации;
- замыкание внутреннего трафика.
Важной задачей B-NT2 является обеспечение совместного использования одного сетевого окончания несколькими оконечными терминалами. При этом количество оконечных устройств, их распределение в пространстве, а также физическая реализация B-NT2 могут существенно различаться.
Сетевое окончание B-NT2 может отсутствовать - "нуль B-NT2", если возможно прямое соединение оконечного устройства пользователя В-ТЕ1 с широкополосным сетевым окончанием B-NT1(рис. 2). В этом случае эталонные точки Sв и Тв совпадают.

Рис. 2. Совпадение эталонных точек SB иTB
Возможно совмещение функций широкополосных устройств сетевого окончания 1-го и 2-го типа (рис. 3).

Рис. 3. Конфигурация с физическим интерфейсом только в точке SB

Также возможно обеспечение функций B-NT2 с широкополосным оконечным устройством пользователя (рис. 4.).

Рис. 4. Конфигурация с физическим интерфейсом только в точке ТB

ШЦСИО также может работать совместно с УЦСИО. Оконечное оборудование УЦСИО ТЕ1, соответствующее Рек. I.430 [3] (базовый доступ), может подсоединяться через стандартный интерфейс к эталонной точке S (рис. 5) [4].
К широкополосному сетевому окончанию 2-го типа может подключаться большое количество и широкополосного, и узкополосного оконечного оборудования пользователей со стандартными интерфейсами В-ТЕ1 и ТЕ1 в эталонных точках SB и S.

Рис. 5. Конфигурация с интерфейсом 64 кбит/с и широкополосным интерфейсом

Завершая краткое описание эталонных конфигураций ШЦСИО на участке пользователь-сеть, обратимся к нижней части рис. 1, где показаны функциональные группы В-ТА, ТЕ2, В-ТЕ2 и эталонная точка R между ними. В отличие от точек S, SВ и ТВ, где могут использоваться только стандартные интерфейсы, определенные Рек. I.432 [5], в эталонной точке R могут использоваться любые интерфейсы, не относящиеся к ЦСИО. Это было сделано для обеспечения доступа в сеть АТМ пользователей нестандартного оконечного оборудования [4,6].
Обычные оконечные устройства ТЕ2 могут подключаться к ШЦСИО через широкополосные согласующие устройства (В-ТА - Broadband Terminal Adapter). Это облегчает подключение пользователя к ШЦСИО на первом этапе и в экономическом, и в организационном отношении. В-ТА обычно подключаются к стыку в эталонной точке SB. Однако одно или несколько согласующих устройств могут объединяться с широкополосным устройством сетевого окончания 2-го типа B-NT2, образуя одно устройство, которое может подключаться к стыку к контрольной точке SB (рис. 6).

Рис. 6. Объединение широкополосных терминальных адаптеров В-ТА с широкополосным устройством сетевого окончания 2-го типа B-NT2

Обеспечение устройством B-NT2 некоторого количества оконечного оборудования (рис. 5) нельзя связывать с определенной топологией. Возможны физические конфигурации типа звезда, шина, кольцо и даже их комбинации, как, например, звездная шина (рис. 7).

Рис. 7. Возможные топологии физической реализации доступа в ШЦСИО

Из рис. 7 можно сделать вывод, что стандарты допускают множество способов реализации доступа пользователей в сеть АТМ, но в Рек. I.413 [2] принято два существенных ограничения:
- на устройство сетевого окончания B-NT1 в эталонной точке SВ допускается только один интерфейс;
- на физическом уровне интерфейсы поддерживают соединения типа "точка-точка", т.е. для одного источника (передатчика) имеется только один стык (приемник).
Это означает на практике, что использование конфигурации типа пассивной шины не рекомендуется.

Эталонная конфигурация ШЦСИО:
рекомендации СС МСЭ и спецификации Форума АТМ

На рис. 8 приведены два варианта эталонной конфигурации ШЦСИО на технологии АТМ. На рисунке 8,а представлена эталонная конфигурация в виде функциональных групп и эталонных точек согласно Рек. СС МСЭ [1,2]. На рисунке 8,б - согласно эталонной конфигурации, принятой Американским национальным институтом стандартизации (ANSI) [7,8], где под оконечной системой (ES - End System) понимается оборудование пользователя, в том числе локальная или городская вычислительная сеть АТМ, а также ЛВС типа Ethernet, Token Ring, FDDI или УПАТС, а под промежуточной системой (IS - Intermediate System) - коммутаторы доступа или транзитные коммутаторы АТМ.

Рис. 8. Эталонная конфигурация ШЦСИО:
а) - согласно СС МСЭ б) - согласно ANSI

Сети АТМ (рис. 8) подразделяются на сети АТМ общего пользования (Public Network) и частные (корпоративные) сети (Private Network).
B-NT1 служит только для завершения линий передачи и выполнения соответствующих функций эксплуатации и технического обслуживания, а B-NT2 могут быть, например, локальной или городской вычислительной сетью или устройством, выполняющим функции мультиплексирования и концентрации ячеек.
В настоящее время принято делить современные сети связи [9] на транспортную сеть (сеть коммутации), выполняющую функции переноса информации, и сеть доступа (абонентскую сеть), обеспечивающую пользователю доступ к услугам по переносу информации. Сеть доступа (CN - Customer Network, CPN - Customer Premises Network, SPN - Subscriber Premises Network) расположена на пользовательской стороне сетевого окончания B-NT1. Интерфейс между абонентской и транспортной сетями обычно расположен в точке ТВ .
Интерфейс пользователь-сеть (UNI - User-Network Interface) может быть стыком в частной сети, совпадающим с эталонной точкой SB , или стыком в сети общего пользования, совпадающим с эталонными точками ТВ или UB (рис. 8).
Сетевой интерфейс (NNI - Network Node Interface) определяется как стандартный стык между сетями или узлами сети. Форум АТМ использует этот термин для обозначения стыка между узлами частной (корпоративной) сети.


СТРУКТУРА И ПРОТОКОЛЫ АТМ

Эталонная модель протоколов

Общие положения

Разбиение на уровни или уровневая архитектура является центральной идеей создания современных информационных и телекоммуникационных систем. Международная организация по стандартизации (МОС) разработала эталонную модель взаимосвязи открытых систем (ВОС), определяющую функции и уровневую организацию набора протоколов, для совместной работы оборудования различных фирм. Эталонная модель ВОС предусматривает 7-уровневую архитектуру, на основе которой разрабатываются конкретные протоколы. Выбор семи уровней был продиктован следующими соображениями инженерного компромисса [10, 11]:
- необходимо иметь достаточно уровней, чтобы каждый из них не был слишком сложным с точки зрения разработки подробных протоколов с правильными и выполнимыми спецификациями;
- желательно иметь не слишком много уровней, чтобы их интеграция и описание не стали слишком сложными;- выбор естественных границ необходимо выполнить таким образом, чтобы родственные функции были собраны на одном уровне, а различающиеся функции были разнесены по разным уровням.
Связь между объектами одного уровня (рис. 9) осуществляется с помощью протокола, под которым понимается набор семантических и синтаксических правил [4,12].
На каждом уровне может быть один или более протоколов. Под протоколом понимается набор семантических и синтаксических правил, определяющих поведение объектов N-го уровня при передаче информации. Протоколы N-го и (N+1)-го уровней показаны на рис. 9 горизонтальными штриховыми линиями.
Объект (N+1)-го уровня по отношению к объекту уровня N является пользователем услуг, а объект N-го уровня по отношению к объекту уровня (N+1) - поставщиком услуг, оказываемых через точку доступа к услугам (SAP - Service Access Point).

Рис. 9 Взаимосвязь элементов уровневой модели ВОС

Объект уровня (N+1) связывается с соседним объектом уровня (N+1) с помощью услуг, предоставляемых нижними уровнями через точку доступа к услугам с помощью примитивов.

Эталонная модель протоколов ШЦСИО

Эталонная модель протоколов УЦСИО определена Рек. I.320 [13]. Модель протоколов ШЦСИО является расширением модели, описанной в данной рекомендации, и полностью соответствует принципам, положенным в основу разработки эталонной модели протоколов ВОС.
Общий вид эталонной модели протоколов ШЦСИО на технологии АТМ представлен на рис. 10.
Модель включает в свой состав плоскость пользователя, плоскость управления и плоскость менеджмента.
Плоскость пользователя (U-plane) обеспечивает перенос всех видов информации в совокупности с соответствующими механизмами защиты от ошибок, контроля и управления потоком, ограничения нагрузки и т.п. Плоскость пользователя имеет уровневую структуру.
Плоскость управления (C-plane) определяет протоколы установления, контроля и разъединения соединений. Ей принадлежат все функции сигнализации, кроме протоколов метасигнализации. Плоскость управления также имеет уровневую структуру.

Рис. 10.Эталонная модель протоколов В ШЦСИО

Плоскость менеджмента (M-plane) обеспечивает: менеджмент (управление) плоскостями и уровнями Функции управления плоскостями

Рис. 11. Уровни и подуровни ШЦСИО и уровни ВОС

обеспечивают координацию всех "граней" модели протоколов и относятся ко всей ШЦСИО, связывая ее в единое целое. Область управления плоскостями не имеет уровневой структуры.

Функции управления уровнями решают задачи распределения сетевых ресурсов, согласования их с параметрами трафика, обработки информации эксплуатации, технического обслуживания и управления сетью. Процедуры метасигнализации также относятся к функциям управления уровнями. Управление уровнями имеет уровневую структуру

Таблица 1
Уровень | Подуровень | Основные функции
Адаптации АТМ | Конвергенции | Конвергенция к службе
 | Сегментации и сборки | Сегментация и сборка
АТМ |  | Общее управление потоком Генерация/удаление заголовка ячейки Преобразование идентификаторов ВП и ВК Мультиплексирование /демультиплексирование ячеек
Физический | Конвергенции с системой передачи | Согласование скорости ячеек Формирование поля контроля ошибок/обнаружение и исправление ошибок Адаптация потока ячеек к кадру системы передачи /выделение ячеек Генерация кадра системы передачи /восстановление кадра
 | Зависящий от физической среды | Синхронизация Передача двоичного сигнала в данной среде

Функции уровней эталонной модели протоколов ШЦСИО определены Рек. I.321 и I.413 [14,2]. В настоящее время детально определены функции только первых трех уровней модели: физического, уровня АТМ, где происходит структурирование ячеек, и уровня адаптации АТМ, который поддерживает услуги более высокого уровня, например, эмуляцию каналов, высокоскоростную передачу данных без установления соединения и т.п.
На рис. 11 показано соотношение уровневой структуры ШЦСИО и уровневой структуры эталонной модели ВОС, а также деление уровней ШЦСИО на подуровни, о чем будет сказано ниже.
Основные функции уровней и их деление на подуровни приведены в табл.1.

Функции физического уровня

Физический уровень (PHY) является самым нижним уровнем протокольного стека АТМ, который определяет интерфейс между уровнем АТМ и физической средой.Физический уровень делится на:
- подуровень, зависящий от физической среды (PMD- Physical Medium Dependent);- подуровень конвергенции с системой передачи (TC - Transmission Convergence Sublayer).
Подуровень, зависящий от физической среды, определяет скорость передачи битового потока через данную физическую среду, обеспечивает синхронизацию между передачей и приемом. На этом уровне осуществляется линейное кодирование и, если необходимо, электрооптическое и оптоэлектронное преобразование сигналов. В качестве физической среды, используемой для распространения сигнала, чаще всего используется одномодовое или многомодовое оптоволокно. Возможно использование коаксиального кабеля, экранированной или неэкранированной медной пары, радиоканала высокого качества.
Подуровень конвергенции с системой передачи определяет порядок передачи пакетов АТМ (ячеек) в битовом потоке и выполняет следующие функции:
- генерацию кадра системы передачи и его восстановление на приеме;
- адаптацию потока ячеек к кадру передачи на передающей стороне и выделение ячеек из кадра на приемной стороне;
- формирование поля контроля ошибок в заголовке на передающей стороне и обнаружение и исправление одиночных ошибок, если это возможно, на приемной стороне;
- согласование скоростей ячеек.
В качестве цифровых систем передачи могут использоваться системы передачи синхронной или плезиохронной цифровой иерархии с собственной структурой кадра. Поэтому требуется специальный механизм упаковки ячеек в поле полезной нагрузки кадра систем передачи СЦИ или ПЦИ. Кроме того, в интерфейсе пользователь-сеть СС МСЭ предложена специальная ячеечная структура, в которой кадр эквивалентен ячейке.
Выделение ячеек - механизм (Рек. I.432 [5] ), позволяющий на приемном конце восстановить границы ячейки. Для защиты механизма выделения ячеек информационное поле ячейки перед передачей скремблируется.
На передающей стороне осуществляется формирование последовательности контроля ошибок в заголовке (HEC - Header Error Control), которая помещается в соответствующее поле заголовка ячейки. На стороне приема значение последовательности контроля ошибок в заголовке пересчитывается и сравнивается с поступившей. В случае несовпадения ошибка, если это возможно, исправляется или ячейка стирается.
Согласование скорости ячеек заключается в том, что если со стороны уровня АТМ поток ячеек меньше пропускной способности системы передачи, то подуровень конвергенции физического уровня на передающей стороне добавляют "пустые" ячейки, которые не содержат информации, а на стороне приема отбрасывает их.
В Рек. I.321 выполнение этой функции возложено на подуровень конвергенции физического уровня с помощью пустых ячеек (Idle Cells), а Форум АТМ решает задачу согласования скорости на уровне АТМ и использует для этого неназначенные ячейки (Unassigned Cells). Это говорит о потенциальной возможности несовместимости двух систем на физическом уровне, использующих различные типы ячеек для согласования скорости.

Функции уровня АТМ

За физическим уровнем следует уровень АТМ. Его характеристики не зависят ни от физической среды передачи, ни от вида передаваемой информации.
На уровне АТМ реализуются следующие основные функции [15] :
- мультиплексирование/демультиплексирование ячеек;
- преобразование идентификаторов виртуальных путей и виртуальных каналов;
- генерация/ удаление заголовка ячейки;
- общее управление потоком в интерфейсе пользователь-сеть.
На передающей стороне реализуется механизм мультиплексирования ячеек, поступающих от различных источников, в единый поток пакетов АТМ. На приемной стороне механизм демультиплексирования разбивает поступающий поток на потоки, соответствующие идентификаторам виртуальных путей и виртуальных каналов. В коммутаторах АТМ в общем случае происходит замена входящих идентификаторов виртуальных путей и виртуальных каналов на исходящие. В коммутаторах виртуальных путей происходит преобразование только идентификаторов виртуальных путей.
Функция генерации/удаления заголовка ячеек осуществляется только в концевых точках АТМ уровня. На передающей стороне к 48-октетному полю полезной нагрузки, поступающему с уровня адаптации АТМ, добавляются 5 октет заголовка, образуя ячейку с незаполненным полем контроля ошибок в заголовке. Заполнение поля контроля ошибок заголовка является функцией физического уровня. На противоположной стороне механизм выделения заголовка удаляет его из ячейки, оставляя 48-октетное поле полезной нагрузки, которое передается на уровень адаптации АТМ. Общее управление потоком осуществляется только в интерфейсе пользователь-сеть для контроля нагрузки в сети доступа и защиты от перегрузок.

Функции уровня адаптации АТМ

Уровень адаптации АТМ находится между уровнем АТМ и более высокими уровнями, его основной функцией является адаптация уровня АТМ к потребностям высших уровней. Он состоит из двух подуровня:
- сегментации и сборки (SAR - Segmentation and Reassembly), основной задачей которого является сегментация на передающей стороне протокольных блоков данных на сегменты, пригодные для записи в информационное поле ячейки (48 октетов) и восстановление на стороне приема принимаемых блоков данных из информационных полей ячеек уровня АТМ;
- конвергенции (Convergence Sublayer), который зависит от службы и предоставляет высшим уровням услуги уровня адаптации и сборки через точки доступа к услугам.
Функции уровня адаптации АТМ определены в Рек. I.362 [16].
Информационные блоки, поступающие от каждой службы могут быть разными, иметь специфическую структуру и предъявлять различные требования к их переносу в сети АТМ.
В целях минимизации количества протоколов на уровне адаптации АТМ в Рек. I.362 предложено проводить классификацию служб по трем основным признакам:
- временной зависимости между источником и получателем (существует или нет);- скорости передачи источника (источники с постоянной скоростью передачи или источники с изменяющейся скоростью передачи);- режиму установления соединения (с установлением соединения или без установления соединения).
Теоретически возможно получение 8 комбинаций, но СС МСЭ пока определены 4 класса служб (рис. 12).

Характеристика | Классы
 | A | B | C | D
Временная зависимость между источником и получателем | Существует |  | Не существует
Скорость передачи | Постоянная | Изменяющаяся
Режим соединения | Ориентирована на соединение |  |  | Не ориентирована

Рис. 12. Классификация служб.

В классе А между источником и получателем существует жесткая временная зависимость. Скорость передачи источника постоянная. Служба ориентирована на соединение. Типичным примером является передача речи с постоянной скоростью (64 кбит/с) или транспортирование по сети АТМ цифровых каналов Т1/Е1. Предоставление такой услуги в сетях АТМ называется эмуляцией канала. Другим примером может служить передача видео с постоянной скоростью.
В классе В также необходимо обеспечивать требуемые характеристики по времени и джиттеру доставки для служб, которые ориентированы на соединение. Отличие класса В от класса А в том, что источниками трафика являются источники с изменяющейся скоростью передачи. Типичными примерами являются передача подвижных изображений и звука.
В классе С не требуется выдерживать постоянными временные характеристики по доставке пакетов. Службы ориентированы на соединения, а источники являются источниками с изменяющейся скоростью передачи. Примером может служить передача данных с установлением соединения и сигнализация.
Класс D отличается от класса С только тем, что класс D включает службы, которые не ориентированы на установление соединения. Класс D предназначен для передачи данных без установления соединения.


ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ

Размещение ячеек АТМ
в кадрах систем синхронной цифровой иерархии

В Рек. I.311 определено, что синхронная цифровая иерархия (SDH - Synchronous Digital Hierarchy) является основой физического уровня ШЦСИО на технологии АТМ как на сетевом уровне, так и в сети доступа интерфейса пользователь-сеть.
Физический уровень с точки зрения систем передачи принято делить на слои регенераторной секции, усилительного участка, цифрового тракта связи. Для систем СЦИ эти понятия совпадают со слоями регенераторной и мультиплексорной секций и цифрового тракта (пути передачи).
Цифровые сети, построенные на аппаратуре СЦИ, позволяют [20,21,22,23]:
- обеспечивать высокую эффективность использования пропускной способности цифровых трактов;- осуществлять постоянный контроль качества функционирования цифровых регенераторных и мультиплексорных секций, а также всего тракта связи;- производить реконфигурацию сети в случае аварии (сети СЦИ иногда называют самовосстананавливающимися);- обеспечивать совместимость линейного и оконечного оборудования, выпускаемого различными производителями;- применять единые стандартизованные процедуры технического обслуживания цифровых трактов связи при их эксплуатации.
Основные идеи СЦИ стандартизованы СС МСЭ в Рек. G.707, G.708 и G.709 [24,25,26]. Обзор основных свойств и принципов построения СЦИ выполнен в [20,21,22].
Основной идеей СЦИ является объединение сигналов в блоки, называемые синхронными транспортными модулями (STM - Synchronous Transport Module), которые имеют кадровую структуру. Кадры передаются синхронно с четкой периодичностью 125 мкс. Кроме информации пользователя, синхронные транспортные модули (СТМ) содержат специальную служебную информацию. Скорость передачи основного модуля СТМ-1 равна 155,520 Мбит/с, а для модулей высших порядков СТМ-N - в N раз выше.
Синхронный транспортный модуль СТМ - 1 (рис. 13), кроме информационной нагрузки, несет служебную (избыточную) нагрузку (OH - Over Head), обеспечивающую выполнение функций контроля, эксплуатации и технического обслуживания, а также других служебных функций. Служебная нагрузка слоя секций называется секционной служебной нагрузкой (SOH - Section OH). Слой секций делится на слой регенераторных секций и слой мультиплексорных секций. В связи с этим секционная служебная нагрузка (SOH) делится на служебную нагрузку регенераторной (RSOH) и мультиплексорной (MSOH) секций.

Рис. 13. Использование СТМ-1 для переноса ячеек АТМ

Служебная нагрузка мультиплексорной секции выполняет функции цикловой синхронизации, контроля ошибок, обеспечивает создание каналов передачи данных и служебной связи.
Служебная нагрузка мультиплексорной секции выполняет функции контроля ошибок, обеспечивает создание каналов передачи данных и служебной связи, а также каналов управления автоматического включения резервных элементов и реконфигурации.
Служебная нагрузка регенеративной секции передается между регенераторами, а служебная нагрузка мультиплексорной секции - между пунктами, в которых формируются и расформировываются синхронные транспортные модули.
Административный блок (AU - Administrative Unit) содержит информационную нагрузку в виде виртуального контейнера и ее указатель (AU Pointer ).
При использовании СТМ-1 для транспортирования ячеек поток ячеек АТМ размещается в контейнере 4-го порядка (C - Container). Таким образом, в СТМ-1 для переноса ячеек выделяется пропускная способность, равная

Размер контейнера в байтах (9x260=2340) не кратен размеру ячейки в байтах (53). Объем контейнера заполняется полностью, и поэтому ячейка может пересекать границу контейнера. Но байт-ориентированная структура контейнера и ячейки должны совпадать. Затем к контейнеру 4-го порядка добавляется служебная нагрузка тракта (POН - Path OH) и образуется виртуальный контейнер (VC - Virtual Container).Затем виртуальный контейнер 4-го порядка (VC-4) записывается в синхронный транспортный модуль. В принципе 1-й байт виртуального контейнера может находиться в любом месте СТМ-1, исключая, первые девять колонок. Административный указатель используется для того, чтобы найти первый байт виртуального контейнера 4-го порядка.В Рек. СС МСЭ G.708 приведен способ построения СТМ-4 из 4 синхронных транспортных модулей СТМ-1. Структура кадра 622,080 Мбит/с, составленная из 4 сцепленных виртуальных контейнеров 4-го порядка, представлена на рис. 14.

Рис. 14. Использование СТМ-4 для переноса ячеек АТМ

Однако, полезная нагрузка СТМ-4 может быть структурирована различными способами, например, из 4 виртуальных контейнеров 4-го порядка (рис. 14) или как единый блок.
В первом случае пропускная способность СТМ-4 будет равна

4x149,760 = 599,040 Мбит/с.

Во втором случае пропускная способность будет несколько выше за счет того, что в едином блоке необходима только одна колонка для служебной нагрузки тракта, и, таким образом, выигрыш в пропускной способности будет составлять

Но пока СС МСЭ рекомендовал 1-й способ, а 3 колонки служебной нагрузки тракта заполняются октетами стаффинга, как показано на рис. 14.


ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ

Интерфейс на основе ячеек

Сектором стандартизации МСЭ на интерфейсе пользователь-сеть рекомендован еще один тип интерфейса со скоростями 155,520 Мбит/с и 622,080 Мбит/с, являющийся непрерывным потоком ячеек, каждая из которых содержит 53 октета. Структура системы передачи ячеечного типа приведена на рис. 15.

Рис. 15. Структура системы передачи ячеечного типа

Максимальное расстояние между смежными ячейками физического уровня составляет 26 ячеек уровня АТМ. После 26-ти ячеек уровня АТМ обязательно вставляется ячейка физического уровня, несущая служебную информацию эксплуатации и технического обслуживания аналогичную информации, которая переносится в СЦИ секционной служебной нагрузкой (SOH) и служебной нагрузкой тракта (РОН).
Отношение 26:27 эквивалентно отношению 149,760 Мбит/с к 155,520 Мбит/с или 599,040 Мбит/с к 622,080 Мбит/с. Таким образом, система передачи на основе ячеек имеют такую же пропускную способность для транспортирования ячеек, как и СТМ-1 и СТМ-4 СЦИ соответственно.
Если поток ячеек уровня АТМ недостаточен, для согласования скоростей вставляются пустые ячейки.
Ячейки эксплуатации и технического обслуживания (ЭТО) физического уровня должны отличаться от ячеек АТМ, что выполняется за счет присвоения ячейкам ЭТО физического уровня уникальных заголовков, приведенные в табл. 2.
Таблица 2
Тип ячейки | 1-й октет | 2-й октет | 3-й октет | 4-й октет | 5-й октет
F 1 | 00000000 | 00000000 | 00000000 | 00000011 | Поле заполняется значениями КОЗ
F 3 | 00000000 | 00000000 | 00000000 | 00001001 | Поле заполняется значениями КОЗ

Ячейки F1 соответствуют слою регенераторных секций. Слои мультиплексных секций и тракта в системах передачи, основанных на ячейках, объединены. Их общие функции выполняют ячейки F3.


ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ

Формирование поля контроля ошибок в заголовке,
обнаружение и исправление ошибок

Существенное улучшение семантической прозрачности сети АТМ может быть достигнуто при условии защиты заголовка ячейки АТМ от ошибок. Наиболее подходящим является адаптивный механизм, обеспечивающий коррекцию одиночных ошибок и обнаружение множественных.

Для защиты заголовка наиболее целесообразным является кодирование, основанное на обобщении кодов Хемминга, получивших название кодов БЧХ (BCH - Bose-Chadhuri-Hocquenghem). Это циклические коды с большим выбором длины и широким спектром возможностей исправления ошибок при ограниченном количестве набора значений n, k, t (табл. 3).
Таблица 3
Общее количество бит n | Полезные биты k | Количество исправляемых бит t | Число проверочных бит m
31 | 26 21 16 | 1 2 3 | 1 10 15
63 | 57 51 45 | 1 2 3 | 6 12 18
127 | 120 113 106 | 1 2 3 | 7 14 21

Из табл. 3 видно, что в кодовом слове из n бит, благодаря наличию m=(n-k) избыточных бит, может быть исправлено t бит. Например, для исправления одиночной битовой ошибки в заголовке из 26 бит потребуется 5 избыточных бит, и общая длина заголовка составит 31 бит. Таким образом, используя значения n, k и m, приведенные в таблице 3, возможно исправить не более t ошибочных бит. Но при увеличении числа проверочных бит с 5 до 8, с соответствующим уменьшением количества полезных бит с 26 до 23-х, количество исправляемых бит останется тем же (t=1), но появится возможность обнаружения множественных ошибок (табл. 3).
В табл. 4 показан процент множественных ошибок, который может быть обнаружен при условии исправления одиночной ошибки t=1 в зависимости от k и m [12].
Из табл. 4 видно, что для k = 32, 40 и 48 бит достаточно 6 проверочных бит для того, чтобы можно было исправить один ошибочный бит в заголовке.
Таблица 4
Число защищаемых бит, k | Число проверочных бит m, %
 | 6 | 7 | 8
32 40 48 | 48% 36% 23% | 74% 68% 62% | 89% 84% 81%

В ячейке АТМ заголовок составляет 5 октетов. Под поле контроля ошибок отведено 8 бит. Следовательно, этого вполне достаточно, чтобы исправлять одиночные ошибки и обнаруживать до 89 % множественных ошибок.
Суть протокола формирования поля контроля ошибок в заголовке заключается в том, что каждый передатчик ячеек АТМ подсчитывает значение поля контроля ошибок в заголовке для первых 4 октетов заголовка и заносит результат в 5-й октет (поле контроля ошибок в заголовке).
Значение поля контроля ошибок определяется как остаток от деления по модулю 2 произведения полинома х8 на содержимое заголовка ячейки (без поля контроля ошибок в заголовке) на производящий полином х8+х2+х+1. Оборудование передатчика подсчитывает этот остаток и прибавляет к нему по модулю 2 фиксированную комбинацию 01010101. Эта сумма и заносится в поле контроля ошибок заголовка.
Поле контроля ошибок в заголовке дает возможность :
- обнаружения и исправления (корректировки) в заголовке ячейки однобитовых ошибок;
- обнаружения до 89% многобитовых ошибок и отбрасывания (стирания) таких ячеек.
Обе эти возможности реализуются оборудованием приема ячеек АТМ с помощью адаптивного механизма, диаграмма состояний которого приведена на рис. 18.

Рис. 18. Диаграмма состояний адаптивного алгоритма

После запуска приемник находится в режиме коррекции. Если обнаружена однобитовая ошибка, то она исправляется. Если обнаружена многобитовая ошибка, то ячейка стирается. В обоих случаях приемник переключается в режим детектирования. В этом состоянии приемника каждая ячейка с обнаруженной одиночной или множественной ошибкой в заголовке стирается. Если ошибок в заголовке не обнаружено, то механизм переходит в состояние коррекции. Следует отметить, что режим работы механизма обнаружения и исправленная ошибок в заголовке ячеек выбран с учетом характеристик ошибок цифровых систем передачи на оптоволокне, которые характеризуются смесью однобитовых ошибок с относительно длинными пачками ошибок, поражающими не только адресную часть, но и поле полезной нагрузки ячеек.
Описанный адаптивный алгоритм гарантирует исправление однобитовых ошибок и малую вероятность доставки ячеек с ошибочными заголовками, пораженными пачкой ошибок.


ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ

Разграничение ячеек

В любой системе с коммутацией пакетов приемный узел должен определять границы пакетов. В протоколе HDLC (High Level Data Link Control), где приняты пакеты переменной длины, их разграничение выполняется с помощью уникальной двоичной последовательности 01111110, которую принято называть флагом. Эта последовательность не должна встречаться в информационном поле пакета. Для гарантии прозрачности данных их подвергают специальной процедуре - вставке бит (Bit Stuffing), исключающей наличие флаговой комбинации внутри пакета.

Рис. 19. Диаграмма реализации процедуры разграничения ячеек.

В сетях АТМ может применяться аналогичный механизм, но его использование на высоких скоростях не является оптимальным.
Рассмотрим три варианта разграничения пакетов АТМ, основанные на:
- использовании пустых ячеек;
- организации регулярной кадровой структуры;
- проверке поля контроля ошибок в заголовке ячейки.
Каждый из этих вариантов может быть описан с помощью диаграммы, приведенной на рис. 19 и имеющий три состояния: "ПОИСК", "ПРЕДСИНХРО" и "СИНХРО".
В состоянии "ПОИСК" система посредством некоторого механизма бит за битом ищет признаки границы ячейки. Если принята последовательность бит, соответствующая признакам, то состояние системы изменяется на "ПРЕДСИНХРО", в котором положение границы проверяется ячейка за ячейкой. Если обнаружены n границ ячеек, следующих одна за другой, то система переходит в состояние "СИНХРО".
Система будет полагать, что произошел срыв синхронизации только тогда, когда обнаружено m следующих один за другим случаев потерь границ ячеек. Параметры n и m определяют скорость, с которой система входит в синхронизм, и обнаруживает потерю синхронизма.
Рассмотрим 3 возможных варианта решения задачи разграничения ячеек.

Разграничение с помощью пустых ячеек

Пустые ячейки, которые вставляются для согласования скоростей цифрового тракта, характеризуются особым значением заголовка. В состоянии "ПОИСК" это значение ищется бит за битом во входящем битовом потоке. В состоянии "ПРЕДСИНХРО" это особое значение заголовка проверяется ячейка за ячейкой для подтверждения правильности выделения границы ячейки. Для этого можно использовать заданное количество правильно определенных границ пустых ячеек. Однако, пустые ячейки в тракте определяются только тогда, когда нет полезной информации, поэтому может пройти достаточно большое время до появления следующей пустой ячейки, а доверительный интервал, в течение которого принимается решение о вхождении в синхронизм, может быть достаточно большим. То же самое происходит и в состоянии "СИНХРО". Перед принятием решения о срыве синхронизации также может пройти достаточно большое время, так как при большой нагрузке в тракте пустые ячейки появляются редко. Кроме того, необходимо принимать во внимание, что механизм разграничения может идентифицировать заголовки ячейки, несущей полезную информацию, как искаженный заголовок пустой ячейки.

Разграничение ячеек за счет периодичности вставляемых ячеек

Для того чтобы избежать ошибочной идентификации заголовков ячеек, можно использовать механизм проверки заголовков периодически вставленных пустых ячеек. Данный механизм имеет много общего с первым вариантом и является, по существу, частным случаем разграничения с помощью пустых ячеек, в котором пустые ячейки вставляются через равные промежутки времени. Это гарантирует, что ячейка, пришедшая через интервал Т после пустой ячейки, должна быть пустой.
Система в состоянии "ПОИСК" осуществляет обнаружение заголовков периодических пустых ячеек. При обнаружении заголовка вставленной ячейки система переходит в состояние "ПРЕДСИНХРО" и ожидает аналогичного заголовка через период Т. Для достижения состояния "СИНХРО" необходимо n подтверждений, следующих друг за другом.
При таком варианте исключается возможность со стороны пользователей преднамеренной вставки значений заголовка в информационное поле, так как в данном случае сам передатчик через равные промежутки времени Т осуществляет вставку особых ячеек. Выбор периода Т определяется на основе компромисса между эффективностью передачи и требуемым временем синхронизации. Действительно, вставка пустых ячеек уменьшает пропускную способность цифрового тракта, так как вводятся пустые ячейки. С другой стороны, чем меньше период Т, тем быстрее система входит в синхронизм.

Разграничение ячеек
за счет использования поля проверки ошибок в заголовке

Данный способ разграничения ячеек использует корреляцию между битами заголовка и соответствующими контрольными битами, записанными в поле контроля ошибок в заголовке механизмом обнаружения и исправления ошибок.
В состоянии "ПОИСК" процесс разграничения выполняется путем проверки (бит за битом, байт за байтом) совпадения контрольных бит с передаваемыми данными путем их деления на порождающий полином. Если остаток (контрольные биты) не соответствуют передаваемой двоичной последовательности заголовка, то процесс проверки повторяется со сдвигом на один бит в битовом потоке. По одному совпадению система переходит в состояние "ПРЕДСИНХРО". После получения n подтверждений о соответствии остатка (синдрома) с принятой двоичной последовательностью заголовка, система переходит в состояние "СИНХРО".
Из состояния "СИНХРО" система может перейти в состояние "ПОИСК" в случае, если m раз подряд остаток (синдром) не соответствует принятой последовательности.
Намеренная или случайная имитация в информационном поле контрольных бит может привести к неправильной синхронизации или увеличению времени вхождения в синхронизм. Для устранения этого явления производится операция скремблирования, гарантирующая псевдослучайную последовательность бит информационного поля так, что вероятность появления синдрома в информационном поле ничтожно мала. Этот метод разграничения ячеек оказался самым эффективным и Рек. I.432 [5] принят для реализации.
Ясно, что значения n и m влияют на характеристики процесса разграничения ячеек.
Предложены следующие значения n и m в зависимости от систем передачи:
- n=6, m=7 для систем передачи СЦИ;
- n=8, m=7 для систем передачи на основе ячеек.
Для систем передачи СЦИ содержимое информационного поля должно скремблироваться с помощью самосинхронизирующегося скремблера с полиномом х43+1. Данный скремблер должен функционировать только при нахождении механизма разграничения в состояниях "ПРЕДСИНХРО" и "СИНХРО" и выполняться в состоянии "ПОИСК".
Для интерфейсов на основе ячейки в Рек. I.432 был определен распределенный скремблер с полиномом 31-го порядка.
Расчеты показывают, что для СЦИ СТМ-1 (155,520 Мбит/с) даже при вероятности ошибки на бит РBER=10-4 механизм разграничения ячеек будет находится в состоянии "СИНХРО" в среднем около одного года, а после потери синхронизации потребуется 28 мкс, чтобы снова войти в состояние "СИНХРО".

Согласование скоростей ячеек

Если на передающей стороне возникает пауза, то есть отсутствуют назначенные ячейки пользователя, неназначенные ячейки уровня АТМ и ячейки ОАМ физического уровня, то для адаптации потока ячеек к двоичной скорости передачи вставляются пустые ячейки. На приемной стороне пустые ячейки отбрасываются. Вставка и отбрасывание пустых ячеек выполняют функцию согласования скорости ячеек.
Пустая ячейка идентифицируется с помощью стандартизованной двоичной комбинации в ее заголовке, приведенной в табл. 5.
Таблица 5.
1-й октет | 2-й октет | 3-й октет | 4-й октет | 5-й октет
00000000 | 00000000 | 00000000 | 00000000 | Действительное значение поля КОЗ

Эта комбинация используется для всей сети АТМ. Каждый октет информационного поля пустой ячейки заполняется комбинацией 01101010.


УРОВЕНЬ АТМ

Виртуальные каналы и виртуальные пути

На уровне АТМ имеются два иерархических слоя, основной задачей которых является перенос ячеек АТМ [32]:
- виртуальные каналы;
- виртуальные пути.
Понятие виртуальный канал (ВК) используется для описания однонаправленной передачи ячеек, имеющих общий идентификатор виртуального канала, а понятие виртуальный путь (ВП) используется для описания однонаправленной передачи ячеек, принадлежащих различным виртуальным каналам, но имеющих общий идентификатор виртуального пути.
Соотношение между понятиями виртуальный канал, виртуальный путь и путь передачи показано на рис. 22.

Рис. 22. Соотношения между путем передачи, виртуальными путями
и виртуальными каналами

Путь передачи может содержать несколько виртуальных путей, а каждый виртуальный путь может содержать несколько виртуальных каналов.
При рассмотрении слоев виртуальных каналов и виртуальных путей уровня АТМ важно определить следующие понятия: звено виртуального канала или виртуального пути и соединение виртуальных каналовили виртуальных путей.
Понятие звено виртуального канала (Virtual Channel Link) используется как часть соединения виртуальных каналов, которая заключается между точкой, в которой ячейкам присваивается данное значение идентификатора виртуального канала, и точкой, в которой идентификатор виртуального канала транслируется или заменяется.
Аналогично звено виртуального пути (Virtual Path Link) определяется точками, где идентификаторы виртуальных путей назначаются, транслируются или меняются.
Последовательность звеньев виртуального канала называется соединением (цепью) виртуальных каналов (VCC - Virtual Channel Connection), а последовательность звеньев виртуального пути принято называть соединением (цепью) виртуальных путей (VPC - Virtual Path Connection).
Соотношения между различными слоями уровня АТМ приведены на рис.23.

Рис. 23. Соотношения между слоями уровня АТМ

ШЦСИО на технологии АТМ ориентирована на соединения, поэтому каждое соединение будет характеризоваться своим ИВК. При освобождении соединения значение ИВК может быть присвоено другому соединению. Преимуществом такого принципа назначения ИВК является использование различных значений ИВК для обеспечения служб типа мультимедиа. Это позволяет добавлять или отнимать виртуальные каналы во время соединения пользователя. Так, например, служба видеотелефонии может начинаться только с речи (один ВК), а видео может быть добавлено или устранено по отдельному ВК. Сигнализация также будет осуществляться по отдельному ВК.
Идентификаторы виртуальных каналов и виртуальных путей в общем случае имеют смысл только для одного звена. В соединениях ВК и ВП значения ИВК и ИВП изменяются в устройствах, осуществляющих коммутацию ВК и ВП.
В сетях АТМ нет необходимости делать разницу между кроссконнектором и коммутатором, т.е. можно использовать один термин "коммутатор" (Switch), но можно делать разницу между коммутатором виртуальных путей и коммутатором виртуальных каналов. В коммутаторе ВП оканчиваются звенья виртуального пути и меняются входящие идентификаторы виртуальных путей на исходящие соответственно направлению соединения ВП, а значения ИВК остаются неизменными (рис. 24).

Рис. 24. Сеть АТМ, построенная на коммутаторах ВП

В будущей ШЦСИО могут поддерживаться и полупостоянные соединения, которые будут переносить большое количество ячеек по одновременно действующим ВК. Эта концепция известна как концепция виртуальных сетей.
Согласно этой концепции в одной сети АТМ общего пользования может одновременно существовать огромное количество виртуальных сетей различных ведомств или корпораций, практически не замечая друг друга. Ресурсы сети общего пользования распределяются между виртуальными сетями динамически, обеспечивая высокую эффективность при достаточной простоте управления.
Между пользователями А и Б установлено соединение ВП, транспортирующее ячейки двух ВК, каждый из которых имеет свой ИВК (ИВК=1,2), который не меняется на узлах, в которых производится только смена входящего ИВП на исходящий ИВП.
Соединение ВП между пользователями В и Г имеет 3 виртуальных канала с идентификаторами виртуальных каналов на каждом звене, равными 2, 3 и 4. Можно отметить, что в звене между пользователями А и В и узлом 1 ИВК=2 используется дважды. Однако это не создает трудностей, так как различные идентификаторы ВП позволяют использовать одинаковые ИВК. Соединение ВП между пользователями Д и Е имеет один виртуальный канал.
В общем случае на пути передачи в интерфейсе пользователь-сеть полю идентификатора ВП отводится 8 бит. Таким образом, в цифровых линиях доступа в сеть может быть организовано одновременно до 28=256 ВП, в каждом из которых может быть до 216=65536 ВК.
В сетевом интерфейсе может быть организовано 212 = 4096 ВП соответственно.В коммутаторах ВК (рис. 25) оканчиваются звенья обоих ВК и, следовательно, звенья ВП. Таким образом, в коммутаторе виртуальных каналов выполняется замена как идентификаторов виртуальных путей, так и виртуальных каналов.

Рис. 25. Коммутатор виртуальных путей и виртуальных каналов

Это позволяет сказать, что коммутатор виртуальных каналов всегда является и коммутатором виртуальных путей.
Соединения ВК и ВП могут устанавливаться между :
- пользователями;
- пользователем и сетью;
- между коммутаторами в сети.
Все ячейки в соединении ВК транспортируются по одному маршруту. Сохраняется последовательность передачи ячеек. Соединения ВК между пользователями могут устанавливаться для переноса информации пользователя или сигнализации. Соединения ВК между пользователем и сетью могут использоваться для доступа в сеть, т.е. выполнять функции переноса информации сигнализации между пользователем и сетью, а соединение ВК между сетевыми узлами использоваться для транспортирования трафика маршрутизации и менеджмента. Соединение ВП между пользователями может создаваться только на время проведения, например, сеанса видеотелефонной связи и содержать соединения ВК для переноса информации пользователей (речи, данных, подвижных изображений) и ВК сигнализации.
Соединения ВП на постоянной или полупостоянной основе между пользователями могут создаваться для организации частных (ведомственных/корпоративных) сетей (например, для организации связи центрального банка с его отделениями или филиалами). Соединения ВП между сетевыми узлами могут организовываться для создания соединений ВК между абонентами этих узлов в интересах обмена информацией маршрутизации и менеджмента.
Соединения ВП между пользователями и сетью могут создаваться для передачи агрегированного трафика локальной вычислительной сети или УПАТС к коммутатору доступа в ШЦСИО.


УРОВЕНЬ АДАПТАЦИИ АТМ

Уровень адаптации АТМ 1-го типа

Уровень адаптации АТМ 1-го типаУровень адаптации АТМ 1-го типа обеспечивает выполнение в интересах верхнего уровня следующего перечня услуг:
- перенос блоков данных служб с постоянной битовой скоростью источника и доставку их получателю с той же скоростью;
- синхронизацию оконечных устройств источника и получателя информации;
- индикацию, если это необходимо, потери или искажения информации, если потеря или искажение информации не восстанавливаются в уровне адаптации;
- перенос между источником и оконечной точкой назначения данных о структуре транспортируемой информации.
Основными функциями, которые выполняет уровень адаптации АТМ 1-го типа в целях обеспечения выполнения вышеперечисленных услуг, являются:
- сегментация и сборка пользовательской информации;
- обработка переменных задержек пакетов АТМ для устранения влияния джиттера;
- обработка потерянных пакетов АТМ и пакетов АТМ, пришедших не по адресу;
- восстановление в приемнике тактовой частоты источника;
- мониторинг битовых ошибок в управляющей информации протокола уровня адаптации АТМ (AAL-PCI, Protocol Control Information);
- обработка битовых ошибок в управляющей информации протокола уровня адаптации АТМ (ААL-PCI);
- отслеживание битовых ошибок в информационном поле пользователя с возможностью их исправления.

Подуровень сегментации и сборки

На передающем конце подуровень сегментации и сборки принимает 47-октетные блоки данных от подуровня конвергенции и добавляет к ним 1 октет заголовка, формируя протокольные блоки данных подуровня сегментации и сборки (SAR-PDU, Protocol Data Unit).
На приемном конце подуровень сегментации и сборки принимает от уровня АТМ 48-октетные блоки и отделяет от них заголовки протокольного блока данных подуровня сегментации и сборки. Полезная нагрузка протокольного блока данных в виде 47-октетного блока поступает в подуровень конвергенции.
Структура 48-октетного протокольного блока данных (информационное поле пакета АТМ) подуровня сегментации и сборки для уровня адаптации первого типа показана на рис. 27.
Индикатор уровня конвергенции (CSI) выставляется подуровнем конвергенции и дает возможность на приемном конце опознать уровень конвергенции, на который должна быть направлена полезная нагрузка протокольного блока данных подуровня сегментации и сборки.
Значение номера последовательности (SN) подуровень сегментации и сборки получает от подуровня конвергенции для каждого 47-октетного блока полезной нагрузки. На приемном конце номер последовательности поступает в равноранговый подуровень конвергенции для обнаружения потери или вставки полезной нагрузки, т.е. сигнализирует о потере пакета АТМ или о прибытии пакета АТМ не по адресу.

рис27
CSI (CS Indication) | - индикатор подуровня конвергенции
SN (Sequence Number) | - номер последовательности
SNP (Sequence Number Protection) | - защита номера последовательности
PDU (Protocol Data Unit) | - протокольный блок данных подуровня сегментации и сборки

Рис. 27. Структура 48-октетного протокольного блока данных
подуровня сегментации и сборки уровня адаптации АТМ 1-го типа

Поле защиты номера последовательности обеспечивает обнаружение и исправление (коррекцию) ошибок в заголовке протокольного блока данных подуровня сегментации и сборки. Для защиты используется 2-ступенчатый метод:Рис. 27. Структура 48-октетного протокольного блока данных подуровня сегментации и сборки уровня адаптации АТМ 1-го типаПоле защиты номера последовательности обеспечивает обнаружение и исправление (коррекцию) ошибок в заголовке протокольного блока данных подуровня сегментации и сборки. Для защиты используется 2-ступенчатый метод:
- поля индикатора подуровня конвергенции и номера последовательности защищаются 3-битовым полем контроля ошибок в заголовке;
- результирующее 7-битовое кодовое слово защищается проверочным битом четности.
В качестве производящего полинома рекомендуется использовать полином G(х)=х3 + х + 1.
Приемник имеет два устойчивых режима:
- исправление, при котором обнаруживаются ошибки и при одиночной ошибке производится ее исправление;
- обнаружение, при котором происходит только обнаружение ошибок.
Структурная схема алгоритма обнаружения и исправления ошибок в заголовке протокольного блока данных подуровня сегментации и сборки протокола уровня адаптации АТМ 1-го типа представлена на рис. 18.
Приемник проверяет контрольные биты и бит четности в заголовке протокольного блока данных. Если в заголовке обнаружена ошибка, то действия предпринимаются в зависимости от того, в каком состоянии находился приемник. При нахождении приемника в состоянии исправления может быть исправлена только одна битовая ошибка, а приемник после исправления перейдет в состояние обнаружения. В режиме обнаружения все заголовки протокольных блоков данных с обнаруженными ошибками считаются имеющими некорректное поле номера последовательности. Если проверенный заголовок не содержит ошибок, то приемник переключается в режим исправления.

Таблица 7
Действия в режиме исправления
Синдром поля КОЗ | Четность | Действия над заголовком | Реакция
Нулевой | Не нарушена | Заголовок признается корректным | Продолжается режим исправления
Ненулевой | Нарушена | Исправление одного бита на основе синдрома. Заголовок признается корректным | Переход в режим обнаружение
Нулевой | Нарушена | Исправление бита четности. Заголовок признается корректным | Переход в режим обнаружение
Ненулевой | Не нарушена | В заголовке многобитовая ошибка | Переход в режим обнаружение

В табл. 7 и 8 представлены подробные действия приемника в режимах исправления и обнаружения, соответственно. Работа алгоритма полностью основана на совмещении корректности значения поля контроля ошибок в заголовке и бита четности.

Таблица 8
Действия в режиме обнаружения
Синдром поля КОЗ | Четность | Действия над заголовком | Реакция
Нулевой | Не нарушена | Заголовок признается корректным | Переход в режим исправления
Ненулевой | Нарушена | Заголовок признается некорректным | Продолжается режим обнаружение
Нулевой | Нарушена | Заголовок признается некорректным | Продолжается режим обнаружение
Ненулевой | Не нарушена | Заголовок признается некорректным | Продолжается режим обнаружение

Приемник передает в подуровень конвергенции результаты подсчета номера последовательности и индикацию подуровня конвергенции, а так же результаты проверки заголовка протокольного блока данных.

Подуровень конвергенции

Подуровень конвергенции является служебно-зависимым и предназначен для переноса:
- асинхронных каналов, т.е. сигналов от источников с постоянной двоичной скоростью, чьи тактовые частоты не синхронизированы с частотой сети связи (например, сигналы G.702 со скоростями 1,544; 2,048; 6,312; 8,448; 32,064; 44,736 и 34,368 Мбит/с);
- синхронных каналов, т.е. сигналов от источников с постоянной двоичной скоростью, чьи тактовые частоты синхронизированы с сетевой тактовой частотой (например, сигналы со скоростями 64, 384, 1536 и 1920 кбит/с, описаны в Рек. I.231);
- видеосигналов диалоговых и распределительных служб;
- сигналов речевого диапазона (например, сигналов G.711 со скоростью 64 кбит/с, кодированных по закону А и m, и сигналов G.722 со скоростью 64 кбит/с);
- звуковых сигналов высокого качества.
Рассмотрим кратко основные функции, которые должен выполнять подуровень конвергенции для решения задач транспортирования информации источников различных служб с постоянными скоростями передачи.
Для защиты от битовых ошибок в службах звукового вещания высокого качества и видео может выполняться обнаружение и исправление ошибок, которое в целях более надежной защиты может комбинироваться с октетным чередованием.
Для некоторых пользователей уровня адаптации АТМ 1-го типа подуровень конвергенции обеспечивает возможность восстановления тактовой частоты в приемнике, например, путем отслеживания заполнения буфера.
Для пользователей, требующих восстановления тактовой частоты источника на стороне приема, уровень адаптации 1-го типа обеспечивает механизм переноса информации синхронизации.
На уровне конвергенции для обнаружения потерянных и пришедших не по адресу пакетов АТМ может использоваться информация, которая получается на подуровне конвергенции и сборки при проверке заголовка протокольного блока данных. Для некоторых служб предусматривается исправление ошибок в поле полезной нагрузки и восстановление потерянных пакетов. Для обеспечения функций подуровня конвергенции для некоторой категории пользователей уровень адаптации АТМ может использовать информацию поля индикации подуровня конвергенции.
Подуровень конвергенции может также формировать сообщения о состоянии сквозных характеристик сети с точки зрения уровня адаптации АТМ:
- о количестве ошибок;
- о количестве потерянных и пришедших не по адресу пакетов АТМ;
- о недогрузке/перегрузке буфера.


УРОВЕНЬ АДАПТАЦИИ АТМ

Уровень адаптации АТМ 2-го типа

Услуги, которые предоставляются уровнем адаптации 2-го типа верхнему уровню, составляют:
- перенос блоков данных служб с изменяющейся скоростью передачи источников;
- обеспечение синхронизации между источником и получателем информации;
- оповещение о потерянной/ошибочной информации, которая не восстанавливается уровнем адаптации АТМ.
Для реализации вышеперечисленных услуг уровень адаптации АТМ 2-го типа должен выполнять следующие основные функции:
- сегментацию и сборку пользовательской информации;
- сглаживание джиттера задержки пакетов ячеек АТМ;
- выявление потерянных и неправильно вставленных ячеек АТМ;
- восстановление в приемнике тактовой частоты источника;
- контроль битовых ошибок и исправление одиночных в управляющей информации протокола уровня адаптации АТМ.
Источник информации является источником с изменяющейся скоростью передачи, поэтому ячейки АТМ могут заполняться неполностью, а уровень заполнения от пакета к пакету может меняться. Все это требует, чтобы в подуровне сегментации и сборки уровня адаптации АТМ 2-го типа выполнялось больше функций, чем при уровне адаптации АТМ 1-го типа.
Формат протокольного блока данных подуровня сегментации и сборки уровня адаптации АТМ 2-го типа представлен на рис.28.
Поле SN позволяет обнаруживать потерянные или пришедшие не по адресу пакеты АТМ. Определенные значения номера последовательности могут служить особым целям.
Поле IT используется для обозначения, что в протокольном блоке содержится начало (ВОМ - Beginning of Message), продолжение (СОМ - Continuation of Message) и завершение сообщения (EOM - End of Message) или блок транспортирует информацию синхронизации, а также компоненты видео или аудио сигналов.
Поле LI показывает число октетов полезной нагрузки в информационном поле частично заполненного протокольного блока данных подуровня сегментации и сборки.
Поле CRC предназначено для обнаружения и исправления ошибок.

рис28
SN (Sequence Number) | - номер последовательности
IT (Information Type) | - тип информации
LI (Length Indicator) | - индикатор длины заполнения информационной части
CRC (Cyclic Redundancy Code) | - циклическая избыточная проверка
PDU (Protocol Data Unit) | - протокольный блок данных

Рис. 28. Структура 48-октетного протокольного блока данных
подуровня сегментации и сборки 2-го типа

Следует отметить, что необходимость наличия вышеперечисленных полей, их расположение и длина составляют предмет дальнейшего изучения.Подуровень конвергенции должен выполнять следующие основные функции:
- восстановление тактовой синхронизации для служб аудио и видео с переменной скоростью;
- контроль последовательности прихода пакетов АТМ с целью обнаружения потерянных или пришедших не по адресу пакетов АТМ;
- обнаружение и исправление ошибок для служб аудио и видео.
Необходимо подчеркнуть, что функции подуровня конвергенции и сборки и протоколы для их реализации также оставлены для дальнейшего изучения.


УРОВЕНЬ АДАПТАЦИИ АТМ

Уровень адаптации АТМ 3/4-го типа

Уровень адаптации АТМ 3/4-го типа рекомендован СС МСЭ для передачи данных службами как с установлением соединений, так и без установления соединений при условии предъявления высоких требований к достоверности передаваемой информации.
Наименование этого уровня адаптации отражает его развитие. В начале службам класса C и D были выделены разные типы уровня адаптации АТМ: уровень адаптации 3-го и 4-го типов соответственно. Затем оба типа были соединены, и, таким образом, уровень адаптации АТМ 3/4-го типа поддерживают оба класса служб [4].
Определены два режима обслуживания: режим сообщение и режим поток. В режиме сообщение один сервисный блок данных проходит через интерфейс уровня адаптации АТМ точно в одном интерфейсном блоке данных (IDU). Обеспечивается транспортировка сервисных блоков данных переменной длины. При этом одиночный сервисный блок данных передается в одном протокольном блоке данных служебно-ориентированного подуровня конвергенции.
В режиме обслуживания поток сервисный блок данных проходит через интерфейс уровня адаптации АТМ в одном или нескольких интерфейсных блоках данных. Передача этих блоков через интерфейс уровня адаптации АТМ может проводиться раздельно во времени. Этот режим обслуживания обеспечивает передачу сервисных блоков данных переменной длины. При этом все интерфейсные блоки данных, принадлежащие одному сервисному блоку данных, передаются в одном протокольном блоке данных служебно-ориентированной части подуровня конвергенции.
В режиме поток может быть реализована услуга внутреннего контейнера, при которой передающий объект уровня адаптации АТМ начинает передачу до того, как будет иметь весь сервисный блок данных. В данном режиме также реализуется прерывание. При прерывании обеспечивается сброс частично переданного через интерфейс уровня адаптации АТМ сервисного блока данных.
В обоих режимах могут быть предоставлены следующие местные (одноуровневые) эксплуатационные процедуры: гарантированное и негарантированное обслуживание.
При гарантированном обслуживании обеспечивается повторная передача утраченных или принятых с ошибками протокольных блоков данных подуровня конвергенции. Управление потоком предоставляется на обязательной основе. Гарантированное обслуживание на уровне адаптации АТМ по всей видимости будет ограничиваться только соединениями "точка-точка".
При негарантированном обслуживании повторная передача утраченных или принятых с ошибками сервисных блоков данных не обеспечивается. В качестве дополнительных услуг может быть предоставлено управление потоком и сброс блоков, принятых с ошибками.

Функции подуровня сегментации и сборки

Подуровень сегментации и сборки принимает от подуровня конвергенции сервисные блоки данных переменной длины и вырабатывает протокольные блоки данных подуровня сегментации и сборки, содержащие до 44 октетов полезной нагрузки.
Основной функцией подуровня сегментации и сборки является перенос между объектами уровня адаптации АТМ по одному соединению уровня АТМ нескольких сервисных блоков данных переменной длины с условием:
- обеспечения сохранности каждого сервисного блока;
- обнаружения ошибок;
- приоритетного обслуживания ;
- сохранения целостности последовательности сервисных блоков данных;
- мультиплексирования/демультиплексирования;
- прерывания.
Для реализации функции сегментации и повторной сборки сервисных блоков данных протокольный блок подуровня сегментации и сборки содержит два поля (рис. 29):
- поле SТ, состоящее из 2 бит;
- поле LI, состоящее из 6 бит.
Указатель типа сегмента показывает, что протокольный блок данных является началом (ВОМ), продолжением (СОМ) или завершением сообщения (ЕОМ) или односегментным сообщением.

рис29
ST (Segment Type) | - тип сегментa
SN (Sequence Number) | - номер последовательности
RES (reserved) | - резерв для протокола третьего типа
MID (Multiplexing Identifier) | - идентификатор мультиплексирования для протокола 4-го типа
LI (Length Indicator) | - индикатор длины заполнения информационной части
CRC (Cyclic Redundancy Code) | - циклическая избыточная проверка
PDU (Protocol Data Unit) | - протокольный блок данных

Рис. 29. Структура 48-октетного протокольного блока данных
подуровня сегментации и сборки 3/4-го типа

Применяется следующее кодирование:
- начало сообщения -10;
- продолжение сообщения- 00;
- завершение сообщения -01;
- односегментное сообщение - 11.
Последний сегмент и сегмент, в который поместилось сообщение полностью, могут содержать меньше октетов полезной нагрузки, чем длина поля полезной нагрузки протокольного блока данных (44 октета). Поле LI содержит двоичное указание числа октетов сервисного блока данных, которое включено в поле полезной нагрузки протокольного блока данных подуровня сегментации и сборки.
Для обнаружения ошибок в протокольном блоке данных используется поле CRC длиной 10 бит. В это поле записывается результат подсчета циклической избыточной проверки, которая выполнятся над всем содержимым протокольного блока данных, включая заголовок, поля полезной нагрузки и индикатора длины. В качестве производящего полинома G(х) используется полином

G(х)= 1+х+х4+х5 +х9+х11.

Для обнаружения потерянных или вставленных пакетов АТМ используется поле номера последовательности (SN), состоящее из 4 бит.Мультиплексирование обеспечивается с помощью 10-битового поля идентификатора мультиплексирования (MID). Это позволяет мультиплексировать трафиk210=1024 пользователей по одному соединению уровня АТМ типа "точка-точка".

Рис.30. Соединение ЛС с сетью АТМ

При передаче данных без установления соединения идентификатор мультиплексирования позволяет обеспечить поочередную передачу блоков данных многих пользователей по одному постоянному виртуальному соединению уровня АТМ, по которому могут транспортироваться пакеты АТМ от одного или нескольких терминалов без установления соединения через сеть АТМ к серверу или между двумя локальными сетями. В качестве примера на рис. 30 показана ЛС, где терминалы обеспечивают обмен данных без установления соединения. В свою очередь ЛС соединена с сетью АТМ шлюзом.
Вся информация от терминалов транспортируется по виртуальному соединению к серверу, который на основании идентификатора мультиплексирования направляет принятую от терминалов ЛС информацию адресатам сети АТМ. Следует отметить, что информация маршрутизации находится на сетевом уровне и сервер должен установить соответствие между значением идентификатора мультиплексирования и информацией сетевого уровня, которая транспортируется только в первом сегменте.
При мультиплексировании в одном соединении АТМ все протокольные блоки данных получают одинаковое качество обслуживания.

Подуровень конвергенции уровня адаптации АТМ 3/4-го типа

Подуровень конвергенции уровня адаптации АТМ, в свою очередь, может быть разделен:
- на общую часть подуровня конвергенции (CPCS);
- на служебно-ориентированную часть подуровня конвергенции (SSCS).
Общая часть подуровня конвергенции уровня адаптации АТМ 3/4-го типа обеспечивает негарантированный перенос кадров любой длины от 1 до 65535 октетов. Соединения могут быть установлены плоскостями контроля (C-plane) или менеджмента (M-plane). Между двумя равноранговыми объектами может быть установлено одно или несколько соединений, однако коммутация соединений не допускается.
Целостность последовательности сервисных блоков данных общей части подуровня конвергенции гарантируется в каждом соединении.Подуровень выполняет следующие функции:
- обеспечивает разграничение и прозрачность сервисных блоков;
- данных общей части подуровня конвергенции;
- обнаруживает ошибки и принимает соответствующие меры (поврежденные сервисные блоки данных отбрасываются или доставляются в служебно-ориентированную часть подуровня конвергенции);
- назначает емкость буфера (каждый протокольный блок данных общей части подуровня конвергенции переносит в приемный равноранговый объект оповещение о максимально необходимой для приема блока данных емкости буфера).
При прерывании частично переданный протокольный блок сбрасывается.Формат протокольного блока данных общей части подуровня конвергенции уровня адаптации АТМ 3/4-го типа показан на рис. 31.

-
рис31
CPI (Common Part Indicator) | - индикатор общей части (1 октет)
Btag (Beginning Tag) | - метка начала (1 октет)
BASize (Buffer Allocation Size) | - необходимая емкость буфера (2 октета)
PAD (Padding) | - заполнение (0...3 октета)
Al (Alignment) | - выравнивание (1 октет)
Etag (End Tag) | - метка конца (1 октет)
Length (Length of CPCS-PDU payload) | длина (2 октета)
Header | - заголовок

Рис. 31 Формат протокольного блока данных подуровня конвергенции
уровня адаптации АТМ 3/4 типа

Поле CPI используется для интерпретации последующих полей в заголовке и в хвостовике. Оно показывает счетные единицы для полей "необходимая емкость буфера" и "длина". Предполагается ,что поле индикатора общей части будет использоваться для идентификации функций менеджмента уровня адаптации АТМ (контроль характеристик, выявление неисправностей, транспортирование сообщений эксплуатации и технического обслуживания).
Поле Btag обеспечивает связь заголовка данного протокольного блока с хвостовиком. В полях метки начала и метки конца записывается одинаковое число, которое изменяется (например, увеличивается) при каждом последующем блоке.
Поле BASize информирует приемное устройство о максимальных требованиях к емкости буфера.Поле
заполнения (PAD) размещается между концом полезной нагрузки и хвостовиком. Оно служит для того, чтобы длина поля полезной нагрузки в сумме с полем заполнения составляла количество октетов, кратное 4.. Поэтому длина поля заполнения может составлять от 0 до 3 октетов. Информации оно не несет.
Поле Al также обеспечивает только 32-битовое выравнивание хвостовика. Оно не несет никакой информации и заполняется нулями.
Поле Etag имеет такое же значение, какое было введено в поле метки начала.
Общая часть подуровня конвергенции предназначена для обеспечения сетевого уровня служб передачи данных без установления соединений (класс D), а также службу ретрансляции кадров (класс С).
Для сетевого уровня без установления соединений служебно-ориентированный подуровень конвергенции не требуется.


УРОВЕНЬ АДАПТАЦИИ АТМ

Уровень адаптации АТМ 5-го типа

Производители оконечного оборудования и пользователи службы высокоскоростной передачи данных с установлением соединений считают, что рекомендованный СС МСЭ протокол уровня адаптации АТМ 3/4-го типа не полностью отвечает их требованиям. Протокол уровня адаптации 3/4 типа имеет очень высокую избыточность в 4 октета на каждый протокольный блок данных подуровня сегментации и сборки из 48 октетов. Вторым недостатком протокола уровня адаптации АТМ 3/4 типа является то, что 8-битовое поле обнаружения ошибок и 4-битовое поле номера последовательности обнаружения потерянных и неправильно вставленных сегментов не обеспечивает достаточный уровень семантической прозрачности сети для переноса длинных блоков данных. Поэтому Форумом АТМ определен новый тип уровня адаптации АТМ 5-го типа, который затем был поддержан СС МСЭ.
Основной задачей, которая решалась при создании и спецификации уровня адаптации АТМ 5-го типа, являлось предоставление услуг высокоскоростной передачи данных с меньшей служебной избыточностью и лучшими показателями семантической прозрачности (ниже общей части подуровня конвергенции).
Необходимо отметить, что на уровне общей части подуровня конвергенции услуги, предоставляемые уровнем адаптации АТМ 5-го типа, должны быть идентичны услугам, обеспечиваемым общей частью подуровня конвергенции уровня адаптации АТМ 3/4-го типа, за исключением мультиплексирования. Если на уровне адаптации АТМ требуется мультиплексирование, то оно должно осуществляться на служебно-ориентированном подуровне конвергенции.

Основные функции подуровня сегментации и сборки

Подуровень сегментации и сборки принимает из общей части подуровня конвергенции сервисные блоки данных переменной длины и вырабатывает протокольные блоки данных, содержащие 48 октетов данных уровня сегментации и сборки.Для того чтобы пользователь уровня адаптации АТМ мог отличить сервисные блоки данных друг от друга, используется специальная метка в поле индикатора полезной нагрузки заголовка пакета АТМ - бит оповещения пользователя уровня адаптации АТМ - пользователю уровня адаптации АТМ, которая указывает на начало или продолжение сервисного блока данных уровня сегментации и сборки (0) или на его окончание (1) (рис. 32).

рис32
PT - бит оповещения пользователя УАА пользователю УАА

Рис. 32. Размещение протокольного блока данных
подуровня сегментации и сборки
уровня адаптации АТМ 5-го типа в ячейке АТМ

Таким образом, уровень адаптации АТМ 5-го типа использует информацию, переносимую в заголовке ячейки АТМ, а функционирование уровня адаптации АТМ больше не является полностью независимым от нижележащего уровня АТМ, что является явным нарушением эталонной модели протоколов ШЦСИО на технологии АТМ. Тем не менее протокол уровня адаптации АТМ 5-го типа принят, так как, по всеобщему мнению, он является простым и эффективным.
Основные функции подуровня слияния:
- негарантированная доставка данных, содержащихся в кадрах пользователя, которые могут иметь любую длину в пределах от 1-го до 65535 октетов;
- обнаружение и индикация ошибок (ошибки в битах, потеря пакета АТМ или поступление пакета АТМ не по адресу);
- целостность последовательности сервисных блоков данных общей
- части подуровня конвергенции в каждом соединении;
- соединение общих частей подуровня конвергенции, которые устанавливаются плоскостью управления или менеджмента.
Выполняемые функции зависят от того, работает ли пользовательслужбы в режиме сообщение или в режиме поток.
В режиме сообщение сервисный блок данных проходит через стык общей части подуровня конвергенции точно в одном интерфейсном блоке данных. Таким образом, обеспечивается передача одного сервисного блока данных в одном протокольном блоке данных общей части подуровня сегментации и сборки.
В режиме поток сервисный блок данных проходит через стык CPCS в одном или нескольких интерфейсных блоках данных, передача которых может оказаться разделенной по времени.

Основные функции подуровня конвергенции

Общая часть подуровня конвергенции обеспечивает передачу всех интерфейсных блоков данных, принадлежащих одному сервисному блоку данных, в одном протокольном блоке данных.
При работе в режиме потока предоставляется возможность прекращения предоставления услуги. При этом может запрашиваться сброс сервисных блоков данных, которые частично уже переданы через данный стык.
Функции, которые реализуются в общей части подуровня конвергенции уровня адаптации 5-го типа, аналогичны функциям, которые выполняются подуровнем конвергенции уровня адаптации 3/4-го типа. Исключением является то, что общая часть подуровня конвергенции уровня адаптации 5-го типа не передает принимающему объекту оповещение о назначаемой емкости буфера. Кроме этого, защита от ошибок в уровне адаптации 5-го типа полностью выполняется в CPCS и не делится между SAR-CS и CPCS, как это рекомендуется выполнять в уровне адаптации АТМ 3/4-го типа.
Формат протокольного блока данных общей части подуровня конвергенции уровня адаптации 5-го типа приведен на рис.33.
Для выполнения функций, которые возлагаются на общую часть подуровня слияния, необходим 8-октетный хвостовик протокольного блока данных. Хвостовик протокольного блока данных всегда размещается в последних 8 октетах последнего протокольного блока подуровня сегментации и сборки. Поэтому поле заполнения имеет длину от 0 до 47 октетов. В этом случае при любой длине полезной нагрузки от 1 до 65575 октетов и 8-октетном заголовке протокольный блок данных общей части подуровня конвергенции может быть разделен без остатка на протокольные блоки подуровня сегментации и сборки для предоставления на уровень АТМ. Допускается любое кодирование этого поля.
Поле индикации пользователь - пользователю используется для прозрачной передачи информации пользователя.
Поле индикатора общей части выполняет аналогичные функции, как и в уровне адаптации АТМ 3/4-го типа.
Поле длины используется для кодирования в двоичном исчислении длины полезной нагрузки в октетах протокольного блока данных общей части подуровня конвергенции. Поскольку максимальная длина кадра пользователя может составлять 65535 октетов, то на поле длины должно быть отведено 2 октета. Это поле также используется приемником для обнаружения потери или увеличения объема информации. Поле длины, заполненное нулями, используется функцией преждевременного прекращения услуги при работе в режиме поток.

рис33
PAD (Padding) | - заполнение (0-47 октет)
AL (Alignment) | - выравнивание (2 октета)
Length (Length of CPCS-PDU Payload) | - длина (2 октета)
CRC (Cyclic Redundancy Check) | - циклическая избыточная проверка (4 октета)
Header | - заголовок
Trailer | - хвостовик
UU (CPCS User-to-User Indication) | - индикатор пользователь-пользователь общей части подуровня конвергенции
CPI (Common Part Indicator) | - индикатор общей части

Рис.33. Формат протокольного блока данных общей части
подуровня конвергенции уровня адаптации АТМ 5-го типа

Поле избыточной циклической проверки заполняется контрольными битами, которые являются результатом деления содержимого протокольного блока данных общей части подуровня конвергенции, включая полезную нагрузку, поле заполнения и первые 4 октета хвостовика.
В качестве порождающего полинома циклической избыточной проверки рекомендуется использовать
Р(х)=х32+ х26 + х23 + х22 + х16 + х12 + х11 + х10 + х8 + х7 + х5 + х4 + х2 + х+1


ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ

Принципы поддержки в сетях АТМ
служб не ориентированных на соединение

Технология АТМ ориентирована на установление соединения. Однако ШЦСИО должна обеспечивать передачу и прием информации служб, которые не ориентированы на соединение (CL -Connectionless). Это особенно важно, так как одним из первых практических применений ШЦСИО является связь локальных и городских вычислительных сетей (LAN и MAN), которые в настоящее время используют преимущественно протоколы без установления соединений.
Рек. I.211 [35] описывает два механизма поддержки служб без установления соединения :
- косвенно через службу с установлением соединения;
- непосредственно через службу без установления соединения.
Функциональная архитектура ШЦСИО, определенная в Рек. I.327 [36], обеспечивает возможность реализации обоих механизмов поддержки служб без установления соединения (рис. 34 и 35).

Рис. 34. Косвенное обеспечение службы ПД, не ориентированной на
установление соединения

При косвенном механизме услуги по передаче данных без установления соединения предоставляются с использованием устанавливаемых соединений между интерфейсами ШЦСИО. Эти соединения могут быть постоянными или создаваться по требованию (рис. 34.).
Протоколы установления соединения прозрачны для ШЦСИО, так как все услуги по установлению соединений и функции уровня адаптации реализуются вне транспортной сети АТМ. Поэтому такой механизм поддержки служб без установления соединений может быть реализован всегда.
Однако использование постоянных соединений влечет за собой снижение эффективности использования сетевых ресурсов, а создание соединения вначале сеанса приводит к удлинению фазы установления соединения и к увеличению служебной нагрузки. Одной из основных характеристик служб без установления соединения в локальных и городских вычислительных сетях считается малая величина задержки. Это обуславливает очень жесткие требования ко времени установления соединения. Считается, что косвенное обеспечение служб не ориентированных на соединение применимо только при небольшом количестве пользователей этих служб и может рассматриваться как временное решение [4].
Второй механизм непосредственной поддержки служб без установления соединения показан на рис. 35.

Рис. 35. Непосредственное предоставление услуг службы ПД без установления соединения

Функции служб без установления соединения (CLFS - Connectionless Function Service) могут реализовываться как вне, так и внутри ШЦСИО. Они определяют протоколы транспортирования информации без установления соединения и маршрут ячеек к месту назначения в соответствии с маршрутной информацией, содержащейся в ячейках.
Предоставление услуг без установления соединения находится выше уровня АТМ. Это требует на уровне АТМ соединения каждого пользователя (клиента) с сервером СL, выполняющим функции службы передачи данных без установления соединения. Такие соединения могут быть заранее устанавливаемыми или коммутируемыми.
Необходимо отметить, что механизм непосредственной поддержки по своему архитектурному решению сводится к схеме "клиент-сервер".
В случае коммутируемых соединений может оказаться, что сообщение не может быть передано адресату из-за отсутствия нужного соединения. В этом случае узел, выполняющий функции CLSF, отказывает пользователю в передаче.
При косвенном механизме предоставления услуг по ПД без установления соединения для реализации полносвязной схемы между n пользователями требуется nx(n-1)/2 соединений, а при механизме непосредственной поддержки и единственном CL-сервере - только n соединений. Количество серверов CL в сети зависит от размера ШЦСИО и объема нагрузки ПД без установления соединения. Функции предоставления услуг ПД без установления соединения могут быть реализованы в специальных узлах предоставления услуг ПД без установления соединения или в узлах коммутации АТМ.Рассмотрим пример реализации рассмотренных выше принципов на практике.


ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ

Обеспечение функционирования высокоскоростных служб ПД,
не ориентированных на соединение через АТМ

Широкополосная служба ПД (CBDS - Connectionless Broadband Data Services) как и мультимегабитная служба ПД (SMDS - Switched MultiMegabit Data Service) являются хорошо известными высокоскоростными службами ПД, не ориентированными на соединение [37]. CBDS является Европейской версией SMDS. Различия между ними практически нет, что позволяет рассмотреть только одну службу.
Сеть АТМ обеспечивает перенос блоков данных службы без установления соединения между специальными серверами, способными поддерживать протоколы ПД без установления соединения. Адаптация между уровнем протокола без установления соединения и уровнем АТМ осуществляется уровнем адаптации АТМ 3/4-го типа. Общая структура протоколов обмена информацией службы без установления соединения приведена на рис. 36.
Для обеспечения передачи информации служб без установления соединения необходимы два протокола и два интерфейса:
- протокол и интерфейс доступа в сеть (CLNAP - Connectionless Network Access Protocol, CLAI - Connectionless Access Interface);
- протокол и интерфейс сетевого уровня (CLNIP - Connectionless Network Interface Protocol, CLNI - Connectionless Network Interface).
Каждый протокольный блок протокола доступа в сеть и сетевого протокола содержит адрес отправителя и адрес получателя, которые формируются в соответствии с Рек. Е. 164 [38]. Размеры поля данных, переносимых сервисными блоками данных протокола доступа (CLNAP) и сетевого протокола (CLNIP), не являются фиксированными, но верхние значения ограничены для CLNAP величиной 9188 октет, а для CLNIP SDU - 9236 октет. Сервисные блоки данных передаются через уровень протокола доступа в сеть (CLNAP) без соединения как "наилучшая попытка" (Best Effort).

рис36
Условные обозначения:
СLAI - интерфейс доступа в сеть службы без установления соединения
CLNI - сетевой интерфейс службы без установления соединения

Рис. 36. Общая структура протоколов служб без установления соединения

Протокольный блок данных СLNAP имеет максимальную длину 9232 октета (9188 октет - поле данных сервисного блока, 40 октет - заголовок и 4 октета - поле контроля ошибок CRC -32).
Структура протокольного блока данных CLNIP приведена на рис. 37.
Структура протокольного блока данных CLNAP имеет следующие отличия от структуры PDU - CLNIP:
- поле идентификатора протокола высшего уровня (HLPI - Higher Layer Protocol Identifier) свободно переносится сетью от источника до получателя за исключением значений от 44 до 47, которые для PDU-CLNAP отбрасываются;
- если расширение заголовка не осуществляется, то все 20 октет могут использоваться в интересах поля расширения заголовка;
- максимальная длина поля данных пользователя составляет 9188 октет.
Функции, выполняемые уровнем адаптации АТМ 3/4-го типа для обоих протоколов, идентичны. Уровень адаптации АТМ 3/4-го типа обеспечивает прозрачную передачу протокольных блоков данных CLNAP и CLNIP между двумя объектами негарантированным способом. За счет идентификатора мультиплексирования (MID) возможно одновременное установление нескольких соединений.

рис37
Обозначения:
PI (Protocol Identifier) | - идентификатор протокола
PADLE (Padding Length) | - длина заполнения
QOS (Quality of Service) | - качество обслуживания
С (CRC Indication Bit) | - индикатор количества бит в поле контроля ошибок
HEL (Header Extension Length) | - длина расширения заголовка
CRC (Cyclic Redundancy Check) | - циклическая избыточная проверка

Рис. 37. Структура протокольного блока данных CLNIP

Информация может передаваться как в режиме сообщения, так и в режиме потока. Служебно-ориентированный подуровень конвергенции не нужен. Его функции практически выполняет уровень CLNAP/ CLNIP.
В режиме сообщения сервер CL собирает все протокольные блоки данных подуровня сегментации и сборки, затем выполняет функции маршрутизации, а затем снова сегментирует сообщение. Из-за необходимости выполнения функции сборки в режиме сообщения сервер CL должен иметь большую буферную память. Кроме того, это может привести и к большим задержкам.
В режиме потока сервер CL, получивший начало сообщения (ВОМ), выполняет функцию маршрутизации, так как полезная нагрузка протокольного блока данных, который поступает из подуровня сегментации и сборки, содержит адрес места назначения. Это позволяет модернизировать маршрутные таблицы, которые в соответствии со входящей комбинацией ИВП и ИВК назначают исходящую комбинацию на транзитных коммутаторах АТМ по всему маршруту. Все остальные протокольные блоки, относящиеся к данному сообщению, проходят по сети только с помощью маршрутных таблиц. После обработки последнего протокольного блока, у которого в поле типа сегмента записано 01, что означает завершение сообщения (ЕОМ), соответствующие записи в маршрутных таблицах удаляются.
При использовании режима потока большая память в сервере CL не нужна и можно достичь малых задержек. С помощью режима потока для службы, не ориентированной на соединение, можно достичь практически такой же временной прозрачности сети, как и для служб ПД ориентированных на соединение, так как начальный протокольный блок данных (ВОМ) обрабатывается аналогично служебному сообщению сигнализации на установление сообщения.
Граничный коммутатор с функциями службы без установления соединения несет ответственность за правильную инкапсуляцию протокольных блоков данных доступа (CLNAP) в протокольных блоках данных сетевого интерфейса (CLNIP) и обратно.
Пусть со стороны пользователя в граничный коммутатор на уровень CLNAP поступил протокольный блок данных (рис.38).

Рис. 38. Структура протокольных блоков данных
на различных уровнях граничного коммутатора (коммутатора доступа)

После присоединения к нему 4-октетного поля выравнивания заголовка (AH - Alignment Header) на уровне CLNIP к нему прибавляется заголовок, образуя протокольный блок данных CLNIP.
Данный блок передается в общую часть подуровня конвергенции, где к нему добавляется заголовок и хвостовик, образуя протокольный блок данных общей части подуровня конвергенции (CPCS) уровня адаптации АТМ 3/4-го типа, в котором инкапсулирован протокольный блок данных CLNAP.
На подуровне сегментации и сборки (SAR) происходит деление протокольного блока данных общей части подуровня конвергенции на сегменты длиной 48 байт, которые являются полем полезной нагрузки ячеек АТМ.
Весь процесс, включая необходимые процедуры на уровне адаптации АТМ 3/4-го типа, показан на рис. 38.
Для широкополосной передачи данных без установления соединения (CBDS) определено несколько классов доступа, которые определяют максимальную скорость передачи пользователем данных.
В зависимости от класса доступа специальный механизм ограничивает скорость передачи информации.
Класс доступа определяется тремя параметрами [39] :
- максимальной информационной скоростью (MIR - Maximum Information Rate), под которой понимается максимальная мгновенная величина информационной скорости во время передачи пачки;
- поддерживаемой информационной скоростью (SIR - Sustained Information Rate), под которой понимается среднее значение информационной скорости при передаче пачечного трафика за длительное время;
- средняя скорость передачи протокольных блоков данных пачечного трафика за длительное время (PPTU - PDUs per Time Unit).
В точке входа в сеть АТМ механизм, реализующий функции контроля параметров пользователя, обычно измеряет пиковую скорость.
Способы измерения поддерживаемой скорости (SIR) и средней скорости передачи блоков данных оставлены для дальнейшего изучения. В сетях DQDB эти параметры контролируются механизмом, который получил наименование "проверки кредита".


ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ

Обеспечение функционирования службы ретрансляции кадров через АТМ

Необходимость быстрого и эффективного взаимодействия между локальными вычислительными сетями явилась одной из основных причин разработки нового стандарта скоростной передачи данных - ретрансляция кадров (Frame Relay).
Ретрансляция кадров - это протокол канального уровня, который устанавливает порядок сборки кадров переменной длины. По сравнению с другими альтернативами (службой аренды линий или Х.25) служба ретрансляции кадров имеет ряд очевидных преимуществ:
- относительно высокая скорость передачи и низкая задержка по сравнению с Х.25;
- высокая пропускная способность;
- эффективное использование сетевых ресурсов за счет статистического мультиплексирования.
Ретрансляция кадров является технологией ориентированной на соединение. Она позволяет осуществлять статистическое мультиплексирование нескольких соединений, что особенно эффективно для трафика пачечной структуры.
Поскольку современные цифровые системы передачи характеризуются малым уровнем ошибок, то отсутствует необходимость в механизме позвенной проверки и исправления ошибок. Поэтому при ретрансляции кадров позвенная проверка ошибок исключена, что обеспечивает снижение времени доставки по сравнению с сетями Х.25, так как процесс обработки кадров в сетевых узлах значительно упрощен и ограничен несколькими основными операциями [40,41].
Однако кадры с битовыми ошибками и неправильной маршрутизацией могут быть обнаружены и отброшены сетевыми элементами. В конечных точках соединения производится обнаружение ошибок и осуществляется повторная передача кадров. Но это выполняется протоколами высших уровней.
Ретрансляция кадров является технологией пакетного типа и поэтому похожа на АТМ. Но пакеты в технологии Frame Relay не являются фиксированными и поэтому получили наименование кадров.
Кадры несут маршрутную информацию, называемую идентификатором соединения звена данных (DLCI - Data Link Connection Identifier), который имеет локальное значение (от звена до звена).
Бит сброса кадра (DE - Discard-Eligibility) подобен полю приоритета потери ячейки в АТМ и используется для защиты от перегрузок. Кадры передаются в соответствии с адресной информацией вдоль виртуального соединения. Виртуальные соединения могут быть постоянными (устанавливаются администрацией) или коммутируемыми (устанавливаются по требованию системой сигнализации).
Несколько виртуальных соединений могут фактически распределять пропускную способность уплотненного канала в зависимости от своей активности. Служба ретрансляции кадров может использоваться для передачи речи и факсимильных сообщений. Оцифровка и передача голосовой информации осуществляется одним из методов кодирования и линейного предсказания (ACELP - Algebraic Code Exited Linear Prediction), позволяющим значительно уменьшить требуемую полосу пропускания по сравнению с ИКМ.
Для целей менеджмента используются специальные кадры, идентифицируемые за счет кодирования идентификаторов соединения звеньев данных. Эти кадры обеспечивают сбор статистики о состоянии физических и логических звеньев и оборудования пользователя.
Ретрансляция кадров по эталонной модели протоколов взаимодействия открытых систем относится ко второму уровню. При ретрансляции кадров [42] выполняются следующие функции:
- нарезка кадров и их выравнивание;
- мультиплексирование /демультиплексирование кадров;
- проверка длины кадра и ее соответствия целому числу октет;
- обнаружение ошибок;
- защита от перегрузок.
Следует сказать, что ретрансляция кадров получила широкое распространение в частных (корпоративных) сетях и сетях общего пользования. Компания U.S. Sprint была первой, предложившей в 1991 г. пользователям услуги Frame Relay.
Существенным преимуществом службы Frame Relay является наличие разработанного комплекса аппаратно-программных средств, предоставляющего абонентам возможность использования большого перечня относительно дешевых услуг. Поэтому служба Frame Relay была первой, для которой были разработаны протоколы работы через сети АТМ.
В Рек. I.555 [43] определены три способа поддержки службы Frame Relay со стороны ШЦСИО на технологии АТМ:
- функции службы ретрансляции кадров поддерживаются внутри ШЦСИО;
- функции службы ретрансляции кадров поддерживаются вне ШЦСИО;
- обеспечивается перенос кадров службы ретрансляции кадров через ШЦСИО.
Первые два способа имеют сходство с непосредственным предоставлением услуг без установления соединения.
При третьем способе протоколы службы ретрансляции кадров выполняются в оконечных устройствах пользователей, соединенных через интерфейсы пользователь-сеть с ШЦСИО. Эти протоколы работают выше уровня адаптации АТМ и прозрачно транспортируются через ШЦСИО.
Определены два типа интерфейсов услуг Frame Relay: интерфейс доступа в ШЦСИО (FR-BAI - Frame Relay B-ISDN Access Interface) и сетевой интерфейс (FR-BNNI - Frame Relay B-ISDN Network-to-Network Interface). Оба интерфейса очень похожи.
На рис. 39 показано место этих интерфейсов в общем протокольном стеке.
Для адаптации кадра к ячейке уровня АТМ используется уровень адаптации АТМ 5-го типа, функционирующий в режиме передачи сообщения.Для эмуляции кадров службы Frame Relay и взаимодействия с ШЦСИО предназначен служебно-ориентированный подуровень конвергенции службы ретрансляции кадров (FR-SSCS - Frame Relay Service-Specific Convergence Sublayer) [43].
Функции служебно-ориентированного подуровня конвергенции службы ретрансляции кадров аналогичны основным функциям уровня звена данных, определенных в [42].
Структура протокольного блока данных служебно-ориентированного подуровня конвергенции службы ретрансляции кадров (FR - SSCS - PDU) соответствует структуре кадра Frame Relay без флага и поля контроля ошибок в кадре.
Существует две возможности переноса кадров службы Frame Relay через ШЦСИО:
- Мультиплексирование на служебно-ориентированном подуровне конвергенции службы ретрансляции кадров и перенос агрегированного потока кадров в одном соединении АТМ. Идентификация кадров от каждого источника осуществляется с помощью идентификаторов соединения звена данных (DLCI). Этот способ получил наименование "много в одном" (Many-to-One).- Мультиплексирование происходит на уровне АТМ. Поток кадров каждого виртуального соединения ретрансляции кадров размещается в отдельное соединение АТМ, используя известный механизм мультиплексирования множества источников в едином цифровом тракте (пути передачи). Данный способ называют "один к одному" (One-to-One).

Рис. 39. Общий протокольный стек переноса кадров службы Frame Relay через сеть АТМ

В настоящее время выделение ресурсов пользователю службы ретрансляции кадров происходит пока по пиковой скорости. Использование других параметров трафика является предметом для изучения.


ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ

TCP/IP через ШЦСИО

Технология, позволившая объединить множество физических сетей в единую глобальную сеть, в которой использовались бы как соединения на физическом уровне, так и набор специальных соглашений и протоколов, получило наименование Internet. Она позволяет компьютерам "общаться" друг с другом независимого от того, к какой сети и каким образом они подключены [44].
Для реализации этой технологии агентством DARPA (Defense Advanced Research Projects Agency) в США был создан стек протоколов TCP/IP, который стал одним из популярнейших протоколов сетевого взаимодействия и стандартом de facto для реализации глобальной сети Internet.
Сеть Internet объединяет около 10 млн. компьютеров по всему миру, а рост ее трафика возрастает фактически вдвое каждые 3-4 месяца. Поэтому решение проблемы объединения этих технологий имеет большое значение как для технологии Internet, так и для технологии АТМ.
Уровни стека протоколов TCP/IP и их взаимосвязь с уровневой моделью протоколов ВОС показаны на рис. 40.

Рис. 40. Протокольный стек TCP/IP

Сетевой уровень - основа TCP/ IP. Именно на этом уровне реализуется принцип межсетевого соединения, в частности маршрутизация пакетов. На сетевом уровне протокол реализует ненадежную доставку пакетов по сети без установления соединения.
Надежную передачу реализует транспортный уровень, на котором два основных протокола TCP и UDP осуществляют связь между машиной - отправителем пакетов и машиной - получателем.
Прикладной уровень - это приложения типа клиент-сервер, базирующиеся на протоколах нижних уровней.
Среди основных приложений TCP/ IP, имеющихся в каждой его реализации, - протокол эмуляции терминала Telnet, протокол передачи файлов FTP, протокол электронной почты SMTP, протокол управления сетью SNMP, протокол передачи гипертекста и др. Протоколы прикладного уровня не зависят от нижних уровней.
В качестве примера на рис. 41 показано соединение двух сетей с помощью протоколов TCP / IP.

Рис. 41. Соединение ЛВС Ethernet и Token Ring с помощью протоколов TCP/IP

При использовании технологии Internet детали физических соединений скрыты от приложений и прикладной уровень не замечает, что клиент приложения работает в Ethernet, а сервер подключен к сети Token Ring. Между ними может быть несколько десятков маршрутизаторов и множество физических сетей различных типов, но приложение будет воспринимать весь этот конгломерат как единую физическую сеть [19, 44].
Хотя рассмотренный нами стек протоколов и называется TCP/IP, сами протоколы TCP и IP являются важнейшими, но не единственными представителями этого семейства. Каждый уровень обслуживается несколькими протоколами.
TCP (Transmission Control Protocol) обеспечивает надежную передачу данных. Он позволяет клиенту и серверу устанавливать между собой логическое соединение и использовать его для передачи больших массивов данных, также реализует гарантированную доставку информации.
Протокол UDP (User Datagram Protocol) является протоколом дейтаграммного типа без установления логического соединения и не гарантирует надежную доставку данных. Функции надежной передачи должны встраиваться в прикладной уровень.
При непрерывном обмене данными между клиентом и сервером связь с помощью протокола транспортного уровня TCP является более эффективной. Если же связь осуществляется редко и для передачи небольших объемов, то предпочтительнее использовать протокол UDP.
Протокол ТСР используют такие известные распределительные приложения, как Telnet, FTP и SMTP. Протоколом UDP пользуется протокол сетевого управления SNMP.
ТСР и UDP идентифицируют приложение по 16-битным номерам портов. Серверы приложения обычно имеют заранее известные номера портов. Назначение номеров портов находятся в ведении организации IANA (Internet Assigned Numbers Authority).
Клиент приложения обычно "не интересуется" номером своего порта для транспортного уровня. Ему лишь необходимо гарантировать, что этот номер уникален. Номера портов клиентов приложения принято называть краткосрочными, так как в общем случае клиенты существуют ровно столько времени, сколько работающий с ними пользователь нуждается в соответствующем сервере.
Internet Protocol (IP) является основным протоколом сетевого уровня. Он используется обоими протоколами транспортного уровня. IP определяет базовую единицу передачи данных - IP - дейтаграмму, указывая точный формат всей информации. Программное обеспечение IP выполняет функции маршрутизации, выбирая путь передачи данных по паутине физических сетей. Для определения маршрута поддерживаются специальные таблицы.
Выбор осуществляется на основе адреса сети, к которой подключен компьютер-адресат.
Протокол IP определяет маршрут отдельно для каждого пакета данных, не гарантируя надежной доставки в нужном порядке.
Благодаря уровневому подходу есть возможность для Internet использовать возможности, предоставляемые ШЦСИО на технологии АТМ, без изменения протоколов высокого уровня за счет разработки нового программного обеспечения, которое должно быть встроено между сетевым уровнем Internet и уровнем адаптации АТМ.
Рассмотрим коротко основные проблемы и возможности их решения:
Инкапсуляция. Проблема может быть решена инкапсуляцией дейтаграмм IP в ячейках АТМ, которая должна осуществляться на уровне адаптации АТМ 5-го типа. Для опознавания используемого протокола высокого уровня в заголовке блока данных, поступающего на уровень адаптации, должен быть специальный индикатор, однозначно определяющий тип протокола [47].
Вторым способом решения этой проблемы является предоставление различных комбинаций идентификаторам виртуальных путей и виртуальных каналов, назначаемых сетью АТМ для различных протоколов верхних уровней [45].
Адресация. Необходима замена адресов IP на адреса АТМ и наоборот. Это наиболее сложная проблема. Создание таблиц соответствия адресов возможно только для сетей небольшого размера. Для больших сетей этот метод очень трудно реализовать.
Эта проблема характерна и при использовании протокола разрешения адресов (ARP): в этом случае уровень АТМ должен обладать очень большими возможностями, что далеко от практического решения.
Требуется разрешить противоречие между объемом информации, необходимой для решения задачи маршрутизации, и ресурсами, выделяемыми для ее накопления, обработки и распределения. Считается, что решение этой проблемы на больших узлах заключается в том, что устройство коммутации должно знать необходимую информацию только о своей локальной топологии в равноуровневой (равноранговой) группе и обобщенную информацию о более удаленных участках сети (равноуровневых группах более высокого уровня иерархии). Это можно выполнять при условии, что ШЦСИО будет иметь иерархическую структуру, а адресация будет использовать принципы, заложенные в телефонных сетях.
Управление соединениями. Существуют две возможности взаимодействия пользователей в АТМ: постоянные виртуальные соединения или соединения по требованию, которые устанавливаются средствами системы сигнализации.
На начальном этапе с успехом могут использоваться постоянные и полупостоянные соединения, устанавливаемые администрациями сети с помощью системы управления. Использование полупостоянных соединений предпочтительнее, хотя требует реализации возможности сигнализации в маршрутизаторах.
Аспекты протокола транспортного уровня ТСР. Принципиально возможно использование протоколов транспортного уровня без каких-либо изменений.
Протокол транспортного уровня ТСР, в отличие от UDP, организуя поток данных между оконечными системами для приложений верхнего уровня, обеспечивает надежную передачу данных между двумя пользователями; позволяет осуществлять дробление потока данных, подтверждать получение пакета данных, задавать таймауты (подтверждение получения информации), организовывать повторную передачу в случае потери данных и т.д.Для протокола, использующего механизм обратной связи, важной характеристикой является объем информации, который может быть передан за время отклика. В сетях АТМ, имеющих большую пропускную способность цифровых трактов связи, объем информации, передаваемой за время отклика, резко увеличивается. Это требует некоторого расширения транспортного протокола ТСР [46].


ПЛОСКОСТЬ ПОЛЬЗОВАТЕЛЯ И ЕЕ ФУНКЦИИ

Эмуляция локальных вычислительных сетей

Поддержка существующих локальных вычислительных сетей (ЛВС) и их объединение в национальные и глобальные вычислительные сети является основным требованием дня к технологии АТМ.
Если участь технологии АТМ в масштабах предприятия еще не очевидна, то никто не посягает на первенство технологии АТМ в глобальных сетях.
Летом 1995 г. рабочая группа по эмуляции ЛВС Форума АТМ представила версию 1.0 спецификации по эмуляции ЛВС (LUNI - LAN Emulation User-to-Network Interface или просто LANE - LAN Emulation) [48].
Целью эмуляции ЛВС является использование возможностей сети АТМ, ориентированной на соединение, имитировать (эмулировать) природу локальных вычислительных сетей, которые обеспечивают передачу информации без установления соединения.
Эмуляция ЛВС очень актуальная задача как для самих ЛВС, так и для ШЦСИО на технологии АТМ. Эмуляция ЛВС дает возможность оконечным станциям ЛВС соединяться с оконечными станциями других ЛВС, а также с высокопроизводительными серверами АТМ, маршрутизаторами, мостами и другими устройствами, решая проблемы расстояний и скоростей обмена. Эмуляция ЛВС дает широкополосным цифровым сетям массового потребителя сетевых ресурсов, чей трафик скоро превысит трафик традиционной телефонной службы.
Уже сегодня около 10 млн. компьютеров объединяют ЛВС, и поэтому нежелательно модифицировать уже установленное оборудование и программное обеспечение ЛВС Ethernet и Token Ring. Более просто между сетью АТМ и ЛВС поставить устройство типа конвертера, которое, получая пакеты от ЛВС и модифицируя их, добавляет заголовок и трайлер с последовательностью проверки кадра (FCS) и отправляет их на уровень адаптации АТМ 5-го типа в качестве протокольного блока данных. Подуровень сегментации и сборки, принимая от уровня конвергенции инкапсулированный пакет, сегментирует его на протокольные блоки данных подуровня сегментации и сборки и отправляет для формирования ячеек и последующего транспортирования по назначению на уровень АТМ.
Следует сразу отметить, что эти функции конвертера могут выполнять уже граничные коммутаторы АТМ, выпускаемые многими производителями оборудования АТМ (например, Fore Systems, Bay Networks Inc., Agila Networks и др.).
Эмуляция ЛВС FDDI также возможна. Однако в этом случае необходимо кадры FDDI переформатировать в кадры Ethernet или Token Ring.
Маршрутизаторы могут устанавливать соединения эмулированной ЛВС Token Ring с эмулированной ЛВС Ethernet. Таким же образом мост может использоваться несколькими эмуляторами ЛВС. Интерфейс пользователь-сеть эмулированной ЛВС (LUNI) позволяет мультиплексировать эмулированные ЛВС. Эмуляция ЛВС позволяет существующим типам ЛВС без всякой модификации их структуры и приложений обеспечивать обмен информацией (рис. 42). Рабочие станции и другие оконечные устройства получают возможность доступа к серверам АТМ, маршрутизаторам и другим устройствам.
Программное обеспечение клиентов LANE дает возможность установления соединений. Конвертеры АТМ-ЛВС выполняют функции граничных коммутаторов и обеспечивают преобразование пакетов ЛВС в ячейки для транспортирования по АТМ. Эмуляция ЛВС располагается на втором уровне эталонной модели протоколов ВОС. В сущности это мост между ЛВС и адресами АТМ на уровне управления доступом к среде (МАС - Media Access Control). Он полностью независим от служб, протоколов и прикладных процессов пользователя, действующих на высших уровнях.

Рис. 42. Логическая структура эмуляции ЛВС

Принятая Форумом АТМ спецификация 1.0 по эмуляции ЛВС состоит из [48] клиентов эмуляции ЛВС (LECs - LAN Emulation Clients) и услуг по эмуляции ЛВС.
Таким образом, эмуляция ЛВС - одна из разновидностей модели клиент-сервер. Программное обеспечение клиента встраивается в конверторах АТМ-ЛВС в качестве драйверов периферийных станций и сетевого сервера АТМ и должно выполнять несколько функций, из которых самой важной является конвертирование адреса управления доступом к среде в адрес АТМ.
Программное обеспечение услуг по эмуляции ЛВС выполняет логические функции сервера эмуляции ЛВС (LES - LAN Emulation Server), сервера конфигурации (LECS - LAN Emulation Configuration Server) и сервера широковещательных и нераспознанных сообщений (BUS - Broadcast and Unknown Server).
Все три функции могут выполняться коммутатором АТМ. Однако эти функции могут быть и распределены между различными устройствами. Так, например, функции сервера эмуляции ЛВС могут быть отданы магистральным коммутаторам, функции сервера конфигурации - специальному серверу АТМ, а функции сервера широковещательных и нераспознанных сообщений - конвертерам АТМ-ЛВС.
В отличие от эмуляции ЛВС, которая связывает сети на уровне доступа к среде передачи, многопротокольный режим передачи через АТМ (MPOA - Multiprotocol over АТМ) должен обеспечивать маршрутизацию трафика на сетевом уровне.
Форумом АТМ создана специальная группа, которая определяет требования к протоколам МРОА и разрабатывает его спецификацию.
Спецификация версии 1.0 многопротокольного режима передачи через АТМ принята Форумом АТМ весной, а версия 2.0 эмуляции ЛВС - осенью 1997 г. Интересно отметить, что если услуги эмуляции ЛВС версии 1.0 потребовали разработки программного продукта объемом около 25 тыс. команд, то услуги МPОА требуют по предварительным данным не менее 250 тыс. команд. Это связано, прежде всего, со сложностью реализации проблемы маршрутизации и расширения функций протоколов транспортного уровня.


ПЛОСКОСТЬ УПРАВЛЕНИЯ И ЕЕ ФУНКЦИИ

Маршрутизация в ШЦСИО

Управление процессами маршрутизации является важнейшей функцией сетевого уровня. Маршрутизация в сетях АТМ имеет некоторое отличие от маршрутизации в пакетных сетях. Сети АТМ ориентированы на соединение. Это означает, что выбор маршрута относится только к установлению соединения, а перенос ячеек в сети происходит по уже выбранному маршруту с помощью коммутаторов АТМ на уровне АТМ согласно уникальным для каждого звена значениям идентификаторов виртуального пути и виртуального канала.
В дейтаграммной сети маршрут выбирается непосредственно для каждого пакета, в следствие чего два последовательных пакета одной и той же пары корреспондирующих пользователей могут проходить по разным маршрутам.
Качество обслуживания пользователей в виртуальном соединении во многом определяется временем задержки, джиттером задержки, а также величиной вероятности потери ячеек или величиной вероятности прихода ячеек не по адресу. Заявка на новое виртуальное соединение должна приниматься только тогда, когда ресурс пропускной способности на всем маршруте прохождения соединения достаточен как для обеспечения качества обслуживания нового виртуального соединения, так и для сохранения требуемого качества обслуживания ранее составленных соединений.
Одним из основных требований к маршрутизации является робастность ее алгоритмов. Алгоритм выбора маршрута для установления соединения должен быть достаточно гибким для учета большого количества противоречивых факторов, определяющих качество обслуживания пользователей при организации виртуального соединения по данному маршруту, а с другой стороны должен быть достаточно простым, чтобы коммутационное устройство доступа пользователей в сеть могло выполнять все функции маршрутизации, управления потоками и защиты от перегрузок.
В самом общем плане алгоритмы маршрутизации можно разбить на 2 класса [10, 11, 52,53]:
- централизованные, в которых решающие функции закреплены за одним узлом, посылающим соответствующие команды остальным узлам;
- децентрализованные (распределенные), при использовании которых каждый узел самостоятельно выбирает маршрут передачи (или ее направление) на основе собственной информации.
Данные алгоритмы, в зависимости от используемой в них информации о структуре и состоянии связности сети, пропускной способности цифровых трактов и интенсивности потоков ячеек, можно разделить на три класса:
- адаптивные (динамические), использующие текущую информацию с той или иной степенью задержки о загрузке и состоянии сети и ее элементов;
- фиксированные (статистические), работающие с заранее заданной информацией или маршрутными таблицами;
- квазистатистические, которые могут быть основаны на совокупности локальных маршрутных таблиц центров коммутации виртуальных путей и виртуальных каналов, корректируемых при устойчивом в течение некоторого времени изменения нагрузки, выходе из строя каких-нибудь сетевых элементов (трактов, узлов), изменении топологии сети. Такие корректировки таблиц маршрутизации осуществляются существенно реже, чем в динамических протоколах, что позволяет разработать более простые протоколы маршрутизации и уменьшить требования к вычислительной мощности устройств управления коммутаторами АТМ.
Но нельзя забывать, что хотя ШЦСИО является сетью ориентированной на соединение, но она должна поддерживать и большое количество служб, обеспечивающих обмен информацией без установления соединений, о чем говорилось выше. Это значительно усложняет проблему маршрутизации в сетях АТМ.
При решении проблемы многопротокольной передачи данных через ШЦСИО на технологии АТМ (MPOA - Multiprotocol over ATM) должен быть определен стандартный подход к поддержке таких протоколов как IP, IPX и других на магистралях АТМ. При подходе, определяемом МРОА, передачу пакетов предполагается осуществлять с помощью коммутаторов АТМ, а вычисление маршрута - на отдельном сервере. Синхронизация функционирования коммутаторов и сервера маршрутизации обеспечивается с помощью специальных программ [34].
MPOA обещает быть удобным способом интеграции интеллектуальных ЛВС в национальные и глобальные сети АТМ и появлением эффективных с точки зрения стоимости и массовых периферийных устройств, которые сделают еще один шаг на своем пути эволюционного развития от LANE к MPOA.
При централизации вычислений маршрутов многопротокольный режим в ШЦСИО означает уменьшение сложности периферийных устройств. Хотя следует отметить, что протоколы обычных маршрутизаторов ненамного сложнее по сравнению МРОА.
Интересно отметить, что такая фирма как Cisco поддерживает идеологию издания мультипротокольного режима, а ряд фирм игнорирует МРОА. Такие фирмы как 3Com, Bay Network, IBM объявили о создании альянса сетевого взаимодействия (NIA -Network Interoperability Alliance). Они предлагают в качестве единого сетевого протокола, который бы подошел и для АТМ и для существующих протоколов сетевого уровня типа IP, интегрированный частный сетевой интерфейс (Integrate PNNI).
Компанией Ipsilon Networks в качестве 3-го варианта подхода предложено интегрированное решение, при котором каждый коммутатор АТМ поддерживает маршрутизацию IP.
Сообщение электронной почты и другие потоки данных малой длительности проходит через маршрутизаторы, а потоки служб без установления соединения, но требующие переноса больших объемов данных, передаются по виртуальным соединениям. Принцип интегрального подхода компании Ipsilon Networks показан на рис. 45.

Рис. 45. Интегрированный подход компании Ipsilon Networks
к проблеме маршрутизации в сетях АТМ

Будучи проще, чем мультипротокольный режим архитектура Ipsilon использует производительность АТМ и в то же время обеспечивает совместимость с оборудованием, работающем с протоколом IP [34, 83].
Все это свидетельствует пока только одно, что выбирая производителя оборудования АТМ, мы очень часто выбираем и архитектуру маршрутизации.


ПЛОСКОСТЬ УПРАВЛЕНИЯ И ЕЕ ФУНКЦИИ

Сигнализация в ШЦСИО

Концепция сигнализации в ШЦСИО

Архитектурная модель ШЦСИО определена в Рек. I. 327 [36], согласно которой система сигнализации в ШЦСИО на технологии АТМ должна обеспечивать передачу сообщений сигнализации между (рис. 46):
- пользователем и сетью;
- пользователями;
- между транзитными коммутаторами или коммутаторами (мультиплексорами доступа).
Основным принципом сигнализации в ШЦСИО на технологии АТМ является внеполосная передача служебной информации, т.е. принцип сигнализации в ШЦСИО аналогичен принципу сигнализации в УЦСИО. Основное отличие состоит в том, что в УЦСИО для сигнализации используется сеть отдельных физических каналов, а в ШЦСИО - сеть отдельных виртуальных каналов, в которых передача пользовательской информации не производится.
Внеполосная организация сигнализации имеет целый ряд существенных преимуществ:
- сигнализация может вестись одновременно с передачей полезной информации;
- обеспечивает малое время установления соединений;
- допускает практически неограниченное множество элементов сигнализации (различных сообщений, параметров сообщений, виртуальных каналов сигнализации и т.п.), имеющихся в наличии;
- обеспечивает высокую гибкость введения новых служб и дополнительных услуг;
- дает возможность реализации устройств управления сигнализацией по хранимой в памяти программе;
- обеспечивает высокую достоверность передачи информации сигнализации и пропускную способность при приемлемой стоимости.

Рис. 46. Структурная схема сигнализации ШЦСИО

Сигнализация в ШЦСИО должна поддерживать:
- узкополосные приложения, основанные на использовании канала со скоростью 64 кбит/с;
- новые широкополосные услуги.
Таким образом, в ШЦСИО предусмотрено, с одной стороны, выполнение функций сигнализации, предусмотренных Рек. Q.931 [54], а с другой стороны, должно быть предусмотрено выполнение функций, связанных с появлением новых служб (например, мультимедиа).
Спецификация ШЦСИО на технологии АТМ требует, чтобы система сигнализации могла выполнять:
- установление, контроль и разъединение соединений виртуальных каналов с требуемым качеством обслуживания для транспортирования всех видов информации;
- реализацию соглашения по трафику, а при необходимости и его перезаключение.
Некоторые заявки могут требовать создания не одного, а нескольких виртуальных каналов для передачи голоса, видеоизображения, данных и не с одним, а с несколькими пользователями, т.е. мультисервисных и многопользовательских соединений.
Все функции сигнализации при реализации принципа внеполосной передачи информации сигнализации можно разбить на две больших группы, связанных с:
- установлением и обслуживанием вызова (Call Control);
- управлением соединений, по которым транспортируется информация пользователя (Bearer Control).
При этом желательно, чтобы большинство функций сигнализации выполнялось только на местных коммутаторах сети АТМ, т.е. на коммутаторах и мультиплексорах доступа, а транзитные коммутаторы АТМ должны быть максимально освобождены от этих функций.
Соединения между пользователями могут быть как симметричными, так и асимметричными. Кроме этого, необходимо обеспечить взаимодействие различных пользователей, имеющих и широкополосное многофункциональное оборудование, и широкополосное однофункциональное оконечное оборудование, и узкополосное цифровое терминальное оборудование или даже аналоговое с соответствующими терминальными адаптерами.
Сообщения сигнализации в ШЦСИО могут переноситься виртуальными каналами сигнализации (SVC - Signalling Virtual Channels) 4 типов [50]:
- виртуальным каналом метасигнализация (ВКМС);
- общим широковещательным виртуальным каналом сигнализации (ОШВКС);
- селективном широковещательном каналом сигнализации (СШВКС);
- виртуальным каналом сигнализация "точка-точка".
На каждом интерфейсе пользователь-сеть может организовываться виртуальный канал метасигнализации. Он является постоянным и двунаправленным. Этот вид канала используется для установления, проверки и разъединения (разрушения) селективных ШВКС и ВКС типа "точка-точка".
В то время, как виртуальный канал метасигнализации является постоянным, ВКС "точка-точка" организуется одной из оконечных точек сигнализации, когда она является активной. ВКС "точка-точка" является двунаправленным, т.е. один виртуальный канал сигнализации организуется в направлении пользователь-сеть, а второй ВКС в обратном направлении. Они используются для установления, контроля и разъединения виртуальных каналов, по которым передается пользовательская информация.
ШВКС, являясь однонаправленными, организуются в направлении от сети к пользователю и предназначены для передачи сигнальных сообщений всем оконечным точкам сигнализации сети доступа (абонентской сети) или выделенной группе оконечных точек сигнализации в случае общего ШВКС и селективного ШВКС соответственно.
Необходимо отметить, что первая серия из 13 рекомендаций, заложивших основу разработки и внедрения сетей на основе технологии АТМ, принята СС МСЭ в 1991 г. Однако, только в одной из них [50] затронуты некоторые аспекты сигнализации. Поэтому основной проблемой, которую необходимо было решить СС МСЭ, заключалась в разрешении противоречия между необходимостью быстрейшего перехода к практической реализации и внедрению в жизнь телекоммуникационных сетей на основе технологии АТМ и невозможностью сразу предоставить пользователям весь комплекс служб и дополнительных услуг из-за недостаточной проработки многих вопросов, и прежде всего сигнализации.
СС МСЭ эта проблема была решена путем разработки плана поэтапного развития системы сигнализации ШЦСИО, реализующего принцип от простого к сложному. План развития системы сигнализации в интерфейсе пользователь-сеть (табл. 9) предусматривает три этапа своего развития, названных первым, вторым и третьим выпусками.
Таблица 9
1 выпуск | 2 выпуск | 3 выпуск
Постоянная скорость передачи Службы с установлением соединения и синхронизацией между источником и получателем | Изменяющаяся скорость передачи Службы с установлением соединения Указание со стороны пользователя требуемого качества обслуживания | Распределительные (дистрибутивные) службы и мультимедиа Согласование качества обслуживания между пользователем и сетью
Соединение типа "точка-точка" (одно и двунаправленное, симметричные и асимметричные Односервисные соединения Указание пиковой скорости источника | Соединения типа "точка-многоточка" Мультисервисные соединения с возможностью увеличения (уменьшения) количества соединений во время сеанса связи Использование приоритета потери ячейки Согласование и пересогласование требуемой скорости между пользователем и сетью | Широковещательные (циркулярные)
Взаимодействие с УЦСИОВ сети доступа сигнализация "точка-точка" и "точка- многоточка" Метасигнализация Ограниченный набор дополнительных услуг | Дополнительные услуги |

В 1 выпуске предусматривается поддержка системы сигнализации служб с постоянной скоростью передачи и с установлением соединений. Если будут поддерживаться службы с изменяющейся скоростью передачи, то выделение полосы пропускания будет производиться только по пиковой скорости. С самого начала предусмотрена реализация двух конфигураций доступа, из которых один использует процедуру метасигнализации, а второй нет.
Во 2 выпуске предусматривается поддержка системы сигнализации служб с изменяющейся скоростью передачи. При этом должно быть реализовано статистическое мультиплексирование, а также разделены процессы управления вызовами и управления соединениями, что дает возможность пользователю во время сеанса связи устанавливать и разрушать соединения.
В 3 выпуске система сигнализации должна обеспечивать поддержку практически всех служб, включая и службы распределения информации, мультимедиа, а также предоставлять пользователю практически полный перечень дополнительных услуг.

Архитектура протокола сигнализации

СС МСЭ различает две конфигурации доступа к системе сигнализации в интерфейсе пользователь-сеть [55]:
- конфигурация доступа "точка-точка";
- конфигурация доступа "точка-многоточка".
При конфигурации доступа "точка-точка" на стороне пользователя имеется только одна оконечная точка сигнализации. Таким оконечным оборудованием пользователя в зависимости от конфигурации сети доступа может быть 1-сервисный терминал или интеллектуальное широкополосное сетевое окончание 2-го типа B-NT2. Для этого типа доступа требуется организация одного постоянного виртуального канала сигнализации, который используется для предложения и установления соединения, а также разъединения. Архитектура протокола сигнализации ШЦСИО для конфигурации доступа "точка-точка" приведена на рис. 47а.

Рис. 47. Архитектура протоколов сигнализации в ШЦСИО
а) -доступ точка-точка
б) - доступ точка-многоточка
в) -сетевой интерфейс в УЦСИО
г) - сетевой интерфейс в ШЦСИО

При конфигурации доступа "точка-многоточка" на стороне пользователя имеется несколько оконечных точек сигнализации. В этом случае для организации и управления другими виртуальными каналами сигнализации необходим постоянный виртуальный канал метасигнализации. Архитектура протокола сигнализации ШЦСИО для конфигурации доступа "точка-многоточка" показана на рис. 47б.
Для передачи сообщений сигнализации на транспортном уровне в сетевом интерфейсе можно использовать уже разработанную и используемую в узкополосных цифровых сетях интегрального обслуживания систему сигнализации № 7 (рис. 47в).
Вполне очевидно, что использование в ШЦСИО на технологии АТМ уже разработанной и внедренной в УЦСИО системы сигнализации № 7 (ОКС № 7) дает возможность более быстрой реализации технологии АТМ, но для ШЦСИО может быть разработана на основе ОКС № 7 своя система сигнализации, наиболее полно использующая достоинства технологии АТМ (рис. 47г).
Передача сообщений сигнализации на сетевом уровне между коммутаторами АТМ может осуществляться по протоколам эксплуатации и технического обслуживания (OAM - Operation and Maintenance) и поэтому для сетевого интерфейса метасигнализация и не нужна.

Метасигнализация

Протокол метасигнализации описан в проекте Рек. Q. 2120 [56]. Он используется для установления, поддержания и разъединения виртуальных каналов сигнализации в интерфейсе пользователь-сеть и работает только по виртуальному каналу метасигнализации.
Идентификатор виртуального канала метасигнализации в каждом виртуальном пути равен единице (VCI = 1), а его пиковая скорость по умолчанию составляет 42 яч/с.
Протокол метасигнализации предусматривает процедуры назначения, проверки и удаления виртуальных каналов сигнализации "точка-точка" и широковещательных (циркулярных) виртуальных каналов сигнализации.
Данные процедуры позволяют:
- ассоциировать оконечные точки сигнализации с типами каналов сигнализации (ОШВКС, СШВКС или ВКС "точка-точка");
- назначать скорости для ВКС;
- разрешать возможные конфликтные ситуации.
Обычно протокол метасигнализации используется между пользователем и сетью. Однако, два пользователя, которые объединены соединением виртуальных путей, также могут использовать этот протокол для управления ВКС "точка-точка" и ШВКС . Для идентификатора виртуального канала ячейка, несущая информацию метасигнализации, использует предварительно заданное значение.
Формат сообщения метасигнализации (рис. 48) не зависит от типа сообщений. Поля, которые в сообщении не используются, заполняются нулями.
Поле дискриминатора протокола (PD - Protocol Discriminator) определяет тип протокола, к которому относится сообщение. Однако, пока протокол метасигнализации - это единственный протокол, используемый в канале метасигнализации.

Рис. 48. Формат сообщения метасигнализации

Поле версии протокола (PV - Protocol Version) служит для указания используемой версии протокола и определяет общий формат сообщений. Представленный на рис. 48 формат сообщения относится к первой версии.
Поле типа сообщения (MT - Message Type) идентифицирует наименование сообщения. Оно также используется для определения назначения и подробного описания формата каждого сообщения.В протоколе метасигнализации определено 6 типов сообщений:
- запрос назначения | (ASSIGN REQUEST);
- назначено | (ASSIGN);
- отменено | (DENIED);
- запрос проверки | (CHECK REQUEST);
- ответ проверки | (СHECK RESPONSE);
- удалено | (REMOVED).
Поле идентификатора справки используется для распознавания данной процедуры назначения среди аналогичных процедур. Значение поля генерируется случайным образом терминальным устройством. Связанный с данным запросом ответ идентифицируется тем же значением идентификатора справки по принципу "на ваш исх.".
Содержимое полей идентификаторов виртуальных каналов сигнализации А и В зависит от используемой процедуры и может содержать:
- идентификатор виртуального канала сигнализации "точка-точка";
- идентификатор селективного широковещательного виртуального канала сигнализации;
- идентификатор общего широковещательного виртуального канала сигнализации.
Идентификатор общего широковещательного ВКС всегда имеет значение 2 (VCI=2), а значение идентификатора селективных ШВКС определяется во время фазы назначения.
Поле скорости ячеек в виртуальном канале сигнализации "точка-точка" определяет запрашиваемую и назначенную скорости. В настоящее время используется только пиковая скорость При работе в режиме статистического мультиплексирования кодировка поля будет расширена. Определены следующие градации скорости ячеек в ВКС "точка-точка": 42, 84, 168, 336, 672, 1344 и 2688 яч/с. По умолчании предоставляется скорость 42 яч/с.
Поле причины (CAUSE) служит для предоставления пользователю более подробной информации о причинах отправки данного сообщения (например, почему сеть послала сообщение "ОТМЕНЕНО").
Поле идентификатора профиля услуг (SPID- Service Profile Identifier) предназначено для запроса со стороны пользователя основных или дополнительных услуг.
Поле нулевого заполнения содержит нули.
Поле циклической проверки с избыточным кодом (CRC - Cyclic Redundancy Check) используется для обнаружения ошибок в сообщениях метасигнализации. Применяется производящий полином типа
G(x) = x10 + x9 + x5 + x4 + x + 1.
Все сообщения метасигнализации, соответствующие им заполнение поля и направления потоков сигнализации приведены в табл. 10.
Сообщения ЗАПРОС НАЗНАЧЕНИЯ инициируются пользователем с целью определения идентификаторов ВКС "точка-точка" и ШВКС. Сети отвечают либо сообщением НАЗНАЧЕНО, в котором сообщит значения идентификаторов, либо сообщением ОТМЕНЕНО с указанием соответствующих причин. На стороне пользователя после отправки сообщения ЗАПРОС НАЗНАЧЕНИЯ включается таймер.
Сообщение ЗАПРОС ПРОВЕРКИ инициируется сетью. Самая простая проверка относится только к одной паре идентификаторов ВКС "точка-точка" и ШВКС, в то время как самая полная проверка относится ко всем каналам сигнализации. Эта процедура также связана с таймером, но на стороне сети.
Сообщение УДАЛЕНО может быть инициировано как со стороны пользователя, так и со стороны сети. В отличие от других сообщений, требующих ответа, процедура "рукопожатия" здесь не используется. Инициирующая сторона просто через случайный промежуток времени посылает второе сообщение УДАЛЕНО.
Таблица 10
Поле сообщения | Сообщения
Запрос назначения Назначено Отменено Запрос
проверки 		Ответ
проверки 		Удалено
Дискриминатор протокола | M | M | M | M | M | M
Версия протокола | M | M | M | M | M | M
Тип сообщения | M | M | M | M | M | M
Идентификатор справки | M | M | M | A | A | A
Идентификатор ВКС А | B | M | A | M | M | M
Идентификатор ВКС Б | A | M | A | A | M | A
Скорость ячеек ВКС точка-точка | M | M | A | A | A | A
Причина | А | М | М | А | А | М
Идентификатор профиля услуг | М | М | А | А | М | А
Циклическая проверка с
избыточным кодом 		М М М М М М
Направление U->N N->U N->U N->U U->N U->N или
N->U

Примечание: А- кодируется значением "0"
B - обычно кодируется значением "0"
М - подставляется действительное значение
N->U - от сети к пользователю
U->N - от пользователя к сети

Уровень адаптации АТМ для сигнализации

Для того чтобы адаптировать протоколы сигнализации в интерфейсах пользователь-сеть и в сетевом интерфейсе к уровню АТМ, необходим соответствующий уровень адаптации АТМ, который получил наименование уровня адаптации АТМ для сигнализации (S-AAL - Signalling AAL).
    Уровень адаптации АТМ для сигнализации может быть разделен на две части (рис. 49):
  • общую часть (CP - Common Part);
  • служебно-ориентированную часть (SSP - Service-Specific Part).

Рис. 49. Структура уровня адаптации АТМ для сигнализации

В качестве общей части уровня адаптации АТМ для сигнализации могут использоваться как уровень адаптации АТМ 3/4 типа, так и уровень адаптации АТМ 5-го типа.
СС МСЭ решено использовать уровень адаптации АТМ 5-го типа, так как он более экономичен.
Для служебно-ориентированной части в интерфейсах пользователь-сеть и сетевом СС МСЭ решил использовать общий протокол, описанный в Рек. Q.2100, Q.2110, Q.2130 и Q.2140 [55, 58-60].
Достижение единого протокола для интерфейса пользователь-сеть и сетевого интерфейса обеспечивает следующие преимущества:
- уменьшает сложность сетевых узлов;
- обеспечивает гибкость функционирования сети;
- обеспечивает простоту эксплуатации и технического обслуживания сетевого оборудования;
- уменьшает стоимость производства и эксплуатации.
Однако, к сожалению, полное единство не возможно из-за различия протоколов, расположенных выше уровня адаптации АТМ. Поэтому для удовлетворения различных требований и была выбрана архитектура служебно-ориентированной части уровя адаптации АТМ для сигнализации (рис. 50).

Интерфейс пользователь-сеть Сетевой интерфейс
Элемент, решающий функции
координации между интерфейсом
пользователь-сеть и служебно-
ориентированным протоколом
(SSCFs for UNI) 		Элемент, решающий функции
координации между сетевым
интерфейсом и служебно-
ориентированным протоколом
(SSCFs for NNI)
Служебно-ориентированный протокол с установлением соединений
(SSCOP)

Рис.50. Служебно-ориентированная часть уровня
адаптации АТМ для сигнализации

Служебно-ориентированный протокол с установлением соединений (SSCOP - Service Specific Connection- Оriented Protocol) обеспечивает механизмы установления и разъединения соединений и надежный обмен информацией сигнализации между объектами сигнализации.
Основными функциями служебно-ориентированного протокола с установлением соединений являются:
- обеспечение целостности последовательности служебных блоков данных при передаче;
- обнаружение потерянных блоков с помощью механизма проверки последовательности и их восстановление методом повторной передачи;
- управление потоком с помощью динамического механизма окна;
- сообщения об ошибках в менеджмент уровня;
- поддержка активного режима, под которым понимается сохранение виртуального соединения между объектами одного уровня даже в случае длительного отсутствия переноса данных;
- установление, разъединение и восстановление соединения;
- обеспечение гарантированного и негарантированного режимов переноса сообщений между двумя равноранговыми объектами;
- обнаружение ошибок в информации управления протоколом;
- обмен между передатчиком и приемником протокола информацией состояния.
Для того чтобы протокол работал на высоких скоростях, конечные автоматы передатчика и приемника разделены. Такое разделение, использование селективной повторной передачи и динамического механизма окна для управления потоком являются основными особенностями служебно-ориентированного протокола с установлением соединений по сравнению с существующими протоколами уровня звена данных. Более подробное описание этого протокола и используемых сообщений можно найти в Рек. Q.2110 [55].
В служебно-ориентированной части уровня адаптации АТМ для сигнализации функции координации между служебно-ориентированным протоколом установления сигнальных соединений и более высокими уровнями протоколов сигнализации функции координации выполняют специальные элементы (SSCFs - Service-Specific Coordination Functions):
- | первый, преобразующий сервисные примитивы между служебно-ориентированным протоколом установления соединений и протоколом Q.2931 3-го уровня в интерфейсе пользователь-сеть (SSCFs for UNI);
- | второй, преобразующий сервисные примитивы между служебно-ориентированным протоколом установления соединений и частью переноса сообщений ОКС № 7 третьего уровня(МТР-3) и некоторых местных функций в сетевом интерфейсе (SSCFs for NNI).


СТРУКТУРА И ПРОТОКОЛЫ АТМ

Эталонная конфигурация ШЦСИО:
рекомендации СС МСЭ и спецификации Форума АТМ

На рис. 8 приведены два варианта эталонной конфигурации ШЦСИО на технологии АТМ. На рисунке 8,а представлена эталонная конфигурация в виде функциональных групп и эталонных точек согласно Рек. СС МСЭ [1,2]. На рисунке 8,б - согласно эталонной конфигурации, принятой Американским национальным институтом стандартизации (ANSI) [7,8], где под оконечной системой (ES - End System) понимается оборудование пользователя, в том числе локальная или городская вычислительная сеть АТМ, а также ЛВС типа Ethernet, Token Ring, FDDI или УПАТС, а под промежуточной системой (IS - Intermediate System) - коммутаторы доступа или транзитные коммутаторы АТМ.

Рис. 8. Эталонная конфигурация ШЦСИО:
а) - согласно СС МСЭ б) - согласно ANSI

Сети АТМ (рис. 8) подразделяются на сети АТМ общего пользования (Public Network) и частные (корпоративные) сети (Private Network).
B-NT1 служит только для завершения линий передачи и выполнения соответствующих функций эксплуатации и технического обслуживания, а B-NT2 могут быть, например, локальной или городской вычислительной сетью или устройством, выполняющим функции мультиплексирования и концентрации ячеек.
В настоящее время принято делить современные сети связи [9] на транспортную сеть (сеть коммутации), выполняющую функции переноса информации, и сеть доступа (абонентскую сеть), обеспечивающую пользователю доступ к услугам по переносу информации. Сеть доступа (CN - Customer Network, CPN - Customer Premises Network, SPN - Subscriber Premises Network) расположена на пользовательской стороне сетевого окончания B-NT1. Интерфейс между абонентской и транспортной сетями обычно расположен в точке ТВ .
Интерфейс пользователь-сеть (UNI - User-Network Interface) может быть стыком в частной сети, совпадающим с эталонной точкой SB , или стыком в сети общего пользования, совпадающим с эталонными точками ТВ или UB (рис. 8).
Сетевой интерфейс (NNI - Network Node Interface) определяется как стандартный стык между сетями или узлами сети. Форум АТМ использует этот термин для обозначения стыка между узлами частной (корпоративной) сети.


ФИЗИЧЕСКИЙ УРОВЕНЬ АТМ

Размещение ячеек в кадрах систем плезиохронной цифровой иерархии

Порядок размещения ячеек в кадрах плезиохронной цифровой иерархии (ПЦИ) определяет Рек. G. 804 [27]. Фактически сохранены полностью только битовые скорости ПЦИ, определенные в Рек. G.702 [18]. Старая структура кадров ПЦИ частично заменена на новую, которая способна поддерживать транспортирование ячеек АТМ и обеспечивать перенос сигнальных элементов ПЦИ [28].
Кадр сигнала 1,5/2 Мбит/с, определенный в Рек. СС МСЭ G. 707 [29], используется для транспортирования ячеек АТМ путем размещения их во временных слотах от 1 до 24 для 1,5 Мбит/с или от 1 до 15 и от 17 до 31 для 2 Мбит/с соответственно. Разграничение ячеек производится с помощью поля контроля ошибок в заголовке таким же механизмом как и при СЦИ.
Структура кадра ПЦИ для 34,368 Мбит/с показана на рис. 16.
Каждый кадр имеет поля полезной нагрузки (530 байт) и служебной нагрузки (7 байт). В поле полезной нагрузки размещается ровно 10 ячеек АТМ. Таким образом, пропускная способность цифрового тракта Е3:

Функции, которые поддерживает служебная нагрузка кадра, аналогичны функциям служебной нагрузки СЦИ.
Совсем другой принцип укладки ячеек используется в Северо-Американской плезиохронной цифровой системе 3-й ступени иерархии DS3. Для размещения ячеек разработан специальный протокол конвергенции физического уровня (PLCP - Physical Layer Convergence Protocol). На рис. 17 показан порядок размещения ячеек АТМ в кадре DS3 на основе протокола конвергенции физического уровня.

Рис. 16. Размещение ячеек АТМ в структуре кадра ПЦИ 3-й ступени иерархии 34,368 Мбит/с

Основным недостатком этого метода упаковки является низкая эффективность использования пропускной способности цифрового тракта, которая составляет около 90 %.

Кадрирование PLSP |  | POI | POH | Полезная нагрузка |
А1 | А2 | Р11 | Z6 | Ячейка АТМ 1 |
А1 | А2 | P10 | Z5 | 2 |
А1 | А2 | P9 | Z4 | 3 |
А1 | А2 | P8 | Z3 | 4 |
А1 | А2 | P7 | Z2 | 5 |
А1 | А2 | P6 | Z1 | 6 |
А1 | А2 | P5 | X | 7 |
А1 | А2 | P4 | B1 | 8 |
А1 | А2 | P3 | C1 | 9 |
А1 | А2 | P2 | X | 10 |
А1 | А2 | P1 | X | 11 |
А1 | А2 | P0 | C1 | 12 | Хвостовик
1 окет | 1 окет | 1 окет | 1 окет | 53 окета |

Рис. 17. Размещение ячеек АТМ протоколом конвергенции физического уровня в структуре кадра DS3


Ссылки

Ссылки на информационные ресурсы, посвященные технологии АТМ.

http://www.atmforum.com | Крупнейший англоязычный сервер, посвященный АТМ.
http://www.citforum.ru | Сервер содержит много разнообразной технической информации, в том числе по теме АТМ.
http://www.setevoi.ru | Ежемесячный журнал по сетевым технологиям.
http://www.nis.nnov.ru | Сайт компании "Нижегородские информационные сети".
http://www.pluscom.ru | Plus Communications Online
http://forum.osp.ru | Издание Открытые системы.
http://www.ccc.ru | Журнал Сети и системы связи.
http://www.anpa.com | Сервер ассоциации ATM Network Planners Association.

Design by Alex Vasilev


Главная страница

Добро пожаловать

в систему дистанционного обучения по дисциплине"ШЦСИО (Широкополосная Цифровая Сеть Интегрального Обслуживания): структура и эталонная модель протоколов".

На этом сайте Вы сможете ознакомиться с материалом данного учебного курса, а также проверить полученные знания, ответив на вопросы теста. Кроме этого, на сайте собранны ссылки на различные информационные ресурсы в сети Internet, посвященные технологии АТМ.
Более подробная информация о проекте находится здесь.

Design by Alex Vasilev


Обучающий курс ШЦСИО

Гостевая книга: задайте интересующие Вас вопросы или выскажете своё мнение о сайте.
Преход на главную страницу проекта.
Оглавление учебного материала по дисциплине ШЦСИО: структура и эталонная модель протоколов
Тут Вам предстоит проверить своё знание учебного материала, ответив на предложенные вопросы.
Ссылки на статьи и сайты посвященные технологии АТМ, а также на другие интересные информационные ресурсы.
Сайт Санкт-Петербургского Государственного Университета Телекоммуникаций им. М.А. Бонч-Бруевича.
Страница кафедры ОПДС
СПб ГУТ им. проф. М.А.Бонч-Бруевича
Информация о данной системе дистанционного обучения, о ее авторах и просто полезные сведения.