Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | Шина ISA

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] Шина ISA
6. Временные диаграммы шины ISA

В таблицах этой главы приведены временные соотношения для всех циклов, объясненных в предыдущей главе. Все времена приведены для частоты SYSCLK= 8 МГц, поэтому, если проектируемая внешняя плата должна работать в компьютерах с частотой SYSCLK до 16 МГц, то следует ужесточить требования к быстродействию внешней платы не менее чем в два раза по сравнению с приведенными. Для ресурсов все времена измерены на разъеме ресурса доступа. Время в пределах 0...11 нс добавлено для учета времени распространения сигнала по шине. В некоторых случаях сигнал возвращается от ресурса, который был источником сигнала, синхронизированного с возвращаемым и в этом случае добавлено 0...22 нс. Время "0" означает теоретически минимально возможное время и используется только как расчетное при определении времени цикла.

ПРИМЕЧАНИЕ: В таблицах и временных диаграммах приведены только сигналы -MEMR и -MEMW, а не -SMEMR и -SMEMW. Сигналы -SMEMR и -SMEMW вырабатываются с задержкой от 0 до 10 нс относительно сигналов -MEMR и -MEMW в тех случаях, когда ЦП, контроллер ПДП или контроллер регенерации является задатчиком на шине. Если задатчиком на шине является внешняя плата, то задержка может быть увеличена до 22 нс.

ПРИМЕЧАНИЕ: Во всех таблицах временных диаграмм TCLK обозначает период тактовой частоты шины.

Таблица 6.1. Временные соотношения для циклов с 0 тактов ожидания, нормальных и удлиненных, для 16- и 8-разрядных ресурсов памяти и УВВ.

N параметра | Наименование | Задатчик на шине (нс) |  | Ресурс доступа (нс)
 |  | Мин | Макс | Мин | Макс
1 | LA<23...17> устанавливается до BALE | 61 |  | 50 |
2 | Ширина импульса BALE | 61 |  | 50 |
3 | LA<23...17> сохраняется после BALE | 26 |  | 15 |
4 | LA<23...17> устанавливается до команды для 16-разрядной памяти [1] | 120 |  | 109 |
5 | -MEM CS16 истинный от LA<23...17> |  | 102 |  | 66
6 | -MEM CS16 удерживается после LA<23...17> | 0 | 0 |  |
7a | SA<19...0> устанавливается до команды для 16-разрядной памяти | 39 |  | 28 |
b | SA<19...0> устанавливается до команды для 16- или 8-разрядного УВВ |  | 102 |  | 91
c | -SBHE устанавливается до команды для 16-разрядной памяти | 49 |  | 38 |
d | -SBHE устанавливается до команды для 16- или 8-разрядного УВВ | 112 |  | 101 |
8a | Длительность команд записи/чтения при доступе к 16-разрядной памяти (нормальный или удлиненный цикл) | 250 |  | 239 |
b | Длительность команд записи/чтения при доступе к 16-разрядным УВВ (нормальный или удлиненный цикл) | 187 |  | 176 |
c | Длительность команд записи/чтения при доступе к 16-разрядной памяти (0 тактов ожидания цикл) | 125 |  | 114 |
d | Длительность команд записи/чтения при доступе к 8-разрядным ресурсам (нормальный или удлиненный цикл) | 530 |  | 519 |
9 | SA<19...0> устанавливается до BALE | 40 |  | 29 |
10a | Время установления данных после сигнала чтения 16-разрядной памяти |  | 209 |  | 187
b | Время установления данных после сигнала чтения 16- разрядного УВВ |  | 132 |  | 110
c | Время установления данных после сигнала чтения 16-разрядной памяти для цикла с 0 тактов ожидания |  | 132 |  | 110
 | d Время установления данных после сигнала чтения 8-разрядного УВВ |  | 489 |  | 467
11a | Время установления данных в цикле записи в 16-разрядную память | 29 |  | 40 |
b | Время установления данных в цикле записи в 16-разрядное УВВ | 33 |  | 22 |
c | Время установления данных в цикле записи в 8-разрядный ресурс | 33 |  | 22 |
12 | SA<19...0>, -SBHE снимаются после командного сигнала | 22 |  | 11 |
13a | Время выключения команды при доступе к 16-разрядному ресурсу | 125 |  | 114 |
b | Время выключения команды придоступе к 8-разрядному ресурсу | 187 |  | 176 |
14 | Время установления данных при чтении до снятия команды | 40 |  | 62 |
15a | Удержание данных при чтении | 0 |  | 0 |
b | Удержание данных при записи | 30 |  | 30 |
16 | Перевод сигналов SD<15...0> в третье состояние после снятия команды | 32 |  | 32 |
17 | -0WS истинный от команды | 40 |  | 18 |
18 | -I/O CS16 истинный от SA<19...0> |  | 126 |  | 90
19 | -I/O CS16 удерживается после снятия SA<19...0> | 0 |  | 0 |
20a | I/O CH RDY в лог."0" от 16-разрядной команды |  | 66 |  | 44
b | I/O CH RDY в лог."0" от 8-разрядной команды |  | 378 |  | 356
21 | I/O CH RDY длительность в лог."0" TCLK | 15600 | TCLK | 15600 |
22 | Снятие командного сигнала после разрешения I/O CH RDY | TCLK |  | TCLK |
23 | Разрешение BALE после снятия команды | 50 |  | 61 |
24 | Период тактовой частоты (TCLK) | 125 | 167 | 125 | 167
25 | Данные устанавливаются до разрешения I/O CH RDY |  |  | 63 |
26 | LA<23...17> удерживается после разрешения команды обращения к памяти | 41 |  | 30 |
27 | Длительность -0WS | 125 |  | 125 |
28 | -0WS устанавливается до спада SYSCLK |  |  | 10 |
29 | -0WS удерживается после спада SYSCLK |  |  | 20 |

Примечание: (1) LA<23...17> вырабатываются так же как SA<19...0>, если задатчик на шине не центральный процессор.

Табл. 6.2. Временные соотношения для цикла регенерации памяти.

N параметра | Наименование | Контроллер регенерации (нс) |  | Внешняя плата (нс)
 |  | Мин | Макс | Мин | Макс
1 | Длительность -MEMR/-SMEMR | 250 |  | 239 |
2 | SA<19...0> устанавливается до-MEMR | 125 |  | 114 |
3 | SA<19...0> удерживается после завершения команды | 10 |  | 21 |
4 | I/O CH RDY в лог."0" от -MEMR/-SMEMR |  | 81 |  | 59
5 | -MEMR снимается после разрешения I/O CH RDY | 125 | 250 | 125 | 261
6 | -REFRESH устанавливается до -MEMR | 250 |  | 239 |
7 | -REFRESH удерживается после запрещения -MEMR (1) | 125 | 250 | 125 | 211
8 | SA<19...0> и -MEMR удерживаются в третьем состоянии после запрещения -MEMR |  | TCLK |  |
9 | Длительность лог."0" I/O CH RDY | TCLK |  | TCLK |
10 | Задержка возвращения управления шиной после запрещения -REFRESH | 2TCLK |  | 2TCLK |

ПРИМЕЧАНИЕ: (1) Сигнал -REFRESH может удерживаться длительное время для выполнения нескольких циклов регенерации памяти.

Таблица 6.3. Временные соотношения для циклов ПДП

N параметра | Наименование | Внешняя плата как источник или контроллер ПДП (нс) |  | Внешняя плата как приемник (нс)
 |  | Мин | Макс | Мин | Макс
1 | -DACK, AEN устанавливаются до -I/OR, -I/OW | 145 |  | 134 |
2 | Адрес устанавливается до команды | 102 |  | 91 |
3a | -I/OR устанавливается до -MEMW | 235 |  | 224 |
b | -MEMR устанавливается до -I/OW | 30 |  | 19 |
4a | Данные устанавливаются от -I/OR(1) |  | 230 |  | 241
b | Данные устанавливаются от -MEMR(1) |  | 261 | 272 |
5a | Данные устанавливаются до разрешения -MEMW |  |  | -21 |
b | Данные устанавливаются до разрешения -I/OW |  |  | -214 |
6 | Команда чтения удерживается после запрещения команды записи | 50 |  | 39 |
7 | Адрес удерживается после запрещения команд | 50 |  | 39 |
8 | Данные удерживаются после запрещения команд(1) | 50 |  | 39 |
9 | I/O CH RDY в лог."0" от команды обращения к памяти (1) |  | 125 |  | 90
10 | T/C устанавливается до команды | -60 | 60 | -49 | 49
11 | T/C удерживается после запрещения команды | -60 | 60 | -49 | 49
12a | Длительность -I/OR | 700 |  | 689 |
b | Длительность -MEMR | 450 |  | 439 |
13a | Длительность -I/OW | 400 |  | 389 |
b | Длительность -MEMW | 650 | 639 |  |
14 | -DACK удерживается после запрещения команды | 60 |  | 49 |
15 | AEN удерживается после запрещения команды | 60 |  | 49 |
16 | DRQ активный от разрешения команды |  | 119 |  | 141
17 | Длительность лог."0" I/O CH RDY | TCLK |  | TCLK |

ПРИМЕЧАНИЕ: (1) Не для контроллера ПДП, а для внешней платы.

Таблица 6.4. Временные соотношения для цикла захвата шины

N параметра | Наименование | ЦП, контроллер ПДП, контроллер регенерации (нс) |  | Внешняя плата (нс)
 |  | Мин | Макс | Мин | Макс
1 | DACK разрешается после разрешения DRQ (1) |  |  |  |
2 | Задержка -MASTER от -DACK 0 |  |  |  |
3 | Контроллер ПДП переводит свои выходы в третье состояние | 0 | 49 |  |
4 | AEN удерживается после разрешения -MASTER | 0 | 49 |  |
5 | Внешняя плата начинает вырабатывать сигналы адреса, данных и командные сигналы |  |  | 60 |
6 | Сигнал -MASTER удерживается после запрещения DRQ |  |  |  | 100
7 | Сигнал -DACK удерживается послезапрещения DRQ (2) | 0 |  | 0 |
8 | Внешняя плата переводит свои выходы в третье состояние до запрещения сигнала -MASTER |  |  | 0 |
9 | ЦП начинает вырабатывать свои сигналы после запрещения сигнала -MASTER | 0 |  |  |
10 | DRQ удерживается запрещенным после запрещения -DACK |  |  | 0 |

ПРИМЕЧАНИЯ: (1) Точные временные интервалы определяются контроллером ПДП. (2) Сигнал DRQ должен оставаться запрещенным, пока разрешен сигнал -DACK.

Файлы с графической иллюстрацией временных диаграмм шины ISA можно переписать здесь. Названия имен файлов соответствует следующим рисункам:

Рис. 6.1. Цикл доступа к 16-разрядной памяти с 0 тактом ожидания

Рис. 6.2. Нормальный и удлиненный цикл записи/чтения 16-разрядной памяти

Рис. 6.3. Нормальный и удлиненный цикл записи/чтения 16-разрядного устройства ввода/вывода

Рис. 6.4. Нормальный и удлиненный цикл записи/чтения 8-разрядной памяти

Рис. 6.5. Нормальный и удлиненный цикл записи/чтения 8-разрядного устройства ввода/вывода

Рис. 6.6. Нормальный и удлиненный цикл регенерации: 1 - Время разрешения сигнала -REFRESH может быть увеличено для выполнения нескольких циклов регенерации; 2 - Текущий задатчик на шине должен перевести сигналы адреса и команд в третье состояние до разрешения сигнала REFRESH.

Рис. 6.7. Нормальный и удлиненный циклы ПДП: 1 - DRQ может стать отрицательным в любое время после -DACK; 2 - IO/ CH RDY запрещается для вставки дополнительных тактов ожидания. Каждый дополнительный такт ожидания состоит из двух тактов SYSCLK; 3 - Контроллер ПДП активизирует сигнал TC в течении последней пересылки данных

Рис. 6.8. Цикл захвата шины: (1) - Контроллер ПДП; (2) - Внешняя плата

7. Характеристики соединителей на шине

7.1. Назначение выводов соединителей, устанавливаемых в слоты

Назначение выводов соединителей показано сверху вниз (при установленной внешней плате сторона компонентов соответствует правой половине соединителей, а место установки крепежной планки - верху).

36-выводный [8/16] соединитель:

Сигнал | Вывод | Вывод | Сигнал
-MEM CS16 | D1 | C1 | -SBHE
-I/O CS16 | D2 | C2 | LA23
IRQ10 | D3 | C3 | LA22
IRQ11 | D4 | C4 | LA21
IRQ12 | D5 | C5 | LA20
IRQ15 | D6 | C6 | LA19
IRQ14 | D7 | C7 | LA18
-DACK0 | D8 | C8 | LA17
DRQ0 | D9 | C9 | -MEMR
-DACK5 | D10 | C10 | -MEMW
DRQ5 | D11 | C11 | SD8
-DACK6 | D12 | C12 | SD9
DRQ6 | D13 | C13 | SD10
-DACK7 | D14 | C14 | SD11
DRQ7 | D15 | C15 | SD12
+ 5 В | D16 | C16 | SD13
-MASTER | D17 | C17 | SD14
Корпус (GND) | D18 | C18 | SD15

62-выводный [8] соединитель:

Сигнал | Вывод | Вывод | Сигнал
Корпус (GND) | B1 | A1 | -I/O CH CK
RESET DRV | B2 | A2 | SD7
+ 5 В | B3 | A3 | SD6
IRQ9 | B4 | A4 | SD5
- 5 В | B5 | A5 | SD4
DRQ2 | B6 | A6 | SD3
- 12 В | B7 | A7 | SD2
-0WS | B8 | A8 | SD1
+ 12 В | B9 | A9 | SD0
Корпус (GND) | B10 | A10 | I/O CH RDY
-SMEMW | B11 | A11 | AEN
-SMEMR | B12 | A12 | SA19
-I/OW | B13 | A13 | SA18
-I/OR | B14 | A14 | SA17
-DACK3 | B15 | A15 | SA16
DRQ3 | B16 | A16 | SA15
-DACK1 | B17 | A17 | SA14
DRQ1 | B18 | A18 | SA13
-REFRESH | B19 | A19 | SA12
SYSCLK | B20 | A20 | SA11
IRQ7 | B21 | A21 | SA10
IRQ6 | B22 | A22 | SA9
IRQ5 | B23 | A23 | SA8
IRQ4 | B24 | A24 | SA7
IRQ3 | B25 | A25 | SA6
-DACK2 | B26 | A26 | SA5
T/C | B27 | A27 | SA4
BALE | B28 | A28 | SA3
+ 5 В | B29 | A29 | SA2
OSC | B30 | A30 | SA1
Корпус (GND) | B31 | A31 | SA0

7.2. Электрические характеристики сигналов

Аббревиатуры, раскрытые ниже, будут использоваться далее при рассмотрении требований к характеристикам сигналов на шине.

ТРИ - выход с тремя состояниями. Имеет состояния: активный низкий уровень, активный высокий уровень, выключено;

ОК - открытый коллекторный выход. Имеет состояния: активный низкий уровень, выключено;

ТТЛ - выход транзисторно-транзисторной логики с двумя состояниями. Имеет состояния: активный низкий уровень, активный высокий уровень;

Iih - входной ток высокого уровня. Такой ток возникает тогда, когда ко входу подключен выход с активным высоким уровнем;

Iil - входной ток низкого уровня. Такой ток возникает тогда, когда ко входу подключен выход с активным низким уровнем.

Ioh - выходной ток высокого уровня. Характеризует нагрузочную способность выхода устройства в активном высоком уровне;

Iol - выходной ток низкого уровня. Характеризует нагрузочную способность выхода устройства в активном низком уровне;

Vih - входное напряжение высокого уровня;

Vil - входное напряжение низкого уровня;

Voh - выходное напряжение высокого уровня;

Vol - выходное напряжение низкого уровня.

Напряжения и токи по цепям сигналов на шине.

На шине ISA могут использоваться только три типа устройств: ТТЛ (транзисторно-транзисторной логики), ТРИ (трехстабильный) и ОК (открытый коллекторный выход). Устройство ТТЛ может быть только фиксированного направления - либо вход, либо выход. Устройство с тремя состояниями может быть как входом так и выходом, и кроме этого, находиться в третьем состоянии.

Таблица 7.1. Напряжения и токи на шине

 | ТТЛ |  | ТРИ |  |  | ОК (1)
 | передатчик | приемник | передатчик | приемник | ТРИ | передатчик
Iil | - | -0.8 | - | -0.8 | -0.4 | -0.4(2)
Iih | - | 0.04 | - | 0.04 | 0.04 | 0.02
Iol | 24 | - | 24 | - | 0.4 | 24
Ioh | -3 | -3 | -3 | - | -0.04 | (3)

ПРИМЕЧАНИЯ:

(1) Voh=2.4 В Vih=2.7 В Vol=0.5 В Vil=0.4 В

Все токи в таблице указаны в миллиамперах. Знак "-" перед значением тока означает, что ток вытекает из внешней платы в кросс материнской платы.

(2) Линия с открытым коллекторным выходом может быть подключена к ТТЛ входу.

(3) По линии с открытым коллекторным выходом ток Ioh (ток утечки) не должен превышать для каждого слота 0.4 миллиампера.

7.4. Дополнительные требования к приемникам и передатчикам на внешних платах

Разработка собственных внешних плат требует соблюдения еще ряда условий, кроме оговоренных в табл. 7.4. Это следующие условия:

  • при проектировании топологии печатного монтажа на внешней плате, следует учитывать, что максимальная длина печатного проводника от контакта разъема до вывода подключенного к этой цепи компонента не должна превышать 65 мм;
  • для минимизации помех на шине, уменьшения переотражений следует использовать компоненты с крутизной фронта нарастания/спада выходного напряжения не хуже 3 нс.
  • максимальная емкость по каждому выводу интерфейсного разъема должна быть не более 20 пФ. В эту емкость входят входные емкости всех приемников и передатчиков, подсоединенных к выводу, и, кроме этого, емкость печатного проводника, связывающего вывод разъема с компонентами.

Таблица 7.2. Номиналы резисторов и способ подключения

Сигнал | На + 5 В | Последовательно
-I/O CH CK | 4.7 кОм | -
I/O CH RDY | 1.0 кОм | -
-I/O CS16 | 300 Ом | -
I/OR | 4.7 кОм | 22 Ом
I/OW | 4.7 кОм | 22 Ом
-MASTER | 300 Ом | -
-MEM CS16 | 300 Ом | -
-MEMR | 4.7 кОм | 22 Ом
-MEMW | 4.7 кОм | 22 Ом
OSC | - | 22 Ом
-REFRESH | 300 Ом | -
-SMEMR | 4.7 кОм | 22 Ом
-SMEMW | 4.7 кОм | 22 Ом
SYSCLK | - | 27 Ом
-0WS | 300 Ом | -

7.5. Нагрузочные резисторы на шине

На кроссе материнской платы установлены нагрузочные резисторы для оптимизации электрических характеристик шины. Нагрузочные резисторы подключаются двумя способами:

  • между линией сигнала и + 5 В;
  • последовательно между ресурсом на материнской плате и линией сигнала на шине.

7.6. Механические характеристики внешней платы

При разработке внешней платы следует также учитывать следующее:

  • толщина платы должна быть 1.6 мм +- 0.2 мм (с учетом толщины фольги);
  • коробление платы не должно превышать 1.3 мм на всей длине платы;
  • максимальная высота компонентов на плате не более 10 мм.

Страницы: 1 2

1997-2006 © Компания Сплайн. При полном или частичном
использовании материалов ссылка на наш сайт обязательна.


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | Шина ISA

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] Шина ISA

Содержание:

1. Введение
1.1. Виды устройств, работающие на шине ISA
2. Характеристики задатчиков на шине
2.1. Центральный процессор
2.2. Контроллер ПДП
2.3. Внешняя плата
2.4. Режимы прямого доступа к памяти или к устройствам ввода/вывода
2.5. Режим сброса
2.6. Контроллер регенерации памяти
 3. Общее описание шины ISA
 3.1. Адресное пространство при обращении к памяти
 3.2. Адресное пространство для устройств ввода/вывода
3.3. Структура прерываний
3.4. Перестановщик байтов
 4. Описание сигналов на шине ISA
 4.1. Сигналы адреса
 4.2. Командные сигналы
4.3. Центральные сигналы управления
 4.4. Сигналы прерывания
 4.5. Сигналы режима ПДП
 4.6. Питание
5. Циклы шины
5.1. Цикл Доступа к Ресурсу
5.1.1. Цикл Доступа к Ресурсу - 0 тактов ожидания
5.1.2. Цикл Доступа к Ресурсу - Нормальный цикл
 5.2. Цикл Регенерации - Введение
 5.1.3. Цикл Доступа к Ресурсу - Удлиненный цикл
5.2.1. Цикл Регенерации - Нормальный цикл
5.2.2. Цикл Регенерации - Удлиненный цикл
5.3. Цикл ПДП
 5.3.1. Цикл ПДП - Нормальный цикл
5.3.2. Цикл ПДП - Удлиненный цикл
5.4. Цикл Захвата Шины
6. Временные диаграммы шины ISA
7. Характеристики соединителей на шине
7.1. Назначение выводов соединителей, устанавливаемых в слоты
7.2. Электрические характеристики сигналов
7.4. Дополнительные требования к приемникам и передатчикам на внешних платах
7.5. Нагрузочные резисторы на шине
7.6. Механические характеристики внешней платы

1. Введение

Шина ISA (Industrial Standart Arhitecture) является фактически стандартной шиной для персональных компьютеров типа IBM PC/AT и совместимых с ними. Шина EISA, с которой ряд фирм выпускал персональные компьютеры, уступила шине PCI и в настоящее время используется редко.

Основные отличия шины ISA персонального компьютера IBM PC/AT от своей предшественницы - шины компьютера IBM PC/XT заключаются в следующем:

  • шина AT компьютеров позволяет использовать на внешних платах как 16-разрядные устройства ввода/вывода, так и 16-разрядную память;

  • цикл доступа к 16-разрядной памяти на внешней плате может быть выполнен без вставки тактов ожидания;

  • объем непосредственно адресуемой памяти на внешних платах может достигать 16 Мб;

  • внешняя плата может становиться хозяином (задатчиком) на шине и самостоятельно осуществлять доступ ко всем ресурсам как на шине, так и на материнской плате.

1.1. Виды устройств, работающие на шине ISA

При описании шины целесообразно представить компьютер как состоящий из материнской платы (motherboard) и внешних плат, которые взаимодействуют между собой и ресурсами материнской платы через шину. Все пассивные устройства (не могущие стать задачиками) на шине можно разделить на две группы - память и устройства ввода/вывода (порты). Циклы доступа для каждой из групп отличаются друг от друга как по временным характеристикам, так и по вырабатываемым на шине сигналам.

Чисто условно, для удобства понимания функционирования шины ISA, будем считать, что на материнской плате компьютера существуют следующие устройства, способные быть владельцами (задатчиками) шины: центральный процессор (ЦП), контроллер прямого доступа в память (ПДП), контроллер регенерации памяти (КРП). Кроме этого, задатчиком на шине может быть и внешняя плата. При выполнении цикла доступа на шине задатчиком может быть только одно из устройств. Рассмотрим подробнее функции этих устройств на шине ISA.

Центральный процессор (ЦП) - является основным задатчиком на шине. По умолчанию именно ЦП будет считаться задатчиком на шине. Контроллер ПДП, а также контроллер регенерации памяти запрещают работу ЦП на время своей работы.

Контроллер ПДП - это устройство связано с сигналами запроса на режим ПДП и сигналами подтверждения режима ПДП. Активный сигнал запроса на ПДП будет разрешать последующий захват шины контроллером ПДП для передачи данных из памяти в порты вывода или из портов ввода в память.

Контроллер регенерации памяти - становится владельцем шины и генерирует сигналы адреса и чтения памяти для регенерации информации в микросхемах динамической памяти как на материнской памяти, так и внешних платах.

Внешняя плата - взаимодействует с остальными устройствами через разъем на шине ISA. Может становиться задатчиком на шине для доступа к памяти или устройствам ввода/вывода.

Кроме этого, на материнской плате компьютера имеется ряд устройств, которые не могут быть задатчиками на шине, но тем не менее взаимодействуют с ней. Это следующие устройства:

Часы реального времени (Таймер-счетчик) - это устройство состоит из часов реального времени для поддержки даты и времени и таймера, как правило на базе микросхемы Intel 8254A. Один из таймеров-счетчиков этой микросхемы вырабатывает импульсы с периодом 15 микросекунд для запуска контроллера регенерации памяти на регенерацию.

Кросс материнской платы - часть материнской платы, которая соединяет разъемы шины ISA для подключения внешних плат с другими ресурсами на материнской плате.

Память на материнской плате - часть или все микросхемы памяти прямого доступа (ОЗУ), используемые для хранения информации ЦП. На внешних платах также могут быть размещены микросхемы дополнительной памяти.

Контроллер прерываний - это устройство связано с линиями запросов прерываний на шине. Прерывания требуют дальнейшего обслуживания ЦП.

Устройства ввода/вывода - часть или все устройства ввода/вывода (такие как параллельные или последовательные порты) могут размещаться как на материнской плате, так и на внешних платах.

Перестановщик байтов данных - это устройство позволяет обмениваться данными между собой 16-разрядными и 8-разрядными устройствами.

Архитектура персонального компьютера IBM PC/AT с точки зрения использования шины ISA показана на рисунке.

Внешние платы, устанавливаемые в разъемы шины, могут быть 8- и/или 16-разрядными. 8-разрядная плата имеет только один интерфейсный разъем и может оперировать только с 8-разрядными данными. 8-разрядный слот также не может быть задатчиком на шине. 16-разрядная плата обязательно имеет два интерфейсных разъема - один основной, такой же как в 8-разрядных платах, и один дополнительный. Такая плата может оперировать как с 8-, так и с 16-разрядными данными и, кроме этого, она может быть задатчиком на шине. Общее число устанавливаемых в разъемы шины плат ограничивается как нагрузочной способностью шины, так и конструктивным исполнением материнской платы. Как правило, допускается устанавливать не более 8 (пять 16-разрядных и три 8-разрядных) внешних плат на шину. Такое ограничение вызвано также и относительно небольшим количеством свободных линий запросов на ПДП и запросов на прерывания, имеющихся на шине.

2. Характеристики задатчиков на шине

2.1. Центральный процессор

Центральный процессор по умолчанию является основным владельцем шины, контроллер ПДП и контроллер регенерации памяти могут стать задатчиками на шине, только предварительно запретив работу ЦП. Процесс запрещения работы ЦП состоит в выработке сигнала запроса на ПДП и приема сигнала подтверждения ПДП.

Центральный процессор может быть источником как 16-разрядных операций, так и 32-разрядных. Когда ЦП является 16-разрядным ресурсом, он может выполнять операции как с 16-, так и с 8-разрядными ресурсами на шине. При выполнении ЦП команды, оперирующей с 16-разрядными данными, если ресурс доступа 8- разрядный, то специальными аппаратными средствами на материнской плате в этом случае выполняются два цикла доступа. Если же ЦП является 32-разрядным, то аппаратно на материнской плате компьютера один 32-разрядный цикл работы ЦП с внешним ресурсом должен быть преобразован в два индивидуальных 16-разрядных цикла доступа.

Особенности для внешних плат. Если ЦП является задатчиком на шине, то внешние платы могут функционировать только в режиме памяти или устройства ввода/вывода.

2.2. Контроллер ПДП

Сигналы для поддержки ПДП заводятся с разъема непосредственно на контроллер ПДП, выполненный, как правило, на микросхеме Intel 8237A. Когда режим ПДП запрашивается каким-либо устройством (хотя бы один из сигналов DRQ становится активным), контроллер ПДП осуществляет захват шины у ЦП. Выдача затем соответствующего сигнала -DACK означает, что контроллер ПДП начал передачу данных. Циклы ПДП не будут выполняться на шине, если сигнал -MASTER будет разрешен с какой-либо внешней платы.

Если запрос на ПДП требуется устройству ввода/вывода, то следует учесть, что каналы 0...3 ПДП поддерживают передачу только 8-разрядных данных; все данные должны передаваться только по линиям SD<7...0>. Перестановка байтов в этом случае выполняется аппаратно на материнской плате в соответствии с сигналами SA0 и -SBHE. Такая перестановка может потребоваться, например, при передаче данных из старшего байта 16-разрядной памяти в 8-разрядный порт. Каналы ПДП 5...7 поддерживают передачу только 16-разрядных данных; все данные должны передаваться как 16-разрядные по линиям SD<15...0>. Память, участвующая в работе в режиме ПДП по этим каналам, должна быть только 16-разрядной. Перестановщик байтов на материнской плате не будет корректировать несоответствие размеров данных.

ПРИМЕЧАНИЕ: 8-разрядная память со своей стороны может передавать данные в режиме ПДП только 8-разрядным устройствам ввода/вывода; использование 8-разрядной памяти с 16-разрядными устройствами ввода/вывода не допускается.

ВНИМАНИЕ! Контроллер регенерации памяти не может захватить шину до тех пор, пока контроллер ПДП ей владеет. Это означает, что любой цикл ПДП не должен превышать 15 мкс. В противном случае может произойти потеря информации в микросхемах динамической памяти.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Сигналы запроса и подтверждения режима ПДП заведены на все внешние платы и эти сигналы вырабатываются обычными ТТЛ выходами, поэтому все внешние платы должны использовать и анализировать различные каналы ПДП. В противном случае возможен конфликт внешних слотов между собой или с устройствами на материнской плате.

Внешние слоты могут быть или памятью прямого доступа или устройством ввода/вывода, когда они взаимодействуют с контроллером ПДП.

2.3. Внешняя плата

Внешние платы могут функционировать в 5 различных режимах: задатчика шины, памяти и устройств ввода/вывода прямого доступа, памяти и устройств ввода/вывода, регенерации памяти или сброса. Платы могут поддерживать любую комбинацию из первых четырех режимов; сигналу сброса должны подчиниться все платы одновременно.

Только 16-разрядные платы с двумя интерфейсными разъемами могут становиться задатчиками на шине. Для захвата шины внешняя плата должна разрешить сигнал -DRQ и, получив сигнал -DACK от контроллера ПДП, разрешить сигнал -MASTER. На этом процедура захвата шины заканчивается.

Внешняя плата, захватив шину, может выполнять любые циклы доступа, так же как центральный процессор. Единственное ограничение - невозможность выполнять циклы ПДП, так как все интерфейсные сигналы, управляющие работой контроллера ПДП, заведены на материнскую плату и не могут быть использованы контроллером ПДП, находящимся на внешней плате. Когда внешняя плата является задатчиком на шине, контроллер ПДП запрещает сигнал AEN и это позволяет устройствам ввода/вывода нормально дешифрировать адрес и быть доступными для внешней платы. При запрещенном сигнале AEN циклы передачи ПДП невозможны (подробнее в разделе описания сигнала AEN, в гл. 3). Кроме этого, циклы ПДП не могут быть выполнены на шине также и потому, что у контроллера ПДП канал, через который был осуществлен захват шины, занят, а другие каналы контроллера ПДП не могут быть использованы до освобождения ранее занятого, т.е. до освобождения шины захватившей ее внешней платой.

ПРИМЕЧАНИЕ: Программное обеспечение, поддерживающее работу внешней платы в качестве задатчика шины, должно обеспечивать использование каналов ПДП только в режиме каскадирования. В противном случае внешняя плата не сможет осуществить захват шины.

ПРИМЕЧАНИЕ: Внешняя плата начинает любой цикл доступа как 16-разрядная, однако если сигнал -MEM CS16 или -I/O CS16 не будет разрешен, цикл будет завершен как 8-разрядный. При этом перестановщик байтов на материнской плате будет определять, по каким линиям данных (SD<15...8> или SD<8...0>) передается байт информации, исходя из анализа сигналов -SBHE и SA0.

ВНИМАНИЕ! Захватившая шину внешняя плата обязана не реже, чем через 15 мкс, вырабатывать сигнал -REFRESH для запроса контроллеру регенерации на регенерацию памяти. Контроллер регенерации при выполнении цикла регенерации памяти вырабатывает сигналы адреса, команд и анализирует сигнал I/O CH RDY, но внешняя плата, выработавшая сигнал -REFRESH, по завершении цикла регенерации снимает этот сигнал и продолжает оставаться задатчиком на шине. При необходимости выполнить несколько циклов регенерации сигнал -REFRESH может быть удержан внешней платой на все время требуемого количества циклов регенерации.

Контроллер регенерации памяти не может захватить шину сам до тех пор, пока контроллер ПДП (а именно через него внешняя плата становится задатчиком на шине) не освободит ее на время регенерации по сигналу -REFRESH.

2.4. Режимы прямого доступа к памяти или к устройствам ввода/вывода

Внешняя плата может работать в режиме ПДП только в том случае, если контроллер ПДП является задатчиком на шине. В режиме прямого доступа к памяти данные всегда передаются между устройством ввода/вывода и памятью на внешней плате. В режиме прямого доступа к устройству ввода/вывода данные передаются между памятью и устройством ввода/вывода на внешней плате. Внешняя плата, отвечающая на шине как 8- или 16-разрядное устройство, должна соответственно использовать 8- или 16- разрядные каналы контроллера ПДП. В табл. 2.2 показано состояние сигналов на шине для режима ПДП.

ВНИМАНИЕ! Следует специально обратить внимание на некоторые особенности при выполнении циклов передачи данных между 8-разрядными устройствами ввода/вывода и 16-разрядной памятью на внешней плате. Во-первых, внешняя плата должна анализировать сигналы -SBHE и SA0 для правильного определения передаваемых данных.

Во-вторых, при записи в УВВ из памяти на внешней плате перестановщик байтов на материнской плате будет определять, по какой половине шины данных (SD<15...8> или SD<7...0>) следует направить байт; внешняя плата после анализа -SBHE и SA0 должна определить, по какой половине шины данных ей направить байт данных. В-третьих, при чтении УВВ в память на внешней плате перестановшик байтов направляет в память байт данных также либо по старшей половине шины данных SD<15...8>, либо по младшей половине SD<7...0>. Внешняя плата по сигналам -SBHE и SA0 должна определять, когда следует переводить в третье состояние свои выходы по младшей половине шины данных SD<7...0> во избежание столкновений на шине.

Внешняя плата может как 16-разрядная память обмениваться в режиме ПДП как с 8-ми разрядными устройствами ввода/вывода, так и с 16-разрядными. Но, если внешняя плата является 8-разрядной памятью, то в режиме ПДП она может обмениваться данными только с 8-разрядными устройствами ввода/вывода. Другая особенность относится к тому случаю, когда контроллер ПДП выполняет запись данных в 8- разрядное устройство вывода на внешней плате из 16-разрядной памяти. Если такая внешняя плата установлена в 16-разрядный слот и может работать в 16-разрядном режиме, она должна для такого случая поддерживать старшую половину шины данных SD<15...8> в третьем состоянии во избежание столкновения сигналов на шине.

ВНИМАНИЕ! Когда контроллер ПДП является задатчиком на шине, он игнорирует сигнал -0WS, поэтому если внешняя плата используется как 16-разрядная память и обмен с ней выполняется контроллером ПДП, применение быстрых микросхем памяти в такой плате лишено смысла.

Обычный доступ к внешней плате как к памяти или устройству ввода/вывода. Внешняя плата становится обычным ресурсом памяти или ввода/вывода, если задатчиком на шине является центральный процессор или другая внешняя плата.

ВНИМАНИЕ! Существуют особенности такого использования внешней платы, если она устанавливается в [8/16] слот, а участвует в обмене данными как 8-разрядная память или УВВ в течении всего цикла доступа. При чтении данных в такую внешнюю плату перестановщик байтов будет переставлять данные между шинами SD<15...8> или SD<7...0> для правильного приема данных внешней платой. Внешняя плата при этом должна поддерживать свои выходы SD<15...8> в третьем состоянии, так как иначе неизбежно столкновение сигналов на шине данных.

ВНИМАНИЕ! Когда некоторые внешние платы становятся задатчиками на шине, они могут игнорировать сигнал I/O CH RDY или -0WS и выполнять цикл доступа как цикл обращения к 8- или 16-разрядной памяти. Но любые внешние платы обязаны возвращать задатчику на шине ISA эти сигналы при необходимости, так как если центральный процессор является задатчиком на шине, то он использует эти сигналы для определения продолжительности цикла доступа.

2.5. Режим сброса

Все внешние платы оказываются в режиме сброса при разрешенном сигнале RESET DRV; иначе этот режим невозможен. Все выходы с тремя состояниями на плате должны быть в третьем состоянии и все выходы с открытым коллектором должны быть в состоянии логической единицы на время не менее 500 нс после разрешения сигнала RESET DRV. Все внешние платы должны завершить свою инициализацию за время не более 1 мс после разрешения сигнала RESET DRV и быть готовыми к выполнению циклов доступа на шине. Любые операции на шине возможны только после запрещения сигнала RESET DRV.

2.6. Контроллер регенерации памяти

Контроллер регенерации памяти выполняет циклы чтения памяти по специальным адресам на материнской плате и внешних платах для регенерации информации в микросхемах динамической памяти. Каждые 15 мкс контроллер пытается овладеть шиной для запуска цикла регенерации. Если в этот момент задатчиком на шине является центральный процессор, то он освобождает шину для контроллера регенерации. Если в этот момент шина захвачена внешней платой, то контроллер регенерации выполнит цикл регенерации только при выработке внешней платой сигнала -REFRESH. Если в этот момент задатчиком на шине являлся контроллер ПДП, то до освобождения им шины цикл регенерации не может быть выполнен.

Когда выполняется цикл регенерации, контроллер регенерации вырабатывает сигналы адреса SA<7...0> с одним из 256 возможных адресов регенерации. Другие адресные линии неопределены и могут находиться в третьем состоянии. Этот цикл может выполняться с задержкой по сигналу I/O CH RDY с разрешенными сигналами -SMEMR и -MEMR.

ВНИМАНИЕ! Циклы регенерации должны выполняться каждые 15 мкс для перебора всех 256 адресов за 4 мс. Если это условие не выполняется, данные, хранящиеся в динамической памяти, могут быть утеряны.

3. Общее описание шины ISA

В данной главе рассматриваются характеристики шины, не зависящие от типа устройства, захватившего шину.

3.1. Адресное пространство при обращении к памяти

Максимальное адресное пространство при обращении к памяти, поддерживаемое шиной ISA, 16 Мб (24 линии адреса), но не все слоты поддерживают полностью это адресное пространство. Когда задатчик на шине осуществляет доступ к памяти на материнской плате или к памяти, установленной в слот, он должен разрешать сигналы -MEMR или -MEMW; аппаратно на материнской плате дополнительно разрешаются сигналы -SMEMR и -SMEMW, если требуемый адрес находится в пределах первого мегабайта адресного пространства. К 8-разрядным слотам подведены только линии -SMEMR и -SMEMR, SD<7...0> и SA<19...0>; поэтому внешние платы, установленные в 8-разрядные слоты, могут быть либо только 8-разрядными устройствами ввода/вывода, либо 8-ми разрядной памятью в первом мегабайте адресного пространства. Внешние платы, устанавливаемые в 8/16-разрядные слоты, принимают все командные сигналы, адреса и данные; они могут быть как 8-, так и 16-разрядными и адресное пространство памяти на них может быть любым в пределах 16 Мб. Цикл доступа к таким внешним платам завершается как 16-разрядный, если плата разрешает сигнал -I/O CS16 или -MEM CS16.

ПРИМЕЧАНИЕ: Память на материнской плате или внешней плате считается 16- разрядным ресурсом только в том случае, если разрешается сигнал -MEM CS16. Этот сигнал вырабатывается из сигналов адреса LA<23...17>; поэтому 16-разрядная память может быть выбрана только блоками по 128 Кб; внутри такого блока память не может быть частично 8-разрядной, а частично 16-разрядной, так как невозможно по обращению к меньшему блоку однозначно выработать сигнал -MEM CS16. Разрядность внутри такого блока должна быть одинаковой при обращении по любому адресу внутри 128 Кб.

ВНИМАНИЕ! Микросхемы динамической памяти требуют циклов регенерации через каждые 15 мкс. Если циклы регенерации выполняются реже, чем через 15 мкс, то данные в памяти могут быть потеряны.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Динамическая память на материнской плате может иметь два вида своей организации - 16- или 32-разрядная. Но разрядность памяти на материнской плате принимается во внимание только центральным процессором, для внешних плат динамическая память на материнской плате всегда только 16-разрядная. ПЗУ на материнской плате, содержащее BIOS (Base Input/Output System - Базовая Система Ввода/Вывода), также всегда 16-разрядное.

3.2. Адресное пространство для устройств ввода/вывода

Максимально адресное пространство для устройств ввода/вывода, поддерживаемое шиной ISA составляет 64 Кб (16 адресных линий). Все слоты поддерживают 16 адресных линий. Первые 256 адресов зарезервированы для устройств, расположенных, как правило, на материнской плате - регистры контроллера ПДП, контроллера прерываний, часов реального времени, таймера-счетчика и других устройств, требующихся для AT совместимости различных компьютеров.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Несмотря на то, что для выбора адреса УВВ доступны все 16 сигналов адреса, традиционно для адресов УВВ в компьютерах серии IBM PC/XT/AT использовались только первые 10 разрядов адреса. Это означает, что адреса из следующих килобайтных блоков будут декодироваться также как адреса в первом килобайте адресов УВВ. Поэтому для вновь разрабатываемых внешних плат следует использовать "окна" в существующем сейчас распределении адресов стандартных УВВ для компьютеров IBM PC/AT. Для увеличения количества используемых адресов УВВ (при необходимости) можно использовать адресное пространство выбранного окна со сдвигом на 1 Кб или кратное ему значение. Очевидно, что внешняя плата в этом случае должна декодировать более чем 10 линий адреса.

3.3. Структура прерываний

Линии запроса на прерывания непосредственно заведены на контроллеры прерываний типа Intel 8259A. Контроллер прерываний будет реагировать на запрос по такой линии в случае, если сигнал на ней перейдет из низкого уровня в высокий. Шина ISA не имеет линий, подтверждающих прием запроса на прерывание, поэтому запрашивающее прерывание устройство должно само определять по реакции ЦП подтверждение приема своего запроса.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Линии запроса на прерывания заведены на все слоты и обрабатываются контроллером прерывания по нарастающему фронту сигнала. До установки новой внешней платы, если она использует в своей работе контроллер прерываний, следует определить, есть ли свободная линия запроса на прерывание и именно ее использовать для новой внешней платы. При не соблюдении этого условия возможно возникновение конфликтных ситуаций на шине.

3.4. Перестановщик байтов

Центральный процессор или внешняя плата могут выполнить как 8- так и 16-разрядные циклы доступа, причем все циклы всегда начинаются как 16-разрядные, а завершаются как 8- или 16-разрядные. Цикл доступа будет завершен как 8-разрядный, если устройство, к которому осуществляется доступ, запретит сигнал -I/O CS16 или -MEM CS16.

Перестановщик байтов всегда находится на материнской плате. Его задача - точно согласовать размер данных, которыми обмениваются устройства. На рис. 3.1 показано место перестановщика байтов при пересылке данных между задатчиком и ресурсом, к которому осуществляется доступ. В табл. 3.1 суммируется вся информация по перестановке байтов во время циклов доступа. Перестановка байтов осуществляется с шины SD<15...0> (HIGH BYTE - старший байт) на SD<7...0> (LOW BYTE - младший байт) или наоборот. В таблице перенос байта с шины SD<15...0> на SD<7...0> обозначается как H > L, наоборот - L < H. LL означает, что байт по младшей половине шины данных не переставляется, HH - что байт по старшей половине шины не переставляется. HH/LL - и старший и младший байт передаются каждый по своей половине шины данных и не переставляются.

Таблица 3.1.

Задатчик на шине |  |  | Ресурс, к которому осуществляется доступ |  | Завершение цикла
Размер данных | -SBHE | SA0 | Размер данных | CS16 | Размер данных | Маршрут чтение запись |
8 | 1 | 0 | 8 | 1 | 8 | LL | LL
 | 0 | 1 | 8 | 1 | 8 | H | H>L
 | 1 | 0 | 16 | 0 | 8 | LL | LL
 | 0 | 1 | 16 | 0 | 8 | HH | HH
16 | 0 | 0 | 8 | 1 | 8 | LL | LL
 | 0 | 0 | 16 | 0 | 16 | HH/LL | HH/LL

На рис. 3.2 показано место перестановщика байтов для циклов пересылки данных в режиме ПДП. В табл. 3.2 суммируется вся информация по перестановке байтов во время циклов ПДП. Перестановка байтов осуществляется с шины SD<15...0> (HIGH BYTE) на SD<7...0> (LOW BYTE) или наоборот. В таблице перенос байта с шины SD<15...0> на SD<7...0> обозначается как H > L, наоборот - L < H. LL означает, что байт по младшей половине шины данных не переставляется, HH - что байт по старшей половине шины не переставляется. HH/LL - и старший и младший байт передаются каждый по своей половине шины данных и не переставляются.

Таблица 3.2.

Устройство ввода/вывода | Контроллер ПДП |  | Память |  |  | Завершение цикла
Размер данных | -SBHE | SA0 - |  | Размер данных | -MEM CS16 |  | Размер данных | Маршрут чтение запись
8 | 1 | 0 |  | 8 | 1 |  | 8 | LL | LL
 | 1 | 0 |  | 16 | 0 |  | 8 | LL | LL
 | Х | 1 |  | 8 | 1 |  | 8 | LL | LL
 | Х | 1 |  | 16 | 0 |  | 8 | H>L | H
16 | 0 | 0 |  | 8 | 1 |  | 8 | Запрещено
 | 0 | 0 |  | 16 | 0 |  | 16 | HH/LL | HH/LL

4. Описание сигналов на шине ISA

В этой главе описываются все сигналы на шине ISA. Для лучшего понимания функционирования шины целесообразно разбить все сигналы на 7 групп: АДРЕСА, ДАННЫЕ, СИНХРОСИГНАЛЫ, КОМАНДНЫЕ СИГНАЛЫ, СИГНАЛЫ РЕЖИМА ПДП, ЦЕНТРАЛЬНЫЕ СИГНАЛЫ УПРАВЛЕНИЯ, СИГНАЛЫ ПРЕРЫВАНИЯ, ПИТАНИЕ. Информация о направленности сигналов (вход, выход или двунаправленный) приводится относительно задатчика на шине.

4.1. Сигналы адреса

Группа сигналов адреса включает в себя адреса, вырабатываемые текущим задатчиком на шине. На шине ISA есть два вида сигналов адреса, SA<19...0> и LA<23...17>.

SA<19...0> [8] [8/16]

Адресные сигналы этого типа поступают на шину с регистров адреса, в которых адрес "защелкивается". Сигналы SA<19...0> позволяют осуществлять доступ к памяти только в младшем мегабайте адресного пространства. При доступе к устройству ввода/вывода только сигналы SA<15...0> имеют действительное значение, а состояние сигналов SA<19...16> не определено.

Во время выполнения циклов регенерации адреса только сигналы SA<7...0> имеют действительное значение, а состояние сигналов SA<19...8> неопределено и эти выводы должны быть в третьем состоянии для всех устройств на шине.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Внешняя плата, ставшая задатчиком на шине, должна разрешать сигнал -REFRESH для регенерации памяти, при этом внешняя плата должна перевести свои выходные формирователи сигналов адреса в третье состояние.

LA<23...17> [8/16]

Сигналы этого типа поступают на шину без "защелкивания" в регистрах. Когда центральный процессор является задатчиком на шине, то значения сигналов на линиях LA<23...17> истинны во время выработки сигнала BALE и они могут иметь произвольное значение в конце цикла доступа. Если задатчиком на шине является контроллер ПДП, сигналы LA<23...17> истинны до начала сигнала -MEMR или -MEMW и сохраняются до конца цикла. При выполнении циклов доступа к памяти сигналы LA<23...17> всегда истинны, а при доступе к устройствам ввода/вывода эти сигналы имеют уровень логического "0".

При выполнении циклов регенерации состояние линий LA<23...17> неопределено и все ресурсы на шине должны поддерживать свои выходы по этим линиям в третьем состоянии.

РЕКОМЕНДАЦИИ: Для "защелкивания" сигналов LA следует использовать только регистры с потенциальным входом. Это вызвано тем, что в этом случае новый истинный адрес появится на выходе регистра по началу сигнала BALE (а не по его заднему фронту) и, кроме этого, во время циклов доступа к памяти каким-либо другим задатчиком, а не ЦП, сигнал BALE поддерживается в состоянии логической "1" и регистр с потенциальным входом станет просто повторителем сигналов LA (что и требуется в таком случае).

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата является задатчиком на шине, то сигналы LA<23...17> должны быть истинны до начала сигнала -MEMR или -MEMW и сохраняться таковыми до завершения цикла. Если внешняя плата разрешает сигнал -REFRESH (следует помнить, что внешняя плата может это сделать, только будучи задатчиком на шине), то вырабатывать сигналы адреса будет контроллер регенерации, поэтому внешней плате следует перевести свои адресные выходы в третье состояние.

-SBHE

Сигнал -SBHE (System Bus High Enable - Разрешение старшего байта на системной шине) разрешается центральным процессором для указания всем ресурсам на магистрали о том, что по линиям SD<15...8> пересылается байт данных. Сигналы -SBHE и SA0 используются для определения того, какой байт и по какой половине шины данных пересылается (в соответствии с табл. 3.1).

Сигнал -SBHE не вырабатывается контроллером регенерации при захвате им шины, так как никаких перестановок байтов нет и нет реального чтения данных.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата становится задатчиком на шине, то она должна вырабатывать сигнал -SBHE так же как центральный процессор.

Если внешняя плата, являющаяся задатчиком на шине, вырабатывает сигнал -REFRESH, то ее выход сигнала -SBHE должен быть переведен в третье состояние.

BALE [8] [8/16]

Сигнал BALE (Bus Address Latch Enable - Разрешение на "защелкивание" адреса на шине) является стробом для записи адреса по линиям LA<23...17> и сообщает ресурсам на шине, что адрес является истинным и его можно "защелкнуть" в регистре. Этот сигнал также информирует ресурсы на шине о том, что сигналы SA<19...0> и -SBHE истинны.

При захвате шины контроллером ПДП сигнал BALE всегда равен логической "1" (вырабатывается на материнской плате), так как сигналы LA<23...17> и SA<19...0> истинны до выработки командных сигналов. Если контроллер регенерации становится задатчиком на шине, то на линии BALE также поддерживается уровень логической единицы, поскольку сигналы адреса SA<19...0> истинны до начала командных сигналов.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

При захвате шины внешней платой сигнал BALE поддерживается материнской платой в состоянии логической "1" на все время захвата шины. Адресные сигналы LA<23...17> и SA<19...0> должны быть при этом истинны в течении времени разрешения платой командных сигналов.

Если центральный процессор является задатчиком на шине и выполняет цикл доступа к ресурсу на внешней плате, то сигналы LA<23...17> истинны только в течении короткого времени, поэтому сигнал BALE должен быть использован для "защелкивания" адреса в регистре. При захвате шины любым устройством, кроме ЦП, на линии BALE поддерживается уровень логической "1".

AEN [8] [8/16]

Сигнал AEN (Address Enable - Разрешение адреса) разрешается тогда, когда контроллер ПДП становится задатчиком на шине и сообщает всем ресурсам на шине о том, что на шине выполняются циклы ПДП. Разрешенный сигнал AEN также информирует все устройства ввода/вывода о том, что контроллер ПДП установил адрес памяти и УВВ следует запретить на время сигнала AEN декодирование адреса.

Этот сигнал запрещается, если задатчиком на шине является центральный процессор или контроллер регенерации.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата, выполняя процедуру захвата шины, вырабатывает сигнал -MASTER, сигнал AEN запрещается контроллером ПДП для того, чтобы позволить внешней плате доступ к устройствам ввода/вывода.

SD<7...0> и SD<15...8>

Линии SD<7...0> и SD<15...8>, как правило, еще называют шиной данных, причем по линии SD15 передается старший значащий бит, а по линии SD0 - младший значащий бит. Линии SD<7...0> - младшая половина шины данных, SD<15...0> - старшая половина шины данных. Все 8-ми разрядные ресурсы могут обмениваться данными только по младшей половине шины данных. Поддержка обмена данными между 16-ти разрядным задатчиком на шине и 8-ми разрядным ресурсом осуществляется перестановщиком байтов на материнской плате (табл. 3.1 и рис. 3.1 иллюстрирует его работу).

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если сигнал - REFRESH разрешен, то внешние платы должны перевести свои выходы по шине данных в третье состояние, так как нет пересылок данных во время циклов регенерации памяти.

4.2. Командные сигналы

Сигналы этой группы управляют как продолжительностью, так и типами циклов доступа, выполняемых на шине. Группа состоит из шести командных сигналов, двух сигналов готовности и трех сигналов, которые определяют размеры и тип цикла.

Командные сигналы определяют вид устройства (память или УВВ) и направление пересылки (запись или чтение).

Сигналы готовности управляют продолжительностью цикла доступа, укорачивая его или, наоборот, удлиняя.

-MEMR [8/16] и -SMEMR [8] [8/16]

Сигнал -MEMR (Memory Read - Чтение памяти) разрешается задатчиком на шине для чтения данных из памяти по адресу, определяемому сигналами по линиям LA<23...17> и SA<19...0>. Сигнал -SMEMR (System Memory Read - Системное чтение памяти) функционально идентичен -MEMR, за исключением того, что сигнал -SMEMR разрешается при чтении памяти, находящейся в пределах первого мегабайта адресного пространства. Сигнал -SMEMR вырабатывается на материнской плате из сигнала -MEMR и, поэтому, задерживается относительно сигнала -MEMR на 10 или менее наносекунд.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата становится задатчиком на шине, то она может разрешать только сигнал -MEMR, так как сигнал -SMEMR может разрешаться только материнской платой при чтении из памяти в первом мегабайте адресного пространства. Если внешняя плата разрешает сигнал -REFRESH, то она должна перевести свой выход по сигналу -MEMR в третье состояние, так после разрешения сигнала -REFRESH контроллер регенерации будет разрешать этот сигнал.

-MEMW [8/16] и -SMEMW [8] [8/16]

Сигнал -MEMW (Memory Write - Запись в память) разрешается задатчиком на шине для записи данных в память по адресу, определяемому сигналами по линиям LA<23...17> и SA<19...0>. Сигнал -SMEMW (System Memory Write - Системная запись в память) функционально идентичен -MEMW, за исключением того, что сигнал -SMEMW разрешается при записи в память, находящейся в пределах первого мегабайта адресного пространства. Сигнал -SMEMW вырабатывается на материнской плате из сигнала -MEMW и, поэтому, задерживается относительно сигнала -MEMR на 10 нс или менее.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата становится задатчиком на шине, то она может разрешать только сигнал -MEMW, так как сигнал -SMEMW может разрешаться только материнской платой при записи в память в первом мегабайте адресного пространства. Если внешняя плата разрешает сигнал -REFRESH, то она должна перевести свой выход по сигналу -MEMW в третье состояние.

-I/OR [8] [8/16]

Сигнал -I/OR (I/O Read - Чтение устройства ввода/вывода) разрешается задатчиком на шине для чтения данных из устройства ввода/вывода по адресу, определяемому сигналами SA<15...0>.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата разрешает сигнал -REFRESH, то она должна перевести свой выход по сигналу -I/OR в третье состояние.

-I/OW [8] [8/16]

Сигнал -I/OW (I/O Write - Запись в устройства ввода/вывода) разрешается задатчиком на шине для записи данных в устройство ввода/вывода по адресу, определяемому сигналами SA<15...0>.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата разрешает сигнал -REFRESH, то она должна перевести свой выход по сигналу -IOW в третье состояние.

-MEM CS16

Сигнал -MEM CS16 (Memory Cycle Select - Выбор цикла для памяти) разрешается 16-разрядной памятью для сообщения задатчику шины о том, что память, к которой он обращается, имеет 16-разрядную организацию и ему следует выполнить 16-разрядный цикл доступа. Если этот сигнал запрещен, то только 8-разрядный цикл доступа может быть выполнен на шине. Память, к которой выполняется цикл доступа, должна выработать этот сигнал из адресных сигналов LA<23...17>.

ПРИМЕЧАНИЕ: Контроллер ПДП и контроллер регенерации игнорируют сигнал

-MEM CS16 при выполнении циклов ПДП и регенерации памяти.

РЕКОМЕНДАЦИИ: Декодировав сигналы LA на внешней плате 16-разрядной памяти, следует разрешить сигнал -MEM CS16, если установленный на шине адрес является адресом этой внешней платы. Так как этот сигнал фиксируется на материнской плате, как правило, по заднему фронту сигнала BALE, то схема дешифрации сигналов LA и последующего формирования -MEM CS16 должна иметь минимально возможную задержку (для компьютеров с тактовой частотой ЦП 20 МГц не более 20 нс).

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата является 16-разрядной памятью, то она должна информировать об этом задатчика на шине, разрешив сигнал -MEM CS16.

Если внешняя плата, являясь задатчиком на шине, выработает сигналы адреса SA<15...0> и какое-либо устройство ввода/вывода случайно при декодировании этого адреса разрешит сигнал -I/O CS16, то внешняя плата должна игнорировать его в течении цикла доступа к памяти.

-I/O CS16

Сигнал -I/O CS16 (I/O Cycle Select - Выбор цикла для УВВ) разрешается 16- разрядным УВВ для сообщения задатчику шины о том, что УВВ, к которому он обращается, имеет 16-разрядную организацию и ему следует выполнить 16-разрядный цикл доступа. Если этот сигнал запрещен, то только 8-разрядный цикл доступа к УВВ может быть выполнен на шине. УВВ, к которому выполняется цикл доступа, должна выработать этот сигнал из адресных сигналов SA<15...0>.

ПРИМЕЧАНИЕ: Контроллер ПДП и контроллер регенерации игнорируют сигнал -I/O CS16 при выполнении циклов ПДП и регенерации памяти.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата является 16-разрядным УВВ, то она должна информировать об этом задатчика на шине, разрешив сигнал -I/O CS16.

Если внешняя плата, являясь задатчиком на шине, выработает сигналы адреса LA<23...17> и какое-либо устройство памяти случайно при декодировании этого адреса разрешит сигнал -MEM CS16, то внешняя плата должна игнорировать его в течении цикла доступа к УВВ.

I/O CH RDY [8] [8/16]

Сигнал I/O CH RDY (I/O Channel Ready - Готовность канала ввода/вывода) является асинхронным сигналом, вырабатываемый тем устройством, к которому осуществляется доступ на шине. Если этот сигнал запрещен, то цикл доступа удлиняется, так как в него будут добавлены такты ожидания на время запрещения. Когда задатчиком на шине является центральный процессор или внешняя плата, то каждый такт ожидания по длительности - половина периода частоты SYSCLK (для тактовой частоты SYSCLK=8 МГц длительность такта ожидания - 62.5 нс). Если задатчиком на шине является контроллер ПДП, то каждый такт ожидания - один период SYSCLK (для SYSCLK=8 МГц - 125 нс). При обращении к памяти на внешней плате ЦП всегда автоматически вставляет один такт ожидания (если сигнал -0WS запрещен), поэтому, если внешней плате достаточно времени цикла с одним тактом ожидания, то запрещать сигнал I/O CH RDY не требуется.

ПРИМЕЧАНИЕ: При выполнении циклов ПДП устройства ввода/вывода не должны вырабатывать этот сигнал, так как УВВ разрешает сигнал DRQ только после того, как истинные данные могут быть приняты или посланы УВВ и необходимости в дополнительном управлении длительностью цикла по сигналу I/O CH RDY нет. Только устройства памяти во время циклов ПДП могут разрешать этот сигнал.

ВНИМАНИЕ: Сигнал I/O CH RDY не может быть запрещен на время больше чем 15 мкс, так как при нарушении этого требования возможна потеря данных в микросхемах динамической памяти.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата является задатчиком на шине, то она должна принимать и анализировать сигнал I/O CH RDY при выполнении ей циклов доступа к другим ресурсам. При работе внешней платы в других режимах она должна разрешать этот сигнал в том случае, когда она готова завершить цикл.

ВНИМАНИЕ! К сожалению, некоторые внешние платы, став задатчиком на шине, игнорируют сигнал I/O CH RDY и выполняют все циклы доступа как обычные циклы доступа к 8- или 16-разрядной памяти. Поэтому, устанавливая в компьютер внешнюю плату, которая требует удлинения цикла доступа по сигналу I/O CH RDY, следует обязательно убедиться в отсутствии в компьютере такой некорректно разработанной внешней платы.

-0WS [8] [8/16]

Сигнал -0WS (0 Wait States - 0 тактов ожидания) является единственным на всей шине сигналом, который требует при приеме его задатчиком на шине синхронизации с частотой SYSCLK. Он разрешается ресурсом, к которому осуществляется доступ центральным процессором или внешней платой, и информирует задатчика на шине о том, что цикл доступа должен быть завершен без вставки такта ожидания.

ПРИМЕЧАНИЕ: Несмотря на то, что этот сигнал присоединен к слоту для 8- разрядных плат, он не может быть использован 8-разрядным ресурсом. Он может быть использован только при доступе к 16-разрядной памяти, установленной в [8/16] слот, когда центральный процессор или внешняя плата являются задатчиком на шине. Этот сигнал игнорируется при доступе к УВВ или когда контроллер ПДП или контроллер регенерации являются задатчиком на шине.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата является задатчиком на шине, то она должна принимать сигнал -0WS от ресурсов, к которым она осуществляет доступ и выполнять циклы доступа с такими ресурсами без дополнительных тактов ожидания. Когда внешняя плата является 16-разрядной памятью, то она должна разрешать сигнал -0WS, если быстродействие этой памяти позволяет выполнять циклы доступа к ней без вставки дополнительного такта ожидания.

ВНИМАНИЕ! К сожалению, некоторые внешние платы, став задатчиком на шине, игнорируют сигнал -0WS и выполняют все циклы доступа как обычные циклы доступа к 8- или 16-разрядной памяти.

-REFRESH [8] [8/16]

Сигнал -REFRESH (Refresh - регенерация) разрешается контроллером регенерации для информирования всех устройств на шине о том, что выполняются циклы регенерации памяти.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если внешняя плата является задатчиком на шине, то она должна разрешать сигнал -REFRESH для запроса на регенерацию памяти. При этом цикл регенерации будет выполнен даже несмотря на то, что контроллер регенерации не является задатчиком на шине.

4.3. Центральные сигналы управления

Группа центральных сигналов управления состоит из сигналов различных частот, сигналов управления и ошибок.

-MASTER

Сигнал -MASTER (Master - Ведущий) должен вырабатываться только той внешней платой, которая желает стать задатчиком на шине.

ВНИМАНИЕ! Если сигнал -MASTER разрешен на время более 15 мкс, то внешняя плата должна запросить цикл регенерации памяти, разрешив сигнал -REFRESH.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Сигнал -MASTER разрешается внешней платой, становящейся задатчиком на шине, только после приема ей соответствующего сигнала -DACK от контроллера ПДП. После того, как сигнал -MASTER будет разрешен, внешняя плата должна ждать минимум один период частоты SYSCLK, прежде чем начать выработку сигналов адреса и данных и минимум два периода SYSCLK до выработки командных сигналов.

-I/O CH CK [8] [8/16]

Сигнал -I/O CH CK (I/O Channel Check - Проверка Канала Ввода/вывода) может быть разрешен любым ресурсом на шине как сообщение о фатальной ошибке, которая не может быть исправлена. Типичный пример такой ошибки - ошибка четности при доступе к памяти. Сигнал - I/O CH CK должен быть разрешен на время не менее 15 нс. Если в момент выработки этого сигнала задатчиком на шине являлся контроллер ПДП или контроллер регенерации, то сигнал -I/O CH CK будет записан в регистр на материнской плате, а обработан только после того, как центральный процессор станет задатчиком на шине.

Этот сигнал, как правило, соединен со входом немаскированного прерывания ЦП и его выработка приводит к прекращению нормальной работы компьютера.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Если сигнал -I/O CH CK разрешается в тот момент, когда задатчиком на шине является внешняя плата, то он записывается в регистр на материнской плате и будет обработан только после захвата шины центральным процессором.

RESET DRV [8] [8/16]

Сигнал RESET DRV (Reset Driver - Сброс Устройства) вырабатывается центральным процессором для начальной установки всех ресурсов доступа на шине после включения питания или падения его напряжения. Минимальное время разрешения этого сигнала - 1 мс.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Внешние платы на все время выработки этого сигнала должны перевести свои выходы в третье состояние.

SYSCLK [8] [8/16]

Сигнал SYSCLK (System Clock - системная частота) в данной книге принимается равной 8 МГц, хотя, как правило, эта частота такая же, как и тактовая частота центрального процессора на материнской плате, но с 50% (по длительности) уровнем логической "1". Все циклы шины пропорциональны SYSCLK, но все сигналы на шине, за исключением -0WS, не синхронизированы с SYSCLK.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Когда внешняя плата является задатчиком на шине, она может использовать SYSCLK для задания длины цикла, но кроме как для выработки -0WS любой сигнал для синхронизации может быть использован.

OSC [8] [8/16]

Сигнал OSC вырабатывается материнской платой всегда фиксированной частотой 14.3818 МГц с 45-55% (по длительности) уровнем логической "1". Сигнал OSC не синхронизирован ни с SYSCLK ни с каким-либо другим сигналом на шине и поэтому не может быть использован для применений, требующих синхронизации с другими сигналами. Исторически этот сигнал появился для поддержки первых контроллеров цветных мониторов для персональных компьютеров серии IBM PC. Этот сигнал удобен для использования внешними платами, поскольку он одинаков для всех моделей компьютеров, совместимых с IBM PC/AT.

4.4. Сигналы прерывания

Группа сигналов прерывания используется для запроса на прерывание центрального процессора.

ПРИМЕЧАНИЕ: Обычно сигналы запроса на прерывания присоединены к контроллеру прерываний типа Intel 8259A. Несмотря на то, что доступ к контроллерам прерываний (как к УВВ) имеет любой задатчик на шине, для совместимости программного обеспечения только центральный процессор может обслуживать контроллер прерываний.

IRQ<15,14,12,11,10> [8/16] IRQ<9,7...3> [8]

Прерывание может быть запрошено ресурсами как на материнской плате, так и на внешних платах разрешением соответствующего сигнала IRQ. Сигнал должен оставаться разрешенным до подтверждения прерывания центральным процессором, которое, как правило, заключается в доступе ЦП к ресурсу, запросившему прерывание.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Запрос на прерывание записывается в триггер в контроллере прерываний по нарастающему фронту сигнала запроса на прерывание и должен вырабатываться микросхемами с обычными ТТЛ выходами. Поэтому, выбирая линию запроса на прерывание для своей внешней платы, следует убедиться, что эта линия не занята какой-либо другой внешней платой.

4.5. Сигналы режима ПДП

Эти сигналы поддерживают циклы пересылки данных при прямом доступе в память.

ПРИМЕЧАНИЕ: Каналы ПДП <3...0> поддерживают только пересылки 8-разрядных данных. Каналы ПДП <7...5> поддерживают пересылки только 16-разрядных данных.

DRQ<7...5,0> [8] [8/16] DRQ<3,2,1> [8]

Сигналы DRQ (DMA Request - запрос на ПДП) разрешаются ресурсами на материнской плате или внешними платами для запроса на обслуживание контроллером ПДП или для захвата шины. Сигнал DRQ должен быть разрешен до тех пор, пока контроллер ПДП не разрешит соответствующий сигнал -DACK.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Сигналы DRQ вырабатываются с выходов обычных ТТЛ микросхем, поэтому при установке внешней платы в слот шины ISA следует правильно выбрать канал ПДП, который не должен быть занят другими внешними платами.

-DACK<7...5,0> [8] [8/16] -DACK<3,2,1> [8]

Сигналы -DACK (DMA Acknowledge - подтверждение ПДП) разрешаются контроллером ПДП как подтверждение сигналов запросов DRQ<7...5,3...0>. Разрешение соответствующего сигнала -DACK означает, что либо циклы ПДП будут начаты, либо внешняя плата захватила шину.

T/C [8] [8/16]

Сигнал T/C (Terminal Count - Окончание счета) разрешается контроллером ПДП тогда, когда по какому-либо из каналов ПДП будет окончен счет числа пересылок данных, то есть все пересылки данных выполнены.

4.6. Питание

Для питания внешних плат на шине ISA используются 5 напряжений питания постоянного тока: +5 В, -5 В, +12 В, -12 В, 0 В (корпус - Ground). Все линии питания заведены на 8-разрядный разъем, кроме одной линии по +5 В и одной линии корпуса на дополнительном разъеме.

Максимально допустимые токи потребления для внешней платы по каждому напряжению питания приведены в табл. 4.1.

Таблица 4.1. Максимальные токи потребления внешней платой

Напряжение | [8] | [8/16]
+5 В | 3,0 А | 4,5 А
+12 В | 1,5 А | 1,5 А
-5 В | 1,5 А | 1,5 А
-12 В | 1,5 А | 1,5 А

ВНИМАНИЕ! Данные, приведенные в табл. 4.1, не означают, что каждая из установленных в слоты внешних плат может потреблять такие токи. Таблица информирует только о том, какие токи разрешается пропускать через разъем (разъемы) внешней платы. Общие допустимые токи потребления для всех внешних плат как правило, ограничиваются источником питания компьютера. Поэтому, до установки новой внешней платы в слот шины следует определить наличие соответствующего резерва по токам потребления для этой платы у источника питания компьютера.

5. Циклы шины

Циклы шины ISA всегда асинхронны по отношению к SYSCLK. Различные сигналы разрешаются и запрещаются в любое время; внутри допустимых интервалов сигналы отклика могут также быть выработаны в любое время. Исключением является только сигнал -0WS, который должен быть синхронизирован с SYSCLK.

На шине существуют 4 индивидуальных типа циклов: Доступ к Ресурсу, ПДП, Регенерация, Захват Шины. Цикл Доступа к Ресурсу выполняется, если центральный процессор или внешняя плата в качестве задатчиков обмениваются данными с различными ресурсами на шине. Цикл ПДП выполняется, если контроллер ПДП является задатчиком на шине и выполняет циклы передачи данных между памятью и УВВ. Цикл Регенерации выполняется только контроллером регенерации для регенерации микросхем динамической памяти. Цикл Захвата Шины выполняется внешней платой для того, чтобы стать задатчиком на шине.

Структурно циклы отличаются по типу задатчика на шине и видами ресурсов доступа на ней. Внутри типа цикла существуют различные виды его, обусловленные различной продолжительностью каждого вида.

Существуют три типа цикла Доступа к Ресурсу:

  • цикл с 0 тактов ожидания - этот цикл наиболее короткий из всех возможных;

  • нормальный цикл - при выполнении такого цикла ресурс доступа не запрещает сигнал готовности I/O CH RDY - далее цикл такого вида будет называться просто нормальным;

  • удлиненный цикл - при выполнении такого цикла ресурс доступа запрещает сигнал готовности I/O CH RDY на время, необходимое ресурсу для приема или передачи данных - далее цикл такого вида будет называться удлиненным.

В циклах ПДП и Регенерация тоже существуют два вида: нормальный и удлиненный, исходя из таких же, описанных выше условий.Ниже все типы циклов будут подробно описаны и, кроме этого, в гл. 6 приведены временные диаграммы всех типов циклов.

5.1. Цикл Доступа к Ресурсу

Центральный процессор начинает цикл Доступа к Ресурсу выработкой сигнала BALE, сообщающего всем ресурсам об истинности адреса на линиях SA<19...0>, а также для фиксации ресурсами адреса по линиям LA<23...17>. Ресурсы должны сообщать ЦП разрешением сигнала -MEM CS16 или -I/O CS16 о том, что цикл должен быть 16- разрядным; иначе цикл будет завершен как 8-разрядный. ЦП также вырабатывает команды -MEMR, -MEMW, -IORC и -IOWC определяющие тип ресурса (память или УВВ), а также направление передачи данных. Если доступ к памяти в первом мегабайте адресного пространства, то также будет разрешаться сигнал -SMEMR или -SMEMW. Ресурс доступа, которому необходимо изменить время цикла, должен отвечать сигналом -0WS или I/O CH RDY для информирования ЦП о продолжительности цикла доступа.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Внешняя плата, захватившая шину, также начинает цикл доступа с выработки адресных сигналов, но, в отличии от ЦП, не подтверждает адрес сигналом BALE. На линии этого сигнала поддерживается материнской платой на все время захвата шины внешней платой уровень логической "1". Поэтому внешняя плата должна выработать истинные сигналы как по линиям SA<19...0> так и по линиям LA<23...17> до начала разрешения командных сигналов, сохраняя адрес до конца цикла. Внешняя плата также должна иметь возможность анализа сигналов -MEM CS16 и -I/O CS16 и в соответствии с этими сигналами завершать цикл как 16- или 8-разрядный.

5.1.1. Цикл Доступа к Ресурсу - 0 тактов ожидания

Цикл доступа с 0 тактов ожидания - наиболее короткий цикл из всех возможных на шине. Этот цикл может быть выполнен только при доступе ЦП или внешней платы (когда она задатчик на шине) к 16-разрядной памяти. В начале цикла задатчик должен установить адрес на линиях LA<23...17> для выбора блока памяти в 128 Кб. Если затем не будет разрешен сигнал -MEM CS16, то цикл будет завершен как 8-разрядный (нормальный или удлиненный) и цикл с 0 тактов ожидания не будет выполнен. Если ресурсом будет разрешен сигнал -MEM CS16, то затем он должен разрешить сигнал -0WS в соответствующее время после выдачи командного сигнала -MEMR или -MEMW для завершения цикла с 0 тактов ожидания. При запрещении сигнала -0WS цикл завершается как нормальный или удлиненный.

ПРИМЕЧАНИЯ: Если сигнал -0WS разрешается ресурсом доступа, то задатчик не требует разрешения сигнала I/O CH RDY - он игнорируется. Только сигнал -0WS является на шине ISA синхронным по отношению к SYSCLK сигналом.

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Внешняя плата, захватившая шину, выполняет цикл доступа с 0 тактов ожидания точно также как центральный процессор.

5.1.2. Цикл Доступа к Ресурсу - Нормальный цикл

Нормальный цикл может быть выполнен ЦП или внешней платой (если она владеет шиной) при доступе к 8- или 16-разрядному УВВ или к памяти. После выдачи на шину сигналов адреса задатчик разрешает командные сигналы -MEMR, -MEMW, -I/OR или -I/OW. В ответ ресурс должен разрешить сигнал I/O CH RDY в соответствующее время, так как иначе цикл будет завершен как удлиненный. Разрешение I/O CH RDY заставляет задатчика завершить цикл за фиксированный период времени (этот период кратен периоду SYSCLK, но не синхронизирован с ним). Длительность нормального цикла определяется временем разрешения сигналов -MEMR, -MEMW, -I/OR или -I/OW которое, в свою очередь, зависит от размера данных и адреса ресурса доступа.

5.1.3. Цикл Доступа к Ресурсу - Удлиненный цикл

Удлиненный цикл может быть выполнен ЦП или внешней платой (если она владеет шиной) при доступе к 8- или 16-разрядному УВВ или к памяти. Задатчик на шине выполняет удлиненный цикл в том случае, если ресурс, к которому осуществляется доступ, не разрешает в соответствующее время после разрешения командного сигнала сигнал I/O CH RDY. Задатчик продолжает разрешать командный сигнал до тех пор, пока ресурс не разрешит сигнал I/O CH RDY. Период времени удлиненного цикла также кратен SYSCLK, но не синхронизирован с ним.

5.2. Цикл Регенерации - Введение

Контроллер регенерации пытается захватить шину по истечении 15 мкс с последнего цикла регенерации двумя способами:

  • если шиной владеет центральный процессор, то он по завершении выполнения текущей команды передает шину контроллеру регенерации;

  • если шиной владеет контроллер ПДП, то шина будет передана контроллеру регенерации только по завершении циклов пересылки данных контроллером ПДП.

Назначение следующих сигналов во время цикла регенерации имеют оригинальную интерпретацию:

-REFRESH - разрешение этого сигнала сообщает о начале цикла регенерации;

Адрес - контроллер регенерации вырабатывает только сигналы по линиям адреса SA<7...0>, остальные сигналы адреса не определены;

-MEMR - сигнал -MEMR разрешается контроллером регенерации, при этом сигнал -SMEMR будет разрешен материнской платой;

SD<15...0> - линии данных игнорируются контроллером регенерации и все ресурсы на шине обязаны перевести свои выходы по линиям данных в третье состояние;

- эти сигналы игнорируются контроллером регенерации:

-0WS

-MEM CS16

-I/O CS16

ОСОБЕННОСТИ ДЛЯ ВНЕШНИХ ПЛАТ

Когда внешняя плата является задатчиком на шине, она должна самостоятельно разрешать сигнал -REFRESH для запуска цикла регенерации памяти.

5.2.1. Цикл Регенерации - Нормальный цикл

Нормальный цикл регенерации контроллер регенерации начинает с разрешения сигнала -MEMR, в ответ ресурс должен разрешить сигнал I/O CH RDY в соответствующее время, так как иначе цикл будет завершен как удлиненный. Длину цикла фактически определяет только продолжительность сигнала -MEMR.

5.2.2. Цикл Регенерации - Удлиненный цикл

Удлиненный цикл контроллер регенерации выполняет в том случае, если хотя бы один ресурс доступа не разрешает сигнал I/O CH RDY в соответствующее время после разрешения сигнала -MEMR. Контроллер регенерации продолжает разрешать сигнал -MEMR до того, как сигнал I/O CH RDY будет разрешен всеми ресурсами на шине. Период времени удлиненного цикла также кратен SYSCLK, но не синхронизирован с ним.

5.3. Цикл ПДП

Цикл ПДП подобен циклу доступа, который выполняет другой владелец шины. Циклы ПДП запускаются после разрешения сигнала -DACK контроллером ПДП. Размер передаваемых данных зависит от используемого канала ПДП: каналы с 0 по 3 определены для 8-разрядных пересылок данных, а каналы с 5 по 7 для 16-разрядных пересылок данных. Сигналы -MEM CS16 и -I/O CS16 игнорируются самим контроллером ПДП, но эти сигналы использует перестановщик байтов на материнской плате.

Циклы ПДП выполняются только между памятью и устройствами ввода/вывода. Сигналы адреса, вырабатываемые контроллером ПДП, содержат только адрес памяти и не содержат адрес УВВ. Процесс пересылки данных в цикле ПДП выполняется так: источник данных выставляет данные на шине, а приемник данных должен быть готов их принять в это же самое время. Команды записи и чтения также разрешаются одновременно для правильного выбора направления пересылки. При этом сигнал чтения обязательно разрешается раньше, чем сигнал записи во избежание столкновения между буферами данных в двух ресурсах.

УВВ, запрашивающее режим ПДП на шине, разрешает сигнал DRQ соответствующего канала. Если задатчиком на шине является центральный процессор, то он освобождает шину контроллеру ПДП, который, в свою очередь, извещает УВВ разрешением сигнала -DACK о том, что начинается цикл ПДП. Так как контроллер ПДП вырабатывает только адрес памяти, УВВ должно использовать сигналы -I/OR, -I/OW и -DACK для приема или передачи данных в режиме ПДП.

Цикл ПДП начинается с разрешения сигнала -DACK соответствующего канала, а также сигнала AEN. Разрешением сигнала AEN контроллер ПДП извещает все ресурсы на шине о том, что адреса и командные сигналы вырабатываются контроллером ПДП, а не центральным процессором, контроллером регенерации или внешней платой. После разрешения командных сигналов контроллер ПДП анализирует сигнал I/O CH RDY для определения длительности цикла.

Если цикл удлиняется, то период удлинения кратен удвоенному периоду SYSCLK, хотя и не синхронизирован с SYSCLK.

ПРИМЕЧАНИЕ: Данные, которые записываются в память или УВВ, должны быть истинны до разрешения команды записи и оставаться истинными до запрещения команды записи.

5.3.1. Цикл ПДП - Нормальный цикл

Нормальный цикл выполняется контроллером ПДП для 8- или 16-разрядных пересылок данных. Контроллер ПДП разрешает сигналы -MEMR, -MEMW, -I/OR и -I/OW, а память, с которой выполняется обмен, должна разрешить сигнал I/O CH RDY в соответствующее время, иначе цикл будет завершен как удлиненный. Разрешение сигнала I/O CH RDY заставляет контроллер завершить цикл за фиксированный период времени; этот период кратен периоду SYSCLK, но не синхронизирован с ним.

Продолжительность разрешения сигналов -MEMR, -MEMW, -I/OR и -I/OW определяет продолжительность всего цикла, причем эта продолжительность зависит от размера данных для различных адресных пространств.

5.3.2. Цикл ПДП - Удлиненный цикл

Удлиненный цикл ПДП выполняется контроллером ПДП также как и нормальный цикл, за исключением того, что при удлиненном цикле сигнал I/O CH RDY не разрешается в соответствующее время после того, как командный сигнал будет разрешен. Контроллер ПДП продолжает разрешать командные сигналы до тех пор, пока УВВ не разрешит сигнал I/O CH RDY. Период времени, на который удлиняется цикл, в этом случае кратен удвоенному периоду SYSCLK, хотя и не синхронен с SYSCLK.

ПРИМЕЧАНИЕ: Сигналы адреса LA<23...0> во время обычного цикла доступа должны записываться в регистр ресурсами доступа для запоминания адреса в течении всего цикла. В отличие от обычных циклов, при выполнении циклов ПДП эти адресные сигналы истинны в течении всего цикла ПДП.

ВНИМАНИЕ! Каналы ПДП, которые используются внешними платами для захвата шины, должны быть запрограммированы в каскадном режиме.

5.4. Цикл Захвата Шины

Любая внешняя плата, установленная в [8/16] слот, может стать задатчиком на шине ISA. Захват шины внешняя плата должна начать с разрешения сигнала DRQ канала ПДП, предварительно запрограммированного в каскадный режим. Канал ПДП, запрограммированный в каскадном режиме, считает, что все циклы ПДП были выполнены внешним ресурсом - в данном случае внешней платой. Контроллер ПДП отвечает внешней плате разрешением сигнала -DACK; внешняя плата в ответ на -DACK разрешает сигнал -MASTER. После разрешения сигнала -MASTER внешняя плата должна ждать некоторое время, после чего может начинать свои циклы доступа.

В основе этого материала книга сотрудника нашей компании Блохнина С.М. по шине ISA, изданная ПК "Сплайн" в 1992 году.

Страницы: 1 2


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | Шина PCI

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] Шина PCI

Содержание:

  • Введение
  • Сигналы шины PCI
  • Разъем шины PCI
  • Циклы шины
    • Подтверждение прерывания (0000)
    • Специальный цикл (0001)
    • Чтение порта (0010) и запись в порт (0011)
    • Чтение памяти (0110) и запись в память (0111)
    • Чтение конфигурации (1010) и запись конфигурационных данных (1011)
    • Множественное чтение памяти (1100)
    • Двойной цикл адреса (1101)
  • Временные диаграммы шины PCI
  • PCI-X

Введение
PCI (Peripheral Component Interconnect bus) - шина для подсоединения периферийных устройств. Стала массово применяться для Pentium-систем, но используется и с 486 процессорами. Частота шины от 20 до 33 МГц, теоретически максимальная скорость 132/264 Мбайт/с для 32/64 бит. В современных материнских платах частота на шине PCI задается как 1/2 входной частоты процессора, т.е при частоте 66 MHz на PCI будет 33 MHz, при 75 MHz - 37.5 MHz. Параметры шины PCI, которыми можно управлять через программу SETUP из BIOS, приведены в разделе "Настройки Setup BIOS".

Имеет версии с питанием 5V, 3.3V и универсальную (с переключением линий +VI/O c 5V на 3,3V). Ключами являются пропущенные ряды контактов 12, 13 и 50, 51. Для слота с питанием 5V ключ расположен на месте контактов 50, 51, для 3,3 В - 12, 13, а для универсального - два ключа: 12, 13 и 50,51. 32-битный слот заканчивается контактами А62/В62, 64-битный - А94/В94.

Слот PCI самодостаточен для подключения любого контроллера (VLB не работала без ISA), на системной плате может сосуществовать с любой из других шин ввода-вывода.
Шина PCI - первая шина в архитектуре IBM PC, которая не привязана к этой архитектуре. Она является процессорно-независимой и применяется, например, в компьютерах Macintosh.
В отличие от остальных шин, компоненты расположены на левой поверхности плат PCI-адаптеров. По этой причине крайний PCI-слот обычно разделяет использование посадочного места с соседним ISA-слотом (Shared slot).

Процессор через так называемые мосты (PCI Bridge) может быть подключен к нескольким каналам PCI, обеспечивая возможность одновременной передачи данных между независимыми каналами PCI (возможно только в спецификации 2.1).

Автоконфигурирование устройств (выбор запросов прерывания, каналов DMA) поддерживается средствами BIOS материнской платы по образу и подобию стандарта Plug & Play. В настоящее время действует спецификация PCI 2.1.

Стандарт PCI определяет для каждого слота конфигурационное пространство размером до 256 восьмибитных регистров, не приписанных ни к пространству памяти, ни к пространству ввода-вывода. Доступ к ним осуществляется по специальным циклам шины Configuration Read и Configuration Write, вырабатываемым контроллером при обращении процессора к регистрам контроллера шины PCI, расположенным в его пространстве ввода-вывода.

На PCI определены два основных вида устройств - инициатор (по ГОСТ - задатчик), т.е. устройство, получившее от арбитра шины разрешение на захват ее и устройство назначения, цель (target) с которым инициатор выполняет цикл обмена данными.

В мае 1999 года появилась спецификация 2.2 стандарта PCI и в это же время фирма Intel выпустила первый chipset с поддержкой версии 2.2 - i810. Поддержка версии 2.2 также появилась в некоторых платах на наборе 440BX. В соответствии с новой спецификацией появились следующие новые возможности:

  • Поддержка "горячей" замены PCI устройств, называемой в стандарте как PCI Hot-Plug. Ввод этой функции позволит добавлять/изымать PCI платы без выключения компьютера. Такая возможность особенно необходима для серверных платформ

  • Система управления энергопотреблением для устройств на шине PCI. Позволяет управлять энергопотреблением как для внешних PCI плат так и для встроенных на материнской плате устройств. Механизм управления подстроен под стандарт ACPI для облегчения управления энергопотреблением PCI устройств со стороны операционной системы.

  • Дополнены и переработаны требования к конструктивной реализации PCI плат.

Следует помнить, что для практического использования новых возможностей PCI расширения стандарта должны быть поддержаны как контроллером шины PCI так и самим PCI устройством.

Сигналы шины PCI
Знак - (минус) перед названием сигнала означает, что активный уровень этого сигнала логический ноль, обозначение {XX:0} означает группу сигналов с номерами от 0 до XX.

AD{31:0} - мультиплексированная шина адреса/данных. Адрес передается по сигналу - FRAME, в последующих тактах передаются данные.

-C/ BE{3:0} - команда/разрешение обращения к байтам. Команда, определяющая тип очередного цикла шины (чтение-запись памяти, ввода/вывода или чтение/запись конфигурации, подтверждение прерывания и другие) задается четырехбитным кодом в фазе адреса по сигналу - FRAME.

-FRAME - индикатор фазы адреса (иначе - передача данных).

-DEVSEL - выбор инициатором устройства назначения.

-IRDY - готовность инициатора к обмену данными.

-TRDY - готовность устройства назначения к обмену данными.

-STOP - запрос устройства назначения к инициатору на останов текущей транзакции.

-LOCK - используется для установки, обслуживания и освобождения захвата ресурса на PCI.

-REQ {3:0} - запрос от PCI-устройства на захват шины (для слотов 3:0).

-GNT {3 0} - разрешение мастеру на использование шины.

PAR - общий бит четности для линий AD{31:0} и C/BE{3:0}.

-ParityER - сигнал об ошибке по четности (от устройства, ее обнаружившего).

-RST - сброс всех устройств.

IDSEL - выбор устройства назначения в циклах считывания и записи конфигурации.

-SERR - системная ошибка, активизируется любым устройством PCI и вызывает немаскируемое прерывание процессора (NMI).

-REQ64 - запрос на 64-битный обмен.

-ASK64 - подтверждение 64-битного обмена.

-INTR A,B,C,D - линии запросов прерывания, направляются на доступные линии IRQ BIOS компьютера. Запрос по низкому уровню допускает разделяемое использование линий прерывания.

Clock - сигнал синхронизации на тактовой частоте шины.

Test Clock, -TSTRES, TestDO, TestDI - сигналы для тестирования адаптеров по интерфейсу JTAG (на системной плате обычно не задействованы).

TSTMSLCT - перевод в режим тестирования.

Разъем шины PCI
Ряд В | Номер | Ряд А | Ряд В | Номер | Ряд А
-12 В | 1 | -TSTRES | -C / BE 3 | 26 | IDSEL
Test Clock | 2 | +12 B | AD 23 | 27 | +3,3 B
GND | 3 | TSTMSLCT | GND | 28 | AD 22
Test DO | 4 | Test DO | AD 21 | 29 | AD 20
+5 B | 5 | +5 B | AD 19 | 30 | GND
+5 B | 6 | -INTR A | +3,3 B | 31 | AD 18
-INTR B | 7 | -INTR C | AD 17 | 32 | AD 16
-INTR D | 8 | +5 B | -C / BE 2 | 33 | +3,3 B
-PRSNT 1 | 9 | Reserved | GND | 34 | -FRAME
Reserved | 10 | +VI / O | -IRDY | 35 | GND
-PRSNT 2 | 11 | Reserved | +3,3 B | 36 | -TRDY
GND / Ключ | 12 | GND /Ключ | -DEVSEL | 37 | GND
GND / Ключ | 13 | GND /Ключ | GND | 38 | -STOP
Reserved | 14 | Reserved | -Lock | 39 | +3,3 B
GND | 15 | -RST | ParityER | 40 | SDONE
Clock | 16 | +VI / O | +3,3 B | 41 | -SBOFF
GND | 17 | -GNT | SysERR | 42 | GND
-REQ | 18 | GND | +3,3 B | 43 | PAR
+V I/O | 19 | Reserved | -C / BE 1 | 44 | AD 15
AD 31 | 20 | AD 30 | AD 14 | 45 | +3,3 B
AD 29 | 21 | +3,3 B | GND | 46 | AD 13
GND | 22 | AD 28 | AD 12 | 47 | AD 11
AD 27 | 23 | AD 26 | AD 10 | 48 | GND
AD 25 | 24 | GND | GND | 49 | AD 9
+3,3 B | 25 | AD 24 | GND / Ключ | 50** | GND / Ключ
GND /Ключ | 51**** | GND / Ключ | GND | 73 | AD 56
AD 8 | 52 | -C / BE 0 | AD 55 | 74 | AD 54
AD 7 | 53 | +3,3 B | AD 53 | 75 | +VI / O
+3,3 B | 54 | AD 6 | GND | 76 | AD 52
AD 5 | 55 | AD 4 | AD 51 | 77 | AD 50
AD 3 | 56 | GND | AD 49 | 78 | GND
GND | 57 | AD 2 | +VI / O | 79 | AD 48
AD 1 | 58 | AD 0 | AD 47 | 80 | AD 46
+ VI / O | 59 | +VI / O | AD 45 | 81 | GND
-ACK 64 | 60 | -REQ64 | GND | 82 | AD 44
+5 B | 61 | +5B | AD 43 | 83 | AD 42
+5 B | 62 | +5B | AD 41 | 84 | +VI / O
Конец 32-битного разъема |  |  | GND | 85 | AD 40
 |  |  | AD 39 | 86 | AD 38
Reserved | 63 | GND | AD 37 | 87 | GND
GND | 64 | -C / BE 7 | +VI / O | 88 | AD 36
-C / BE | 65 | - C / BE 5 | AD 35 | 89 | AD 34
-C / BE | 66 | + VI / O | AD 33 | 90 | GND
GND | 67 | PAR 64 | GND | 91 | AD 32
AD 63 | 68 | AD 62 | Reserved | 92 | Reserved
AD 61 | 69 | GND | Reserved | 93 | GND
+VI / O | 70 | AD 60 | GND | 94 | Reserved
AD 59 | 71 | AD 58 | Конец 64-битного разъема
AD 57 | 72 | GND

*12, 13 - ключ для 3,3V

**50,51 - ключ для 5V

Циклы шины
По сигналам C/BE (от C/BE3 до C/BE0) во время фазы передачи адреса определяется тип цикла передачи данных.

C/BE | Команда
0000 | Interrupt Acknowledge (подтверждение прерывания)
0001 | Special Cycle (специальный цикл)
0010 | I/O Read (чтение порта)
0011 | I/O Write (запись в порт)
0100 | reserved (резервировано)
0101 | reserved (резервировано)
0110 | Memory Read (чтение памяти)
0111 | Memory Write (запись в память)
1000 | reserved (резервировано)
1001 | reserved (резервировано)
1010 | Configuration Read (чтение конфигурации)
1011 | Configuration Write (запись конфигурации)
1100 | Multiple Memory Read (множественное чтение памяти)
1101 | Dual Address Cycle (двойной цикл адреса)
1110 | Memory-Read Line (чтение памяти)
1111 | Memory Write and Invalidate (запись в память и проверка)

Подтверждение прерывания (0000)
Контроллер прерываний автоматически распознает сигнал INTA и реагирует на него передачей вектора прерывания по шине AD.

Специальный цикл (0001)
AD15-AD0 | Описание
0x0000 | Processor Shutdown (процессор прекращает работу)
0x0001 | Processor Halt (останов процессора)
0x0002 | x86 Specific Code (специальный код для машин на архитектуре Intel x86)
0x0003 to 0xFFFF | Reserved (зарезервировано)

Чтение порта (0010) и запись в порт (0011)
Порты ввода/вывода на шине PCI могут быть 8 или 16-ти разрядными, хотя собственно стандарт на шину PCI позволяет иметь 32-х разрядное адресное пространство. Это вызвано тем, что на компьютерах с архитектурой Intel x86, адрес порта может иметь не более 16 разрядов. Пока и 16-ти разрядный адрес порта не может быть использован, так как карты на шине ISA могут декодировать только 10 разрядов.

Адресное пространство конфигурации доступно по адресам портов 0x0CF8 (Адрес) и 0x0CFC (Данные), причем адрес должен быть записан первым.

Чтение памяти (0110) и запись в память (0111)

По шинам AD передается адрес двойным словом (четыре байта). Сигналы AD0 и AD1 декодировать не требуется. Истинность данных определяется сигналами C/BE.

Чтение конфигурации (1010) и запись конфигурационных данных (1011)

Эти операции выполняются для конфигурационного пространства PCI карты. Размер области конфигурации составляет 256 байт, причем читать/записывать в нее можно только в 32-х разрядной сетке, т.е. двойными словами. Поэтому AD0 и AD1 должны быть установлены в 0, AD2-7 содержать адрес двойного слова, AD8-10 используются для выбора адресуемого устройства, а оставшиеся шины адреса игнорируются.

Адрес/Бит   32          16   15           0

00          Unit ID        | Manufacturer ID
04          Status         | Command
08          Class Code               | Revision
0C          BIST  | Header | Latency | CLS
10-24            Регистр адреса
28          Резерв
2C          Резерв
30          Базовый адрес ПЗУ устройства
34          Резерв
38          Резерв
3C          MaxLat|MnGNT   | INT-pin | INT-line
40-FF       Используется самим устройством

Примечания:

  1. Unit ID - идентификационный номер устройства

  2. Manufacturer ID - идентификатор производителя устройства

  3. Status - состояние

  4. Class Code - код класса устройства

  5. BIST - Built-In Self Test - встроенный тест

Множественное чтение памяти (1100)

Это расширение обычного цикла чтения памяти. Используется для чтения больших блоков памяти без кэширования.

Двойной цикл адреса (1101)
Двойной цикл адреса необходим в том случае, если необходимо передать 64-х разрядный адрес в версии PCI с 32-х разрядной адресной сетке. В первом цикле передаются четыре младших байта адреса, затем четыре старших байта. Во втором цикле необходимо также передать команду, определяющую тип устройства, чей адрес выставлен (порт ввода/вывода, память и т.д.). Собственно PCI поддерживает 64 разряда адреса для портов ввода/вывода, но в PC на процессорах архитектуры от Intel такое адресное пространство не поддерживается (не позволяет сам процессор).

Временные диаграммы шины PCI
            ___     ___     ___     ___     ___     ___
CLK     ___|   |___|   |___|   |___|   |___|   |___|   |___

        _______                                   _________
FRAME          |_________________________________|

                ______  _______  ______  ______  ______
AD      -------<______><_______><______><______><______>---
                Адрес   Данные1  Данные2 Данные3 Данные4

                ______  _______________________________
C/BE    -------<______><_______________________________>---
                Команда Сигнал разрешения передачи байта

         ____________                                   ___
IRDY                 |_________________________________|

         _____________                                  ___
TRDY                  |________________________________|

         ______________                                 ___
DEVSEL                 |_______________________________|

Цикл передачи данных на PCI, включает 4 фазы передачи данных, без тактов ожидания. Данные передаются по переднему фронту сигнала CLK.

                        [1]              [2]        [3]
          ___     ___     ___     ___     ___     ___     ___     ___
CLK     _|   |___|   |___|   |___|   |___|   |___|   |___|   |___|   |_

        _____                                                  ________
FRAME        |________________________________________________|

                                   A               B           C
              ______           ______________  ______  _____________
AD      -----<______>---------<______________><______><_____________>--
                Адрес              Данные1      Данные2    Данные3

              ______  ______________________________________________
C/BE    -----<______><______________________________________________>--
              Команда   Сигнал разрешения передачи байта

                                                       Ожидание
         __________                                    _____         __
IRDY               |__________________________________|     |_______|

                       Ожидание        Ожидание
         ____________________         ______                         __
TRDY                         |_______|      |_______________________|

         ____________                                                _
DEVSEL               |______________________________________________|

Цикл передачи данных на PCI включает 3 фазы передачи данных с тактами ожидания. Данные передаются по переднему фронту сигнала CLK.

PCI-X

Летом 1999 года консорциум SIG по PCI принял спецификацию принципиально нового варианта шины PCI - PCI-X. Несмотря на превосходные технические параметры, новая шина разрабатывалась под скептическим взглядом Intel, которая активно ведет разработку собственной шины NGIO. До настоящего времени практически все интерфейсы, разрабатываемые Intel (AGP,PCI, USB) принимались компьютерной индустрией Официальный взгляд Intel на PCI-X выглядит так: PCI-X хорошая шина, но жизнь ее будет недолговечной, так как когда мы разработаем и утвердим NGIO, PCI-X уйдет с рынка, проиграв NGIO по переспективности и производительности. Время покажет, кто победит, но очевидно, что только при поддержке PCI-X Intel в своих chipset она может найти широкое распространение.
Активное участие таких крупных компаний как IBM, Compaq, Hewlett-Packard в разработке PCI-X тем не менее дает новой шине существенные шансы на успех, и, кроме этого, в ее пользу говорит принятие спецификации PCI-X в то время как NGIO еще находится в разработке.

Основные отличия PCI-X от PCI:

  • тактовая частота шины до 133 MHz

  • возможно использование различных слотов для разных скоростей обмена данными; стандарт предусматривает 1 слот с частотой 133 MHz, 2 слота на 100 MHz, остальные слоты могут использоваться на частоты 33 и 66 MHz.

  • значительно уменьшено время, выделяемое на операции в PCI-X (все времена в наносекундах):

    Параметр

    133 MHz PCI-X

    100 MHz PCI-X

    66 MHz PCI-X

    66 MHz обычная PCI

    33 MHz обычная PCI

    Tval (max)

    3.8

    3.8

    3.8

    6

    11

    Tprop

    2.0

    4.5

    9.5

    5

    10

    Tskew

    0.5

    0.5

    0.5

    1

    2

    Tsu

    1.2

    1.2

    1.2

    3

    7

    Tcyc

    7.5

    10

    15

    15

    30

    Thold

    0

    0

    0

    1

    2

  • Основные функциональные отличия сведены в таблицу:

Возможности | PCI | AGP1.0 | AGP2.0 | PCI-X
Совместимость с PCI | Да | Нет | Нет | Да
Скорость шины 100 Mhz | Нет | Нет | Нет | Да
Скорость шины 133 Mhz | Нет | 66 DDR | 66 DDR | Да
Скорость шины 266 Mhz | Нет | Нет | 66 QDR | Нет
Разрядность шины данных | 32/64 | 32 | 32 | 64
Разрядность шины адреса | 32/64 | 32/36/64 | 32/47/64 | 64
Максимальная скорость обмена, MBytes/s | 533 | 533 | 1064 | 1064
Допустимость нескольких слотов | Да | Нет | Нет | Да
Иерархическая топология | Да | Нет | Нет | Да
Некогерентные транзакции | Нет | Да | Да | Да
Идентификатор устройства и шины (позволяет оптимизировать параметры обмена) | Нет | Нет | Нет | Да

Примечания:

  1. DDR - Double Data Rate - удвоенная скорость обмена данными

  2. QDR - Quad Data Rate - учетверенная скорость обмена данными


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | AGP порт

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] AGP порт

  • Введение

  • Конструктивное исполнение

  • Принципы работы и основные преимущества AGP по сравнению с PCI

    1. Физические характеристики AGP по сравнению с PCI

    2. Сравнение AGP и PCI видеокарт

  • Развитие AGP

    1. AGP 2.0

    2. AGP Pro

    3. AGP 8X

  • Что дальше?

Введение

Стандарт на AGP был разработан фирмой Intel с для того, чтобы не меняя сложившийся стандарт на шину PCI, ускорить ввод/вывод данных в видеокарту и, кроме этого, увеличить производительность компьютера при обработке трехмерных изображений без установки дорогостоящих двухпроцессорных видеокарт с большими объемами как видеопамяти, так и памяти под текстуры, z-буфер и т.п.. Этот стандарт был поддержан большим количеством фирм, входящих в AGP Implementors Forum, организацию, созданную на добровольной основе для внедрения этого стандарта. Стартовая версия стандарта - AGP 1.0.

Конструктивное исполнение:

  • Отдельный слот с питанием 3.3 V, напоминающий слот PCI, но на самом деле никак с ним несовместимом. Обычная видеокарта не может быть установлена в этот слот и наооборот.

Принципы работы и основные преимущества AGP по сравнению с PCI:

1. Физические характеристики AGP по сравнению с PCI

  • Скорость передачи данных до 532 Mb/s, которая обусловлена частотой шины AGP 66 MHz, возможностью отмены механизма мультиплексирования шины адреса и данных (на PCI по одним и тем же физическим линиям сначала выдается адрес, а потом данные). Шина PCI имеет тактовую частоту 33 MHz и 32 разряда данных, поэтому может пропустить 33 000 000 х 4 байта = 132 Mb/s. AGP имеет частоту шины 66 MHz и ту же разрядность и в стандартном режиме (точнее - режим "1x") может пропустить 66 000 000 х 4 байта = 266 Mbytes/s. В режиме x1 в качестве строба используется сам сигнал тактовой частоты. Для повышения пропускной способности шины AGP в стандарт заложена возможность передавать данные с помощью дополнительных специальных сигналов, используемых как стробы, вместо сигнала CLK в обычном режиме (это режимы "2x" и "4х"). В режиме 2x пропускная способность становится тем самым 66 000 000 х 2 х 4 байта = 532 Mbytes/s. В режиме "4х" (введен в спецификации 2.0) пропускная способность возрастает соответственно, до 1064 Mbytes/s.

  • Кроме "классического" способа адресации как на PCI - сначала выставляется адрес, затем на тех же шинах появляются данные, в AGP может использоваться режим sideband addressing, называемый также "адресацией по боковой полосе", при котором шины адреса и данных разнесены и поэтому могут передаваться одновременно. Скорость обмена в режиме SBA существенно возрастает, так как ликвидируются временные затраты на передачу адреса по шине. При этом используются специальные, отсутствующие в PCI, сигналы адреса SBA (SideBand Addressing). В таблице ниже приведены результаты теста 3DMark99 для видеокарты ASUS V3400 TNT 16 MB SGRAM с включенным режимом SBA и без него.

 | 2 MB текстуры | 4 MB текстуры | 8 MB текстуры | 16 MB текстуры | 32 MB текстуры
SBA включен, кадров в секунду | 214.1 | 159.2 | 103.5 | 58.9 | 28.3
SBA выключен, кадров в секунду | 202.4 | 144.6 | 95.3 | 49.3 | 22.9

Из таблицы видно, что с увеличением размера текстур и, соответственно, увеличением объема передаваемых в видеокарту данных разница в быстродействии (в процентном отношении) резко возрастает.

  • Конвейрная обработка данных на AGP в отличии от PCI. Рисунок ниже показывает это наглядно:

Timing diagram for AGP&PCI buses

Рисунок 1. AGP против PCI. На PCI по выставленному адресу после задержки появляются данные. На AGP сначала выставляется пакет адресов, на которые следует ответ пакетом данных. (c) Intel Corporation

  • Основная обработка трехмерных изображений выполняется в основной памяти компьютера как центральным процессором, так и процессором видеокарты. Механизм доступа процессора видеокарты к памяти получил название DIrect Memory Execute (DIME - непосредственное выполнение в памяти). Следует упомянуть, что сейчас не все видеокарты стандарта AGP поддерживают этот механизм. Некоторые карты пока имеют только механизм, аналогичный bus master на шине PCI, т.е. используются каналы DMA для быстрой перекачки даннных в видеокарту. Не следует путать этот принцип с UMA (Unified Memory Architecture), который используется в недорогих видеокартах, размещенных, как правило, на материнской плате (например, SP97-V фирмы ASUSTeK Computers). Основные отличия:

    • Область основной памяти компьютера, которая может использоваться AGP картой (ее также называют "AGP память"), не заменяет память экрана. В UMA основная память используется как память экрана, а AGP память лишь дополняет ее.

    • Пропускная способность памяти в UMA видеокарте меньше, чем для шины PCI.

Рисунок 2. Структурная схема взаимодействия AGP карты и компьютера.

  • Для вычислений текстур привлекаются только центральный процессор и процессор видеокарты.

  • Центральный процессор записывает данные для видеокарты непосредственно в область обычной памяти, доступ к которой получает также и процессор видеокарты.

  • Выполняются только операции чтения/записи в память

  • Нет арбитража на шине (AGP порт всегда один) и временных затрат на него

2. Сравнение AGP и PCI видеокарт:

  • Реально AGP карта будет опережать обычную карту (если сравнивать карты с близкими по мощности видеопроцессорами) только на задачах обработки трехмерных изображений, требующих большого объема памяти для текстур (более 8 Mb). Надо понимать при этом, что собственно память компьютера должна быть не менее 32 MB, иначе AGP карте негде будет размещать текстуры.

  • Тесты различных карт, выполненные Tom Pabst осенью 1997 года, показали, что на обычных тестах практически никакой разницы между появившемися сейчас AGP картами и эталонной картой Matrox Millenium II нет. На трехмерных тестах разница есть, но не очень существенная. С тех пор много воды утекло и ситуация существенно изменилась, о чем и говорится далее.

  • Windows 95 OSR2 версии 2.5 уже достаточно полно поддерживает AGP и результаты трехмерных тестов для AGP опережают результаты для PCI, особенно при сценах с большими наборами текстур. На сайте Tom Pabst можно посмотреть их результаты. В Windows NT 4.0 поддержки AGP нет и только в версии NT 5.0 (Windows 2000) преимущества AGP можно будет использовать.

  • Стандарт AGP сам по себе не гарантирует роста производительности. Только в том случае, когда разработчик видеокарты (точнее, процессора видеокарты) использует все возможности шины, это дает прирост производительности. Например, видеокарта Matrox Millenium II AGP не поддерживает как DIME, так и режим "2x", поэтому практически невозможно найти приложение, под которым AGP вариант этой видеокарты будет как-то превосходить вариант PCI.

  • AGP видеокарта может существенно опередить такую же PCI видеокарту только в случае использования либо DMA и x2, либо DIME и x2. В режимах без x2 выигрыша практически нет. Проверить, в каком режиме работает видеокарта в компьютере, можно с помощью небольшой программы pcilist, которую можно переписать с сайта фирмы EnTech Taiwan.

Развитие AGP

1. AGP 2.0

В декабре 1997 года фирма Intel выпустила предварительную версию стандарта AGP 2.0, а в мае 1998 года окончательный вариант. Основные отличия от предыдущей версии:

  • Скорость передачи может быть увеличена еще в два раза по сравнению с 1.0 - этот режим получил название "4x" - и достигать значения 1064 MB/c.

  • Скорость передачи адреса в режиме "адресации по боковой полосе" также может быть увеличена еще в два раза

  • Добавлен механизм "быстрой записи" Fast Write (FW). Основная идея - запись данных/команд управления непосредственно в AGP устройство, минуя промежуточное хранение данных в основной памяти. Для устранения возможных ошибок в стандарт на шину введен новый сигнал WBF# (Write Buffer Full - буфер записи полон). Если сигнал активен, то режим FW невозможен.

Первые видеокарты, поддерживающие версию 2.0, появились в конце апреля 1999 года. По внешнему виду AGP разъема видеокарты можно легко определить наличие такой поддержки.

a3400tnt.jpg (35662 bytes)

Вид на разъем видеокарты с AGP 1.0

agp4x_slot.jpg (8824 bytes)

Вид на разъем видеокарты с AGP 2.0

Как видно из фотографий, конструктивно разъемы отличаются дополнительной прорезью у AGP 2.0. Поскольку соответствующий разъем на материнской плате будет иметь пластиковую полосу в под вторую прорезь, плату с AGP 1.0 в такой разъем установить будет нельзя, а наооборот - без каких-либо проблем.

2. AGP Pro

В июле 1998 года Intel выпустила версию 0.9 спецификации на AGP Pro, существенно отличающейся конструктивно от AGP 2.0. Краткая суть отличий в следующем:

  • Изменен разъем AGP - добавлены выводы по краям существующего разъема для подключения дополнительных цепей питания 12V и 3.3V

  • Совместимость с AGP 2.0 только снизу вверх - платы с AGP 2.0 можно устанавливать в слот AGP Pro, но не наооборот.

  • AGP Pro предназначена только для систем с ATX форм-фактором. Установка плат AGP Pro в NLX системы не предусмотрена (слишком велик размер платы в AGP Pro).

  • Поскольку карте AGP Pro разрешено потребление до 110 Wt (!!), высота элементов на плате (с учетом возможных элементов охлаждения) может достигать 55 мм, поэтому два соседних слота PCI должны оставаться свободными. Кроме этого, два соседних слота PCI могут использоваться платой AGP Pro для своих целей.

  • С точки зрения схемотехники новая спецификация ничего не добавляет, кроме специальных выводов, сообщающих системе о потреблении платы AGP Pro.

AGP Pro Slot Image

Из рисунка видно, что размеры слота AGP Pro вызывают ностальгические воспоминания по концу 80-х годов, когда плата контроллера дисплея выглядела почти так же (хотя по толщине не была больше одного отсека). Конечно, спецификация на AGP Pro оговаривает максимальные габариты и токи потребления, но после ознакомления с ней в голову приходит крамольная мысль - а что Intel теперь считает основным процессором в компьютере?

AGP 8X

В ноябре 2000 года Intel выпустила предварительную версию (draft) следующего варианта AGP шины - 8X. Основная идея - увеличение полосы пропускания до 8х4=32 байт за один такт системной шины. Это означает, что скорость передачи данных на шине возрастет до 2-х Гигабайт в секунду. Как это получается, видно из рисунка ниже:

Кроме этого, в проект нового варианта шины заложены несколько принципиальных изменений, расширяющих возможности интерфейса AGP. Можно перечислить некоторые из них:

  • Понижение уровня напряжений сигналов на шине

  • Циклы калибровки

  • Динамическая инверсия шины

  • Поддержка изохронного режима передачи данных

  • Поддержка нескольких AGP 8X портов (ранее был возможен только один порт)

  • Новые регистры конфигурации для 8Х шины

Что дальше?

На самом деле с уменьшением стоимости синхронной памяти SDRAM (и ее разновидности - синхронной графической памяти SGRAM), а также еще более быстрой DDR DRAM перспективы AGP не так радужны, как в свое время казалось. Основная цель, которую преследовала Intel - создание дешевого эквивалента профессиональным видеокартам с большими объемами локальной памяти теряет смысл при низкой стоимости памяти. Значение полосы пропускания в платах стандарта AGP 2.0 (1 GB/s), которые еще только должны появиться, в 2 раза меньше реальной сегодняшней полосы пропускания для локальной SGRAM памяти, достигающей 2 GB/s. Поэтому увеличение тактовой частоты и разрядности шины PCI может свести на нет все преимущества AGP.
Другое дело, что AGP стал фактически единственным интерфейсом для видеокарт и только этот факт делает практически невозможным обратный переход к PCI, поэтому AGP развиваться будет и впредь, но как бы параллельно с развитием PCI.

Accelerated Graphics Port (AGP) - Ускоренный графический порт


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | Шина USB

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] Шина USB

При подготовке этого раздела использовались материалы с USB Implementers Forum.

Содержание:

  • Введение

  • Технические характеристики

  • Топология

  • Кабели и разъемы

  • Какие устройства есть или будут использовать USB

  • Развитие USB

Введение

Шина USB (Universal Serial Bus - универсальная последовательная шина) появилась по компьютерным меркам довольно давно - версия первого утвержденного варианта стандарта появилась 15 января 1996 года. Разработка стандарта была инициировна весьма авторитетными фирмами - Intel, DEC, IBM, NEC, Northen Telecom и Compaq.
Основная цель стандарта, поставленная перед его разработчиками - создать реальную возможность пользователям работать в режиме Plug&Play с периферийными устройствами. Это означает, что должно быть предусмотрено подключение устройства к работающему компьютеру, автоматическое распознавание его немедленно после подключения и последующей установки соответствующих драйверов. Кроме этого, желательно питание маломощных устройств подавать с самой шины. Скорость шины должна быть достаточной для подавляющего большинства периферийных устройств. Попутно решается историческая проблема нехватки ресурсов на внутренних шинах IBM PC совместимого компьютера - контроллер USB занимает только одно прерывание независимо от количества подключенных к шине устройств.

usb_connect.gif (12518 bytes) Практически все поставленные задачи были решены в стандарте на USB и весной 1997 года стали появляться компьютеры, оборудованные разъемами для подключения USB устройств (см. фото слева), но периферия с подключением к USB до середины 1998 года так практически и не появилась. В чем дело? Почему только к концу 1998 года уже существенно активнее производители оборудования стали предлагать на рынке устройства с USB интерфейсом? Этому есть несколько объяснений:

  • отсутствие острой необходимости для пользователей настольных компьютеров в устройствах с полной поддержкой Plug&Play. Периферия к настольному компьютеру подключается, как правило, всерьез и надолго и особой нужды в частой смене периферии у подавляющего большинства пользователей нет.

  • более высокая стоимость устройств с USB по сравнению с аналогичными устройствами, имеющими стандартные интерфейсы

  • отсутствие поддержки со стороны производителей программного обеспечения и, главным образом, Microsoft, хотя она и была одним из авторов стандарта. Только в Windows 98 появилась полная поддержка USB, а в Windows NT она только должна быть в 1999 году.

Сейчас USB стала активно внедряться производителями компьютерной периферии. Сенсацией стало наличие в компьютере iMAC фирмы Apple Computers только USB в качестве внешней шины.

Технические характеристики

Возможности USB следуют из ее технических характеристик:

  • Высокая скорость обмена (full-speed signaling bit rate) - 12 Mb/s

  • Максимальная длина кабеля для высокой скорости обмена - 5 m

  • Низкая скорость обмена (low-speed signaling bit rate) - 1.5 Mb/s

  • Максимальная длина кабеля для низкой скорости обмена - 3 m

  • Максимальное количество подключенных устройств (включая размножители) - 127

  • Возможно подключение устройств с различными скоростями обмена

  • Отсутствие необходимости в установке пользователем дополнительных элементов, таких как терминаторы для SCSI

  • Напряжение питания для периферийных устройств - 5 V

  • Максимальный ток потребления на одно устройство - 500 mA (это не означает, что через USB можно запитать устройства с общим током потребления 127 x 500 mA=63.5 A)

Поэтому целесообразно подключать к USB практически любые периферийные устройства, кроме цифровых видеокамер и высокоскоростных жестких дисков. Особенно удобен этот интерфейс для подключения часто подключаемых/отключаемых приборов, таких как цифровые фотокамеры. Конструкция разъемов для USB рассчитана на многократное сочленение/расчленение.
Возможность использования только двух скоростей обмена данными ограничивает применяемость шины, но существенно уменьшает количество линий интерфейса и упрощает аппаратную реализацию.
Питание непосредственно от USB возможно только для устройств с малым потреблением, таких как клавиатуры, мыши, джойстики и т.п.

Топология

USB icon Такой иконой официально обозначается шина USB как в Windows 98, так и на задних стенках компьютеров (к сожалению, далеко не всех), а также на всех разъемах USB. Эта икона на самом деле правильно отображает идею топологии USB. Топология USB практически не отличается от топологии обычной локальной сети на витой паре, обычно называемой "звездой". Даже терминология похожа - размножители шины также называются HUB'ами.

Условно дерево подключения USB устройств к компьютеру можно изобразить так (цифрами обозначены периферийные устройства с USB интерфейсом):

usb_topologi.gif (3588 bytes)

Вместо любого из устройств может также стоять HUB. Основное отличие от топологии обычной локальной сети - компьютер (или host устройство) может быть только один. HUB может быть как отдельным устройством с собственным блоком питания, так и встроенным в периферийное устройство. Наиболее часто HUB'ы встраиваются в мониторы и клавиатуры

schema.gif (11347 bytes)

На рисунке выше показан пример правильного соединения периферийных устройств в условную USB сеть. Так как обмен данными по USB идет только между компьютером и периферийным устройством (между устройствами обмена нет), то устройства с большими объемами приема и/или передачи данных должны подключаться либо к самому компьютеру, либо к ближайшему свободному узлу. В данном случае наивысший трафик у колонок (~1.3 Mb/s), затем идут модем и сканер, подключенные к HUB'у в мониторе и завершают цепь клавиатура, джойстик и мышь, трафик у которых близок к нулю.
Может возникнуть вопрос - почему колонки имеют такой высокий трафик? Дело в том, что колонки с USB интерфейсом существенно отличаются от обычных. Для использования таких колонок НЕ ТРЕБУЕТСЯ звуковая карта. Драйвер колонок отправляет оцифрованный звук сразу в колонки, где с помощью АЦП (ADC) он преобразуется в аналоговый сигнал и подается на динамики.

Кабели и разъемы

Сигналы USB передаются по 4-х проводному кабелю, схематично показанному на рисунке ниже:
Usb cable image

Здесь GND - цепь "корпуса" для питания периферийных устройств, VBus - +5V также для цепей питания. Шина D+ предназначена для передачи данных по шине, а шина D- для приема данных.
Кабель для поддержки полной скорости шины (full-speed) выполняется как витая пара, защищается экраном и может также использоваться для работы в режиме минимальной скорости (low-speed). Кабель для работы только на минимальной скорости (например, для подключения мыши) может быть любым и неэкранированным.
Разъемы, используемые для подключения периферийных устройств, показаны на рисунке ниже.

Разъемы серии "А"

Разъемы серии "В"

  • предназначены ТОЛЬКО для подключения к источнику, т.е. компьютеру или HUB'у.

  • предназначены ТОЛЬКО для подключения к периферийному устройству

usb_a_male.jpg (10474 bytes)

Вилка типа "A".

usb_b_male.jpg (10585 bytes)

Вилка типа "B".

usb_a_female.jpg (3291 bytes)

Розетка типа "А"

usb_b_female.jpg (3598 bytes)

Розетка типа "В"

Как видно из рисунка, невозможно подключить устройство неправильно, так как разъем серии "А" можно подключить только к активному устройству на USB - HUB'у или компьютеру, а серии "В" только к собственно периферийному устройству.

USB разъемы имеют следующую нумерацию контактов:

Номер контакта | Назначение | Цвет провода
1 | V BUS | Красный
2 | D - | Белый
3 | D + | Зеленый
4 | GND | Черный
Оплетка | Экран | Оплетка

Цоколевка разъемов USB

usb_female_out.gif (2632 bytes) | usb_female_in.gif (1572 bytes)
Розетка типа 'A' | Розетка типа 'B'

usb_male_out.gif (1539 bytes) | usb_male_in.gif (1880 bytes)
Вилка типа 'A' | Вилка типа 'B'

Какие устройства есть или будут использовать USB

В режиме низкой скорости:

  • Клавиатуры

  • Мыши

  • Джойстики

  • Матричные принтеры

  • Дигитайзеры

  • Цифровые фотокамеры

  • Модемы для обычных телефонных линий

  • Цепи управления монитором компьютера

В режиме высокой скорости:

  • Колонки

  • ISDN модемы

  • Внешние накопители класса Iomega Zip

  • Офисные АТС

  • Лазерные и струйные принтеры

Развитие USB

В 1999 году тот же консорциум компьютерных компаний, который инициировал разработку первой версии стандарта на шину USB, начал активно разрабатывать версию 2.0 USB, которая отличается тем, что полоса пропускания шины увеличена в 20 (!) раз, до 250 Mbits/s, что делает возможным передачу видеоданных по USB и делает ее прямым конкурентом IEEE-1394 (FireWire).
Совместимость всей ранее выпущенной периферии и высокоскоростных кабелей полностью сохраняется и сохраняется одно из самых главных достоинств USB - низкая стоимость контроллера. Контроллер стандарта 2.0 также предполагается интегрировать в chipset.
Все хорошо, но есть одно но: шина IEEE-1394 уже весьма активно используется даже в бытовых цифровых видеокамерах, для нее есть платы видеомонтажа и при постоянном падении цен на цифровые видеокамеры она будет использоваться все шире и шире. Новая же версия USB должна быть только окончательно разработана к середине 2000 года, а первые устройства с поддержкой нового варианта USB должны появиться не ранее конца 2000 года. Для компьютерной индустрии это очень большие сроки. Уже в июле 1999 года, например, фирма ASUSTeK Computers выпускает первую материнскую плату (P3B-1394) со встроенным контроллером IEEE-1394. Наверняка это не останется незамеченным и другие производители также начнут выпускать подобные платы. Поэтому к моменту выхода устройств на USB 2.0 место под солнцем может быть уже занято.


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | UltraDMA/66/100

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] UltraDMA/66/100

  • Ultra DMA/66

    • Ultra ATA/100

    • Serial ATA

    Ultra DMA/66

    Появление очередного стандарта на IDE интерфейс вызвано острой необходимостью - IDE жесткие диски со скоростью вращения шпинделя 7200 об/мин начали выпускаться в заметных объемах, и ничего не мешает увеличить скорость до 10000 об/мин.
    При таких скоростях считывания скорость передачи данных по интерфейсу становится немаловажным фактором, влиящим на быстродействие компьютера в целом. Кроме этого, надо учитывать желание производителей жестких дисков поостоянно подстегивать интерес к новым технологиям и тем самым постоянно стимулировать спрос на их продукцию.

    Перед разработчиками стандарта стояла задача - увеличить вдвое скорость передачи данных, не потеряв в надежности и, самое главное, не вызвав повышения стоимости реализации интерфейса как на самом IDE устройстве, так и в контроллере IDE. Кроме этого, необходимо сохранить совместимость сверху вниз, так как низкоскоростные IDE устройства, такие как магнитооптические накопители, CD-ROM приводы и жесткие диски , выпущенные ранее, должны работать с контроллерами UDMA/66 без каких-либо проблем.

    Основное преимущество работы IDE устройств с поддержкой нового стандарта явствует из названия Ultra DMA/66 - скорость обмена по новому интерфейсу равна 66 MB/c.

    Скорость обмена
    (max.)

    Тип разъма

    Количество проводников в кабеле

    CRC контроль

    DMA Mode 1

    11.1 MBytes/s

    40-выводов IDE

    40

    Нет

    Multi-word DMA Mode 1

    13.3 MBytes/s

    40-выводов IDE

    40

    Нет

    Multi-word DMA Mode 2

    16.6 MBytes/s

    40-выводов IDE

    40

    Нет

    Ultra ATA Mode 2

    33.3 MBytes/s

    40-выводов IDE

    40

    Да

    Ultra ATA Mode 4

    66.6 MBytes/s

    40-выводов IDE

    80

    Да

    Главное отличие нового стандарта - увеличенная в два раза скорость обмена. Поскольку длительность каждого сигнала на IDE соответственно также уменьшается в два раза, то резко возрастает угроза влияния помех на сигналы интерфейса. Уже при разработке стандарта UltraDMA/33 был применен метод CRC (Cyclical Redundancy Check - циклический контроль с избыточным кодом) и данные тем самым контролировались на всей цепи их прохождения.
    CRC сохранился в качестве метода контроля целостности данных, но, кроме этого, пришлось впервые (с момента появления IDE интерфейса) изменить кабель, показанный на рисунке ниже.

    udma66_cable.gif (6986 bytes)

    Теперь кабель имеет 80 проводников при тех же 40 контактах. Во всем остальном стандарт полностью совместим со своими предшественниками. Любой жесткий диск с интерфейсом UltraDMA/66 будет работать с любым контроллером IDE и наооборот. Единственное жесткое условие - жесткий диск стандарта UltraDMA/66 будет работать с соответствующим контроллером только через специальный кабель. Как видно на фотографии ниже, внешне кабель для UltraDMA/66 отличается только более тонкими проводниками и разница эта не очевидна (если только рядом не лежит обычный IDE кабель). Проще всего отличить один кабель от другого по цвету разъемов. На кабелях для UltraATA/66 голубой разъем ВСЕГДА подключается к контроллеру, а черные разъемы - к периферийным устройствам.

    UltraDMA/66 Cable photo

    На фотографии верхний кабель - обычный IDE кабель, ниже - кабель для UltraDMA/66.

    Первые жесткие диски с поддержкой нового стандарта были выпущены фирмой Western Digital в декабре 1998 года.

    В заключении хотелось бы предостеречь от больших надежд на качественный скачок в производительности дисковой подсистемы компьютера после появления и внедрения UltraDMA/66. Реально скорость работы в 66 MBytes/sec будет достигаться только при работе с буфером на жестком диске. Поэтому при работе с жестким диском, имеющим размер буфера до 512 kBytes, можно ручаться за то, что никакого реального прироста производительности дисковой подсистемы при замене диска и контроллера с UltraDMA/33 на UltraDMA/66 не произойдет. Какое-то повышение производительности будет заметно на жестких дисках с буфером 2 MBytes и больше. Скорее всего размер буфера и дальше будет расти, так как только в этом случае рост скорости интерфейса будет заметен.
    Многие проводят параллели между SCSI и IDE, так как скорость SCSI интерфейса также постоянно растет. Но эти сопоставления неправомерны - на одной SCSI шине может быть до 15 устройств и при размере буфера на каждом, например, 2 MBytes, контроллер должен иметь возможность непрерывно оперировать с 30 MBytes данных и для этого просто необходимо иметь высокие скорости на SCSI интерфейсе. На IDE шине в принципе возможно подключение только двух устройств и поэтому скорость интерфейса такого существенного значения не имеет.
    Результаты практического применения UltraDMA/66 можно посмотреть здесь.

    Ultra ATA/100

    В самом начале 2000 года появились первые соообщения об очередном развитии IDE интерфейса - Ultra ATA/100 и в июне того же года Intel выпустила первый контроллер, поддерживающий новый вариант IDE интерфейса. Этот контроллер получил название 82801BA ICH2 и входит в состав наборов i820e и i815e. Первый жесткий диск с новым интерфейсом выпустила фирма Maxtor также в середине 2000 года.

    Скорость обмена
    (max.)

    Тип разъма

    Количество проводников в кабеле

    CRC контроль

    DMA Mode 1

    11.1 MBytes/s

    40-выводов IDE

    40

    Нет

    Multi-word DMA Mode 1

    13.3 MBytes/s

    40-выводов IDE

    40

    Нет

    Multi-word DMA Mode 2

    16.6 MBytes/s

    40-выводов IDE

    40

    Нет

    Ultra ATA Mode 2

    33.3 MBytes/s

    40-выводов IDE

    40

    Да

    Ultra ATA Mode 4

    66.6 MBytes/s

    40-выводов IDE

    80

    Да

    Ultra ATA Mode 5

    100 MBytes/s

    40-выводов IDE

    80

    Да

    Принцип функционирования Ultra ATA/100 не существенно отличается от UltraDMA/66 (Ultra ATA/66). После получения информации от жесткого диска о его поддержке режима Ultra ATA/100 драйвер IDE соответствующим образом программирует IDE контроллер и просто повышается тактовая частота работы на интерфейсе. Внутренняя частота контроллера в этом режиме становится 133 MHz, но, поскольку сигналы записи на диск формируются контроллером, а сигналы чтения с диска собственно диском и есть значительная разница в способах формирования сигналов записи и чтения, чтение диска выполняется со скоростью 100 MBytes/s, в то время как запись только со скоростью 88.9 MBytes/s. Несимметричность интерфейса, пожалуй, главная особенность нового варианта IDE.

    Для работы с конкретным диском по Ultra ATA/100 совершенно необязательно поддержка этого режима другими устройствами на том же канале IDE. Обмен данными по Ultra ATA/100 возможен между контроллером и именно тем устройством, которое этот режим поддерживает.

    Никаких конструктивных изменений новый интерфейс не требует. Подходит тот же кабель, что и для Ultra DMA/66.

    Serial ATA

    Последовательный IDE, или более правильно ATA интерфейс пока не будоражит умы, но очевидно, что переход на последовательный тип интерфейса неизбежен и здесь - для подключения даже таких недорогих устройств, как жесткие диски и другие накопители информации.
    В чем принципиальная разница между параллельным и последовательным интерфейсом? Немного утрируя, можно представить передачу данных так:

    • Параллельный интерфейс. Данные передаются одновременно байтами, словами и т.д., в сопровождении специального сигнала. В качестве такого сигнала может выступать и собственно сигнал записи или чтения. По какому-либо фронту этого сигнала и осуществляется запись данных, при чтении - в контроллер интерфейса, а при записи - в само устройство. Для повышения производительности интерфейса часто используется несколько подобных сигналов и оба фронта каждого из них. Количество физических проводов определяется в этом случае разрядностью интерфейса, набором управляющих сигналов и т.п. Пример - PCI, IDE, SCSI, AGP, Centronics.
    • Последовательный интерфейс. Данные передаются побитно, один бит за другим по одному физическому проводу и разрядность передаваемых данных значения не имеет. Пример - RS232C, IEEE-1394, USB, Ethernet, Fibre Channel.

    С точки зрения обыкновенного здравого смысла параллельный интерфейс всегда быстрее по определению - за один период тактового сигнала шины передаются сразу 8 или 16 или 32 или 64 бита данных. Это утверждение на самом деле правильно для бескабельных шин, таких, как например PCI или AGP. Для бескабельных интерфейсов в качестве проводников используются проводники в печатной плате, которые могут быть достаточно легко разведены в различных слоях печатной платы и их взаимовлияние, а также воздействие внешних помех может быть сведено к минимуму.
    Но для шин, которые используют кабели для подключения устройств к контроллерам шины, ситуация совсем иная. При прохождении сигналов по параллельной шине вместе с повышением тактовой частоты шины растет как уровень наводок сигналов шины друг на друга, так и "незащищенность" шины от внешних помех. Источников помех много как в самом компьютере, так и за его пределами. Разработчики параллельных интерфейсов, конечно, принимают меры для снижения ущерба от наводок и помех. На примере IDE/ATA можно увидеть, что уже на этапе UltraDMA/33 был введен CRC контроль для проверки правильности приема/передачи данных по интерфейсу. Но этого оказалось недостаточно и всего через год для внедрения UltraDMA/66 потребовалась замена и интерфейсного кабеля с обычного в 40 проводников на кабель с 80 проводниками. Дополнительные провода были добавлены в кабель исключительно для защиты от помех.
    Дальнейшее развитие IDE/ATA как параллельного интерфейса с точки зрения специалистов стало невозможным. Потери от помех, точнее от применения методов защиты от помех сводят на нет повышение пропускной способности интерфейса.

    Именно по указанным выше причинам компании APT Technologies, Dell, Intel, Maxtor, Quantum, Maxtor, Seagate создали рабочую группу по разработке нового стандарта интерфейса для подключения различных накопителей информации. Стандарт был назван SerialATA. Конкретные преимущества нового интерфейса таковы:

    • Малое количество проводов - 2 пары
    • Возможность подачи питания по общему кабелю.
    • Высокая скорость обмена данными с практически неограниченными ресурсами для роста в будущем.
    • Стоимость набора "контроллер + кабель + интерфейсная часть накопителя" практически совпадает с обычным параллельным IDE.

    Разъемы, которые будут использоваться в новом интерфейсе, выглядят так:

    Здесь с - интерфейсная часть кабеля, d - разъем питания на кабеле, a и b - ответные части на накопителе информации.

    В таблицу ниже сведены этапы развития нового стандарта.

    Первый этап | Второй этап | Третий этап
    Скорость обмена | 1.2 GBytes/s | 2.4 GBytes/s | 4.8 GBytes/s
    Начало внедрения | середина 2001 года | середина 2004 года | середина 2007 года
    Кабель/разъемы | Как на первом этапе | Возможны изменения
    Совместимость по сигналам | Да | Да

    Для совместимости жестких дисков и других накопителей планируется на первом этапе выпуск этих устройств с поддержкой SerialATA и обычного IDE одновременно.

    • 1997-2006 © Компания Сплайн. При полном или частичном


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | IEEE-1394 (FireWire)

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] IEEE-1394 (FireWire)

При подготовке этого раздела использовались материалы с сайта IEEE-1394 Trade Association.

Содержание:

  • Введение

  • Технические характеристики

  • Совместимость

  • Топология шины

  • Сеть на IEEE-1394

  • Кабели и разъемы

Введение

В последнее время, в связи с бурным ростом возможностей компьютерной обработки видеоизображений в компьютерном мире возникла острейшая нужда в высокоскоростной шине, по которой было бы возможно передавать значительные потоки данных, и кроме этого, требовала всего нескольких проводов (т.е. была бы последовательной), позволяла бы строить "деревья", на которые можно было бы "нанизывать" различные периферийные устройства. По скоростным характеристикам из существующих шин, допускающих подключение внешних устройств к компьютеру, подходит только SCSI, но она не удовлетворяет многим из условий, описанных выше.
Во-первых, для высокоскоростной передачи данных необходим вариант Ultra Wide SCSI, который требует разъемов с большим числом контактов, что делает практически невозможным размещение такого разъема на, например, цифровой видеокамере. Во-вторых, топология SCSI шины предполагает только последовательное подключение устройств к шине, что приводит как к необходимости иметь на внешнем устройстве два разъема и так и иметь в обязательном порядке терминатор для установки его на последнем разъеме в цепи. В-третьих, шина SCSI не предусматривает цепей питания для периферийных устройств и это приводит к обязательной необходимости внешнего источника питания для каждого из периферийных устройств. В-четвертых, шина SCSI не предусматривает "горячего" (т.е. без выключения питания и перезагрузки компьютера) подключения/отключения устройств на шине.
Интерфейс USB, который очень подходит конструктивно (маленький разъем, есть цепи питания для периферийных устройств), не имеет необходимой для переноса больших потоков данных пропускной способности. Новый вариант USB (2.0), который начал разрабатываться в 1999 году, удовлетворяет практически всем требованиям к высокоскоростной шине, но завершена его разработка только в первом квартале 2000 года, а появились первые устройства с его поддержкой только в начале 2001 года.
Именно из-за ограничений имеющихся шин интерфейс IEEE-1394 (FireWire) стал широко внедряться в компьютерной индустрии в последние годы уходящего века. Так как название FireWire (огненный провод) принадлежит фирме Apple Computers и может использоваться только для описания изделий Apple или с ее разрешения, правильное название - IEEE-1394. Некоторые компании придумали собственное зарегистрированное название, например у Sony - iLink. Пока основная сфера применения IEEE-1394 - поддержка обмена данными между компьютером и видеокамерами и видеомагнитофонами DV стандарта. В связи с тем, что DV видеокамеры выпускаются во все больших и больших количествах и при непрерывном падении стоимости, некоторые производители материнских плат уже в конце 1999 года объявили о выходе первых плат со встроенным контроллером IEEE-1394. В частности, фирма ASUSTeK Computers выпустила материнскую плату P3B-1394 со встроенным контроллером IEEE-1394.
Новая сфера применения, получившая основное развитие с начала 2000 года - устройства хранения информации с интерфейсом IEEE-1394. Начали выпускаться внешние боксы для установки в них любых IDE/ATAPI устройств с внешним интерфейсом IEEE-1394, питанием по этому же интерфейсу и возможностью "горячего" подключения к компьютеру. В первую очередь такие устройства находят себе применение для обмена видеоинформацией, так как на один IDE жесткий диск сейчас возможно записать до 6 часов видео DV формата и, как правило, в компьютерах, предназначенных для обработки цифрового видео, есть контроллер интерфейса IEEE-1394. Фирма Fujitsu также выпустила аналогичные накопители на магнитооптических дисках емкостью до 1.3 GBytes.
Самые массовые из устройств, в которых используется интерфейс IEEE-1394, цифровые видеокамеры, требуют скорости передачи данных всего 25 Mbits/s, но ряд периферийных устройств, таких как жесткие диски, сканеры требуют скоростей обмена выше 400 Mbits/s и в конце мая 2001 года был согласован следующий вариант стандарта, IEEE-1394b, предусматривающий повышение скорости передачи данных вдвое, т.е. до 800 Mbits/s.
Посмотреть весь спектр производимых с интерфейсом IEEE-1394 устройств можно на www.askfor1394.com.

Технические характеристики

Основные характеристики шины можно свести к следующим показателям:

  • скорость передачи данных до 400 Mbits/s по стандарту IEEE-1394a и 800 Mbits/s по стандарту IEEE-1394b, согласованному в 1394 Trade Association в конце мая 2001 года.

  • 16-ти разрядный адрес позволяет адресовать до 64K узлов на шине

  • предельная теоретическая длина шины 224 метра

  • "горячее" подключение/отключение без потери данных

  • автоматическое конфигурирование, аналогичное Plug&Play

  • произвольная топология шины - по аналогии с локальными сетями может использоваться как "звезда" так и общая шина (только в виде цепочки, в отличие от сети на коаксиальном кабеле)

  • никакие терминаторы не требуются

  • возможность обмена с гарантированной пропускной способностью, что крайне необходимо для передачи видеоизображений

  • Максимальное расстояние между двумя устройствами в цепочке по IEEE-1394a - 4.5 м, по IEEE-1394b - 100 м.

Топология шины

Топология IEEE-1394 позволяет как древовидную, так и цепочечную архитектуру, а также комбинацию из того и другого. Поэтому легко строить любые варианты подключения различных устройств к шине. Стандарт предусматривает архитектурное разделение шины на 2 основных блока - кабельная часть и контроллер (контроллеры). Так как контроллеров может быть несколько, эту часть также называют объединительной (backplane - дословно задний план, кросс-плата и т.п.).
Адрес узла на "дереве" 16-ти разрядный, что позволяет адресовать до 64К узлов. К каждому узлу может быть подключено до 16-ти конечных устройств. На объединительной панели (backplane) может быть подключено до 63 узлов к одному мосту (bridge) шины. Так как под идентификатор номера шины (моста) отведено 10 разрядов, то общее количество узлов и составляет 64K.
Каждый узел обычно предусматривает подключение 3-х устройств, хотя собственно стандарт разрешает подключение до 27 устройств. Устройства могут быть подключены через стандартные кабели длиной до 4.5 метра.

wire1fig1.gif (6150 bytes)

Пример топологии IEEE-1394

Здесь и далее на рисунках под DV (Digital Video) устройствами понимаются устройства с интерфейсом IEEE-1394.

Физические адреса (ID) устройствам назначаются при подаче питания на контроллер шины и устройства, подключенные к ней, после общего сброса шины, а также при "горячем" подключении устройства к шине. Адреса присваиваются в порядке последовательности обнаружения и/или подключения устройств. Никакая установка перемычек или переключателей на самих устройствах не требуется.
Стандарт на кабельную часть предусматривает три скорости передачи данных по шине - 98.304, 196.608 и 393.216 Mbits/s. Обычно эти значения в различных документах огругляют до 100, 200 и 400 Mbits/s, используя для краткости обозначения S100, S200 и S400.

Благодаря применению размножителей, репитеров и т.п. устройств топология IEEE-1394 может быть достаточно сложной, хотя в 90% случаев ее применения наверняка столь сложная топология не потребуется.

fw_topology2.gif (9926 bytes)

Совместимость

Для удобства программирования и совместимости устройств на IEEE-1394 был разработан стандарт, названный Open Host Controller Interface (OHCI). Он предъявляет определенные требования к регистрам контроллера IEEE-1394 и их отображению в памяти. Кроме этого, OHCI совместимый контроллер должен удовлетворять требованиям по управлению энергопотреблением в соответствии со спецификацией ACPI.
Microsoft в своих операционных системах Windows 98 Second Edition и Windows 2000 поддерживает только OHCI совместимые контроллеры IEEE-1394. Все остальные контроллеры (например, от Adaptec) должны сопровождаться соответствующими драйверами и совместимость таких устройств с драйверами жестких дисков операционной системы, например, не гарантируется.

Сеть на IEEE-1394

В вышедшей осенью 2000 года операционной системе Microsoft Windows Millenium Edition впервые появилась встроенная поддержка сетей на базе контроллеров IEEE-1394. Такая сеть имеет скорость передачи данных в 4 раза большую, чем Fast Ethernet и очень удобна для дома или малого офиса. Единственное неудобство при построении такой сети заключается в малой предельной длине одного сегмента, всего 4.5 метра. Для ликвидации подобного недостатка выпускаются репитеры на 2 или 3 соединения, подобные показанным на фотографиях ниже:

Кабели и разъемы

Стандартный кабель для IEEE-1394 состоит из 2 витых пар передачи сигналов шины, двух проводов питания и все это заключено в экранированную оболочку. Провода питания рассчитаны на ток до полутора ампер и напряжение от 8 до 40 вольт. На рисунке ниже показан один из вариантов кабеля IEEE-1394.

cable1394.GIF (1423 bytes)

Кабели и розетки для подключения периферийных устройств существуют в нескольких вариантах, в зависимости от требуемых параметров (это только ряд примеров):

Кабель на 6/6 проводов, поддержка скорости передачи до 400 Mbits/s. Напряжение питания до 40 V при токе до 1.5 А. Длина от 0.7 м до 4.5 м. | 5923366a.gif (3773 bytes)
Кабель на 6/4 проводов, поддержка скорости передачи до 100 Mbits/s. Напряжение питания до 5 V при токе до 0.5 А. Длина от 1 м до 4.5 м. | 5923364a.gif (4112 bytes)
Кабель на 4 провода, поддержка скорости передачи до 100 Mbits/s. Напряжение питания до 5 V при токе до 0.5 А. Длина от 1 м до 4.5 м. | 5923344a.gif (3360 bytes)
Розетка на 4 провода, поддержка скорости передачи до 400 Mbits/s. Напряжение питания до 5 V при токе до 0.5 А. | 54030a.gif (2533 bytes)
Розетка на 6 проводов, поддержка скорости передачи до 400 Mbits/s. Напряжение питания до 40 V при токе до 1.5 А. | 53462a.gif (3637 bytes)
Розетка на 6 проводов, поддержка скорости передачи до 400 Mbits/s. Напряжение питания до 40 V при токе до 1.5 А. | 53460a.gif (2872 bytes)


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | SCSI глоссарий

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] SCSI глоссарий

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Объяснение многих терминов, применяемых по отношению к SCSI устройствам, просто необходимо для понимания правильности применения SCSI.

A

Active Negation - активное отрицание - применение этого метода позволяет существенно снизить шумы на SCSI шине.

Active Termination - активное терминирование - в случае активного терминирования активный терминатор представляет собой один или несколько стабилизаторов напряжения вместо пассивного делителя напряжения на резисторах, применяемого при пассивном терминировании.
Вот так устроен пассивный терминатор (символом /// изображены резисторы):

    Питание  ------////-------+------////-----  GND
                                       |
                                       |
                               SCSI сигнал

Такая схема должна использоваться для каждого сигнала шины SCSI.

Активный терминатор существенно отличается от него:
             Регулятор на 2.85V
               +-----------+   +2.85V    110 Om
Питание   -----|вход выход |-----+------////------SCSI сигнал
               |   gnd     |     |
               +-----------+     |
                    |            +------////------SCSI сигнал
                    |            |
GND  ---------------+            |
                                 +------////------SCSI сигнал
                                 |
                                и т.п.

Напряжение, вырабатываемое специальным стабилизатором, показанным на рисунке, всегда корректируется в зависимости от общей нагрузки и поддерживается на необходимом уровне.

ASPI - Advanced SCSI Programming Interface (усовершенствованный интерфейс программирования для SCSI) - стандарт для программирования взаимодействия между SCSI контроллером и драйверами SCSI устройств. ASPI позволяет разным драйверам разделять один аппаратный канал SCSI.

ASPI Manager - ASPI менеджер - программа, управляющая взаимодействием различных ASPI модулей, собственно SCSI контроллеров и устройств SCSI, подключенных к этим контроллерам. ASPI менеджеры всегда создаются под конкретную операционную систему - DOS, OS/2 и UNIX, а также конкретные модели SCSI контроллеров.

Asynchronous Data Transfer - асинхронная передача данных - один из способов передачи данных по SCSI интерфейсу. Был введен в самом первом варианте стандарта SCSI (SCSI-1). Скорость передачи данных, как правило, не превышает 2 MB/s. Основное отличие асинхронного интерфейса от синхронного в том, что по асинхронному интерфейсу передача данных осуществляется только после подтверждения принимающим устройством приема ранее посланных данных и разрешения тем самым на передачу следующих. Его еще иногда называют интерфейсом спросил/ответил. Отсюда простой вывод - чем длиннее кабель, тем ниже скорость передачи, так пока сигнал подтверждения приема не придет к передатчику, новые данные не будут отправлены. Задержка распространения сигнала составляет для типичного SCSI кабеля 5.25 ns/m.

B

BIOS - Basic Input/Output System (базовая система ввода/вывода) - в данном случае программа настройки и управления SCSI контроллерами. Аналогично BIOS материнской платы, хранится в специальной микросхеме памяти, как правило, позволяющей перезапись информации. В любом случае, наличие энергонезависимой памяти обязательно для SCSI контроллера для хранения настроек BIOS.

Bus Mastering - единоличное управление шиной - метод, подробно описываемый в основном "Глоссарии", и используемый практически всеми современными SCSI контроллерами.

C

Command Queueing - формирование очереди команд - в первоначальном варианте SCSI стандарта (SCSI-1) такое понятие отсутствовало, так как можно было послать только одну команду на одно устройство. Теперь можно посылать до 256 команд сразу на одно устройство, причем устройство имеет право само определить порядок выполнения команд для оптимизации своей работы.

D

Differential - дифференциальный - термин, указывающий, что сигнал на SCSI двуполярный, т.е. значение определяется не только уровнем, но и также полярностью используемого напряжения. Это позволяет снизить воздействие шумов на SCSI шину и максимально физически удлинить SCSI кабель. Первый вариант SCSI интерфейса с использованием двуполярных сигналов LVD SCSI (Ultra2SCSI), разрешает длину кабеля до 12 m.

Disk Array - дисковый массив - несколько дисков, объединенных SCSI контроллером как бы в один физический диск, который видит операционная система.

E

Exclusive OR (XOR) - исключающее ИЛИ - одна из операций в булевой алгебре. При выполнении этой операции над 0 и 1 результат равен 0, над 1 и 1 тоже 0 и только при 0 и 0 результат равен 1. Благодаря таким свойствам, этот алгоритм используется в RAID уровней 2, 3, 4 и 5, так в результате побитной операции XOR, например, над двумя байтами сразу определяется количество единиц в байте. Эта информация сохраняется вместе с данными на диске для их контроля.

F

Fast SCSI - быстрое SCSI - следующий этап развития самого первого варианта стандарта SCSI (SCSI-1). Согласно этому стандарту, скорость передачи данных была повышена с 5 MBytes/s до 10 MBytes/s. Термин Fast SCSI применим только к контроллерам и устройствам, обеспечивающим синхронный обмен данными со скоростью свыше 5 MBytes/s, т.е. 10 MBytes/s и выше. Этот применим только к SCSI-2 устройствам, так как SCSI-1 таких характеристик по скорости не обеспечивает.

Forced Perfect Termination (FPT) - принудительное идеальное терминирование - наиболее современная форма терминирования с использованием нескольких регуляторов напряжения и нескольких диодов. Идея FPT показана на рисунке.

Fpt.gif (4453 bytes)

FPT делает невозможным практически любые переотражения сигнала и поэтому становится популярной формой активного терминирования.

H

Host - главный - собственно компьютер, в который устанавливается Host Adapter.

Hot Swap - горячая замена - термин, применяемый для дисковых систем, допускающих смену жесткого диска во время операций обращения к дисковой системе без потерь информации в системе.

Host Adapter - главный адаптер - общепринятое наименование интеллектуальных контроллеров, которые управляют подключенными к ним периферийными устройствами. К таким адаптерам относятся и SCSI контроллеры.

I

Interrupt 13 (оно же INT13) - 13 прерывание - программное прерывание для операций с дисками, используемое DOS. Поддерживается BIOS компьютера для IDE жестких дисков и BIOS SCSI адаптеров для SCSI жестких дисков. Если SCSI контроллер обнаружил подключенный к нему жесткий диск (диски), то он загружает поддержку INT13 для своих дисков и перехватывает обращения внешних DOS программ (или обращения, например Windows до загрузки ими драйвера SCSI контроллера) к SCSI жестким дискам. Поддержка INT13 распространяется только на жесткие диски. Если к SCSI контроллеру подключен, например, только привод CD-ROM, то SCSI BIOS не загружается и контроллер выдает сообщение: Hard Disk Drive not found - SCSI BIOS not installed! (Жесткий диск не обнаружен, SCSI BIOS не используется).

Initiator - инициатор - устройство, вырабатывающее команды на SCSI шине, как правило, это SCSI контроллер. Инициатор обязательно работает в паре с target.

L

LVD - Low Voltage Differential (низковольтный дифференциальный) - двуполярный дифференциальный) сигнал, используемый для высокоскоростной передачи данных в современных вариантах SCSI интерфейса. При использовании LVD уровень напряжения сигнала находится в пределах +--1.8 V. На LVD интерфейсе сигналы положительной и отрицательной полярности идут по разным физическим проводам. Для поддержки SCSI LVD требуется специальный кабель, состоящий из групп витых пар.

LUN - Logical Unit Number (логический номер устройства) - дополнительный идентификатор устройства на шине SCSI, позволяющий разместить на одном физическом SCSI адресе несколько устройств. Например, внешний дисковый массив имеет один SCSI адрес, но каждому диску присваивается свой LUN, что позволяет компьютеру видеть каждый диск в отдельности.

M

Mirroring - зеркализация - также часто называется RAID уровня 0 или дуплексированием (при использовании 2 SCSI контроллеров). Реализуется полным дублированием записываемой информации на 2 диска одновременно. Дорогостоящий метод с точки зрения дисковой избыточности, но позволяющий сэкономить средства за счет применения обычного SCSI контроллера, а не дорогостоящего контроллера RAID.

MTBDL - Mean Time Before Data Loss (время между потерями данных) - один из показателей надежности RAID контроллеров. Означает среднее время между случаями потери или повреждения данных RAID контроллерами.

MTBF - Mean Time Between Failure (время между отказами) - один из показателей надежности. Как правило, этим показателем оценивается надежность жестких дисков. Для SCSI дисков обычным значением MTBF является 1 000 000 часов.

MTDA - Mean Time Data Availability (время доступности данных) - среднее время между сбоями доступа к данным без потери и/или повреждения самих данных.

MTTR - Mean Time To Repair (время для ремонта) - параметр определяет среднее время восстановления RAID массива до первоначального полностью отказоустойчивого состояния.

Multithreading - многопотоковость - способность SCSI контроллера формировать 2 или более ожидающих обработки команд к 2 или более SCSI устройствам.

N

Narrow SCSI Device - дословно "узкое SCSI устройство" - таким термином в документации и литературе по SCSI устройствам исторически обозначаются 8-ми разрядные SCSI устройства. Как "широкие" (wide) обозначаются 16-ти разрядные SCSI устройства.

P

Parity - четность - один из способов использования избыточности данных для контроля их целостности. Применяется в RAID уровней 2, 3, 4 и 5 для восстановления данных из-за какой-либо аварии.

Q

QAS - Quick Arbitration and Selection (быстрый арбитраж и выбор) - механизм, применяемый в Ultra320 SCSI для снижения непроизводственных затрат на SCSI шине. Увеличивает максимальное использование SCSI шины, но поддерживается только в том случае, если поддержка QAS есть в подключенных к шине устройствах.

R

RAID - Redundant Array of Inexpensive Disks (избыточный массив недорогих дисков) - это термин был придуман в 1987 году учеными Университета Беркли в Калифорнии. Контроллеры RAID систем используются для построения дисковых массивов, в которых выход из строя одного из дисков не приводит к потере или повреждению данных, хранящихся на дисках массива. Для RAID массивов определены ряд уровней (level):

  • RAID уровня 0 - требует минимально 2-х дисков и обеспечивает наивысшую производительность, но без защиты от потери и/или повреждения данных. Алгоритм работы основан на разделении данных на "полоски" (striping). В том случае, если от дисковой системы требуется наивысшая производительность, но при этом также требуется защита от выхода из строя жестких дисков и нет недостатка в средствах, устанавливаются два RAID контроллера зеркально и каждый конфигурируется под уровень 0.

  • RAID уровня 1 - работает только с 2 дисками и фактически делает только зеркализацию (mirroring). Зеркализация не снижает производительность при чтении, но скорость записи снижается существенно, так как приходится выполнять запись на два диска, причем сначала на один, затем на другой.

  • RAID уровня 5 - требует минимально 3-х дисков и обеспечивает как защиту данных от выхода из строя жестких дисков, так и вполне приемлемую производительность. Применяется как striping, так и parity. Избыточность составляет 1 диск в одном массиве. Т.е. при установке 3-х дисков по 9 GBytes операционная система увидит только 18 GBytes. Установив 6 дисков по 9 GBytes, можно использовать для работы 45 GBytes и т.д.

  • RAID уровня 7 - требует хотя бы одного диска и представляет собой обычное независимое подключение дисков к RAID контроллеру. Никакие striping, parity и т.п. не используются. Сами диски могут быть отформатированы и разбиты на логические диски в необходимой для использования операционной системе. При использовании RAID других уровней это невозможно. Применение RAID 7 фактически представляет собой использование RAID контроллера в качестве обычного, но очень высокопроизводительного SCSI контроллера с кэш-памятью.

  • RAID уровня 0+1 - использует striping от RAID уровня 0 и mirroring от RAID уровня 1. Отличается повышенной, по сравнению с обычным RAID уровня 1, производительностью, хотя избыточность по-прежнему 100%.

  • RAID уровня 10 - та же архитектура, что и в RAID уровня 0+1, но примененная для дискового массива из нескольких групп дисков. Избыточность соответственно 100%.

  • RAID уровня 30 - используется striping, но "полоска" данных распределяется по большим группам дисков с использованием контроля по четности..

  • RAID уровня 50 - то же, что и RAID уровня 30, но с использованием XOR для контроля целостности данных.

Redundant - избыточность - дублирование диска или любой другой составляющей дисковой подсистемы для сохранения данных.

Removability - переносимость - возможность устройства со сменным носителем, такой как магнитооптический накопитель, например, выполнять замену диска во время работы без потери данных. Без поддержки режима переносимости замена диска приведет к потере данных.

S

SAF-TE - SCSI Accessed Fault-Tolerant Enclosures (Доступная диагностика сбоев SCSI устройств) - спецификация на аппаратное обеспечение корзин для жестких дисков горячей замены. Предусматривает диагностику температуры жестких дисков, а также их работоспособности по анализу активности диска. В соответствии с результатами диагностики также выполняется управление индикацией работоспособности и активности по каждому из дисков, установленных в корзине. В случае выхода из строя диска также предусматривается отключение питания неисправного диска. Если к корзине подключены вентиляторы, то обеспечивается управление их включением/выключением в зависимости от температуры внутри корзины. Программы диагностики, поставляемые производителями RAID контроллеров, например AMI, умеют извлекать диагностическую информацию из корзин, поддерживающих эту спецификацию.

SCAM - SCSI Configures Auto Magically (SCSI устройства конфигурируются автоматически, как по волшебству) - алгоритм конфигурирования SCSI устройств, представляющий собой как бы Plug and Play, но только для SCSI устройств. SCSI адаптер, поддерживающий такой режим, может присвоить адрес SCSI устройства (SCSI ID) автоматически как самому себе, так и всем периферийным устройствам, подключенным к нему. Поддержка SCAM также дает возможность SCSI контроллеру управлять терминированием всей шины.

SCSI - Small Computer Systems Interface (системный интерфейс для малых компьютеров) - интерфейс, разработанный для объединения на одной шине различных по своему назначению устройств, таких как жесткие диски, накопители на магнитооптических дисках, стримеры, сканеры и т.д. Применяется в различных архитектурах компьютерных систем, а не только в PC. Стандарт определяет не только физический интерфейс, но и систему команд, управляющих устройствами SCSI. За время своего существования стандарт активно развивался и к настоящему времени существуют следующие варианты (термины в таблице утверждены техническим комитетом T10 по SCSI):

Название | Макси- мальная скорость, Mbytes/s | Разрядность шины | Максимальная длина кабеля в метрах (1) |  |  | Макси- мальное количество устройств
 |  |  | Single- ended SCSI | Диф- ферен- циальный сигнал | LVD
SCSI-1 (2) | 5 | 8 | 6 | 25 | (3) | 8
Fast SCSI (2) | 10 | 8 | 3 | 25 | (3) | 8
Fast Wide SCSI | 20 | 16 | 3 | 25 | (3) | 16
Ultra SCSI (2) | 20 | 8 | 1.5 | 25 | (3) | 8
Ultra SCSI (2) | 20 | 8 | 3 | 25 | (3) | 4
Wide Ultra SCSI | 40 | 16 | - | 25 | (3) | 16
Wide Ultra SCSI | 40 | 16 | 1.5 | - | - | 8
Wide Ultra SCSI | 40 | 16 | 3 | - | - | 4
Ultra2 SCSI (2,4) | 40 | 8 | (4) | 25 | 12 | 8
Wide Ultra2 SCSI (4) | 80 | 16 | (4) | 25 | 12 | 16
Wide Ultra3 SCSI (6) | 160 | 16 | (4) | (5) | 12 | 16
Wide Ultra3 SCSI 320 (6) | 320 | 16 | (4) | (5) | 12 | 16

Примечания:

  1. Кабель максимальной длины не рекомендуется использовать.

  2. Слово "narrow" может предшествовать этому термину.

  3. В стандартах SCSI не предполагается применение технологии LVD для таких вариантов интерфейса.

  4. Только в том случае, если все устройства на шине поддерживают LVD, возможно использование кабеля до 12 метров длиной и, кроме этого, работа со скоростью обмена 80 MBytes/s. В случае установки хотя бы одного устройства Single-Ended SCSI все параметры интерфейса определяются именно этим единственным устройством, т.е. преимущества LVD Ultra2 SCSI становятся недоступными.

  5. Дифференциальный сигнал не используется на скоростях выше 80 MBytes/s.

  6. Все интерфейсы выше Ultra2 только 16-ти разрядные.

Для определения того, в каком режиме может работать конкретное устройство, например, жесткий диск, часто требуется знать расшифровку SCSI икон, которыми маркируется устройство:

"Классический" single-ended SCSI. | scsi_se_logo.gif (1902 bytes)
LVD SCSI. Оборудование, маркированное такой иконой, может работать только с LVD SCSI контроллерами. | scsi_lvd_logo.gif (2002 bytes)
Обозначает устройство, поддерживающее как обычный, single-ended SCSI, так и с LVD SCSI. | scsi_mm_logo.gif (2177 bytes)

Используемые SCSI разъемы сведены в таблицу:

Интерфейс | Разъем
Разъем под SCSI-1. Используется, в основном, в недорогих сканерах. | 50pincen.gif (5924 bytes)
Разъем, использовавшийся в компьютерах Sun Microsystem | sun-dg.gif (6639 bytes)
Используется для 8-ми разрядного Fast SCSI. | 50pinHD.gif (3544 bytes)
SCSI разъем компьютеров от Apple. | DB25.gif (4235 bytes)
Разъем для всех 16-ти разрядных вариантов SCSI | 68pinHD.gif (3919 bytes)
Разъем для всех 16-ти разрядных вариантов SCSI, совмещенный с питанием. Применяется для облегчения "горячей" замены. | 80pin.gif (3003 bytes)

SCSI Overhead - непроизводственные затраты у SCSI - этим термином обозначается время, необходимое SCSI контроллеру для выработки команды. Чем меньше SCSI Overhead, тем лучше контроллер.

Single-Ended SCSI - асимметричный SCSI - термин обозначает обычный SCSI интерфейс, в котором для каждого сигнала на шине есть свой проводник. Этот термин часто используется для указания принадлежности к "классическому" SCSI. В LVD SCSI и последующих вариантах SCSI каждый сигнал идет уже по 2 проводам (по одному положительной полярности, а по другому отрицательной).

SLED - Single Large Expensive Disk (одиночный большой и дорогой диск) - обозначение дисков старых больших компьютеров. Именно в противовес им и появился RAID.

Software Array - программа управления массивом - программа, заменяющая аппаратный RAID контроллер. Ее использование снижает стоимость системы, но резко увеличивает нагрузку на центральный процессор.

Striping - разделение данных на "полоски" - распространение данных равномерно по многим дискам для повышения производительности дисковой системы. Эта операция может быть проделана над одиночным байтом, словом или любым другим блоком данных. Повышение скорости записи/чтения достигается за счет передачи небольших блоков данных (каждый из которых как правило, помещается в буфер жесткого диска) одновременно на все диски массива. Понятно, что термин "одновременно" условен, но поскольку скорость обмена данными на SCSI интерфейсе намного превышает скорость записи/чтения на диск, реально это именно так.
Выбор размера определяется критерием максимальной производительности. Striping применяется в RAID контроллерах и размер "полоски" определяется, как правило, объемом и организацией кэш-памяти RAID контроллера. Увеличение объема данных в одной полосе для приложений с последовательным доступом к диску (т.е. в основном операции выполняются над большими массивами данных, например, при записи видео) увеличивает скорость записи/чтения на диск, но в противном случае (приложение работает с большим количеством маленьких файлов) работа замедляется, так как одна "полоса" будет занимать много строк кэш-памяти и частая смена данных потребует большего времени.

Synchronous Transfer - синхронная передача - обмен данными между контроллером и периферийным устройством с заранее согласованной скоростью обмена. Очевидно, что оба (контроллер и периферийное устройство) должны поддерживать выбранную скорость. Скорость обмена при синхронной передаче зависит только от характеристик устройств на шине и физических характеристик интерфейсного кабеля. На дифференциальном SCSI интерфейсе достигнута скорость 80 MBytes/s и уже фактически внедрен очередной вариант (также на дифференциальном сигнале) SCSI со скоростью обмена 160 MBytes/s.

T

Tagged queuing - упорядоченная очередь - механизм, применяемый для повышения производительности SCSI интерфейса. Начиная со SCSI-2 контроллер (host adapter) вместе с периферийными устройствами имеет право переопределять последовательность команд для минимизации поиска информации на носителе (жестком диске, CD-ROM приводе и т.п.).

Target - цель - в терминологии SCSI это приемник SCSI команд на интерфейсе. Это может быть любое SCSI устройство, такое как жесткий диск, привод CD-ROM и т.п.

Termination - терминирование - в соответствии с требованиями к конструктивному исполнению шины SCSI, на последних устройствах с обеих концов шины должны быть установлены нагрузочные резисторы. Резисторы на обоих концах шины необходимы для уменьшения переотражения сигналов.

U

Ultra3 SCSI - общее название самого высокоскоростного SCSI интерфейса. Его подмножеством являются Ultra160 SCSI и Ultra160+ SCSI. Стандарт предусматривает 32-х разрядную передачу данных, использование дифференциального интерфейса и возможность передачи данных как по заднему, так и переднему фронту сигнала REQ/ACK.

Ultra160 SCSI - последний вариант SCSI интерфейса, внедрение которого началось в конце 1999 года. Совместим по кабелям, терминаторам и разъемам с Ultra2 SCSI. В случае совмещения устройств Ultra2 SCSI и Ultra160 SCSI на одном канале контроллера Ultra160 SCSI каждое из устройств будет работать на своей полной скорости. Отличается от предыдущих рядом принципиальных улучшений:

  • скорость обмена данными увеличена до 160 MBytes/s

  • 32-х разрядный алгоритм CRC контроля передаваемых/принимаемых данных, позволяющий обнаруживать:

    • одиночные ошибки (один бит неверен)

    • двойные ошибки (два бита неверны)

    • любые ошибки с нечетными битами

    • ошибки в 32-х разрядных пакетах данных

  • поддержка 64-разрядной шины PCI (понятно, что иначе смысл нового интерфейса теряется - пропускная способность 32-разрядной PCI - 133 MBytes/s).

  • добавлен механизм Domain Validation, определяющий порядок автоматической проверки всего интерфейса в целом. Проверке подлежит как контроллер интерфейса, так и кабели, объединительные панели, а также собственно устройства на интерфейсе, например, жесткие диски. Только при выявлении соответствия всех компонентов требованиям спецификации Ultra160 SCSI контроллер установит режим Ultra160 SCSI на интерфейсе.

Ultra160+ SCSI - модернизированный вариант Ultra160 SCSI, отличающийся добавлением возможности пакетного обмена и быстрым арбитражем на шине. В этом стандарте переработан весь механизм арбитража с целью уменьшения времени, отнимаемого процедурой арбитража у шины.

Ultra160/m SCSI - старое название Ultra160 SCSI. Некоторые производители, например Quantum, до сих пор применяют именно это обозначение. Термины Ultra160/m SCSI и Ultra160 SCSI обозначают один и тот же стандарт.

Ultra320 SCSI - вариант SCSI, отличающийся скоростью обмена до 320 мегабайт в секунду, добавлением возможности пакетного обмена и быстрым арбитражем на шине. В этом стандарте переработан весь механизм арбитража с целью уменьшения времени, отнимаемого процедурой арбитража у шины.

W

Wide - широкий - общепринятый термин для обозначения 16-ти разрядных вариантов SCSI интерфейса. 8-ми разрядные варианты обозначаются как narrow (узкие).

При подготовке этого материала использовалась информация с сайтов компаний Adaptec и Mylex, а также из собственно стандартов SCSI.


Компания Сплайн | Информационный центр | Статьи, обзоры и описания | Описания интерфейсов | BIOS SCSI

Статьи, обзоры и описания
Цифровое видео
Аксессуары
Аксессуары
Сумки для видеокамер
Штативы
Аппаратура
Для ввода-видео видео
PCI контроллер интерфейса IEEE-1394 IOI1394TTO
Контроллер IOI-CB1394DE PCMCIA
Репитер FW2UTP5_01
Для работы с DVD
DVD Глоссарий
Плюс против минуса - кто кого?
Совместимость DVD-R болванок - информация к размышлению
Совместимость различных DVD носителей
Универсальный обучаемый пульт Kameleon 6
Универсальный обучаемый пульт SRC-3000
Универсальный пульт Kameleon 6 второго поколения
Архив Цифрового видео
Архив описаний оборудования
DVD плееры
DVD плеер с жестким диском BBK-9907S
DVD проигрыватель BBK DVD-AB908S
DVD проигрыватель BBK DVD-BBK916PS
DVD проигрыватель BBK DVD-BBK928PS
DVD проигрыватель BBK DVD-BBK938S
DVD проигрыватель BBK DVD-BBK939S
DVD проигрыватель BBK DVD-BBK969S
Pentium 3 или 4 - что выбрать для своей видеостудии
Для ввода-вывода видео
Hollywood DV-Bridge
Matrox RT2000
miroVIDEO Studio 200/400
Pinnacle DV500DV500+DV500 DVD
Pinnacle Pro-One
Pinnacle Studio Deluxe
Pinnacle Studio DV
Внешний бокс
Микрофон Labtec Verse-704 USB
Микрофонный усилитель
Устройства аналогового ввода/вывода видео
Для работы с DVD
Dazzle Digital Video Creator 150
Dazzle DVD.master
DVD проигрыватель BBK DVD-BBK919PS
DVD проигрыватель BBK DVD-BBK931S
DVD+RW привод Hewlett-Packard DVD100i
DVD-R/RW привод Pioneer A03 — примеры практического использования
Pioneer A03 — создание собственных DVD фильмов стало возможным
Pioneer A04 — следующий DVD рекордер от Pioneer
Pioneer A05 — высокоскоростной DVD рекордер от Pioneer
Pioneer A06 — двухформатный DVD рекордер от Pioneer
Pioneer A07 — 8x DVD рекордер от Pioneer
Архив статей
Домашняя видеостудия на базе контроллера IEEE-1394
Новые процессоры Intel и работа с видео
Цифровая видеокамера как Web камера
Вопросы и ответы по цифровому видео (FAQ)
Технологии цифрового видео
DVD своими руками — практическое руководство по программе ReelDVD
MPEG - что, как и почему?
Scenarist Pro
Ulead MediaStudio Pro 6.5 — жить стало легче
Ulead MediaStudio Pro 7 — новый видеоредактор, внешне похожий на старый
Ulead MediaStudio Pro 8 - Время перемен настало
Автоматизированное создание меню для программ DVD авторинга
Видео для начинающих. Что выбрать?
Домашняя видеостудия, технология работы
Кодеры MPEG - попытка сравнения
Меню DVD диска - краткий курс для начинающего автора
Многоканальный звук в любительском видео
Озвучивание фильма — маленькие хитрости
Революция в домашнем видео
Телевидение и компьютер — вопросы и ответы
Цифровые видеокамеры
Описание
Canon MV300i
Canon MV30i
Canon MV400i, 430i, 450i
Panasonic DS-15EN
Panasonic DS-28EN
Panasonic NV-MX300 EN
Panasonic NV-MX8EN
Sony DCR-TRV900
Статьи
Выбор видеокамеры – критерии оценки
Тенденции современного рынка цифровых видеокамер
Тестирование
Сравнение трех видеокамер Canon MV30i, Sony D8 TRV410 и Canon MV300i от 7 августа 2000 года
Сравнение пяти видеокамер Canon MV30i, Sony D8 TRV410, Sony TRV900, Sony PC100 и JVC DVL107 от 21 августа 2000 года
Сравнение трех 3CCD видеокамер CanonXM1, SonyTRV900 и Panasonic DX100 от 12.09.2000
Сравнение 3CCD видеокамер Sony TRV900 и Panasonic MX300 от 13 декабря 2000 года
Сравнение компактных видеокамер Sony DCR-PC5 и Canon MV3i от 26 апреля 2001 года
Сравнение видеокамер Sony DCR-TRV110, Canon MV30i и Canon MV430i от 18 июня 2001 года
Сравнение видеокамер Panasonic NV-DS15EN, Panasonic NV-DS28EN, Canon MV430i и Sony D8 TRV110 от 06 июля 2001 года
Сравнение видеокамер Sony DCR-TRV30 и Canon MV30i от 2 августа 2001 года
Сравнение видеокамер Sony DCR-TRV30, Canon MV30i и Canon MVX1i от 10 декабря 2001 года
Сравнение видеокамер Panasonic NV-DS88EN и Panasonic NV-DS28EN от 12 января 2002 года
Сравнение видеокамер Canon MV30i и Panasonic NV-MX8EN от 14 февраля 2002 года
Сравнение видеокамер Panasonic DS30EN, Canon MV30i и Panasonic DS28EN от 15 мая 2002 года
Сравнение видеокамер Canon MV400i и Canon MV500i от 4 июля 2002 года
Сравнение видеокамер Panasonic NV-MX350EN и Canon XM2 от 11 сентября 2002 года
Сравнение видеокамер Panasonic NV-DS30EN и Panasonic NV-GX7EN от 03 октября 2002 года
Сравнение видеокамер Panasonic GX7, Panasonic MX300 и Panasonic MX500 от 2 июня 2003 года
Сравнение видеокамер Canon MV30i и Canon MVX3i от 14 октября 2003 года
Сравнение видеокамер Canon XM2 и JVC HD10 от 27 ноября 2003 года
Сравнение видеокамер Panasonic NV-GS30EN, Canon MV600i, Canon MV500i и Canon MVX100i от 25 июня 2003 года
Тестирование видеокамеры Canon MVX25i
Мониторы
Как выбрать монитор
Как выбрать качественный монитор при покупке
Мониторы на жидкокристаллических панелях (LCD)
Описания интерфейсов
Шина ISA
Шина PCI
AGP порт
Шина USB
UltraDMA/66/100
IEEE-1394 (FireWire)
SCSI глоссарий
BIOS SCSI
Архив описаний и обзоров
CD-ROM
В системном блоке
Видеокарты
Diamond Multimedia
Matrox Graphics
Жесткие диски
Western Digital
Жесткий диск Western Digital Corporation с интерфейсом IEEE-1394
Quantum
Seagate
IBM
Память
Внешние боксы от Sarotech, снятые с производства
Магнитооптика
Модемы
Мониторы
Мониторы MAG Innovision
Мониторы ViewSonic
Периферия
Аккустические системы
Акустические системы
Акустические системы, не поставляемые в настоящее время
Звуковые карты
Звуковые карты
Модели
Принципы работы
Принтеры
Лазерные принтеры от Hewlett-Packard
Принтеры
Струйные принтеры фирмы Hewlett-Packard
Струйные принтеры фирмы Seiko Epson
Цифровой презентатор AVerEPack30
Системы хранения данных
Maxtronic SA-8600
Maxtronic Indy-2400
Maxtronic PA-8200
Promise RM8000
Сканеры
Внешние дисковые массивы и устройства хранения данных
Dacal CD Library-II
Fibre Channel - вспомнить все
Maxtronic Pegasus 820GR - сетевая система хранения данных
Maxtronic SA-7230
Maxtronic SA-8630
SCSI или Serial ATA - что же выбрать?
Некоторые особенности использования IDE/SATA жестких дисков в RAID системах
Серия Janus от Maxtronic - что нового?
Способы защиты данных и диагностики жестких дисков в системах от Maxtronic International
Глоссарий
#
A
B
C
D
E
F
G
H
I
J
M
N
O
P
R
S
T
U
W
Периферия
CD/DVD дубликаторы
Дубликатор CD/DVD IOI U2FWEIDE525-2
Дубликаторы CD/DVD на 7-11 приводов
Блоки бесперебойного питания
Внешние боксы
Боксы от Sarotech
Внешние боксы от IOI Technology
Клавиатуры
Модемы
Что такое модем?
Мыши
Устройства рукописного ввода
Navisis NAVInote
Seiko InkLink Handwriting System
Разное
Сети
Удаленное диагностирование
Серверные платформы
Что такое серверная платформа?
Модели
Intel SC5000 (Hudson)
Intel ISP1100
Intel SR2100 (Byrd-II)
Intel SR1200
Intel SR2200
Intel SR2300
Intel SC5100 (Hudson-II)
Intel SC5200 (Hudson-III)
Intel SC5300 (Riggins)
Intel SR1300
Intel SR2400
Системный блок
Видеокарты
3D глоссарий
Как работает видеокарта с 3D ускорителем
Видеокарты
Жесткие диски
Принципы работы жестких дисков
Контроллеры
Контроллеры
Контроллеры Promise IDE RAID FastTrak
Внешний бокс фирмы IOI Technology Corporation с интерфейсом
Контроллер IOI-1394TTO
Контроллер IOI-CB1394DE PCMCIA
RAID контроллеры Intel SRCU21 и SRCU31
Контроллер Intel RAID SRCU32
Корпуса
Материнские платы
Краткие сведения о наборах микросхем (чипсетах)
Материнские платы
Материнские платы ASUS
P4PE
P4P800
Платы, снятые с производства
ASUSTeK P/I-P55T2P4
ASUSTeK P6UP5
ASUSTeK серия TX97
ASUSTeK серия P2L97
ASUSTeK SP97-V
ASUSTeK серия P2B
ASUSTeK серия P3B
ASUSTeK серия P3V
ASUSTeK серия CU
ASUSTeK CUR-DLS
Asustek CUSL2/TUSL2
АSUSTeK P4B
АSUSTeK P4B266
Спецификация модуля C-P55T2D
Настройки Setup BIOS
BIOS Features Setup
Chipset Features Setup
Main
PnPPCI Configuration Setup
Power Management Setup
Настройки Setup BIOS
Установка параметров для кэш-памяти
Процессоры
Процессоры
События
Разъемы и соединения
Внешние
Внутренние
Цифровые фотокамеры
Epson PC600
Nikon 885
Тестирование оборудования
Статьи, обзоры и описания [image] Описания интерфейсов [image] BIOS SCSI

BIOS SCSI контроллеров

За основу взят BIOS наиболее популярных у нас в стране и в мире SCSI контроллеров Adaptec.

Раздел SCSI Disk Utilities

Format Disk
Verify Disk Media

Раздел Configure/Host Adapter Setting

Раздел Basic Host Adapter Setting

Host Adapter SCSI ID
SCSI Parity Checking
Host Adapter SCSI Termination

Раздел Boot Device Setting

Boot Target ID
Boot LUN Number

Раздел SCSI Device Configuration

Initiate Sync Negotiation
Maximum Sync Transfer Rate
Enable Disconnection
Initiate Wide Negotiation
Send Start Unit Command
BIOS Multiple LUN Support
Include In BIOS Scan
Write Back Cache

Раздел Advanced Configuration Options

Reset SCSI bus at IC Initialization
Extended BIOS Translation for DOS Drivers
Host Adapter BIOS (Configuration Utility Reserves BIOS Space)
Support Removable Disks Under BIOS as Fixed Disks
Display <Ctrl> <A> Messages during BIOS Initialization
Verbose/Silent
BIOS Support for Bootable CD-ROMs
BIOS Support for Int 13 Extention

Раздел SCSI Disk Utilities

После выбора этого раздела контроллер сканирует SCSI устройства и выводит список всех SCSI устройств с указанием их идентификационных номеров (SCSI ID). Именно здесь можно узнать все номера устройств, параметры доступа к которым можно далее менять в установках SCSI Setup.

  • Format Disk - форматирование диска - выбор этого параметра запускает низкоуровневое форматирование диска. На самом деле реальное низкоуровневое форматирование уже много лет никакими программными средствами невозможно и эту операцию выполняют только при производстве диска на заводе. Сейчас под низкоуровневым форматированием понимают полное уничтожение информации на диске (как правило, во все сектора диска записываются нули).

  • Verify Disk Media - проверка поверхности диска - после выбора этого параметра будет выполнена проверка на чтение всех секторов диска. Операция проверки не приводит к каким-либо повреждениям информации на диске.

Раздел Configure/Host Adapter Setting

Раздел Basic Host Adapter Setting

  • Host Adapter SCSI ID - идентификатор SCSI контроллера - определяет адрес SCSI контроллера как SCSI устройства на шине. По умолчанию обычно равен 7. Может принимать значения от 0 до 7 на narrow SCSI интерфейсах и от 0 до 15 на wide SCSI интерфейсах. Определить SCSI ID можно, например, экранному сообщению SCSI контроллера при включении компьютера (адреса SCSI ID всегда указаны слева):

    Adaptec AHA-3940U/3940UW BIOS v1.22

    (c) 1996 Adaptec, Inc. All Rights Reserved.

    Press <Ctrl><A> for SCSISelect(TM)Utility!

    SCSI ID #0 - WD ENTERPRISE 9100 - Drive C: (80h)

    SCSI ID #2 - QUANTUM P40S-94-40-04xx - Drive D: (81h)

    SCSI ID #3 - Toshiba CD_ROM:XX3355

    SCSI ID #4 - HP Tape Streamer

    BIOS Installed Successfully!

  • SCSI Parity Checking - контроль четности на SCSI - параметр разрешает/ запрещает контроль по четности на SCSI интерфейсе. Для использования режима контроля по четности необходимо его разрешение также и на подключенных к контроллеру устройствах (как правило, просто следует правильно установить соответствующие джамперы). Может принимать значения:

    • Enabled - разрешено

    • Disabled - запрещено

  • Host Adapter SCSI Termination - терминирование SCSI контроллера - параметр определяет, включать и как терминаторы на самом контроллере. Вопрос включения/ выключения решается просто - если внешние SCSI устройства не подключаются, то терминирование должно быть включено, в противном случае выключено. Большинство современных контроллеров имеют режим AUTO, в котором сам контроллер определяет необходимость включения/выключения терминирования. Параметр может принимать значения:

    • Auto (automatic) - контроллер сам определяет необходимость терминирования.

    • Low ON или High ON - принудительное включение терминирования. Что именно включать, Low или High определяется конкретным контроллером.

Раздел Boot Device Setting

  • Boot Target ID - идентификатор устройства загрузки - указывается адрес SCSI устройства, с которого должна выполняться загрузка операционной системы. Значение по умолчанию 0. Может принимать значения от 0 до 7 на narrow SCSI интерфейсах и от 0 до 15 на wide SCSI интерфейсах. Изменение параметра необходимо в случае подключения нескольких устройств, с которых может быть выполнена загрузка. Для упрощения ситуации рекомендуется всегда загрузочным создавать устройство с адресом 0.

  • Boot LUN Number - логический адрес загружаемого устройства - кроме физического адреса SCSI устройства, ему может быть присвоен (разрешением параметра BIOS Multiple LUN Support) логический адрес LUN - Logical Unit Number - логический номер устройства. Именно этот адрес может быть задан в этом параметре для указания загрузочного устройства.

Раздел SCSI Device Configuration

В этом разделе параметры устанавливаются для каждого устройства на шине индивидуально. Обычно конфигурационный экран выглядит примерно так (в зависимости от типа конкретного контроллера вид может меняться):

adaptec_conf_screen.gif (26187 bytes)

Все параметры в этом меню могут конфигурироваться индивидуально для каждого устройства, поэтому количество устройств зависит от конкретной архитектуры компьютера.

  • Initiate Sync Negotiation - начать с синхронного обмена - параметр устанавливает, какой способ обмена контроллер будет пытаться установить сначала - синхронный или асинхронный. Как правило, всегда следует оставлять значение по умолчанию, т.е. разрешить контроллеру инициировать синхронный обмен данными. Иное может быть необходимо только при подключении старых периферийных устройств, или обдуманном нарушении правил применения SCSI (например, использование слишком длинного кабеля для подключения периферийного устройства).Может принимать значения:

    • Yes - разрешено

    • No - запрещено

  • Maximum Sync Transfer Rate - максимальная скорость при синхронной передаче - устанавливается значение максимально возможной скорости для устройства. Значение по умолчанию зависит от конкретного контроллера. Максимальная скорость обмена должна устанавливаться с учетом максимально возможных скоростей как самого контроллера так и периферийного устройства в соответствии с таблицей вариантов SCSI интерфейсов. Если Initiate Sync Negotiation установлен в значение No, то в этом поле будет указана максимальная скорость для устройства, принятая контроллером после "переговоров" (negotiation) с устройством.

  • Enable Disconnection - разрешение на отсоединение - параметр разрешает использование одного из самых главным преимуществ SCSI - возможность отдать команду устройству, отсоединиться от него и заняться обслуживанием другого устройства. Значение параметра следует устанавливать в No при подключении к контроллеру только одного периферийного устройства для ускорения работы с ним. Если же устройств больше одного, то значение параметра должно быть Yes. Также значение Yes обязательно для устройств с интерфейсом Ultra320 SCSI, поскольку значение No приведет к отказу от пакетной передачи данных и переключению тем самым интерфейса в режим Ultra160 SCSI. Может принимать значения:

    • Yes - разрешено

    • No - запрещено

  • Initiate Wide Negotiation - попытаться начать с 16-ти разрядного обмена - при выборе Yes контроллер пытается организовать обмен в 16-ти разрядном режиме, в противном случае он будет работать только на обмен 8-ми разрядными данными. Параметр следует устанавливать в No только в случае возникновения проблем с каким-либо 8-ми разрядным устройством. Может принимать значения:

    • Yes - разрешено

    • No - запрещено

  • Send Start Unit Command - отправить команду на старт устройства - параметр оказывает действие только на те SCSI устройства, в которых заложена поддержка этой команды, причем ее поддержка часто требует установки соответствующего джампера на самом устройстве. При выборе Yes на устройство (точнее, на его двигатель) будет подано питание только после инициализации его SCSI контроллером перед загрузкой операционной системы. В противном случае питание будет подано просто по включению компьютера. Плюс в разрешении отправки команды только один: нагрузка на источник питания компьютера будет нарастать плавно, что важно при большом количестве высокооборотных, и, соответственно, потребляющих много энергии, жестких дисков. Может принимать значения:

    • Yes - разрешено

    • No - запрещено

  • BIOS Multiple LUN Support - поддержка множественных LUN - при установке в Yes загрузка устройств с множеством LUN разрешается, в противном случае нет.Может принимать значения:

    • Yes - разрешено

    • No - запрещено

  • Include In BIOS Scan - включить в сканирование BIOSом - после включения компьютера SCSI контроллер сканирует все подключенные к нему устройства для определения загрузочного. Параметр позволяет исключить из сканирования те устройства, которые не будут загрузочными для уменьшения времени на инициализацию компьютера. Может принимать значения:

    • Yes - разрешено

    • No - запрещено

  • Write Back Cache - кэш-память с обратной записью - параметр разрешает кэш-память с обратной записью на периферийных устройствах, подключенных к SCSI контроллеру. Разрешать работу кэш-памяти следует при точной уверенности, что выбранное устройство эту функцию поддерживает правильно. Фирма Adaptec, в частности, при ответе на вопросы покупателей своих SCSI контроллеров об этом параметре, рекомендует обратиться к производителю подключаемого к SCSI контроллеру устройства. Поэтому, в случае малейших сомнений по этому поводу следует оставить NC (No Change - не изменять), доверив решение по этому вопросу SCSI контроллеру. Может принимать значения:

    • Yes - разрешено

    • No - запрещено

    • NC - не изменять

Раздел Advanced Configuration Options

  • Reset SCSI bus at IC Initialization - сброс шины SCSI во время инициализации - разрешает/запрещает сброс всех устройств на шине. Запрещение может потребоваться только при использовании нескольких контроллеров в одном компьютере, поэтому рекомендуется параметр разрешать. Может принимать значения:

    • Enabled - разрешено

    • Disabled - запрещено

  • Extended BIOS Translation for DOS Drivers > 1 GBytes - поддержка расширенного представления для DOS дисков объемом более 1 GBytes - разрешение этого параметра позволяет представить геометрию диска в виде, необходимом для понимания MS-DOS версии 5.0 и выше. Такие операционные системы как UNIX, Windows NT и т.д. не требуют разрешения этого параметра. Следует помнить, что изменение значения этого параметра может привести к потери всей информации на диске, поэтому, если необходимо его изменение, следует сохранитть данные на другом накопителе. Может принимать значения:

    • Enabled - разрешено

    • Disabled - запрещено

  • Host Adapter BIOS (Configuration Utility Reserves BIOS Space) - разрешение загрузки в память BIOS SCSI контроллера - параметр фактически разрешает или запрещает использование BIOS контроллера. Разрешение необходимо в случае загрузки операционной системы с какого-либо периферийного устройства, подключенного к данному контроллеру. В противном случае разумнее запретить загрузку BIOS контроллера. Это сэкономит время и место в памяти. Может принимать значения:

    • Enabled - разрешено

    • Disabled - запрещено

  • Support Removable Disks Under BIOS as Fixed Disks - поддержка сменных дисков как фиксированных дисков - параметр управляет возможностью использования сменных дисков (таких как CD или магнитооптических) как обычных жестких дисков. Установка будет действительна только для MS-DOS, так как в при использовании других операционных систем все определяется соответствующими драйверами. Следует обязательно помнить о том, что нельзя заменять сменные носители, если они определены как фиксированные, так данные в этом случае могут быть потеряны. Может принимать значения:

    • Boot Only (только загрузочные ) - определяет как фиксированные только те устройства, которые указаны как загрузочные в параметрах раздела Boot Device Setting.

    • All Disks (все диски) - все сменные диски становятся фиксированными.

    • Disabled (запрещено) - сменные диски не поддерживаются BIOS и для их использования необходимы драйверы.

  • Display <Ctrl> <A> Messages during BIOS Initialization - показывать сообщение Ctrl+A в течении процедуры инициализации - после разрешения этого параметра BIOS будет индицировать сообщение Press <Ctrl> <A> for SCSISelect(TM) Utility при загрузке системы. В противном случае надпись появляться не будет, но войти по нажатию Ctrl+A в SETUP будет возможно в любом случае, с появлением надписи на экране или без оной. Может принимать значения:

    • Enabled - разрешено

    • Disabled - запрещено

  • Verbose/Silent - Подробно/Умолчать - при выборе Verbose (обычно установлено по умолчанию) на экран выводится подробная информация как о самом контроллере, так и о подключенных к нему устройствах. В противном случае (выбрав Silent) эта информация на экране не отображается.

  • BIOS Support for Bootable CD-ROMs - поддержка BIOSом загрузки с CD-ROM - разрешение позволяет компьютеру загрузиться с SCSI CD-ROM. Разумеется, сам CD-ROM диск должен также быть загрузочным. Может принимать значения:

    • Enabled - разрешено

    • Disabled - запрещено

  • BIOS Support for Int 13 Extention - поддержка BIOSом расширений Int 13 - разрешение включает поддержку BIOSом SCSI адаптера расширений для дисковых операций, введенных в Int 13 для Plug&Play операционных систем. Рекомедуется разрешать этот параметр при использовании операционных систем типа Windows 95/98. Может принимать значения:

    • Enabled - разрешено

    • Disabled - запрещено