:: Электронное пособие

Электронное пособие > АТ команды > Команды расширенного набора
АТ команды

» Команды расширенного набора

Команда | Назначение
AT&C | Управление сигналом CD последовательного порта
AT&D | Управление функциями цепи DTR (108)
AT&Fn | Загрузка заводской конфигурации из ПЗУ
AT&Gn | Управление защитным тоном
AT&In | Интерфейс с постоянной скоростью
AT&Kn | Управление потоком терминал-модем
AT&Ln | Выбор арендованного канала
AT&M | Выбор синхронного/асинхронного режима
AT&Nn | Установка вида проверки знаков в асинхронном режиме (при 7 или 8 битах данных)
AT&Pn | Скважность импульсов набора
AT&Qn | Выбор режима передачи
AT&Rn | Варианты использования цепей RTS/CTS
AT&Sn | Варианты использования цепи DSR (107)
AT&Tn | Тестирование и диагностика
AT&V | Отображение текущей конфигурации и профилей пользователя
AT&Wn | Запись содержимого регистров S в энергонезависимую память
AT&X | Источник тактовой частоты в синхронном режиме
AT&Yn | Выбор профиля пользователя "по умолчанию"
AT&Zn=x | Сохранить телефонный номер в энергонезависимой памяти

AT&C - Управление сигналом CD последовательного порта. Управляет сигналом "Обнаружение несущей" DCD (цепь 109) в последовательном порте модема. Рекомендуется использовать эту команду, если для используемого компьютера или терминала требуется, чтобы сигнал DCD находился некоторое время в состоянии "выключено".

AT&C0 - Сигнал DCD всегда включен.
AT&C1 - Сигнал DCD всегда выключен.

AT&D - Управление функциями цепи DTR (108). Переход включено/выключено цепи "Терминал данных готов" DTR (цепь 108) должен происходить в течение времени, определяемого регистром S25 (по умолчанию 0,05 сек.). Положительные переходы в цепи DTR (выключено/включено), возникающие в течение 5 сек. после разъединения, игнорируются. Когда введены команды AT&D2 или AT&D3 цепь DTR должна быть включена в состоянии автоответа.

AT&D0 | Игнорируются переходы в DTR, DTR не требуется для автоответа.
AT&D1 | Вводится командный режим после обнаружения перехода включено/выключено в цепи DTR, и подготавливается последовательный порт для приема команды AT на любой скорости.
AT&D2 | Отключение от линии после обнаружения перехода включено/выключено в цепи DTR, и подготовка последовательного порта для приема команды AT на любой скорости.
AT&D3 | Отключение от линии и сброс после обнаружения перехода включено/выключено в цепи DTR, и подготовка последовательного порта для приема команды AT на любой скорости.

AT&Fn - Загрузка заводской конфигурации из ПЗУ. В регистры S модема записываются значения команд и установок, хранящиеся в ПЗУ модема, n - индекс выбранного профиля конфигурации (n = 0,1...).

AT&Gn - Управление защитным тоном.

AT&G0 - Защитный тон выключен.
AT&G1 - Включен защитный тон частотой 550 Гц.
AT&G2 - Включен защитный тон частотой 1800 Гц.

AT&In - Интерфейс с постоянной скоростью. Позволяет обеспечить обмен данными с терминалом на постоянной скорости, независимо от скорости, определяемой режимом (МККТТ или Bell), выбранным в модеме для передачи данных в канале связи.

AT&I0 | Интерфейс постоянной скорости с ООД запрещен.
AT&I1 | Интерфейс постоянной скорости с ООД разрешен.
AT&I2 | Интерфейс постоянной скорости с ООД разрешен, сообщения CONNECT отображают скорость передачи терминала.
AT&I3 | Интерфейс постоянной скорости с ООД разрешен только для режима V.23.

AT&Kn - Управление потоком терминал-модем. Определяет, каким образом модем управляет потоком данных между местным терминалом и модемом. Когда буфер модема близок к заполнению, модем либо передает XOFF, либо выключает цепь CTS (106) для остановки потока данных. Когда буфер почти пуст, модем либо передает XON, либо включает цепь CTS (106) для возобновления потока данных.

Модем реагирует также на знаки XON/XOFF, принимаемые от местного терминала, либо на включения/выключения местным терминалом цепи RTS (105), вызывающие возобновление/прекращение передачи от терминала. Модем передает терминалу знаки XON/XOFF, а также пропускает эти знаки к удаленному модему, если выбран "прозрачный" метод управления потоком.

При работе модема в непосредственном режиме (AT&Q0) управление потоком не используется, и модем игнорирует установки этой команды.

AT&K0 - Управление потоком запрещено.
AT&K3 - Разрешено управление потоком CTS/RTS.
AT&K4 - Разрешено управление потоком XON/XOFF.
AT&K5 - Разрешено прозрачное управление потоком XON/XOFF.

AT&Ln - Выбор арендованного канала. Разрешает или запрещает соединения по арендованным каналам, когда местный и удаленный модем работают по выделенной двухпроводной арендованной линии. Оба модема должны работать на одной и той же самой скорости. Один из модемов должен быть установлен в вызывающий режим, а другой модем - в отвечающий режим.

Команда выбора режима арендованного канала не может использоваться в модеме, установленном в автоматический надежный режим.

Для ответа на входящий вызов необходимо ввести команду ATA (Ответ). Для организации вызова следует ввести команду ATD (Набор). При вводе команды "Набор" в этом режиме не требуется набирать телефонный номер, модем автоматически подключается к линии и пытается установить соединение, после ввода команд ATD или ATA.

AT&M - Выбор синхронного/асинхронного режима. Управляет переключением модема в синхронный или асинхронный режим и выбором способа синхронного набора.

Команда AT&M1 позволяет установить прямое соединение в асинхронном режиме и затем перейти в синхронный режим. Для организации соединения следует подключить модем к асинхронному компьютеру или терминалу. Затем переключить модем к синхронному компьютеру или терминалу.

Когда выбрана команда AT&V1, цепь DTR (108) на модеме должна находиться в состоянии "включено" для установления синхронного соединения даже, если выбрана конфигурация модема, в которой эта цепь игнорируется. (Используемая связная программа должна включить эту цепь). Для того, чтобы иметь достаточное время на переключения от асинхронного устройства к синхронному или для перехода оконечного устройства из одного режима в другой (если оно может работать в обоих режимах) может быть увеличено значение в регистре S25.

AT&M0 | Работа в качестве асинхронного модема.
AT&M1 | Используется команда ATD для установления соединения в асинхронном режиме, затем необходимо выполнить переключение в синхронный режим после установления соединения.
AT&M2 | Работа в синхронном режиме. Вызывается номер, хранящийся по первому входу памяти телефонных номеров модема при его подключении к линии в вызывающем режиме.
AT&M3 | Работа в асинхронном режиме с переключением режимов передача данных/речь под управлением цепи DTR.

Примечание: Цепь DTR (108) должна находиться во включенном состоянии, чтобы модем мог ответить на входящий вызов. Если модем не обнаруживает включенной цепи DTR (108) в течение времени, определяемого регистром S25, он отключается от линии. Необходимо чтобы синхронный компьютер или терминал обеспечивал передачу сигнала по цепи DTR (108).

AT&Nn - Установка вида проверки знаков в асинхронном режиме (при 7 или 8 битах данных).

AT&N0 - Автоматическая установка вида проверки по команде АТ.
AT&N1 - Проверка на четность (EVEN).
AT&N2 - Проверка на нечетность (ODD).
AT&N3 - Постоянно "1" (MARK).
AT&N4 - Постоянно "0" (SPACE).
AT&N5 - Проверка не делается (NONE).

Виды проверок, устанавливаемые командами AT&N3 и AT&N4, используются только при 7 битах данных в знаке.

AT&Pn - Скважность импульсов набора. Управляет отношением времени подключения к линии (соединение) к времени отключения от линии (разрыв), при использовании импульсного метода набора телефонного номера.

AT&P0 | Скважность импульсов набора для США (39% соединение, 61% разрыв). Частота следования 10 импульсов в секунду.
AT&P1 | Скважность импульсов набора для Великобритании (33% соединение, 67% разрыв). Частота следования 10 импульсов в секунду.
AT&P2 | Скважность импульсов набора для Японии (33% соединение, 67% разрыв). Частота следования 20 импульсов в секунду.

AT&Qn - Выбор режима передачи. Обеспечивает установку основных режимов передачи модема: асинхронного, синхронного, с исправлением ошибок.

AT&Q0 | Выбор асинхронного режима работы в непосредственном режиме. В этом режиме скорость терминала должна быть согласована со скоростью в канале.
AT&Q1 | Выбор синхронного режима 1. Предназначен для терминалов, которые могут работать как с синхронным, так и с асинхронным протоколами. Для установления соединения в асинхронном режиме используется команда автонабора, после установления соединения производится переключение в синхронный режим. Модем отключается от канала и переходит в асинхронный режим, когда обнаруживает переход ВКЛ-ОТКЛ в цепи DTR (108) или, если пропадание несущей от удаленного модема превышает интервал времени, задаваемый регистром S10.
AT&Q2 | Выбор синхронного режима 2. Предназначен для синхронных терминалов с набором записанного номера. Модем автоматически набирает записанный номер при обнаружении перехода ОТКЛ-ВКЛ цепи DTR (108). Асинхронный терминал в этом режиме нужен только для записи или сохранения номера в энергонезависимой памяти модема. Номер записывается с помощью команды "AT&Z0 = x". Модем набирает номер, хранящийся по первому входу памяти. Модем отключается от канала и переходит в асинхронный режим, когда обнаруживает переход ВКЛ-ОТКЛ в цепи DTR (108) или, если пропадание несущей от удаленного модема превышает интервал времени, задаваемый регистром S10.
AT&Q3 | Выбор синхронного режима 3. Этот режим позволяет цепи DTR (108) выполнять функцию переключателя "речь/данные". Оператор вручную инициирует соединение, переведя цепь DTR (108) в состояние ОТКЛ, и имитируя, тем самым, для модема режим передачи речи. Для выполнения соединения оператор переключает модем в режим передачи данных, включив цепь DTR после набора последней цифры номера. Модем отключается от канала и переходит в асинхронный режим, когда обнаруживает переход ВКЛ-ОТКЛ в цепи DTR (108) или, если пропадание несущей от удаленного модема превышает интервал времени, задаваемый регистром S10.
AT&Q5 | Выбор режима с исправлением ошибок. Модем согласует установление канала с исправлением ошибок. Конфигурация модема установлена таким образом, что в случае невозможности согласования канала с исправлением ошибок производится либо разъединение, либо модем переходит в нормальное асинхронное соединение, см. команду AT\Nn.
AT&Q6 | Выбор асинхронного режима работы в нормальном режиме (буферирование скорости). В этом режиме скорость терминала может отличаться от скорости передачи в канале связи.

AT&Rn - Варианты использования цепей RTS/CTS. Управляет состоянием цепи "Готов к передаче" CTS (106) только в синхронном режиме. Рекомендуется использовать команду AT&R0 для имитации полудуплексной синхронной работы. Когда введена команда AT&R0, с задержкой, определяемой регистром S26, состояние цепи CTS (106) повторяет состояние цепи RTS ("Запрос передачи" - 105), передаваемое от компьютера или терминала. При вводе команды AT&R1 состояние цепи CTS "включено" сохраняется в течение всего соединения.

AT&R0 - Цепь CTS повторяет состояние цепи RTS в синхронном режиме.
AT&R1 - Цепь CTS игнорирует состояние цепи RTS в синхронном режиме.

Примечание: Установка команды "Варианты использования цепей CTS/RTS" игнорируется во время асинхронных соединений.

AT&Sn - Варианты использования цепи DSR (107). Данная команда определяет, будет ли данная цепь функционировать в соответствии со стандартом EIA-232-D, либо будет оставаться постоянно в состоянии ВКЛ.

AT&S0 | Цепь DSR постоянно находится в состоянии ВКЛ.
AT&S1 | Цепь DSR включается в начале процедуры вхождения в связь (handshaking) и выключается при нахождении в тестовом режиме или в режиме ожидания.

AT&Tn - Тестирование и диагностика. Производит выбор команд тестирования. Команды тестирования должны вводиться в командном режиме при асинхронной работе и выбранном непосредственном режиме работы модема (AT&Q0) на скоростях 1200 бит/с и выше. Перед началом тестов "цифровые шлейфы" должно быть установлено соединение по каналу связи. Если это не сделано, модем выводит сообщение ERROR. Если при включении местного аналогового шлейфа модем соединен с противоположным модемом, соединение разрушается. Тестовая проверка ведется в течение времени, задаваемого регистром S18 (тестовый таймер). Если величина в тестовом таймере равна нулю, то для завершения теста необходимо ввести команду AT&T0.
AT&T0 | Прекращает любой текущий тест. В случае нахождения в соединении необходимо предварительно ввести команду перехода "+++". Последующее введение команды АT&T0 позволяет перевести местный и удаленный модемы в нормальный режим передачи данных, если прерванная проверка была цифровым шлейфом.
AT&T1 | Инициирует проверку местного аналогового шлейфа L3 в соответствии с Рекомендацией МККТТ V.54. Проверяется работа тракта передачи сигнала между ООД и местным модемом. В этой проверке модем должен возвращать на дисплей введенные в него знаки с ООД.
AT&T3 | Включает местный цифровой шлейф. При этом знаки, принятые местным модемом от удаленного модема, возвращаются обратно к удаленному модему. Это позволяет удаленному модему, который не поддерживает рекомендацию V.54, осуществлять проверку в режиме дистанционного цифрового шлейфа совместно с местным модемом.
AT&T4 | Позволяет модему отвечать удаленному вызывающему модему на запрос введения режима дистанционного цифрового шлейфа.
AT&T5 | Запрещает модему отвечать удаленному вызывающему модему на запрос введения режима дистанционного цифрового шлейфа.
AT&T6 | Заставляет модем ввести проверку в режиме удаленного цифрового шлейфа L2 в соответствии с Рекомендацией МККТТ V.54. Знаки, принятые от местного ООД, передаются при этом местным модемом удаленному модему и возвращаются им обратно местному модему и ООД.
AT&T7 | Инициирует дистанционный цифровой шлейф с самотестированием. Эта проверка аналогична проверке по команде AT&T6, за исключением того, что модем непрерывно передает тестовую комбинацию и проверяет верность принятых данных. Возникающие при передаче ошибки накапливаются счетчиком. После окончания проверки модем выводит количество ошибок в виде трехзначного числа.
AT&T8 | Инициирует местный аналоговый шлейф с самотестированием. Эта проверка аналогична проверке по команде AT&T6, за исключением того, что тестовая комбинация передается в режиме местного аналогового шлейфа (как по команде AT&T1). Это позволяет проверять функции приема и передачи местного модема без фактического соединения с каналом связи.

AT&V - Отображение текущей конфигурации и профилей пользователя. Отображает профили активной конфигурации (установки регистров S, команд и телефонных номеров). Во время вывода указанной информации игноруются входные сигналы от терминала. Например:

AT&V0 | Отображение активной конфигурации и хранимых в энергонезависимом ОЗУ профилей конфигурации.
AT&V1 | Отображение хранимых телефонных номеров.

AT&Wn - Запись содержимого регистров S в энергонезависимую память. Осуществляет запись в профиль с номером "n" (n=0,1...) энергонезависимой памяти активную конфигурацию модема (значения текущих установок регистров S).

AT&X - Источник тактовой частоты в синхронном режиме. Определяет источник синхронизации элементов передаваемого сигнала в режиме синхронной работы.

AT&X0 | Тактовая частота от модема.
AT&X1 | Тактовую частоту поставляет оконечный терминал.
AT&X2 | Подчиненная тактовая частота (в качестве тактовой частоты передачи используется полученная в модеме тактовая частота приема).

AT&Yn - Выбор профиля пользователя "по умолчанию". Назначает, какой из имеющихся в модеме профилей пользователя будет загружаться в активную конфигурацию при включении питания. Значение n определяет номер используемого профиля пользователя (n = 0,1 ...).

AT&Zn=x - Сохранить телефонный номер в энергонезависимой памяти. Сохраняет телефонный номер "x" в n-ой области памяти телефонного справочника модема. Команда &Zn помещается в строку набора вместо цифрового кода номера (Например: ATDP&Z1).

В данной команде "x" представляет собой строку знаков в коде ASCII, содержащую знаки десятичных цифр и модификаторов набора. Действительные значения цифр включают десятичные значения от 0 до 9, а для тонального набора - символы A, B, C, D, # и *. Модем игнорирует недействительные знаки. При строке набора длиннее допуст имого значения (обычно 20 знаков) знаков возвращается сообщение об ошибке.


:: Электронное пособие

Электронное пособие > АТ команды > Аппаратное управление потоком
АТ команды

» Аппаратное управление потоком

Модемы могут использовать 2 типа аппаратного управления потоком: однонаправленный и двунаправленный. Однонаправленное аппаратное управление потоком аналогично методу управления XON/XOFF. Вместо передачи знака XOFF местному терминалу модем переводит в низкое состояние уровень в цепи "готов к передаче" CTS (106).

Приняв изменение уровня сигнала CTS, местный терминал прекращает передачу данных последовательному порту. Передача данных возобновляется, когда модем переводит уровнь цепи CTS в верхнее состояние, что для последовательного порта аналогично передаче сигнала XON.

Местный терминал может запретить модему передавать данные в его сторону. Это возможно только тогда, когда действует двунаправленное аппаратное управление потоком. При аппаратном двунаправленном управлении потоком цепь CTS используется точно также, как и при однонаправленном управлении. В дополнение, модем останавливает передачу данных местному терминалу, если он переводит в низкое состояние уровень в цепи "Запрос передачи" RTS (105). Модем восстанавливает передачу, когда уровень цепи RTS переходит в верхнее состояние. Однако, для большинства применений эффективен однонаправленный метод управления потоком.

Примерами таких применений являются системы, главным образом предназначенные для передачи файлов. Для применений, требующих приема файлов и не поддерживающих метод управления потоком XON/XOFF, рекомендуется двунаправленный аппаратный метод управления потоком, при котором местные терминалы также могут управлять потоком данных от модема.


:: Электронное пособие

Электронное пособие > АТ команды > Команды основного набора
АТ команды

» Команды основного набора

Команда | Назначение
A/ | Повторить предыдущую команду
ATA | Ответ
ATBn | Режим Bell/МККТТ
ATCn | Управление несущей
ATD | Набрать телефонный номер
ATD/n | Набрать номер, хранящийся по n-му входу энергонезависимого ОЗУ
ATEn | Эхо команды
ATFn | Эхо знаков в состоянии работы по каналу/формат связи
ATG | Повторный набор/отображение последнего номера
ATHn | Отключиться от линии
ATIn | Запрос идентификационных кодов модема
ATJn | Распознавание речи/данных
ATK | Таймер соединения
ATLn | Регулировка громкости громкоговорителя
ATMn | Управление включением/выключением громкоговорителя
ATNn | Согласование видов модуляции
ATN=n | Установка числа повторений набора номера
ATN? | Считывание установки числа повторений набора номера
ATOn | Возврат в режим соединения
ATP | Набор номера импульсным методом
ATQn | Разрешение ответов модема
ATSr? | Вывод содержимого регистра S c номером r
ATSr=n | Запись в регистр S с номером r значения n
ATT | Набор номера многочастотным методом
ATU | Задание фиксированного режима работы
ATVn | Форма кода ответа
ATWn | Сообщение о процессе согласования
ATXn | Расширенные коды ответов модема
ATY | Разрешение разъединения по длинной последовательности "пробелов"(нулей)
ATZ | Сброс

ATA - Ответ. Используется для ручного ответа на входящий вызов (независимо от значения в регистре S0). После появления тона станции модем подключается к линии и вводит режим соединения. После этого делается тарифная задержка в 2,1 сек., и затем модем посылает тон ответа. Если несущая не обнаружена в течение S7 секунд, модем отключается от линии и переходит в командный режим. Данная команда должна быть последней в командной строке.

ATB - Режим Bell/МККТТ. Эта команда позволяет выбрать стандарт Bell или Рекомендацию МККТТ для работы.
ATB0 | Например: МККТТ V.22bis (на скорости 2400 бит/с) или МККТТ V.22 (на скорости 1200 бит/с)
ATB1 | Например: Bell 212A (на скорости 1200 бит/с) или Bell103 (на скорости 300 бит/с)

ATCn - Управление несущей. Управляет несущей на передаче. Обычно модем установлен на включение и выключение несущей (вариант C1). Сигнал несущей включен, когда модем вызывает, отвечает или соединен с удаленным модемом; и выключен в других режимах. Версия C0 этой команды часто не используется.

ATD <Строка набора> - Набор телефонного номера. Данная команда управляет набором телефонного номера и инициирует попытку установления соединения. Обнаружив эту команду, модем подключается к линии, выжидает 2 секунды и затем начинает последовательность набора. Команда набора должна быть последней командой в командной строке.

<Строка набора> представляет собой строку кодов ASCII, состоящую из цифр и модификаторов набора, длина строки не должна превышать емкости буфера командной строки.

Действительными являются десятичные цифры от 0 до 9 и при тональном наборе символы A, B, C, D, # и *. Модем игнорирует недействительные знаки. При строке набора длиннее, чем емкость буфера, возвращается сообщение об ошибке.

ATDSn или ATD/n - Модем набирает телефонный номер, записанный командой AT&Zn по входу n в энергонезависимом ОЗУ. Команда D/n должна быть последней в командной строке. Отличия между указанными командами заключается в том, что команда DS=n игнорирует все следующие за ней команды, а команда D/n вырабатывает сообщение ERROR, если она не является последней в командной строке.

ATDL - Модем набирает последний набиравшийся до этого номер. При этом знак L должен непосредственно следовать за знаком D, любой знак, следующий за знаком L будет игнорироваться модемом. Для отображения последнего набиравшегося номера может быть использована команда \S. Однако, последний набиравшийся номер не сохраняется после выключения питания.

ATE - Эхо команд. Эта команда управляет отображением эхо знаков команд, посылаемых от местного компьютера или терминала к местному модему, когда модем находится в командном режиме.

ATE0 - Запрещает эхо команд на местном устройстве.
ATE1 - Разрешает эхо команд на местном устройстве.

Если терминал имеет такую конфигурацию, при котором он ожидает эха переданных знаков (в асинхронных применениях это иногда называется дуплексной или полудуплексной работой), следует использовать команду ATE1. Если была введена команда ATE0, и терминал имеет конфигурацию, в которой ожидаются эхо-сигналы, терминал не будет отображать знаки, которые вводятся с клавиатуры.

Если конфигурация терминала такова, что он ожидает эха знаков, переданных им, необходимо ввести команду ATE0. В другом случае каждый переданный знак будет сдваиваться на экране терминале. (Например, AATT вместо AT).

ATFn - Эхо знаков в состоянии работы по каналу/формат связи.

Первый вариант применения

В состоянии работы по каналу (on-line) разрешает передачу на экран эха данных, поступающих от терминала.

ATF0 - Разрешено эхо знаков данных.
ATF1 - Запрещено эхо знаков данных.

Примечание: Следует обратить внимание на отличие данной команды от команды ATEn, управляющей передачей эхо знаков в командном режиме.

Второй вариант применения

Используется в сочетании с командой ATBn, для задания связного формата передачи данных, когда в режиме вызова или ответа соединение устанавливается на заранее заданной скорости. Команды ATF1-ATF3 задают фиксированные режимы. Если отвечающий модем не соответствует этим стандартам, и не имеет свойства автоматического согласования режимов, соединение разрушается.

ATF0 - Используемый формат определяется командами AT%Hn, AT%Sn и AT%R.
ATF1 - Скорость 300 бит/с, ЧМ.
ATF2 - Пониженная скорость 600 бит/с Рекомендации V.22.
ATF3 - Скорость 1200 бит/с, ЧМ.
ATF4 - Скорость 1200 бит/с, Рекомендация V.22 или Bell 212A.
ATF5 - Скорость 2400 бит/с, Рекомендация V.22bis.

Примечание: Для возможности использования установок данной команды должна быть введена команда AT%H0

ATG - Повторный набор/отображение последнего номера. Команда может использоваться в одном из двух видов командных строк. Одна из них позволяет сохранять в строке набора часто используемый подряд телефонный номер, до тех пор, пока не будет введен новый номер:

АТDG - Позволяет набрать временно сохраняемый телефонный номер.
ATG - Позволяет вывести на экран временно сохраняемый телефонный номер.

ATHn - Отключение от линии.
Эта команда управляет подключением модема к линии и отключением модема от линии.

ATH0 - Разъединяет с удаленной системой и отключает модем от линии.
ATH1 - Подключает к линии (иногда выполняет функцию "Не отвечать на вызов").

ATI - Запрос идентификационных кодов модема.

ATI0 - Идентификационный код
ATI1 - Идентификационный код
ATI2 - Выдает ответ "OK" при правильной контрольной сумме
ATI3 - Дата коррекции и версия ППЗУ
ATI9 - Дата коррекции и версия программных средств

В модемах разного типа имеются различные версии и номенклатура ответов на эту команду.

ATJn - Распознавание речи/данных.

ATJ0 - Запрещено распознавание речи/данных.
ATJ1 - Разрешено распознавание речи/данных.

ATK - Таймер соединения/вывод вспомогательной информации. Позволяет вывести на экран длительность соединения в минутах и секундах. Длительность соединения измеряется внутренним таймером и сохраняется после окончания соединения до начала следующего соединения. Этот таймер запускается после установления соединения. Команда ATK может использоваться в любое время после прекращения соединения, а также а процессе соединения при первом переходе из режима передачи данных в командный режим.

При использовании данной команды для вывода вспомогательной информации возможны различные варианты ее использования, например:

ATK - Отображение команд набора АТ от A до Z.
ATK& - Отображение команд от &C до &Z.
ATKD - Отображение модификаторов набора (эта команда должна быть последней в командной строке).

ATLn - Регулировка громкости громкоговорителя.

ATL0 - Малая громкость.
ATL1 - Малая громкость.
ATL2 - Средняя громкость.
ATL3 - Большая громкость.

ATMn - Управление включением/выключением громкоговорителя.

ATM0 | Громкоговоритель всегда выключен.
ATM1 | Громкоговоритель включен до тех пор, пока модем не примет сигнал несущей от удаленной станции.
ATM2 | Громкоговоритель всегда включен.
ATM3 | Громкоговоритель выключен во время набора модемом номера и во время приема модемом несущей от удаленной станции.

ATNn - Согласование видов модуляции. Используется для обеспечения соединения только на заданной скорости.

ATN0 | Задает соединение модемов на скорости, определяемой регистром S37. Если S37=0, скорость должна соответствовать скорости, на которой была передана последняя команда AT.
ATN1 | Автоматическое установление скорости передачи на основании скорости входных знаков (S37=0). Позволяет модемам соединяться на любой скорости, поддерживаемой обоими модемами. В этом случае игнорируется команда ATBn, и модем реализует только попытки соединения в режиме МККТТ. На арендованных каналах (если введена команда AT&L1) при этом запрещен режим автоматической установки скорости.

ATN=n - Установка числа повторений набора номера. Определяет, количество повторений модемом набора номера в случае обнаружения сигнала "занято". Число повторений " n " может устанавливаться от 1 до 15, если n=0, повторений набора номера нет. Счетчик числа повторений сбрасывается в момент установления соединения или при вводе команд ATZ либо AT&F. Длительность интервала между повторениями задается командой N5 = n, где n обозначает число двухсекундных интервалов.

ATN? - Считывание установки числа повторений набора номера. Введение команды ATN? вызывает отображение установленного числа повторений набора номера.
Введение команды ATN5? вызывает отображение значения интервала между повторными наборами номера в виде числа, равного количеству двухсекундных интервалов.

ATOn - Возврат в режим соединения.
ATO0 | Заставляет модем ввести режим соединения и начать вхождение в связь в вызывающем режиме на скорости передачи, равной скорости ввода команд AT. Этой команде должна предшествовать команда ATH1 для подключения модема к линии.
ATO1 | Заставляет модем ввести режим соединения и потребовать последовательности повторной настройки от удаленного модема. Эта команда используется только на оговариваемых обычно скоростях передачи.
Команда ATO1 может быть использована для уменьшения ошибок, связанных с ухудшением коррекции в случае повышенного уровня шумов. Если ошибки вызываются некоторыми другими причинами, использование команды ATO1 не позволяет улучшить характеристики. Если повторная настройка неудачна, модем разъединяется.

ATP - Набор номера импульсным методом. Определяет использование импульсного метода для набора телефонного номера (модификатор набора).

ATQn - Разрешение ответов модема. Эта команда определяет, будет ли модем передавать ответные сообщения компьютеру или терминалу для подтверждения команд АТ или о событиях, характеризующих состояние соединения (например OK, BUSY, RING и т.п.).

ATQ0 - Разрешение ответных сообщений.
ATQ1 - Запрет ответных сообщений.

Примечание: Если ответные сообщения запрещены, необходимо делать небольшую паузу, достаточную для выполнения команд, перед тем, как предпринимать последующие действия.
Смотрите также описание команды ATVn.

ATSr? - Считывание содержимого регистров S. Эта команда вызывает передачу содержимого регистра, с номером r на терминал данных.
Величина r представляет собой десятичную целую цифру от 0 до 27.

ATSr=n - Запись в регистры S. Для хранения конфигурации в модеме имеются регистры S. Содержимое этих регистров может быть модифицировано указанной командой.
Величина r представляет целое десятичное число от 0 до 97, а n - целое десятичное число от 0 до 2105. Команда ATSr=n устанавливает регистр S с номером r в значение n.

ATT - Набор номера многочастотным методом. Определяет использование многочастотного метода для набора телефонного номера (модификатор набора).

ATUn - Задание фиксированного режима работы. Определяет новую установку режима работы модема.

ATU0 - Работа под управлением команд АТ и режим V.22bis (ручное включение).
ATU1 - Режим V.22, скорость 600 бит/с, фиксированная.
ATU2 - Режим V.22, скорость 1200 бит/с, фиксированная.
ATU3 - Режим V.22bis, скорость 1200 бит/с, фиксированная.
ATU4 - Режим V.22bis, скорость 2400 бит/с, фиксированная.
ATU5 - Режим V.21, скорость 300 бит/с, фиксированная.
ATU6 - Режим V.23, скорость 75/1200 бит/с, фиксированная.

ATVn - Форма кодов ответов. Определяет форму, полную или сокращенную, в которой модем передает терминалу свои ответы и сообщения.
"Форма кода результата при MNP" (AT\Vn) модифицирует сообщения о соединении, чтобы отобразить соединение в режиме надежного канала.

ATV0 - Передавать коды ответа в сокращенной (цифровой) форме.
ATV1 - Передавать коды ответа в полной (текстовой) форме.

ATWn - Сообщение о процессе согласования. Разрешает использование дополнительного набора кодов ответов для сообщения о прохождении фазы согласования в режиме защиты от ошибок. С помощью этих ответов сообщаются скорость передачи данных и тип используемого протокола (в цифровой и буквенной форме).

Если согласовано установление канала с защитой от ошибок и канал установлен, выводится сообщение CONNECT XXXX (где ХХХХ - скорость передачи в соединении).

В режиме защиты от ошибок может быть выведено сообщение CARRIER XXXX, указывающее скорость, отличную от скорости в сообщении CONNECT XXXX.

ATW0 | Не выводятся сообщения о процессе установления соединения с исправлением ошибок
ATW1 | Выводятся сообщения о процессе установления соединения с исправлением ошибок
ATW2 | Не выводятся сообщения о процессе установления соединения с исправлением ошибок. В сообщениях CONNECT XXXX указывается скорость передачи даннных модемом

ATXn - Расширенные коды ответов. Эта команда определяет, каким образом модем отвечает на тон станции и тон занятия, и какой тип кода ответа CONNECT отображается. Коды ответов отображают надежный режим только тогда, когда была введена команда AT\V1. Когда модем игнорирует ответ станции, он выжидает в течение интервала времени, определяемого регистром S6, и затем набирает номер, независимо от наличия тона станции.

Коды ответа CONNECT, выводящие скорость в бит/с и режим, следующие: CONNECT (совместимость с Bell 103), CONNECT 103/REL, CONNECT 1200, CONNECT 1200/REL, CONNECT 2400 и CONNECT 2400/REL.

Примечание: Модификатор W вызывает ожидание тона станции, независимо от установки ATXn.

ATX0 | Модем игнорирует тон станции и сигнал занятия. Сообщение CONNECT передается только при удовлетворительном установлении соединения.
ATX1 | Модем игнорирует тон станции и сигнал занятия. Ответный код соединения с указанием скорости в бит/с передается при удовлетворительном установлении соединения.
ATX2 | Модем игнорирует тон занятия. Код ответа NO DIALTONE передается, если тон станции не обнаружен в течение 5 секунд с начала попытки соединения. Передача кода ответа с указанием скорости в бит/с производится при удовлетворительном установлении соединения.
ATX3 | Модем игнорирует тон занятия. Передается сигнал BUSY, если обнаружен тон занятия. Передача кода ответа с указанием скорости в бит/с производится при удовлетворительном установлении соединения.
ATX4 | Код ответа NO DIALTONE передается, если тон станции не обнаружен в течение 5 секунд с начала попытки соединения. Модем передает сигнал BUSY, если обнаружен тон занятия. Передача кода ответа CONNECT с указанием скорости в бит/с производится при удовлет- ворительном установлении соединения.

ATYn - Разрешение разъединения после длительной передачи "пробелов". Если данное свойство разрешено, модем разъединяется (отключается от линии) при приеме им непрерывного сигнала BREAK ("пробелов", или "0") в течение интервала времени, большего или равного 1,6 сек. и передает BREAK в течение 4 сек. до отключения от линии после приема команды ATH0.

ATY0 - Запрещено разъединение.
ATY1 - Разрешено разъединение.

ATZ - Сброс. Эта команда выполняет следующие действия:

восстанавливает все заводские установки по умолчанию;
если модем находится в режиме соединения, завершает вызов и отключает модем от линии;
после обработки этой команды модем возвращается в командный режим;
сбрасывает модем и буферы последовательного порта, устанавливает паритет и скорость в бит/с в соответствии с этими параметрами местного компьютера или терминалал, когда будет передана следующая команда AT.


:: Электронное пособие

Электронное пособие > АТ команды > Автоматический надежный режим
АТ команды

» Автоматический надежный режим

Автоматический надежный режим (AT\N3) предназначен для таких случаев, когда неизвестно, поддерживает или нет протоколы исправления ошибок удаленная система, с которой устанавливается взаимодействие. В автоматическом надежном режиме модем ведет в течение заданного времени обнаружение входящих знаков протокола LAPM (если он используется) удаленного модема и, в случае их обнаружения, инициирует процедуру установления надежного соединения.

Если входящие знаки протокола LAPM не обнаружены, модем переходит на обнаружение входящих знаков протокола MNP. Если в течение приблизительно четырех секунд он обнаруживает эти знаки, он пытается организовать надежный канал. В случае необнаружения знаков протокола MNP и, если включена регулировка скорости в бит/с, и была введена команда AT\C0, вместо этого модем устанавливает непосредственное соединение. Если регулировка скорости в бит/с выключена, модем переходит в нормальное соединение (используя управление потоком, если оно разрешено).


:: Электронное пособие

Электронное пособие > Общие сведения > Связные программы для модемов
Общие сведения
» Основные функции протоколов передачи файлов

Передача файлов (текстовых и бинарных) - функция, которую наиболее часто применяют пользователи модемов для телефонных каналов. Она осуществляется с помощью протоколов передачи файлов, реализуемых в составе связных программ для модемов.

Телефонные каналы представляют собой черезвычайно неблагоприятную связную среду с большой вероятностью возникновения ошибок из-за различных помех, которые приводят к искажению сигналов. Поэтому основной целью таких протоколов является обеспечение безошибочной передачи данных.

Для этого передаваемые данные разбиваются на блоки (кадры) определенной длины, и в каждый из них включается проверочная комбинация кода, обнаруживающая ошибки. Эта комбинация формируется по определенному правилу (контрольная сумма, алгоритм циклического кода) на базе передаваемых информационных битов блока. На приемном конце канала производится повторное определение проверочной комбинации по аналогичному правилу и сравнение ее кодов с принятой проверочной комбинацией. При совпадении кодов принимающая сторона посылает подтверждение правильного приема блока ("ack" - acknowledgement), а при их несовпадении - запрос на повторную передачу данного блока либо отрицательное извещение ("nak" - nagative acknowledgement).

Другой важной задачей протоколов передачи файлов является управление потоком передаваемых данных. В простейших протоколах очередной блок не передается до тех пор, пока не поступит подтверждение правильного приема предыдущего блока. Но такой метод приводит к потерям времени на ожидание подтверждения, что снижает скорость передачи. Поэтому более совершенные пртоколы предусматривают непрерывную передачу определенного числа блоков до поступления подтверждения (так называемый "метод окна"). При этом методе необходимо использовать память, так как в течение определенного времени нужно хранить некоторое количество блоков.

Кроме того, протоколы передачи файлов обеспечивают передачу вспомогательной информации. Это кодовые последовательности, управляющие установлением соединения и разъединением на уровне канала данных; сведения, включющие имя и дату создания файла или последней его модификации, размер файла и т.п.). Некоторые разновидности протоколов позволяют в одном сеансе передавать не один файл, а группу файлов (batch transmission).

В комплекс функций, выполняемых протоколами передачи файлов, может быть включена также функция защиты соединения. Например, проверка пароля или контроль аутентичности передаваемой информации.

В зависимости от наличия в модеме или связной программе протокола защиты от ошибок протоколы передачи можно разделить на две группы.

Среди протоколов, рассчитанных на отсутствие защиты от ошибок в модеме или связной программе, наиболее широко используются XModem, XModem-CRC, XModem-lk, YModem, ZModem, Kermit.

Если же защита от ошибок реализована, то используются протоколы, исключающие потери времени на повторный запрос блоков, принятых с ошибками. К таким протоколам можно отнести, например, YModem-g и ZModem. Протокол ZModem допускает оба варианта применения.

Распространены специализированные протоколы, предназначенные для определенных служб и сетей, - такие, как SEALink, Telnet, Compuserve Quick B. Практически все они являются модификациями протокола XModem.


:: Электронное пособие

Электронное пособие > Общие сведения > Взаимодействие с каналом связи
Общие сведения

» Взаимодействие с каналом связи

Практически все модемы для коммутируемых каналов обеспечивают выполнение функций автовызова и автоответа: набор номера импульсным или многочастотным методом, контроль состояния канала, прием вызывного сигнала, yправление установлением соединения и контроль соединения производятся по командам, посылаемым с оконечного оборудования с использованием набора команд АТ компании Hayes Microcomputer Products (США) и/или набора команд Рекомендации МККТТ V.25bis. С помощью команд из этих наборов в энергонезависимую память модема (если она имеется) могут быть записаны телефонные номера абонентов, а с помощью набора команд АТ может быть выполнены установка конфигурации модема и изменение его режима работы.


:: Электронное пособие

Электронное пособие > АТ команды > Формат знаков, образующих команды AT
АТ команды

» Формат знаков, образующих команды AT

Набор команд АТ предназначен для асинхронных терминалов, и знаки команд в обоих направлениях передаются в стандартном стартстопном формате (7 или 8 битов данных, 1 стартовый бит, 1 или 2 стоповых бита, бит проверки на четность или нечетность, который может также или отсутствовать (при 8 битах данных) или иметь постоянное значение 1 (mark) или 0 (space). Для передачи буквенно-цифровых символов используется код США ASCII.

Модемы, в которых используется набор АТ, при первом приеме префикса АТ автоматически подстраиваются под формат данных и скорость передачи связного порта персональной ЭВМ или терминала, с которым они соединены. Скорость обмена между модемом и терминалом в режиме передачи команд может быть выбрана в диапазоне от 300 до 9600 бит/с.


:: Электронное пособие

Электронное пособие > Общие сведения > Связные программы для модемов
Общие сведения
» Выбор протокола передачи файлов

Передача файлов являеттся одной из наиболее трудных задач для пользователя при работе со связной программой. Это можно объяснить не только многовариантностью выбора, но и тем, что одни и те же протоколы скрываются под разными наименованиями, а иногда разные изготовители используют одно и то же название для различных протоколов. Поэтому в первую очередь для передачи файлов нужно убедиться, что на обоих концах канала используется один и тот же протокол.

Протокол передачи файлов в кодах ASCII фактически таковым не является. Он не поддерживает координацию между передающей и приемной системами, исправление ошибок и передачу бинарных файлов. Его можно применять для передачи текстовых файлов системе, подключенной к линии, как альтернативу печати сообщения в режиме on-line. При приеме его полезно использовать, если нужно сохранить весь сеанс или его часть на диске. Для передачи файлов этот протокол использовать не рекомендуют.

Протокол XModem с контрольной суммой (checksum) имеется почти в любой связной программе, представленной на рынке. Обнаружение ошибок с помощью контрольной суммы требует меньшего объема служебной информации, по сравнению с более совершенным методом проверки по циклическому коду (CRC), и является более быстрым. Однако протокол XModem-CRC обнаруживает ошибки, которые пропускает протокол XModem.

Протокол XModem-1k аналогичен классическому протоколу XModem, отличаясь от него только объемом используемых блоков - 1 Кбайт вместо 128 байт. Благодаря большим размерам блока, уменьшается относительная доля передаваемой служебной информации, обеспечивающей обнаружение ошибок. Но если обнаружена ошибка, то требуется повторная передача большого объема данных. При хорошем качестве линии связи протокол XModem-1k обеспечивает более быструю передачу, чем XModem. Если же качество соединения плохое, то более быстродействующим оказывается протокол XModem.

Для передачи нескольких файлов необходимо использовать протокол YModem (во многих связных программах он называется YModem Batch).

При использовании модемов или связных программ, имеющих встроенные протоколы защиты от ошибок, следует применять протокол YModem-g (во многих связных программах он называется YModem-g Batch). В этом, так называемом потоковом, протоколе передающая сторона ожидает подтверждения правильного приема блока данных. В случае обнаружения ошибки принимающая сторона просто прерывает прием. Если установлено соединение с исправлением ошибок (например, с помощью модема с протоколами MNP4 или V.42), то протокол YModem-g обеспечивает более быструю передачу файлов, чем различные варианты протокола XModem или протокол YModem.

Протокол ZModem, также представляющий собой вариант потокового протокола, не прерывает передачу в случае обнаружения ошибки. Вместо этого приемная сторона посылает запрос на повторную передачу поврежденных данных. Благодаря этим свойствам протокол ZModem можно считать наилучшим независимо от того, установлено ли модемное соединение, исправляющее ошибки.

Потокол Kermit разработан для передачи информации больших и мини ЭВМ, которые могут обрабатывать только 7-битовые знаки. При передаче бинарных файлов в программе используется метод под названием "8-bit quoting" для отдельной передачи восьмого бита. Однако некоторые версии Kermit не поддерживают этого метода, что ограничивает его применение для текстовых файлов.

Недостатком протокола Kermit является высокая сложность: для его использования требуется достаточно детальное ознакомление с режимами и особенностями его работы. Кроме того, это относительно медленный протокол, так что использовать его рекомендуется только в тех случаях, когда нет других вариантов.


:: Электронное пособие

Электронное пособие > Общие сведения > Цепи стыка между терминалом и модемом
Общие сведения

» Цепи стыка между терминалом и модемом, используемые при управлении

Цепи стыка, используемые в процедурах установления и проведения соединения приведены ниже, там же показаны направления передачи сигналов по цепям стыка.

Цепь стыков |  | Направление передачи
Номер(мнем.) | Наименование | От модема | К модему
103 (TXD) | Передаваемые данные |  | X
104 (RXD) | Принимаемые данные | X |
106 (CTX) | Готов к передаче | X |
107 (DSR) | Модем готов | X |
108.1 | Подключить модем к линии |  | X
108.2(DTR) | Терминал данных готов |  | X
125 | Индикатор вызова | X |
Примечание. Физически существует только одна цепь 108, которая в зависимости от установленного режима управления модема называется либо 108.1 либо 108.2.

Команды от терминала к модему передаются по цепи 103 ("Передаваемые данные"), а ответы модема - по цепи 104 ("Принимаемые данные").

Цепь 106 - "Готов к передаче". Переход цепи 106 в состояние ВКЛ производится в ответ на переход в состояние ВКЛ цепи 108. Переход цепи 106 в состояние ОТКЛ осуществляется в процессе подключения к линии после обнаружения ответного тона либо, когда модем прерывает соединение из-за перевода терминалом цепи 108.2 в состояние ОТКЛ.

Цепь 107 - "Модем готов". Модем должен перевести цепь 107 в состояние ВКЛ в следующих случаях:

в конце процедуры автоматического установления соединения для указания терминалу, что соединение установлено и модем подключен к каналу;
после завершения процедуры ручного установления соединения.

Модем должен перевести цепь 107 в состояние ОТКЛ в следующих случаях:

для сообщения терминалу, что соединение прекращено во время фазы передачи данных (применяется в тех странах, где это требуется внутренними правилами);
в ответ на требование прекращения соединения при переводе терминалом цепи 108.2 (108.1) в состояние ОТКЛ.

Цепь 108.1 - "Подключить модем к линии". Терминал переводит цепь 108.1 в состояние ВКЛ в следующих случаях:

для передачи команды модему подключиться к линии, набрать хранящийся в модеме номер и выполнить процедуру установления соединения в качестве вызывающего модема;
для передачи команды модему подключиться к линии и выполннить процедуру соединения в качестве отвечающего модема, если цепь 125 находится в состоянии ВКЛ.

Модем должен переводить цепь 108.1 в состояние ОТКЛ в следующих случаях:

для инициации модемом прекращения соединения во время передачи данных;
для инициации прерывания модемом процедуры установления соединения;
для сообщения модему, что терминал не готов принять входящий вызов.

Цепь 108.2 - "Терминал готов". Терминал переводит цепь 108.2 в состояние ВКЛ в следующих случаях:

для разрешения модему ручного или автоматического установления соединения;
для указания модему, что терминал готов к приему входящего вызова.

Модем должен переводить цепь 108.2 в состояние ОТКЛ в следующих случаях:

для иницииации модемом прекращения соединения во время передачи данных;
для инициации прерывания модемом процедуры установления соединения;
для сообщения модему, что терминал не готов принять входящий вызов.

Цепь 125 - "Индикатор вызова". По цепи 125 поступает терминалу от модема сообщение о поступлении входящего вызова. До занятия линии входящий вызов имеет преимушество по отношению к запросу соединения.


:: Электронное пособие

Электронное пособие > АТ команды > Изменение конфигурации модема
АТ команды

» Изменение конфигурации модема

Под конфигурацией модема понимаются все установки, определяющие режим работы модема (скорость передачи, алгоритм взаимодействия с терминалом, формат передаваемых данных и другие параметры), которые могут быть изменены пользователем в процессе эксплуатации модема.

Во всех модемах имеется ПЗУ, хранящее конфигурацию модема, устанавливаемую при его изготовлении, т.н. "заводскую конфигурацию". Профили заводской конфигурации (один или несколько) обычно содержат установки типовых режимов использования модема, они не могут быть изменены пользователем. В документации на модемы заводские установки режимов называются установками "по умолчанию" и выделяются в перечнях возможных установок.

Для хранения профилей конфигурации, которые могут быть сделаны активными, могут быть изменены и фактически используются при эксплуатации и в модемах имеется энергонезависимое ОЗУ. При поставке модемов в энергонезависимом ОЗУ записаны профили заводской конфигурации модема.

Управление модемом производится с использованием т.н. активной конфигурации, хранимой в регистрах S, организованных в рабочем ОЗУ модема. При включении питания модема в качестве активной конфигурации загружается один из профилей энергонезависимого ОЗУ (активный хранимый профиль). Номер загружаемого профиля определяется и может быть изменен значением последней команды ATYn, которая была введена перед выключением питания.

Изменение активной конфигурации производится путем ввода соответствующих команд. Для того, чтобы сохранить измененную конфигурацию в энергонезависимом ОЗУ для дальнейшего использования следует ввести команду AT&Wn, где n - номер профиля энергонезависимого ОЗУ (n = 0,1 ...), в котором будет храниться данная активная конфигурация. Для сохранения активной конфигурации в профиле энергонезависимого ОЗУ, определяемом введенной ранее командой AT&Yn, в ряде типов модемов используется команда AT&W9.

Для вызова в качестве активной конфигурации одного из профилей заводской конфигурации служит команда AT&F, при этом номер загружаемого профиля также будет определяться командой AT&Yn.

В случае сброса модема с помощью команды ATZn в качестве активной конфигурации загружается хранимый профиль с соответствующим номером из энергонезависимого ОЗУ. В ряде типов модемов при сбросе с использованием команды ATZ9 активная конфигурация загружается в профиль, определяемый введенной ранее командой AT&Yn.

Многие типы модемов могут отображать текущую конфигурацию модема, хранящуюся в ОЗУ и в энергонезависимой памяти. В частности, для этой цели используются команды AT&V или AT\S. Ниже приведен пример отображения текущей конфигурации одного из модемов:

Активный набор:

B1 E1 M1 Q0 V1 X4 Y0 &C0 &D0 &G0 &J0 &L0 &P0 &R0 &S0 &X0
S00:000 S01:000 S02:043 S03:013 S04:010 S05:008 S06:002 S07:030
S08:002 S09:006 S10:014 S12:050 S14:AAH S16:00H S18:000 S18:000
S21:00H S22:76H S23:17H S25:005 S26:001 S27:40H

Команды коррекции ошибок:

\A3 \B3 \G0 \J1 \K4 \M0 \N3 \Q2 \T000 \V1 \X0 %A000 %C1 -P0

Хранимый набор 1:

S00:000 S14:AAH S18:000 S21:00H S22:76H S23:17H S25:005 S26:001
S27:40H

Телефонные номера:

&Z0, &Z:


:: Электронное пособие

Электронное пособие > АТ команды > Установление и прекращение соединения
АТ команды

» Установление и прекращение соединения

С использованием команд набора АТ реализуются следующие функции управления соединением:

набор номера и установление соединения;
автоматический и ручной ответ на вызов;
переход в командный режим и обратно в режим передачи данных без прекращения соединения;
прекращение соединения.

Набор номера и установление соединения. Типовая команда набора номера и установления соединения имеет вид:

ATDР 9, 123-4567<CR>

Отдельные элементы этой команды выполняют следующие функции:

AT | префикс команды
D | команда набора
Р | использование импульсного набора
9 | телефонный индекс для выхода на внешнюю линию
, | пауза в 2 секунды
1234567 | телефонный номер
<CR> | "возврат каретки" (знак окончания команды)

Знаки пробела, скобки и дефис предназначены только для улучшения читаемости. Они не занимают места в буфере команд.

После приема этой команды модем подключается к линии и пытается обнаружить ответный тон. В случае необнаружения ответа станции в течение 5 секунд, модем отключается от линии и возвращает сообщение "NO DIALTONE". При обнаружении непрерывного в течение 1 сек. ответного тона посылается десятичная цифра 9 в виде соответствующей комбинации импульсов. Затем перед набором остальных цифр делается пауза в течение 2 сек. После этого модем ожидает "ответного тона" от удаленного модема, и после обмена установленными комбинациями между местным и удаленным модемами процедура вхождения в связь завершается.

Окончательно модемы связываются на взаимно согласованной скорости, величина которой сообщается в отображаемом сообщении "CONNECT". Если модем обнаруживает сигнал "занято", то он отключается от линии и выдает сообщение "BUSY". Если модем не может войти в связь в течение времени, задаваемого регистром S7, он отключается от линии и выдает сообщение "NO CARRIER".

Модему могут быть заданы импульсный или тональный методы набора телефонного номера (команды ATP или АТТ, соответственно).

В команду установления соединения (командную строку набора номера) может быть введен ряд, так называемых модификаторов, позволяющих:

делать необходимые паузы во время набора (","; "/"; "!");
ожидать приема определенных сигналов ("W" - ожидание ответного тона станции, "@"-ожидание вызова до окончания набора);
перейти в режим ответа после набора номера и установления соединения ("R");
перейти в командный режим после окончания номера (";");
набрать номер, хранящийся в энергонезависимой памяти модема ("Sr",где r - порядковый номер данного телефонного номера в памяти: в модемах разного типа запоминается различное количество телефонных номеров - от 1 до 10 и более);
выполнить набор альтернативного телефонного номера, если соединение по основному номеру не удается установить в течение некоторого времени ("/","N");
организовать автоматическое повторение набора номера n=0-15 раз, если вызываемый номер занят ("N=n") с заданным периодом повторения. - в целях защиты, запретить отображение телефонного номера на экране (например, путем помещения номера при записи между знаками "<>").

Автоматический ответ на вызов. Возможность автоматического ответа модема определяется содержимым его регистра S0. Если S0=0, то свойство автоответа запрещено, и модем не может ответить на телефонный вызов.

Если значение S0 находится в пределах от 1 до 255, модем производит подсчет количества телефонных звонков и выдачу сообщения RING на каждый поступивший звонок. Если подсчитанное количество звонков сравняется с числом, хранящимся в регистре S0, модем подключается к линии, выдерживает период молчания в 2,1 с., затем передает в линию ответный тон. Оба модема начинают процедуру вхождения в связь, эта процедура продолжается, пока модемы не введут режим передачи данных или не обнаружат, что они не совместимы.
Примечание: Если значение S0 слишком велико, вызывающий модем может отключиться от линии прежде, чем отвечающий модем передаст ему ответный тон. Это обусловлено тем, что на передающей стороне время ожидания обычно составляет не более 45 с. Значение регистра S7 определяет "период ожидания" вызывающего модема после окончания последовательности набора.

Ручной ответ. Существует 2 варианта использования возможности ручного ответа:

Первый вариант использования

Если выбран вариант "автоответа" и поступил входящий вызов, ответ RING, ввести команду ATA до того, как модем ответит на вызов.Модем игнорирует подсчет звонков, ожидает 2,1 cекунды, затем передает ответный тон и начинает последовательность вхождения в связь.

Второй вариант использования

Если модем находится в командном режиме, ввести команду ATA. Модем "ожидает" 2,1 c., затем передает ответный тон и ожидает последовательности вхождения в связь от вызывающего модема. Если режим соединения не вводится в течение 45 с. (или в течение времени, определяемого установкой регистра S7) модем отключается от линии и возвращает сообщение "NO CARRIER".

В любом случае приема вызывного сигнала модем передает ООД сообщение "RING", независимо от того, разрешено или нет свойство автоответа. Если модем включен, но не введено ни одной команды AT, модему неизвестны скорость и формат знака подключенного к нему терминала или компьютера. В этих условиях модем передает сообщение "RING" на скорости и с типом паритета, определяемыми регистром S23.

Переход в командный режим в процессе соединения. Возможен переход в командный режим без прекращения соединения. Для этой цели используется "последовательность перехода" - "+++". После ввода этой последовательности модем выводит ответ "ОК", и становится возможным управление модемом путем ввода команд АТ с терминала.

Для обратного перехода в режим передачи данных используется команда "ATO0".

Если перед переходом в командный режим качество связи было неудовлетворительным (например, повышенная частость ошибок или плохое качество принимаемого сигнала), при переходе можно инициировать повторную начальную настройку модемов, для чего необходимо использовать команду АТО1.

Непосредственная передача команд модему (или прием ответов модема) осуществляется с клавиатуры терминала (или на дисплей терминала) либо с использованием стандартных связных программ для модемов либо с использованием простейших программ ввода/вывода знаков в последовательный связной порт (стык типа RS-232) терминала.

Некоторые типы модемов имеют отдельный асинхронный порт управления, служащий для передачи команд управления конфигурацией и режимом работы модема, как от местного, так и от удаленного терминалов или персональных ЭВМ.

Прекращение соединения. После завершения передачи данных прекращение соединения может быть сделано несколькими способами.

Разъединение модема может быть достигнуто путем перехода сначала в командный режим с помощью команды "+++", и последующего введения команды ATH<CR>. После этого модем находится в командном режиме и готов к приему новых команд.

Если обнаружено пропадание несущей на время, большее, чем определено в регистре S10, модем непосредственно прекращает соединение и возвращает сообщение "NO CARRIER". Если S10=255, разъединение при пропадании несущей запрещено.

Если ранее была введена и запомнена команда ATY1 (Разъединение по длительному "пробелу" - по "0" информации ), и непрерывно следующие "0" принимаются в течение 1,6 c., то модем прекращает соединение.


:: Электронное пособие

Электронное пособие > АТ команды > Автоматическое согласование скоростей
АТ команды

» Автоматическое согласование скоростей

В модемах имеется последовательный порт и т.н. "канальный порт" модема (т.е. условный порт, скорость передачи которого равна скорости передачи данных в телефонном канале). Последовательный порт предназначен для подключения разъема терминала или ПЭВМ. Модем обменивается данными с терминалом через последовательный порт. Канальный порт модема предназначен для подключения к телефонной линии. Модем обменивается данными с удаленным модемом через канальный порт модема. Свойство автоматического согласования скоростей позволяет установить скорость канального порта местного модема в соответствии со скоростью удаленного модема. Регулировка скорости в бит/с определяет соответствие скорости передачи через последовательный порт скорости в соединении. Последовательный порт может работать в более широком диапазоне скоростей, чем канальный порт модема. Ниже приведены примеры значений окончательных скоростей последовательного порта модема (имеющего возможности передачи данных в канале со скоростями 300, 1200 и 2400 бит/с) после того, как установлено соединение, когда "регулировка скорости в бит/с" включена (AT\J1).

Скорость соединения | Скорость в последовательном порте до соединения | Скорость в последовательном порте после соединения
300 | 50-300 | 300
1200 | 600-1200 | 1200
2400 | 2400-9600 | 2400

Возможно установление соединения между двумя модемами, если они первоначально не установлены на одну и ту же скорость. Если у удаленного модема нет свойства автоматического согласования скоростей, то соединение может быть и не установлено.

В зависимости от предварительной установки скоростей обоих модемов скорость соединения может определяться либо вызывающим, либо отвечающим модемом.

Данное свойство обеспечивает автоматическую установку последовательного порта для согласования со скоростью соединения. По умолчанию обычно данное свойство включено. При этом ПЭВМ или терминал будут автоматически согласованы со скоростью входящих данных. В другом случае потребуется вручную изменить установку используемой связной программы для изменения скорости передачи терминала.

Когда автоматическая регулировка скорости в бит/с выключена, последовательный порт остается на фиксированной скорости, и не требуется изменение скорости в программе при установлении нормального или надежного соединений. (Заводской установкой по умолчанию является обычно непосредственное соединение, в котором модем игнорирует установку команды регулирования скорости в бит/с). Однако, если свойство регулировки скорости в бит/с отключено (AT\J0), следует использовать управление потоком для предотвращения потери данных из-за переполнений буфера (AT\Qn). Управление потоком осуществляет старт и остановку передачи данных.

В дополнение к необходимости управления потоком при выключенном регулировании скорости в бит/с, необходимо разрешить управление потоком для соединения с надежным каналом и когда имеют место задержки, вызванные коррекцией ошибок.


:: Электронное пособие

Электронное пособие > Общие сведения > Защита от ошибок и от несанкционированного доступа
Общие сведения

» Защита от ошибок и от несанкционированного доступа, сжатие данных

Наряду со своими основными функциями, модемы выполняют также исправление ошибок при передаче, сжатие данных и защиту от несанкционированного доступа.

В модемах используются обычно методы исправления ошибок путем обнаружения ошибок с помощью кода и повторного автозапроса блоков данных, принятых с ошибками. Наиболее широко применяется протокол MNP (Microcom Network Protocol) компании Microcom, классы 2-4. В последние годы в модемы стал вводиться протокол LAPM, стандартизированный МККТТ (Рекомендация V.42). МККТТ предусматривает дальнейшее развитие и совершенствование протокола LAPM. В качестве возможной альтернативы в Рекомендации V.42 предусмотрено использование протокола MNP.

Применение в модемах сжатия данных позволяет существенно сократить время передачи информации и, тем самым, время занятия канала связи. Наиболее часто применяется протокол MNP, класс 5, а в последнее время - протокол BLTZ (Рекомендация V.42bis).

В некоторых типах модемов реализованы функции защиты от несанкционированного доступа к модему как со стороны оконечного оборудования, так и со стороны канала. В первом случае для этой цели используется доступ по паролю, а во втором случае - автоматический обратный вызов. При автоматическом обратном вызове после установления соединения с вызывающим абонентом, выдающим себя за клиента данной системы, соединение разрушается, и вызванный модем автоматически устанавливает соединение с данным клиентом по его номеру, который хранится в памяти модема.


:: Электронное пособие

Электронное пособие > Задать вопрос (FAQ)
Задать вопрос (FAQ)

Имя:
E-mail: поля E-Mail и URL заполнять
не обязательно
URL:

- Что такое технология ADSL?
ADSL (Asymmetric Digital Subscriber Line) - это технология, аналогичная модемной, позволяющая передавать данные и речь по одной витой паре медных проводов. ADSL позволяет достичь скорости до 8 Мбит/с при входящей и до 1 Мбит/с при исходящей связи при расстоянии от конечного пользователя до АТС до 5.4 км. В технологии ADSL обычную телефонную линию можно использовать для разговоров по телефону, одновременно передавая или принимая по той же линии данные. Обычные модемы, подключаемые по коммутируемой линии, например, по технологии 33.6K или 56K, такой возможности не дают.
- Каким образом технология ADSL позволяет одновременно разговаривать по телефону или пользоваться факсом и передавать по той же телефонной линии данные?
В технологии ADSL для передачи данных и голоса используются разные участки спектра сигнала. Нижняя часть спектра - от 0 до 4 кГц - используется для обычной телефонной связи (POTS, Plain Old Telephone Service) и передачи факсов, а данные передаются в диапазоне от 38 кГц до 1.2 МГц. Такой подход позволяет одновременно передавать по одной и той же телефонной линии аналоговый сигнал речевой или факсимильной связи и данные. Конечный пользователь может пользоваться своей телефонной аппаратурой и номером, как обычно.


:: Электронное пособие

Электронное пособие > Общие сведения > Функции модемов и методы управления этими функциями
Общие сведения

» Функции модемов и методы управления этими функциями

Все модемы имеют целый ряд общих характеристик и возможностей, к ним относятся: стык с оконечным оборудованием данных (RS-232 или шина персональной ЭВМ типа IBM PC или IBM PS/2), тестовые режимы, диапазон уровней передаваемого и принимаемого сигнала и многие другие. Эти характеристики и возможности, в основном, соответствуют требованиям Рекомендаций МККТТ
серии V.


:: Электронное пособие

Электронное пособие > АТ команды > Основные функциональные группы команд набора AT
АТ команды

» Основные функциональные группы команд набора AT

Команды набора АТ могут быть разделены на следующие функциональные группы:
команды управления установлением и прекращением соединения по коммутируемому телефонному каналу;
команды управления модемом в нормальном режиме;
команды управления модемом в надежных режимах (при использовании защиты от ошибок и сжатия данных);
команды управления отображением ответов модема.


:: отзыв !
:: помощь
:: авторы
Электронное пособие > Отзывы о пособии
Отзывы о пособии

» Переходное состояние

Сейчас Вы перейдете в гостевую книгу. Приносим свои извинения за причиненные неудобства.


:: помощь

:: отзыв !
:: помощь
:: авторы
Электронное пособие > Помощь
Помощь

Надеемся, что данный раздел поможет Вам быстрее освоиться в данном пособии и более эффективно использовать драгоценное время (отведенное на процесс обучения).

Навигация по данному пособию может осуществляется с помощью верхнего меню.

Например, при нажатии на данный графический объект Вы перейдете к разделу "Общие сведения о модемах". Воспользоваться верхним меню можно в любой момент изучения пособия.

Электронное пособие > Помощь
Так же находясь в каком-либо подразделе, Вы можете воспользоваться серым полем верхнего меню, чтобы вернуться к основному разделу или к начальной странице данного пособия.

Рассмотрим возможности нижнего меню:
Вы можете отправить электронное письмо разработчикам данного пособия.
Задайте вопрос преподователю! Для этого необходимо заполнить форму, которая появится после нажатия на эту пиктограмму. Ваш запрос будет обработан в ближайшее время и вывешен в списке лучших вопросов (если есть на то основание).
Зачем тратить кучу времени? Воспользуйтесь поиском! Выберети эту пиктограмму, введите в соответствующее поле интересующее Вас слово или термин, запустите поиск и ... Ура!!! Результат поиска перед Вами.
Хмм... Наверно эта пиктограмма понравится тем кто не хочет тянуться мышкой до верхнего меню (я думаю, бывают такие ситуации). А результат все тот же - Вы вернетесь к оглавлению выбранного вами раздела.
Пора проверить свои знания! Один клик мышкой на соответствующей картинке и Вы попадаете в тестовую систему. Выбираем тему тестирования, отвечаем на вопросы, узнаем результаты у преподователя.

Внимательно узучив графическое изображение в левом верхнем углу, можно обнаружить под ним три странных записи:
:: отзыв ! | Линк на гостевую книгу сайта кафедры.
:: помощь | Вы уже здесь!
:: авторы | Советую прочитать.


:: авторы

:: отзыв !
:: помощь
:: авторы
Электронное пособие > Авторы пособия
Авторы пособия

» Пособие подготовили:

Свердлов Леонид Маркович [идея, первоначальная разработка]
Сотрудник компании SendMail, сотрудник кафедры ОПДС, первый системный администратор, душа и мозг компьтерного класса кафедры, с его идеи началась разработка этого пособия.

Едигарев Кирилл Сергеевич [дизайн, наполнение материалами, верстка]
Сотрудник кафедры ОПДС, системный администратор компьтерного класса кафедры, продолжает добрые традиции и начинания своего учителя и предшественника, генератор безумных идей, изобретатель идеи сомнительных графических элементов, влияющий на логику обучаемых. Во многом благодаря безотказной работе вверенной ему техники и было создано это пособие.

Крайнов Михаил Александрович [дизайн, программирование, верстка]
Сотрудник компании Sovintel, добровольный помощник кафедры ОПДС, друг и соратник системного администратора, воплотитель безумных идей, составитель безумных текстов и частичный воплотитель идеи сомнительных графических элементов, влияющий на логику обучаемых.

» Авторы выражают благодарность:

Когновицкому Олегу Станиславовичу
За вдохновление и веру в нас.

Доронину Евгению Михайловичу
За добрые советы и готовность придти на помощь в трудную минуту.

Симониной Ольге Александровне
За то, что спорила и ругала, не верила и сомневалась.

» Отдельное спасибо:

Нашим Мамам, Папам, Бабушкам, Дедушкам, Сестрам и Братьям
За то, что Вы любите нас, а мы любим Вас!

PR-технологиям и НЛП
За то, что они есть.

Рязановой Наталье
За безотказную помощь в распитии сомнительной жидкости, что в общем-то и помогло закончить этот титанический труд.

Чечениной Елене
За моральную и физическую поддержку.

Танечке
За ... За то что она есть.

Ким Насте
За пищу духовную и не только.

Киму Дмитрию
За блестящий пилотаж транспортных средств, не способных к передвижению, за "Маму", "Сестренку" и "Коня".

Лазареву Артему
За техническую поддержку, громкий голос и вечное понимание.

Санникову Павлу
За доброту, макароны, сосиски и огурцы.

"Русскому Радио"
За музыкальное сопровождение процесса.

"Акуле"
За песню "Кислотный ДиДжей".


:: Электронное пособие

Электронное пособие > Общие сведения > Взаимодействие с оконечным оборудованием
Общие сведения

» Взаимодействие с оконечным оборудованием

Номенклатура цепей стыка модемов с оконечным оборудованием и функции этих цепей для внешних модемов определены Рекомендациями V.24 и V.28 (что соответствует параметрам стандарта США RS-232C), а также Рекомендациями, определяющими тип модема. Встроенные версии модемов представляют собой фактически входные/выходные устройства персональных ЭВМ, подключенные к их общим шинам, и удовлетворяют требованиям этих шин в части параметров и сигналов взаимодействия.


:: электронное пособие :: начало

Санкт-Петербургский Государственный Университет Телекоммуникаций им. проф. М.А. Бонч-Бруевича
Электронное пособие по модемам

Кафедра "Обработки и Передачи Дискретных Сообщений"

1. Авторский коллектив:
асс. Свердлов Леонид Маркович,
инж. студ. СК-76 Едигарев Кирилл Сергеевич,
инж. студ. СК-76 Крайнов Михаил Александрович.

2. Год разработки: 2000.

3. Использование.
a) Пособие используется для обучения студентов всех форм обучения (очная, вечерняя, заочная, дистанционная) в дисциплинах:

Программное обеспечение СПД
специальность 2009, факультеты СС, СК и ВТ;
специальность 2009, факультет ВиЗО;
специальность 5504, Департамент фундаментальной подготовки.

Системы телематики и электронная почта
специальность 5504, Департамент фундаментальной подготовки.

Программное обеспечение СТД
специальность 2202, факультет СС, СК и ВТ.

Мультимедиа технологии при передаче дискретных сообщений
специальность 2204, факультет СС, СК и ВТ.

Основы телекоммуникаций
специальность 3503, Гуманитарный факультет;
специальность 3504, Гуманитарный факультет.

Системы ПД
специальность 2010, факультет МТС.

б) Электронное пособие используют в своих занятиях 6 преподавателей.

в) Для данного электронного пособия предусмотрена тестовая система контроля знаний с помощью доступа через сеть Интернет. Также предусмотрена обратная связь с обучаемым посредством системы FAQ (Frequently Asked Questions) и электронной почты.

г) Учитывая полезность, низкие транзакционные издержки и отсутствие вредных побочных эффектов, кафедра высоко оценивает эффективность использования данного электронного пособия в учебном процессе. Кафедра считает целесообразным использовать данное электронное пособие в учебном процессе в ГУТ, а также в ВУЗах, изучающих телекоммуникационные и модемные технологии.


:: меню

Электронное пособие > Общие сведения
Общие сведения

» Назначение модемов
» Стандарты на модемы и передачу данных
» Цепи стыка между терминалом и модемом, используемые при управлении
» Функции модемов и методы управления этими функциями
» Функции проверки модемов и канала связи
» Взаимодействие с оконечным оборудованием
» Взаимодействие с каналом связи
» Защита от ошибок, сжатие данных и защита от несанкционированного доступа
» Связные программы для модемов
» Протоколы передачи файлов для модемов


:: меню

Электронное пособие > АТ команды
АТ команды

» Основные модификации набора команд AT
» Команды основного набора
» Команды расширенного набора
» Команды "супернабора"
» Модификаторы набора телефонного номера
» Правила построения команд AT
» Формат знаков, образующих команды АТ
» Основные функциональные группы команд набора AT
» Назначение регистров S
» Изменение конфигурации модема
» Основные режимы работы модема
» Установление и прекращение соединения
» Набор номера и установление соединения
» Автоматический ответ на вызов
» Ручной ответ
» Переход в командный режим в процессе соединения
» Прекращение соединения
» Управление работой громкоговорителя
» Перевод модема в режим соединения с исправленим ошибок
» Автоматическое согласование скоростей
» Управление потоком в модеме
» Метод управления потоком XON/XOFF
» Аппаратное управление потоком
» Управление потоком при работе с протоколами LAPM и MNP
» Надежный режим
» Автоматический надежный режим
» Проверка модема и канала связи
» Включение местного аналогового шлейфа
» Включение местного аналогового шлейфа с самопроверкой
» Включение дистанционного цифрового шлейфа
» Включение дистанционного цифрового шлейфа с самопроверкой
» Включение местного цифрового шлейфа
» Прекращение проверок модема и канала связи
» Перевод модема в режим управления командами Рекомендации V.25BIS
» Сообщения и ответы модема


:: меню

Электронное пособие > S регистры
S регистры

» Назначение регистров S
» Регистр S0: Количество звонков до ответа
 » Регистр S1: Подсчет звонков
» Регистр S2: Знак кода перехода
» Регистр S3: Знак возврата каретки
» Регистр S4: Знак перевода строки
» Регистр S5: Знак возврата на одну позицию
» Регистр S6: Ожидание тона станции
» Регистр S7: Ожидание несущей после набора номера
» Регистр S8: Время паузы в наборе по модификатору "запятая"
» Регистр S9: Время ответа схемы обнаружения несущей
» Регистр S10: Задержка между пропаданием несущей и отключением от линии
» Регистр S11: Скважность тона набора
» Регистр S12: Защитное время кода перехода
» Регистр S14: Варианты побитного распределения
» Регистр S16: Варианты проверок модема
» Регистр S18: Таймер проверок (хранится в энергонезависимой памяти)
» Регистр S21: Варианты побитного распределения
» Регистр S23: Варианты побитного распределения
» Регистр S25: Задержка в цепи DTR (108) и CTS (106)
» Регистр S26: Задержка между цепями RTS (105) и CTS (106)
» Регистр S27: Варианты побитного распределения
» Регистр S30: Значения таймера неактивности
» Регистр S37: Установка скорости передачи в канале связи
» Регистр S38: Задержка перед форсированным разъединением
» Регистр S40: Варианты распределения битов (MNP)
» Регистр S41: Варианты распределения битов (MNP)
» Регистр S44: Способ построения кадров
» Регистр S46: Выбор протокола
» Регистр S49: Задание нижнего предела емкости буфера
» Регистр S50: Задание верхнего предела емкости буфера
» Регистр S70: Таймаут по низкому качеству принимаемого сигнала
» Регистр S71: Таймаут по пропаданию несущей
» Регистр S72: Таймаут для проверки качества арендованного канала
» Регистр S73: Таймаут работы на пониженной скорости
» Регистр S74: Число повторных настроек до перехода на пониженную скорость
» Регистр S75: MIN время работы на коммутируемом канале после резервного переключения
» Регистр S82: Варианты обработки разрыва
» Регистр S86: Код причины нарушения соединения
» Регистр S90: MAX длина строки при использовании протокола BTLZ с двумерным кодированием
» Регистр S91: Программируемые уровни передачи/уровень передачи арендованного канала
» Регистр S95: Распределение битов расширенных кодов ответа
» Регистр S97: Программируемые уровни передачи


:: электронное пособие

Электронное пособие > ADSL модемы
ADSL модемы

» Общие сведения

Цифровая абонентская линия (Digital Subscriber Line) - это уникальная технология, позволяющая передавать данные на высокой скорости по обычным медным проводам, традиционно используемым в телефонии.

DSL включает в себя несколько родственных технологий (ADSL, SDSL, HDSL, VDSL, IDSL) объединяемых общим названием - xDSL.

Технология DSL | Максимальная скорость | Максимальное расстояние | Требуемое кол-во телефонных пар | Основное применение
HDSL | 2.048Мбит/с | 3500 м | 2 | Объединение сетей, услуги E1
SDSL | 2.048Мбит/с | 3500 м | 1 | Объединение сетей, услуги E1
IDSL | 128Кбит/с | 5500 м | 1 | Передача данных
ADSL | 8Мбит/с - прием 1.5Мбит/с - передача | 5500 м | 1 | Доступ к Internet, удаленный доступ к ЛВС, голос, видео
ADSL Lite | 1.5Мбит/с - прием 512Кбит/с - передача | 5500 м | 1 | Доступ к Internet, удаленный доступ к ЛВС, голос, видео
VDSL | 52Мбит/с - прием 2.3Мбит/с - передача | 300 м | 1 | Объединение сетей, Телевидение высокого разрешения

Все DSL технологии можно разделить на 2 основных класса:

1. Симметричные технологии (скорость приема и скорость передачи данных одинаковы). К таким технологиям относятся HDSL, SDSL, IDSL.

2. Ассиметричные технологии (скорость приема данных абонентом значительно выше скорости передачи данных от него и значительно выше скоростей симметричных технологий). К таким ассиметричным технологиям относятся ADSL,VDSL.

Симметричные технологии нашли широкое применение при решении задач объединения сетей и использования общих баз данных, организации "выделенных линий" и в случае размещения корпоративных Internet-серверов у абонента.

Максимальная скорость при этом не превышает 2.048 Мбит/с при длине линии связи до 3.5 км. и только низкоскоростная технология IDSL позволяет передавать данные на расстояние до 5.5 км.

Асимметричные технологии позволяют передавать данные абоненту с еще более высокими скоростями (до 8 Mбит/с). Эти технологии используются в основном для организации высокоскоростного абонентского доступа в Internet, передачи голоса и Video на расстояние до 5.5 км.

» Технология ADSL

В настоящее время наиболее перспективной и бурно развивающейся является технология ADSL.

ADSL (Asymmetric Digital Subscriber Line) - это технология позволяющая передавать информацию по обычной абонентской паре, стандартного телефонного кабеля.

ADSL - это технология постоянного, некоммутируемого соединения абонента. Вам не требуется каждый раз устанавливать связь с вашим поставщиком услуг Internet, Вы всегда подключены к сети передачи данных. Передача данных по ADSL технологии производится по тому же кабелю на котором работает Ваш телефон.

Для передачи данных используется диапазон находящийся выше полосы частот отведенной для передачи голоса (выше 4 KHz), поэтому данные и обычный телефонный трафик можно передавать по одной и той же линии связи.

В помещении абонента устанавливается ADSL модем, который подключается параллельно Вашему телефонному аппарату (иногда требуется применение специального частотного разделителя - Splitter).

Далее, со стороны АТС производится подключение вашей телефонной линии к оборудованию DSLAM (DSL Access Multiplexor), которое устанавливается поставщиком услуг ADSL.

Максимально возможная скорость получения данных (до 8Мбит/с) зависит от характеристик конкретной телефонной линии.

Основными факторами влияющими на максимальную скорость передачи данных по линии связи - является длина линии связи, сечение жилы, влияние внешних помех и соседних пар находящихся в этом же кабеле.

Чем короче линия и больше сечение жилы кабеля, тем больше вероятность достигнуть максимальной скорости. Если параметры линии не позволяют работать на максимальной скорости, то скорость передачи данных снижается.

» Стандарты G.dmt и G.lite

Современные ADSL модемы используют помехоустойчивую DMT модуляцию (Discrete Multi-Tone). Группа 15 ITU-T, стандартизирующая DSL, присвоила всем стандартам направления ADSL индекс "G".

Наиболее распространен полноскоростной ADSL по ITU G.992.1 (G.dmt), со скоростью к абоненту до 8Мбит/с и исходящим потоком от абонента до 1 Мбит/с. На практике обычно не всегда требуются такие высокие скорости, да и не все линии связи способны качественно передавать данные с полосой частот до 1.1 MHz.

В октябре 1998 г. ITU-T принял первую редакцию '"упрощенного" стандарта ADSL (G.992.2), получившего название G.Lite. Этот стандарт представляет собой измененный стандарт G.dmt G.Lite менее требователен к качеству телефонной линии так как для своей работы использует более узкую полосу частот (до 420 KHz).

При использовании ADSL оборудования стандарта G.Lite, максимальная скорость получения данных абонентом достигает 1.5М бит/с, а максимальная скорость передачи данных до 512Кбит/с. Технология ADSL G.Lite не требует обязательного применения специального частотного разделителя (Splitter) со стороны абонента, что значительно упрощает установку и подключение, а также снижает общую стоимость оборудования.


:: элетронное пособие

Электронное пособие > Телекоммуникационные программы
Телекоммуникационные программы

Существует огромное множество различных телекоммуникационных программ, предоставляющих пользователю удобство работы с модемом - MTE, Telix, Comi, Bitcom и т.д.
Мы рассмотрим основные возможности нескольких наиболее распространенных коммуникационных програм. Основные параметры, по которым мы оцениваем коммуникационные программы, являются: программная эмуляция протоколов коррекции ошибок (NMP), наличие разнообразных протоколов обмена файлами, дружелюбный интерфейс с пользователями.

MTE

Широко распространенная коммуникационная программа фирмы MagicSsoft. В МТЕ версии 2.10g программно реализован протокол MNР. Поэтому, если ваш модем не имеет аппаратной реализации протокола MNР, использование МТЕ позволяет установить устойчивую связь с MNP-модемами (или с не MNP-модемами, работающими под управлением MTE).

МТЕ имеет следующие встроенные протоколы обмена файлами: ASCII, Xmodem, Xmodem CRC, Ymodem, Ymodem-G, Zmodem, Kermit.

Telix

Telix, версия 3.12-удобная коммуникационная программа, поддерживающая много протоколов обмена файлами. В Telix реализованы следующие протоколы: Kermit, Modem7, SEAlink, Telink, Xmodem, Xmodem-lk, Ymodem, Ymodem-G, Zmodem, HSlink, MobyTurbo, ASCII.

Combit

Combit, версии 1.27b-удобная коммуникационная программа, часто поставляется в комплекте с модемами, не имеющими апаратной реализации MNP. Выполняет программную эмуляцию протоколов MNP2, MNP4, MNP5, MNP7.

Bitcom

Bitcom, версии 3.584-коммуникационная программа, часто постовляемая в комплекте с модемами, не имеющими аппаратной реализации MNP. Выполняет программную эмуляцию протоколов MNP (до MNP5 включительно).

Bitcom поддерживает следующие протоколы обмена файлами:Kermit, Xmodem, Xmodem CRC, Ymodem, Ymodem-G, Zmodem, ASCII.

Venta4Net

Venta4Net создана российской компанией "Вента" на базе программы VentaFax. Программа Venta4Net является комплексом, состоящим из одной серверной и нескольких клиентских частей. Серверный модуль устанавливается на компьютер, оснащенный факс-модемом. Программа позволяет отсылать факсимильные и голосовые сообщения с любого компьютера локальной сети через факс-модем, установленный на единственном компьютере этой сети - сервере Venta4Net.
Принятые сообщения (в зависимости от настроек) могут быть адресованы одному или нескольким пользователям - клиентам Venta4Net. Связь между клиентскими машинами и сервером осуществляется по протоколу TCP/IP. Программа предназначена для использования с операционными системами Windows 98, Me, NT 4.0, 2000 и XP.
При передаче факсимильных сообщений с помощью Venta4Net, помимо обычных для автономных факсимильных аппаратов режимов автоматической или ручной отправки, можно рассылать как одиночные факсы, так и целые их пакеты по расписанию, указав промежуток времени, когда Venta4Net будет включаться и отсылать факсы заранее определенным абонентам.
Venta4Net может получать готовое изображение от сканера (по протоколу TWAIN), а также отправлять документы из любых офисных приложений Windows, поддерживающих функцию печати (на виртуальный принтер VentaFax, устанавливаемый в систему при инсталляции программы). Также для отправки факсимильных сообщений можно воспользоваться преимуществами, предоставляемыми технологией Drag&Drop, - просто перетащить пиктограмму имеющегося документа на ярлык Venta4Net на Рабочем столе или на ее открытое окно.
Прием факсимильных сообщений может производиться как в ручном, так и автоматическом режимах. Принятые факсимильные сообщения сохраняются в виде файлов стандартного графического формата (TIFF) и могут автоматически распечатываться сразу по окончании их приема. Принятые факсимильные сообщения можно просмотреть и, если нужно, отредактировать, используя приложение Менеджер сообщений. Принятые голосовые сообщения сохраняются в стандартном для Windows голосовом формате (WAV).
Программа обеспечивает рассылку голосовых сообщений (телефонограмм), а при необходимости - запишет ответ абонента.
Совместная работа автоответчика и АОНа может обеспечить такую удобную функцию, как способность автоответчика выдавать для разных абонентов разные сообщения.
Задания, созданные пользователями на клиентских компьютерах, передаются на сервер по протоколу TCP/IP и помещаются в общее расписание. Сервер обрабатывает расписание и осуществляет рассылку сообщений. Пользователи клиентской части программы, имеющие соответствующие права доступа, помимо создания, отправки и приема факсов могут просматривать (или даже редактировать) расписание рассылки и Журнал на сервере, а также создавать свои собственные, индивидуальные графики рассылки и телефонные справочники.
Более подробную информацию о Venta4Net можно получить на официальном сайте программы - http://www.venta4net.ru.

» Важные комментарии

Программы, необходимые для проведения учебного процесса на кафедре ОПДС СПбГУТ, находятся на жестких дисках компьютеров, расположенных в аудитории 263. Путь: C:\Student. Каталог Student открыт на полный доступ для локальной сети.


:: электронное пособие

Электронное пособие > Протоколы
Протоколы

» Рекомендация V.8
» Рекомендация V.17
» Рекомендация V.21
» Рекомендация V.22
» Рекомендация V.22bis
» Рекомендация V.23
» Рекомендация V.24
» Рекомендация V.25
» Рекомендация V.25bis
» Рекомендация V.26
» Рекомендация V.26bis
» Рекомендация V.26ter
» Рекомендация V.27
» Рекомендация V.28
» Рекомендация V.29
» Рекомендация V.32
» Рекомендация V.32bis
» Рекомендация V.32ter
» Рекомендация V.33
» Рекомендация V.34
» Рекомендация V.41
» Рекомендация V.42
» Протокол MNP
» Рекомендация V.42bis
» Рекомендация V.90
» Рекомендация V.92
» Рекомендация V.44


:: Электронное пособие

Электронное пособие > АТ команды > Модификаторы набора телефонного номера
АТ команды

» Модификаторы набора телефонного номера

Модификатор | Назначение
"@@" | Ожидание тона посылки вызова до окончания набора
"!" | Кратковременное отключение от линии
" / " | Пауза в 0,125 секунды/набор альтернативного телефонного номера
"," | Пауза во время набора
";" | Возврат в командный режим после набора
R | Переход в режим ответа
W | Ожидание ответного тона станции
"< >" | Запрет отображения номера при наборе

"@@" - Ожидание тона посылки вызова до окончания набора. При обнаружении этой команды в строке набора модем ожидает приема (в течение периода времени, определяемого регистром S7), по крайней мере, 5-и секунд молчания. Если модем не обнаруживает этой паузы в течение периода, определяемого регистром S7, он отвечает сообщением NO ANSWER и отключается от линии. Рекомендуется применять данный модификатор в случае, если вызываемая система не вырабатывает ответного тона.

"!" - Кратковременное отключение от линии. Введение этого модификатора в строку набора заставляет модем на 1/2 с. отключиться от линии и затем вновь подключиться к ней.

"/" - Пауза в 0,125 секунды/набор альтернативного телефонного номера. Модификатор набора. При помещении в командную строку набора до телефонного номера вызывает паузу в наборе номера длительностью 0,125 сек. При помещении в строке набора после телефонного номера следом за ней вводится альтернативный телефонный номер. Эта команда вызывает набор альтернативного телефонного номера, если в течение 5 секунд после набора основного номера соединение не устанавливается.

"," - Пауза во время набора. Когда модем обнаруживает модификатор "запятая" в строке набора, перед набором следующих цифр он делает паузу на период, задаваемый регистром S8. В течение этой паузы модем ничего не передает. Запятая используется, когда после набора цифры 9 необходимо дождаться появления другого ответного тона перед набором следующих цифр номера. По умолчанию, значение, задаваемое регистром S8, равно 2 сек. Для задания более длительной паузы следует ввести в строку несколько"запятых".

";" - Возврат в командный режим после набора. Введеный в конце строки набора, этот модификатор вызывает возврат модема в командный режим после соединения. Данный модификатор позволяет использовать строку набора длиннее 39 знаков.

Примечание: После ввода этого модификатора регистр задержки S7 не активен. Модем остается подключенным к линии пока не поступит следующая команда набора.

R - Переход в режим ответа. Этот модификатор следует за последним знаком строки набора. Когда модем обнаруживает модификатор, он делает выдержку времени в 2 с. и переходит в режим ответа. Данный модификатор рекомендуется использовать для перевода вызывающего модема после окончания набора номера в режим ответа в тех случаях, когда известно, что вызываемый модем находится только в вызывающем режиме (это эквивалентно команде ATA).

W - Ожидание ответного тона станции. Модификатор W помещается между цифрами в строке набора. В этом случае модем ожидает второго ответного тона станции в течение периода времени, задаваемого регистром S7. Если модем принял ответный тон до истечения этого периода, он продолжает набор. Если ответный тон не принят, модем возвращает сообщение NO DIALTONE и отключается от линии. По умолчанию, величина периода, задаваемого регистром S7 равена 30 с.

Примечание: Данная команда аналогична команде ",", за исключением того, что модем пытается обнаружить ответный тон вместо нахождения в состоянии молчания в течение этого периода.

"< >" - Запрет отображения номера при наборе. При реализации в модеме функции защиты от несанкционированного доступа к набираемым телефонным номерам записываемые в память модема номера ограничиваются указанными знаками. В этом случае при наборе телефонного номера, хранимого в памяти, отображение его на экране терминала не производится.


:: Электронное пособие

Электронное пособие > АТ команды > Перевод модема в режим соединения с исправлением ошибок
АТ команды

» Перевод модема в режим соединения с исправлением ошибок

Для модемов, реализующих функции защиты от ошибок и сжатия данных, определены следующие режимы работы: нормальный, непосредственный, надежный и автоматический надежный (устанавливаются командой AT\Nn).

Нормальный режим (AT\N0) может быть использован для связи практически с любым модемом. В нормальном режиме коррекция ошибок не используется. Когда регулировка скорости передачи в бит/с в модеме выключена (AT\J0), то передача данных в канале и на стыке с терминалом может вестись на различных скоростях, в этом случае для предотвращения потери данных должно использоваться управление потоком (AT\Gn).

В непосредственном режиме управление потоком не используется. Таким образом, последовательный порт всегда регулирует скорость соединения.

Надежный режим работы с применением протоколов MNP или LAPM (Рекомендация V.42) позволяет модему установить надежное, без ошибок соединение с любым другим модемом, который также поддерживает указанные протоколы. Если неизвестно, поддерживает ли модем, с которым будет устанавливаться соединение, соответствующий протокол, модем должен быть установлен в т.н. "автоматический надежный режим". Это дает возможность устанавления соединения с модемами, которые поддерживают и не поддерживают эти протоколы защиты от ошибок. В этом режиме в процессе установления соединения модем последовательно проверяет возможности установления соединения, сначала с использованием протокола LAPM (Рекомендация V.42), затем - с помощью протокола MNP (Альтернативный протокол Рекомендации V.42), и только в случае невозможности работы с указанными протоколами устанавливается соединение без исправления ошибок.

Установление конфигурации модема для работы с исправлением ошибок включает следующие этапы:

Ввод команды AT\J0 для выключения регулировки скорости в бит/с.
Установка модема в надежный режим (AT\N2), если модем будет вызывающим, или в автоматический надежный режим (AT\N3) и в режим автоответа (в регистр S0 должно быть записано значение, большее 0), если модем будет отвечающим.
Установка одного из следующих вариантов управления потоком между модемом и терминалом (который используется в терминале, к которому подключен модем):
    XON/XOFF: Ввести AT\Q1
    CTS: Ввести AT\Q2
    CTS/RTS: Ввести AT\Q3
    XON/XOFF (однонаправленный): Ввести AT\Q4
Смотрите раздел "Управление потоком в модеме". Если используемая связная программа поддерживает коды ответов MNP, ввести AT\V1 для разрешения кодов ответов MNP.
Для включения функции сжатия данных должна быть введена команда AT%C1. Для использования преимущества повышенной пропускной способности следует задать последовательному порту самую высокую скорость, которую поддерживает терминал или ПЭВМ (до 9600 бит/с, но исключая 7200 бит/с).

После этого модем готов к установлению надежного соединения с другим модемом, имеющим возможности исправления ошибок и сжатия данных и установленным в надежный или автоматический надежный режимы.


:: Электронное пособие

Электронное пособие > Общие сведения > Связные программы для модемов
Общие сведения

» Протоколы передачи файлов для модемов

» Основные функции протоколов передачи файлов
» Распространенные протоколы передачи файлов
» Выбор протокола передачи файлов


:: Электронное пособие

Электронное пособие > Общие сведения > Связные программы для модемов
Общие сведения

» Связные программы для модемов

Наиболее удобным способом управления модемами является использование стандартных или специализированных связных программ. Связные программы позволяют с помощью команд управления из набора команд АТ или Рекомендации V.25bis реализовать следующие функции:

устанавливать требуемую конфигурацию (режим) модема (только набор команд АТ);
управлять установлением и прекращением соединения путем ввода команд с клавиатуры ЭВМ, контролировать указанные процессы путем вывода на экран дисплея ответов модема;
управлять обменом файлами данных с удаленным оборудованием данных;
программно реализовать протоколы защиты от ошибок и сжатия данных;
эмулировать режим удаленного стандартного терминала большой ЭВМ;
включать диагностические режимы работы работы модема;
хранить справочник телефонных номеров абонента.

Связные программы обычно входят в комплект поставки модемов, устанавливаемых внутрь персональных ЭВМ.


:: Электронное пособие

Электронное пособие > Общие сведения > Связные программы для модемов
Общие сведения
» Распространенные протоколы передачи файлов

Протокол передачи файлов представляет собой набор правил передачи файлов. В его задачи входит:

  1. исправление возникающих при передаче ошибок,
  2. передача и прием определенных кодов, служащих для орнизации связи (handshaking),
  3. выполнение некоторых функций передачи файлов и прекращения передачи.

    » Протокол XModem
    » Протокол XModem-CRC
    » Протокол XModem-1k
    » Протокол YModem
    » Протокол YModem-g
    » Протокол ZModem
    » Протокол Kermit

    Протокол XModem

    Среди протоколов передачи файлов между ПК одним из первых появился XModem. Разработанный еще в 1977 году Вардом Христенсеном, он широко использовался в справочных службах, вводился в недорогие связные программы для ПК и фактически стал стандартом для связи между ПК с использовнием модемов.

    Последовательность действий, выполняемых при передаче файла с помощью протокола XModem, показана на рисунке.

    передатчик
    приемник
    (задание тайм-аута на интервал в 10 с)
    <=====
    "nak"
    "soh" 01 FE -данные- "xx"
    =====>
    <=====
    "ack"
    "soh" 02 FD -данные- "xx"
    =====>
    (помеха в линии связи)
    <=====
    "nak"
    "soh" 02 FD -данные- "xx"
    =====>
    <=====
    "ack"
    "soh" 03 FC -данные- "xx"
    (знак ack искажен)
    =====>
    <=====
    "ack"
    "soh" 03 FC -данные- "xx"
    =====>
    <=====
    "ack"
    "eot"
    =====>
    <=====
    любой знак кроме "ack"
    "eot"
    =====>
    <=====
    "ack"
    Передача завершена

    Передающий ПК начинает передачу файла только после приема от принимающего ПК знака "nak". Принимающий ПК передает этот знак до тех пор, пока не начинается передача файла. Если передано девять знаков "nak", а передача файла не началась, то процесс возобновляется вручную.

    После приема знака "nak" передающий ПК посылает знак начала блока "soh" (start of header), два номера блока (сам номер и его двоичное дополнение по "единицам"), блок данных из 128 байт и контрольную сумму "xx" (блоки нумеруются по модулю 256). Контрольная сумма (1 байт) представляет собой остаток от деления на 255 суммы значений кодов знаков, входящих в блок данных.

    В свою очередь принимающий ПК тоже вычисляет контрольную сумму и сравнивает ее с принятой. Если сравниваемые значения различны или если прошло 10 с и не завершен прием блока, принимающий ПК посылает передатчику знак "nak", означающий запрос на повторную передачу последнего блока. В случае принятия правильного блока приемник передает "ack", а если следующий блок не поступил в течение 10 с, то передача знака "ack" повторяется до тех пор, пока блок не будет правильно принят. После девяти неудачных попыток передачи блока связь прерывается.

    Для исключения повторной передачи одного и того же блока из-за потери подтверждающего сообщения в протоколе используется двукратная передача номера. Принимающий ПК контролирует неповторяемость принятого блока, и если блок ошибочно передан повторно, то он сбрасывается. После успешной передачи всех данных передающий ПК посылает знак завершения "eot" (end of transmission), сообщающий об окончании передачи файла.

    Перерыв в передаче блока свыше 1 с считается разрывом связи.

    Преимуществами данного протокола по сравнению с другими являются:

  4. его доступность для разработчиков программных средств;
  5. простота реализации на языках высокого уровня;
  6. малый объем приемного буфера (256 байт);
  7. возможность передачи не только символьных (коды ASCII), но и исполняеиых файлов (с расширением .COM и .EXE). Последнее возможно вследствии того, что конец файла определяется подсчетом переданных байтов и вместо знака файлового маркера (Ctrl-Z) используется специальный сигнал завершения. Эффективность обнаружения ошибок данным протоколом составляет 99,6% - выше, чем при обычной асинхронной проверке четности (95%).

    К основным недостаткам этого протокола можно отнести:

  8. низкое быстродействие;
  9. большая вероятность необнаруженных ошибок;
  10. необходимость задания имени файла при приеме;
  11. относительно большой объем передаваемой служебной информации.

    Последующие модифакации протокола XModem были направлены на устранение этих и некоторых других его недостанков.

    Протокол XModem-CRC

    В протоколе XModem-CRC передается два проверочных знака, образующих проверочную комбинацию CRC-16, вместо одного знака арифметической контрольной суммы, используемого в исходном протоколе XModem-CRC и в большинстве коммерческих приложений. Проверка CRC-16 гарантирует обнаружение всех одиночных и двойных ошибок, всех нечетных ошибок, всех пакетов ошибок длиной до 16 знаков; 99,9969% 17-битовых пакетов ошибок и 99,9984% более длинных пакетов ошибок.

    В начале соединения вместо знаков "nak", как в протоколе XModem, приемник передает знаки "c". Если передатчик не поддерживает протокол XModem-CRC, он игнорирует эти знаки. Не получив ответа на передачу трех знаков "c", приемник переходит на работу по протоколу XModem и передает знаки "nak".

    Протокол XModem-1k

    Данный протокол представляет собой модификацию XModem-CRC с блоками длиной 1024 байт. При такой длине блоков значительно снижается влияние задержек в системах с разделением времени, модемах и сетях с коммутацией пакетов. Кроме того, по сравнению с обычным протоколом XModem уменьшается относительная доля заголовка в общем объеме передаваемой информации.

    Для сообщения приемнику об увеличении длины передаваемого блока вместо знака "soh" (01) в его начале ставится знак "stx" (02). Номер блока, передаваемый во втором и третьем байтах, увеличивается на единицу независимо от его длины.

    Передатчик не должен изменять длину блока между 128 и 1024 байт, если не был принят знак "ack" для текущего блока. Игнорирование этого ограничения может привести к необнаружению ошибок.

    При использовании блоков по 1024 байт возможно увеличение длины передаваемого файла до значения, кратного 1024.

    Блоки длиной 1024 байт могут применяться при групповой или одиночной передаче файлов. Для сохранения целостности данных, передаваемых по телефонному каналу, с этим вариантом следует использовать проверку CRC-16.

    Протокол YModem

    Протокол YModem - это протокол XModem-CRC, в котором реализована групповая передача файлов. Его появление было вызвано необходимостью устранения недостатков протокола XModem.

    Все программы, реализующие протокол YModem, должны выполнять следующие функции:

  12. передачу имени и пути файла в блоке 0 в виде строки знаков кода ASCII, завершающейся знаком "нуль";
  13. их использование на приемном конце файла в качестве имени и пути принятого файла, если иная реализация не оговорена специально;
  14. применение проверки CRC-16 при приеме знаков "c", в противном случае - использование 8-битовой контрольной суммы;
  15. прием любой комбинации из 128- и 1024-байтовых блоков внутри каждого принимаего файла; возможность переключения длины блоков в конце файла (файлов) и/или в случае частых повторных передач;
  16. исключение изменения длины неподтвержденного блока на передающем конце канала;
  17. передачу в конце каждого файла знака "eot" до десяти раз, пока не будет принят знак "ack" (часть спецификации протокола XModem);
  18. обозначение конца сеанса связи нулевым (пустым) именем пути.

    Связные программы, в которых не реализованы все перечисленные функции, с протоколом YModem не совместимы.

    Выполнение этих минимальных требований не гарантирует надежной передачи файлов при помехах.

    Расширения протокола XModem и протокол YModem устраняют некоторые недостатки протокола XModem, сохраняя в основном его простоту.

    Как и в случае передачи одного файла, приемник инициирует групповую передачу путем посылки знака "c" (для режма CRC-16).

    Передатчик открывает файл и передает номер 0 блока и последующую информацию.

    Для групповой передачи требуются только имена файлов.

    Для обеспечения совместимости "вверх" все неиспользуемые байты блока 0 должны иметь значение 0.

    Имя файла (возможно с указанием пути) передается как строка кодов ASСII, завершаемая знаком "нуль". Этот формат имени файла используется в функциях, ориентированных на операционную систему MS-DOS, или в функциях fopen библиотеке языка Си. В имя файла не включаются пробелы. Обычно передается только само имя (без префекса справочника). Название привода источника (например, A:, B: и т.д.) не передается. Если в имя файла включен каталог, его название должно ограничиваться знаком "/".

    Обозначение длины файла каждого последующего поля произвольно. Длина файла представлена в блоке как десятичная строка, обозначающая количество байтов в файле. В нее не должны входить знаки CPMEOF (^Z) или другие знаки (garbage characters), используемые для заполнения последнего блока.

    Если передаваемый файл увеличивается во время передачи, параметр "длина файла" должен представлять свое максимально ожидаемое значение или не передаваться вовсе.

    Дата модификации является необязательным параметром, имя файла и его длина могут передаваться без передачи даты модификации.

    Протокол YModem допускает возможность введения других полей заголовка без нарушения совместимости со своими прежними программами. Оставшаяся часть блока устанавливается в 0. Это существенно для сохранения совместимости "вверх".

    Если блок имени файла принят с ошибкой по коду, необходимо запросить повторную передачу. Прием блока с именем файла, успешно открытого для записи, подтверждается знаком "ack". Если файл не может быть открыт для записи, приемник прерывает передачу с помощью знака "can".

    Затем приемник инициирует передачу содержимого файлов в соответствии с протоколом XModem-CRC.

    После того как содержимое файла передано, приемник запрашивает имя следующего файла.

    Передача нулевого имени файла может означать, во-первых, что групповая передача завершена, и, во-вторых, что запрошенные у передатчика файлы не могут быть открыты для чтения.

    По умолчанию приемник запрашивает CRC-16.

    Протокол YModem поддерживается большинством связных программ общего пользования.

    Протокол YModem-g

    В настоящее время разработаны методы, обеспечивающие передачу данных с очень высокими скоростями и малой вероятностью ошибок. Эти методы реализованы в высокоскоростных модемах и ряде связных программ; при их применении достигается скорость передачи, близкая к предельной, но при существенном увеличении времени задержки. Эти задержки уменьшают пропускную способность большинства протоколов передачи данных, исправляющих ошибки.

    Вариант g протокола YModem (YModem-g) обеспечивает высокую эффективность передачи в таких условиях. Протокол YModem-g используется приемником, который инициирует групповую передачу путем посылки знака "g" вместо "c". Передатчик, распознавший этот знак, прекращает ожидание обычных подтверждений по каждому переданному блоку и передает последовательные блоки на полной скорости с использованием метода управления потоком, например XON/XOFF.

    Прежде чем передавать файл, передатчик ожидает первоначальных знаков "g", а в конце передачи каждого файла - подтверждающего знака "ack". Такой способ синхронизации позволяет приемнику открывать и закрывать файлы в нужное время.

    При обнаружение ошибки в случае использования протокола YModem-g приемник прерывает передачу, посылая последовательность, состоящую из многих знаков "can".

    Расширение YModem-g протокола YModem позволяет значительно увеличить скорость передачи в каналах с защитой от ошибок (при использовании модемов со встроенным протоколом защиты от ошибок). Это достигается за счет отказа от переспроса принятых с ошибками блоков: при обнаружении ошибки передача файла просто прерывается. Для повышения быстродействия в последующих модификациях протокола XModem (например, в протоколе ZModem) был применен так называемый "оконный" алгоритм, при котором последующие блоки передаются подряд, без ожидания подтверждения правильного приема блока.

    Протокол ZModem

    Этот протокол, введенный в большинство связных программ, получил сейчас самое широкое применение. Представляя собой фактически развитие протоколов XModem и YModem, протокол ZModem устраняет их недостатки и, будучи совместимым с ними, имеет ряд преимуществ:

  19. высокое быстродействие благодаря использованию "оконного" алгоритма;
  20. динамическая адаптация к качеству канала связи посредством изменения в широких пределах размера блока;
  21. защита управляющей информации, доступа к передаче и защита от имитации управляющих сигналов;
  22. возможность возобновления прерванной передачи файла с того места, на котором произошло прерывание;
  23. повышенная достоверность передачи благодаря использованию 32-разрядной проверочной комбинации;
  24. возможность оптимального применения как в канале с высокой вероятностью ошибок, так и в каналах, работающих практически без ошибок (в которых уже реализован протокол, исправляющий ошибки).

    Протокол ZModem разрабатывался для следующих областей применения:

  25. работа в сетях с большим временем задержки (по сравнению с временем передачи знака) и малой вероятностью ошибок;
  26. передача с помощью модемов с временным разделением и буферизацией, характеризующихся значительными задержками и быстрым снижением пропускной способности при росте обмена по обратному каналу;
  27. обеспечение прямой связи между двумя модемами при высокой вероятности ошибок в канале.

    Протокол ZModem может быть использован либо самостоятельно, либо в сочетании с защитой от ошибок канального уровня, реализованной протоколами X.25, V.42, MNP, Fastlink и др. В случае сочетания с протоколами канального уровня протокол ZModem обеспечивает обнаружение и исправление ошибок в интерфейсах между средой, в которой исправляется ошибка, и остальной частью канала связи.

    Можно сказать, что протокол ZModem - это результат технического компромисса между рядом противоречивых требований: простотой реализации и использования, обеспечением высокой пропускной способности, сохранением целостности информации и высокой надежностью передачи.

    Протокол позволяет программно инициировать передачу файлов либо передавать команды и/или модификаторы другим программам. Имена файлов вводятся только один раз. При групповых передачах допускается общее задание файлов (например, "*.txt"). Общее требование: сведение к минимуму количества команд, вводимых с клавиатуры.

    Вместе с файлами передается специальный служебный кадр, инициирующий автоматический прием. Если на противоположном конце не поддерживается протокол ZModem, то он может перейти в режим протокола YModem.

    Протокол ZModem экономно использует пропускную способность обратного канала. Благодаря этому свойству модемы, которые динамически распределяют передачу в двух направлениях, осуществляют передачу с оптимальными скоростями; специальные свойства протокола ZModem обеспечивают простую и эффективную реализацию широкого спектра задач главных ЭВМ, работающих с разделением во времени.

    Передача файлов осуществляется без начального таймаута независимо от того, какая из программ запущена первой, в отличие от протокола XModem, требующего задержки в 10 с.

    С самого начала сеанса по протоколу ZModem вся передаваемая информация защищается циклическим кодом с проверочной комбинацией CRC из 16 или 32 битов. Кроме того, в протоколе реализован механизм защиты информации против сообщений типа "троянский конь", имитирующих разрешенные команды или передачу файлов.

    Хотя протокол ZModem имеет широкий набор возможностей, он не предназначен для замены протоколов канального уровня - таких, как, например, протокол X.25.

    Протокол адаптируется к задержкам сети и систем с временным разделением путем непрерывной передачи данных, продолжающейся до тех пор, пока приемник не прервет передатчик запросом на повторную передачу искаженных данных. Фактически протокол ZModem использует отдельный файл как "окно". Такое упрощение управления буфером исключает переполнение "окна", которому подвержены протоколы MEGAlink, Super Kermit и др.

    ZModem разработан в качестве протокола передачи файлов общего назначения компанией Telenet (США). Его описание и исходная программа Unix rz / sz общедоступны. Лицензирование, торговые марки и ограничение копирования на применение этого протокола и исходной программы Unix rz /sz не распространяются.

    Протокол Kermit

    Протокол Kermit, реализованный практически во всех связных программах, предназначен в основном для передачи файлов между ЭВМ разных типов, включая большие и мини ЭВМ. Он оптимизирован для работы как при сильных помехах, так и при больших задержках сигнала. В отличие от протоколов XModem и YModem в нем используются пакеты переменной длины с максимальным значением 94 байт. Аналогично протоколу YModem протокол Kermit обеспечивает групповую передачу файлов.

    Наряду со стандартным протоколом Kermit в ряде связных программ реализован более эффективный протокол Super Kermit, предусматривающий для уменьшения задержек при передаче переменное "окно" передачи, в котором может содержаться от 1 до 32 пакетов. На приемном конце канала осуществляется обнаружение ошибок, но повторная передача не запрашивается до тех пор, пока не будут переданы все пакеты "окна". Кроме того, в протоколе реализован простой метод сжатия данных, также позволяющий сократить время передачи. Если на противоположном конце канала поддерживается протокол Kermit, то происходит автоматическое переключение на работу с ним.


:: Электронное пособие

Электронное пособие > Общие сведения > Назначение модемов
Общие сведения

» Назначение модемов

Модемы предназначены для преобразования цифровых сигналов оконечного оборудования передачи данных - ООД (терминалы, персональные ЭВМ и т.п.) в вид, пригодный для передачи по аналоговым телефонным каналам и для обратного преобразования принятых из телефонного канала аналоговых сигналов в цифровой вид. Выпускаемые в настоящее время модемы являются "интеллектуальными", т.е. могут управляться с помощью команд, передаваемых от терминала (персональной ЭВМ) к модему по той же цепи, что и данные. Модемы, в свою очередь, передают на терминал ряд сообщений и могут возвращать все команды, полученные от терминала (режим "эха") по цепи принимаемых данных.


:: Электронное пособие

Электронное пособие > АТ команды > Основные модификации набора команд AT
АТ команды

» Основные модификации набора команд AT

Набор команд АТ Hayes Microcomputer Products является фактическим промышленным стандартом на управление модемами для телефонных каналов. Этот набор команд имеет следующие разновидности:

основной набор команд - был впервые реализован в модеме Smartmodem 1200 этой компании и предназначен для Hayes-совместимых модемов на скорость 1200 бит/с;

расширенный набор команд (AT plus) - предназначался для модемов по Рекомендации V.22bis (прототип - модем Smartmodem2 0 2400 той же компании). Традиционный набор расширен "&"-командами. Так же модем содержит память конфигурации и телефоных номеров.

"супернабор" - базируется на расширенном наборе и поддерживает ряд новых свойств высокоскоростных модемов, таких, как управление потоком данных, протокол защиты от ошибок, изменение режима работы интерфейса, управление последовательностями вхождения в связь. Так как модемы значительно различаются по своим свойствам, то в настоящее время не существует единого стандартного "супернабора". В состав "супернабора" дополнительно входят т.н."\"-команды и "%"-команды, а в некоторых типах модемов -"*"-команды.

Некоторые компании, выпускающие модемы, создали собственные наборы команд управления, например компании Case (Великобритания) или Microcom (США), однако в свои модемы они в обязательном порядке включают набор команд АТ.


:: probe

Электронное пособие > S регистры > Назначение S регистров
S регистры

» Назначение регистров S

Модемы сохраняют в ОЗУ установки активной конфигурации в регистрах S. Общее число регистров в модемах может быть до 97 (регистры с S0 до S96). При этом задействованы могут быть не все регистры. В большинстве типов модемов задействовано порядка 30 регистров S (от S0 до S27), а максимальное количество регистров используется в модемах, где применяются протоколы защиты от ошибок и сжатия данных по Рекомендациям МККТТ V.42 и V.42bis. При этом функциональное назначение регистров с номерами, большими 30 в разных типах модемов может быть различным, и для таких регистров приводятся возможные варианты использования при реализации разных функций модемов.

Установки регистров S определяют рабочие характеристики модемов (например, скорость передачи, вид модуляции, формат данных, включение или выключение громкоговорителя, полные или сокращенные коды ответов и многое другое). При включении питания модема в регистры S загружаются величины, хранящиеся в энергонезависимом ОЗУ. Каждый регистр 8-разрядный. С помощью команд АТ содержимое регистров S может быть считано (ATSr?) или изменено (ATSr=n).

Во многих случаях могут использоваться заводские установки команд и регистров модемов, поэтому изменение большинства установок по умолчанию может никогда не потребоваться .

Некоторые регистры управляют одной функцией, для включения или выключения функции необходимо изменить значение числа в регистре (byte mapped registers). Другие регистры управляют несколькими функциями, для интерпретации их действия используется распределение комбинаций битов (bit-mapped registers), т.н. "регистры с распределением битов". Обычно рекомендуется использовать регистры с распределением битов только для считывания состояния модема; для изменения установок модема следует использовать команды.

Набор команд АТ позволяет изменять содержимое регистров S, не зная фактических значений и назначения определенных битов регистров внутри регистра. Например, команда ATB1 устанавливает в 1 бит 6 в регистре S27.

Обычно довольно редко требуется непосредственно считывать значение или записывать его в регистры S, но в некоторых случаях это необходимо. Например, для того, чтобы модем автоматически отвечал на входящий вызов: для задания количества звонков, после которого модем подключается к линии следует ввести в регистр S0 ненулевое десятичное число.


:: Электронное пособие

Электронное пособие > АТ команды > Основные режимы работы модема
АТ команды

» Основные режимы работы модема

После включения питания модем устанавливается в режим ожидания (idle mode). В этом режиме ожидается либо прием команды от терминала либо прием вызывного сигнала из телефонной линии. В первом случае, приняв знаки "АТ" от терминала, модем переходит в КОМАНДНЫЙ РЕЖИМ. В этом режиме путем передачи команд терминал управляет модемом, а модем выполняет указанные команды и передает ответы и сообщения терминалу.

После организации канала между модемами и их вхождения в связь (успешного окончания настроечной комбинации) модем переходит в режим передачи данных. В этом режиме ведется обмен данными между терминалами, т.е. модем передает всю принятую им из канала информацию терминалу и всю принятую от терминала информацию - в канал связи. В этом режиме модемом не отвечает на команды АТ.


Ответы модема

Сообщения и ответы модема

Набором команд АТ предусмотрены формирование модемом и передача терминалу ответов на команды и сообщений о состоянии соединения. Эти ответы и сообщения могут выводиться в виде цифровых кодов либо в виде буквенно-цифрового текста (команда ATVn). Выдача модемом ответов и сообщений может быть заблокирована (команда ATQn). Существует минимальный (базовый) набор сообщений и ответов. Количество ответов из этого набора, разрешенных модему, определяется индексом введенной команды ATXn. Базовый набор ответов и сообщений модема включает:
Текстовая форма | Цифровая форма | Назначение
OK | 0 | Команда выполнена без ошибки
CONNECT | 1 | Установлено соединение на скорости 300 или 1200 бит/с, если введена команда ATX0; установлено cоединение на скорости 300 бит/с, если введены команды ATX1, ATX2, ATX3 или ATX4
CONNECT 300 | 1 | Соединение установлено на скорости 300 бит/с
RING | 2 | Обнаружен вызов
NO CARRIER | 3 | Несущая не обнаружена или потеряна, соединение с другим модемом потеряно по какой-либо причине
ERROR | 4 | Недопустимая команда, аппаратная ошибка или переполение буфера команд
CONNECT 1200 | 5 | Установлено соединение между терминалом и модемом на скорости 1200 бит/с
NO DIALTONE | 6 | Не обнаружен ответный тон станции
BUSY | 7 | Обнаружен сигнал занятия, соединение прервано
NO ANSWER | 8 | Ответный тон удаленного модема не обнаружен
CONNECT 600 | 9 | Установлено соединение между терминалом и модемом на скорости 600 бит/с
CONNECT 2400 | 10 | Установлено соединение между терминалом и модемом на скорости 2400 бит/с
CONNECT 4800 | 31 | Установлено соединение между терминалом и модемом на скорости 4800 бит/с
CONNECT 9600 | 30 | Установлено соединение между терминалом и модемом на скорости 9600 бит/с
CONNECT 7200 | 32 | Установлено соединение между терминалом и модемом на скорости 7200 бит/с
CONNECT 12000 | 33 | Установлено соединение между терминалом и модемом на скорости 12000 бит/с
CONNECT 14400 | 34 | Установлено соединение между терминалом и модемом на скорости 14400 бит/с
CONNECT 19200 | 36 | Установлено соединение между терминалом и модемом на скорости 19200 бит/с
CONNECT 1200/75 | 22 | Установлено соединение между терминалом и модемом на скорости 1200 бит/с (терминал-модем) и 75 бит/с (модем-терминал)
CONNECT 75/1200 | 23 | Установлено соединение между терминалом и модемом на скорости 75 бит/с (терминал-модем) и 1200 бит/с (модем-терминал)
При использовании в модеме протоколов исправления ошибок и сжатия данных командой AT\V1 разрешается вывод модифицированных ответов и сообщений модема:
Текстовая форма | Цифровая форма | Назначение
CONNECT 300/REL | 20 | Установлено соединение в режиме V.21 или Bell 103 (300 бит/с) с исправлением ошибок
CONNECT 300/REL/COMP | 30 | Установлено соединение в режиме V.21 или Bell 103 (300 бит/с) с использованием протокола MNP, класс 4
CONNECT 1200/REL | 22 | Установлено соединение в режиме V.22 (1200 бит/с) с использованием протокола MNP, класс 4
CONNECT 1200/REL/COMP | 32 | Установлено соединение в режиме V.22 (1200 бит/с) с использованием протокола MNP, класс 5
CONNECT 2400/REL | 23 | Установлено соединение в режиме V.22 (2400 бит/с) с использованием протокола MNP, класс 4
CONNECT 2400/REL/COMP | 33 | Установлено соединение в режиме V.22 (2400 бит/с) с использованием протокола MNP, класс 5
CONNECT 4800/REL |  | Установлено соединение в режиме V.22 (4800 бит/с) с использованием протокола MNP, класс 4
CONNECT 4800/REL/COMP |  | Установлено соединение в режиме V.22 (4800 бит/с) с использованием протокола MNP, класс 5
CONNECT 9600/REL |  | Установлено соединение в режиме V.22 (9600 бит/с) с использованием протокола MNP, класс 4
CONNECT 9600/REL/COMP |  | Установлено соединение в режиме V.22 (9600 бит/с) с использованием протокола MNP, класс 5
CONNECT 300 | 40 | Установлено соединение между модемами на скорости 300 бит/с
CARRIER 1200/75 | 44 | Установлено соединение между модемами на скорости 1200 бит/с (местный модем - удаленный модем) 75 бит/с (удаленный модем - местный модем)
CARRIER 75/1200 | 45 | Установлено соединение между модемами на скорости 75 бит/с (местный модем - удаленный модем) 1200 бит/с (удаленный модем - местный модем)
CARRIER 1200 | 46 | Установлено соединение между модемами на скорости 1200 бит/с
CARRIER 2400 | 47 | Установлено соединение между модемами на скорости 2400 бит/с
COMPRESSION: CLASS 5 | 66 | Используется протокол сжатия данных MNP, класс 5
COMPRESSION: V.42bis | 67 | Используется протокол сжатия данных V.42bis (BTLZ)
COMPRESSION: NONE | 69 | Протокол сжатия данных не используется
PROTOCOL: NONE | 70 | Протокол исправления ошибок не используется
PROTOCOL: MNP 2 | 72 | Используется протокол MNP, класс 2
PROTOCOL: MNP 3 | 74 | Используется протокол MNP, класс 3
PROTOCOL: MNP 4 | 76 | Используется протокол MNP, класс 4
PROTOCOL: LAPM | 77 | Используется протокол V.42bis (LAPM)
PROTOCOL: MNP 5 | 78 | Используется протокол MNP, класс 5
PROTOCOL: V.42bis | 81 | Используется протокол сжатия данных V.42bis
PROTOCOL: ALT | 80 | Используется протокол MNP, класс 4 (Альтернативный протокол Рекомендации V.42)
В ряде типов модемов используются следующие ответы и сообщения:
HANG UP | Модем отключился от линии после обнаружения речевого вызова, на который не последовал ответ
BLACKLISTED | Ответ модема при попытке набора телефонного номера, занесенного в "черный список". В этот список помещаются телефонные номера, количество следующих подряд неудачных попыток набора которых превысило в течение некоторого времени заданное число. Такие номера после помещения в "черный список" не могут быть использованы в течение длительного времени, например, в течение 4 часов.
NVRAM ERROR | Ошибка при записи в энергонезависимое ОЗУ
VOICE CALL | Модемом обнаружен речевой вызов


:: Электронное пособие

Электронное пособие > АТ команды > Правила построения команд AT
АТ команды

» Правила построения команд AT

Аббревиатура АТ обозначает по-английски "внимание" (attention). Передача этого кода служит модему сигналом о том, что будет ему передана одна или более команд.

любой передоваемой модему команде или группе команд должна предшествовать передача знаков "АТ" или "at";
с одним префиксом "АТ" может передавать несколько команд;
передаваемая модему команда или группа команд должна завершаться служебным знаком "CR" (возврат каретки);
Примечание: исключением из указанных выше правил является единственная команда "А/" - повторение предыдущей команды, при ее использовании не требуется передавать знаки АТ и CR.
максимальная длина команды не должна превышать емкости буфера команд модема;
Примечание: обычно длина буфера составляет 40 знаков. При этом не учитываются вводимые для удобства чтения команды знаки пробела и дефиса, а также знаки АТ и CR.
в случае ввода несуществуещей или слишком длинной команды модем возвращает сообщение "ERROR" (ошибка);
на правельно введеную команду после ее исполнения модем отвечает сообщением ОК, если не предусмотрено для конкретного случая другого варианта ответа

Некоторые команды требуют числового аргумента. Если он отсутствует, предполагается, что это 0 (ноль).


:: Электронное пособие

Электронное пособие > АТ команды > Назначение регистров S
АТ команды

» Назначение регистров S

Информация о введенных командах АТ и другие данные, определяющие режимы работы и текущие характеристики модема, сохраняются в т.н. регистрах S. Часть регистров S доступна для изменения их содержимого пользователем. Эти регистры представляют собой 8-разрядные ячейки оперативной памяти контроллера модема. Первоначальная загрузка регистров S производится при включении питания из энергонезависимого ОЗУ модема.


:: probe

Электронное пособие > S регистры > Описание
S регистры

» Регистр S0

Количество звонков до ответа. Определяет, после какого числа вызывных звонков модем отвечает на входящий вызов, т.е. подключается к телефонной линии. Введение значения от 1 до 255 переводит модем в режим автоответа. Например, если S0=3, модем ожидает 3 звонка и затем начинает передачу последовательности ответа. Если S0=0, автоматический ответ запрещен. Возможно считывание и изменение значений в регистре.

» Регистр S1

Подсчет звонков. Значение в данном регистре увеличивается на 1 при каждом обнаружении модемом сигнала звонка из телефонного канала. Значение сбрасывается в 0, если сигнал звонка не обнаруживается в течение 8-секундного интервала. Когда значение в регистре S1 становится равным значению в регистре S0, модем начинает передачу последовательности ответа.
Возможно только считывание значения в регистре. Диапазон возможных значений от 0 до 255.

» Регистр S2

Знак кода перехода. В данном регистре хранится значение ASCII кода перехода. Этот код перехода позволяет пользователю выйти из режима передачи данных и ввести командный режим. Значение по умолчанию равно 43, что соответствует знаку "+" кода ASCII. При значениях, больших 127, обнаружение кода перехода запрещается.

Возможны считывание и изменение знака кода перехода. При изменении его, например, на "-", необходимо ввести команду ATS2=45 (45 является десятичным значением кода ASCII для "-"). После этого вход в командный режим будет производиться с помощью "---" вместо "+++", как это было ранее.
Диапазон возможных значений в регистре от 0 до 255.

» Регистр S3

Знак возврата каретки. В регистре S3 хранится десятичное значение кода ASCII знака возврата каретки. Этот знак служит завершающим знаком командной строки и кода ответа. Нормально используется значение 13, но если используется нестандартное оконечное оборудование данных, возможно использование другого значения.
Диапазон возможных значений в регистре от 0 до 255.

Примечание: Обычно значение S3 не сохраняется в энергонезависимой памяти. Оно инициализируется значением 13 при включении модема, или после приема команды ATZ.

» Регистр S4

Знак перевода строки. В регистре S4 хранится десятичное значение кода ASCII знака "перевод строки". Нормально используется значение 10. Этот знак является выходным после знака "возврат каретки", если разрешены коды ответа в развернутой форме (команда ATV1).
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255.

Примечание: Обычно значение S4 не сохраняется в энергонезависимой памяти. Оно инициализируется значением 10 при включении модема, или после приема команды ATZ.

» Регистр S5

Знак возврата на одну позицию. В регистре S5 хранится десятичное значение кода ASCII знака "возврат на одну позицию". Нормально используется значение 8. Этому знаку не должно присваиваться значение, соответствующее печатаемому знаку кода ASCII (т.е., между 33 и 126) или 127 и более. В случае присвоения указанных значений, модем их не распознает.

Когда принят знак "возврат на одну позицию" во время ввода команды, производятся следующие операции:

  1. Модем возвращает эхо знака на терминал.
  2. На терминал выводится знак пробела в коде ASCII (20).
  3. На терминал выводится еще один знак "возврат на одну позицию.
Так как выводится эхо трех знаков, то время, требующееся модему для обработки знака "возврат на одну позицию", примерно равняется времени, которое нужно для передачи 3-х знаков на выбранной скорости передачи. Не рекомендуется передавать многократно эти знаки между между оконечными станциями, так как модем не сможет достаточно быстро обработать их. Попытка ввода данного знака в начале команды (после "AT"), приводит к прекращению передачи эхо.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255.

Примечание: Обычно значение S5 не сохраняется в энергонезависимой памяти. Оно инициализируется значением 8 при включении модема, или после приема команды ATZ.

» Регистр S6

Ожидание тона станции. Этот регистр определяет время ожидания модема после подключения к линии до момента набора им первой цифры номера. Эта задержка обеспечивает телефонной станции время для обнаружения подключения к линии и посылки в линию ответного тона станции ("приглашения к набору"). Если введены команды ATX3 или ATX4, значение в S6 игнорируется. Минимальный период ожидания равен 2 секундам - модем игнорирует любое меньшее значение в регистре S6.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255.
Единица измерения - секунда. Значение по умолчанию обычно равно 002.

» Регистр S7

Ожидание несущей после набора номера. Когда используются расширенные варианты кода ответа ATX3 или ATX4, этот регистр задает время, в течение которого модем ожидает ответный сигнал. Этот регистр определяет также время ожидания модемом несущей от удаленного модема до того, как он отключится от линии в случае ее необнаружения. Модем производит обнаружение несущей, если даже ответный сигнал не обнаружен до истечения таймера S7. Это может привести к удвоению времени ожидания, по сравнению с временем, задаваемым регистром S7, если несущая не обнаружена.
Отвечающий модем использует регистр S7 только для задания периода ожидания несущей.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255.
Единица измерения - секунда. Значение по умолчанию обычно равно 030.

» Регистр S8

Время паузы в наборе по модификатору "запятая". Данный регистр задает длительность паузы в наборе номера, при введении в команду модификатора "," ("запятая"). В общем случае эта пауза используется для ожидания второго тона станции, при вызове с АТС или когда используются специальные телефонные службы.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255.
Единица измерения - секунда. Значение по умолчанию обычно равно 002.

» Регистр S9

Время ответа схемы обнаружения несущей. Задает интервал времени, в течение которого в приемнике должна присутствовать принимаемая несущая, чтобы модем обнаружил это и перевел в состояние "включено" цепь "Обнаружение несущей данных" DCD (109). С увеличением этого времени уменьшается вероятность ложного обнаружения несущей при наличии шумов, таких, как сигнал "занято", речь и т.п. Значение, хранящееся в данном регистре, влияет только на время, требуемое для распознавания присутствия несущей.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255 (от 0,1 до 25,5 сек.).
Единица измерения - 0,1 секунды. Значение по умолчанию обычно равно 006 (0,6 сек.).

» Регистр S10

Задержка между пропаданием несущей и отключением от линии. Задает задержку между обнаружением пропадания несущей сигнала данных от удаленной станции и моментом разъединения модема. Эта задержка позволяет приемнику переносить кратковременные пропадания несущей без отключения от линии местного модема. Если S10=255, то модем игнорирует состояние несущей и функционирует, как будто несущая все время присутствует.

Если в регистре S10 установлено значение, меньшее, чем время ответа на обнаружение несущей в регистре S9, то любое пропадание несущей приводит к разъединению, так как наступает таймаут модема до того, как истекает время задержки ответа схемы обнаружения несущей. Фактическая длительность мгновенного пропадания, которая не чувствуется, равна разности значений времен, определяемых регистрами S10 и S9.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255 (от 0,1 до 25,5 сек.).
Единица измерения - 0,1 секунды. Значение по умолчанию обычно равно 014 (1,4 сек.).

» Регистр S11

Скважность тона набора. В регистре S11 содержится значение в миллисекундах длительности элемента тона набора и паузы. По умолчанию длительность элемента тона равна 95 мс и длительность паузы между элементами 95 мс.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 1 до 255 (от 1 до 255 мс).
Единица измерения - 1 миллисекунда. Значение по умолчанию обычно равно 095 (95 мс).

» Регистр S12

Защитное время кода перехода. Защитное время кода перехода - это интервал времени непосредственно до начала и после окончания кода перехода. Если интервал времени меньше, чем задано в регистре S12, модем не распознает код перехода. Эта задержка защищает модем от ошибочного введения командного режима вместо режима соединения. Задаваемый регистром S12 интервал времени является также максимальным временем раздела отдельных знаков кода перехода. Если определено, что защитное время равно 0, временная синхронизация не является фактором в распознавании защитного времени.

На приведенном выше рисунке:
"+++" - знаки кода перехода;
"T" представляет время;
"XXX" - знаки, введенные в режиме соединения;
"ATH" - команда. Для введения командного режима Т1 и Т4 должны быть больше S12, а Т2 и Т3 - меньше, чем S12.

При задании защитного времени следует следить, чтобы оно не оказалось меньше времени передачи знака на выбранной скорости передачи. Если скорость передачи 300 бит/с, а в регистре S12 установлена 1 (20 миллисекунд), то последовательность перехода никогда не будет обнаружена. Это обусловлено тем, что время передачи одного знака на скорости 300 бит/с равно 33,3 мс - больше, чем защитное время, равное 20 мс. Если значение в регистре S12, будет равно 2 (2х20мс = 40мс), последовательность перехода будет распознана, при этом обеспечиватся интервал между 2 передаваемыми знаками перехода, не превышающий защитное время 40 мс.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255 (от 0 до 5,1 с).
Единица измерения - 20 миллисекунд. Значение по умолчанию обычно равно 050 (1 сек.).

» Регистр S14

Варианты побитного распределения. В регистре S14 содержится распределение значений битов, определяющих внутренние состояния модема. Данный регистр предназначен только для считывания.

Бит | Команда | Описание | Значение
7 | A,D,R | Режим | 0 - ответ 1 - вызов(*)
6 | не используется | - | -
5 | DT,DP | Метод набора | 0 - тональный 1 - импульсный(*)
4 | - | - | Всегда 0
3 | V | Форма кода ответа | 0 - короткий 1 - развернутый(*)
2 | Q | Код ответа | 0 - разрешен 1 - запрещен(*)
1 | E | Эхо | 0 - нет 1 - да(*)
0 | не используется | - | -
* - установка по умолчанию.

» Регистр S16

Варианты проверок модема. Регистр S16 отображает состояние проверочных режимов модема. Проверки включаются командами AT&T. Данный регистр предназначен только для считывания.

Бит | Команда
7 | не используется
6 | Аналоговый шлейф ALB с самопроверкой
5 | Разрешен ответ на включение дистанционного цифрового шлейфа удаленным модемом
4 | Запрещен ответ на включение дистанционного цифрового шлейфа удаленным модемом
3 | Дистанционный цифровой шлейф RDLB
2 | Местный цифровой шлейф LDLB
1 | не используется
0 | Аналоговый шлейф ALB

» Регистр S18

Таймер проверок (хранится в энергонезависимой памяти). Содержимое регистра S18 управляет длительностью режимов проверки. Когда значение в S18 равно 0, работа таймера проверок запрещена.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255.
Единица измерения - секунда. Значение по умолчанию обычно равно 0.

» Регистр S21

Варианты побитного распределения. В регистре S21 содержится распределение значений битов, определяющих внутренние состояния модема. Данный регистр предназначен только для считывания.

Бит | Описание команда | Значение/Команда
7 | Разъединение по длительным "пробелам" | 0 - ATY0(*) 1 - ATY1
6 | Цепь DSR (107) всегда включена | 0 - AT&S0 1 - AT&S1
5 | Управление цепью CD (109) последовательного порта | 0 - AT&C0 1 - AT&C1
4 , 3 | Цепь DTR (108) всегда включена Цепь DTR выключена в командном состоянии Отключение цепи DTR вызывает прекращение работы в канале С выключением цепи DTR производится инициализация модема | 0,0 - AT&D0 0,1 - AT&D1 1,0 - AT&D2 1,1 - AT&D3
2 | Варианты режимов цепей RTS/CTS (105/106) | 0 - AT&R0 1 - AT&R1
1 | не используется | -
0 | Тип разъема канала связи | 0 - RJ11 1 - RJ12, 13

» Регистр S23

Варианты побитного распределения. В регистре S23 содержится распределение значений битов, определяющих внутренние состояния модема. Данный регистр предназначен только для считывания. Установка по умолчанию 07.

Бит | Описание команда | Значение/Команда
7 , 6 | Выбор защитного тона | 00 - AT&G0 01 - AT&G1 10 - AT&G2 11 - не используется
5 , 4 | Вариант паритета | 00 - четный 01 - "пробел" 10 - нечетный 11 - "нажатие"
3 | не используется | -
2 , 1 | Скорость последовательного порта, бит/с | 00 - 300 бит/с 01 - не используется 10 - 1200 бит/с 11 - 2400 бит/с
0 | Ответ на запрос включения удаленного цифрового шлейфа RDLB | 0 - AT&T5 1 - AT&T4

» Регистр S25

Задержка в цепи DTR (108) и CTS (106). Во время синхронного режима и режима синхронного набора хранимого номера (AT&M2) модем игнорирует переход включено/выключено цепи DTR (108) с длительностью, меньшей, чем задана регистром S25.

Во время асинхронного/синхронного режима (AT&M1) регистр S25 выполняет 2 функции.
Во-первых, он задает интервал времени в секундах, в течение которого модем ожидает проверки состояния цепи DTR после установления соединения. Это обеспечивает достаточный период времени для отключения модема от асинхронного терминала и для подключения его к синхронному компьютеру или терминалу без обратного перевода в командное состояние. Кроме того, указанная задержка действует в случае пропадания цепи DTR.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255.
Единица измерения - секунда. Значение по умолчанию обычно равно 005 (5 сек.).

» Регистр S26

Задержка между цепями RTS (105) и CTS (106). В случае отслеживания цепью "Готов к передаче" CTS значения сигнала в цепи "Запрос передачи" RTS и, когда модем обнаруживает при этом переход выключено/включено в цепи RTS, регистр S26 задает время ожидания модема до включения цепи CTS. Цепь CTS повторяет значения в цепи RTS, когда введена команда AT&R0.
Возможны считывание и изменение значений в регистре. Диапазон возможных значений в регистре от 0 до 255 (от 0,01 до 2,55 сек.).
Единица измерения - 0,01 секунды. Значение по умолчанию обычно равно 1 (0,01 сек.).

» Регистр S27

Варианты побитного распределения. В регистре S27 содержится распределение значений битов, определяющих внутренние состояния модема. Данный регистр предназначен только для считывания. Установка по умолчанию 40H (шестнадцатиричное значение).

Бит | Описание команда | Значение/Команда
7 | не используется | -
6 | Режим МККТТ/Bell | 0 - МККТТ V.22 1 - Bell 212A
5 , 4 | Источник тактов передачи | 00 - AT&X0 01 - AT&X1 10 - AT&X2 11 - AT&X3
3 , 2 | не используется | -
1 , 0 | Режим передачи | 00 - Асинхронный режим 01 - Синхронный режим 1 10 - Синхронный режим 2 11 - Синхронный режим 3

» Регистр S30

Значения таймера неактивности. Сообщает величину интервала времени (количество 10-секундных интервалов) до разъединения, в течение которого модем ожидает, в случае отсутствия приема или передачи данных. Таймер не запускается, пока не появляется сообщение CONNECT (смотрите команду AT\Tn).
Диапазон возможных значений интервала времени 0 - 42 минуты.
Значение по умолчанию равно 0.

» Регистр S37

Установка скорости передачи в канале связи. Диапазон значений: 0 - 7. Если установлено недопустимое значение, выполняется функция как при значении в регистре "по умолчанию".
Значение по умолчанию: 0.

Значения S27 | Действия, выполняемые при разных значениях в регистре
0 | Попытка установления соединения на скорости, с которой была введена последняя команда АТ. Для команд АТ, введенных со скоростью, большей предельной скорости данного модема, устанавливается предельная скорость
1 - 3 | Попытка соединения на скорости 300 бит/с
4 | Зарезервировано
5 | Попытка соединения на скорости 1200 бит/с
6 | Попытка соединения на скорости 2400 бит/с
7 | Попытка соединения по V.23 на скорости 75/1200 бит/с

Следует отметить, что в этом случае ограничивается максимальная скорость соединения. Действие установок регистра разрешено при вводе команды AT\N0.

» Регистр S38

Задержка перед форсированным разъединением. Данный регистр определяет задержку между приемом модемом команды АТН на разъединение (или после перехода цепи DTR из состояния ВКЛ в состояние ОТКЛ, если модем запрограммирован на эту функцию) и процедурой разъединения. Для соединений с исправлением ошибок этот регистр может использоваться для обеспечения передачи данных из буфера модема перед разъединением.

Если в регистре установлено число между 0 и 254, модем ожидает соответствующее время перед разъединением для того, чтобы удаленный модем дал подтверждения о передаче данных из своего буфера. Если указанное время истекло до передачи всех данных, то выводится сообщение NO CARRIER для указания о имевшей место потере данных. Если до истечения этого времени все данные были переданы, то на команду АТН выводится сообщение ОК.

При установке в регистре значения 255 модем работает без таймаута и продолжает доставку данных, находящихся в буфере, до потери соединения или до передачи всех данных.
Диапазон: 0 - 255 секунд.
По умолчанию устанавливается обычно 20 секунд.

» Регистр S40

Варианты распределения битов (MNP). Указывает состояние различных команд MNP.

Бит | Состояние различных команд
0 , 1 | AT\Nn (00 - AT\N0, 01 - AT\N1, 10 - AT\N2, 11 - AT\N3).
2 - 4 | AT\Kn (000 - AT\K0, 001 - AT\K1, 010 - AT\K2, 011 - AT\K3, 100 - AT\K4, 101 - AT\K5).
5 , 6 | AT\An (00 - AT\A0, 01 - AT\A1, 10 - AT\A2, 11 - AT\A3)
7 | AT\Gn

По умолчанию записывается значение: "0111 0111".

» Регистр S41

Варианты распределения битов (MNP). Указывает состояние различных команд.

Бит | Состояние различных команд
0 , 1 | AT%Cn
2 - 4 | AT%En
5 , 6 | AT\Ln
7 | AT\G0

» Регистр S44

Способ построения кадров. Диапазон значений: 0 - 3
По умолчанию записывается значение 3.

» Регистр S46

Выбор протокола. Управляет выбором протокола LAPM со сжатием данных или без сжатия данных в соответствии с протоколом BTLZ.

Значения S27 | Действия, выполняемые при разных значениях в регистре
0 | LAPM (V.42 или MNP 2-4)
2 | Эквивалентно значению "0"
4 - 135 | Только протокол MNP 2-5
136 | Реализуется протокол LAPM без сжатия данных (V.42).
138 | Реализуется протокол LAPM со сжатием данных (BLTZ).

В дополнение к протоколу BLTZ (Рекомендация V.42bis) в модеме может быть реализован также протокол сжатия данных MNP 5. Протокол BLTZ используется только с протоколом LAPM, а протокол MNP 5 только с протоколом MNP 4. Разрешение/запрет работы протокола MNP 5 осуществляется командой AT%Cn.

» Регистр S49

Задание нижнего предела емкости буфера при 256-байтовом буферировании. Данный регистр совместно с регистром S50 определяет количество сохраняемых байтов при использовании 256-байтового скоростного буферирования. Когда количество знаков, накопленных в модеме, становится равным значению в данном регистре, дается разрешение терминалу возобновить передачу. Если в регистрах S49 и S50 установлены несовместимые значения (S49 >= S50 или значения вне диапазона), буфер емкостью 1250 байтов используется с нижней границей в 100 знаков.
Значение по умолчанию равно 8.

» Регистр S50

Задание верхнего предела емкости буфера при 256-байтовом буферировании. Данный регистр совместно с регистром S49 определяет количество сохраняемых байтов при использовании 256-байтового скоростного буферирования. Когда количество знаков, накопленных в модеме, становится равным значению в данном регистре, для терминала запрещается передача до тех пор, пока загрузка буфера не станет меньше значения, задаваемого регистром S49. Если в регистрах S49 и S50 установлены несовместимые значения (S49 >= S50 или значения вне диапазона), буфер емкостью 1250 байтов используется с верхней границей в 875 знаков.

» Регистр S70

Таймаут по низкому качеству принимаемого сигнала. Регистр определяет интервал приема сигнала с плохим качеством по арендованному каналу, по истечении которого модем предпринимает попытку переключения на коммутируемый канал. Перед переключением модем может попытаться перейти на пониженную скорость передачи. Запись нулевого значения в регистр блокирует указанное свойство.
Единица измерения - 10 секунд.
Диапазон возможных значений от 0 до 255 (от 0 до 2550 сек.).

» Регистр S71

Таймаут по пропаданию несущей. При работе по арендованным или коммутируемым каналам значение в регистре определяет интервал времени после пропадания несущей на приеме, по истечению которого модем разрушает соединение. При нулевом значении в регистре разединение выполняется модемом сразу же после пропадания несущей.
Единица измерения - 10 секунд.
Диапазон возможных значений от 0 до 255 (от 0 до 2550 сек.).

» Регистр S72

Таймаут для проверки качества арендованного канала. Определяет интервал времени, в течение которого арендованный канал должен работать с удовлетворительным качеством после устранения повреждения, после которого может быть выполнено обратное переключение модема (ручное или автоматическое) с коммутируемого канала на арендованный. Данный регистр используется, если командой AT%D разрешен режим резервного переключения. Регистр приводится в активное состояние командой AT%Mn. Для исключения режима постоянных повторных настроек в регистр должно быть записано значение, большее 3. При записи в регистр нулевого значения обратное переключение производится сразу же после восстановления арендованного канала.
Единица измерения - 10 секунд.
Диапазон возможных значений от 0 до 255 (от 0 до 2550 сек.).

» Регистр S73

Таймаут работы на пониженной скорости. Определяет интервал времени, в течение которого модем работает на пониженной скорости (fallback mode), определенной командой AT%Fn (второй вариант применения), до возврата на прежнюю скорость. Запись нулевого значения в регистр запрещает это свойство.
Единица измерения - 10 секунд.
Диапазон возможных значений от 0 до 255 (от 0 до 2550 сек.).

» Регистр S74

Число повторных настроек до перехода на пониженную скорость. Определяет число попыток повторной настройки модемов до введения режима пониженной скорости (если это разрешено командой AT%Fn). Запись нулевого значения запрещает это свойство.
Диапазон возможных значений от 0 до 255.

» Регистр S75

Минимальное время работы на коммутируемом канале после резервного переключения. Определяет минимальный интервал времени после резервного переключения с арендованного на коммутируемый канал, в течение которог модем работает по коммутируемому каналу, независимо от состояния арендованного канала. Запись в регистр нулевого значения вызывает непосредственное переключени на арендованный канал после его восстановления.
Единица измерения - 10 секунд.
Диапазон возможных значений от 0 до 255 (от 0 до 2550 сек.).

» Регистр S82

Варианты обработки разрыва. Сигналы разрыва представляют для пользователя средство привлечения внимания удаленного модема. Тип разрыва зависит от специфики конкретного применения. Протокол LAPM определяет 3 способа обработки сигнала разрыва: последовательный, ожидаемый и разрушающий.
Диапазон значений: 3, 7 или 128. При вводе недопустимых значений регистр функционирует в соответствии со значением "по умолчанию".
Значение по умолчанию равно 128.

Значения S82 | Варианты обработки разрыва
3 | Ожидаемый разрыв: Модем передает сигнал разрыва непосредственно; целостность данных сохраняется как до, так и после разрыва
7 | Разрушающий разрыв: Модем передает сигнал разрыва непосредственно; данные, обрабатываемые каждым модемом в момент разрыва не сохраняются
128 | Последовательный разрыв: Модем передает сигнал разрыва последовательно с любыми передаваемыми данными. Целостность данных сохраняется как до, так и после передачи разрыва

» Регистр S86

Код причины нарушения соединения. Когда модем возвращает ответ NO CARRIER, в данный регистр записывается некоторое значение, служащее для определения причины нарушения соединения. В регистр записывается первое событие, вызвавшее передачу указанного ответа.

Значения S86 | Код причины нарушения соединения
0 | Нормальное разъединение, появления ошибок в кадрах не было
4 | Пропадание несущей
5 | Неудачное согласование протокола V.42 при обнаружении модема с исправлением ошибок на противоположном окончании (должна быть введена команда AT\N2)
9 | Модемы не могут найти общий протокол
12 | Нормальное разъединение, инициируемое удаленным модемом
13 | Удаленный модем не отвечает после 10 повторных передач одного и того же сообщения
14 | Нарушение протокола: принят недействительный блок согласования

» Регистр S90

Максимальная длина строки при использовании протокола BTLZ с двумерным кодированием. Эффективность передачи может значительно ухудшится, если длина строки выбрана слишком большой, но существенное улучшение может быть достигнуто путем передачи повторяющихся файлов.
Диапазон: 0 - 255 знаков.

» Регистр S91

Программируемые уровни передачи/уровень передачи арендованного канала. С помощью значений в регистре величина уровня передачи может быть установлена в диапазоне от 0 до -15 дБм с шагом 1 дБ для передачи данных как в синхронном, так и в асинхронном режимах. Работа данного регистра разрешена, когда разрешены параметры Японии (напр., с помощью перемычки) или выбран арендованный канал (AT&L1).

S91 = 0 ... S91 = 15 - Уровень 0 дБм ... -15 дБм

Уровень передачи не может быть изменен во время соединения, но может быть установлен для будущего соединения. При работе "на-себя" уровень передачи не должен превышать - 9 дБм.
Примечание. В некоторых типах модемов данный регистр используется для задания длины справочника:
0 - 512 входов, 1 - 1024 входа, 2 - 2048 входов, 3 - 4096 входов.

» Регистр S95

Распределение битов расширенных кодов ответа. При установке битов этого регистра разрешены соответствующие сообщения о процессе согласования, независимо от того, какая команда ATWn была введена.

Бит | Состояние различных команд
0 | Сообщение CONNECT отображает скорость модема вместо скорости терминала
1 | Если установлен протокол исправления ошибок, в конце сообщения о соединении добавляется "/ARQ"
2 | Разрешены коды ответа CARRIER
3 | Разрешены коды ответа PROTOCOL
4 | Зарезервирован
5 | Разрешены коды ответа COMPRESSION. Если используется однонаправленный режим, к сообщению добавляются знаки "/T" или "/R" в зависимости от направления сжатия
6 , 7 | Зарезервирован

» Регистр S97

Программируемые уровни передачи. Уровень передачи регулируется значениями, устанавливаемыми в регистре, в диапазоне от -1 дБм до -15дБм с шагом 2 дБ для передачи как в синхронном, так и в асинхронном режимах. Работа данного регистра разрешена, только, когда разрешены параметры Японии.

S97 = 0 ... S
S97 = 7 - Уровень -1 дБм ... -15 дБм с шагом 2.

Уровень передачи не может быть изменен во время соединения.


:: Электронное пособие

Электронное пособие > АТ команды > Управление работой громкоговорителя
АТ команды

» Управление работой громкоговорителя

В большинстве типов модемов имеется встроенный громкоговоритель. Громкоговоритель позволяет контролировать процесс установления соединения (ответ станции, вызвной тон, ответ дальнего модема, сигнал "занято" и др.). Включение и выключение модема, а также изменение его режима работы (периода включения во время соединения) осуществляется с помощью команды ATMn. Регулировка громкости может производиться путем вращения регулятроа громкости (если он имеется в модеме), а фиксированная установка уровня громкости (малого, среднего и большого) выполняется с помощью команды ATLn.


:: Электронное пособие

Электронное пособие > Общие сведения > Стандарты на модемы и передачу данных
Общие сведения

» Стандарты на модемы и передачу данных

Все основные характеристики модемов (величины скоростей, режимы передачи, используемые виды модуляции, формы спектров модулированных сигналов, номенклатура и параметры цепей обмена с ООД и др.) определены Рекомендациями Международного Консультативного Комитета по телеграфии и телефонии МККТТ. На начальном этапе для передачи данных использовались арендованные телефонные каналы, для этих каналов предназначены модемы по Рекомендациям V.26 (2400 бит/с), V.27 (4800 бит/с), V.29 (9600 бит/с) и V.33 (14400 бит/с). Характеристики передачи арендованных каналов значительно лучше, чем у коммутируемых каналов.

В настоящее время из-за высокой стоимости арендованных каналов, а также, благодаря созданию высокоэффективных средне- и высокоскоростных модемов для коммутируемых каналов (скорости 2400-14400 бит/с), имеет место преимущественное использование для передачи данных коммутируемых телефонных каналов. Для таких каналов предназначены модемы по Рекомендациям V.21 (300 бит/с, дуплекс), V.22 (1200 бит/с, дуплекс), V.22bis (2400 бит/с, дуплекс с частотным разделением направлений передачи), V.23 (1200 бит/с, полудуплекс), V.26bis (2400 бит/с,полудуплекс), V.26ter (дуплекс с использованием эхокомпенсации), V.27ter (4800 бит/с, полудуплекс), V.32 (9600 бит/с, дуплекс), V.32bis (14400 бит/с, дуплекс).

В то же время, практически все выпускаемые модемы имеют возможности работы в режимах, соответствующих Рекомендациям на более низкие скорости, а также - в соответствии со стандартами Bell (США), что сделано для обеспечения совместимости с парком ранее выпущенных и еще находящихся в эксплуатации модемами. Модемы по Рекомендации V.22bis, например, имеют обычно режимы работы по Рекомендациям V.21, V.22, V.23 и стандартам Bell 103 (300 бит/с, дуплекс) и Bell 212A (1200 бит/с, дуплекс); а модемы по Рекомендации V.32 - режим работы по V.22bis и все режимы пониженных скоростей, приведенные для модема по V.22bis.


:: Электронное пособие

Электронное пособие > АТ команды > Управление потоком в модем
АТ команды

» Управление потоком в модем

Управление потоком представляет собой возможность включения и выключения передачи информации между связанными между собой с помощью модемов терминалами или ПЭВМ. Большинство ПЭВМ и терминалов поддерживают управление потоком. Если оконечное оборудование не поддерживает управление потоком, необходимо обеспечить работу последовательного порта на скорости, НЕ БОЛЬШЕЙ, чем действительная скорость соединения. В этих обстоятельствах управление потоком должно быть запрещено как в канальном порте модема, так и в последовательном порте.

Модем может принимать и передавать данные через последовательный порт на скорости, отличающейся от скорости канального порта модема. Это возможно благодаря наличию двух буферов, по одному на каждое направление потока данных. Если последовательный порт работает на скорости большей, чем скорость канального порта модема, его буфер заполняется полностью. Пока ПЭВМ или терминал, соединенный с последовательным портом используют управление потоком, при заполнении буфера потерь данных не происходит.


:: Электронное пособие

Электронное пособие > АТ команды > Управление потоком при работе с протоколами LAPM и MNP
АТ команды

» Управление потоком при работе с протоколами LAPM и MNP

При работе модема в надежном режиме, когда функционируют протоколы исправления ошибок (LAPM или MNP), они сами управляют потоком в канальном порте модема без использования метода XON/XOFF. Переспросы, выполняемые для исправления ошибок, могут вызвать заполнение буфера (если телефонный канал имеет высокий уровень шумов), поэтому в этом режиме важно использовать управление потоком в последовательном порте.


:: Электронное пособие

Электронное пособие > АТ команды > Команды "супернабора"
АТ команды

» Команды "супернабора"

Команда | Назначение
AT\A | Максимальный размер блока протокола MNP
AT\Bn | Передача разрыва
AT\Cn | Установить буфер автоматического надежного режима
AT\E | Эхо данных в нормальном режиме
AT\F | Просмотр хранимых телефонных номеров
AT\Gn | Управление потоком между модемами
AT\Jn | Регулировка скорости передачи данных
AT\Kn | Управление разрывом
AT\Ln | Канал MNP с блочной передачей
AT\Nn | Управление режимом работы
AT\O | Установление надежного канала
AT\Pn | Записать номер в энергонезависимое ОЗУ
AT\Q | Управление потоком в последовательном порте
AT\S | Отображение состояния модема
AT\U | Прием надежного канала
AT\Tn | Управление таймером неактивности
AT\Vn | Форма кода ответа в режиме с протоколом MNP
AT\Y | Переключение в надежный режим
AT\Xn | Передача команд XON/XOFF
AT\Z | Переключение в нормальный режим
AT%An | Знак выхода из автоматического надежного режима
AT%C | Управление сжатием/управление несущей на передаче
AT%Dn | Установка размера справочника (BLTZ)/управление резервной заменой арендованного канала на коммутируемый канал
AT%En | Разрешение/запрет автоматической повторной настройки
AT%Fn | Скорость передачи в канале
AT%Hn | Вариант выбора режима
AT%Mn | Выбор одно- или двунаправленного режима (BLTZ)
AT%On | Переход на арендованный канал из режима работы по коммутируемому каналу
AT%R | Отображение содержимого регистров S
AT%Sn | Установка максимальной длины строки (BTLZ)
AT%U | Сброс скорости последовательного порта
AT%V | Отображение версии фирменного программного обеспечения
AT-Pn | Контроль паритета

AT\A - Максимальный размер блока протокола MNP.

Устанавливает максимальный размер блока протокола MNP для соединений потокового канала (stream link). Эта команда используется, если требуется вести передачу в режиме надежного канала с длиной блоков, меньшей, чем нормальная длина. Это может дать положительный эффект в случае, если известно, что соединение будет проходить при при малых отношениях сигнал/шум.

AT\A0 | Установить максимальный размер блока до 64 знаков.
AT\A1 | Установить максимальный размер блока до 128 знаков.
AT\A2 | Установить максимальный размер блока до 192 знаков.
AT\A3 | Установить максимальный размер блока до 256 знаков.

AT\Bn - Передача разрыва.

Передача удаленной системе из командного состояния сигнала разрыва (Break). При нахождении модема в командном режиме по команде AT\Bn передается разрыв удаленной системе. Для возврата в состояние соединения необходимо ввести команду ATO.

n - целое число между 1 и 9, указывающее интервал времени в количестве периодов по 100 миллисекунд, в течение которого передается сигнал разрыва. (По умолчанию равно 300 миллисекундам). Во время работы надежного канала (с исправлением ошибок) длительность сигнала разрыва всегда равна 300 миллисекунд.

В случае работы в режиме надежного канала при передаче команды ATBn передается кадр Link Attention PDU протокола MNP.

AT\Cn - Установить буфер автоматического надежного режима

Команды AT\Cn определяют порядок обработки данных, принимаемых в начальный период ожидания, когда модем отвечает на вызов в автоматическом надежном режиме.
AT\C0 | Данные не сохраняются в буфере. Все данные, принятые в течение периода ожидания, сбрасываются
AT\C1 | Данные, принятые в течение периода ожидания, сохраняются в буфере. При установлении надежного канала, модем cбрасывает данные. Если период ожидания заканчивается или в буфере накоплено 200 знаков, модем переходит в нормальный режим и пропускает данные, накопленные в буфере к местному терминалу
AT\C2 | Модем не накапливает данные в буфере и непосредственно переключается в нормальный режим после приема знака выхода из автоматического надежного режима, определенного командой AT%A. Данные, принятые до приема знака выхода из автоматического надежного режима, сбрасываются модемом, а сам знак перехода передается терминалу
Данная команда действительна только при нахождении модема в режиме ответа. Модем, находящийся в режиме вызова игнорирует установки этой команды и не накапливает данные в буфере в течение периода первоначального установления протокола MNP.

AT\E - Эхо данных в нормальном режиме

AT\E0 | В нормальном режиме запрещено эхо данных от местного терминала
AT\E1 | В нормальном режиме разрешено зхо данных от местного терминала
В непосредственном или в надежном режимах эхо данных всегда запрещено.

AT\F - Просмотр хранимых телефонных номеров

Позволяет отображать телефонные номера, хранящиеся в энергонезависимом ОЗУ модема. Эта команда эквивалентна команде AT&V2.

AT\Gn - Управление потоком между модемами

Задает метод управления потоком, используемый при передаче данных от удаленного модема к местному модему во время соединения в нормальном режиме. Когда установлена команда AT\G1, модем передает знак XOFF для остановки принимаемых данных и передает знак XON для возобновления приема данных.

AT\G0 - Запрещает управление потоком порта модема
AT\G1 - Устанавливает порт модема в режим управления потоком с помощью сигналов XON/XOFF.

Примечание: В надежном канале имеется собственный метод управления потоком и в нем игнорируются установки AT\Gn. Однако установки управления потоком последовательного порта (AT\Qn) остаются активными в надежном канале.

AT\Jn - Регулировка скорости передачи данных

После установления соединения, когда регулировка скорости в бит/с разрешена (AT\J1), модем автоматически устанавливает скорость последовательного порта для согласования со скоростью соединения. Когда введена команда AT\J1, последовательный порт остается на установленной скорости после завершения соединения. Если компьютер или терминал не может автоматически устанавливать скорость, она должна быть изменена на новое значение вручную.

В нормальном или надежном режимах с включенным управлением потока (AT&Kn или ATG1) регулировка скорости должна быть выключена путем ввода команды AT\J0. В этом случае модем поддерживает постоянную скорость последовательного порта независимо от действительной скорости соединения. Для получения информации о переустановке скорости в бит/с последовательного порта смотрите команду AT%Un%0 (Сброс скорости последовательного порта).

В непосредственном режиме эта команда игнорируется, и регулировка скорости передачи данных всегда разрешена.

AT\J0 - запрещает свойство регулировки скорости в бит/с
AT\J1 - разрешает свойство регулировки скорости в бит/с

Примечание: Для достижения самой высокой пропускной способности, когда используется сжатие данных, следует выключить регулировку скорости в бит/с (AT\J0).

AT\Kn - Управление разрывом

Определяет реакцию модема на сигнал разрыва, принятый модемом, от местного терминала или от удаленной системы. В приведенной ниже таблице перечислены различные типы реакции на значение n, когда модем принимает или передает разрыв. Модемы могут накапливать несколько значений разрыва как в порте модема, так и в последовательном порте.

Примечание: В режиме соединения надежного канала установка управления разрывом передатчика, определяет, каким образом приемник обрабатывает разрыв.

AT\Kn - где n - число между 0 и 5, указывающее тип разрыва, передаваемого модемом.

Разрыв, передаваемый последовательному порту; модем в состоянии передачи данных во время надежного или нормального соединения:
n | Воздействие
0, 2, 4* | Вводит командное состояние, но не передает разрыв удаленной системе
1 | Очищает буферы данных и немедленно передает разрыв удаленной системе
3 | Немедленно передает разрыв удаленной системе
5 | Передает разрыв удаленной системе последовательно с передаваемыми данными
* Вызывает переход в командное состояние. Для передачи разрыва следует ввести команду AT\B (Передать разрыв) с последующей командой ATO(Ввести состояние соединения).

Передана команда "Передача разрыва", модем находится в командном состоянии в течение надежного или нормального соединений:
n | Воздействие
0, 1 | Очищает буферы данных и немедленно передает разрыв удаленной системе
2, 3 | Немедленно передает разрыв удаленной системе
4, 5 | Передает разрыв удаленной системе последовательно с любыми передаваемыми данными, помещенными в буфер
Разрыв принят от порта модема, модем находится в состоянии соединения в нормальном соединении:
n | Воздействие
0, 1 | Очищает буферы данных и немедленно передает разрыв в последовательный порт
2, 3 | Немедленно передает разрыв в последовательный порт
4, 5 | Передает разрыв в последовательный порт последовательно с любыми ранее помещенными в буфер данными

AT\Ln - Канал MNP с блочной передачей

AT\L0 - Инициируется установление блочного канала
AT\L1 - Инициируется установление потокового канала

Рекомендуется использовать эту команду только в специфических применениях, в которых применяется протокол стыка.

Примечание: Если производится изменение типа канала с MNP, то это изменение не действует до следующего соединения. Оба модема должны иметь одну и ту же установку AT\Ln.

AT\Nn - Управление режимом работы

Выбор рабочего режима используется модемом в состоянии соединения. Режим работы определяет, как модем взаимодействует с удаленной системой.
AT\N0 | Нормальный режим (с буферированием). Может использоваться для связи почти с любым модемом. В нормальном режиме не используется коррекция ошибок. Когда выключена регулировка скорости передачи данных, последовательный порт и порт модема могут работать во время соединения на разных скоростях. Для предотвращения потери данных должно использоваться управление потоком.
AT\N1 | Непосредственный режим. В этом режиме модем не буферирует данные и управление потоком игнорируется. В соединенном состоянии последовательный порт всегда регулирует скорость соединения, независимо от установки команды регулирования скорости в бит/с. Непосредственный режим используется в соединениях без MNP, когда последовательный порт согласован с портом модема, а коррекция ошибок не включена, и для форматов специального назначения или наборов знаков, таких, как Бодо или телекс.
AT\N2 | Надежный режим. Режим надежного канала с MNP используется для обеспечения обнаружения ошибок и автоматической повторной передачи данных, если возникают ошибки. Это гарантирует, что связь между местной и удаленной системой будет без ошибок. Удаленная система должна быть оборудована таким образом, чтобы работать с надежным каналом с MNP. Когда действует команда AT\N2, модем пытается организовать надежный канал с MNP непосредственно после установления соединения. Если попытка не удается, модем прекращает соединение. При работе в надежном канале с MNP должно использоваться управление потоком в последовательном порте. Когда модем обнаруживает ошибки передачи, он сохраняет данные от последовательного порта в буфере, пока выполняется исправление ошибки. Удаленная система также должна использовать управление потоком, когда действует команда AT\N2.
AT\N3 | Автоматический надежный режим. В некоторых вариантах модем должен взаимодействовать с удаленными системами, которые могут поддерживать или не поддерживать надежный канал с MNP. Для таких ситуаций предназначен автоматический надежный режим. В автоматическом надежном режиме отвечающий модем производит обнаружение входящих знаков протокола MNP от удаленного модема. Если он обнаруживает их в течение приблизительно 3 секунд, модем пытается установить соединение в режиме надежного канала.
Примечание: Если регулировка скорости в бит/с выключена (AT\J0), модем переходит в режим нормального соединения и использует управление потоком, если оно разрешено.

Данная команда функционирует только в асинхронном режиме работы.

AT\O - Установление надежного канала

Заставляет модем инициировать организацию надежного канала независимо от того, является ли модем вызывающим или отвечающим. Однако, для успешного установления надежного канала на удаленном модеме должна быть введена команда AT\U.

Модем передает 2 запроса на установление надежного канала и, если не получает ответа, возвращается в исходное состояние.

AT\Pn - Записать номер в энергонезависимое ОЗУ

Производит запись следующего за данной командой номера по входу n энергонезависимого ОЗУ. Эквивалентна команде AT&Zn. Записанный номер может быть набран с помощью команд ATD/n или ATDS=n.

AT\Q - Управление потоком в последовательном порте

Эта команда действует только в надежном или в нормальном режимах.
AT\Q0 | Запрещено управление потоком в модеме
AT\Q1 | Разрешено программное управление потоком типа XON/XOFF в модеме. Возможна передача данных в обоих направлениях: к модему и от модема
AT\Q2 | Модем использует цепь CTS (106) для управления данными, поступающими от местного терминала. Местный терминал не может управлять потоком данных, поступающих от модема
AT\Q3 | Модем использует двунаправленное аппаратное управление потоком по цепям CTS/RTS (106/105)

AT\S - Отображение состояния модема

Отображает текущие установки модема. Вводится для обеспечения совместимости с набором команд Microcom. При нахождении модема в состоянии соединения в первой строке выводимого сообщения указывается время, прошедшее от начала соединения (часы:минуты:секунды).

Данная команда аналогична команде AT&V.

AT\Tn - Управление таймером неактивности

Определяет интервал времени в минутах, в течение которого модем ожидает до автоматического отключения от линии, если он не передает или не принимает данные. Если команда AT\Tn установлена в свое значение по умолчанию (AT\T0), то то работа таймера неактивности запрещена.

Величина n - число в диапазоне от 0 до 255, определяет интервал времени в минутах (по умолчанию равно 0).

Таймер неактивности должен быть установлен до введения состояния соединения. Таймер неактивности может функционировать только в соединениях с нормальным или надежным каналами, он игнорируется, когда модем работает в непосредственном режиме. В синхронных режимах таймер неактивности не функционирует.

AT\U - Прием надежного канала

Позволяет принять запрос надежного канала (по команде AT\O) от инициатора соединения независимо от того, является ли модем вызывающим или отвечающим. После ввода команды модем ожидает в течение 12 секунд запроса надежного канала от противоположного модема и, если не принимает его, то переходит в предыдущее состояние. Эта команда выполняется только при наличии физического соединения модемов. Данная команда должна быть последней в командной строке.

AT\Vn - Форма кода ответа в режиме с протоколом MNP

Определяет индикацию кодов ответа о том, что установлен надежный канал. Когда установлена команда AT\V0, модем использует коды ответа, предусматриваемые командой ATV. Рекомендуется использовать команду AT\V0, если примененной связной программой не предусмотрено ожидание приема кода ответа надежного канала, если даже надежное соединение установлено. Если связной программой поддерживаются коды ответа MNP, следует ввести команду AT\V1.

AT\V0: Разрешает стандартные коды ответа.
AT\V1: Разрешает модифицированные коды ответа MNP.

Фактическая скорость местного терминала после установки скорости зависит от команды AT\Jn.

AT\Y - Переключение в надежный режим

Заставляет модем сделать попытку организовать надежный канал с MNP, когда соединение уже установлено в нормальном режиме. Данная команда должна быть последней в командной строке.

Если модем явялется вызывающим, то он пытается инициировать установление надежного канала. Если модем является отвечающим, то он делает попытку приема надежного канала.

AT\Xn - Передача команд XON/XOFF

Данная команда действует только в режимах нормального или надежного каналов.
AT\X0 | Запрещает модему передавать связанному с ним терминалу принятые знаки XON/XOFF, если командами AT\Q1 (сторона терминала) или AT\G1 (сторона модема) выбран метод управления потоком XON/XOFF. Модем непосредственно реагирует на знаки XON/XOFF. Сигналы XON/XOFF передаются противоположному модему только при полном буфере.
AT\X1 | Разрешена передача модемом знаков XON/XOFF в обоих направлениях: от местного терминала к удаленной системе, от удаленной системы к местному терминалу. Модем непосредственно реагирует на знаки XON/XOFF и сразу же передает их удаленному модему.

Если управление потоком XON/XOFF деактивировано, знаки XON/XOFF передаются как регулярные данные.

Предупреждение: Когда введена команда AT\X0 и разрешено управление потоком XON/XOFF, местные устройства, такие, как компьютеры или принтеры могут передавать знаки XON/XOFF последовательному порту модема. Если модем уже управляет потоком данных к удаленной системе, местные знаки управления потоком не мешают соединению. Однако, если введена команда AT\X1, знаки местного управления потоком, предназначенные для местной системы, могут включить поток данных от удаленной системы до того, как модем готов принять данные, что приведет к потере данных.

AT\Z - Переключение в нормальный режим

Команда вызывает непосредственный переход местного и удаленного модемов в нормальный режим во время нахождения в режиме надежного канала.

AT%An - Знак выхода из автоматического надежного режима

Прием этого знака вызывает выход модема из автоматического надежного режима. Величина n может принимать значения 0-127 кодов ASCII

AT%C - Управление сжатием/управление несущей на передаче

Первый вариант применения
AT%C0 | запрещает сжатие данных во время надежных соединений;
AT%C1 | разрешает сжатие данных во время надежных соединений. (При использовании протокола защиты от ошибок LAPM устанавливается протокол сжатия BTLZ, при использовании протокола защиты от ошибок MNP, класс 4, устанавливается протокол сжатия данных MNP, класс 5.
Данная команда определяет, будет ли модем пытаться использовать сжатие данных во время надежного соединения. Оба модема должны иметь введенные команды управления сжатием и блочного канала MNP в их значениях по умолчанию (AT%C1 и AT\L0, соответственно) к моменту установления надежного соединения. Рекомендуется также для получения более эффективных результатов выключить регулировку скорости в бит/с (AT\J0).

Второй вариант применения

В этом варианте данная команда позволяет устанавливать режим постоянной или коммутируемой несущей на передаче. В большинстве применений несущая на передаче существует постоянно как в вызывающем, так и в отвечающем модемах. В применениях с полудуплексной передачей может потребоваться установка удаленного модема в режим коммутируемой несущей на передаче для обеспечения требуемого времени смены направления передачи.

AT%C0: Постоянная несущая
AT%C1: Коммутируемая несущая

AT%Dn - Установка размера справочника (BLTZ)/управление резервной заменой арендованного канала на коммутируемый канал

Первый вариант применения

Управляет заданием размеров справочника.

AT%D0 512 входов
AT%D1 1024 (1 к) входов
AT%D2 1024 (2 к) входов
AT%D3 4096 (4 к) входов

Хотя задано 4 варианта размеров справочника, которые могут быть выбраны пользователем, модемом может быть согласован любой размер справочника от 512 до 4096 входов. Справочник с размером до 2048 входов может использоваться как при одно- , так и при двунаправленном сжатии. В случае выбора справочника с 4096 входами в режиме двунаправленного сжатия модем автоматически переходит на размер в 2048 входов.

Второй вариант применения

В этом варианте команда AT%D управляет свойством модема выполнять резервное переключение передачи на коммутируемый канал с арендованного канала при ухудшении качества последнего. Модем может быть установлен на автоматическое либо ручное переключение. Отказ арендованного канала регистрируется, когда несущая на приеме отсутствует в течение времени, большего, чем интервал, определяемый регистром S71. При инициации переключения используется один из хранимых профилей конфигурации и сохраняемый в памяти телефонный номер. После переключения на коммутируемый канал арендованный канал может непрерывно контролироваться (в зависимости от введенной команды AT%M). После восстановления арендованного канала модем автоматически возвращается на арендованный канал (если это разрешено командой AT%M), используя соответствующий профиль когнфигурации, хранящийся в памяти модема. Этот возврат разрешается только после того, как арендованный канал обеспечивает удовлетворительный уровень приема в течение времени, задаваемого регистром S72. Возможен ручной возврат оператором модема на работу по арендованному каналу с помощью команды AT%O.
AT%D0 | Резервирование запрещено
AT%D1 | Ручное переключение на коммутируемый канал. В этом случае переключение осуществляется с помощью АТ-команды или органов управления модема (если они имеются)
AT%D2 | Переключение производится автоматически после обнаружения отказа арендованного канала. Это свойство реализуется, когда значение сигнала качества оказывается хуже некоторого заданного порога в течение времени большего, чем определено регистром S70, или когда превзойдено значение, хранящееся в регистре S74 (последовательные повторные настройки)
Примечание: Если разрешено свойство перехода на пониженную скорость (команда AT%Fn), модем предпринимает попытки перехода на пониженную скорость до принятия решения о переключении на коммутируемый канал.

AT%En - Разрешение/запрет автоматической повторной настройки

Управляет введением режима автоматического контроля модемом качества канала и введением запроса повторной настройки для достижения максимальной пропускной спомбности в случае ухудшения качества линии или сигнала.

AT%E0 Запрет автоматической повторной настройки
AT%E1 Разрешение автоматической повторной настройки

AT%Fn - Скорость передачи в канале

AT%F0 | Автоматическое распознавание и установка способа передачи (доминирует над установкой ATF1).
AT%F1 | 300 бит/с (@stand[V.21]), фиксированная скорость
AT%F2 | 1200 бит/с (@stand[V.22]), фиксированная скорость
AT%F3 | 2400 бит/с (@stand[V.22bis]), фиксированная скорость
AT%F4 | 2400/1200 бит/с (V.22bis)
AT%F5 | 4800 бит/с (@stand[V.32]), фиксированная скорость
AT%F6 | 9600 бит/с (V.32), фиксированная скорость
AT%F7 | 9600/4800 бит/с (V.32), фиксированная скорость

AT%Hn - Вариант выбора режима

Команда определяет тип последовательности вхождения в связь для определения режима, используемой во время установления соединения.
AT%H0 | Специальная для определенного типа модема последовательность определения режима. Тип последовательности вхождения в связь определяют команды ATFn и ATBn
AT%H1 | Последовательность обнаружения режима в соответствии с МККТТ. Тип последовательности вхождения в связь определяет команда АТ%Sn
AT%H3 | Фирменная (компании Octocom) последовательность определения режима. Универсальная последовательность автоматического определения режима (multi-mode autodetect), производится выбор одного из следующих режимов: V.32, V.22bis, V.23, V.21, Bell 212A, Bell 103

AT%Mn - Выбор одно- или двунаправленного режима (BLTZ)

Управляет вариантами сжатия протокола BLTZ.

AT%M0 Сжатие по протоколу BLTZ запрещено.
AT%M1 Разрешено кодирование по протоколу BLTZ только для канала передачи вызывающего модема
AT%M2 Разрешено кодирование по протоколу BLTZ только для канала приема вызывающего модема
AT%M3 Разрешено двунаправленное сжатие по протоколу BLTZ

В случае выбора однонаправленного режима местный и удаленный модемы должны быть согласованно сконфигурированы, т.е., оба должны быть установлены в режим вызова с однонаправленной передачей или в режим вызова с однонаправленным приемом. Если регистр S95 установлен на разрешение отображения сообщений о сжатии, к сообщению "COMPRESSION:V42BIS", отображаемому на передающем (кодирующем) окончании должно добавляться "/Т", а на приемном (декодирующем) окончании должно добавляться "/R".

AT%On - Переход на арендованный канал из режима работы по коммутируемому каналу

Команда вызывает попытку модема, работающего в резервном режиме по коммутируемому каналу, вернуться на работу по арендованному каналу. В качестве возможных вариантов пользователь может выбрать безусловный переход на коммутируемый канал или переход после установления факта нормального функционирования арендованного канала. Если модем не работает в режиме резервирования, при вводе данной команды выводится сообщение об ошибке. Конфигурация модема, используемая при работе по арендованному каналу хранится в профиле 0 памяти, определяемой пользователем; конфигурация, используемая в резервном режиме, всегда хранится в профиле 4, а телефонный номер - в области 0 телефонного справочника.
AT%O0 | Вызывает возврат на арендованный канал, безусловное прерывание соединения по коммутируемому каналу.
AT%O1 | Вызывает возврат на арендованный канал, но соединение по коммутируемому каналу сохраняется, пока не подтверждено, что модем установил соединение по арендованному каналу.

AT%R - Отображение содержимого регистров S

Позволяет вывести на экран содержимое регистров S в шестнадцатиричном и десятичном форматах. Значения для неиспользуемых регистров равны "0".

AT%Sn - Установка максимальной длины строки (BTLZ)

Производится выбор максимального количества знаков, которые могут быть сжаты в одно кодовое слово. Параметр n может принимать значения от 6 до 250.

AT%U - Сброс скорости последовательного порта

Эта команда подготавливает последовательный порт к изменению скорости в бит/с со значения 4800 бит/с или более на любое другое значение. Данную команду следует использовать для изменения скорости последовательного порта, когда он работает на скорости 4800 бит/с или выше. После этого необходимо изменить скорость в связной программе. После команды AT%U не следует вводить других команд; введение другой команды AT отменяет команду AT%U. Пока последовательный порт установлен на скорость 4800 бит/с или выше, модем не распознает команды, передаваемые на скоростях, отличающихся от текущей скорости (4800 бит/с или выше).

Примечание: Не требуется вводить команду AT%U, когда регулировка скорости в бит/с вызывает изменение скорости последовательного порта во время соединения.

AT%V - Отображение версии фирменного программного обеспечения

Отображает номер версии программного обеспечения модема. Эквивалентна команнде ATI3.

AT-Pn - Контроль паритета

AT-P0: Модем игнорирует паритет специальных знаков
AT-P1: Cпециальные знаки обрабатываются только в случае их правильного паритета


:: Электронное пособие

Электронное пособие > АТ команды > Надежный режим
АТ команды

» Надежный режим

В надежном режиме организуется канал передачи данных с обнаружением ошибок и автоматическим переспросом данных в случае обнаружения ошибок с помощью протоколов LAPM или MNP, класс 4. Это обеспечивает безошибочную передачу данных между местным и удаленным терминалами.

В этом режиме (AT\N2) модем использует управление потоком в своем последовательном порте. Когда модем обнаруживает ошибку, он удерживает данные от последовательного порта в своем буфере на время коррекции ошибки передачи.

Работа надежного канала является прозрачной, для его использования не требуется дополнительных аппаратных средств или дополнительной программы. Единственным требованием является, чтобы и местная и удаленная системы имели возможность работы в режиме надежного канала и поддерживали управление потоком (AT\Qn).

Так как надежный канал обеспечивает безошибочную передачу в то время, как нормальный канал допускает появление ошибок, следует использовать надежный канал во всех случаях, когда удаленная система поддерживает его. При использовании протоколов исправления ошибок модем оказывается селективным по отношению к типу системы, с которой он взаимодействует. Непосредственно после установления соединения модем делает попытку организации надежного канала. Если эта попытка не удается, модем прекращает соединение. Могут быть следующие причины неудачи в организации надежного канала:

удаленная система не имеет возможности организации надежного канала;
удаленная система имеет возможность организации надежного канала , но не использует ее;
телефонный канал так неустойчив и зашумлен, что даже надежный канал не может обеспечит удовлетворительной связи.


:: Электронное пособие

Электронное пособие > Общие сведения > Функции проверки модемов и канала связи
Общие сведения

» Функции проверки модемов и канала связи

Практически все модемы обеспечивают возможность включения местных аналогового и цифрового, а также удаленного цифрового испытательных шлейфов (в соответствии с Рекомендациям МККТТ V.51 и V.54), и, кроме того - возможность самопроверки модема в испытательных шлейфах (передача и прием испытательной последовательности, сравнение на приеме принятой комбинации с эталонной последовательностью, отображение количества возникающих ошибок).


:: Электронное пособие

Электронное пособие > АТ команды > Проверка модема и канала связи
АТ команды

» Проверка модема и канала связи

Проверка модема и канала связи производится с использованием команд AT&Tn (Команды тестовых режимов).

Включение местного аналогового шлейфа.
Bключение местного аналогового шлейфа L3 (аналоговый выход передатчика соединяется со входом приемника) производится с помощью команды AT&T1. После выполнения этой команды любые введенные с терминала знаки возвращаются модемом после прохождения по приемопередающему тракту модема. Возможно включение местного аналогового шлейфа в режиме работы по линии без разрушения соединения. При этом предварительно необходимо передать модему команду перехода "+++" и после получения ответа модема "ОК" ввести команду АТ&Т.

Включение местного аналогового шлейфа с самопроверкой.
Включение местного аналогового шлейфа с самопроверкой модема осуществляется командой AT&T8. В этом режиме на передаче включается генератор тестовой комбинации, а на приеме - устройство контроля верности принятой комбинации и счетчик ошибок. Путем установки счетчика интервала тестирования (регистр S18) задается длительность сеанса тестирования, после истечения которой проверка автоматически прекращается. Если значение в регистре S18 равно 0, длительность сеанса задается вручную, и для прекращения проверки необходимо ввести команду AT&T0. После окончания проверки модем выводит количество зарегистрированных ошибок и ответ "ОК".

Включение дистанционного цифрового шлейфа.
Для включения дистанционного цифрового шлейфа L2 (цифровой выход приемника удаленного модема соединен с цифровым входом его передатчика) используется команда AT&T6. При этом предварительно должно быть установлено соединение между модемами.

Удаленный модем отвечает соответствующими действиями на команду включения удаленного цифрового шлейфа от местного модема, если ему была передана предварительно от своего терминала команда разрешения ответа на этот вид проверки AT&T4. Если предварительно удаленному модему от своего терминала была передана команда запрета ответа на запрос удаленного цифрового шлейфа АТ&Т5, то включение удаленного цифрового шлейфа не происходит.

Включение дистанционного цифрового шлейфа с самопроверкой.
Возможно включение удаленного цифрового шлейфа с самопроверкой местного и удаленного модемов и канала связи. В этом виде проверки, включаемом командой АТ&Т7, также, как и в режиме местного аналогового шлейфа, в местном модеме включаются генератор проверочной комбинации и устройство контроля верности принятой комбинации и счетчик ошибок. Длительность сеанса проверки и отображение ошибок производятся также, как и в режиме местного цифрового шлейфа.

Включение местного цифрового шлейфа.
Некоторые типы ранее выпущенных модемов не имеют возможности иницировать установление проверки в режиме удаленного цифрового шлейфа. Для создания такой возможности в современных модемах имеется проверочный режим местного цифрового шлейфа, включаемый командой АТ&Т3. После передачи этой команды цифровой выход приемника местного модема соединяется с цифровым входом его передатчика. Установление этог режима требует предварительной договоренности между местным и удаленным терминалами, так как установление шлейфа производится местным модемом, а проверка качества соединения - удаленным модемом.

Прекращение проверок модема и канала связи.
Прекращение всех проверок происходит автоматически, если в регистр S18 записана ненулевая величина, по истечении интервала времени, задаваемого этой величиной, либо вручную - с помощью команды AT&T0.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.8
Протоколы

» Рекомендация V.8

Определяет процедуру обмена сигналами взаимодействия между модемами и начало сеанса передачи данных. При этом происходит определения типа модуляции, который будут использовать модемы (V.34, V.32, V.32bis, V.22, V.21 и т.д.), дуплексный или полудуплексный обмен, вызывной тон, защита от ошибок (V.42 или др.).


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.17
Протоколы

» Рекомендация V.17

Полудуплексный факсимильный модем со скоростями передачи до 14400 бит/c (допускаются скорости 12000, 9600 или 7200 бит/c) для использования в коммутируемых телефонных сетях общего пользования. На скорости 14400 бит/с используется 128-кратная относительная амплитудно-фазовая модуляция с помехоустойчивым кодированием в режиме исправления ошибок. Перед началом работы модемы обмениваются настроечными сообщениями на скорости 4800 бит/с.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.21
Протоколы

» Рекомендация V.21

Дуплексный модем со скоростью передачи данных 300 бит/с, предназначенный для использования в коммутируемых телефонных сетях общего пользования, также может быть использован на арендованных линиях.

Модуляция двоичных данных осуществляется путем изменения частоты сигнала, в результате чего скорость модуляции будет равна скорости передачи данных. Данные могут передаваться в синхронном либо асинхронном режиме. Максимальная выходная мощность модема, поступающая в линию, не должна превышать 1 мВт.

Уровень мощности сигнала модема должен быть приведен в соответствие с допустимым, при условии потери мощности при прохождении сигнала между ним и точкой подключения к международным сетям так, чтобы соответствовать номинальному уровню сигнала для входа в международную сеть и не должен превышать -13 дБ. Все цепи сопряжения модема с ООД должны подчиняться функциональным и прочим требованиям Рекомендации V.24. Уровень принимаемого из линии сигнала на входах модема для всех типов соединений, т. е. Для коммутируемых телефонных сетей общего пользования или некоммутируемых арендованных телефонных линий:

более чем -43 дБ цепь 109 в состоянии ВКЛ;
менее чем -48 дБ цепь 109 в состоянии ВЫКЛ.

Состояние цепи 109 для уровней между -43 дБ и -48 дБ является неопределенным, кроме того, детектор сигнала может обладать свойством гистерезиса, так что изменение ВЫКЛ во ВКЛ будет происходить при сигнале не менее чем на 2 дБ больше, чем для изменения из ВКЛ в ВЫКЛ. На коммутируемых или арендованных линиях, где условия передачи известны, можно допустить при установке модема изменение уровней детектора принимаемого из линии сигнала данных на меньшую чувствительность (например, на -33 дБ и -38 дБ соответственно).


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.22
Протоколы

» Рекомендация V.22

Дуплексный модем со скоростью передачи данных 1200 бит/с предназначен в коммутируемых каналах общего пользования и на 2-точечных 2-проводных арендованных линиях телефонного типа.

Модем имеет следующие основные характеристики:

дуплексный режим работы на 2-проводных ТФОП и 2-точечных арендованных линиях;
разделение каналов частотным путем;
дифференциальная фазовая манипуляция для каждого из каналов с синхронной передачей в линии на номинальной скорости 600 Бод;
включение скремблера;
для включение возможностей проверки.

Скорость передачи данных в линию составляет 1200 бит/с или 600 бит/с +/- 0,01% при скорости модуляции, равной 600 Бод +/- 0,01%.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.22bis
Протоколы

» Рекомендация V.22bis

Дуплексный модем на скорость 2400 бис/с с применением метода частного разделения, стандартизированный для использования на коммутируемой телефонной сети общего пользования и 2-точечных 2-проводных арендованных каналах телефонного типа.

Стандартизирован модем для дуплексной работы со скоростью 2400 или 1200 бит/с по 2-проводному телефонному каналу (коммутируемому или арендованному). Каналы передачи данных для двух направлений связи разделяются по частоте. Несущая частота в нижнем канале равна 1200 Гц, в верхнем - 2400 Гц. При скорости 2400 бит/с в каждом канале применена относительная амплитудно-фазовая модуляция с 16 состояниями сигнала и со скоростью модуляции 600 Бод. При скорости 1200 бит/с применена относительная 4-фазная модуляция. Модем имеет 4 режима работы:

2400 бит/с, синхронно;
2400 бит/с, стартстопно, 8, 9, 10 или 11 битов в знаке;
1200 бит/с, синхронно;
1200 бит/с, стартстопно, 8, 9, 10 или 11 битов в знаке.

В состав модема включается адаптивный автоматический корректор, рассчитанный на выравнивание усредненной частотной характеристики коммутируемого канала. Включается также скремблер для обеспечения "прозрачности" организуемого дискретного канала. Для предотвращения ложных срабатываний приемников телефонной сигнализации в модеме предусмотрена передача защитного тона 1800 Гц (допускается 550 Гц). Стык модема с ООД содержит около 15 цепей, в том числе цепи синхронизации. Электрические характеристики цепей стыка должны соответствовать Рекомендации V.28, а распределение контактов в разъеме - стандарту ISO 2110. Модем V.22bis в режимах 3 и 4 (на скорости 1200 бит/с) может работать совместно с модемом V.22. Переход на скорость 1200 бит/с осуществляется путем автоматического распознавания скорости во время процедуры вхождения в связь.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.23
Протоколы

» Рекомендация V.23

Стандартизируется модем для полудуплексной работы со скоростями 600 или 1200 бит/с по телефонной коммутируемой сети общего пользования с использованием частотной модуляции. Предусматривается передача данных синхронная или асинхронная с организацией асинхронного обратного канала со скоростью 75 бит/с. Разделение прямого и обратного каналов осуществляется по частоте.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.24
Протоколы

» Рекомендация V. 24

Перечень определений цепей стыка между оконечным оборудованием данных (ООД) и аппаратурой окончания канала данных (АКД). Приведен список рекомендованных цепей стыка между АКД и ООД, который содержит:

цепи стыка серии 100 (цепи общего назначения);
серии 200 (цепи для управления при параллельном автоматическом вызове).

Цепи серии 100 включают в себя 43 цепи различного назначения, служащие как для передачи сигналов данных, так и для осуществления ряда служебных функций. Они используются также для программирования АКД и управления при последовательном автоматическом вызове. Основными цепями серии 100 являются:

102 | сигнальная земля или общий обратный провод.
103 | передаваемые данные (из ООД в АКД).
104 | принимаемые данные (из АКД в ООД).
105 | запрос передачи (от ООД к АКД).
106 | готов к передаче (от АКД к ООД).
107 | аппаратура передачи данных готова (от АКД к ООД).
108.1 | подключить аппаратуру передачи данных к линии.
108.2 | оконечное оборудование данных готово (от ООД к АКД).
109 | детектор принимаемого линейного сигнала канала данных (от АКД к ООД).
114 | синхронизация элементов передаваемого сигнала (от AКД к ООД).
118 | передаваемые данные обратного канала (от ООД к АКД).
119 | принимаемые данные обратного канала (от АКД к ООД).
125 | индикатор вызова (от АКД к ООД).
141 | местный шлейф (от ООД к АКД).
142 | индикатор испытания (от АКД к ООД).

Цепи серии 200 включают в себя 12 цепей, используемых во время параллельного автоматического вызова, в том числе:

202 | запрос вызова (от ООД к АКД).
203 | линия данных занята (от АКД к ООД).
204 | дальняя установка подключена (от АКД к ООД).
206 207 208 209 | цифровой сигнал (от ООД к АКД).
210 | запрос следующей цифры (от АКД к ООД).

Определяются функции каждой цепи и взаимосвязь между ними. Для конкретной аппаратуры в соответствии с потребностями может быть произведен выбор цепей из общего списка.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.25
Протоколы

» Рекомендация V. 25

Устройство автоматического ответа и/или устройство автоматического параллельного вызова для коммутируемой телефонной сети общего пользования, а также нейтрализация устройств управления эхом при ручных и автоматических вызовах.

Определены принципы построения устройства параллельного автоматического вызова, включаемого в состав АКД в тех случаях, когда управление вызовом (в том числе набор номера) производится не вручную, а автоматически под управлением ООД. Для параллельного автоматического вызова используются цепи стыка серии 200. Описываются рекомендуемые процедуры на стыке ООД-АКД в вызывающей и вызываемой оконечных установках данных. Описываются также процедуры в телефонном канале во время установления соединения. После набора номера вызывающая АКД посылает в телефонный канал прерываемый вызывной тон (1300 Гц или другую частоту, соответствующую двоичной 1, в применяемой АКД). Вызываемая АКД посылает ответный тон 2100 Гц. Посылаемый в канал сигнал 2100 Гц обеспечивает нейтрализацию эхозаградителей или других устройств управления эхо, которые могут содержаться в коммутируемой телефонной сети в канале большой протяженности.

Обычный телефонный абонент, случайно подсоединенный к автоматически вызывающей или автоматически отвечающей установке, будет получать тональные сигналы в течение достаточно длительного времени, чтобы определенно убедиться в неверном соединении.


:: Электронное пособие

Электронное пособие > АТ команды > Перевод модема в режим управления командами набора V.25bis
АТ команды

» Перевод модема в режим управления командами набора Рекомендации V.25bis

Во многих типах модемов, преимущественно европейских изготовителей, реализованы оба рассматриваемых набора команд управления. При включении питания модема для работы по умолчанию обычно выбирается один из наборов команд. Для перехода в режим управления с использованием команд набора Рекомендации V.25bis в набор команд АТ модема вводится соответствующая команда. После ее передачи от терминала модему последний должен ответить сообщением VAL, что свидетельствует о переходе в режим управления командами набора Рекомендации V.25bis.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.25bis
Протоколы

» Рекомендация V. 25bis

Стандартизируются принципы построения вызова, при котором все процедуры осуществляются только по цепям стыка серии 100, без использования цепей серии 200. Описываются процедуры на стыке ООД-АКД в вызывающей и вызываемой установках, а также в телефонном канале во время установления соединения. Предусматривается, что АКД V.25bis обязательно должна иметь возможность взаимодействовать с АКД V.25.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.26
Протоколы

» Рекомендация V. 26

Стандартизирован модем для дуплексной работы со скоростью 2400 бит/с по 4-проводным арендованным каналам тональной частоты. Используется относительная 4-фазная модуляция. Поток данных, подлежащих передаче, разделяется на пары битов (дибиты). В зависимости от вида дибита изменяется фаза линейного сигнала; изменения производятся со скоростью модуляции 1200 Бод. Предусмотрена возможность организации узкополосного канала на скорость 75 бит/с. Особенностью модема является то, что он предназначен для работы по каналам, удовлетворяющим Рек. М. 1020 (т. е. по каналам особого качества). Стык модема с ООД содержит около 15 цепей, в том числе цепи синхронизации. Электрические характеристики цепей стыка должны соответствовать Рек. V. 28, а распределение контактов в разъеме - стандарту ISO 2110.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.26bis
Протоколы

» Рекомендация V.26bis

Стандартизирован модем для полудуплексной работы со скоростью 2400 или 1200 бит/с по 2-проводным каналам коммутируемой телефонной сети. Принципы построения модема базируются на положениях рекомендации V. 26. Отличие заключается в добавлении уменьшенной скорости 1200 бит/с, на которую можно перейти, если не обеспечивается работа на скорости 2400 бит/с. Указывается, что нормальная работа на скорости 2400 бит/с не может быть гарантирована по каждому соединению или направлению. Рекомендуется проводить испытания до принятия решения об организации конкретной системы передачи данных, работающей по коммутируемой телефонной сети со скоростью 2400 бит/с.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.26ter
Протоколы

» Рекомендация V. 26ter

Дуплексный модем на 2400 бит/с с методом эхокомпенсации, стандартизированный для использования на коммутируемой телефонной сети общего пользования и 2-точечных 2-проводных арендованных каналах телефонною типа.

Стандартизирован модем для дуплексной работы со скоростью 2400 или 1200 бит/с по 2-проводному телефонному каналу (коммутированному или арендованному). В отличие от модема V.22 здесь каналы передачи данных для двух направлений работают на одинаковой несущей частоте 1800 Гц и разделяются методом эхокомпенсации. Применены относительная 4-фазная (на скорости 2400 бит/с) и 2-фазная (на скорости 1200 бит/с) модуляции. Модем имеет 4 режима работы:

2400 бит/с, синхронно;
2400 бит/с, стартстоппо, 8, 9, 10 или 11 битов в знаке;
1200 бит/с, синхронно;
1200 бит/с, стартстопно, 8, 9, 10 или 11 битов в знаке.

В состав модема включается скремблер и корректор (адаптивный автоматический или компромиссно фиксированный). Стык модема с ООД содержит около 15 цепей, в том числе цепи синхронизации. Электрические характеристики цепей стыка должны соответствовать Рек. V.28, а распределение контактов в разъеме - стандарту ISO 2110. Отмечается, что в некоторых странах использование таких модемов на коммутируемой телефонной сети может не разрешаться.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.27
Протоколы

» Рекомендация V. 27

Модем стандартизирован для дуплексной работы со скоростью 4800 бит/с по 4-проводному арендованному каналу тональной частоты. Может использоваться канал особого или обычного качества. В модеме применена относительная 8-фазная модуляция, при которой фаза сигнала изменяется со скоростью фазовой модуляции 600 Бод в зависимости от вида последовательности из трех битов (трибитов). В состав модема должен входить регулируемый вручную корректор, способный компенсировать искажения частотных характеристик канала. Возможно введение узкополосного обратного канала на скорость до 75 бит/с. Этот канал может использоваться, например, для передачи запросов на повторение блоков данных, принятых с ошибками. Стык модема с ООД содержит около 15 цепей, в том числе цепи синхронизации. Электрические характеристики цепей стыка должны соответствовать Рек. V.28, а распределение контактов в разъеме - стандарту ISO 2110.

В модеме содержится скремблер/дескремблер. В скремблере (передающей части модема) передаваемый сигнал умножается на квазислучайный сигнал, генерируемый с помощью образующего полинома х^7 + х^6 + 1. В дескремблере (приемной части модема) производится обратная операция, после чего сигнал приобретает первоначальную форму. Благодаря этому сигнал в канале связи будет всегда содержать в себе тактовую частоту и будет иметь более равномерный спектр. Это повышает устойчивость работы модема и обеспечивает "прозрачность" организуемого дискретного канала.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.28
Протоколы

» Рекмендация V. 28

Электрические характеристики несимметричных цепей стыка, работающих 2-полюсным током.

Нормируются характеристики 2-полюсных цепей стыка между ООД и АКД, работающих со скоростями не выше 20000 бит/с. Рекомендация V.28 предназначена для использования в аппаратуре на транзисторных схемах. Значения электрических характеристик этой схемы приведены. Максимальное напряжение в цепи не должно превышать +/-25 В. В цепях передачи данных позиция 1 должна соответствовать напряжению на стыке не менее -3 В, в позиции 0 - напряжению более +3 В. В управляющих цепях эти сигналы соответствуют позициям РАЗОМКНУТО и ЗАМКНУТО.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.29
Протоколы

» Рекомендация V. 29

Стандартизирован модем для дуплексной работы со скоростью передачи данных 9600 бит/с по 4-проводным арендованным каналам тональной частоты, удовлетворяющим Рек. М. 1020 или М. 1025 (рекомендации о характеристиках каналов особого качества). Предусмотрена возможность снижения скорости до 7200 или 4800 бит/с. При скорости 9600 бит/с применяется относительная амплитудная модуляция с 16 состояниями сигнала. При скорости 7200 бит/с используется лишь 8 состояний сигнала. При скорости 4800 бит/с используется 4-фазная модуляция. Скорость модуляции линейного сигнала при всех скоростях передачи данных составляет 2400 Бод. В состав модема входят адаптивный автоматический корректор, а также скремблер. Может входить также мультиплексор для разделения общего потока (например, со скоростью 9600 бит/с) на несколько подканалов с меньшими скоростями (например, 2400 и 4800 бит/с). Стык модема с ООД содержит около 15 цепей, в том числе цепи синхронизации. Электрические характеристики цепей стыка должны соответствовать Рек. V.28, а распределение контактов в разъеме - стандарту ISO 2110.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.32
Протоколы

» Рекомендация V. 32

Стандартизируются модемы для дуплексной работы со скоростями 9600 или 4800 бит/с по 2-проводному телефонному каналу (коммутируемому или арендованному). Предусматривается работа со скоростью 2400 бит/с. Каналы передачи и приема разделяются методом эхокомпенсации и поэтому работают на одинаковой несущей частоте 1800 Гц. При скорости 9500 бит/с используется 16 или 32-кратная амплитудно-фазовая модуляция. При 32-кратной модуляции предусматривается помехоустойчивое кодирование для повышения достоверности. В модеме предусматриваются адаптивный корректор и скремблер. Перед началом работы модемы должны обмениваться настроечными последовательностями для согласования скорости передачи и других параметров, а также настройки адаптивных корректоров и эхокомпенсаторов.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.32bis
Протоколы

» Рекомендация V. 32bis

Стандартизируется дуплексный модем для работы со скоростями 14400, 12000, 9600, 7200 или 4800 бит/с по 2-проводному телефонному каналу (коммутируемому или арендованному). Каналы передачи и приема разделяются методом эхокомпенсации и работают на частоте 1800 Гц. Используется 128-кратная амплитудно-фазовая модуляция с использованием помехоустойчивого кодирования. Предусматривается обмен настроечными последовательностями на скорости 4800 бит/с, а также возможность взаимодействия с модемом V.32 на скоростях 9600 и 4800 бит/с. Кроме того, такой модем может иметь возможность работать с модемами V.22 и V.22bis (с разделением направлений передачи и приема по частоте).


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.32ter
Протоколы

» Рекомендация V. 32ter

Стандартизируется дуплексный модем для работы со скоростями от 4800 до 19200 бит/с для работы по КСОП. Может предусматриваться расширенный протокол, обеспечивающий скорость до 21600 бит/с (V.32terbo).


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.33
Протоколы

» Рекомендация V. 33

Стандартизируется дуплексный модем для работы со скоростями 1200, 2400, 4800, 7200, 9600, 12000, 14400 бит/с по 4-проводным арендованным каналам. Предусматривается возможность использования мультиплексора.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.34
Протоколы

» Рекомендация V.34

PSTN была разработана для голосовых коммуникаций (см. Рисунок ). Искусственно ограничивая звуковой спектр только теми частотами, которые относятся к человеческой речи, сетевые инженеры обнаружили, что они могут сузить необходимую для каждого звонка полосу пропускания, увеличив за счет этого количество возможных одновременных звонков. И хотя это ограничение хорошо работает для голоса, оно накладывает ограничения на передачу данных.

Модемы V.34 оптимизированы для ситуаций, в которых оба конца подключены к PSTN аналоговыми линиями. И хотя большая часть сети цифровая, модемы V.34 рассматривают ее, как если бы она была полностью аналоговой. Модемы V.34 невероятно устойчивы, но они не могут воспринять всю полосу пропускания, которая становится доступной в том случае, если один из концов соединения будет полностью цифровым. Стандарт V.34 был построен на предположении, что оба конца соединения несут ущерб от шума квантования, появляющегося вследствие использования аналого-цифровых преобразователей (analog-to-digital converters - ADC).

Рисунок1. Анатомия соединения V.34

Отношение сигнала к шуму

Отношение сигнал/ шум (signal-to-noise ratio - SNR) является мерой эффективности соединения и представляет результат деления мощности сигналя на мощность шума. Чем выше это отношение, тем чище соединение, и тем больше количество данных, которые можно по нему передать. В тех случаях, когда сигнал подвергается аналого-цифровому преобразованию, даже при самых лучших условиях отношение сигнал/шум ("порог шума") порядка от 38 до 39 децибел, что ограничивает практические скорости передачи по V.34 33.6 Кбит/с.

Асимметричное функционирование: каналы по направлению основного трафика и против него

Соединения V.90 используют один двунаправленный канал: по направлению основного трафика и против него. Канал аналогового модема V.90, работающий по основному направлению трафика (прием данных), способен работать с более высокими скоростями, так как в этом случае отсутствует потеря информации при цифро-аналоговом преобразовании. Работающий же против основного направления трафика (посылка данных) канал аналогового модема V.90 вынужден использовать аналого-цифровое преобразование, что ограничивает скорость передачи до скоростей протокола V.34.

Чтобы аналоговую информацию можно было пересылать по PSTN, она должна быть преобразована в двоичные цифры. Значения амплитуд входящего аналогового сигнала измеряются 8000 раз в секунду, и каждая амплитуда записывается как код модулирования импульсного кода (pulse code modulation - PCM). Система дискретизации использует 256 дискретных 8-битных кодов PCM.

Поскольку аналоговые сигналы непрерывны, а двоичные цифры дискретны, цифры, которые посылаются по PSTN и реконструируются на другом конце соединения, могут только приблизительно представлять исходный аналоговый сигнал. Различия между исходным сигналом и реконструированным квантованным (оцифрованным) сигналом называются шумом квантования и этот шум ограничивает скорость модема.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.41
Протоколы

» Рекомендация V. 41

Стандартизируется защита от ошибок с использованием решающей обратной связи с циклическим кодом в режиме обнаружения ошибок с образующим полиномом 16-й степени. Длина блока может составлять 260, 500, 960, 3860 бит, из которых 16 проверочные и 4 служебные, а остальные информационные.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.42
Протоколы

» Рекомендация V. 42

МККТТ в качестве стандарта на защиту от ошибок в модемах приняла в Рек. V.42 протокол LAPM (Line Access Protocol for Modems). Это объясняется совместимостью протокола LAPM с другими ранее принятыми МККТТ протоколами для цифровых сетей с пакетной коммутацией X.25 (протокол LAPВ) и для цифровых сетей интегрального обслуживания (протокол LAPD). В то же время эффективность протоколов LAPM и MNP, класс 4 примерно одинакова. Последний протокол помещен в качестве альтернативного в приложении к Рек. V.42.

В последние годы протоколы LAPM вместе с MNP стали широко вводиться практически во все выпускаемые модемы.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.42bis
Протоколы

» Рекомендация V. 42bis

Сжатие данных наряду с защитой от ошибок является той функцией, введение которой в модемы позволило значительно повысить их эффективность и тем самым продлить существование модемов на этапе перехода к полностью цифровым сетям. В то время как протокол MNP (класс 5) стал фактическим промышленным стандартом на сжатие данных в модемах, МККТТ (МГЭ-Т) в качестве Рек. V.42bis принял метод сжатия данных BTLZ (British Telecom Lempel-Ziv), разработанный компанией British Telecom.

Выбор указанного метода был сделан на основании сравнительного анализа результатов испытательной передачи определенннх файлов с использовянием 5 различных методов сжатия: MNP, классы 5 и 7, фирмы Microcom (CITTAt: CommPre-ssor, фирмы Adaptive Computer Technolnpies (США); модифицированный алгоритм Lempel-Ziv (BTLZ), компании British Telecommunication PLC (Великобритания). Испытательные последовательности включали: текстовые файлы; электронные таблицы; записи сессий электронной почты; файлы программ для ЭВМ. На основании полученных результатов был сделан вывод, что метод BLTZ обеспечивает высокую степень сжатия и более эффективное использование памяти и ресурсов процессора.

Первым отличием алгоритма BTLZ от других алгоритмов является способ организации справочника, в котором хранятся более короткие коды, используемые для передачи вместо повторяющихся длинных отрезков данных. При других алгоритмах справочник заранее определен и хранится в ПЗУ, алгоритм ВTLZ динамически формирует идентичные справочники на передаюшей и приемной сторонах, и последние хранятся в ОЗУ. Поэтому достигаемая степень сжатия при этом тем больше, чем больший объем памяти занят справочником,в то время как степень сжатия при других алгоритмах ограничена фиксированным объемом справочника.

Другим преимуществом протокола BTLZ является его способность распознавать наличие последовательностей данных, близких к случайным. При обнаружении таких последовательностей алгоритм выключает механизм сжатия, продолжает контроль и включает этот механизм при пропадании случайного характера последовательности данных. Другие рассмотренные протоколы в такой ситуации снижают пропускную способность до величины меньшей, чем даже номинальная скорость модема.

При сжатии текстов с помощью протокола BTLZ могут быть получены коэффициенты сжатия до 3, а для более регулярных данных, таких как файлы электронных таблиц и некоторые графические файлы коэффициент сжатия может достигать 4.

Данный метод сильно чувствителен к ошибкам в потоке данных, которые приводят к изменению передающего и приемного справочников, поэтому он должен использоваться в сочетании с исправлением ошибок; по этой причине он введен как Рек. V.42bis (добавление к Рек. V.42).


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.44
Протоколы

» Рекомендация V.44

V.44 - это новый компрессионный стандарт, разработанный Hughes Network System, для замены V.42bis. Более высокий уровень компрессии позволяет "скачивать" информацию из Интернета на 20-60% быстрее. Преимущества работы по этому протоколу наиболее ощутимы при просмотре веб-страниц, так как HTML-файлы особенно хорошо поддаются коспрессии.

Алгоритм сжатия, используемый V.44, наилучшим образом подходит к сетям с пакетным обменом и широко используется в спутниковых сетях HNS. Алгоритм был рассмотрен американскими и международными центрами стандартизации и был принят в качестве нового стандандарта сжатия данных.

Основные отличия от V.42bis.

1. Более высокая эффективность сжатия различных типов данных, в т.ч. тех, для которых сжатие по протоколу V.42bis не было эффективным.

2. Большая гибкость в организации словарей сжатия и управления ими, внутренние структуры словарей у передатчика и приемника различны.

3. Ассиметричность словарей сжатия в направлении приема и передачи (например, возможно создание словаря большего размера в предпочтительном направлении за счет уменьшения размера словаря обратнрго направления), что позволяет более эффективно использовать оперативную память модема.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.90
Протоколы

» Рекомендация V.90

Шум квантования ограничивает скорость коммуникационного канала V.34 примерно до 35 Кбит/с. Но шум квантования влияет только на аналого-цифровые преобразования, а не на цифро-аналоговые. Этот факт служит основой стандарта V.90: если между цифровым модемом V.90 и PSTN отсутствуют аналого-цифровые преобразования, и если этот подключенный цифровым образом передатчик (трансмиттер) использует только 255 уровней дискретного сигнала, которые доступны в цифровой части телефонной сети, то именно эта неискаженная цифровая информация поступает на приемник (ресивер) аналогового модема, и при этом не происходит потери информации в процессах преобразования.

На Рисунке показано, как работает этот процесс:
  1. Сервер цифровым, по сути дела, образом подключается к магистрали телефонной компании.
  2. Сигналы сервера таковы, что в процессе кодирования используются только те 256 кодов PCM, которые используются в цифровой части телефонной сети. Другими словами, отсутствует шум квантования, связанный с преобразованием сигналов аналогового типа в дискретные коды PCM.
  3. Эти коды PCM преобразуются в соответствующие дискретные аналоговые напряжения и посылаются на аналоговый модем по цепи с аналоговой петлей (analog loop circuit) без потери информации.
  4. Ресивер клиентской стороны реконструирует дискретные сетевые коды PCM принятых им аналоговых сигналов, декодируя то, что послано трансмиттером.

С цифрового модема V.90 данные в PSTN посылаются как двоичные цифры. Но чтобы соответствовать приведенным выше условиям шага 2, цифровой модем V.90 передает данные (8 бит в одной посылке) на клиентский ADC с той же скоростью, что и телефонная сеть (8000 Гц). Это означает, что частота символов модема должна быть равна частоте дискретизации телефонной сети.

Рисунок. Соединение V.90 1. Аналоговый модем V.90 2. Цифровой модем V.90

Модемные соединения V.90

Во время настроечной последовательности сигналов, модем V.90 изучает линию, чтобы определить, имеют ли место аналого-цифровые преобразования по основному направлению трафика. Если такие преобразования обнаружены, модемы V.90 соединяются по V.34. Аналоговый модем V.90 предпринимает попытку соединиться по V.34 и в тех случаях, когда удаленный модем не поддерживает V.90.

Задача аналогового модема V.90 состоит в различении 256 возможных значений напряжения, чтобы успеть восстановить 8000 кодов PCM за одну секунду. Если модему удается справиться с этой задачей, скорость загрузки будет близка к 64 Кбит/с (8000 х 8 бит/код). Однако оказывается, что есть несколько проблем, которые замедляют скорости.

Во-первых, хотя проблема с порогом шума при квантовании и устранена, возникает другой, гораздо более низкий порог шума, налагаемого сетевым оборудованием цифро-аналогового преобразователя (digit-to-analog converter - DAC) и локальной петлей (local loop service) в местах расположения клиентов. Этот шум возникает из-за различных нелинейных искажений и сетевых перекрестных помех (crosstalk).

Во-вторых, сетевые цифро-аналоговые преобразователи не являются линейными преобразователями, а работают по определенному правилу преобразования. В результате, сетевые коды PCM, представляющие малые значения напряжения, продуцируют очень малые шаги выходного напряжения цифро-аналогового преобразователя, в то время как коды, представляющие большие значения напряжения, продуцируют большие шаги напряжения.

Эти две проблемы делают невозможным использование всех 256 дискретных кодов, поскольку соответствующие уровни выходного напряжения DAC вблизи нуля слишком близки друг к другу, чтобы точно представлять данные в зашумленной петле. (Примечание: Каждый сетевой код PCM соответствует уровню напряжения DAC). Поэтому кодировщик V.90 использует различные подмножества 256 кодов, которые устраняют выходные сигналы DAC, наиболее чувствительные к шуму. Например, наиболее надежные 128 уровней используются для 56 Кбит/с, 92 уровня используются для посылки 52 Кбит/с и так далее. Использование меньшего числа уровней обеспечивает более надежное функционирование, хотя и при меньшей скорости передачи данных.

Требования V.90

Для передачи с полной скоростью (56 Кбит/с) необходимо выполнение следующих трех условий:

  1. Цифровой на одном из концов. Большинство провайдеров услуг имеют сегодня цифровое подключение к PSTN. Конец соединения V.90, обращенный к PSTN, должен приходить в цифровом потоке, например, "транковый" (trunk-side) channelised T1, ISDN PRI или ISDN BRI. "Линейный" (line-side) T1 не будет работать, так как при этом добавляются дополнительные аналого-цифровые и цифро-аналоговые преобразования. После того, как аналоговый звонок пользователя будет преобразован в цифровой и послан по сетевому носителю, в транковой конфигурации звонок остается цифровым до тех пор, пока он по линиям T1, PRI или BRI не достигнет цифрового модема.
  2. Поддержка V.90 на обоих концах. Стандарт V.90 должен поддерживаться на обоих концах соединения: как аналоговым модемом пользователя, так и сервером удаленного доступа или модемным пулом на стороне хост-компьютера. Обычно удаленный пользователь использует модемы 3Com Courier, U.S. Robotics, Megahertz( или другие марки модемов V.90 и вызывает по номеру 3Com U.S. Robotics MP I-модем, NETServer I-модем, Courier I-модем, SuperStack II Remote Access System 1500, концентратор удаленного доступа Total Control или другие марки цифровых модемов V.90.
  3. Одно аналого-цифровое преобразование. На пути следования звонка между цифровым модемом V.90 и аналоговым модемом может быть только одно аналого-цифровое преобразование. Если линия - channelized T1, соединение должно быть "транковым", а не с "линейным". Если телефонная компания обслуживает по линейному типу, обычно появляется еще одно дополнительное аналого-цифровое преобразование.


:: электронное пособие

Электронное пособие > Протоколы > Рекомендация V.92
Протоколы

» Рекомендация V.92

    V.92 - новая спецификация протокола модуляции доступа по коммутируемой телефонной линии, принятая ITU (International Telecommunications Union - Международный Союз по Телекоммуникациям), включающая в себя три новых функции, повышающие производительность сеансов связи: Быстрое соединение (QuickConnect), Постановка сеанса связи в режим ожидания (Modem-on-Hold), Передача с использованием ИКМ (PCM Upstream).

    Рекомендация V.92 стала развитием протокола V.90, а документ, подготовленный ITU-T в 2000 году имеет в своем названии дополнение «Enhancements to Recommendation V.90», что можно перевести как «добавление, расширение рекомендации V.90»

    Рекомендация V.92 определяет взаимодействие между двумя различными модемами, один из которых цифровой (на стороне провайдера), а другой — аналоговый (на стороне клиента). Принципиальные характеристики этих модемов следующие:

  • дуплексный режим передачи данных;
  • PCM-модуляция в обоих направлениях передачи данных на символьной скорости 8000;
  • передача данных по синхронному каналу в сторону от цифрового модема к аналоговому модему на скоростях от 28000 бит/c до 56000 бит/c (с шагом 8000 бит/c);
  • передача данных по синхронному каналу в сторону от аналогового модема к цифровому модему на скоростях от 24000 бит/c до 48000 бит/c
    (с шагом 8000 бит/c);
  • разделение направления передачи (дуплекс) методом эхо-компенсации
    в аналоговом модеме;
  • адаптивные методы, позволяющие достигать близкие к максимальным значения скоростей на каждом конкретном канале связи;
  • установка соединения на протоколе V.34, если канал не поддерживает PCM-модуляцию;
  • использование рекомендации V.8 (опционально V.8bis) для осуществления настроечной комбинации;
  • уменьшение времени на процедуру соединения (Quick Connect);
  • поддержка процедуры Modem-on-Hold после поступления «звонка вторжения»
    (CallWaiting).

    Следует отметить из новых функций модема, поддерживаемых протоколом V.92, следующие улучшенные характеристики по сравнению с предыдущим стандатом:

  • QuickConnect означает сокращение времени установки соединения при помощи запоминания модемом характеристик телефонной линии (процедура начальной тренировки). Обычно, модемное «рукопожатие»
    (шумы и звуки, слышимые при установке соединения) длится около полуминуты, что на большинство пользователей действует раздражающе. Использование QuickConnect сокращает это время приблизительно наполовину.
  • Увеличение скорости восходящего канала от пользователя к Интернет-провайдеру (функция V.PCM Upstream) до 48 Кбит/c путём единственного аналого-цифрового преобразования. Это весьма полезное свойство при передаче данных большого объёма
    (e-mail с вложениями, видео и mp3-файлы). Скорость приёма данных из Интернет остаётся той же - 56 Кбит/с.
  • Функция Modem-On-Hold, которая допускает временное прерывание модемной сессии (например, при телефонном вызове) и автоматическое восстановление связи при завершении разговора. При этом пользователь остается на линии («on-hold») и через компьютер получает уведомление о входящем голосовом вызове. Данная функция может быть реализована, только если АТС абонента поддерживает услугу «Ожидание вызова»
    (такая услуга поддерживается современными электронными и цифровыми ТС.

    Для того чтобы получить преимущества от использования протокола V.92 необходимо соблюсти следующие условия:

  • иметь модем, поддерживающий протокол V.92;
  • быть абонентом цифровой АТС с включенной функцией дополнительного вида обслуживания «Уведомление о входящем вызове»;
  • ваш провайдер должен поддерживать протокол V.92;
  • на вашем компьютере должна быть запущена программа для обработки вторичных звонков (например, Internet Call Notification для модемов U.S.Robotics).

Если хотя бы одно из этих условий не соблюдается — функции V.92, будут недоступны.


:: Электронное пособие

Электронное пособие > АТ команды > Метод управления потоком XON/XOFF
АТ команды

» Метод управления потоком XON/XOFF

Метод управления потоком XON/XOFF характеризуется следующими признаками:

передачей знака XOFF (код DC3 ASCII) по цепи передачи информации TXD (103) для сигнализации местному или удаленному терминалу о необходимости прерывания потока информации;
передачей знака XON (код DC1 ASCII) по цепи приема информации RXD (104) для сигнализации местному или удаленному компьютеру о необходимости восстановления потока информации.

Знак XOFF представляет собой знак CONTROL-S, а знак XON - знак CONTROL-Q (В случае передачи этих знаков непосредственно с клавиатуры ПЭВМ).

Модемы поддерживают управление потоком XON/XOFF как в последовательном порте, так и в канальном порте модема. Если управление потоком разрешено в канальном порте модема и в последовательном порте, и знак XOFF принят по каналу связи, этот знак заставляет порт модема приостановить передачу даннных из буфера модема в канал связи.

Буфер заполняется, когда местное устройство, подключенное к последовательному порту, передает в это время данные в последовательный порт. Если буфер заполнился, модем передает знак XOFF от последовательного порта, который командует местному стройству прервать передачу. Местное устройство возобновляет передачу данных только в том случае, если оно принимает знак XON по каналу связи от удаленной системы. Затем знак XON передается от последовательного порта к местному устройству. Это заставляет местное устройство возобновить передачу данных.

Указанный метод называется программным методом управления потоком. Модем поддерживают также т.н. "аппаратное управление потоком" в последовательном порте.