1.1. Общие принципы компьютерной телекоммуникации. Основные понятия и термины

Любая система передачи данных (СПД) состоит из трех основных компонент: передатчика (или так называемый "источник передачи информации"), канала передачи данных и приемника (также называемый "получателем" информации).В случае двухсторонней (дуплексной) передачи источник и получатель могут быть объединены так, что их оборудование может передавать и принимать данные одновременно. В простейшем случае система передачи данных между точками А и Б состоит из следующих основных семи частей:

  • Оконечного оборудования данных в точке А.
  • Интерфейса (или стыка) между оконечным оборудованием данных и аппаратурой канала данных.
  • Аппаратуры канала данных в точке А.
  • Канала передачи между точками А и Б.
  • Аппаратуры канала данных в точке Б.
  • Интерфейса (или стыка) аппаратуры канала данных.
  • Оконечного оборудования данных в точке Б.

Оконечное оборудование данных (ООД) - это обобщенное понятие, используемое для описания оконечного прибора пользователя или его части. ООД может являться источником информации, ее получателем или тем и другим одновременно. ООД передает и/или принимает данные посредством использования аппаратуры канала данных (АКД) и канала передачи. В литературе часто употребляется соответствующий международный термин - DTE (Data Terminal Equipment). В качестве DTE может выступать персональный компьютер, большая ЭВМ (mainframe computer), терминал, устройство сбора данных, кассовый аппарат, приемник сигналов глобальной навигационной системы или любое другое оборудование, способное передавать или принимать данные.

Аппаратура канала данных также называется аппаратурой передачи данных или DCE (Data Communications Equipment). Функция DCE состоит в обеспечении возможности передачи информации между двумя или более DTE по каналу определенного типа, например по телефонному. Для этого DCE должен обеспечить соединение с DTE с одной стороны и с каналом передачи - с другой. На рис. 1 DCE может являться аналоговым модемом, если используется аналоговый канал, или, например, устройством обслуживания канала/данных (CSU/DSU - Channel Service Unit/Data Service Unit), если используется цифровой канал типа E1/T1 или ISDN.

Модемы, разработанные в 60 - 70-х годах, представляли собой устройства исключительно с функциями преобразования сигналов. Однако в наше время модемы приобрели множество сложных функций, которые будут рассмотрены ниже.

Слово "модем" является сокращенным названием устройства, осуществляющего процесс МОдуляции/ДЕМодуляции. Модуляцией называется процесс изменения одного или нескольких параметров выходного сигнала по закону входного сигнала. При этом входной сигнал является, как правило, цифровым и называется модулирующим. Выходной сигнал обычно представляет собой аналоговый и называется модулированным. В настоящее время модемы наиболее широко используются для передачи данных между компьютерами через коммутируемую телефонную сеть общего пользования (КТСОП, GTSN - General Switched Telephone Network).

Важную роль во взаимодействии DTE и DCE играет их интерфейс, который состоит из входящих/исходящих цепей в DTE и DCE, разъемов и соединительных кабелей. В отечественной литературе и стандартах также часто употребляется термин стык.

Соединение DTE с DCE происходит по одному из стыков типа C2. При подключении DCE к каналу связи или среде распространения применяется один из стыков типа C1.

Основные понятия и термины

Данные в компьютере представлены в цифровой форме - закодированы в виде нулей и единиц, которым физически соответствует низкий или высокий уровень напряжения. Телефонная сеть рассчитана на передачу речевых сообщений, представляемых в форме аналоговых электрических сигналов, поэтому непосредственная передача цифровой информации через телефонную сеть невозможна.

Для преобразования форм представления информации необходимо устройство, включаемое между компьютером и телефонной линией. Такое устройство называют модемом (сокращение от МОдулятор/ДЕМодулятор).

Процесс преобразования данных из цифровой формы в аналоговую называется модуляцией. Процесс преобразования данных из аналоговой формы в цифровую называется демодуляцией. Таким образом, основное назначение модема - преобразование данных из цифровой формы в аналоговую, пригодную для передачи по телефонному каналу и, наоборот, из аналоговой в цифровую, воспринимаемую компьютером.

Скорость передачи данных

Передающему модему от компьютера передается поток бит. В зависимости от физического протокола передачи данных, по которому работает модем, при модуляции он ставит в соответствие каждому биту или последовательности бит цифровой информации некоторый аналоговый сигнал. Единицей скорости изменения сигнала (т.е. скорости передачи данных в канале) является бод. Скорость передачи в канале называется модуляционной скоростью. Под скоростью передачи данных понимают цифровую скорость передачи и используют единицу измерения бит/с.

В среднем, при передаче данных через модем, каждым десяти переданным битам соответствует 1 байт или символ. Часто скорость передачи данных измеряют в символах в секунду (обозначается CPS - от английского Character Per Second).

Управление потоком

Модем поддерживает два метода управления потоком: Hardware Flow Control (аппаратное управление потоком) и Software Flow Control (программное управление потоком).

Hardware Flow Control (аппаратное управление потоком) - выполняется посредством сигналов CTS и RTS порта RS-232C. Это двунаправленное управление потоком. Когда буфер передачи модема становится почти полным, модем устанавливает сигнал CTS в состояние логического нуля, чтобы оповестить компьютер, что он не может принимать данные. Когда по мере передачи данных к удаленному модему буфер передачи модема очищается, модем переводит сигнал CTS в состояние логической единицы, чтобы информировать компьютер, что модем снова готов к приему очередной порции данных. Сигнал RTS используется коммуникационным программным обеспечением компьютера. Когда приемный буфер программного обеспечения становится почти полон, оно будет переводить сигнал RTS в состояние логического нуля, чтобы информировать модем об остановке передачи данных от модема в компьютер. Когда, по мере обработки принятых данных, приемный буфер программного обеспечения очищается, оно переводит сигнал RTS в состояние логической единицы, чтобы сигнализировать модему о продолжении передачи данных в компьютер.

Software Flow Control (программное управление потоком) - это двунаправленное управление потоком посредством передачи символов XON и XOFF. И модем, и компьютер рассматривают XOFF как сигнал к прекращению передачи данных, а XON - как сигнал к ее возобновлению.

Установление соединений для передачи данных

Когда мы звоним на другой модем или наш модем отвечает на звонок удаленного модема, модем пытается установить соединение для передачи данных на максимально возможной скорости.

Если линия зашумленная или удаленный модем не поддерживает высокую скорость передачи, наш модем может автоматически переходить на более низкую скорость до тех пор, пока не найдет подходящую. После этого два модема начинают обмениваться специальными сигналами согласования (handshake), при помощи которых согласовываются протоколы передачи данных. Если модемы установили соединение, то наш модем выдает соответствующее сообщение "CONNECT nnnn" (например, "CONNECT 2400"), где nnnn - параметры установленного соединения.

Телекоммуникационное программное обеспечение

Для работы с модемом требуется телекоммуникационное программное обеспечение. В настоящее время существует большое количество телекоммуникационных пакетов.

После загрузки коммуникационной программы она переходит в режим симуляции терминала (в разных пакетах этот режим называется по-разному, например Terminal Mode или Direct Mode). В этом режиме осуществляется управление модемом при помощи AT-команд, вводимых вручную и на экран выводятся ответы модема. При этом программа служит как бы буфером между пользователем и модемом, позволяя управлять модемом не только с помощью AT-команд, но и через систему меню.

Синхронный и асинхронный режимы

Существуют два метода обмена данными между модемом и компьютером - синхронный и асинхронный. В синхронном режиме данные передаются и принимаются бит за битом и стробируются посредством сопровождающего тактового синхросигнала. Не все модемы поддерживают синхронный режим обмена данными с компьютером.

В асинхронном режиме данные посылаются символ за символом, при этом временные паузы между символами могут быть различны. При передаче байта (группа бит, кодирующая передаваемый символ), наряду с битами данных в поток вставляются служебные биты: стартовый бит, стоповые биты, иногда биты контроля четности.

Стартовый бит указывает начало байта данных, биты данных содержат собственно данные, бит четности представляет собой проверочный бит, обычно устанавливаемый в ноль или единицу так, чтобы общее число единиц в байте было всегда или четно, или нечетно. Этот бит используется для контроля правильности передачи данных при работе с большими машинами (mainframes). Стоповые биты представляют собой один или два бита, означающих конец передаваемого байта.
<<< ^^^ >>>
Created by Aleksey Vishnyakov © 2002


1.2. Классификация модемов

Строгой классификации модемов не существует и, вероятно, не может существовать по причине большого разнообразия как самих модемов, так и сфер применения и режимов их работы. Тем не менее, можно выделить ряд признаков, по которым и провести условную классификацию. К таким признакам или критериям классификации можно отнести следующие: область применения; метод передачи; интеллектуальные возможности; конструктивное исполнение; поддержка протоколов модуляции, исправления ошибок и сжатия данных. Можно выделить еще множество более детальных технических признаков, таких как применяемый способ модуляции, интерфейс сопряжения с DTE и так далее.

По области применения современные модемы можно разделить на несколько групп:

  • для коммутируемых телефонных каналов;
  • для выделенных (арендуемых) телефонных каналов;
  • для физических соединительных линий:
    • модемы низкого уровня (линейные драйверы) или модемы на короткие расстояния (short range modems);
    • модемы основной полосы (baseband modems);
  • для цифровых систем передачи (CSU/DSU);
  • для сотовых систем связи;
  • для пакетных радиосетей;
  • для локальных радиосетей.

Подавляющее большинство выпускаемых модемов предназначено для использования на коммутируемых телефонных каналах. Такие модемы должны уметь работать с автоматическими телефонными станциями (АТС). Различать их сигналы и передавать свои сигналы набора номера.

Основное отличие модемов для физических линий от других типов модемов состоит в том, что полоса пропускания физических линий не ограничена значением 3.1 кГц, характерным для телефонных каналов. Однако полоса пропускания физической линии также является ограниченной и зависит в основном от типа физической среды (экранированная и неэкранированная витая пара, коаксиальный кабель и др.) и ее длины.

С точки зрения используемых для передачи сигналов модемы для физических линий могут быть разделены на модемы низкого уровня (линейные драйверы), использующие цифровые сигналы, и модемы с "основной полосы" (baseband), в которых применяются методы модуляции, аналогичные применяемым в модемах для телефонных каналов.

В модемах первой группы обычно используются цифровые методы биимпульной передачи, позволяющие формировать импульсные сигналы без постоянной составляющей и часто занимающие более узкую полосу частот, чем исходная цифровая последовательность.

В модемах второй группы часто используются различные виды квадратурной амплитудной модуляции, позволяющие радикально сократить требуемую для передачи полосу частот. В результате на одинаковых физических линиях такими модемами может достигаться скорость передачи до 100 Кбит/с, в то время как модемы низкого уровня обеспечивают только 19.2 Кбит/с.

Модемы для цифровых систем передачи напоминают модемы низкого уровня. Однако в отличие от них обеспечивают подключение к стандартным цифровым каналам, таким как E1/T1 ил ISDN, и поддерживают функции соответствующих канальных интерфейсов.

Модемы для сотовых систем связи отличаются компактностью исполнения и поддержкой специальных протоколов модуляции и исправления ошибок, позволяющих эффективно передавать данные в условиях сотовых каналов с высоким уровнем помех и постоянно изменяющимися параметрами. Среди таких протоколов выделяются ZyCELL, ETC и MNP10.

Пакетные радиомодемы предназначены для передачи данных по радиоканалу между мобильными пользователями. При этом несколько радиомодемов используют один и тот же радиоканал в режиме множественного доступа, например, множественного доступа с контролем несущей, в соответствии с ITU-T AX.25. радиоканал по своим характеристикам близок к телефонному и организуется с использованием типовых радиостанций, настроенных на одну и ту же частоту в УКВ либо КВ диапазоне. Пакетный радиомодем реализует методы модуляции и множественного доступа.

Локальные радиосети являются быстроразвивающейся перспективной сетевой технологией дополняющей обыкновенные локальные сети. Ключевым их элементом являются специализированные радиомодемы (адаптеры локальных радиосетей). В отличие от ранее упомянутых пакетных радиомодемов такие модемы обеспечивают передачу данных на небольшие расстояния (до 300 м) с высокой скоростью (2-10 Мбит/с), сопоставимой со скоростью передачи в проводных локальных сетях. Кроме того, радиомодемы локальных радиосетей работают в определенном диапазоне частот с применением сигналов сложной формы, таких как сигналы с псевдослучайной перестройкой рабочей частоты.

По методу передачи модемы делятся на асинхронные и синхронные. Говоря о синхронном либо асинхронном методе передачи обычно подразумевают передачу по каналу связи между модемами. Однако передача по интерфейсу DTE - DCE также может быть синхронной и асинхронной. Модем может работать с компьютером в асинхронном режиме и одновременно с удаленным модемом - в синхронном режиме или наоборот. В таком случае иногда говорят, что модем синхронно-асинхронный или он работает в синхронно-асинхронном режиме.

Как правило, синхронизация реализуется одним из двух способов, связанных с тем, как работают тактовые генераторы отправителя и получателя: независимо друг от друга (асинхронно) или согласованно (синхронно). Если передаваемые данные составлены из последовательности отдельных символов, то, как правило, каждый символ передается независимо от остальных и получатель синхронизируется вначале каждого получаемого символа. Для такого типа связи обычно используется асинхронная передача. Если передаваемые данные образуют непрерывную последовательность символов или байтов, то тактовые генераторы отправителя и получателя должны быть синхронизированы в течение длительного промежутка времени. В этом случае используется синхронная передача.

Асинхронный режим передачи используется главным образом тогда, когда передаваемые данные генерируются в случайные моменты времени, например пользователем. При такой передаче получающее устройство должно восстанавливать синхронизацию в начале каждого получаемого символа. Для этого каждый передаваемый символ обрамляется дополнительным стартовым и одним или более стоповыми битами. Такой асинхронный режим часто применяется при передаче данных по интерфейсу DTE -DCE. При передаче данных по каналу связи возможности применения асинхронного режима передачи во многом ограничены его низкой эффективностью и необходимостью использования при этом простых методов модуляции, таких как амплитудная и частотная. Более совершенные методы модуляции, такие как ОФМ, КАМ и др., требуют поддержания постоянного синхронизма опорных тактовых генераторов отправителя и получателя.

При синхронном методе передачи осуществляют объединение большого числа символов или байт в отдельные блоки или кадры. Весь кадр передается как одна цепочка битов без каких-либо задержек между восьмибитными элементами. Чтобы принимающее устройство могло обеспечить различные уровни синхронизации, должны выполняться следующие требования:

  • Передаваемая последовательность битов не должна содержать длинных последовательностей нулей или единиц для того, что бы принимающее устройство могло устойчиво выделять тактовую частоту синхронизации.
  • Каждый кадр должен иметь зарезервированные последовательности битов или символов, отмечающие его начало и конец.

Существует два альтернативных метода организации синхронной связи: символьно- или байт-ориентированный, и бит-ориентированный. Различие между ними заключается в том, как определяются начало и конец кадра. При бит-ориентированном методе получатель может определить окончание кадра с точностью до отдельного бита, а при байт-ориентированном методе с точностью до байта (символа).

Кроме высокоскоростной передачи данных собственно по физическим каналам синхронный режим часто применяется и для передачи по интерфейсу DTE - DCE. В этом случае для синхронизации используются дополнительные интерфейсные цепи, по которым передается сигнал тактовой частоты от отправителя к получателю.

По интеллектуальным возможностям можно выделить модемы:

  • без системы управления;
  • поддерживающие набор АТ-команд;
  • с поддержкой команд V.25bis;
  • с фирменной системой команд;
  • поддерживающие протоколы сетевого управления.

Большинство современных модемов наделено широким спектром интеллектуальных возможностей. Стандартом де-факто стало множество АТ-команд, разработанных в свое время фирмой Hayes и позволяющее пользователю или прикладному процессу полностью управлять характеристиками модема и параметрами связи. По этой причине модемы, поддерживающие АТ-команды носят название Hayes-совместимых модемов. Следует заметить, что AT-команды поддерживают не только модемы для КТСОП, но и пакетные радиомодемы, внешние адаптеры ISDN и ряд других модемов с более узкими сферами применения.

Наиболее распространенным набором команд, позволяющим управлять режимами установления соединения и автовызова являются команды рекомендации ITU-T V.25bis.

Специализированные модемы для промышленного применения часто имеют фирменную систему команд, отличную от набора АТ-команд. Причиной тому является большое различие в режимах работы и выполняемых функциях между модемами широкого применения и промышленными (сетевыми) модемами.

Промышленные модемы часто поддерживают протокол сетевого управления SMNP (Simple Manager Network Protocol), позволяющий администратору управлять элементами сети (включая модемы) с удаленного терминала.

По конструкции различают модемы:

  • внешние;
  • внутренние;
  • портативные;
  • групповые.

Внешние модемы представляют собой автономные устройства, подключаемые к компьютеру или другому DTE посредством одного из стандартных интерфейсов DTE - DCE. Внутренний модем - это плата расширения, вставляемая в соответствующий слот компьютера. Каждый из вариантов конструктивного исполнения имеет свои преимущества и недостатки, которые будут рассмотрены далее.

Портативные модемы предназначены для использования мобильными пользователями совместно с компьютерами класса Notebook. Они отличаются малыми габаритами и высокой ценой. Их функциональные возможности, как правило, не уступают возможностям полнофункциональных модемов. Часто портативные модемы оснащены интерфейсом PCMCIA.

Групповыми модемами называют совокупность отдельных модемов, объединенных в общий блок и имеющих общие блок питания, устройства управления и отображения. Отдельный модем группового модема представляет собой плату с разъемом, устанавливаемую в блок, и рассчитан на один или небольшое число каналов.

Модемы также можно классифицировать в соответствии с реализованными в них протоколами. Все протоколы, регламентирующие те или иные аспекты функционирования модемов, могут быть отнесены к двум большим группам:

  • международные;
  • фирменные.

Протоколы международного уровня разрабатываются под эгидой ITU-T и принимаются им в качестве рекомендаций (ранее ITU-T назывался Международным консультативным комитетом по телефонии и телеграфии - МККТТ, международная абревиатура - CCITT). Все рекомендации ITU-T относительно модемов относятся к серии V. Фирменные протоколы разрабатываются отдельными компаниями - производителями модемов, с целью преуспеть в конкурентной борьбе. Часто фирменные протоколы становятся стандартными протоколами де-факто и принимаются частично либо полностью в качестве рекомендаций ITU-T, как это случилось с рядом протоколов фирмы Microcom. Наиболее активно разработкой новых протоколов и стандартов занимаются такие известные фирмы, как AT&T, Motorolla, U.S.Robotics, ZyXEL и другие.

С функциональной точки зрения модемные протоколы могут быть разделены на следующие группы:

  • Протоколы, определяющие нормы взаимодействия модема с каналом связи (V.2, V.25);
  • Протоколы, регламентирующие соединение и алгоритмы взаимодействия модема и DTE (V.10, V.11, V.24, V.25, V.25bis, V.28);
  • Протоколы модуляции, определяющие основные характеристики модемов, предназначенных для коммутируемых и выделенных телефонных каналов. К ним относятся такие протоколы, как V.17, V.22, V.32, V.34, HST, ZyX и большое количество других;
  • Протоколы защиты от ошибок (V.41, V.42, MNP1 - MNP4);
  • Протоколы сжатия передаваемых данных, такие как MNP5, MNP7, V.42bis;
  • Протоколы, определяющие процедуры диагностики модемов, испытания и измерения параметров каналов связи (V.51, V.51, V.53, V.54, V.56).
  • Протоколы согласования параметров связи на этапе ее установления (Handshaking), например V.8.

Приставки "bis" и "ter" в названиях протоколов обозначают, соответственно, вторую и третью модификацию существующих протоколов или протокол, связанный с исходным протоколом. При этом исходный протокол, как правило, остается поддерживаемым.

Некоторую ясность среди многообразия модемных протоколов может внести их условная классификация, приведенная на рисунке:

Рис. 1.2.1. Условная классификация модемных протоколов

Следует также заметить, что некоторые протоколы нельзя отнести только к одной из приведенных групп, так как они описывают реализацию ряда различных функций, например, таких как модуляция и коррекция ошибок. В первую очередь, это относится к фирменным протоколам (ZyCELL, MNP10 и другим).


1.3. Устройство и возможности современных модемов. Схема подключения модема к компьютеру и телефонной линии

Конструктивно модемы могут быть выполнены либо в виде отдельной платы (так называемые встроенные модемы), которая устанавливается непосредственно внутри корпуса компьютера в слоты расширения. При этом имеются некоторые ограничения при выборе компьютера и соответствующего ему модема. Внешний модем выполняется в виде отдельного устройства, подключаемого обычно к последовательному порту компьютера. Как правило, он имеет отдельный блок питания и световые индикаторы, позволяющие контролировать состояние модема.

Обычный модем включает в себя специализированный процессор, управляющий его работой; ОЗУ, которое сохраняет значения S-регистров и осуществляет буферизацию передаваемых и принимаемых данных; ПЗУ, где хранится программа его работы и стандартные конфигурации; в большинстве модемов - энергонезависимое ОЗУ или ППЗУ, где может быть сохранено несколько подготовленных пользователем конфигураций; громкоговоритель для обеспечения контроля работы. Структурная схема модема представлена на рис. 1.3.1.

Рис. 1.3.1. Структурная схема модема

Рис. 1.3.1. Структурная схема модема.

Как правило, и внешние, и внутренние модемы имеют набор переключателей или перемычек, при помощи которых устанавливаются номер порта и используемая модемом линия прерывания (СОМ1, COM2 и т.д.), при этом следует иметь в виду, что несколько СОМ-портов могут иметь одну линию прерывания. Поэтому если модем использует СОМ1, то другое устройство (например мышь или другой модем) необходимо использовать с портом COM2 или COM4, а порт COM3 использовать нельзя во избежание конфликтов.

Для подключения модема к телефонной сети используется специальный разъем (обычно он обозначается "Line" или "Jack").

При работе с модемом следует учитывать, что он может находиться в одном из двух режимов: командном или передачи данных. После включения питания модем обычно переходит в командный режим. При этом он готов воспринимать и выполнять команды от компьютера (например, можно изменять конфигурацию модема, записывать или считывать данные из его регистров, устанавливать соединение с другим модемом и т. д.). Из этого режима модем может перейти в режим передачи данных в следующих случаях:

  • после обмена настроечными последовательностями и установления связи с другим модемом;
  • после перехода в режим тестовых проверок.

Переход модема в командный режим из режима передачи данных происходит:

  • после неудачной попытки установления связи с другим модемом;
  • при получении модемом от компьютера специальной Escape-последовательности (обычно "+++" с тайм-аутами до и после в 1-2 сек.);
  • при поступлении команды во время набора номера (при этом модем еще находится в командном режиме);
  • после потери несущей во время сеанса передачи данных.

Все команды, передаваемые модему от компьютера, начинаются с префикса AT (от английского Attention - внимание), а должны заканчиваться символом возврата каретки (<CR> или <Enter>).

Для того чтобы начать работу с модемом следует запустить коммуникационную программу на компьютере, указав в ней номер COM-порта, соответствующий номеру COM-порта модема. После этого происходит инициализация соответствующего COM-порта компьютера и он готов для передачи модему команд.


1.4. Интерфейсы модемов. Цепи и назначение сигналов интерфейса RS-232

Способ подключения модема к компьютеру зависит от того, внутренний модем или внешний.

Внешний модем подключается к любому COM-порту компьютера. Внутренний модем устанавливается на материнской плате в свободный слот. Питание внешнего модема осуществляется от отдельного блока питания.

Для подключения телефонной линии и телефона на задней панели модема имеются два разъема типа RJ11 (Registered Jack 11), - разъем для подключения модема к телефонной линии обозначен "Line" или "Wall", разъем для подключения телефона - "Phone".

Внешне каждый COM-порт представлен собственным разъемом. Существует два стандарта на разъемы COM-порта: DB25 и DB9. Первый разъем имеет 25, а второй 9 выводов.

Разводка разъемов DB25 и DB9 со стороны последовательного асинхронного адаптера (COM-порта):

Номер контакта |  | Назначение контакта и сигналы интерфейса RS-232 | Вход или выход
DB25 | DB9
1 | - | Защитное заземление (Frame Ground, FG) | -
2 | 3 | Передаваемые данные (Transmitted Data, TD) | Выход
3 | 2 | Принимаемые данные (Received Data, RD) | Вход
4 | 7 | Запрос для передачи (Request to Send, RTS) | Выход
5 | 8 | Сброс для передачи (Clear to Send, CTS) | Вход
6 | 6 | Готовность данных (Data Set Ready, DSR) | Вход
7 | 5 | Сигнальное заземление (Signal Ground, SG) | -
8 | 1 | Детектор принимаемого с линии сигнала (Data Carrier Detect, DCD) | Вход
9-19 | - | Не используется | -
20 | 4 | Готовность выходных данных (Data Terminal Ready, DTR) | Выход
21 | - | Не используется | -
22 | 9 | Индикатор вызова (Ring Indicator, RI) | Вход
23-25 | - | Не используется | -

Интерфейс RS-232 (Recommended Standard - 232 ) определяет обмен между устройствами двух типов: DTE (Data Terminal Equipment - терминальное устройство) и DCE (Data Communication Equipment - устройство связи). Разработан ассоциацией EIA (Electronic Industries Association of America).

Рассмотрим сигналы интерфейса RS-232 более подробно на примере взаимодействия компьютера (DTE) и модема (DCE).

Входы TD и RD используются компьютером и модемом по разному. Компьютер использует вход TD для передачи данных, а модем - для приема. Вход RD компьютер использует для приема данных, а модем - для передачи.

Компьютер устанавливает сигнал на линии DTR, чтобы показать модему, что он готов к проведению сеанса связи. Сигнал на линии DSR означает, что модем готов для взаимодействия с компьютером.

Когда модем произвел соединение, он устанавливает соединение с другим удаленным модемом, он устанавливает сигнал на линии DCD, чтобы сообщить об этом компьютеру.

Сигналы RTS и CTS используются для аппаратного управления потоком данных между компьютером и модемом (hardware flow control). Когда компьютер может принять данные, он подает сигнал по линии RTS. Если модем готов для принятия данных, он выдает сигнал CTS.


1.5. Индикаторы внешнего модема

Обычно внешние модемы имеют набор индикаторов, по которым можно определять состояние модема. Чаще всего эти индикаторы следующие:

MR Modem Ready - Модем готов к обмену данными. Если этот индикатор не горит, то надо проверить линию питания модема,

HS High Speed - Модем работает на максимально возможной для него скорости,

АА Auto Answer - Модем находится в режиме автоответа. То есть модем автоматически будет отвечать на приходящие звонки. Когда модем обнаружит звонок (вызов) на телефонной линии, этот индикатор замигает,

CD Carrier Detect - Индикатор зажигается, когда модем обнаруживает несущую частоту на линии. Индикатор должен гореть на протяжении всего сеанса связи и гаснуть, когда один из модемов освободит линию (положит трубку),

ОН Off-Hook - Этот индикатор горит, если трубка снята (линяя занята),

SD Send Data - Индикатор мигает, когда модем передает данные в линию,

RD Receive Data - Индикатор мигает, когда модем принимает данные с линии,

TD Terminal Ready - Компьютер готов к обмену данными с модемом. Этот индикатор горит, когда модем получил от компьютера сигнал DTR.


1.6. Модемные протоколы и стандарты. Виды протоколов. Протоколы взаимодействия и модуляции

Рекомендация V.8

Определяет процедуру обмена сигналами взаимодействия между модемами и начало сеанса передачи данных. При этом происходит определение типа модуляции, который будут использовать модемы (V.34, V.32, V.32bis, V.22, V.21 и т.д.), дуплексный или полудуплексный обмен, вызывной тон, защита от ошибок (V.42 или др.).

Рекомендация V.17

Полудуплексный факсимильный модем со скоростями передачи данных до 14400 бит/с (допускаются скорости 12000, 9600 или 7200 бит/с) для использования в коммутируемых телефонных сетях общего пользования. На скорости 14400 бит/с используется 128-кратная относительная амплитудно-фазовая модуляция с помехоустойчивым кодированием в режиме исправления ошибок. Перед началом работы модемы обмениваются настроечными сообщениями на скорости 4800 бит/с.

Рекомендация V.22bis

Дуплексный модем на скорость 2400 бит/с с применением метода частотного разделения, стандартизированный для использования на коммутируемой телефонной сети общего пользования и двухточечных двухпроводных арендованных каналах телефонного типа.

Рекомендация V.24

Перечень определений цепей стыка между оконечным оборудованием данных (ООД) и аппаратурой окончания канала данных (АКД).

Рекомендация V.32bis

Стандартизируется дуплексный модем для работы со скоростями 14400, 12000, 9600, 7200 или 4800 бит/с по двухпроводному телефонному каналу (коммутируемому или арендованному). Каналы передачи и приема разделяются методом эхокомпенсации. Используется 128-кратная амплитудно-фазовая модуляция с использованием помехоустойчивого кодирования.

Рекомендация V.34

Стандартизируется дуплексный модем для работы по КСОП со скоростями до 28800 бит/с. Причем соединение начинается по рекомендации V.21 (300 бит/с), что позволяет такому модему поддерживать соединение практически со всем спектром модемов, находящихся в эксплуатации.


1.7. Необходимость коррекции и сжатия данных в модемах. Протоколы коррекции и сжатия данных

Рекомендация V.42

МККТТ в качестве стандарта на защиту от ошибок в модемах принял в Рекомендации V.42 протокол LAPM (Line Access Protocol for Modems).

Протокол MNP

С середины 80-х гг. в модемах начал широко применяться протокол MNP (Microcom Networking Protocol) компании Microcom (США). Этот протокол предусматривает обнаружение ошибок с помощью кода и повторный запрос ошибочно принятых блоков информации. Благодаря очень широкому использованию, протокол MNP превратился в фактический международный промышленный стандарт. Существует 10 классов этого протокола.

В классе 4, наряду с протоколом исправления ошибок используются 2 метода повышения эффективности передачи: "Адаптивное изменение длины пакетов" (Adaptive Packet Assembly) и "Оптимизация фазы данных" (Data Phase Optimisation). Посредством адаптивного изменения длины пакетов модем непрерывно приспосабливается к уровню помех в канале связи. При малом числе ошибок автоматически увеличиваются размеры пакета (максимум до 256 байтов), чтобы повысить эффективность протокола путем уменьшения относительной доли служебной информации пакета, обеспечивающей управление передачей и контроль ошибок. В случае плохого канала протокол уменьшает размеры пакета (минимум до 32 байтов), чтобы уменьшить затраты времени на повторную передачу.

В классе 5 протокола MNP в модемы вводится сжатие данных. Сжатие/расширение данных (Basic Data Compression) производится в процессе передачи с использованием адаптивного алгоритма. Например, при работе в диалоговом режиме сжатие данных ускоряет вывод информации на экран. Достигаемая степень сжатия зависит от типа передаваемого файла. Исполняемые файлы имеют наименьший коэффициент сжатия. Далее следуют файлы электронных таблиц. Наибольший коэффициент сжатия имеют текстовые файлы. Коэффициент сжатия изменяется в пределах от 1,3 до 2. Средний коэффициент сжатия составляет 1,6.

Рекомендация V.42bis

Сжатие данных, наряду с защитой от ошибок, является той функцией, введение которой в модемы позволило значительно повысить их эффективность и, тем самым, продлить существование модемов на этапе перехода к полностью цифровым сетям. В то время, как протокол MNP (класс 5) стал фактическим промышленным стандартом на сжатие данных в модемах, МККТТ в качестве Рекомендации V.42bis принял метод сжатия данных BTLZ (British Telecom Lempel-Ziv), разработанный компанией British Telecom.

Первым отличием алгоритма BTLZ от других алгоритмов является способ организации справочника, в котором хранятся более короткие коды, используемые для передачи вместо повторяющихся длинных отрезков данных.

Другим преимуществом протокола BTLZ является его способность распознавать наличие последовательностей данных, близких к случайным. При обнаружении таких последовательностей алгоритм выключает механизм сжатия, продолжает контроль, и включает этот механизм при пропадании случайного характера последовательности данных. Другие рассмотренные протоколы в такой ситуации снижают пропускную способность до величины меньшей, чем даже номинальная скорость модема.

При сжатии текстов с помощью протокола BTLZ могут быть получены коэффициенты сжатия до 3, в то время, как для более регулярных данных, таких, как файлы электронных таблиц и некоторые графические файлы, коэффициент сжатия может достигать значений 4.


1.8. Интеллектуальные возможности модемов для телефонных каналов. Управление модемами. Команды управления модемами (АТ-язык). Наборы АТ-команд

После выпуска американской фирмой Hayes модемов серии Smartmodem, система команд, использованная в ней, стала неким стандартом, которого придерживаются остальные фирмы - разработчики модемов. Система команд, применяемая в этих модемах, носит название hayes-команд, или AT-команд.

Со времени выпуска первых AT-совместимых модемов набор их команд несколько расширился, но все основные команды остались без изменения.

Все команды, передаваемые компьютером модему, надо начинать префиксом AT (ATtention - внимание) и заканчивать символом возврата каретки (<CR>). Только команда А/ и Escape-последовательность "+++" не требуют для себя префикса AT.

После префикса AT могут идти одна или сразу несколько команд. Для ясности эти команды могут быть отделены друг от друга символами пробела, тире, скобками. В большинстве случаев команды могут быть написаны как заглавными, так и строчными буквами.

При передаче модему команд они сначала заносятся во внутренний буфер, который, как правило, имеет размер 40 символов. Команды, записанные в буфер модема, исполняются после поступления символа возврата каретки. Вследствие ограниченности размера буфера не следует передавать модему слишком длинные команды (больше размера буфера). Длинные команды можно разбивать на части и передавать в несколько заходов. При этом каждая часть должна начинаться префиксом AT и заканчиваться символом возврата каретки.

Если вы допустили ошибку при наборе команды, то ее можно исправить, используя клавишу Backspace.

После выполнения каждой команды модем посылает обратно компьютеру ответ в виде числа или слова. Этот ответ означает, выполнена ли команда или произошла ошибка.

Основные команды модема

AT - Начало (префикс) командной строки. После получения этой команды модем автоматически подстраивает скорость передачи и формат данных к параметрам компьютера.

А - Автоответ. Если режим автоматического ответа выключен (S0=0), команда используется для ответа на звонок от удаленного модема. Команда заставляет модем снять трубку (подключиться к линии) и установить связь с удаленным модемом.

А/ - Модем повторяет последнюю введенную команду. Команда передается на модем без префикса AT и исполняется модемом немедленно, не ожидая прихода символа возврата каретки.
Если вы передадите модему строку AT A/ <CR>, то модем укажет на ошибку и вернет слово ERROR.

Bn - Команда производит выбор стандарта, согласно которому будет происходить обмен данными между модемами. При скорости передачи 300 бит/с происходит выбор между стандартами BELL 103 и CCITT V.21, при скорости 1200 bps - между BELL 212A и CCITT V.22bis. При скорости 2400 bps эта команда игнорируется и используется стандарт CCITT V.22. Если n=0, устанавливаются стандарты CCITT V.21/V.22. а если n=1 - стандарты BELL 103/212A.

Ds - Команда используется для набора номера. После получения этой команды модем начинает набор номера и при установлении связи переходит в режим передачи данных. Команда состоит из префикса AT, символа D и телефонного номера, в состав которого могут входить следующие управляющие модификаторы: P или T. Эти модификаторы производят выбор между импульсной и тоновой системой набора (в зависимости от типа конкретной АТС).

, - Символ запятой вызывает паузу при наборе номера. Длительность паузы определяется содержимым регистра S8.

; - Символ точки с запятой, если он находится в конце командной строки, переводит модем после набора номера в командный режим.

@ - Модем ожидает пятисекундной тишины на линии в течение заданного промежутка времени. Промежуток времени, в течение которого модем ожидает тишины, задается в регистре S7. Если в течение этого времени паузы тишины не было, модем отключается и отвечает NO ANSWER.

! - Если знак ! стоит перед знаками последовательности набора, модем переходит в состояние ON HOOK (кладет трубку) на 1/2 секунды, а затем снова переходит в состояние OFF HOOK (снимает трубку).

S - Модем набирает телефонный номер, записанный в его памяти. Эта команда выполняется только для модемов, имеющих встроенную энергонезависимую память и возможность записи в нее номеров телефонов.

R - После набора номера переводит модем в режим автоответа. Этот модификатор должен находиться в конце набираемого номера.

W - Перед дальнейшим набором телефонного номера модем ожидает длинный гудок из линии. Причем время ожидания гудка содержится в регистре S7. Если в отведенное время гудок не появился, модем прекращает набор номера и возвращает сообщение NO DIALTONE. Этот параметр может быть полезен при наборе междугородних номеров.

En - Управление эхо-выводом команд, передаваемых модему. После команды Е1 модем возвращает каждый знак, передаваемый ему, обратно компьютеру, что позволяет узнать, как работает связь модема и компьютера. Команда Е0 запрещает эхо-вывод.

Fn - Переключение между дуплексным/полудуплексным режимами. При n=0 переход в полудуплексный режим, а при n=1 - в дуплексный.

Hn - Эта команда используется для управления телефонной линией. Если n=0, то происходит отключение модема от линии, если n=1, модем подключается к линии.

In - Выдает идентификационный код модема и контрольную сумму содержимого памяти модема- Если n=0, модем сообщает свой идентификационный код, если n=1, модем проводит подсчет контрольной суммы EPROM и передает ее компьютеру, n=2 - модем проверяет состояние внутренней памяти ROM и возвращает сообщение ОК или CHECKSUM ERROR (ошибка контрольной суммы). При n=3 выдаётся состояние модема.

Ln - Установка громкости сигнала внутреннего динамика: n=0,1 соответствует низкой громкости, n=2 - средней и n=3 - максимальной.

Мn - Управление внутренним динамиком. При n=0 динамик выключен. При n=1 динамик включен только во время набора номера и выключен после обнаружения несущей. При n=2 динамик включен все время. При n=3 динамик включается после набора последней цифры номера и выключается после обнаружения несущей отвечающего модема.

Qn - Управление ответом модема на АТ-команды. При n=0 ответ разрешен, при n=1 ответ запрещен. Независимо от состояния Q0 или Q1 модем всегда сообщает содержание S-регистров, свой идентификационный код, контрольную сумму памяти и результаты теста.

On - Команда переводит модем из командного режима в режим передачи данных. При этом модем отвечает CONNECT. Команда O и O0 переводят модем в режим передачи данных без инициирования последовательности сигналов проверки линии связи. Команда O1 переводит модем в режим передачи данных и заставляет модем передать последовательности сигналов проверки линии связи, т.е. производить повторное квитирование с удалённым модемом.

Sr? - Чтение содержимого регистра модема, имеющего номер r.

Sr=n - Запись в регистр модема с номером r числа n. Число n может иметь значения от 0 до 255. Все команды модифицируют содержимое одного или более S-регистров. Некоторые S-регистры содержат временные параметры, которые можно поменять только командой S.

Vn - Производит выбор вида ответа модема на АТ-команды При n=0 ответ происходит цифровым кодом, а при n=1 модем отвечает в символьном виде на английском языке. Использование цифровой формы ответа облегчает обработку результатов выполнения команды при написании собственных программ управления модемом.
Стандартный набор ответов модема

ОК | 0 | Модем выполнил команду без ошибок
CONNECT | 1 | Модем установил связь со скоростью 300 bps
RING | 2 | Модем обнаружил сигнал звонка
NO CARRIER | 3 | Модем потерял несущую частоту
ERROR | 4 | Ошибка в командной строке
CONNECT 1200 | 5 | Модем установил связь со скоростью 1200 bps
NO DIALTONE | 6 | Отсутствие сигнала станции при снятии трубки
BUSY | 7 | Модем обнаружил сигнал "занято"
NO ANSWER | 8 | Нет ответа после ожидания сигнала
CONNECT 600 | 9 | Модем установил связь со скоростью 600 bps
CONNECT 2400 | 10 | Модем установил связь со скоростью 2400 bps

Yn - Способ отключения модема от линии. Существуют два способа отключения модема от линии: стандартный, когда модем получает неактивный сигнал DTR от компьютера, и принудительный, когда модем получает от удаленного модема сигнал перерыва BREAK. Команда АТН0 направляет удаленному модему сигнал перерыва BREAK, который длится 4с. При n=0 модем отключается стандартно, при n=1 модем отключается после получения из линии сигнала BREAK.

Z - Сбрасывает конфигурацию модема. При этом во все регистры загружаются значения, принятые по умолчанию. Значения регистров, принятые по умолчанию берутся из энергонезависимой памяти модема или, если модем такой памяти не имеет, из постоянной памяти или определяется исходя из переключателей на плате модема.

+++ - Escape-последовательность, используемая для перехода в командный режим работы модема. Благодаря этой команде можно перейти из режима передачи данных модемом в командный режим работы без разрыва связи. Модем требует тишины перед и после направления этой Escape-последовательности. Величина этого промежутка тишины определена в регистре S12.

&Cn - Данная команда управляет сигналом DCD порта RS-232-C. При n=0 сигнал DCD всегда активен, а при n=1 сигнал DCD устанавливается только тогда, когда модем обнаруживает несущую частоту от удаленного модема.

&Dn - Управление сигналом DTR. При n=0 модем игнорирует DTR, n=1 - при потере сигнала DTR модем переходит в командный режим работы, n=2 - при потере сигнала DTR модем прекращает связь, отключается от линии, отключает режим автоответа и переходит в командный режим работы, n=3 - при потере сигнала DTR автоматически сбрасывается конфигурация модема, как при выполнении команды ATZ. Модем обнаруживает потерю сигнала DTR, если сигнал DTR отсутствует дольше времени, определенного в регистре модема S25.

&F- модем устанавливает конфигурацию, записанную в постоянную память.

&Gn - Включение/выключение защитной частоты. n=0 - защитная частота выключена, n=1 - модем генерирует защитную частоту 550 Hz, n=2 - модем генерирует защитную частоту 1800 Hz. Использование данной команды зависит от особенностей телефонной линии.

&Ln - Вид линии связи. При n=0 передача по обычным (коммутируемым) линиям связи, n=1 передача по выделенным каналам.

&Mn - Установка асинхронно/синхронного режима работы. При n=0 устанавливается асинхронный режим, при n=1,2,3 устанавливается синхронный режим.

&Pn - Установка импульсного коэффициента набора номера в соответствии с различными стандартами. При n=0 - коэффициент заполнения замыкание/интервал 39/61 (Америка), при n=1 - 33/67 (Англия).

&Rn - Управление сигналом CTS: n=0 - сигнал переходит в активное состояние после получения сигнала RTS. Данные, передаваемые модему до поступления сигнала RTS, игнорируются. Если n=1 модем игнорирует RTS.

&Sn - Управление сигналом DSR порта RS-232-C. При n=0 сигнал DSR активен всегда, а при n=1 сигнал DSR активизируется только после окончания этапа установления связи между модемами.

&Tn - Тестирование модема. От n зависит вид теста.

&V - Модем показывает свою текущую конфигурацию и телефонные номера, записанные в энергонезависимой памяти.

&W - Модем записывает свою текущую конфигурацию в энергонезависимую память. При сбросе модема будет загружена именно эта конфигурация.

&Zn - Используется для записи телефонного номера в энергонезависимую память модема. Количество телефонов зависит от модели модема.


1.9. АТ-команды для тестирования модема. Порядок выполнения местных (аналогового и цифрового) и удаленного цифрового тестов

Локальный аналоговый тест

Рис. 1.9.1. Локальный аналоговый тест

Данный тест позволяет убедиться в исправности канальной части модема, т.е. в работоспособности модулятора и демодулятора. Для начала проверки следует ввести команду АТ&Т1. Данная команда переводит модем в режим передачи данных с компьютера по местному шлейфу в соответствии с рисунком. При этом любые вводимые с компьютера данные будут проходить через модем на его канальную часть и возвращаться обратно для отображения на мониторе.

Проверка выполняется до тех пор, пока не истечет время, задаваемое числом, записанным в регистре S18, или пока она не будет прервана вручную командой "+++". В последнем случае после получения ответа ОК необходимо выдать модему команду завершения теста АТ&ТО. Другим способом завершения теста является использование команды АТН.

Локальный аналоговый тест с самодиагностикой

Рис. 1.9.2. Локальный аналоговый тест с самодиагностикой

Для выполнения локального аналогового теста с самодиагностикой служит команда AT&T8. При этом модем сам генерирует тестовые сообщения и подсчитывает число ошибок.

Локальный цифровой тест

Рис. 1.9.3. Локальный цифровой тест

При выполнении этого теста удаленный компьютер, последовательные и канальные порты удаленного и местного модемов. Удаленный модем, передавая определенную последовательность данных. Поступив на ваш модем, оно будет отправлено обратно удаленному модему. Если принятое удаленным модемом сообщение будет эквивалентно переданному, то линия и удаленный модем исправны.

Последовательность действий:

  • Набрать номер удаленного модема и произвести с ним соединение;
  • Вернуться в режим передачи команд и ввести команду АТ&ТЗ;
  • Пользователь удаленного компьютера вводит для передачи последовательность символов.

Завершение теста аналогично предыдущему.

Удаленный цифровой тест

Рис. 1.9.4. Удаленный цифровой тест

Предназначен для проверки канального порта удаленного модема, телефонного канала, местного последовательного порта и канального порта модема. Тест выполняется при согласии удаленного абонента на выпонение теста (команда AT&T4).

Последовательность действий:

  • Набрать номер удаленного модема и произвести с ним соединение;
  • Вернуться в режим передачи команд и ввести команду АТ&Т6;
  • Ввести последовательность знаков.

Завершение теста аналогично.

Удаленный цифровой тест с самодиагностикой

Рис. 1.9.5. Удаленный цифровой тест с самодиагностикой

Удаленный цифровой тест с самодиагностикой выполняется по команде AT&Т7 и согласии удаленного абонента. Модем сам генерирует тестовые сообщения и подсчитывает число ошибок.


1.10. Назначение и использование S-регистров модема

Hayes-совместимые модемы имеют набор регистров, определяющих различные характеристики модема. Содержимое большинства этих регистров можно считывать и изменять программным способом. Для чтения и записи регистров модема можно использовать AT-команды ATSr? и ATSr=n, где r - номер регистра, а n - число, которое в него записывается.

Регистр S0 - Количество звонков до ответа

Определяет, после какого числа вызывных звонков модем отвечает на входящий вызов, т.е. подключается к телефонной линии. Введение значения от 1 до 255 переводит модем в режим автоответа. Например, если S0=3, модем ожидает 3 звонка и затем начинает передачу последовательности ответа (снимает трубку, подключается к линии и отвечает на вызов удаленного модема). Если S0=0, автоматический ответ запрещен. Возможно считывание и изменение значений в регистре.

Регистр S1 - Подсчет звонков

Значение в данном регистре увеличивается на 1 при каждом обнаружении модемом сигнала звонка из телефонного канала. Значение сбрасывается в 0, если сигнал звонка не обнаруживается в течение 8-секундного интервала. Когда значение в регистре S1 становится равным значению в регистре S0. модем начинает передачу последовательности ответа.

Возможно только считывание значения в регистре.

Регистр S2 - Знак кода перехода

В данном регистре хранится значение ASCII кода перехода (ESCAPE-символ). Этот код перехода позволяет пользователю переключить модем из режима передачи данных в командный режим без разрыва связи с удаленным модемом. Значение по умолчанию равно 43, что соответствует знаку "+" кода ASCII. При значениях, больших 127, обнаружение кода перехода запрещается.

Возможны считывание и изменение знака кода перехода. Для изменения его, например, на "-", необходимо ввести команду ATS2=45 (45 является десятичным значением кода ASCII для "-"). После этого переход в командный режим будет производиться с помощью "---" вместо "+++", как это было ранее.

Регистр S3 - Знак возврата каретки

В регистре S3 хранится десятичное значение кода ASCII знака "возврат каретки" <CR>. Этот знак служит завершающим знаком командной строки и кода ответа. По умолчанию используется значение 13, но если применяется нестандартное оконечное оборудование данных, можно переопределить этот знак, дописав в регистр новое значение.

Примечание: Обычно значение S3 не сохраняется в энергонезависимой памяти. Оно инициализируется значением 13 при включении модема, или после приема команды ATZ.

Регистр S4 - Знак перевода строки

В регистре S4 хранится десятичное значение кода ASCII знака "перевод строки" <LF>. По умолчанию используется значение 10. Этот знак является выходным после знака "возврат каретки", если разрешены коды ответа в развернутой форме (команда ATV1).

Возможны считывание и изменение значений в регистре.

Примечание: Обычно значение S4 не сохраняется в энергонезависимой памяти. Оно инициализируется значением 10 при включении модема, или после приема команды ATZ.

Регистр S5 - Знак возврата на одну позицию

В регистре S5 хранится десятичное значение кода ASCII знака "возврат на одну позицию" <Backspace>. По умолчанию используется значение 8. Этому знаку не должно присваиваться значение, соответствующее печатаемому знаку кода ASCII (т.е., от 31 до 126). В случае присвоения указанных значений, модем их не распознает.

Когда принят знак "возврат на одну позицию" во время ввода команды, производятся следующие операции:

1. Модем возвращает эхо знака на терминал.
2. На терминал выводится знак пробела в коде ASCII (20).
3. На терминал выводится еще один знак "возврат на одну позицию".

Так как выводится эхо трех знаков, то время, требующееся модему для обработки знака "возврат на одну позицию", примерно равняется времени, которое нужно для передачи 3-х знаков на выбранной скорости передачи. Не рекомендуется передавать многократно эти знаки между оконечными станциями, так как модем не сможет достаточно быстро обработать их.

Возможны считывание и изменение значений в регистре.

Примечание: Обычно значение S5 не сохраняется в энергонезависимой памяти. Оно инициализируется значением 8 при включении модема, или после приема команды ATZ.

Регистр S6 - Ожидание тона станции

Этот регистр определяет время ожидания модема после подключения к линии до момента набора им первой цифры номера. Эта задержка обеспечивает телефонной станции время для обнаружения подключения к линии и посылки в линию ответного тона станции ("приглашения к набору"). Если введены команды АТХ3 или АТХ4, значение в S6 игнорируется. Минимальный период ожидания равен 2 секундам - модем игнорирует любое меньшее значение в регистре S6.

Возможны считывание и изменение значений в регистре.

Единица измерения - секунда.

Значение по умолчанию обычно равно 002.

Регистр S7 - Ожидание несущей после набора номера

Этот регистр определяет время после набора номера, в течение которого модем должен выполнить соединение (обнаружить несущую частоту от удаленного модема). Если в течение этого времени модем установит связь, то он выдаст сообщение CONNECT согласно команде ATXn. Если связь не будет установлена, модем отвечает NO CARRIER.

Возможны считывание и изменение значений в регистре.

Единица измерения - секунда.

Значение по умолчанию обычно равно 030.

Регистр S8 - Время паузы в наборе по модификатору "запятая"

Данный регистр задает длительность паузы в наборе номера, при введении в команду ATD модификатора ","("запятая"). В общем случае, эта пауза используется для ожидания второго тона станции при вызове с АТС, или когда используются специальные телефонные службы.

Возможны считывание и изменение значений в регистре.

Единица измерения - секунда.

Значение по умолчанию обычно равно 002.

Регистр S9 - Время ответа схемы обнаружения несущей

Определяет время, в течение которого модем должен принимать несущую от удаленного модема. Если несущая частота принималась в течение этого времени, модем передает в компьютер сигнал DCD.

С увеличением этого времени уменьшается вероятность ложного обнаружения несущей при наличии шумов, таких, как сигнал "занято", речь и т.п.

Возможны считывание и изменение значений в регистре.

Единица измерения - 0,1 секунды.

Значение по умолчанию обычно равно 006 (0,6 сек.).

Регистр S10 - Задержка между пропаданием несущей и отключением от линии

Задает задержку между обнаружением пропадания несущей частоты от удаленного модема и моментом разъединения связи. Эта задержка позволяет приемнику переносить кратковременные пропадания несущей без отключения от линии местного модема. Если S10=255, то модем игнорирует состояние несущей и функционирует, как будто несущая все время присутствует. Значение регистра S10 должно быть больше значения регистра S9, иначе связь установить нельзя.

Возможны считывание и изменение значений в регистре.

Единица измерения - 0,1 секунды.

Значение по умолчанию обычно равно 014 (1,4 сек.).


1.11. Режимы работы модема. Сообщения и ответы модема. Функции, выполняемые модемом в различных режимах. Действия для перехода из одного режима в другой

Модем может находиться в одном из двух основных режимов - командном режиме или режиме данных. В командном режиме модем исполняет команды, вводимые оператором. В режиме данных модем воспринимает все, что может быть получено от компьютера, как данные, которые должны быть переданы в линию. Таким образом, бесполезно вводить команды в режиме данных, так как модем не будет на них реагировать.

Переключение модема в режим данных. Модем автоматически переходит в режим данных после установления соединения с удаленным модемом.

Переключение модема в командный режим. Модем автоматически переключается в командный режим в следующих случаях:

  • при включении питания;
  • при разрыве соединения с удаленным модемом;
  • если модем набирает номер, а мы нажали какую-нибудь клавишу на клавиатуре компьютера. В этом случае, перед тем как перейти в командный режим, модем аннулирует текущий вызов;
  • после ввода оператором Escape-последовательности (ручная смена режима).

Ручная смена режима. Если модем установил асинхронное соединение с удаленным модемом и находится в режиме данных, то перевести его в командный режим, не разрывая текущего соединения, можно, введя с клавиатуры специальную управляющую последовательность символов, которая называется Escape-последовательностью. По умолчанию, Escape-последовательностью является последовательность из трех подряд символов "плюс" - "+++". Если требуется, данные символы можно заменить, изменив содержимое регистра S2.

Для возобновления передачи данных необходимо ввести команду ATO. Модем выдаст сообщение "CONNECT nnnn", где nnnn - параметры установленного соединения, после чего вернется в режим данных.

Основные принципы программирования модемов.

Доступ к модему происходит через последовательный асинхронный порт. При этом для передачи модему команд их необходимо просто записать в регистр данных COM-порта, на котором находится модем. Ответ от модема также поступает через последовательный порт. Передавая модему команды, его можно проинициализировать, перевести в режим автоответа или заставить набрать номер.

Когда модем наберет номер удаленного абонента или когда модему в режиме автоответа придет вызов, ом попытается установить связь с удаленным модемом. После установления связи модем передает компьютеру через СОМ-порт специальное сообщение и переключится из командного режима в режим передачи данных. После этого данные, передаваемые модему, перестают восприниматься им как команды и сразу передаются по телефонной линии на удаленный модем.

Итак, после установления связи с удаленным модемом, коммуникационная программа может начинать обмен данными. Обмен данными так же, как и передача команд, осуществляется через СОМ-порт, Затем при помощи специальной Escape-последовательности можно переключить модем из режима передачи данных обратно в командный режим и положить трубку, разорвав связь с удаленным модемом.

Последовательность действий для установления связи

а) Инициализация COM-порта

Проводим инициализацию COM-порта, к которому подключен модем. Для этого программируем регистры микросхемы UART, задавая формат данных и скорость обмена. Заметим, что модем будет проводить соединение с удаленным модемом как раз на этой скорости. Чем скорость выше, тем быстрее будет происходить обмен данными с удаленным модемом.

Однако при увеличении скорости на плохих телефонных линиях сильно возрастает количество ошибок.

б) Инициализация модема

Передавая модему AT-команды через СОМ-порт, производим его инициализацию. При помощи AT-команд можно установить различные режимы работы модема - выбрать протокол обмена, установить набор диагностических сообщений модема и т.д.

в) Соединение с удаленным модемом

Передаем модему команду набора номера (ATD). В этом случае модем набирает номер и пытается установить связь с удаленным модемом. Или передаем модему команду AT S0=1 для перевода его в режим автоответа. После этого модем ожидает звонка от удаленного модема, а когда он приходит, пытается установить с ним связь.

г) Возможные ответы модема

В зависимости от режима, в котором находится модем, он может передавать компьютеру различные сообщения. Например, если модем производит вызов удаленного модема (AT-команда ATD), то модем может выдать следующие сообщения:

CONNECT - Успешное соединение
BUSY - Номер занят
NO DIALTONE - На линии отсутствует сигнал коммутатора
NO ANSWER - Абонент не отвечает
NO CARRIER - Неудачная попытка установить связь

Когда приходит звонок, модем передает компьютеру сообщение RING, если регистр модема SO равен нулю. В этом случае для ответа на звонок надо послать модему команду АТА. Если модем находится в режиме автоответа и регистр модема SO не равен нулю, то модем автоматически пытается ответить на звонок и может выдать следующие сообщения:

CONNECT - Успешное соединение
NO DIALTONE - Нет несущей частоты удаленного модема
NO CARRIER - Неудачная попытка установить связь

Если модем передал компьютеру сообщение CONNECT, значит, он успешно произвел соединение и теперь работает в режиме передачи данных. Теперь все данные, которые вы передадите модему через СОМ-порт, будут преобразованы модемом в форму, пригодную для передачи по телефонным линиям, и переданы удаленному модему. И наоборот, данные, принятые модемом по телефонной линии, переводятся в цифровую форму и могут быть прочитаны через СОМ-порт, к которому подключен модем.

Если модем передал компьютеру сообщения BUSY, NO DIALTONE,NO ANSWER, NO CARRIER значит, произвести соединение с удаленным модемом не удалось и надо попытаться повторить соединение.

д) Перевод модема в командный режим

После окончания работы коммуникационная программа должна перевести модем в командный режим и передать ему команду положить трубку (АТНО) Для перевода модема в командный режим можно воспользоваться Escape-последовательностью "+++". После того, как модем перешел в командный режим, можно опять передавать ему AT-команды.

е) Сброс сигналов DTR и RTS

Низкий уровень сигналов DTR и RTS сообщает модему, что компьютер не готов к приему данных через СОМ-порт.

При работе с асинхронным последовательным адаптером вы можете использовать механизм прерываний. Так как передача и прием данных модемом представляют собой длительный процесс, то применение прерываний от порта позволяет использовать процессорное время для других нужд.


1.12. Протоколы передачи файлов. Межкомпьютерный обмен файлами

ASCII
Протокол работает без коррекции ошибок. При передаче файлов по телефонным линиям из-за шума принятый файл может отличаться от передаваемого.
Xmodem
Протокол передает данные пакетами по 128 байт. Вместе с пакетом передается контрольная сумма. При получении пакета контрольная сумма вычисляется снова и сравнивается с суммой, вычисленной на передающей машине. Если суммы совпадают, то пакет передан без ошибок.
Xmodem CRC
Протокол с проверкой циклическим избыточным кодом. В нем 8-битовая контрольная сумма заменена на 16-битовый циклический избыточный код. Протокол передает данные пакетами по 128 байт.
Xmodem 1K
Протокол, увеличивающий размер пакета с 128 до 1024 байт. При увеличении количества ошибок размер пакета снова уменьшается. Такое изменение длины пакета позволяет увеличить скорость передачи файлов. В остальном протокол Xmodem 1K совпадает с протоколом Xmodem CRC.
Ymodem
Протокол позволяет передать много файлов за одны передачу. Во время передачи файлов он хранит их имена, размер и дату и может использовать блоки размером 128 или 1024 байт.
Ymodem-G
Протокол предназначен для использования с модемами, автоматически осуществляющими коррекцию ошибок на аппаратном уровне. В этом протоколе упрощена защита от ошибок, т.к. это выполняет сам модем.
Zmodem
Протокол передачи данных, использующий окна. Он осуществляет передачу данных пакетами по несколько штук в окне. При этом принимающий данные компьютер не передает подтверждения или сигнал переноса неправильного пакета, пока не получит все пакеты в окне.
Протокол Zmodem может изменять длину пакета (блока) от 64 до 1024 байт в зависимости от качества линии.
Кроме того протокол обладает следующей полезной особенностью: если при передаче файла произошел сбой на линии и вы не успели передать весь файл, то при повторной передаче этого же файла он автоматически начнет передаваться с того места, где произошел обрыв связи.
Kermit
Протокол был разработан в Колумбийском университете в 1981 году для связи различных типов компьютеров, включая большие компьютеры, мини компьтеры и персональные компьютеры. Для увеличения скорости обмена данными протокол осуществляет предварительную компрессию данных.


2.1. Требования к телекоммуникационному программному обеспечению для обмена данными между компьютерами по телефонному каналу

1. Возможность использования различных портов ввода-вывода и номеров прерываний: COM1-COM4, IRQ3 или IRQ4.

2. Как можно больший выбор скоростей передачи данных по последовательному порту: 75, 110, 300, 1200, 2400, 4800, 9600, 19600, 38400, 57600, 115200 bps (выбор скорости зависит от типа модема, его максимальной скорости и типа микросхемы UART).

3. Возможность изменять следующие параметры:

  • число бит данных (7 или 8)
  • число стоповых бит (1 или 2)
  • тип проверки (на четность, на нечетность, без проверки)

4. Поддержка как можно большего числа протоколов передачи (например, Xmodem, Xmodem CRC, Xmodem 1K, Ymodem, Ymodem G, Zmodem, Kermit и т.п.). При передаче файлов очень важно одно из достоинств протокола Zmodem - восстановление прерванной передачи файлов, однако желательно предусмотреть в программе возможность установления запрета на восстановление передачи.

5. Возможность задания и сохранения данных о конфигурации (префикс и окончание строки набора, строки инициализации, автоответа, отбоя и т.п.).

6. Эмуляция режима Host-компьютера (позволяет организовывать на базе компьютера BBS или банк данных для группового использования).

7. Возможность выбора типа эмулируемого терминала (TTY, ANSI, ANSI-BBS, VT52, VT100, VT102, WISE и др.).

8. Регистрация событий, происходящих в течение сеанса связи в log-файлах.

9. Автоматизация часто повторяющихся последовательностей действий. Использование Script-команд.

10. Ввод и хранение вспомогательной информации, такой как телефонные номера, данные о конфигурации модема и др.

11. Возможность указания каталогов, в которые будут помещаться принятые файлы и файлы, подлежащие передаче.

12. Наличие встроенной системы поиска.

13. Возможность передачи и приема не только данных, но и факсов, голосовых сообщений (при использовании факс-модемов и голосовых факс-модемов).

14. Организация чата (беседы-переписки) между пользователями.

15. Возможность просмотра принятых файлов, не выходя из программы.

16. Наличие режима автодозвона с настройками таких параметров, как количество звонков, время ожидания ответа, длительность паузы перед следующим звонком, обзвон различных абонентов.

17. Возможность вывода на печать.

18. Наличие режима обработки почты.

19. Временный выход из программы.

20. Выдача информации о соединении в любой момент работы.

21. Использование "горячих" клавиш для основных функций.

Кроме того, к программе, реализующей выход в Интернет, добавляется множество дополнительных требований, таких как:

  • возможность указания proxy-сервера,
  • автоматическая передача пароля компании-провайдеру при установлении соединения,
  • графический вьювер,
  • возможность работы с электронной почтой,
  • предупреждение при скачивании определенных типов файлов о возможности наличия в них вирусов,
  • "предугадание" окончания вводимого пути,
  • память посещенных страниц,
  • организация кэша (хранение в отдельных каталогах всей принятой информации).

Однако эти требования касаются в основном удобства пользовательского интерфейса и наличия сервисных функций.


2.2. Структура телекоммуникационных программных пакетов и назначение их основных компонент

Существует огромное множество различных телекоммуникационных программ, предоставляющих пользователю удобное средство работы с модемом - МТЕ, Telix, Comit, Bitcom и т.д.

Основные параметры, по которым оцениваются коммуникационные программы являются: программная эмуляция протоколов коррекции ошибок (MNP), наличие разнообразных протоколов обмена файлами, интерфейс с пользователем.

Типовой телекоммуникационный пакет может включать в свой состав следующие файлы:

Файл с расширением .exe - сама выполняемая коммуникационная программа.

Файл с расширением .doc - руководство пользователя.

Файл с расширением .cnf - файл, содержащий значения конфигурационных параметров (файл конфигурации коммуникационной программы).

Файл с расширением .use или .log - журнал с записями о всех выполненных вызовах и переданных или принятых файлах с указанием даты и времени.

Файл с расширением .cap - файл "захвата". Содержит данные, поступающие из порта связи и выводимые на экране терминала.

Файл с расширением .img или .msg - содержит всю информацию, выводимую в терминальном окне.

Файл с расширением .fon - файл с записями телефонных номеров и параметров связи (телефонная книжка).

МТЕ

Широко распространенная коммуникационная программа фирмы MagicSoft Inc. В МТЕ версии 2.10 программно реализован протокол MNP. Поэтому, если ваш модем не имеет аппаратной реализации протокола MNP, использование МТЕ позволяет установить устойчивую связь с MNP-модемами.

MTE имеет следующие встроенные протоколы обмена файлами: ASCII, Xmodem CRC, Ymodem, Ymodem-G, Zmodem, Kermit.

Telix

Telix, версия 3,12 - удобная коммуникационная программа, поддерживающая много протоколов обмена файлами. В Telix реализованы следующие протоколы: Kermit, Modem7, SEAIink, Telink, Xmodem, Xmodem-1k, Ymodem, Ymodem-G, Zmodem, HSlink, MobyTurbo.

ASCII

Однако Telix имеет один большой недостаток: эта программа не поддерживает программной эмуляции MNP. Вследствие этого ее невозможно использовать на сильно зашумленных линиях с модемами, не обеспечивающими аппаратную коррекцию ошибок.

Comit

Comit, версии 1.27b - удобная коммуникационная программа, часто поставляется в комплекте с модемами, не имеющими аппаратной реализации MNP. Выполняет программную эмуляцию протоколов MNP2, MNP4, MNP5, MNP7.

К сожалению, эта коммуникационная программа имеет очень бедный набор протоколов для обмена файлами. Поддерживаются протоколы Xmodem, Xmodem CRC, Ymodem, Ymodem-G, ASCII.

Bitcom

Bitcom, версии 3,584 - коммуникационная программа, часто поставляемая в комплекте с модемами, не имеющими аппаратной реализации MNP. Выполняет программную эмуляцию протоколов MNP (до MNP5 включительно).

Bitcom поддерживает следующие протоколы обмена файлами: ASCII, Xmodem CRC, Ymodem, Ymodem-G, Kermit, CompuServe Plus.

Следует также отметить, что в Bitcom неудачно реализован интерфейс с пользователем.


2.3. Режимы работы и функции терминальных программ. Команды, реализуемые телекоммуникационными программами

Команды телекоммуникационной программы Telix

Основные команды

Alt + C - Очистка экрана

Alt + X - Выход из Telix

Alt + H - Отбой модема

Alt + P - Изменение параметров связи

Alt + L - Открытие параметров связи

Alt + F - Показ меню некоторых общих операций DOS

Alt + J - Переход в командный процессор DOS

Alt + M - Показ меню разнообразных функций в режиме терминала

Alt + B - Просмотр назад (просмотр старых экранов)

Alt + U - Вкл/Выкл журнала использования

Alt + K - Запуск редактора определения клавиш / макрокоманд клавиатуры

Alt + D - Доступ к директории набора

Alt + Q - Перенабор одного или нескольких номеров, которые были ввдены с помощью команды "список"

Alt + S - Передача файлов

Alt + R - Прием файлов

Alt + Z - Переход на экран помощи в режиме терминала

Alt + T - Изменение времени, в течение которого Telix ожидает соединения

Alt + G - Запуск скрипта (выполнение)

Вспомогательные команды

Alt + E - Вкл/Выкл локального эха

Shift + Tab - Вкл символов перевода к каждому вводу

Ctrl + End - Послать сигнал удаленному главному удаленному компьютеру

Ctrl + @ - Вкл/Выкл принтера

Alt + V - Ввод одной команды DOS или имени файла для выполнения

Alt + A - Запуск редактора

Alt + I - Ввод одной команды DOS или имени файла записи изображений Telix

Alt + Y - Режим беседы

Alt + W - Функция таблицы перекодировки

Alt + = - Вкл/Выкл режима DOORWAY в режиме терминала


2.4. Организация интерфейса для взаимодействия пользователя с телекоммуникационным пакетом программ. Основные пункты меню и их назначение

Взаимодействие пользователя с коммуникационной программой (КП) организуется посредством команд КП и меню. Например, в КП Telix команды выбираются путем нажатия двух клавиш одновременно. А полный перечень команд может быть выведен на экран при нажатии клавиш Alt и Z.

Меню КП позволяет менять конфигурацию программы, которая сохраняется в файле конфигурации.

Типовое меню может включать следующие пункты:

  • Установка экрана
  • Функции терминального режима
  • Общие параметры
  • Установки модема
  • Определение имен каталогов и файлов
  • Опции протоколов передачи файлов
  • Сохранение настроек в файле конфигурации
  • Выход

Рассмотрим эти пункты.

1. Установка экрана

Имеется возможность настроить терминальное окно, задав желаемые размеры, состав и цвет элементов, размещаемых в окне. После выбора нужных режимов вывода на экран и желаемых цветов необходимо выбрать пункт "Сохранение настроек в файле конфигурации".

2. Функции терминального режима

В этом пункте меню могут быть переопределены:

  • параметры связи (скорость передачи данных, количество битов данных, наличие и способ контроля, количество стоповых битов), например 9600, 8/N/1;
  • номер последовательного порта для связи (COM1, COM2, …);
  • стандарт для эмуляции терминала (TTY, ANSI, VT102, …);
  • способ управления потоком данных (программный или аппаратный);

3. Общие параметры

В этом пункте могут быть изменены некоторые общие установки, такие как:

  • включение и отключение звука. При этом для различных режимов и ситуаций могут быть предусмотрены разны звуки;
  • включение и отключение сохранения частично принятых файлов (сохранение или стирание файлов, передача которых была прервана);
  • форматы для показа даты (MMDDYY, DDMMYY, YYMMDD, …) и времени (12-часовой или 24-часовой).

4. Установки модема

К установкам модема относятся:

  • строка инициализации модема. Эта строка посылается в модем при каждом запуске КП. Разные модемы могут потребовать разных строк;
  • ответы модема, которые он посылает при успешном соединении, например CONNECT, если соединение по той или иной причине не произошло, например NO CARRIER, BUSY, NO DIALTONE и т.д.;
  • строка отбоя. Это строка, которую КП передает модему, чтобы он повесил трубку;

5. Определение имен каталогов и файлов

При выборе этого пункта меню могут быть определены:

  • каталог, в который КП загружает принятые файлы;
  • каталог, в котором КП ищет файлы для передачи;
  • каталог, в котором находятся Script-файлы (файлы-сценарии) для выполнения специальных коммуникационных режимов;
  • файл для записи протоколов сеансов связи с абонентами (дата, время, параметры связи…);
  • файл для записи информации, выводимой на экран во время работы КП.

6. Опции протоколов передачи файлов

Наличие такого пункта в меню позволяет конфигурировать внешние и внутренние протоколы передачи файлов. Внешний протокол - это протокол передачи файлов, который реализован за рамками КП. Должны быть определены имя протокола, клавиши для вызова его в меню передачи файлов и способ его вызова.

Для протокола Zmodem могут быть указаны опции - восстановление после сбоя при приеме и передаче. Когда прерванную передачу и прием по протоколу Zmodem нужно продолжить, необходимо включить данные функции. Когда включена функция "восстановление после сбоя при приеме" то. Если файл, принимаемый с помощью протокола Zmodem, уже существует на диске (и он короче, чем файл, передаваемый отправителем), КП сообщит отправителю, что ему следует передать только байты, необходимые для завершения файла. Если включена функция "восстановление после сбоя при передаче", передающая сторона попытается сообщить отправителю, что ему следует продолжить прерванную передачу.

Для протокола Zmodem также можно указать тип передаваемых файлов. Эта функция позволяет определить, является ли файл, передаваемый с помощью протокола Zmodem, двоичным, ASCII или каким-то другим. "Двоичный" означает, что КП убедится, что не происходит никакого конвертирования принимаемых или передаваемых символов ни на одном конце строки. "ASCII" означает, что при приеме, до тех пор, пока другая сторона не заблокирует это, КП будет рассматривать принимаемый файл как текстовый и убедится, что конец каждой строки имеет символ возврата каретки, а за ним символ перевода строки путем добавления символов возврата каретки, если файл имеет только символы перевода строки. Установка ASCII во время передачи заставит КП сообщить другой системе, что ей следует производить конвертирование на конце каждой строки, хотя другая сторона может и заблокировать это. Наконец, установка "Другие" заставит КП рассматривать файл как двоичный до тех пор, пока другая система не покажет что-то другое. Нельзя применять установку ASCII для файлов, которые не являются текстовыми файлами ASCII, так как двоичные файлы быть испорчены.

Во всех случаях после установки необходимых конфигурационных значений следует выбрать и выполнить пункт "Сохранение настроек в файле конфигурации".

Последний пункт "Выход" позволяет вернуться в терминальный режим.


2.5. Алгоритм действий пользователя при компьютерном приеме и передаче файлов по коммутируемой телефонной сети общего пользования

Примерная блок-схема алгоритма действий пользователа для установления связи и ведения диалога с удаленным пользователем:

Рис. 2.5.1. Алгоритм действий пользователя для установления связи и ведения диалога с удаленным пользователем

Примерная блок-схема алгоритма действий пользователя при передаче файлов удаленному абоненту:

Рис. 2.5.2. Алгоритм действий пользователя при передаче файлов удаленному абоненту

Примерная блок-схема алгоритма действий пользователя при приеме файлов от удаленного абонента:

Рис. 2.5.3. Алгоритм действий пользователя при приеме файлов от удаленного абонента


Дисциплина
"Программное обеспечение систем передачи данных"

 Содержание

2.6. Языковые и программные средства для реализации телекоммуникационных прикладных задач

Многие телекоммуникационные пакеты имеют в своем составе внутренний язык и транслятор, которые позволяют легко и быстро создавать программы, ориентированные на различные прикладные задачи. Язык включает аппарат подпрограмм; операторы условного и безусловного переходов; операторы для организации циклических конструкций, диалога с пользователем, оформления экрана; встроенные функции для организации сеансов связи и обмена данными с удаленными абонентами и другие средства.

Рассмотрим один из таких языков - внутренний SALT-язык пакета TELIX (Script Application Language for Telix).

Общие сведения по SALT-языку

Внутренний SALT-язык пакета TELIX обеспечивает более гибкую работу в среде пакета при организации сеансов связи с удаленными абонентами. Он позволяет легко и быстро создавать SLT-документы (SLT-файлы), ориентированные на различные прикладные задачи.

Это язык высокого уровня, относится к классу C-подобных языков программирования. Включает большой набор встроенных функций, ориентированных на различного рода телекоммуникационные задачи, а также множество предопределенных переменных.

Текст программы на SALT-языке называется SLT-документом или SLT-модулем (файлом). Он представляет собой последовательность предложений SALT-языка и имеет ASCII-формат. Файл, содержащий SALT-документ, может иметь любое имя, но в качестве его расширения рекомендуется использовать SLT, которое является значением по умолчанию для пакета TELIX. Для выполнения исходный SLT-файл должен быть откомпилирован автономным CS-компилятором с SALT-языка (CS.EXE).

Результатом успешной компиляции является откомпилированный (загрузочный) SLC-файл, имеющий одинаковое с исходным файлом имя и расширение SLC.

В случае обнаружения первой ошибки компиляции выводится: имя исходного файла, номер строки с ошибкой и тип ошибки. Дальнейшая компиляция при этом прекращается.

После устранения всех обнаруженных ошибок компилятор создает загрузочный SLC-файл.

Ключевые слова языка являются буквонезависимыми и не могут использоваться в качестве идентификаторов. Имена переменных, функций и констант также буквонезависимы.

Основной логической единицей SALT-языка является предложение, которое заканчивается точкой с запятой. Группы предложений в документе берутся в фигурные скобки, которые являются блочными ограничителями языка.

Логическая структура SLT-документа

В общем случае SLT-документ состоит из набора определений глобальных переменных, набора определений функций пользователя, заголовка главной функции (Main) и самого тела документа, содержащего допустимые конструкции SALT-языка. Определения первых двух наборов могут чередоваться между собой, если это не нарушает логику документа в связи с принципами глобальности и локальности определений.

Для пояснения SLT-документов, как правило, используются комментарии. Комментарии не обрабатываются компилятором. Текст одного комментария располагается между двумя слешами и концом строки документа.

Например:

// Пример сценария на SALT-языке

Логическая структура SLT-документа:

[ <описания глобальных переменных> ]
[ <описания функций> ]
Main ( ) { основное тело SLT-документа }

Конструкции SALT-языка

Переменные

SALT-язык допускает использование целочисленных и символьных переменных. В качестве идентификатора переменных используются имена длиной до 31 символа из алфавита a-z, A-Z, 0-9, _. Первый символ имени не должен быть цифрой.

Примеры:

Number
A263
GUT
Name_File

В соответствии с местом описания в SLT-документе переменные могут быть глобальными и локальными.

Сферой действия глобальной переменной является часть SLT-документа от точки ее определения до конца документа.

Сферой действия локальной переменной является область функции, в которой она определена.

Допускается использование целочисленных и символьных переменных.

Определение целочисленных переменных:

Int <имя_1>, …, <имя_k>;

В определении можно задавать начальные значения переменных:

Int <имя_1> = <значение_1>, …, <имя_k> = <значение_k>;

где <значение_1>…<значение_k> - целочисленные константы.

Определение символьных переменных:

Str <имя_1> [N_1], …, <имя_k> [N_k];

где 0 < N <= 32767 - длина значения символьной константы.

Можно задать начальные значения:

Str <имя_1> [N_1] = <значение_1>, …, <имя_k> [N_k] = <значение_k>;

где <значение_1> … <значение_k> - символьные константы.

Примеры:

Int A, B, C;
Int D = 5, E = -5;
Str Number[7], Name[12];
Str Telix[10] = "CONNECTION"

Константы

Целочисленная константа может быть десятичной или шестнадцатеричной.

Десятичная константа представляет собой последовательность десятичных цифр (0-9).

Шестнадцатеричная константа представляет собой последовательность шестнадцатеричных цифр (0-9, A-F) и начинается идентификатором "0x".

Примеры:

1942
-384789
0121002207
0x2942
0x3869F
0xABCDE

Символьная константа представляет собой последовательность ASCII-символов, ограниченную кавычками.

Функции (пользовательские)

Определяются в SLT-документе непосредственно пользователем и используются аналогично встроенной функции языка. Допускается использование вложенных функций и каждое определение констант, переменных и функций, сделанное в теле данной функции пользователя, является для SLT-документа, использующего эту функцию, локальным. Можно создавать библиотеки функций.

Определение пользовательской функции:

<имя функции> ( [ <список формальных параметров> ] )
{ [ <описания локальных переменных> ]
[ <описания функций> ]
[ <предложения SALT-языка> ] }

Имя функции - определяется требованиями языка к идентификатору и должно быть уникальным.

Элементы списка параметров разделяются запятыми и имеют формат:

<тип><идентификатор>

где тип может быть Int или Str.

Количество элементов списка не должно превышать 12; допускается отсутствие формальных параметров.

Каждая функция, как правило, заканчивается предложением

RETURN [<выражение>];

по которому в точку вызова функции возвращается вычисленное значение <выражения>, имеющее тот же тип (Int или Str), что и точка вызова. При отсутствии <выражения> возвращается пустое значение.

Для вызова функции указывается ее имя и в скобках - значения для формальных параметров (если таковые имеются).

Кроме пользовательских функций в SALT-языке представлены встроенные функции. Встроенные функции доступны любому SLT-документу без специального их определения. Они позволяют задать операции для работы с монитором, принтером, клавиатурой. COM-портом, с датой, временем, таймером и др.

Предложения SALT-языка

Простейшим типом предложения языка является выражение, имеющее формат

<выражение>;

В качестве выражения выступает конструкция из констант, переменных, вызовов функций и операторов. Допускается использование двадцати операторов.

Знак оператора | Назначение | Приоритет выполнения
- | знак отрицательного числа | 1
! или NOT | логическое НЕ | 1
++ | инкремент числа | 2
-- | декремент числа | 2
* | произведение | 3
/ | деление | 3
% | остаток по модулю | 3
+ | сложение | 4
- | вычитание | 4
< | меньше | 5
> | больше | 5
<= | меньше или равно | 5
>= | больше или равно | 5
== | тождество | 6
!= | неравенство | 6
& | побитная операция И | 7
| | побитная операция ИЛИ | 8
&& или AND | логическая операция И | 9
|| или OR | логическая операция ИЛИ | 10
= | операция присваивания | 11

Приоритет операций можно переопределить посредством круглых скобок.

Примеры:

A != (X * Y + Z / K) - 85
X = (Y + 51 * Z) / P
P = X % 5
A <= B
C == B * (X + Y / Z)
Y = -51 * 2 * (P * L - 8)

Примеры предложения-выражения:

Artur = 130288;
Text = "TELIX";
X = 51 * (X + Y / K) / P + 93;

IF-предложение

IF-предложение имеет два формата:

1)

IF ( <выражение> ) { <предложение или группа предложений> };

Предложение или группа предложений выполняются только тогда, когда значение <выражения> отлично от нуля (истинно), в противном случае выполняется следующее за IF предложение;

2)

IF ( <выражение> ) { <предложение или группа предложений 1> }; ELSE { <предложение или группа предложений 2> };

Выполняется <предложение или группа предложений 1>, если значение <выражения> истинно, в противном случае выполняется <предложение или группа предложений 2>.

Допускается использование вложенных IF-предложений.

Примеры:

IF (C > 0) Y = X + 51 * Z;
IF (A / 5 <= 1995 / X) B = (C + D * M) /
      P; ELSE A = X;
IF (A > 0) B = 5; ELSE
      IF (A < 0) B = -5; ELSE
      B = 0;

WHILE-предложение

WHILE-предложение имеет следующий формат:

WHILE ( <выражение> ) { <предложение или группа предложений> };

Выполняется <предложение или группа предложений> до тех пор, пока значение <выражения> истинно. Если же <выражение> ложно при первом же его вычислении, то предложение не выполняется ни разу.

GOTO-предложение

GOTO-предложение обеспечивает безусловный переход в SLT-документе и имеет следующий формат:

GOTO <метка>;

В качестве <метки>используется идентификатор, определяющий в документе место, куда передается управление.

Идентификатор задается следующим образом:

<идентификатор>:

DO-WHILE-предложение

DO-WHILE-предложение имеет следующий формат:

DO { <предложение или группа предложений> } WHILE ( <выражение> );

<Предложение или группа предложений> выполняются до тех пор, пока <выражение> истинно. Отличие DO-WHILE-предложения от WHILE-предложения заключается в том, что в случае DO-WHILE-предложения <предложение или группа предложений> обязательно выполнится хотя бы один раз, даже если <выражение> ложно при первом же его вычислении.

FOR-предложение

FOR-предложение является одним из наиболее распространенных средств организации циклических конструкций.

FOR ( <выражение 1>; <выражение 2>; <выражение 3> ) { <предложение или группа предложений> };

где
<выражение 1> инициализирует переменную цикла, присваивая ей начальное значение;
<выражение 3> определяет приращение шага цикла;
<выражение 2> задает логическое завершение цикла;

<Предложение или группа предложений> будет выполняться до тех пор, пока <выражение 2> истинно. <Выражение 2> может представлять сложное логическое условие.

Допускается вложение циклов.

BREAK-предложение

BREAK-предложение имеет формат:

BREAK;

Служит для выхода из циклических участков SLT-документа. После выхода из цикла выполняется следующее за ним предложение документа.

Если BREAK-предложение используется в конструкции вложенных циклов, то оно осуществляет выход только непосредственно из цикла, в котором оно определено.

CONTINUE-предложение

CONTINUE-предложение имеет формат:

CONTINUE;

Используется подобно BREAK-предложению только в теле циклической конструкции и предназначено для пропуска следующих за ним предложений тела цикла.

Приведем пример простейшего SLT-документа:

// Primer 1
Str S[10] = "SALT-TELIX";
F (Int X, Int
      Y)
{
Int Z;
Z = (X + Y) * 2 + X * Y + 54;
RETURN Z;
}
Main ()
{
Prints (S);
Printn (F (3, 7));
}

В результате выполнения данного примера (после обработки его CS-компилятором) производится вывод символьной строки и результата выполнения пользовательской функции.


3.1. Факс-модемная технология. Назначение факс-модемов. Основные характеристики факс-модемов

Факсимильная передача изображений

Для передачи и воспроизведения на расстоянии неподвижных изображений предназначена система факсимильной связи. Передаваемым изображением может быть рукописный, машинописный или типографский текст, фотография, чертеж, карта и др.

Факсимильное сообщение следует считать непрерывным - любой участок изображения сколь угодно малых размеров может иметь любое значение оптической плотности в некотором диапазоне плотностей. Ограниченные возможности зрения позволяют дискретизировать непрерывное факсимильное сообщение и тем самым снизить его избыточность до разумной величины. Дискретизация производится по площади изображения и по оптической плотности отдельных участков с учетом разрешающей способности и контрастной чувствительности глаза.

Суть дискретизации по площади заключается в разложении всей площади изображения на отдельные элементарные площадки. Каждая площадка характеризуется одним единственным значением оптической плотности, получаемым путем усреднения плотностей в пределах этой площадки.

В факсимильных аппаратах общего назначения размер элементарной площадки должен составлять около 0,1 мм.

Дискретизация по оптической плотности заключается в округлении полученного значения плотности элементарной площадки оригинала до ближайшей фиксированной величины. В результате на копии будут воспроизведены только определенные, фиксированные плотности, число которых сравнительно невелико. Для качественной передачи художественной фотографии необходимо передать и воспроизвести на копии 10-15 градаций оптической плотности, отличающихся друг от друга. При передаче двух-градационных изображений дискретизацию производят двумя уровнями оптической плотности - черным и белым.

МККТТ определил четыре группы стандартных факсимильных аппаратов, классифицируемых по типу сканируемого сигнала, используемому методу модуляции и коммуникационным характеристикам.

Аппараты группы G1 кодируют и передают аналоговые сигналы. Определена стандартная частота сканирования линий - 180 линий в минуту, исходя из характеристик канала связи, могут быть установлены другие значения скорости. Факсимильные аппараты группы 1 работают с разрешением 3,85 линии на 1 мм и затрачивают примерно 6 мин на передачу документа формата A4. Только на выделенных линиях аппараты группы 1 могут использовать амплитудную модуляцию. Частота несущей должна находиться в интервале 1300-1900 Гц. Во время передачи самый высокий уровень сигнала соответствует черному цвету, самый низкий - белому. Как на выделенных, так и на коммутируемых линиях, аппараты группы 1 могут использовать частотную модуляцию. Для коммутируемых линий частота несущей равна 1700 Гц. Для выделенных линий частота несущей принимается 1900 Гц, частоты 1500 Гц и 2300 Гц для белого и черного цветов.

Аппараты группы G2 кодируют и передают аналоговые сигналы, как и аппараты группы 1, но используют более эффективные методы модуляции. Это позволяет обеспечить стандартную скорость сканирования 360 линий в минуту. Аппараты группы 2 обеспечивают тоже самое разрешение, что и аппараты первой группы, но затрачивают от 2 до 3 минут на передачу того же самого изображения. Амплитудная модуляция приводит к образованию двух боковых полос, которые являются зеркальным отображением друг друга и несут одинаковую информацию. Факсимильные аппараты группы 2 предназначены для работы в сетях телефонного типа, использующих амплитудную модуляцию с частично подавленной боковой полосой. Модуляционная система такого типа подавляет одну из избыточных боковых полос, уменьшая полную ширину полосы частот сигнала, обеспечивая тем самым возможность расширения информационной полосы частот. Аппараты группы 2 используют несущую с частотой 2100 Гц. Уровень белого соответствует максимальной амплитуде сигнала, а уровень черного - минимальной амплитуде или вообще отсутствию сигнала.

Цифровые факсимильные аппараты

Развитие техники связи идет в направлении цифровизации. Это связано с тем, что цифровые системы имеют ряд существенных преимуществ по сравнению с аналоговыми: возможностью регенерации сигнала на промежуточных пунктах; универсальностью способа передачи, что позволяет передавать факсимильную информацию наряду с другими видами сообщений по единой цифровой системе связи; возможностью сокращения времени передачи за счет оптимального кодирования факсимильного сигнала; применением хорошо развитой цифровой элементной базы при создании новых образцов цифровой факсимильной аппаратуры; возможностью сопряжения цифровых факсимильных аппаратов с ЭВМ в целях обработки факсимильной информации.

Факсимильные аппараты группы G3 знаменуют переход от аналоговых к цифровым методам передачи факсимильных сообщений и существенно отличаются от аппаратов групп 1 и 2. Цифровые факсимильные аппараты рассматривают изображение как набор дискретных элементов (пикселей). Каждый пиксель может быть или черным (ему соответствует двоичная 1) или белым (двоичный 0) - промежуточные полутона не допускаются. Последовательность двоичных цифр, вырабатываемая при оцифровке изображения, может быть сжата, передана по каналу связи и проконтролирована на наличие ошибок с использованием любых методов, применяемых в модемах. Все аппараты группы 3 обеспечивают стандартное вертикальное разрешение 3,85 линии на миллиметр. Возможна установка более высокого разрешения - 7,7 линии на миллиметр. В обоих случаях разрешение по горизонтали устанавливается на уровне 1728 пикселей для стандартной линии сканирования длиной 215 мм, что эквивалентно 8 пикселям на миллиметр. В модификации стандарта T.4, датированной 1992 г., добавляются новые режимы кодирования с более высоким разрешением: 15,4 линии на миллиметр по вертикали и 16 пикселей на миллиметр по горизонтали.

В цифровых факсимильных аппаратах блоки электрооптического анализа и синтез-дискретные (в качестве преобразователей свет-сигнал используется, например, ПЗС-линейка и термопечатающая линейка).

В результате цифровых преобразований получается последовательность единичных элементов (двоичный код), поэтому скорость передачи факсимильной информации измеряют количеством бит в секунду (бит/с).

Цифровые данные, формирующие каждую линию сканирования, уплотняются перед передачей. Поэтому время, затрачиваемое на передачу одной линии сканирования может изменяться от линии к линии внутри некоторого произвольно определяемого интервала. Стандарт T.4 рекомендует затрачивать на передачу каждой линии сканирования не менее 20 мс, хотя допустимо изменение этого параметра в пределах от 0 до 40 мс. Максимальное время передачи линии сканирования не должно превышать 5 с.

Внутри линии сканирования группы смежных черных и белых пикселей чередуются. Для обеспечения синхронизации цветов воспроизводимого и передаваемого изображений все линии должны начинаться с группы белых пикселей. Если линия начинается с черного пикселя, передается цепочка белых пикселей нулевой длины.

Применение аппаратов группы G4 в основном концентрируется на интеграции службы факсимильной связи с другими службами связи и передачи сообщений. Служба факсимильной связи с использованием аппаратов группы 4 добавляет некоторые полезные усовершенствования в передачу факсимильных сообщений, не отказываясь при этом от концепции растровой графики. Определены, например, базовые величины разрешения: 200, 300 и 400 точек на дюйм. Добавлен режим передачи без сжатия данных, позволяющий осуществлять передачу изображения, не применяя обычные алгоритмы сжатия. Новый режим, называемый смешанным режимом, обеспечивает пересылку текста как данных и передачу графических изображений в растровой форме.

Стандарты для аппаратов группы 4 ввели три класса факсимильных терминалов в соответствии с их рабочими характеристиками. Терминалы, которые просто посылают и принимают факсимильные сообщения, определяются как терминалы класса 1. Терминалы класса 2 могут получать как телексы (текстовые сообщения, пересылаемые между факсимильными аппаратами), так и смешанные сообщения. И, наконец, терминалы. Формирующие группу 3, могут создавать, передавать и принимать сообщения в любой форме.

Назначение факс-модемов

По мере развития вычислительной техники многие фирмы стали выпускать платы расширения к персональным компьютерам (ПК), позволяющие ПК обмениваться факсимильными сообщениями с факсимильными аппаратами группы 3. Такая плата получила название факс-платы. Выпускались две их разновидности, позволяющие только передавать факсы или передавать и принимать их.

Так как факс-платы основывались на тех же принципах передачи информации, что и обыкновенные модемы, то эти два устройства были объединены вместе и названы факс-модемом.

Имея компьютер, сканер и печатающее устройство, можно не приобретать факсимильный аппарат. Достаточно дополнительно приобрести только факс-модем. Подключив его к компьютеру, получаем факс-машину, которая реализует все функции факсимильного аппарата.

Более того, комбинация компьютера в факс-модем имеет несколько преимуществ перед традиционными факсимильными аппаратами:

  • если в качестве печатающего устройства используется струйный или лазерный принтер, то качество принятых и выведенных на принтер факсимильных сообщений, как правило выше, чем при использовании обычных факсимильных аппаратов;
  • факсимильный аппарат не может выполнять другие функции, кроме передачи образов бумажных документов. Компьютер, сканер, факс-модем и принтер можно задействовать для решения других задач;
  • факс-модем позволяет передавать не только факсимильные сообщения, но и обычные файлы, работая как обычный модем;
  • установив факс-модем в локальной сети, можно обеспечить его совместное использование пользователями, что позволяет сэкономить денежные средства;
  • принятое компьютером факсимильное сообщение может быть передано на другую факс-машину без потери качества, так как компьютер передает принятый "электронный образ" документа.


3.2. Рекомендации ITU-T для факс-модемов. Управление факс-модемами

Рекомендация для факс-модемов

Факс-модемы представляют собой более сложные устройства, чем обычные модемы. Они предназначены для работы с факсимильными аппаратами, и поэтому должны поддерживать все протоколы, с которыми работают факсимильные аппараты группы 3.

Наиболее распространенные рекомендации для факс-модемов представлены в следующей таблице.

Рекомендация | Скорость передачи (бит/с)
V.21 | 300
V.17 | 9600, 14400
V.27bis | 4800
V.27ter | 2400, 4800
V.29 | 7200, 9600

Протокол V.21 применяется только на этапе установления связи. Далее начинают работу другие протоколы: V.17, V.27bis, V.27ter или V.29. Эти протоколы обеспечивают прием или передачу факсимильного сообщения в полудуплексном режиме. Необходимо, чтобы факс-модем поддерживал кроме V.21 как минимум одну рекомендацию по передаче данных по телефонным линиям.

Кроме указанных протоколов факс модем должен соответствовать рекомендациям МККТТ Т.4 и Т.30 из перечня рекомендаций серии Т "Оконечное оборудование и протоколы для телематических служб".

Рассмотрим более подробно все рассмотренные протоколы.

Протокол V.21

Дуплексный протокол с частотным разделением каналов и частотной модуляцией. Скорость передачи данных 300 бит/с. Предназначен для использования как в коммутируемых телефонных сетях общего пользования, так и на арендованных линиях. Так как модуляция двоичных данных осуществляется путем изменения частоты сигнала, то скорость модуляции равна скорости передачи данных. На нижнем канале (его обычно использует для передачи вызывающий модем) "1" передается частотой 980 Гц, а "0" - 1180 Гц. На верхнем канале (передает отвечающий модем) "1" передается частотой 1650 Гц, а "0" - 1850 Гц. Данные могут передаваться в синхронном либо асинхронном режиме.

Протокол V.21 используется факсимильными аппаратами группы 3 (для передачи управляющих команд при факсимильной связи используется только верхний канал) и факс-модемами на этапе установления связи. Сама передача факсимильных сообщений происходит уже в соответствии с другим, более эффективным протоколом.

Протокол V.17

Полудуплексный факсимильный протокол для использования в коммутируемых телефонных сетях общего пользования. В нем используется модуляция с решетчатым кодированием, или треллис-модуляция (TCM - Trellis Coded Modulation). TCM является вариантом многопозиционной амплитудно-фазовой модуляции, которую называют еще квадратурной амплитудной модуляцией (QAM -Quadrature Amplitude Modulation). Здесь изменяется и фаза, и амплитуда сигнала, однако, для повышения помехозащищенности передачи информации, вводится избыточность, что позволяет в процессе демодуляции использовать более совершенный алгоритм декодирования.

Частота несущего сигнала - 1800 Гц, модуляционная скорость 2400 Бод. Протокол имеет режимы 16-ТСМ, 32-ТСМ, 64-ТСМ и 128-ТСМ. Соответственно информационная скорость может быть 7200, 9600, 12000 и 14400 бит/с.

Протокол V.27ter

В этом протоколе применяется фазоразностная модуляция (DPSK - Differential Phase Shift Keying) с частотой несущего сигнала 1800 Гц. Могут использоваться два режима с разными информационными скоростями: 2400 и 4800 бит/с. Информационная скорость 2400 бит/с достигается модуляционной скоростью 1200 Бод и кодированием дибита (4-поэиционная DPSK) а 4800 бит/с - скоростью 1600 бод и кодированием трибита (8-позиционная DPSK).

Протоколы данного семейства - V.27 и V.27bis используются редко. Они отличаются от V.27ter, главным образом, типом канала - выделенного четырехпроводного, для которого они предназначены.

Протокол V.29

Протокол для дуплексной работы ее скоростью передачи данных 9600 бит/с по 4-проводным арендованным каналам тональной частоты, удовлетворяющим рекомендациям М.1020 или М.1025 (рекомендации о характеристиках каналов особого качества). В протоколе применяется квадратурная амплитудная модуляция. Частота несущего сигнала - 1700 Гц, модуляционная скорость - 2400 Бод. Имеет режимы 8- и 16- позиционной QAM. Соответственно информационная скорость может быть 7200 и 9600 бит/с. Предусмотрена возможность снижения скорости до 7200 или 4800 бит/с. В состав модема, реализующего этот протокол, входит адаптивный автоматический корректор, а также скремблер. Может входить также мультиплексор для разделения общего потока (например со скоростью 9600 бит/с) на несколько подканалов с меньшими скоростями (например, 2400 и 4800 бит/с).

Рекомендация Т.4

Рекомендация Т.4 определяет стандарты факсимильной аппаратуры группы 3 для передачи документов: размер листа передаваемого документа, направление сканирования документа, разрешение, алгоритмы сжатия передаваемой графической информации и др. Например, для формата А4 (210х297 мм) зона гарантированного воспроизведения должна составлять 196,6x281.46 мм, направление развертки должно быть слева направо, сверху вниз; стандартная разрешающая способность - 3,85 строки/мм, минимальное время передачи всей кодированной строки развертки 20 мс, максимальное - не более 5 секунд; в качестве алгоритма сжатия определена одномерная схема кодирования длин серий (допускается использование двумерной схемы кодирования). Аппаратура группы 3, работающая по коммутируемой телефонной сети общего пользования, должна использовать сигнал модуляции, скремблера, коррекции и синхронизации, определенные в рекомендации V.27ter. При работе по арендованным каналам или коммутируемым цепям высокого качества указанные сигналы могут определяться Рекомендацией V.29.

Рекомендация T.30

Рекомендация T.30 "Процедуры для факсимильной передачи документов по коммутируемой телефонной сети общего пользования" регламентирует процедуру установления соединения, согласование параметров связи, передачу образа документа и завершение связи. Так, установление соединения может осуществляться вручную или автоматически; передаче сообщения предшествует процедура предсообщения, которая должна осуществлять идентификацию возможностей и контроль выбранных условий. Процедура передачи сообщения должна отвечать требованиям соответствующей Рекомендации, касающейся оборудования. В процессе передачи сообщения должно обеспечиваться управление синхронизацией, обнаружением и исправлением ошибок, а также контролем линии. Завершение связи должно включать последовательное выполнение двух этапов: процедуры пост-сообщения, обрабатывающей сигналы "конец сообщения", "многостраничная передача" и "конец факсимильной процедуры", и этапа разъединения соединения, выполняемого вручную или автоматически.

И, наконец, в дополнение к расширенному набору AT-команд факс-модем должен поддерживать набор команд класса 1 или класса 2, предназначенных для управления факсом.

Управление факс-модемами

Подобно модемам, поддерживающими набор AT-команд управления, факс-модемы также используют специальные AT-команды. В настоящее время существуют специальные два различных стандарта на такие команды. Они называются командами класса 1 и класса 2. Факс-модем может поддерживать один или оба класса команд управления.

Чтобы определить без документации, является ли модем факс-модемом, а также узнать, какие классы команд управления он поддерживает, надо ввести команду

AT+FCLASS=?

В ответ на эту команду модем может вернуть строку, в которой через запятую будут перечислены цифры 0,1 и 2. Например, можно получить строку

0, 1

или

0, 1, 2.

Цифра 0 означает, что факс-модем может работать в режиме обычного модема и передавать данные. Цифры 1 и 2 означают, что модем поддерживает команды класса 1 и 2 соответственно.

Если модем вернул в ответ на команду AT+FCLASS=? строку

ERROR

то это означает, что он не может работать в режиме обмена факсимильными сообщениями.

Если модем вернул в ответ на команду AT+FCLASS=? строку

ОК

то, возможно, такой модем может быть использован в качестве факс модема. Подробную информацию о возможностях модема можно получить ив документации или с помощью команды ATI.

Обычно после включения питания факс-модем работает как обычный модем и не реагирует на команды класса 1 и 2 (кроме команды +FCLASS). Чтобы переключить факс-модем в режим факсимильной связи, необходимо ввести команду

AT+FCLASS=1

или команду

AT+FCLASS=2

После ввода первой команды факс-модем начинает воспринимать команды класса 1, но не реагирует на команды класса 2. Если введена вторая команда, факс-модем станет откликаться на команды класса 2, но не перестанет реагировать на команды класса 1. Передав модему команду

AT+FCLASS=0

можно вернуть его в режим обычного модема.

Чтобы узнать текущий режим работы факс-модема, надо передать ему команду

AT+FCLASS?

Рассмотрим некоторые команды для факс-модемов:

AT+FTH | Инициализирует передачу данных в соответствии с протоколом HDLC
AT+FTM | Передача факсимильных данных
AT+FRM | Прием факсимильных данных
AT+FTS | Передача паузы
AT-FRS | Прием паузы
AT+FAA | Выбор режима автоматического ответа
AT+FMFR? | Выдать идентификатор фирмы-изготовителя факс-модема
AT+FMDL? | Выдать идентификатор модели факс-модема
AT+FREV? | Выдать идентификатор версии факс-модема
AT+FDCC? | Выдать параметры устройства
AT+FDIS? | Выдать параметры текущего сеанса связи
AT+FDCS? | Выдать согласованные параметры текущего сеанса связи
AT+FLID? | Выдать идентификатор станции
AT+FPTS? | Состояние передачи страницы
AT+FCR? | Вовможность приема факсимильных сообщений
AT+FAA? | Режим автоответа
AT+FBUF? | Размер буфера факс-модема
AT+FPHCTO? | Определение тайм-аута
AT+FAXERR? | Значение кода ошибки
AT+FBOR? | Порядок следования опт данных
AT+FDT | Передача данных
AT+FET=N | Передать пунктуацию страницы
AT+FDR | Начать или продолжить прием данных
AT+FK | Завершить сеанс связи

Пример:

АТ+FMFR?
 ROCKWELL
OK
 AT+FMDL?
 RC32ACL
OK
 AT+FREV?
 CES-03 931216
OK

Приведенный пример показывает, как использовать команды класса 2 для определения фирмы-изготовителя, идентификатора и модификации факс-модема.


3.3. Требования к телекоммуникационному программному обеспечению для обмена факсимильными сообщениями между факс-машинами по телефонному каналу

Разработка собственного программного обеспечения для обмена факсимильными сообщениями является достаточно сложной задачей, требующей знания Рекомендаций ITU-T (МККТТ) Т.4 и Т.30 и навыков по составлению драйверов для различных операционных сред.

В настоящее время имеется широкий выбор приложений, предназначенных для подготовки, отправки и приема факсимильных сообщений как из среды операционной системы Windows, так и из среды MS-DOS.

Назовем основные требования, которым должны отвечать такие программыные средства и кратко рассмотрим некоторые из них.

Первое требование. Возможность задания способа подключения факс-модема:

  • номер COM-порта, если факс-модем установлен в компьютере;
  • работа в сети, если факс-модем установлен на другом компьютере;
  • …

Программа должна проверить, действительно ли к компьютеру подключен факс-модем и, если необходимо, осуществить его настройку.

Второе требование. Настройка факс-модема:

  • ввод кода страны, региона и номера вашего факс-модема;
  • установка режима ответа факс-модема на входящие телефонные звонки. Например, факс-модем не будет отвечать на входящие звонки и не станет принимать факсимильные сообщения от удаленного модема; ручной ответ на входящие вызовы; автоматический ответ на входящие вызовы и прием факсимильного сообщения, при этом может быть указано количество звонков, после которого факс-модем снимет трубку и установит соединение;
  • режим работы динамика факс-модема и громкость звуковых сигналов. Например, динамик постоянно отключен/включен, включен только на время набора номера;
  • тип набора: импульсный или тоновый.

Третье требование. Передача факсимильного сообщения. Возможность настроек - время передачи факсимильного сообщения (как можно быстрее, в заданное время или передать по самому дешевому тарифу).

Четвертое требование. Автоматический и ручной прием факсимильных сообщений. Автоматическая печать факса после получения.

Пятое требование. Наличие телефонной книги. Возможность автоматической отправки факсимильного сообщения по отмеченным телефонным номерам абонентов.

Шестое требование. Просмотр и печать полученных факсимильных сообщений в различных масштабах.

Седьмое требование. Наличие встроенных редакторов для составления сообщений. Комбинирование файлов и использование шаблонов при составлении сообщений.

Восьмое требование. Протоколирование сеансов связи по передаче и приему факсимильных сообщений.

Программы для управления факс-модемами из среды операционной системы MS-DOS

Имеется большое количество программ MS-DOS, предназначенных для посылки и приема факсимильных сообщений, например, программа BitFax for DOS.

BitFax является полностью оснащенной программой для работы с факсимильными сообщениями для операционной системы MS-DOS. Среди возможностей BitFax:

  • отправление и получение факсимильных сообщений в фоновом режиме
  • автоматическая печать факсимильного сообщения после получения
  • просмотр и печать полученного изображения
  • автоматическое определение принимаемых сигналов: факс-связь, модем-связь, голос
  • обработка различных типов файлов
  • отправление нескольких файлов за один сеанс связи
  • "телефонная книга"
  • совместимость с текстовыми редакторами
  • комбинирование файлов на одной странице
  • сеанс связи, запланированный по времени
  • автоповтор набора номера при занятой линии
  • просмотр текстовых, графических и факс файлов
  • общий отчет и протокол передач (программы Bitfaxrx.log и Bitfaxtx.log)
  • использование заготовок писем
  • сохранение экрана и запись текста печати в файл

Однако операционная система MS-DOS мало приспособлена для работы с факсимильными сообщениями. Отсутствие поддержки многих шрифтов может существенно затруднить процесс подготовки и передачи факсимильных сообщений в том числе с символами кириллицы.

Программы для посылки и приема факсимильных сообщений in среды операционной системы Windows

Среди приложений для факс-модемов для ОС Windows 3.1 следует отметить продукцию фирмы Delrina: WinFax Lite и WinFax PRO 4.0. Эти приложения, как и приложение Microsoft AT Work PC Fax, позволяют передавать факсимильное сообщение так же просто, как распечатать документ на принтере.

WinFax Lite - небольшое приложение, обеспечивающее основные возможности передачи и приема факсимильных сообщений. Отличается простотой, удобством использования и небольшими требованиями к ресурсам компьютера.

WinFax PRO 4.0 - сложное профессиональное приложение, предназначенное для управления факс-модемами. Может перенаправлять принятые факсимильные сообщения по другому телефонному номеру. Предусмотрена возможность автоматического распознавания текста. Графическое изображение принятого факсимильного сообщения может быть переведено в текстовую форму, пригодную для дальнейшей обработки обычным текстовым редактором.

WinFax является программой для операционных систем Windows 9Х/NT. Оснащена всеми необходимыми возможностями, обеспечивает большее разнообразие особенностей индивидуализации и автоматизации посылки факсов.

Позволяет просматривать и изменять факсы во время их создания, оформить титульный лист и т.д. Удобный набор номеров факсимильных аппаратов с непосредственным использованием телефонной книги.

Факсы передаются быстрее и с улучшенным факсимильным сжатием. WinFax обнаруживает и исправляет помехи, которые могут привести к недостаточному качеству передачи. Возможно посылать факсы с лазерным качеством с высокой вероятностью получения такого же качества копии на другой факс машине.

Кроме того, WinFax обладает следующими особенностями:

  • Вам не обязательно иметь модем непосредственно на вашем компьютере. Вы можете посылать и принимать факсы через модем на ведущей станции в Вашей локальной сети.
  • Расширенный диалог посылки данных.
  • Расширенная телефонная книга. Интеграция с MS Outlook. Возможность использования базы данных под управлением MS Access в качестве телефонной книги.
  • Возможность принять факсы и звуковые сообщения немедленно после старта Вашего компьютера.
  • Поддержка множества различных модемов. Возможность мобильной связи. Поддержка факс устройств, таких как телефоны, которые могут быть подсоединены к компьютеру и управляться подобно модему.

Программа VentaFax предназначена для работы с факс-модемами Класса 1 или Класса 2 в среде Windows 3.х, Windows 9х. Требования к системным ресурсам минимальны.

Программа имеет оригинальный интерфейс на русском языке, благодаря которому работать с программой очень легко и приятно.

Прием и передача факс-сообщений производится как в автоматическом, так и в ручном режиме. Программу отличает высокая скорость работы, что позволяет быстро отправить подготовленный документ.

Принимаемая и передаваемая страницы документа в реальном времени отображаются на экране в виде движущейся страницы на фоне факс-аппарата.

Программа организована таким образом, что некоторые ее части можно использовать автономно в качестве оперативной Lite-версии.

В качестве дополнительных возможностей программа VentaFax позволяет:

  • передавать документ на фоне бланка или логотипа и подписи;
  • запрашивать документ от абонента (режим polling);
  • осуществить автоматическую рассылку документов по расписанию, с использованием различных стратегий рассылки;
  • вести один или несколько телефонных справочников, в том числе защищенных паролем;
  • импортировать и экспортировать справочники из других форматов;
  • быстро разложить по назначенным папкам (каталогам) пришедшие факсы;
  • осуществить предварительный просмотр документа перед отправкой;
  • очистить от "мусора" факс-сообщение, принятое от факса с плохим сканером;
  • сохранить документ или его часть в одном из графических форматов bmp, tif или pcx;
  • просматривать и печатать документы в различных масштабах;
  • посылать несколько документов в одном сеансе связи;
  • работать с "горячей" записной книжкой на 10 абонентов;
  • хранить факсы в форматах qfx и tiff (class F);
  • и много других удобных возможностей.


3.4. Примеры программных пакетов для подготовки, передачи, приема и обработки факсимильных сообщений с использованием факс-модемов

Факсимильные программы превращают компьютер в факс-машину, которая обеспечивает посылку и прием факсимильных сообщений. Используя их, можно передать (принять) факсимильные документы с вашего компьютера на любой другой или на любой факсимильный аппарат в мире в любое время. Данные программы имеют гораздо большие возможности, чем обычным факс-аппарат. Они позволяют иметь "телефонную книгу" практически любого размера (ограниченного количеством свободного места на диске), содержащую номера телефонов, фамилии абонентов (названия организаций) и информацию о них, расположенную в любом удобном порядке, предоставляют возможность объединять абонентов в группы получателей. Это избавляет от необходимости рассылать одно и тоже послание каждому адресату в отдельности - программа сделает это сама, если указать номер группы, Они также ведут "протокол передачи", содержащий всю необходимую информацию о посланных и полученных факсимильных сообщениях.

BitFax является полностью оснащенной программой для работы с факсимильными сообщениями (ФС) для операционной системы MS-DOS. Среди возможностей BitFax:

  • Отправление и получение факсимильных посланий в фоновом режиме
  • Автоматическая печать ФС после получения
  • Просмотр и печать полученного ФС
  • Автоматическое определение принимаемых сигналов: факс-связь, модем-связь, голос
  • Обработка различных типов файлов
  • Отправление нескольких файлов за один сеанс связи
  • "Телефонная книга"
  • Совместимость с текстовыми редакторами
  • Комбинирование файлов на одной странице
  • Сеанс связи, запланированный по времени
  • Работа без меню
  • Автоповтор набора номера при занятой линии
  • Просмотр текстовых, графических и факс файлов
  • Общий отчет и протокол передач (файлы Bitfaxrx.log и Bitfaxtx.log)
  • Использование заготовок писем
  • Сохранение экрана и запись текста печати в файл

WinFax является современной программой для операционных систем Windows 9x/NT. Она оснащена всеми необходимыми возможностями и обеспечивает большое разнообразие особенностей индивидуализации и автоматизации посылки ФС. WinFax обнаруживает и исправляет помехи, которые могут привести к недостаточному качеству передачи.

Возможно посылать факсы с лазерным качеством с высокой вероятностью получения такого же качества копии на другой факс-машине.

Кроме того, WinFax обладает следующими особенностями:

  • Не обязательно иметь модем непосредственно на вашем компьютере. Вы можете посылать и принимать факсы через модем на ведущей станции в вашей локальной сети
  • Расширенный диалог посылки данных
  • Расширенная телефонная книга. Интеграция с MS Outlook. Возможность использования базы данных под управлением MS Access в качестве телефонной книги
  • Возможность принять факсы и звуковые сообщения немедленно после старта вашего компьютера
  • Поддержка множества различных модемов. Возможность мобильной связи. Поддержка факс устройств, таких как телефоны, которые могут быть подсоединены к компьютеру и управляться подобно модему


3.5. Порядок обмена сообщениями между факсимильным аппаратом и факс-машиной

Передача ФС с ФА

1. Проверить, подключен ли ФА к телефонной линии и сети питания
2. Переключить ФА в режим передачи факсимильных сообщений
3. Установить требуемую разрешающую способность (Standard, Fine, Super Fine, Half Tone…) и контрастность (Light, Original…)
4. Вставить документ
5. Поднять трубку и набрать номер, по которому необходимо послать ФС
6. Если на приемной стороне ответили, попросить их нажать кнопку пуска для начала приема ФС
7. Нажать на ФА кнопку пуска (Start, Send…), когда услышите сигнал факса
8. Положите трубку

Осуществляется сканирование и передача документа

Передача ФС с факс-машины

1. Подготовить документ для посылки
2. Запустить телекоммуникационную программу для посылки факсимильного сообщения
3. Указать, какой документ (файл) необходимо переслать
4. Ввести номер, по которому необходимо послать документ
5. Выполнить команду посылки факсимильного сообщения

После этого факс-машина произведет инициализацию факс-модема, наберет указанный номер удаленного абонента и попытается установить связь. В случае успешного установления связи программа передаст факсимильное сообщение и завершится. Если номер занят или возникли какие-то проблемы, программа повторит попытку соединения через некоторое время в зависимости от настроек оператора.

Прием ФС факсимильным аппаратом или факс-машиной

1. Этот процесс может происходить в автоматическом режиме после заданного числа звонков, после которых факс-аппарат или факс-машина сняли трубку и установили связь
2. В ручном режиме необходимо при поступлении звонка перевести факс-аппарат или факс-машину в режим приема факсимильного сообщения

Осуществляется вывод принимаемого ФС на специальную или обычную бумагу. При приеме ФС факс-машиной оно обрабатывается и хранится как файл.

Рис. 3.5.1. Блок-схема алгоритма передачи ФС с факс-машины на ФА

Рис. 3.5.1. Блок-схема алгоритма передачи ФС с факс-машины на ФА

Рис. 3.5.2. Блок-схема алгоритма приема ФС с ФА на факс-машину

Рис. 3.5.2. Блок-схема алгоритма приема ФС с ФА на факс-машину


3.6. Методы сокращения полосы частот факсимильного сигнала. Алгоритм кодирования длин серий

При переходе к цифровому факсимильному сигналу увеличивается полоса частот сигнала, а, следовательно, потребуется более широкий канал связи для передачи сигнала в цифровом виде по сравнению с передачей аналогового сигнала. Поэтому весьма остро ставится вопрос о сокращении полосы частот факсимильного сигнала.

Методы сокращения полосы частот факсимильного сигнала основаны на учете избыточности изображения. Как полутоновые, так и двухградационные черно-белые изображения имеют большую статистическую избыточность.

Имеется ряд статистических моделей двухградационного изображения. Так, при электрооптическом анализе двухградационного изображения после соответствующей обработки сигнала, образующегося на выходе фотоэлектрического преобразователя, получается сигнал в виде случайной последовательности единиц и нулей, причем единицы и нули группируются. Если принять сигнал, соответствующий "черному" за "1", а сигнал, соответствующий "белому" за "0", то получатся пачки (серии) единиц и нулей. Статистика появления серий единиц и нулей обуславливается правилами формирования знаков (букв, цифр). При разбиении изображения на элементарные площадки (элементы изображения) число их достаточно велико. Если же элементами изображения считать серии черно-белых отрезков изображения вдоль строки, то объём передаваемых сообщений уменьшится. Модель двухградационного изображения в виде серий является основой для разработки методов эффективного кодирования.

Алгоритм кодирования длин серий.

При кодировании по этому методу двухуровневый факсимильный сигнал от каждой строки развертки разбивается на отдельные элементы - дискретизируется. Элементам белого приписывается значение логического нуля, а черного единицы. При этом учитывается, что, как правило, в среднем длины черных участков изображения много короче белых. Длины белых участков кодируются, например, шестиэлементными кодовыми комбинациями (до 63 элементов сигнала), а отрезки черного - трехэлементными (до семи элементов сигнала). Кодирование строки всегда начинается с белого; для определения начала строки передается служебная комбинация из девяти нулей. При кодировании белого различают отрезки; меньше 63 элементов изображения; больше, но не кратные 63 элементам; равные или кратные 63 элементам. В первом случае отрезки кодируются шестиэлементными кодовыми комбинациями. Во втором случае длина отрезка кодируется несколькими шестиэлементными комбинациями, причем все они, кроме последней, состоят из одних единиц. В третьем случае длина отрезка кодируется одной или несколькими шестиэлементными комбинациями, состоящими из одних единиц, и для определения окончания белого передастся служебная кодовая комбинация из шести нулей.

При кодировании черного различают отрезки; меньше 7 элементов изображения; больше, но не кратные 7 элементам; равные или кратные 7 элементам. Они кодируются так же, как и отрезки белого, но при этом используются не шести, а трехэлементные кодовые комбинации.

Для оценки методов сжатия используется коэффициент сжатия, который определяется по формуле:

K = N / Nсж

где N - число элементов на изображении, Nсж - число двоичных разрядов для представления сжатого изображения (с учетом служебных кодовых комбинаций).

Метод КДС обладает низкой помехоустойчивостью. Неверно принятый код длины серии приводит к так называемому "треку ошибок", поскольку декодер воспроизведет серию не той длины. Таким образом, даже одиночная ошибка за счет помехи в канале приводит к "разрушению" строки.


3.7. Методы сокращения полосы частот факсимильного сигнала. Алгоритм адресно-позиционного кодирования

При кодировании штриховых изображений возможны новые значения двух типов: переход из белого в чёрное и переход из чёрного в белое. Координата элемента с новым значением яркости (КНЗ) отсчитывается относительно начала строки изображения. Для безошибочного восстановления изображения по сжатым данным необходимо в начале кодограммы строки указать признак (код) её начала и значение яркости первого элемента строки:

[код начала строки] [код первого элемента] [КНЗ] [КНЗ] ...... [КНЗ].

При равномерном кодировании длина кода будет определяться из условия, что элемент с новым значением яркости находится в конце строки. Таким образом, длина двоичного кода k = log2 N, где N - число элементов изображения на строке.

Данный метод не эффективно применять для обработки текстовых факсимильных документов. При передаче контурных карт, чертежей и подобных им изображений избыточность сокращается примерно в 5-6 раз.

Метод АПК менее чувствителен к ошибкам, т.е. обладает большей помехоустойчивостью, чем многие другие методы сжатия. Помехоустойчивость АПК заключается в том, что поражение ошибкой координаты нового значения яркости приводит к искажению небольшой группы элементов строки до следующего нового значения яркости. При кодировании длин серий (КДС), случайная ошибка приводит к сдвигу всех последующих серий до конца строки. Таким образом, подтверждается непреложное правило: помехоустойчивость тем ниже, чем меньше избыточности в передаваемых данных и наоборот; то есть выигрывая в эффективности сжатия, безусловно теряем в помехозащищенности.

Еще одним критерием оценки различных методов сжатия является сложность построения их алгоритмов, которая в свою очередь определяет максимальные затраты времени на обработку сигнала процессором и объем вычислительных ресурсов. Благодаря постоянному совершенствованию цифровой элементной базы, относительная стоимость обработки сигналов постоянно снижается по сравнению с общей стоимостью аппаратуры факсимильной связи. Кроме того, тактовые частоты современных процессоров в среднем на пять порядков выше верхней частоты факсимильного сигнала, поэтому время передачи в целом в меньшей степени зависит от сложности алгоритмов программ и, соответственно, от скорости обработки цифрового сигнала изображения. В значительной степени скорость передачи факсимильной информации определяется скоростью развертки и временем прохождения трафика в сети. Таким образом, сложность алгоритмов сжатия-восстановления не является определяющим критерием при обосновании и выборе различных методов.

Подводя итог оценке основных характеристик АПК, можно заключить, что данный метод можно использовать для передачи определенной факсимильной информации. Алгоритм АПК построен для двухградационных изображений и с приемлемой эффективностью устраняет избыточность в таких изображениях, как метеокарты, графики, чертежи, укрупненные контурные рисунки и т. п. Повышенная помехозащищенность данного метода позволяет вести передачу в условиях помех, несколько худших, чем это допускают многие другие методы сжатия.


3.8. Методы сокращения полосы частот факсимильного сигнала. Алгоритм оптимального неравномерного кодирования

Алгоритм оптимального неравномерного кодирования учитывает статистику исходного двоичного изображения: наиболее вероятные длины серий кодируются наиболее короткими кодовыми комбинациями, а наименее вероятные - наиболее длинными. Примером такого кода является одномерный код Хаффмана. При использовании этого кода серии черных и белых элементов кодируются в соответствии с кодовой таблицей (таблицы 1/T.4 и 2/T.4). Размер кодовой комбинации в таблице обратно пропорционален вероятности появления соответствующей длины серии.

Характерная особенность этих кодовых комбинаций заключается в том, что они не содержат повторяющихся последовательностей единичных и нулевых элементов. Этим обеспечивается однозначное декодирование и, кроме того, не требуется вводить дополнительные элементы для обозначения начала или конца кодовых комбинаций. Иначе говоря, в любой последовательности кодовых комбинаций всегда однозначно определяются начало и конец каждой из них, т.е. код является самосинхронизирующимся.

Код Хаффмана имеет ряд модификаций и считается одним из самых эффективных для кодирования факсимильных изображений текстов и рисунков. Модифицированные коды Хаффмана (МКФ) широко применяются в факсимильной аппаратуре третьей группы.

Еще более эффективны способы так называемого двумерного кодирования. Для них характерно, что позиция каждого меняющегося элемента кодируемой строки кодируется с учетом позиции соответствующего меняющегося элемента опорной строки, расположенной непосредственно над кодируемой строкой. При этом используются корреляционные свойства изображения соседних строк (их "похожесть"). После кодирования опорной строки следующая строка изображения вычитается из опорной, а затем кодируется разностный сигнал. Поскольку при вычитании фактически осуществляется декорреляция изображения (разрушаются статистические связи), то устраняется избыточность. Энтропия преобразованного сигнала возрастает, а, следовательно, возрастает эффективность кодирования.

Рассмотренные методы сжатия обладают низкой помехоустойчивостью. Неверно принятый код длины серии приводит к так называемому "треку ошибок", поскольку декодер воспроизведет серию не той длины (и не той градации яркости). Таким образом, даже одиночная ошибка за счет помехи в канале может вызвать поток ошибок при декодировании сигнала.

Особенно чувствительно к ошибкам двумерное кодирование, поскольку ошибки приводят не только к "трекам", но и распространяются на соседние строки. Чтобы предотвратить вертикальное распространение искажений от строки к строке, двумерным способом кодируется не более двух - четырех соседних строк, после чего строка кодируется одномерным способом.

Одномерная схема кодирования длин серий, рекомендованная для факсимильной аппаратуры группы 3, следующая:

Данные (Data)

Строка Data состоит из серий кодовых слов переменной длины. Каждое кодовое слово представляет длину серии только белого либо только черного. Серии белого и черного чередуются. В сумме 1728 элементов изображения представляют одну горизонтальную строку развертки длиной 215мм.

Для того чтобы гарантировать удержание синхронизации и цвета на приеме, все строки Data должны начинаться кодовым словом длины серии белого. Если фактическая строка развертки начинается с серии черного, передается длина серии белого, равная нулю. Длина серий черного или белого вплоть до максимальной длины одной строки развертки (1728 элементов изображения) определяется с помощью кодовых слов по таблице 1/Т.4 и 2/Т.4. Существуют кодовые слова двух типов: завершающие и начальные кодовые слова. Каждая длина серии представляется либо одним словом завершающего кода, либо одним начальным кодовым словом, за которым следует завершающее кодовое слово.

Длина серий в диапазоне от 0 до 63 элементов изображения кодируется соответствующим завершающим кодовым словом. Необходимо отметить, что существуют разные перечни кодовых слов для длины черных и белых серий.

Длина серий в диапазоне от 64 до 1728 элементов изображения кодируется сперва начальным кодовым словом, представляющим длину серии, которая равна или короче требуемой. Затем следует завершающее кодовое слово, представляющее разность между реальной длиной серии и длиной серии, представленной начальным кодом.

Конец строки (EOL)

Это кодовое слово следует за каждой строкой Data. Это - специальное кодовое слово, которое никогда не появляется в действительной строке Data; поэтому возможна ресинхронизация после пакета ошибок.

Кроме того, этот сигнал передается перед первой строкой Data страницы.

Формат: 000000000001

Заполнение (FILL)

Пауза в потоке сообщений может заполняться путем передачи сигнала FILL. FILL может вставляться между строкой Data и EOL, но никогда не вводится в строку Data. FILL должен добавляться для гарантии, что суммарное время передачи Data, FILL и EOL не меньше минимального времени передачи всей кодированной строки развертки, установленного в процедуре управления, указанной в предсообщении.

Формат: последовательность нулей переменной длины.

Возврат к управлению (RTC)

Конец передачи документа обозначается путем передачи шести последовательных сигналов EOL. После сигнала RTC передатчик будет передавать команды постсообщения в соответствии с цикловым форматом и скоростями передачи сигналов управления, определенных в Рекомендации Т.30.

Формат: 000000000001........000000000001
(в сумме 6 раз)

Рис. 3.8.1 и 3.8.2 уточняют связь определенных выше сигналов. На рис. 3.8.1 показаны несколько строк развертки данных, начиная с начала переданной страницы. На рис. 3.8.2 показана последняя кодированная строка развертки страницы.

Рис. 3.8.1.

T - минимальное время передачи полной кодированной строки развертки

Рис. 3.8.2.


4.1. Глобальная компьютерная сеть Интернет. Структура. Административное управление. Документы RFC

В последние годы во всем мире наблюдается бурный рост интереса к глобальной сети Internet, объединяющей миллионы пользователей. Слово Internet означает "между сетей" (inter - между, net - сеть). Это название описывает функцию Internet - соединение в глобальном масштабе различных региональных и локальных сетей. Таким образом, речь идет о сети, соединяющей отдельные сети. Российские компьютерные сети являются частью этого всемирного объединения сетей. Они предоставляют пользователям полный спектр услуг Internet по передаче данных и по доступу к информации, размещенной на компьютерах по всей Земле.

Internet сформировалась в середине 80-х годов путем объединения на основе ряда соглашений существовавших в то время корпоративных, региональных и правительственных компьютерных сетей. У истоков Internet стоят правительственная сеть DARPA (США), сеть CERN (Европейский центр ядерных исследований), а в России - компьютерные сети ОИЯИ (Дубна) и Курчатовского института (Москва).


4.2. Возможности, предоставляемые сетью Интернет

Сеть Internet обеспечивает своим пользователям, во-первых, быстрый и недорогой доступ к нужной им компьютерной информации, в какой бы точке Земли она ни находилась. Во-вторых, Internet позволяет передавать на любой подключенный к ней компьютер информацию, имеющуюся у пользователя, Обе указанные возможности пользователи Internet реализуют, получая услуги от фирм, называемых провайдерами. Провайдер (provider = поставщик) предоставляет услуги по доступу к Internet различным фирмам, учебным заведениям и т.д. К провайдеру подключены по телефонным каналам компьютеры пользователей.

Кроме телефонных каналов в Москве, Санкт-Петербурге и других городах России используются каналы ISDN. Аббревиатура ISDN расшифровывается как Integrated Services Digital Network (цифровая сеть с интеграцией сервисов). Интеграция сервисов - это возможность передачи по таким каналам не только речи, музыки, компьютерных сообщений, но и видеофильмов в реальном времени. Для подключения к провайдеру по каналу ISDN необходим маршрутизатор, или ISDN-модем.

По телефонному или ISDN-каналу может передаваться информация девяти видов: тексты, таблицы, графика, базы данных, звук, видеоклипы, программы, гипертексты, виртуальная реальность.

На свой компьютер пользователь Internet получает информацию с сервера, Поясним двойной смысл слова "сервер". Во-первых, сервер - это компьютер, имеющий один или несколько мощных процессоров, сотни Мбайтов основной памяти, десятки или сотни Гбайтов внешней памяти. Во-вторых, информация и программы, размещенные на сервере, также называются сервером, Программный сервер может обмениваться информацией одновременно с одной пли несколькими программами-клиентами. С помощью программы-клиента пользователь обращается к программе-серверу, чтобы получить информацию или выполнить обработку информации на том компьютере, который хранит программу-сервер и информацию. Технология "клиент-сервер" широко используется в локальных и глобальных вычислительных сетях.

Сидя перед экраном компьютера, пользователь запускает одну из программ-клиентов, обеспечивающих передачу и прием информации. Эта программа, реализуя определенный вид услуг, взаимодействует с сервером провайдера, а он в свою очередь обращается к другим компьютерам, с которыми нужно осуществить обмен информацией. На своем экране пользователь видит результаты обмена информацией. С помощью клавиатуры и мыши он может управлять обменом. Рассмотрим виды услуг, существующих в Internet.

Электронная почта

Электронная почта (Electronic mail = E-mail) - это самая популярная услуга. В мире имеется более 90 миллионов пользователей электронной почты. Она передает данные первых восьми возможных видов. Стандарт MIME (Multipurpose Internet Mail Extension - многоцелевое расширение электронной почты для Internet) был разработан для того, чтобы обеспечить в Internet передачу графики, звука и видеоинформации. Большинство провайдеров поддерживают стандарт MIME.

Эта услуга дешева по сравнению с другими услугами, существующими в Internet. За отправку одного килобайта (половины страницы текста, набранного в формате ASCII) провайдер взимает: 1) $0.04 для международной почты. 2) $0.01 для междугородной почты в пределах СНГ. В Санкт-Петербурге передача осуществляется бесплатно. Прием любой корреспонденции также не оплачивается. Ежемесячная абонентская плата за E-mail подключение составляет $5.

Можно указать преимущества E-mail по сравнению с обычной почтой.

1. Провайдер передает электронное письмо сразу после поступления его от отправителя и оно хранится в электронном почтовом ящике получателя или у его провайдера. То есть E-mail обеспечивает гораздо более высокую скорость, чем обычная почта. Например, поступление писем в Швецию, Англию и Америку обеспечивается в день их отправки.

2. Надежность доставки электронных писем гораздо выше, чем обычных. Это обеспечивается полной автоматизацией всех процессов доставки электронной почты.

3. Если у фирмы большой объем переписки, то электронная почта оказывается гораздо дешевле обычной.

4. Регистрация передаваемых и получаемых электронных писем обеспечивается программами без участия человека (а следовательно без ошибок).

5. Компьютерные технологии используются для "написания" отправляемых писем и для обработки поступившие.

6. Электронная почта позволяет отправлять и принимать сообщения в любое время суток.

7. Наличие электронной почты является элементом имиджа и известности любой фирмы.

Недостатком E-mail является, во-первых, возможность прочтения сообщения посторонними лицами. Для обеспечения конфиденциальности переписки следует шифровать отправляемые сообщения. Во-вторых, недостаток электронной почты состоит в том, что факт пересылки по ней информации пока что не может быть подтвержден документом.

Чтобы отправить сообщение электронной почтой, необходимо указать: 1) кому предназначено ваше сообщение и 2) имя компьютера. Имя получателя отделяется от имени компьютера (адреса компьютера) знаком @. При этом формат адреса электронной почты в общем виде выглядит следующим образом:

<имя получателя>@<адрес компьютера>

Например: emd@pds.sut.ru

Списки рассылки и телеконференции

Электронное письмо можно отправить не только по одному адресу, а сразу в несколько различных пунктов. Удобнее всего это делать, заказав у провайдера поддержку сервера списка рассылки. Сообщения, помещаемые на сервер списка рассылки, отправляются только тем пользователям, которые на него подписаны. Дискуссионный список рассылки отличается тем, что его подписчики могут отправлять свои сообщения ни адрес этого сервера. Сообщение каждого подписчика рассылается сервером всем остальным участникам списка.

Электронная почта предоставляет информационную услугу по проведению телеконференций. У провайдера можно получить перечень электронных конференций по тематике, интересующей пользователя. Каждая конференция создастся организацией или лицом по определенной группе тем. Для этого на сервере размещается каталог общего доступа. В нем имеются подкаталоги - темы или вопросы, интересующие пользователей этой конференции, а каждая тема содержит последовательно пронумерованные ответы пользователей на эти вопросы. Телеконференция накапливает и периодически обновляет электронные письма по конкретной тематике. Устаревшие сообщения удаляет специальная программа-робот (cancelbot).

Самым ценным свойством электронных конференций является их специализация. Существует более 13 000 конференций, это автоматически разделяет их читателей на отдельные рыночные группы.

Серверы в Internet

Технология "клиент-сервер" дает пользователям Internet большой выигрыш в скорости выполнения их запросов. Во-первых, сервер может обмениваться информацией одновременно с несколькими программами-клиентами. Поэтому пользователь не ждет в очереди. Во-вторых, обработка информации (поиск в базе данных, просмотр гипертекста или каталога, разархивирование данных для ознакомления с ними и т.д.) осуществляется быстро, так как сервер работает на высокопроизводительном компьютере. В-третьих, программа-клиент не предъявляет больших требований к компьютеру пользователя и быстро работает даже на дешевых ПК. Основные виды серверов рассмотрим в следующем порядке: FTP, Telnet, WWW.

FTP-серверы

Сокращение FTP (File Transfer Protocol) означает "протокол передачи файлов". FTP - это способ перемещения файлов между двумя компьютерами, отличающийся от электронной почты более высокой скоростью. FTP-ссрвер представляет собой информацию и программу, к которой обращаются пользователи Internet, используя соответствующую программу-клиента. Тысячи FTP-серверов в Internet содержат открытые для бесплатного доступа данные. Для их получения нужно заключить договор с провайдером на сеансное FTP-подключение к Internet. За один час работы провайдер взимает $1.8 днем и $1.0 ночью. Ежемесячная абонентская плата за FTP-подключение составляет $5.

Чтобы установить связь с нужным компьютером, следует командой ftp запустить программу-клиента FTP, а затем указать доменное имя этого компьютера. Когда установится связь с соответствующим компьютером, на дисплее появится предложение ввести имя пользователя. Если лицо, установившее связь, не является зарегистрированным пользователем этого FTP-сервера, то у него нет личного имени пользователя. В таком случае нужно ввести слово "anonymous" (анонимный). Очень многие FTP-серверы представляют определенные права доступа не только зарегистрированным пользователям, но и анонимным, хотя для последних существуют ограничения по доступу к информации. Такие серверы FTP называются анонимными. В сети Internet существует несколько десятков тысяч анонимных серверов FTP.

После ввода имени или слова anonymous нужно ввести пароль. Как правило, в качестве пароля используется адрес электронной почты лица, установившего связь. Пароль при вводе не отображается на экране. После этого FTP-сервер указывает, в каких каталогах следует искать определенные файлы. Он представляет данные в виде списка файлов и каталогов. Для того, чтобы узнать, что содержится в том или ином файле, нужно получить и прочитать файл с описанием (README). Войдя в нужный каталог, посетитель FTP-сервера получает доступ к этим файлам. Нужный файл следует переместить на свой компьютер, используя команду get, вводимую после приглашения FTP>. Например, файл primer.txt можно получить посредством команды:

FTP>get primer.txt

Программы, которые посетитель может получать от анонимного FTP-сервера, имеют юридический статус shareware или freeware. В то время, как freeware в соответствии с его названием является действительно бесплатным программным продуктом, shareware относится к особому виду реализации программного обеспечения. В отличие от коммерческих программ копирование и передача shareware разрешены. Концепция shareware основала на том, чтобы предоставить пользователю возможность сначала опробовать определенный программный продукт, а затем решать, соответствует ли он требованиям пользователя или целесообразно поискать другую программу. При этом все права на программные продукты принадлежат их авторам. По истечении определенного времени опробования, которое, как правило, составляет 30 дней, нужно зарегистрироваться у автора для дальнейшего пользования программой.

Telnet-серверы

Программа Telnet обеспечивает интерактивный доступ к удаленному компьютеру. То есть после установления связи с другим компьютером у пользователя Telnet появляется ощущение, что он сидит непосредственно перед тем компьютером, к которому подключился. Telnet предоставляет ему все возможности удаленного компьютера, если конечно ему разрешен доступ ко всем ресурсам.

WWW-серверы

Начиная с 1992 года, непрерывно и стремительно растет популярность системы WWW (World Wide Web - всемирная паутина). Она является самой новой и совершенной из подсистем Internet. WWW-сервер (или Web-сервер, Web-site, Web-сайт, сайт, Web-узел) содержит страницы гипертекста.

Для доступа к WWW-серверам используются программы-клиенты, называемые программами просмотра, а также броузерами или браузерами от английского слова browse [brauz] = бегло просматривать. Наиболее эффективны и популярны две программы просмотра: Internet Explorer фирмы Microsoft и Netscape Navigator фирмы Netscape Communications.

Поисковые серверы

Если у пользователя нет сведений о сервере и имени файла, который содержит нужную ему информацию, то лучше использовать поисковую систему (сервер), например, www.rambler.ru, www.yandex.ru и др. Поисковый сервер обеспечивает поиск документа по определенной теме или путем использования ключевых слов.

Чтобы произвести поиск, нужно установить связь с одним из поисковых серверов. Связь обычно устанавливается с помощью броузера. После этого на экране появляется меню, в котором пользователь находит интересующую его тему или составляет из ключевых слов запрос на поиск. Поисковый сервер составляет в результате своей работы список документов, которые могут заинтересовать пользователя.

Наш город представлен в Интернет множеством сайтов, освещающих различные стороны жизни Санкт-Петербурга. Официальный сервер Администрации города размещен по адресу: http://www.gov.spb.ru. На сервере хорошо представлена структура Администрации нашего города, ведутся разделы "Новости", "Культура", "Образование", "Туризм", "История" и др.

Самое большое число пользователей Интернет - в США: 144 млн. В России в 2000 году регулярно пользовались Интернет примерно 3 млн. При этом, 24% использовали Интернет как справочник, 15% - в качестве инструмента исследования, 12% - как источник новостей, 14% - как развлечение…


4.3. Подключение пользователей к сети Интернет

В настоящее время широко используются два варианта подключения к сети Интернет:

  • постоянное подключение;
  • коммутируемое IP-соединение.

Постоянное подключение позволяет работать с Интернетом в любое время и часто используется для подключения локальной сети к Интернету, после чего все пользователи локальной сети могут одновременно работать в Интернете. Постоянное подключение осуществляется с помощью выделенной линии связи, которая обеспечивает высокую скорость передачи информации.

Коммутируемое IP-соединение (Dial-Up IP) - основной способ подключения к Интернету подавляющего большинства пользователей. С помощью этого соединения ваш модем через обычную телефонную линию связывается с модемом, установленном на компьютере поставщика сетевых услуг. После установки связи ваш компьютер становится частью Интернета и вам становятся доступны все услуги. Этот вид соединения также называют сеансовым соединением.

При коммутируемом IP-соединении между вашим компьютером и другими компьютерами, подключенными к Интернету, осуществляется передача пакетов TCP/IP. Так как протоколы TCP/IP изначально были разработаны для компьютеров находящихся в постоянном соединении друг с другом, то, чтобы эти протоколы работали при коммутируемом соединении, используются дополнительные протоколы: SLIP или PPP.

SLIP (Serial Line Internet Protocol) - Интернет-протокол для последовательного канала.

PPP (Point-to-Point Protocol) - протокол точка-точка, также называемый протоколом взаимодействия между узлами. Данный протокол появился позже, чем SLIP, и в нем учтены недостатки протокола SLIP, например, он содержит больше возможностей для коррекции ошибок.


4.4. Возможности, структура, настройка и основные принципы работы с программными пакетами Microsoft Internet Explorer и Netscape Navigator

Для работы в Интернет необходим простой и понятный инструмент, позволяющий использовать все возможности сети. Выбор такого инструмента является достаточно важной задачей. В настоящее время наиболее широко используются пакет программ Internet Explorer, разработанный фирмой Microsoft, и пакет программ Netscape Navigator, разработанный фирмой Netscape Communications Corporation. В последних разработках этой фирмы браузер Netscape Navigator входит в качестве основного компонента в пакет программ, который называется Netscape Communicator.

4.4.1. Microsoft Internet Explorer

В настоящее время Internet Explorer является одной из самых популярных программ для работы в сети Интернет. Так как эта программа разработана фирмой Microsoft, то она максимально интегрирована в операционную систему Windows и наиболее полно использует ее возможности.

Главной программой пакета Internet Explorer является программа просмотра Web-страниц, называемая browser (веб-навигатор, веб-обозреватель, проводник). Проводник Интернета поддерживает все возможности, закладываемые разработчиками Web-страниц, включая звуковое и видео сопровождение отображаемой информации.

Internet Explorer поддерживает современные стандарты шифрования информации; реализована возможность пересылки конфиденциальных данных.

В комплект Internet Explorer входит программа для работы с электронной почтой - Internet Mail. С помощью программы Internet News возможна работа с новостями.

Также в комплект Internet Explorer входит программа Microsoft NetMeeteng, которая позволяет реализовывать дополнительные возможности, предоставляемые сетью Интернет - устанавливать голосовую связь и обмениваться с рабочих мест видео и графическими данными. А использование продукта Active Movie позволяет демонстрировать видеофильмы. Воспроизводить звуки, оживлять рисунки, то есть реализовывать возможность мультимедиа в Интернете.

Работа программы Internet Explorer начинается с загрузки на компьютер начальной страницы. В процессе работы можно прервать процесс загрузки Web-страницы, нажав кнопку Stop (Стоп). Если нажать кнопку Refresh (Обновить), то текущая Web-страница будет заново загружена из сети.

Адрес страницы, которую необходимо найти в сети, загрузить и отобразить, вводится в поле адреса. Новая страница может быть загружена, если вы указателем мыши выбрали ссылку на текущей Web-странице и щелкнули на ней мышью.

Работа с программой представляет собой перемещение по бесконечной паутине ссылок на различные Web-страницы в Интернете. Для облегчения такого перемещения можно воспользоваться кнопками Back (Назад) и Forward (Вперед).

Назовем некоторые дополнительные настройки программы.

Так, чтобы ускорить загрузку Web-страниц, можно запретить загрузку на ваш компьютер изображений, звука или видео. Для этого следует использовать меню View-Options-General-Multimedia (Вид-Параметры-Общие-Мультимедиа).

Чтобы не набирать в поле адреса полный адрес интересующей страницы, следует использовать массив ссылок, в который предварительно записываются адреса Web-страниц и их условные имена. Для этого используются меню Navigation-Customize-Link N (Переходы-Настройка-Ссылка N), где N-номер ссылки 1, 2, … В поле ввода Address (Адрес) введите полный адрес ссылки и нажмите кнопку OK. Теперь для того, чтобы указать адрес загружаемой страницы, достаточно нажать кнопку Links (Ссылки) и в появившемся списке выбрать нужное имя ссылки.

Для хранения адресов и быстрого доступа к этим адресам в программе Internet Explorer предусмотрена и папка Favorites (Избранное). В этой папке можно запомнить адрес текущей Web-страницы и поставить в соответствие этому адресу любое название для данной ссылки.

Чтобы завершить работу программы Internet Explorer, необходимо воспользоваться меню File-Close (Файл-Закрыть) или щелкнуть мышью на кнопке [X] в правом верхнем углу окна программы Internet Explorer.

4.4.2. Использование Netscape Communicator (версия 4)

Описание пунктов меню

Все функции Netscape представлены в пунктах меню программы. На основной панели Netscape Communicator располагаются следующие пункты меню:

Файл - здесь осуществляется работа с файлами.

Правка - позволяет редактировать содержимое страницы и настраивать Communicator.

Вид - отвечает за параметры отображения содержимого страницы

Переход - позволяет осуществлять переходы между страницами.

Компоненты - вызывает открытие окон компонентов пакета Communicator.

Справка - поиск справки об использовании пакета Communicator.

Раскроем каждый из перечисленных пунктов меню.

Назначение пунктов меню Файл

Меню Файл позволяет открывать, сохранять, печатать файлы и выполнять другие задачи в окнах Communicator. В этом меню содержатся следующие пункты:

Создать - в этом пункте можно создать, например, новое окно браузера, создать и отправить новое почтовое сообщение, создать новую пустую web-страницу.

Открыть - открыть страничку в формате HTML. Можно вести адрес URL или выбрать файл с помощью кнопки Выбрать файл. Указав адрес страницы, следует нажать кнопку Открыть, чтобы открыть страницу.

Сохранить как - позволяет сохранить файл, открытый в Navigator. Можно сохранить страницу в формате только текста или в исходном формате (HTML).

Сохранить кадр как - позволяет сохранить файл, содержащий выбранный в данный момент кадр. Можно сохранить страницу в формате только текста или в формате HTML.

Отправить страницу - позволяет создать и отправить письмо в окне составления сообщений, к которому будет прикреплена текущая страница.

Изменить страницу - позволяет изменить текст страницы в формате HTML, определяющий содержание и отображение страницы.

Изменить кадр - позволяет изменить исходный текст кадра в формате HTML, определяющий содержимое кадра и его отображение.

Передать файл - позволяет выбрать файл для отправки на FTP-сервер, задаваемый текущим адресом URL.

Автономный резким/Подключенный резким. Отображает диалоговое окно, позволяющее отключиться от провайдера Интернет, если вы находитесь в подключенном режиме, или подключиться к нему, если вы работаете автономно.

Параметры страницы - позволяет задать параметры печати для последующих операций печати.

Предварительный просмотр - представляет текущую страницу таким образом, как она будет напечатана.

Печать - печать области содержимого текущей страницы Navigator или, если выбран кадр, кадра.

Закрыть - закрытие текущего окна Navigator.

Выход - закрытие текущего окна Navigator и выход из Communicator.

Назначение пунктов меню Правка

Меню Правка позволяет вырезать, копировать, вставлять и находить элементы в окнах Communicator, а также устанавливать параметры для настройки Communicator. В этом меню имеются следующие пункты:

Вырезать - удаление текущего выделенного фрагмента и помещение его копии в буфер обмена.

Копировать - помещение копии выделенного фрагмента в буфер обмена.

Вставить - помещение содержимого буфера обмена в точку вставки на текущей странице в окне Navigator.

Выделить все - выделение всего содержимого текущего окна.

Найти на странице - позволяет задать слово или фразу и найти их на текущей странице Navigator (или в кадре). Если в тексте уже выделен фрагмент, поиск происходит в этом фрагменте.

Найти далее - поиск дополнительного вхождения текста, указанного в поле Найти на странице.

Поиск в Интернет - отображение страницы, предоставляющей доступ к поисковым системам Интернет и другим поисковым службам.

Искать в каталоге - отображение диалога, предоставляющего доступ к каталогам адресной книги, в которых можно указать поиск людей и их адресов в Интернет.

Настройки. Этот пункт выводит диалоговое окно со списком множества категорий настроек.

Назначение пунктов меню Вид

Меню Вид позволяет управлять отображением панелей инструментов, содержимого страницы и информацией о странице. В этом меню имеются следующие пункты:

Показать/убрать панель управления - если нужно показать или убрать кнопки панели инструментов.

Показать/убрать панель адреса - если нужно показать или убрать поле адреса (URL) и меню Закладки.

Показать/убрать персональную панель инструментов - если хочется показать или убрать персональную панель инструментов.

Увеличить шрифт - увеличение размера шрифта на экране. Внесенные изменения изменят параметры на панели настроек Шрифты.

Уменьшить шрифт - уменьшение размера текста на экране. Внесенные изменения изменяют параметры на панели Шрифты.

Обновить - отображение новой копии страницы Navigator. Navigator проверяет на сетевом сервере, не изменилась ли страница. Если она не изменилась, копия загружается из кэш-памяти. Если она изменилась, копия загружается с сервера. Если нажать кнопку Обновить на панели управления, удерживая клавишу Shift, Navigator загружает новую копию с сетевого сервера, независимо от того, была ли изменена страница.

Показать рисунки - этот пункт отвечает за вывод изображений на текущей странице в окне Navigator. Обычно изображения загружаются автоматически, Однако если при загрузке страницы на панели настроек Дополнительно не установлен флажок Автоматически загружать изображения, каждое изображение заменяется небольшим значком. Если выбрать Показать рисунки, все значки будут заменены соответствующими изображениями. Изображения загружаются из исходных файлов, однако страница не перезагружается (ссылки на изображения не обновляются из исходной страницы).

Обновить окно - позволяет отобразить новую копию текущей страницы Navigator из памяти компьютера, чтобы заменить загруженную ранее. В отличие от пункта Обновить, Обновить окно не отображает обновленную версию страницы, а происходит просто повторное отображение страницы.

Прекратить загрузку - прекращает передачу страницы из сети.

Остановить анимацию - прекращает анимацию.

Код страницы - открытие окна с исходным текстом страницы в формате HTML. На страницах, на которых используются кадры, можно просмотреть исходный текст кадра в формате HTML, поместив указатель мыши в кадр, щелкнув правой кнопкой мыши и выбрав в появившемся меню пункт Просмотреть исходный текст кадра.

Информация - открывает в отдельном окне страницу с информацией о структуре текущей страницы, Сюда входит, если эта информация доступна, заголовок страницы, адрес (URL), тип MIME, исходный текст, локальный файл кэш, дата последнего изменения, длина содержимого, срок истечения, кодировка и статус защиты. Для страниц с зашитой указывается также тип шифрования и информация о сертификате. Для страниц с кадрами можно просмотреть информацию о странице в кадре, поместив курсор мыши на кадр, щелкнув правой кнопкой мыши и выбрав в появившемся меню пункт Просмотреть информацию о кадре.

Службы страницы - отображение страницы со службами, предлагаемыми Netscape Enterprise Server. Этот пункт меню доступен, если текущая страница передается сервером Enterprise.

Кодировка. В этом меню предлагается выбрать кодировку, если кодировка страницы не указана или недоступна. Если вам нужно установить кодировку по умолчанию для любой страницы, выберите в меню Кодировки пункт Установить по умолчанию.

Назначение пунктов меню Переход

Меню Переход позволяет переходить между страницами. В этом меню имеются следующие пункты:

Назад - при выборе этого пункта меню производится отображение предыдущей страницы из списка посещений. В списке посещений находятся адреса страниц, которые пользователь просматривал; в списке посещений кадра находятся кадры, которые просматривались в этом наборе кадров.

Вперед - при выборе этого пункта меню происходит отображение следующей страницы в списке посещений. Пункт Вперед доступен, если вы использовали команду Назад или переход по списку посещений.

Основная страница - отображение базовой страницы, адрес которой указан на панели настроек Navigator. По умолчанию базовой является страница компании Netscape.

Назначение пунктов меню Компоненты

Меню Компоненты позволяет переключаться между окнами пакета Communicator и получать доступ к окнам, представляющим первичные функции Communicator. В этом меню находятся следующие пункты:

Navigator - отображение окна Navigator, предоставляющего доступ к web.

Почтовый ящик Messenger - отображение окна Входящее, которое позволяет работать с почтой.

Группы новостей Collabra - отображение окна Message Center, позволяющего работать с группами новостей, а также с почтой.

Редактор страниц - отображение окна редактора Composer, предоставляющего основные инструменты по созданию web-страниц.

Конференция - отображение окна конференций, предоставляющее средства голосового обмена информацией в реальном времени.

Netcaster - отображение окна Netcaster, предоставляющего средства автоматической доставки web-страниц и просмотра web в автономном режиме.

Показать/прикрепить панель компонентов - установка положения панели компонентов. Если панель прикреплена, она находится в правом нижнем углу окна. Если она не прикреплена, она отображается в виде перемещаемой панели.

Почтовое отделение - отображение окна Почтовое отделение, содержащего почтовые ящики и папки для писем и сообщений групп новостей.

Адресная книга - отображение окна адресной книги, в котором можно создавать и изменять файлы с почтовыми адресами.

Закладки - отображение окна закладок, в котором предоставляется возможность создавать и изменять закладки.

Журнал посещений - отображает окно списка посещений, где перечислены страницы, которые вы посещали. Если дважды щелкнуть на странице, то она будет открыта.

Консоль Java - отображает окно консоли Java. Некоторые программы Java выводят здесь информацию.

Безопасность - отображение окна Безопасность. Эта страница позволяет работать с такими элементами как статус шифрования, персональные сертификаты и сертификаты узлов, приложения для защиты и пароли.

Назначение пунктов меню Справка

Меню Справка позволяет найти документацию и службы поддержки для пакета Communicator и других продуктов Netscape. В этом меню имеются следующие пункты:

Содержание справки - содержание справки со ссылками на указатель и разделы.

Информация о версии - информация о пакете Communicator и новых возможностях этого программного обеспечения.

Обновление программного обеспечения - отображение страницы, содержащей информацию о том, как получить последние варианты обновления пакета Communicator.

Регистрация - отображение страницы с регистрационным номером вашей копии Communicator. Если вы еще не зарегистрировали свою копию программы, то на этой странице можно найти инструкции.

Защита - отображение страницы, содержащей информацию о решениях Netscape в области защиты со ссылками на технические описания разработок компании Netscape.

Сеть - ресурсы с информацией о группах новостей и этикете в Интернет.

О дополнительных модулях - предоставление информации в формате MIME об установленных на текущий момент дополнительных модулях. Дополнительные модули - это программы, расширяющие возможности определенной платформы Communicator.

Шрифты - представление информации о формате шрифта для установленных на данный момент средств отображения шрифтов.

О пакете Communicator - информация о версии, авторском праве и лицензии на пакет Netscape Communicator.

Кнопки панели инструментов

Рассмотрим назначение кнопок очень важной и удобной панели - панели инструментов, панели незаменимой при хождении по сайтам и серверам.

Назад, или комбинация Alt + <-. Эта кнопка позволяет вернуться из текущего документа в тот, который был на экране до него, при этом эти два документа не обязательно должны быть связаны гипертекстовой ссылкой.

Вперед, или комбинация Alt + ->. Эта кнопка доступна только тогда, когда вы вернулись на один или несколько шагов кнопкой Назад Она позволяет отменить возвращение и снова загрузить следующий в цепочке пройденных вами документов.

Обновить. Если вы прервали получение документа кнопкой Стоп, или если подозреваете, что документ загрузился не полностью или с ошибками, нажатие этой кнопки заставит Netscape повторить попытку получения документа: поиск сервера в Интернете, посылку запроса и скачивание документа - заново.

Домой - при нажатии этой кнопки Netscape перейдет на основную страницу - страницу которую Netscape загружает вместе со своей загрузкой.

Поиск. Эта кнопка открывает окно для поиска текстовой строки в текущем документе. В нем предлагается указать направление поиска (вверх или вниз), искать ли с учетом регистра и то, что мы хотим найти.

Мой Netscape. При нажатии на эту кнопку загружается персональная начальная страница пользователя, т.е. сайт Netscape.

Печать. Эта кнопка, как и команда Печать из меню Файл, позволяет напечатать текущую страницу на принтере.

Защита. Эта кнопка аналогична по своей функции команде Безопасность из меню Компоненты.

Стоп, или клавиша Esc. Эта кнопка позволяет прервать загрузку документа.

Панель адреса

Самый очевидный способ получит документ, URL которого известен, - поставить щелчком мыши курсор в строку Адрес, набрать нужный URL и нажать ENTER Кнопка с треугольником в правом конце строки Адрес откроет список тех URL, которые вы вводили в этой строке раньше.

Находясь в строке Адрес можно обмениваться информацией с буфером Windows с помощью комбинаций клавиш для копирования (Ctrl+C), вставки (Ctrl+V) и удаления (Ctrl+X),Например, если в некоем тексте, который вы читаете в Netscape, нужный вам URL-адрес приведен, но не оформлен как гипертекстовая ссылка, можно выделить его протаскиванием мышью, скопировать в буфер, а затем вставить в строку Адрес.

Существует и другой способ заказать конкретный URL - с помощью команды Файл-Открыть страницу. Никаких особых преимуществ у этого метода нет - если не считать того, что в меню Файл есть команда Открыть, которая позволяет открыть в окне браузера любой HTML-документ, хранящийся на диске вашего компьютера. Таким образом вы сможете читать сохраненные на жестком диске документы в режиме off-line, т.е. без подключения к Интернету.

Если вы хотите просматривать одновременно несколько документов, дайте команду Компоненты-Навигатор или Ctrl+1, и на экране появится точная копия окна Netscape со всеми органами управления. Теперь в это новое окно можно загрузить какой-нибудь другой документ из любой точки Интернета.

Таких производных браузеров можно запустить столько, сколько позволяет объем памяти компьютера и канал связи. Созданные таким образом экземпляры программы никак не связаны между собой - в частности, каждый из них придется закрывать отдельно.

В комплект Netscape Communicator кроме браузера Netscape Navigator входит также такая программа как Netscape Messenger. Выбрать ее можно из пункта меню Компоненты или нажав Ctrl+2. Netscape Messenger получает, отправляет, обрабатывает и помогает управлять электронными сообщениями с мультимедиа данными и сообщениями Collabra. Netscape Collabra (Ctrl+3), в свою очередь, позволяет принимать участие в группах новостей Collabra. Для этого необходимо открыть сервер новостей и отобразить группы новостей, предоставляемые сервером. Просмотрев доступные вам группы новостей, вы можете подписаться на них или просматривать не подписываясь.

Также в пакете Netscape Communicator есть редактор Web-страниц Composer (Ctrl+4) Программа Composer позволяет создавать Web-страницы, письма или группы новостей с помощью обычных методов копирования-вставки и буксировки. Возможности программы Composer полезны как опытным, так и начинающим создателям web-страниц.

Также в пакете есть программа Netscape Conference (Ctrl+5) предоставляющая следующие возможности обмена данными и воспроизведения звука в реальном времени:

  • разговор в реальном времени с коллегами со всего мира;
  • во время сеанса chat можно отправлять и получать текстовые сообщения (служба Chat);
  • использование общего окна рисования (служба Окно Рисования);
  • возможность переходить по страницам World Wide Web во время сеанса совместной навигации по Интернет (служба Совместный Просмотр);
  • возможность обмениваться или передавать файлы данных (служба Обмен Файлами).

Еще есть Netscape Netcaster, который автоматически доставляет информацию и предоставляет следующие преимущества:

  • с помощью Netcaster вы можете подписаться на любые каналы (каналами называются Web-серверы, автоматически доставляемые информацию) и получать необходимую информацию Netcaster может также автоматически обновлять каналы;
  • можете отобразить канал в режиме полноэкранного - webtop. В Windows webtop всегда остается на экране, отображаясь под другими окнами, в которых пользователь работает. С помощью webtop можно легко просмотреть последнюю информацию, появившуюся в канале за то время, пока вы выполняли другие задачи;
  • при автономном просмотре есть возможность загрузить любой Web-сервер и просмотреть его в автономном режиме (отключившись от Интернет);
  • Netcaster's Channel Finder (Поиск Каналов) предоставляет готовый список интересных каналов в Интернет.


4.5. Организация поиска информации в сети Интернет

4.5.1. Традиционные поисковые системы Интернета

Для поиска информации используются специальные внешние службы - поисковые серверы: поисковые машины и каталоги.

Поисковые машины - это такие серверы, которые накапливают информацию о содержимом сайтов автоматически, при помощи специальных программ-роботов.

Информацию для серверов-каталогов отбирают люди. В отличие от поисковых машин, информация в каталогах более точно структурирована, причем в вертикальном иерархическом виде.

И поисковые машины, и каталоги являются внешними службами или, как их еще называют, автономными системами. Особенностью автономных систем является то, что цикл работы с информацией выполняется полностью непосредственно на этой системе, начиная с получения информации от первоисточника и заканчивая предоставлением поискового сервиса конечному пользователю.

Автоматические поисковые системы охватывают больший объем информации, их сведения чаще обновляются и поэтому более актуальны. Однако информация на таких серверах плохо структурирована, потому что оценка содержимого того или иного сайта - трудно формализуемая задача. Чаще всего программа-робот отбирает документы только по наличию искомых слов в тексте документа. Примером поисковой машины является AltaVista (http://www.altavista.com).

В каталогах вся информация имеет четкую вертикальную иерархическую структуру. Причем эта структура строится на основе смыслового содержания. В этом главная ценность каталогов, обрабатываемых людьми: можно найти не множество сайтов, содержащих данные ключевые слова, а множество сайтов, посвященных данной тематике. Примером каталога может служить сервер Yahoo (http://www.yahoo.com).

Каталоги WWW, содержащие большое количество записей, часто размещают на своих страницах локальные поисковые машины. Реализуемые в виде традиционных шаблонов, которые мало чем отличаются от шаблонов на автоматических индексах.

Как для поисковых машин, так и для каталогов устанавливается некий принцип отбора информации. Этот принцип закладывается либо в алгоритмы работы поисковых машин, либо в регламент работы людей (для каталогов). В зависимости от того, откуда и какой тип информации накапливается, оценивают две характеристики автономных систем - пространственный масштаб и специализацию.

Пространственный масштаб призван ограничить количество первоисточников информации до некоего конечного предела. Например, поисковая система может быть построена в рамках только одного сайта. Поиск может быть ограничен рамками одного географического домена (например, ru). Такие системы называют региональными.

Существует множество поисковых серверов, которые не имеют подобных ограничений. Их называют глобальными информационно-поисковыми системами.

Особенности регионального подхода могут присутствовать и в глобальных системах. Так, система Lycos (http://www.lycos.com) сортирует результаты поиска в зависимости от того, из какого региона поступил запрос.

Наиболее популярные поисковые сервера загружены настолько, что возникает необходимость в создании "зеркал" (mirrors). Зеркала должны содержать точную копию первичной поисковой системы и гарантировать быстрое обслуживание обращений, поступающих из определенной географической зоны.

При обращении к той или иной поисковой системе следует учитывать, какие сервисы она предоставляет. Например, в отечественной поисковой машине Яндекс (http://www.yandex.ru) введен поиск не только страниц, но и серверов. Суть этого метода заключается в том, что ключевые слова ищутся не по всем страницам, а лишь по их заголовкам (то, что заключено в HTML между тегами "title"). В зарубежной AltaVista сделана отдельная служба Real Names, которая содержит перечень всех зарегистрированных страниц компаний и организаций.

Следующий важный сервис - это специализация поиска. В настоящее время Интернет является хранилищем разных типов информации. Поэтому и поиск информации тоже может быть формализован. Можно искать исключительно графические изображения, можно - мультимедийные записи в формате MP3 и т.д. На многих поисковых серверах можно задать тип искомой информации. кроме того, существуют и серверы, которые специализируются на поиске информации строго определенного типа. FTPSearch (http://ftpsearch.lycos.com) специализируется исключительно на поиске файлов. Он индексирует всевозможные ftp-серверы на предмет находящихся там файлов. Поиск осуществляется непосредственно по наименованию искомого файла. Аналогично MP3Search (http://mp3.box.sk) специализируется на поиске исключительно файлов в формате MP3.

Еще одним важным моментом является то, какой язык запросов использует та или иная система. Чем сложнее этот язык - тем более тонкую настройку поиска оказывается возможным провести. В настоящее время не существует единого унифицированного языка запросов для поисковых систем. Разработка такого языка сделала бы возможной интеграцию различных поисковых сервисов в единую сверхсистему поиска. В феврале 1999 был начат проект SESP (Search Engine Standards Project), в котором участвует 15 крупнейших поисковых систем Интернета. В задачу проекта входит стандартизация работы поисковых служб (материалы о нем можно найти по адресу http://www.searchenginewatch.com).

4.5.2. Метапоисковые системы

Еще одним перспективным направлением развития поисковых сервисов в сети является использование метапоисковых систем. Основа метапоисковых систем - это интерфейс между пользователем и множеством поисковых систем. Метапоисковая система не предназначена для индексирования и накопления информации. назначение ее - чистый поиск и обработка результатов поиска.

Метасистема позволяет, в соответствии с пожеланиями пользователя, ограничить свой поиск определенными поисковыми серверами, проверять существование ресурсов, на которые указывают результаты поиска, осуществлять уточненный поиск в результатах поиска и т.д. Метапоисковые системы часто называют клиентами к поисковым серверам.

Примером метапоисковой системы может служить отечественная разработка "ДИСКо Искатель" компании "ДИСКо" (http://www.disco.ru).

Основной чертой метапоисковых систем нового поколения является объединение поисковых серверов различных специализаций. В рамках одного приложения можно осуществлять поиск информации различного типа. При обработке поискового запроса допускается соединение более чем со 100 поисковыми системами (в т.ч. и со специализированными). Результаты поиска дополнительно обрабатываются: ссылки, дублирующие уже найденные, системой исключаются; полученные адреса проверяются на доступность. Есть возможность конфигурации работы с поисковыми серверами (можно выбрать серверы, с которыми будет работать система, указать максимальное число ссылок, получаемых с каждого сервера и т.д.).

Однако и в случае использования метапоисковых систем не обойтись без знаний о традиционных поисковых серверах - именно они служат базой для всякого поиска.


5. Программное обеспечение электронной почты для передачи и обработки сообщений в системе REX400 и сети Интернет

Электронная почта (ЭП) - Electronic mail (E-Mail) - средство передачи сообщений или документов между пользователями без применения бумажного носителя. Сообщения могут включать в себя тексты, изображения, данные. Для передачи сообщений могут объединяться компьютеры самых различных конфигураций и совместимостей.

Для хранения сообщений перед их передачей используют электронные почтовые отделения (международные, национальные, региональные, фирменные и т.д.), В отделениях создаются почтовые ящики пользователей.

Развитие технологий ЭП привело к расширению её сервиса:

  • срочная и несрочная доставка,
  • многоадресная доставка,
  • временное хранение,
  • речевое извещение,
  • извещение о не доставленных сообщениях,
  • информирование адресатов о поступивших для них сообщениях,
  • предоставление справочника адресатов.

Передача сообщений может осуществляться через телефонную сеть, цифровую сеть с интегральным сервисом (ISDN) и сети других типов.

Единицей информации, посылаемой при помощи ЭП, является сообщение, построенное в соответствии с требованиями почтовой программы и протоколов.

Основные функции ЭП:

  • ввод документов в систему и вывод документов,
  • передача документов в почтовые ящики пользователей и обмен документами между ящиками,
  • проверка исправления ошибок, возникающих при передаче,
  • пересылка подтверждений о доставке документов,
  • рассылка документов по списку адресов.

Различные производители предлагают разные структуры ЭП. Многообразие компьютерных сетей порождает насущную проблему их интеграции или, по крайней мере, соединения на уровне обмена сообщениями. Разные сети различаются способами соединения машин друг с другом, скоростью, с которой передаются сообщения, системой, по которой машинам даются имена, и соглашениями о том, в каком виде должно быть сообщение (например, максимальный размер письма, который принимает электронная почта, или пишется ли адрес большими или малыми буквами).

Для того чтобы послать сообщение с машины, подключенной к одной сети, на машину в другой сети, нужно найти промежуточную машину, подключенную к обеим, через которую сообщение и пойдет. Такая машина называется шлюзом (Gate) между этими сетями. Шлюз принимает сообщение из сети А, переписывает его в форму, принятую в сети В, и отправляет через сеть В на ту машину, для которой оно предназначено.

Для удобства и надежной работы пользователей осуществляется стандартизация использования ЭП.


5.1. Принципы построения систем электронной почты на базе рекомендаций ITU-T. Электронная почта как компьютерная система обработки сообщений

Огромное многообразие систем ЭП, затрудняющее общение абонентов одних систем с абонентами других, вызвало потребность создания универсального стандарта, который был разработан Международным консультативным комитетом по телеграфии и телефонии (МККТТ) для унификации сервисных служб и возможности сопряжения систем, построенных с использованием различных технических средств. Этот стандарт получил название рекомендаций серии Х.400. Эти рекомендации аккумулируют в себе передовой опыт построения распределенных систем обработки сообщений и отражают перспективные направления и принципы развития систем документальной связи. Рекомендации Х.400 описывают структуру универсальной системы обработки и передачи сообщений, в которую заложена возможность сопряжения практически с любой почтовой системой и телематической средой (факс, телекс, телетекст, видеотекст, голос, видео, мультимедиа, системы электронного обмена данными, физическая доставка и др.).

Протоколы серии Х.400 практически исключают возможность потери или искажения передаваемой информации. В отличие от ЭП, применяемой в Internet, стандарт Х.400 изначально создан для коммерческих целей. Системы ЭП класса Х.400 отличаются высокой надежностью, великолепным сервисом и готовностью к развитию. Это привело к тому, что все современные системы ЭП либо строятся на стандарте Х.400, либо, как минимум, имеют шлюз в системы Х.400.


5.2. Структура системы передачи сообщений X.400. Протоколы и области управления. Имена и адреса, характеристика услуг в системе X.400. Многофункциональная система обработки и передачи сообщений REX400

Система REX400 обеспечивает обмен между различными телематическими средами (например, между факсимильной и телеграфной связью), между пользователями локальных и глобальных компьютерных систем (X.25.TCP/IP), Одним из главных преимуществ системы REX400 является интеграция широкого спектра почтовых, телеграфных и пр. услуг.

Отправитель | Получатель
 | ЭП REX400 | Другие ЭП | Факс | Телекс | АТ-50
ЭП REX400 | ДА | ДА | ДА | ДА | ДА
Другие ЭП | ДА | ДА | ДА* | ДА* | ДА*
Факс | ДА | ДА* | ДА | НЕТ | НЕТ
Телекс | ДА | ДА* | ДА | ДА | ДА
АТ-50 | ДА | ДА* | ДА | ДА | ДА

*При наличии организационно-правового согласования с данными системами ЭП.

Для работы с REX400 не требуется никакого специального оборудования, достаточно иметь ПЭВМ и модем, факсимильный модем или факсимильный аппарат, телетайп или программу-эмулятор телетайпа на ПЭВМ.

REX400 использует технологию "Store and Forward" (сохраняю и передаю), поэтому не нужно беспокоиться, включено ли оборудование у адресата (компьютер, факс, телетайп и др.) в момент передачи сообщения.

Размеры передаваемого сообщения практически не ограничены и могут быть от одного символа до нескольких мегабайт.

Сообщение может быть направлено одновременно неограниченному числу получателей.

Также можно зарегистрировать лист рассылки. Это позволит автоматически перенаправлять корреспонденцию, пришедшую на адрес листа рассылки, по адресам, приведенным в этом листе.

Информация в REX400 защищена. Лишь пользователь с зарегистрированным именем и известным только ему паролем имеет доступ к пришедшей на его имя корреспонденции.

Для доступа к системе REX400 можно использовать модем и подключиться непосредственно к станции системы REX400 через телефонную сеть общего пользования.

Кроме того, можно сначала подключиться к сети пакетной коммутации и через нее получить доступ к станции REX400. Работать таким образом придется, если станция, на которой зарегистрирован пользователь, не имеет коммутируемых входов. Данный способ предпочтителен, когда станция находится в другом городе.

Владельцы телеграфных терминалов могут подключиться к системе REX400 через телеграфную сеть общего пользования (телексную или АТ-50).

Пользователь может через шлюз в сеть Х.25 попасть в любые сети мира и иметь доступ к мировым информационным ресурсам.

Структурная схема системы REX400 показана на рис. 5.2.1.:

Рис. 5.2.1. Структурная схема системы REX400

AM - асинхронный модем (V.22, V.22bis, V.23, V.42, V.42bis)
ТА - телеграфный адаптер
ФМ - факсимильный модем (VFax-M/Board, ZYXEL и др.)
Почта - ЭП REX400
СА - сетевой адаптер Х.25

Рис. 5.2.1. Структурная схема системы REX400

Базовый компонент технологии - почтамт REX400 - содержит в себе следующие функциональные подсистемы:

  • RexMail - электронную почту Х.400,
  • RexFAX - подсистему факсимильного сервиса,
  • RexGATEWAY - шлюз в сети Х.25,
  • RexTelex/AT-50 - подсистему телекс/телеграфного сервиса,
  • RexInfo - информационно-справочную систему,
  • RexUUCP - шлюз в компьютерные сети с адресацией Internet,
  • RexMINIMAX - сетевую систему управления базами данных.

Подсистема RexMail обеспечивает почтовый сервис по электронной передаче сообщений в соответствии с международными рекомендациями сети Х.400, Содержание сообщения может представлять собой несколько объектов, каждый из которых может быть текстом или файлом в произвольной комбинации, а также вложенным сообщением.

Услуги подсистемы ЭП:

  • формирование сообщений с указанием его темы,
  • отправка сообщений по адресам следующих типов:
    1. адрес Х.400
    2. телексный адрес или адрес в сети АТ-50
    3. телефонный номер факсимильного средства
    4. адрес в формате Internet
    5. номер абонентского ящика в системе REX400
  • отправка пробы для абонентов с адресом Х.400,
  • перенаправление прочитанных сообщений,
  • регистрация личного абонентского ящика,
  • регистрация личного телекс/телеграфного номера для пользователей системы,
  • получение извещений о доставке, недоставке, прочтении сообщений,
  • возврат содержимого при недоставке сообщения,
  • многоадресная отправка сообщений,
  • ведение архивов для всех видов сообщений,
  • создание и ведение собственной области на почтамте для каждого пользователя,
  • поддержка удаленных операций с файлами в собственной области,
  • создание, управление и ведение телематических досок объявлений,
  • ведение и просмотр каждым пользователем индивидуальной статистики,
  • выбор языка общения и интерфейса,
  • возможность работы с системой в режиме реального времени (on line), используя любую коммуникационную программу,
  • возможность работы с системой в почтовом режиме off line, используя агенты пользователей удаленного доступа (для среды MS-DOS и Windows),
  • прием факсов, телексов, телеграмм, а также сообщений из компьютерных сетей с адресацией Internet.

Подсистема RexFAX позволяет пользователям подключаться к системе REX400, применяя обычный факсимильный аппарат, отправлять и принимать факсимильные сообщения, а также работать с факсимильной доской объявлений.

Услуги подсистемы:

  • прием факсимильных сообщений с факсимильных средств абонентов (факсимильный аппарат, факсимильный модем на компьютере),
  • рассылка факсимильных сообщений от пользователей других подсистем REX400:
    • из RexMail - текст, графические файлы в формате PCX
    • из RexTelex/AT-50 - текст
    • из RexFAX - факсы
  • рассылка факсимильных сообщений от пользователей других систем ЭП (Internet, Relcom и др.),
  • отправка сообщений администратору системы,
  • отправка сообщений по следующим адресам:
    • адрес Х.400
    • телефонный номер факсимильного средства
    • адрес в формате Internet
    • номер абонентского ящика в системе REX400
  • регистрация личного абонентского ящика,
  • доставка факсимильных сообщений пользователям системы REX400 (RexMail - в виде графического файла в формате TIFF, RexFAX - факсимильное сообщение),
  • многоадресная рассылка сообщений,
  • отложенная доставка сообщений (отправка сообщений в заданное время),
  • использование псевдонимов для сокращенного ввода адресов,
  • ведение архива для отправленных сообщений,
  • повторная отправка сообщений из архива (без твердой копии),
  • отправка сообщений зарегистрированными и незарегистрированными абонентами системы в абонентский ящик абоненту системы REX400 (факсимильному или абоненту ЭП),
  • прием сообщений в почтовый ящик пользователя после неудачных попыток доставки на его факсимильное средство,
  • прием сообщений с факсимильной доски объявлений,
  • прием сообщений из личного почтового ящика,
  • голосовая подсказка при работе с системой,
  • получение извещений о доставке или недоставке с указанием причины,
  • ведение детальной статистики для пользователя.

Подсистема RexGATEWAY позволяет пользователям подключаться и работать в режиме реального времени (on line) с ресурсами сетей Х.25.

Услуги подсистемы:

  • полная эмуляция работы высокоскоростного терминального концентратора (ПАД) по протоколу Х.28,
  • подключение к информационным ресурсам по сетевым адресам и сокращенным мнемоническим именам,
  • справочная поддержка по сетевым ресурсам,
  • возможность просмотра индивидуальной статистики и истории соединений.

Подсистема RexTelex/AT-50 позволяет подключаться к REX400 с обычного телеграфного аппарата, отправлять сообщения получателям различных телекоммуникационных сред.

Услуги подсистемы:

  • прием сообщений с обычных телеграфных и телексных аппаратов или соответствующих терминалов,
  • отправка сообщений получателям в ЭП, на факс, на телекс, телеграф по следующим адресам:
    • адрес Х.400
    • телексный адрес или адрес в сети АТ-50
    • телефонный номер факсимильного аппарата
    • адрес в формате Internet
    • номер абонентского ящика в системе REX400
  • получение извещений о доставке и недоставке сообщения,
  • многоадресная отправка сообщений,
  • отложенная доставка,
  • ведение и просмотр каждым пользователем индивидуальной статистики,
  • регистрация личного телекс/телеграфного номера или абонентского ящика для пользователей системы (конечным адресом может быть указан телефонный номер факсимильного аппарата, почтового ящика в системе REX400 или в другой почте Х.400, а также адрес абонента в компьютерных сетях с адресацией Internet).

Информационно-справочная подсистема Rexinfo предназначена для размещения текстовых материалов простой структуры (руководства, описания, справочники и др.) и предоставления доступа для работы с ней пользователям в режиме реального времени (on line).

Услуги подсистемы:

  • просмотр информации по гипертекстовому принципу,
  • поддержка многоязычного интерфейса,
  • сбор статистики по работе пользователей.

RexUUCP обеспечивает обмен сообщениями между абонентами системы REX400 и сетей с адресацией типа Internet, например с абонентами системы Relcom.

Услуги подсистемы:

  • поддержка для пользователей системы REX400 адреса в формате Internet,
  • прием из сетей с форматом адреса Internet сообщений и передача их абонентам системы REX400,
  • передача сообщений от абонентов системы REX400 абонентам с форматом адреса Internet,
  • рассылка телексов, телеграмм и факсов пользователям других компьютерных сетей, поддерживающих формат адреса Internet, средствами системы REX400 (через подсистемы RexFAX и RexTelex/AT-50).


5.3. Порядок использования программных средств для подготовки, передачи, приёма и обработки электронной корреспонденции в системе REX400

Для подготовки, редактирования, передачи, приема, обработки и хранения сообщений предназначена почтовая программа "Агент пользователя". Соединение со станцией REX400 устанавливается только на время, которое необходимо для отсылки заранее подготовленных сообщений и приема сообщений, поступивших в почтовый ящик.

Агент пользователя позволяет ускорить и облегчить работу по подготовке электронной почты, а также сократить время работы с системой REX400, что при активной работе с системой существенно снижает расходы.

Агент пользователя обеспечивает следующие виды соединения со станцией REX400:

  • по телефонной сети с помощью модема,
  • по нуль-модемному кабелю,
  • через терминальный концентратор (PAD) сети пакетной коммутации Х.25,
  • по каналам TCP/IP, по локальной сети.

Для работы с почтовой программой под управлением операционной системы MS-DOS необходимы следующие аппаратные средства:

  • IBM-совместимый компьютер с микропроцессором Intel 80286 или выше, объемом оперативной памяти не менее 640 К, графическим адаптером EGA или выше, жестким диском объемом не менее 5 Мбайт и хотя бы одним последовательным портом (СОМ-порт).
  • Дуплексный модем (V.22, V.22bis, V.32, V32.bis, V.42, V.42bis, MNP5) или полудуплексный модем "ИСМ-1200" ("ИСМ-1200М"), производимый АО "Мастак" или выделенный канал сети X. 25,

Программа выполняется в операционной среде MS-DOS версии 3.30 и выше. Перед началом работы должен быть загружен экранный драйвер и драйвер клавиатуры для работы с русскими символами в альтернативной кодировке, а также драйвер манипулятора "мышь", если имеется второй последовательный порт.

Для работы с агентом пользователя необходимо установить соответствующее программное обеспечение на жесткий диск и затем задать его конфигурацию.

Установка и настройка параметров агента пользователя

Для установки агента пользователя на жесткий диск компьютера необходимо выполнить следующие действия:

  • убедиться в наличии необходимого свободного пространства на жестком диске, на который устанавливается агент пользователя,
  • вставить дистрибутивную дискету например, в дисковод "А:",
  • набрать в командной строке "setup.bat х:", где х - имя жесткого диска, на который будет установлен агент пользователя.

После запуска программы установщика на экране компьютера будет выводиться информация о процессе установки. В случае успешного завершения установки агента пользователя на экране монитора появится сообщение:

"Установка Агента Пользователя прошла успешно".

В случае возникновения ошибок при установке на монитор компьютера будет выведено сообщение об ошибке.

Примечание:

В файле "config.sys" должно быть указано количество файлов, к которым MS-DOS может обращаться, не менее 30.

Например: FILES=35

Примечание:

В файле "autoexec.bat" в пути доступа к исполняемым файлам необходимо добавить путь к агенту пользователя.

Например: PATH=C:\DOS;C:\NC;C:\WINDOWS;C:\UA-REX

После установки агента пользователя на компьютере необходимо произвести настройку системы, включающую в себя задание конфигурации агента пользователя, параметров пользователя и параметров коммуникационного порта. В дальнейшем все параметры можно редактировать с учетом их изменения Администратором станции (например, имя станции) или пользователем (например, пароль).

Для задания иди изменения параметров агента пользователя выберите клавишами навигации в главном меню пункт "Настройка" и подпункт "Настройка системы", нажмите клавишу "Enter". На экране монитора появится блок диалога "Настройка системы".

Блок диалога содержит следующие окна:

  • Текстовый редактор - имя текстового редактора,
  • Часовой пояс - временная поправка часового пояса относительно Гринвича (для Москвы 3),
  • Порт - тип подключения к станции REX400,
  • Тип монитора - цветной или черно-белый,
  • Язык общения - английский или русский.

Пользуясь клавишами "Tab" и "Shift-Tab" для перехода между окнами и клавишами навигации для установки ключей, введите параметры в соответствующих окнах.

Для записи внесенных изменений нажмите "Enter", для выхода без записи - "Esc".

Параметры пользователя необходимо вводить в соответствии с присвоенными атрибутами при регистрации в системе.

Для задания или изменения параметров пользователя выберите клавишами навигации в главном меню пункт "Настройка" и подпункт "Параметры пользователя", затем нажмите клавишу "Enter". На экране монитора появится блок диалога "Параметры пользователя". Блок диалога содержит следующие окна:

  • Логическое имя - для ввода уникального имени в системе пользователя (логическое имя или LOGIN) в виде буквенно-цифровой строки символов,
  • Пароль - для ввода пароля,
  • Фамилия, Имя, Инициалы, Поколение, Организация, Подразделение 1, Подразделение 2, Подразделение 3, Подразделение 4 для задания адреса в системе REX400 в формате Х.400,
  • Адрес станции - для задания адреса станции REX400,
  • Код страны и Код города - для задания цифрового кода страны и кода города пользователя, которые будут автоматически подставляться в факсимильный адрес получателя, если они не указаны непосредственно в строке телефонного номера,
  • Номер сообщения - для задания номера, начиная с которого система автоматически будет формировать номера новых сообщений.

Пользуясь клавишами "Tab" и "Shift-Tab" для перехода между окнами, введите параметры в соответствующих окнах.

Для записи внесенных изменений нажмите "Enter", для выхода без записи - "Esc".

В случае, если не определен какой-либо из обязательных параметров, то система выдаст предупреждение, например "Не задано поле <Логическое имя>".

Параметры порта необходимо вводить в соответствии с установками коммуникационного оборудования (модема), а также с учетом параметров точки входа на станцию REX400.

Для задания или изменения параметров порта выберите клавишами навигации в главном меню пункт "Настройка" и подпункт "Параметры порта", нажмите клавишу "Enter". На экране монитора появится блок диалога "Параметры порта". Блок диалога содержит следующие окна:

  • Порт - номер коммуникационного порта, к которому подключен модем. Альтернативные значения; СОМ1, COM2, COM3, COM4,
  • Скорость передачи - значение скорости, на которой модем будет передавать и принимать данные; параметр зависит от типа компьютера и используемого модема. Его значение может варьироваться в диапазоне от 300 до 115200 бит/с,
  • Контроль - опция контроля, параметр указывает на то, каким образом используется бит четности. Его значение определяется на основании значений информационных битов (см. Разрядность) и может дополнять сумму информационных битов до четного числа (EVEN) или до нечетного числа (ODD). Если этот режим не используется, то параметр принимает значение (NONE),
  • Бит данных - число информационных бит в байте при передаче данных, Допускаются значения: 7 или 8 бит,
  • Стоповых бит - число бит, которые замыкают передаваемый информационный байт. Допустимые значения: 1 или 2 бита,
  • Инициализация модема - строка настройки модема, которая вводится в модем перед сеансом связи,
  • Файл сценария " сценарий подключения к почтовой станции REX400.

Для записи внесённых изменений нажмите "Enter", для выхода без записи - "Esc".

На рис. 5.3.1. представлена блок-схема алгоритма установки и настройки агента пользователя.

Рис. 5.3.1. Алгоритм установки и настройки агента пользователя.

Рис. 5.3.1. Алгоритм установки и настройки агента пользователя.

Запуск агента пользователя осуществляется инициацией программы ua_rex.exe.

После запуска агента пользователя на экране монитора появится окно для ввода пароля.

Введите пароль и нажмите "Enter". При вводе пароля в строке будет выводиться символ "*". Если это первый вход в почтовую программу, то нажмите "Enter". Если пароль введен правильно, на экране будет выведено меню. Можно начинать работу с агентом пользователя системы REX400.

Чтобы завершить работу с агентом пользователя, надо нажать клавиши "Alt+X" или выбрать через меню следующий пункт:

"Выход" - "Завершить работу".

Подготовка электронного сообщения

Для того, чтобы подготовить новое сообщение (шаблон сообщения), нажмите клавишу "F4", или в главном меню "Сообщение" выберите опцию "Создать новое сообщение". На экране появится шаблон нового сообщения, в котором будет присутствовать только имя отправителя (Originator).

Теперь заполните следующие поля сообщения:

  • тема сообщения,
  • адрес(а) получателя(ей) (основные получатели, получатели копии, получатели слепой копии),
  • тело сообщения (текст, присоединенные файлы),
  • отложенная доставка.

Тема сообщения:

Тема сообщения - это произвольный текст длиной не более 128 символов на русском или английском языке, содержащий краткую аннотацию сообщения.

Для того, чтобы ввести тему сообщения, нажмите клавиши "Shift+F5", или выберите в главном меню подпункт "Сообщение"/"Редактировать сообщение"/"Тема сообщения". На экране монитора появится блок диалога "Тема сообщения".

Ввод текста должен заканчиваться нажатием на клавишу "Enter". Для выхода без внесения изменений используется клавиша "Esc".

Примечание: для переключения клавиатуры РУС/ЛАТ используется установленный драйвер клавиатуры. Способ переключения клавиатур приведен в описании этого драйвера.

Ввод адресов получателей сообщения:

Для каждого отправляемого сообщения можно указать адреса указателей трех типов:

  • основные получатели,
  • получатели копии,
  • получатели слепой копии.

Для того чтобы сообщение было отправлено, необходимо указать хотя бы один адрес любого из перечисленных выше типов.

Окно списка адресов предназначено для отображения всех введенных в процессе работы с блоком диалога адресов получателей. Окно ввода блока диалога служит для ввода и корректировки адреса. Для перехода между окнами при работе в блоке диалога используются клавиши "Tab" и "Shift+Tab".

Ввод адресов получателей можно производить тремя способами:

1. непосредственный набор строки адреса,
2. покомпонентный ввод адреса,
3. ввод адреса с использованием адресной книги.

Выберите клавишами навигации в главном меню пункт "Сообщение"/"Редактировать сообщение"/... и подпункт в зависимости от типа адреса, например, "Основные получатели".

На экране компьютера появится блок диалога для ввода списка адресов соответствующего типа. Он состоит из двух окон - для ввода адреса ("Адрес") и для отображения текущего списка адресов ("Список адресов").

Клавишами навигации можно выбрать тип адреса, который хотите ввести, Нажмите "Enter" для покомпонентного ввода или "Esc", если достаточно хорошо знаете формат адреса, принятый в системе REX400, и можете ввести этот адрес в строке редактора.

При непосредственном вводе адресов получателей в окне ввода набирается строка адреса получателя с клавиатуры (после набора первого символа меню выбора типа адреса исчезнет), после чего нажимается клавиша "Enter". Адрес вводится в список адресов рассылки данного документа и отображается в окне списка адресов.

Примечание: пользуйтесь непосредственным вводом адреса, если точно знаете формат адреса. В данной версии агента пользователя не проверяется правильность ввода адреса.

При покомпонентном вводе адреса система выдаст меню для выбора типа адреса. Используя клавиши навигации, выберите тип адреса и нажмите клавишу "Enter".

В зависимости от выбранного типа адреса система выдаст на экран блок диалога для ввода соответствующего адреса.

Для ввода адреса в формате Х.400 система выдаст на экран монитора блок диалога "Адрес Х.400".

Первые три поля "C:", "ADMD:", "PRMD:" будут заполнены автоматически. Тем не менее, их можно изменить.

Пользуясь для перехода между окнами клавишами "Tab" и "Shift+Tab", введите адрес получателя электронной почты. Адресные аргументы задавайте в соответствующих окнах, отметьте необходимые услуги в окне "Сервис" клавишей "Space".

Примечание: обязательно должно быть заполнено поле "S:".

После окончания ввода адреса нажмите клавишу "Enter", и адрес занесется в список адресов рассылки и появится в окне списка адресов блока задания адреса.

Для ввода адреса получателя сообщения с использованием записной книжки система выдаст на экран монитора блок диалога "Имя адресата".

Пользуясь клавишами навигации, выберите имя из списка и нажмите клавишу "Enter". После выбора имени из записной книжки само имя будет занесено в список адресов рассылки, оно появится в окне списка адресов блока задания адреса.

Удалить адрес из списка адресов можно следующим образом:

  • перейти в окно "Список адресов:", нажав клавишу "Tab",
  • выбрать клавишами навигации удаляемый адрес,
  • нажать клавишу "Delete".

После запроса на подтверждение адрес будет удален из списка.

Если нужно отредактировать ранее внесенный в список адрес, то необходимо выполнить следующие действия:

  • перейти в окно "Список адресов:", нажав клавишу "Tab",
  • выбрать клавишами навигации редактируемый адрес,
  • нажать клавишу "Enter".

Выбранный адрес будет перенесен в окно "Адрес:". Отредактируйте адрес и нажмите "Enter". В список будет внесен откорректированный адрес.

Чтобы в составе сообщения отправить один или несколько файлов, следует нажать клавиши "Shift+F7" или выбрать клавишами навигации в главном меню пункт "Сообщение"/"Редактировать сообщение"/"Присоединенные файлы". На экране монитора появится блок диалога "Присоединенные файлы" для включения в состав сообщения.

В нижней части блока ввода отображается текущий путь.

Блок диалога включает четыре окна:

  • окно ввода имени присоединяемого файла "Имя файла",
  • окно списка присоединенных файлов "Список присоединенных файлов",
  • окно выбора файла из текущего каталога "Файлы",
  • окно выбора текущего каталога "Дир.".

Число присоединенных файлов не должно превышать 20.

В окне ввода имени файла введите имя присоединяемого файла или шаблон имени (в шаблоне допускается использование символов "*" и "?") и нажмите клавишу "Enter". Если введено имя файла, то имя будет занесено в список присоединяемых файлов.

Примечание: всегда указывайте полный путь к файлу.

Если введен шаблон, то маркер переместится в окно "Файлы", где можно непосредственно выбрать файл (подвести маркер к выбранному файлу и нажать "Enter"). Файл будет внесен в список присоединяемых файлов.

Для смены директории или диска перейдите в окно "Дир.:", используя клавишу "Tab", и выберите необходимую директорию. Имя текущей директории отображено под окном "Файлы".

Для удаления какого-либо файла из списка присоединенных файлов перейдите в окно "Список присоединенных файлов:", подведите маркер к удаляемому файлу и нажмите "Delete".

Для возврата в редактор сообщений по окончании формирования списка нажмите на клавишу "Esc".

Если необходимо продолжить формирование ранее созданного сообщения, загрузите его из "Рабочей папки" сообщений. Для этого в режиме выбора папок необходимо выбрать "Рабочую папку", и затем выбрать сообщение из списка. Сообщение будет загружено.

Блок-схема алгоритма подготовки сообщения представлена на рис. 5.3.2.

Рис. 5.3.2. Алгоритм подготовки сообщения.

Рис. 5.3.2. Алгоритм подготовки сообщения.

Передача и прием сообщений

Чтобы отправить подготовленные сообщения и принять со станции сообщения, пришедшие в Ваш адрес, нажмите клавиши "Ctrl+F2" или выберите клавишами навигации в главном меню пункт "Почта"/"Отправить и принять сообщения". На экране монитора появится окно со списком сообщений, подготовленных для отправки. Если этот список пуст, то на экран будет выведено сообщение об этом (приема и передачи в этом случае не будет).

Если Вы не хотите отправлять сообщение, находящееся в списке на отправку, то его можно удалить из отправляемого списка сообщений (при этом сообщение останется в папке на отправку). Для этого выберите его в окне, используя клавиши навигации, и нажмите на клавишу "Delete". Сообщение будет удалено из списка.

Примечание: все сообщения, удаленные из списка на отправку, останутся в папке "Сообщений на отправку".

Для отправки списка сообщений нажмите клавишу "Enter". Система автоматически произведет подключение к станции и передаст сообщения. В этом же сеансе будут приняты сообщения из Вашего почтового ящика на станции, они будут помещены в палку принятых сообщений.

Для отмены отправки сообщений нажмите клавишу "Esc".

Если необходимо только принять со станции пришедшие сообщения, то нажмите клавиши "Ctrl+F3" или выберите клавишами навигации в главном меню пункт "Почта"/"Принять сообщения".

Непосредственно перед отправкой агент пользователя запросит пароль. Введите пароль, который зарегистрирован на хост-станции. В процессе ввода пароля символы не отображаются в окне ввода.

В процессе отправки сообщений на экран компьютера выводится информация о текущем состоянии процесса передачи.

Если в сеансе связи были приняты сообщения, то информация о количестве принятых сообщений будет выведена на экран.

На рис. 5.3.3 представлена блок-схема алгоритма отправки сообщения.

Рис. 5.3.3. Алгоритм отправки сообщения.

Рис. 5.3.3. Алгоритм отправки сообщения.

Обработка полученной корреспонденции

С помощью агента пользователя принимаются информационные объекты двух типов: сообщения и извещения.

Все информационные объекты, полученные с почтовой станции, будут сложены в папку "Принятых сообщений". Выбирая сообщение (или извещение) из этой папки, можно прочитать его содержимое. Подведите маркер к сообщению и нажмите "Enter". Сообщение будет загружено.

Все полученные присоединенные к сообщению файлы будут находиться в поддиректории "File".

После того, как полученное сообщение прочитано, система предложит выбрать одну из альтернатив:

Если выберите пункт:

  • "Копировать в архив" - то сообщение будет переложено в папку "Архив отправленных сообщений" и можно работать с ним, считав сообщение из этой папки,
  • "Удалить" - то сообщение будет удалено,
  • "Перенаправить" - то будет создано новое сообщение, у которого в качестве содержимого будет вложено сообщение, а само сообщение переложено в папку "Архив отправленных сообщений",
  • "Возврат" - то вернетесь обратно в сообщение.

Примечание: сообщение (извещение) считается прочитанным, если после загрузки принятого сообщения либо загрузили другое сообщение, либо выгрузили сообщение, либо завершили работу.

Полученные извещения могут быть следующего содержания:

  • извещение о доставке,
  • извещение о получении,
  • абонент найден (после посылки пробы),
  • извещение о доставке в шлюз сети UUCP,
  • извещение о недоставке.

В извещении о недоставке будет указана причина.


5.4. Электронная почта в сети Интернет. Структура, организация и методы доступа в сети. Протоколы электронной почты

Служба электронной почты (e-mail) предназначена для обеспечения возможности обмена персональными сообщениями. Данная служба состоит из объектов клиентов службы (клиентских программ доступа) и серверов электронной почты. Каждый пользователь сети закреплен за своим сервером и имеет в нем электронный "почтовый ящик" под определенным именем. Для отправки сообщения достаточно передать его в определенном формате на свой почтовой сервер с указанием адреса получателя. Почтовый сервер, проанализировав адрес получателя, отправит сообщение через сеть почтовых серверов серверу, содержащему почтовый ящик получателя, куда это сообщение и будет положено. Для получения своих сообщений пользователь должен обратиться к своему почтовому серверу и считать их из почтового ящика.

Существует несколько типов служб электронной почты, базирующихся на различных протоколах обмена: Х.400, UUCP, SMTP, POP3 и др.

В сети Internet наибольшее распространение получила служба электронной почты, базирующаяся на протоколах SMTP и POP3.

Реализация электронной почты на базе протоколов SMTP и POP3

В сети Internet электронная почта передается по TCP-соединениям посредством агентов передачи сообщений Message Transfer Agent (MTA) -рис.1. Наиболее распространенный MTA для Unix систем - это Sendmail. Среднее почтовое сообщение содержит примерно 1500 байт данных, однако некоторые сообщения могут содержать мегабайты данных, если электронная почта используется для посылки файлов.

Передача почтовых сообщений осуществляется с использованием простого протокола передачи почты Simple Mail Transfer Protocol (SMTP).

Пользователь получает почту посредством протокола почтового отделения Post Office Protocol (POP3 - POP версии 3).

Для обмена почтовыми сообщениями пользователи общаются с пользовательскими агентами (user agent, UA), которые реализуют команды протоколов SMTP и POP3. Команды передаются в форме ключевых слов и указывают на необходимость совершить ту или иную операцию. В настоящее время существует очень много реализаций почтовых агентов пользователя, например, MS Outlook, Netscape Messenger, The Bat! и др.

Взаимодействие по протоколу SMTP строится по принципу двусторонней связи, которая устанавливается между отправителем и получателем почтового сообщения. При этом отправитель инициирует соединение и посылает запросы на обслуживание, а получатель отвечает на эти запросы. Канал связи устанавливается непосредственно между отправителем и получателем сообщения. При таком взаимодействии почта может дойти до абонента в течение нескольких секунд после отправки.

Агент пересылки сообщений - основной компонент системы передачи почты в сети Internet. После того как UA пошлет сообщение в выходную очередь, за дело принимается МТА. Он извлекает очередное сообщение и посылает его другому МТА. Этот процесс продолжается до тех пор, пока сообщение не достигнет почтового сервера получателя.

Для доставки почты из своего почтового ящика пользователь обращается к почтовому агенту, который, выполняя команды протокола POP3, переносит или копирует почтовые сообщения в почтовый ящик пользовательского агента.

Для взаимодействия по протоколу SMTP агент пользователя использует порт 25 на агенте передачи сообщений, а по протоколу POP - порт 110.

Протоколы SMTP и POP3 описаны в документах под названием Request for Comment (RFC).

RFC821 описывает протокол SMTP, а именно как UA общается с МТА и как общаются друг с другом агенты передачи почты по TCP соединению.

RFC 1939 описывает протокол POP3, то есть процесс доставки и команды взаимодействия с сервером POP.

Формат сообщения и адресация в системе электронной почты

Основной стандарт на формат сообщений электронной почты описан в документе RFC822. Согласно рекомендации RFC822, сообщение состоит из двух главных составляющих: конверта и содержания.

В конверте хранятся данные о пересылке и доставке сообщения. Также здесь имеется информация, необходимая для ответа на сообщение. Данные представляются в виде текстовых строк, состоящих из ключевого слова и значения, разделяемых между собой двоеточием. В конверте должны быть указаны как минимум адреса электронной почты отправителя и получателя.

Содержание сообщения состоит из заголовка и тела. Заголовок содержит информацию, созданную автоматически пользовательским агентом отправителя и агентами передачи сообщений, которые участвовали при пересылке электронного письма. В заголовке есть уникальный идентификатор сообщения, даты и время обработки сообщения каждым МТА. Пользовательский агент получателя может сжать, переформатировать или вообще скрыть заголовок сообщения.

Тело содержит текст, созданный отправителем. Тело сообщения отделяется от заголовка пустой строкой.

Первоначально для представления содержания письма было определено использование только символов ASCII-кода. Специально разработанный стандарт MIME (Multipurpose Internet Mail Extensions - многоцелевые расширения для Internet-почты) описывает как пересылать по электронной почте исполняемые, графические, мультимедийные, смешанные данные. Почтовый стандарт MIME приведен в документе RFC 1521.

Основные ключевые слова и их назначение:

To:
Основной получатель. Указывается адрес электронной почты. Можно указать адреса нескольких получателей через запятую. From: Автор сообщения. Указывается адрес электронной почты.
Cc:
Carbon Copy. Дополнительные получатели, синтаксис такой же, как для поля "To".
Bcc:
Blind Carbon Copy. Дополнительные получатели, адреса которых не должны быть видны другим получателям. Синтаксис аналогичен полям "То" и "Cc".
Subject:
Тема письма.
Date:
Дата и время написания письма.
Return-Path:
Служит для указания адреса возврата письма.
Reply-To:
Адрес для ответа на прочитанное письмо.
Message-ID:
Уникальный идентификатор сообщения, присваиваемый электронному письму почтовой системой отправителя. Как правило, идентификатор составляется из текущей даты, времени, адреса компьютера и некоторой случайной величины.
In-Reply-To:
Ссылка на письмо, ответом на которое является настоящее письмо.
Received:
Содержит путь прохождения письма по почтовым серверам. Полей обычно несколько, и каждое такое поле обозначает один сервер в маршруте. Серверы указываются в обратном хронологическом порядке, то есть каждый новый сервер вставляет свою запись сверху.
MIME-Version:
Наличие этого ключевого слова говорит о том, что текст письма форматирован в соответствии со стандартом MIME. Значение слова указывает используемую версию стандарта.
X-Mailer:
Информация о почтовой программе, использованной для написания письма.
Priority:
Приоритет письма. Может быть "Normal" (обычным), "Urgent" (срочным), "Non-urgent" (не срочным). Может оказывать влияние на скорость обработки и передачи письма различными промежуточными почтовыми системами.
Importance:
Пометка от отправителя получателю о важности сообщения - "High", "Normal" или "Low". He влияет на скорость пересылки.
Content-Tape:
Формат содержимого письма. Определяет тип информации в письме и способ ее представления. В частности, задается кодировка письма, если используется какой-либо национальный набор символов.
Content-Transfer Encoding:
Метод кодировки, используемый в письме, согласно стандарту MIME.

Адреса пользователей электронной почты в сети Internet имеют следующий формат:

<имя_полъзователя>@<почтовый_домен>

Знак "@" входит в состав символов кода ASCII (код 01000000) и называется - коммерческим "эт". Используется в качестве специального сокращения со значением предлога "на".

Слева от знака "@" записывается уникальный идентификатор конкретного пользователя. Он не должен совпадать для нескольких пользователей на одном почтовом сервере. Правила составления имени определяются почтовой системой. Например, на общедоступном почтовом сервере mail имя может состоять из латинских букв, цифр, символов "_" и "-", и не может быть длиннее 16 символов.

Справа от знака "@" записывается имя почтового домена, которое в частном случае может быть именем сервера, обслуживающего почтовый ящик пользователя. Имя состоит из названий поддоменов (уровень доменов уменьшается справа налево). Имя сервера можно рассматривать как самый младший поддомен в электронном адресе. В качестве разделительного знака между поддоменами используется "точка".

Например, в адресе ivanov@pds.sut.ru "ivanov" имя пользователя, а "pds.sut.ru" доменное имя почтового сервера, который находится на кафедре ОПДС (поддомен "pds") кафедра является структурным подразделением Государственного университета телекоммуникаций (поддомен "sut"), университет является уникальным учебным заведением в России (поддомен "ru").

Для пересылки электронного сообщения по сети Internet доменному адресу (текстовому логическому имени почтового сервера) ставится в соответствие электронный адрес (IP-адрес). Перевод доменных имен в их точные IP-адреса осуществляет программа на сервере доменных имен, который входит в состав системы доменных имен - Domain Name System (DNS).

Рис. 5.4.1. Пример реализации электронной почты в сети Internet.

Рис. 5.4.1. Пример реализации электронной почты в сети Internet


5.5. Программные средства для подготовки, отправки, получения и обработки электронных писем

Значительный объём информации, передаваемый в сети Internet, занимает электронная почта, поэтому выбор программы для работы с ней является достаточно важной задачей.

  • Netscape Mail. Входит в пакет программ Netscape Navigator. Пакет программ широко распространён и удобен в работе, но не является русифицированным. Поэтому возможны проблемы с использованием русских символов при наборе и чтении писем на русском языке, что несколько снижает привлекательность использования этой программы.
  • Eudora. Является одной из самых распространенных программ для работы с электронной почтой. Одним из ее несомненных достоинств является то, что базовая версия этой программы Eudora Light распространяется свободно и бесплатно. Коммерческая версия программы Eudora Pro требует регистрации и содержит в себе больше функциональных возможностей. Она так же широко распространена и не является русифицированной.
  • dMail. Разработана для создания, редактирования, приёма и передачи сообщений в сети Relcom, которая является старейшей и наиболее крупной компьютерной сетью России и около десяти лет входит в состав Internet. Одним из несомненных достоинств программы dMail является то, что эта программа написана в России и предназначена для работы с сообщениями на русском языке. Также достоинством является поддержка всех существующих протоколов работы с электронной почтой, в том числе протокола UUCP.
  • Internet Mail. Входит в комплект Internet Explorer - одного из популярных пакетов программ для работы в Internet.
  • Outlook Express.
  • The Bat.

В комплект поставки Microsoft Windows уже входят программные продукты для работы с электронной почтой, например Outlook Express.

Интересной альтернативой, заслуживающей внимания пользователей, ведущих активную переписку и связанных с электронной почтой по характеру своей работы, может быть почтовый клиент по имени "The Bat". Узнать этот продукт можно по изображению летучей мыши на заставке программы при загрузке и в уголке каждого окна почтового клиента. (Bat в переводе с английского языка как раз и означает - "летучая мышь"). Программа разработана фирмой RITLABS (www.ritlabs.com).

Эта программа может быть установлена в разных конфигурациях. Так один из вариантов предполагает, что программа работает на компьютере, который подключается к почтовому северу через телефонную сеть. В этом случае программа сама может дозвониться до провайдера, забрать почту и, если необходимо. То отключиться сразу же по окончании приема корреспонденции.

Конфигурирование программы производится с помощью пункта меню "Свойства" (Options) > "Подключение и Администрирование" (Network & Administration). Эта функция доступна только администратору.

Программа The Bat работает на уровне почтовых ящиков. Каждый отдельный ящик программа рассматривает как отдельного пользователя. Для каждого ящика можно установить пароль для доступа к содержимому. Содержимое писем можно просматривать как в виде текста, так и в виде HTML-страницы. В программе предусмотрена проверка орфографии вводимого текста. Назовем еще ряд отличительных особенностей The Bat:

  • возможность отключения автоматического просмотра письма при перемещении строки выделения по списку писем;
  • возможность создания индивидуального шаблона ответа для каждого адресата;
  • установка максимального размера принимаемых писем;
  • возможность открывать письма без их загрузки на ваш компьютер;
  • поддержка всех кодировок кириллицы;
  • установка автоматической перекодировки исходящих и входящих писем;
  • возможность сортировки входящей почты. Ключевое слово для сортировки может содержаться в любой части электронного документа;
  • шифрование писем с помощью PGP;
  • обработка прикрепленных графических файлов с помощью внешних редакторов.

Рассмотрим пример настройки клиентской почтовой программы The Bat для работы в сети Интернет. Предположим, что почтовый ящик пользователя зарегистрирован на сервере www.mail.ru.

Список параметров для настройки почтовой программы должен включать:

E-mail address: ваше_имя@mail.ru
POP3 сервер: pop.mail.ru
SMTP сервер: smtp.mail.ru
Имя пользователя: имя на mail.ru
Пароль: пароль на mail.ru

Запустите программу The Bat.

Выберите в меню "Ящик" > "Создать почтовый ящик", в поле "Имя ящика" указать имя папки для хранения электронной корреспонденции. В поле "Имя и фамилия" указать свои имя и фамилию, в поле "Адрес Е-mail" - адрес электронной почты, зарегистрированный на mail.ru. Указать имена SMTP-сервера и POP3-сервера. В поле "Имя пользователя" ввести имя, под которым вы зарегистрированы на mail.ru, поле "Пароль" оставить пустым, установить метку "Оставлять копии сообщения на сервере". Ответить "да" на вопрос "Проверить остальные установки ящика?".

Необходимо обратить внимание на следующие значения:

  • В разделе "Общие сведения" в полях "E-mail адрес" должно стоять: ваше_имя@mail.ru
  • В разделе "Транспорт" в качестве SMTP сервера должно стоять smtp.mail.ru; в качестве POP сервера - pop.mail.ru
  • В разделе "Кодирование 8-битных символов" должна стоять установка "Не кодировать"
  • В разделе "Доставка" должно стоять "Немедленная"
  • В поле "Пользователь" должно стоять ваше имя на mail.ru
  • В поле "Протокол" должно стоять "РОР3"
  • Опция "Шифровать при посылке" не должна быть включена
  • Убедиться, что в разделе "Специальное" установлены правильные значения портов служб: SMTP - 25, РОРЗ - 110
  • Пункт "Сохранять сообщения на сервере" должен быть отмечен

Остальные параметры могут быть установлены по вашему усмотрению.

Для проверки почтового ящика необходимо открыть созданную папку и воспользоваться пунктом меню "Ящик">"Проверить почтовый ящик" или кнопкой "Получить новую почту".

Для прочтения поступившей корреспонденции открыть папку "Inbox" и выбрать нужное письмо.

Для подготовки нового письма необходимо воспользоваться пунктом меню "Сообщение" > "Написать" или соответствующей кнопкой "Написать сообщение". В окне "Редактирование сообщения" заполнить заголовок и ввести текст письма.

Для отправки письма необходимо воспользоваться пунктом меню "Сообщение" > "Отправить немедленно" или соответствующей кнопкой "Отправить сообщение".

Отправленное письмо должно находиться в папке "Sent". Чтобы ответить на полученное письмо, необходимо его отметить, выбрать в пункте меню "Сообщение" подпункт "Ответить" или воспользоваться соответствующей кнопкой "Ответить на выбранные сообщения".

Ввести текст ответа. Если к письму надо прикрепить файл, следует воспользоваться кнопкой "Присоединить файлы", выбрать прикрепляемый файл. (К одному письму можно прикрепить до 4 файлов. Каждый файл не может превышать 500 Кбайт.)

Отправить письмо. Чтобы удалить письма из какой-либо папки, выберите эту папку ("Inbox", "Outbox", "Sent" или "Trash"), выделите письма и удалите их, воспользовавшись кнопкой "Удалить выбранные сообщения" или подпунктом "Удалить" из пункта меню "Сообщение".


5.6. Программное обеспечение, оборудование и меры безопасности, используемые для защиты электронной почты

Рассмотрим пример использования программы Pretty Good Privacy (PGP) для защиты электронной почты посредством шифрования и цифровой подписи.

Для защиты электронной переписки и гарантии достоверности источника сообщения применяются два ключа: общедоступный и личный.

Генерация общедоступного и личного ключей

При использовании PGP в первый раз, сначала необходимо сгенерировать пару ключей, выбрав в меню '"Keys" программы PGPkeys пункт "New Key". После генерации ключей вам будет предложено отослать отрытый ключ на публично доступный сервер ключей certserver.pgp.com.

Пользователь, с которым вы ведете переписку, должен знать ваш открытый ключ. Он может получить его с сервера certserver.pgp.com, если вы туда его отослали, или вы можете отослать его пользователю электронным письмом. Для этого надо скопировать ключ из главного окна PGPkeys в окно почтового сообщения.

Пользователь, получивший ваш ключ,. сможет шифровать направляемую вам почту. Чтобы посылать зашифрованные письма ему, вам потребуется получить его открытый ключ.

Идентификатор своего личного ключа можно узнать, выбрав этот ключ в главном окне программы PGPkeys и использовав пункт "Properties" меню "Keys" этой программы.

Чтобы подтвердить подлинность общедоступного ключа другого пользователя, этот ключ надо подписать. Для этого выделите его и выберите пункт "Sign" из меню "Keys" в PGPkeys.

Чтобы указать степень доверия, с которой вы относитесь к какому либо общедоступному ключу, выделите его и щелкните на нем правой кнопкой мыши, выберите из контекстного меню пункт "Key Properties". Если вы установите степень доверия к этому ключу ("Trusted"), другие ключи, подписанные его владельцем, будут считаться действительными.

Чтобы отозвать ключ, выделите его и выберите пункт "Revoke" из меню "Keys" в PGPkeys.

Импорт открытого ключа PGP из сообщения

Открытые ключи PGP могут рассылаться в виде текстовых ASCH-файлов. Для импортирования открытого ключа PGP из почтового сообщения служит команда главного меню ''Инструменты" ^"Импортировать PGP ключ".

Шифрование сообщения с помощью PGP

Чтобы зашифровать сообщение для определенного получателя, надо иметь его открытый ключ.

При помощи The Bat! можно зашифровать сообщение либо вручную из редактора сообщений, используя команду меню "PGP">"Зашифровать весь текст", либо автоматически, включив опцию "PGP">"Зашифровать перед отправкой".

Расшифровка сообщении, зашифрованных PGP

Для расшифровки зашифрованного сообщения необходимо в программе The Bat! выбрать пункт меню "Инструменты">"Расшифровать POP".

Добавление цифровой подписи в сообщение

Сообщение можно подписать либо вручную из редактора сообщений, используя команду меню "PGP">"Подписать весь текст" или "PGP">"Подписать блок", либо автоматически, включив опцию "Подписать перед отправкой" из меню PGP.

Верификация сообщении, снабженных цифровой подписью

Для верификации полученного подписанного сообщения необходимо выбрать команду главного меню "Инструменты">"Проверить подпись PGP". Алгоритм обработки цифровой подписи позволяет выяснить, является ли отправитель сообщения, указанный в заголовке письма, и поставивший цифровую подпись одним и тем же лицом, и не претерпело ли сообщение модификацию в пути.


5.7. Сравнение глобальных электронных почт X.400 и Internet Mail

1. Разработчики

Стандарт Х.400 был разработан ITU (International Telecommunications Union) и признан ISO (International Standardisation Organisation). Почта Internet Mail разработана IETF (Internet Engi-neering Task) - добровольной некоммерческой организацией.

IETF признана ISO и ITU как полноправный член процесса стандартизации с юридическим оформлением этого факта и взаимным членством.

2. Доступность стандартов

Важнейшим отличием между ISO/ITU и IETF является их подход к публикации своих стандартов. Публикации ISO/ITU стоят денег и защищены авторскими правами.

IETF всегда декларировала, что публикации RFC должны быть доступны всем желающим сети Internet, без ограничений на копирование и распространение. Результатом такой политики стало то, что разработка приложений для Internet стала делом, доступным даже любителям, в то время как создание продуктов, поддерживающих стандарты ISO/ITU, требует наличия некоторого начального капитала и уверенности в том, что потраченные деньги вернутся.

Почта Internet Mail привлекательна:
  • Простотой
  • Широчайшей распространенностью
  • Дешевизной
  • Множеством новых (но далеко не общепринятых) свойств, таких, как MIME и уведомления о доставке
Почта X.400 привлекательна:
  • Строгой - можно сказать, даже жесткой - стандартизацией
  • Наличием коммерческих операторов с гарантированным уровнем сервиса
  • Стандартизацией использования уведомлений о доставке и о получении

3. Цена

Цена складывается из следующих факторов:
  • Цена приобретения
  • Цена требуемой аппаратной платформы
  • Цена инсталляции
  • Цена обучения
  • Цена рабочего времени, затрачиваемого на работу с приложением
  • Цена технической поддержки
  • Цена обслуживания
  • Смежные расходы (платы оператору сети, поставщику услуг)

Internet Mail и Х.400 абсолютно не сравнимы по цене приобретения; самые дешевые продукты Х.400 дороже самых дорогих для Internet.

Цена аппаратной платформы сравнима.

Цена установки и настройки меньше у Х.400.

Цена обучения. Продукты Х.400, безусловно, сложнее, и полное овладение их возможностями требует серьезного обучения.

Цена времени, затраченного на работу с приложением, сравнима.

Наибольшей популярностью Х.400 пользуется среди государственных организаций всего мира.

Существует большое количество программных продуктов, реализующих Х.400. Помимо того, что большинство крупнейших производителей ПО, включая Microsoft, IBM, Lotus, Novell либо анонсировали, либо продают почтовые продукты, совместимые с Х.400, есть множество «чисто Х.400»-продуктов.

4. Адресация

Структура адреса различна, но имеются общие черты адресации:
  • Оба типа адресации в целом иерархические, когда администратор «высшего уровня» присваивает имена «низшему»
  • Оба используют в именах ограниченный набор символов
  • Оба могут быть разделены на компоненты
  • Оба типа создают глобальную схему адресации
  • Оба с трудом «переводятся» друг в друга

Система адресации Х.400 по атрибутам не во всех случаях может быть оправдана.

Большая часть атрибутов используется очень редко, например атрибуты физической доставки, необходимые в случае, когда электронное письмо в какой-то момент должно стать бумажным, быть заклеенным в конверт и доставленным почтальоном.

Название атрибута заставляет человека, читающего адрес, считать, что это название действительно соответствует реальному положению вещей. Человеку кажется, что в поле «organisation» стоит обязательно название организации, а если в неком адресе присутствует поле «surname», то этот адрес принадлежит человеку.

У пользователей также создается иллюзорное представление об иерархии адресов. Если в адресе стоит «O=Rosnet; S=Belozerov», это означает, что Belozerov использует услуги сети Rosnet, а вовсе не то, что Belozerov в этой компании работает.

Следующая проблема состоит в использовании обязательного атрибута «страна». SITA, крупнейший сетевой оператор, работающий для авиакомпаний, в одностороннем порядке начал использовать значение «C=WW» от «world wide», поскольку многие его пользователи не хотели быть привязаны в адресе к стране, с которой они имели мало общего. Консорциум ISODE, имеющий офисы в Англии и США, использует атрибут «C=FI», поскольку его оператор зарегистрирован в Финляндии.

5. Уведомления

Термин «Уведомление о доставке» используется для обозначения как собственно этого уведомления («да, письмо доставлено сюда»), так и обратного («нет, письмо не может быть достав-лено сюда»).

Формат уведомлений Internet Mail не стандартизован. Содержание сложно трактует смысл.

Уведомление Х.400 представляет собой сжатую двоичную структуру с четко определенным форматом.

Коды ошибок в Х.400 представляют собой числа, и возможность дописывать в уведомление какой-либо текст, например, трассировочную информацию. Коды ошибок покрывают большинство возможных ситуаций.

Почтовые системы Х.400 и Internet Mail существуют без видимой тенденции к победе одной из них, они дополняют друг друга. Любая большая компания должна иметь оба вида почты.

Х.400, как более предсказуемая в своем поведении и надежная, может служить для ответственных приложений, Internet Mail будет применяться как более дешевое решение.


6.1. Система факсимильного сервиса Санкт-Петербургского Телеграфа

Дисциплина
"Программное обеспечение систем передачи данных"

 Содержание

6.1. Сиcтема факсимильного сервиса Санкт-Петербургского Телеграфа

Общие сведения о системе факсимильного сервиса

Система расширенного Факс-Сервиса, предлагаемая Санкт-Петербургским Телеграфом, эксплуатируется как коммерческая сеть факсимильной связи на территории России, СНГ и дальнего зарубежья, а также имеет прямые выходы в международные телефонные сети.
В системе использован принцип "Store and Forward" (накопления и последующей передачи сообщений). Это позволяет существенно увеличить набор возможностей, предлагаемых пользавателям, по сравнению с обычным факс-аппаратом.
Факсимильные сети, построенные на этом принципе, уже получили широкое распространение в США, но еще только начинают внедряться в Европе и в Японии. Интерес к ним достаточно велик, поскольку системы такого типа не только принципиально совместимы со всемы важнейшими сетями "электронной почты" или обычной факсимильной связи, но и являются прекрасным дополнением к ним.
Адресаты, которым система расширенного Факс-Сервиса доставляет факс-сообщения, сами не обязательно должны быть абонентами системы. Для работы с системой необходимо иметь факс-аппарат или персональный компьютер с факс-модемом.
Все, что требуется от абонента для входа в систему - это лишь позвонить в центральный узел системы расширенного Факс-Сервиса Санкт-Петербургского Телеграфа и "представиться" системе, назвав свой персональный код-идентификатор и пароль.
Сетевые узлы работают круглосуточно. Система сразу же принимает у абонента вместе с кодом команды документ, соответствующим образом обрабатывает полученный документ и передает дальше в цифровом виде (либо непосредственно адресату, либо следующему серверу для ретрансляции - в зависимости от алгоритма маршратизации), используя современные методы сжатия данных и коррекции ошибок.

Система представляет абоненту следующие основные возможности.

  • Доступ к системе с любого факс-аппарата, имеющего возможность оперативного переключения режима набора номера телефона из импульсного в тональный.
  • Отправка документа, в том числе, и с подтверждением о доставке.
  • Доставка документа по номеру факса (любым адресатам) или по коду адресата (если он является абонентом системы). В последнеем случае доставленный документ может быть выведен на факсовый аппарат или положен в "почтовый ящик" адресата.
  • Доставка документа немедленно или с задержкой - дата и точное время доставки задаются отправителем в диалоговом режиме.
  • Автоматическая циркулярная рассылка одного и того же документа по заранее составленным спискам ("группам"). Списки создаются и модифицируются самими абоненотами с факс-аппарата в диалоговом режиме. Абонент в любой момент может запросить у системы распечатку созданной им группы (или групп), которая будет автоматически выведена на его факс-аппарат.
  • Обеспечение конфиденциальности передаваемой информации благодаря наличию у каждого абонента личного кода и пароля, присваиваемых ему при регистрации.
  • Возможность передачи и приема текстовых и графических файлов. Доступ к системе из любых сетей электронной почты.
  • Выдача квитанции с указанием результата выполнения команды абонента ("документ доставлен - не доставлен"), даты и времени доставки или причины, по которой система не смогла выполнить задание (занятость линии, отсутствие ответа со стороны принимающего факс-аппарата и.т.д.). Имеется возможность принимать эту информацию на факс-аппарат в виде списка.
  • Голосовые подсказки на одном из двух языков - русском и английском для менее опытных и начинающих пользователей, передаваемые на телефон/динамик факс-аппаратов. Возможо отключение подсказок или их игнорирование в ходе сеанса связи.

    • Система принципиально совместима с другими телекоммуникационными системаи и сетями. Сервер системы может взаимодействовать, после соответствующего дополнения аппаратными и програмными средствами, с сервером другой системы на базе одной "UNIX-машины".

    Вход в систему

    Для подключения к факс-серверу необходимо набрать со своего факс-аппарата телефонный номер системы расширенного Факс-Сервиса.
    После речевого приглашения от системы "Добро пожаловать в систему факс-сервиса", необходимо переключить свой факс-аппарат в режим тонального набора номера.
    После речевого приглашения от системы ''Наберите код и пароль", наберите свой код пользователя и пароль, присвоенные при регистрации.
    Введите команду задания режима работы системы и, при необходимости, параметры выбранной команды - номер факс-аппарата или личный код абонента системы расширеннного Факс-Сервиса, время отправки сообщения и.т.д. и.т.п.

    Команды

    Все команды системы Расширенного Факс-Сервиса Снкт-Петербургского Телеграфа объединены в несколько основных функциональных групп.

    ОТПРАВКА ДОКУМЕНТОВ

    - Без подтверждения о доставке
    - С передачей отправителю подтверждения о доставке. Подтверждение может быть передано на фвкс-аппарат отправителя или в почтовый ящик отправителя.

    После ввода соответствующей команды система может выполнить следующие действия.
    1. Отослать документ по указанному номеру факса немедленно.
    2. Отослать документ по коду пользователя немедленно.
    3. Отослать документ по коду группы немедленно.
    4. Отослать документ по номеру факса в указанное время.
    5. Отослать документ по коду пользователя в указанное время.
    6. Отослать документ по коду группы в указанное время.
    7. Положить документ в почтовый ящик (FAXBOX) пользователя.
    8. Положить документ в почтовый ящик группы пользователей.
    9. Отослать документ по указанному миникоду немедленно.
    10. Отослать документ по указанному миникоду в заданное время.

    ПРИЕМ ДОКУМЕНТОВ

    После ввода соответствующей команды система может выполнить следующие действия по приему документов из почтового ящика на факс-аппарат адресата.
    1. Получить все документы.
    2. Получить очередной (в порядке поступления).
    3. Получить документ по его номеру.
    4. Получить все документы, пришедшие от указанного пользователя системы.
    5. Удалить документ с указанным номером.
    6. Получить список (каталог) документов, находящихся в Вашем почтовом ящике.

    РАБОТА С МИНИКОДАМИ

    РАБОТА С ГРУППАМИ РАССЫЛКИ ДОКУМЕНТОВ

    ДОПОЛНИТЕЛЬНЫЕ КОМАНДЫ

    После получения от пользователя его личного кода и пароля система информирует его о том, что находится в "Основном меню", и предлагает выбрать одну из доступных команд.
    Если пользователю системы часто приходится набирать длинные телефонные номера (содержащие код страны, города и т.д.), то система расширенного Факс-Сервиса позволяет упростить эту задачу.
    Можно закодировать любой такой номер комбинацией, например, из одной или двух цифр. В списках команд на отсылку или на прием докумнетов предусмотрены специальные команды, указывающие системе, что введенное пользователем число должно интерпритироваться как сокращенный телефонный номер (миникод), подлежащий расшифровке. Система автоматически восстановит полный телефонный номер, по которому и произведет отсылку документа.
    Для более комфортной работы пользователя система после ввода дополнительных команд обеспечивает также следующий сервис.

  • Получить текущую речевую подсказку.
  • Присвоить пользователю статус "Начинающий" (с выдачей подробных речевых подсказок).
  • Присвоить пользователю стандартный статус (с выдачей сокращенных речевых подсказок).
  • Присвоить пользователю статус "Эксперт" (без выдачи речевых подсказок).
  • Разрешить системе прием документов с ошибками без запроса соответствующей санкции у пользователя.
  • Разрешить системе прием документов с ошибками с запросом соответствующей санкции у пользователя.
  • Повторить выполнение задания по отсылке документа.Номер задания указывается в квитанции, высылаемой системой.
  • Прекратить попытки выполнения задания по отсылке документа. Номер задания указывается в квитанции, высылаемой системой.
  • Выдача речевых подсказок на русском языке.
  • Выдача речевых подсказок на английском языке.
  • Выдача речевых подсказок на немецком языке.
  • Перейти в основное меню.
  • Перейти в предыдущее меню.
  • Получить подробную подсказку о командах текущего меню.
  • Перейти в меню отсылки документов .
  • Перейти в меню получения документов.
  • Перейти в меню получения документации по системе.
  • Перейти в меню работы с миникодами.

    • Выводы

    Система Расширенного Факс-Сервиса позволяет:
    1. Передавать факс-сообщения с высоким качеством.
    2. Система, получив факс-сообщение один раз, произведет нужное число попыток, необходимое для успешной доставки сообщения, не занимая входную линию (это особенно эффективно при групповой рассылке).
    3. Передавать все факс-сообщения по местному телефону (без набора кодов междугородней и международной связи).
    4. Выдавать уведомление о доставке факс-сообщеня (на E-mail или факс-аппарат).
    5. Осуществлять отправку факс-сообщений с помощью:
    - факс-аппаратов (Fax-to-Fax)
    - персональных комльютеров, оснащенных факс-модемами и специальным программным обеспечением (Telegraph Mailer-to-Fax)
    - путем передачи сообщений по электронной почте (E-mail-to-Fax)
    -путем передачи сообщений через WWW-сервер CПT (WWW-to-Fax)
    6. Отправлять факс-сообщение немедленно или в заданное время - особенно эффективно при отправке сообщений в страны с разными часовыми поясами.
    7. Оплачивать только успешно доставленные сообщения.
    8. Отправлять факс-сообщения круглосуточно.


6.2. Факс-Сервисы "Невалинк"

Факс-сервисы, предлагаемые "Невалинк", позволяют отказаться от использования факс-машины в офисе, если работа осуществляется в основном со странами Западной Европы, США, Канадой или Юго-Восточно-Азиатским регионом. Именно на этих направлениях экономия от использования новых технологий может достигать 95%.
Предлагаемый пакет дает пользователю несколько несомненных преимуществ:
1. Стоимость отправки гораздо меньше, чем обычно.
2. Тариф не зависит от времени суток.
3. Возможен автодозвон, если вызываемый телефонный номер занят. Сообщение, единожды отправленное в Сеть, что занимает несколько секунд, с вероятностью до 100% будет доставлено, если правильно указан номер телефона и у абонента установлен факсимильный аппарат.
4. Качество передачи не зависит от времени суток и остается неизменно высоким.
5. Возможно получение отчета о каждой отправке с анлизом причин, если факсимильное сообщение не получено адресатом.
6. Поскольку программное обеспечение совместимо с WINDOWS приложениями, нет необходимости печатать на бумаге рассылаемые документы. Качество изображения при этом ограничивается только возможностями факс-машины абонента.
7. До нуля сводится опасность отключения телефона, если Вы случайно забыли оплатить счета за международную связь.

Подключение к факс-сервисам не требует крупных расходов. При ежемесячных затратах на дальнюю связь свыше 200-300 долларов вложения окупаютя через 4-6 недель.


6.3. Автоматизированная факсимильная связь Global Enhanced Fax

Global Enhanced Fax-это услуга автоматизировнной факсимильной связи. Предлагается множество автоматизированных функций, независимо от сигналов "занято" и часовых поясов, включая многоадресную рассылку. Информационный поток между Вашими международными офисами, поставщиками и клиентами будет автоматизирован.
Продажа, переписка внутри компании, ведение делопроизводства и финансовой отчетности - это только некоторые области применения Global Enhanced Fax. Услуга представляет интерес для представителей всех отраслей бизнеса. Производители и дистрибьюторы увеличат объем продаж, оперативно передавая данные о наличии новой продукции и складских запасах. Банки смогут оперативно рассылать срочную информацию. Агенства и отделы связи с общественностью получат возможность автоматизировать работы по доставке обзоров срочных новостей, пресс-релизов и информационных сводок.
Глобал Один - это не просто объединение независимых компаний. Это новый единый организм, созданный Deutsche Telekom, France Telekom и Sprint. Услуга предоставляется в 20-ти странах мира на территории Азии, Европы, Северной и Южной Америки.

Многоадресная и единичная рассылка

На рассылку одного или сотни факсимильных документов требуется одно и то же время. Услуга позволяет автоматически отправлять информацию по заранее подготовленному адресному листу, что обеспечивает значительную экономию времени. Срочные многоадресные сообщения найдут адресатов во много раз быстрее.

Автоматический повторный набор

Система автоматически многократно повторит попытку передачи сообщения, экономя время отправителя.

Безбумажная технология

Каждое отправленное сообщение сохраняется в памяти под своим уникальным номером. Если абонент потерял полученное факсимильное сообщение, можно незамедлительно предоставить еше одну копию, указав номер документа. Информация будет отправлена по первоначальному или по новому адресу.

Альтернативная адресация

Можно увеличить вероятность доставки сообщения, задав альтернативный номер факс-аппарата назначения, который будет использован системой, если соединение с абонентом не устанавливается.

Миникоды

Можно присвоить хорошо запоминающиеся миникоды своим постоянным абонентам. Это увеличит скорость отправки сообщений.

Установка времени передачи данных

Отправителю не придется думать о разнице часовых поясов. Услуга позволит установить время доставки факсимильных сообщений в часы и дни, которые удобны адресатам.

Оперативное подтверждение

При получении адресатом информации отправитель получает подтверждение доставки сообщения. Оно включает дату, точное время доставки и количество переданных страниц.

Ежедневные журналы регистрации доставки

Ежедневно в удобное время можно получить полный отчет о работе факса за прошедший день. Это позволяет контролировать и анализировать деятельность сотрудников.

Коды счетов

Можно присвоить специальные коды каждому сообщению, а также любому отделу или сотруднику. Это облегчит учет и конроль расходов.


Содержание.

Дисциплина
"Программное обеспечение систем передачи данных"

 Титульная страница

Содержание

Введение в дисциплину.

1. Организация компьютерной телекоммуникации.

1.1. Общие принципы компьютерной телекоммуникации. Основные понятия и термины.

1.2. Классификация модемов. Модемы для подключения компьютеров к телефонной сети общего пользования.

1.3. Устройство и возможности современных модемов. Схема подключения модема к компьютеру и телефонной линии.

1.4. Интерфейсы модемов. Цепи и назначение сигналов интерфейса RS-232.

1.5. Индикаторы внешнего модема.

1.6. Модемные протоколы и стандарты. Виды протоколов. Протоколы взаимодействия и модуляции.

1.7. Необходимость коррекции и сжатия данных в модемах. Протоколы коррекции и сжатия данных.

1.8. Интеллектуальные возможности модемов для телефонных каналов. Управление модемами. Команды управления модемами (АТ-язык). Наборы АТ-команд.

1.9. АТ-команды для тестирования модема. Порядок выполнения местных (аналогового и цифрового) и удаленного цифрового тестов.

1.10. Назначение и использование S-регистров модема.

1.11. Режимы работы модема. Сообщения и ответы модема. Функции, выполняемые модемом в различных режимах. Действия для перехода из одного режима в другой.

1.12. Протоколы передачи файлов. Межкомпьютерный обмен файлами.

2. Телекоммуникационные пакеты программ для передачи и обработки файлов.

2.1. Требования к телекоммуникационному программному обеспечению для обмена данными между компьютерами по телефонному каналу.

2.2. Структура телекоммуникационных программных пакетов и назначение их основных компонент.

2.3. Режимы работы и функции терминальных программ. Команды, реализуемые телекоммуникационными программами.

2.4. Организация интерфейса для взаимодействия пользователя с телекоммуникационным пакетом программ. Основные пункты меню и их назначение.

2.5. Алгоритм действий пользователя при компьютерном приеме и передаче файлов по коммутируемой телефонной сети общего пользования.

2.6. Языковые и программные средства для реализации телекоммуникационных прикладных задач.

3. Программные средства для передачи и обработки факсимильных сообщений в компьютерных сетях.

3.1. Факс-модемная технология. Назначение факс-модемов. Основные характеристики факс-модемов.

3.2. Рекомендации ITU-T для факс-модемов. Управление факс-модемами.

3.3. Требования к телекоммуникационному программному обеспечению для обмена факсимильными сообщениями между факс-машинами по телефонному каналу.

3.4. Примеры программных пакетов для подготовки, передачи, приема и обработки факсимильных сообщений с использованием факс-модемов.

3.5. Порядок обмена сообщениями между факсимильным аппаратом и факс-машиной.

3.6. Методы сокращения полосы частот факсимильного сигнала. Алгоритм кодирования длин серий.

3.7. Методы сокращения полосы частот факсимильного сигнала. Алгоритм адресно-позиционного кодирования.

3.8. Методы сокращения полосы частот факсимильного сигнала. Алгоритм оптимального неравномерного кодирования.

4. Программное обеспечение для работы в сети Интернет.

4.1. Глобальная компьютерная сеть Интернет. Структура. Административное управление. Документы RFC.

4.2. Возможности, предоставляемые сетью Интернет.

4.3. Подключение пользователей к сети Интернет.

4.4. Возможности, структура, настройка и основные принципы работы с программными пакетами Microsoft Internet Explorer и Netscape Navigator.

4.5. Организация поиска информации в сети Интернет.

5. Программное обеспечение электронной почты для передачи и обработки сообщений в системе REX400 и сети Интернет.

5.1. Принципы построения систем электронной почты на базе рекомендаций ITU-T. Электронная почта как компьютерная система обработки сообщений.

5.2. Структура системы передачи сообщений X.400. Протоколы и области управления. Имена и адреса, характеристика услуг в системе X.400. Многофункциональная система обработки и передачи сообщений REX400.

5.3. Порядок использования программных средств для подготовки, передачи, приёма и обработки электронной корреспонденции в системе REX400.

5.4. Электронная почта в сети Интернет. Структура, организация и методы доступа в сети. Протоколы электронной почты.

5.5. Программные средства для подготовки, отправки, получения и обработки электронных писем.

5.6. Программное обеспечение, оборудование и меры безопасности, используемые для защиты электронной почты.

5.7. Сравнение глобальных электронных почт X.400 и Internet Mail.

6. Примеры систем факсимильного сервиса.

6.1. Система факсимильного сервиса Санкт-Петербургского Телеграфа.

6.2. Факс-Сервисы "Невалинк".

6.3. Автоматизированная факсимильная связь Global Enhanced Fax.

Заключение.