1. Ступени распределения вызовов

Основные понятия

Одной из основных задач существующих инфокоммуникационных технологий является предоставление пользователям информационных услуг, одним из самых ярких классов систем для оказания подобных услуг являются инфоцентры или центры информационных услуг, в зависимости от функциональности, называемые также Call- и контакт-центрами, центрами обслуживания вызовов и операторскими центрами.

Информационная услуга - это любая услуга, предусматривающая прием информации от клиента, обработку и, если требуется, дальнейшее продвижение этой информации, передачу клиенту ответной информации, а также распределение заранее подготовленной в центре информации по списку, т. е. передачу ее всем клиентам, занесенным в этот список.

Информационной услугой может быть прием всевозможных заказов, выдача разнообразных справок или сведений, передача группе клиентов объявлений по интересующим их вопросам и др. В предоставлении информационных услуг, как правило, участвуют операторы центра (называемые агентами).

Исторически первая версия инфоцентра — автоматические ступени распределения вызовов (СРВ), используемые в операторских центрах (рис. 1) и именуемые в англоязычной литературе Automated Call Distributor (ACD).

Операторские центры, как правило, работают в круглосуточном режиме, а интенсивность потока поступающих к ним вызовов может достигать нескольких сотен в минуту. В инфоцентрах используются информационные ресурсы, хранящиеся в соответствующих базах данных, обрабатывается и запоминается поступающая информация, автоматически протоколируется вся деятельность операторов, связанная с обслуживанием вызовов, а также выполняется целый ряд других функций.

Главной задачей, которую решают операторские центры, является обеспечение ответов на возможно большее количество входящих вызовов и/или создание и завершение возможно большего количества исходящих вызовов, ибо каждый вызов, требующий обработки в инфоцентре, либо является потенциальным источником дохода, либо несёт в себе важную информацию. Потеря вызова крайне нежелательна, а иногда и просто недопустима.

Помимо этого, должно обеспечиваться рациональное распределение входящих вызовов между операторами в соответствии с их функциональными задачами и квалификацией, а также возможность контроля работы операторов управляющим персоналом центра. Для этого в состав программного обеспечения инфоцентров часто включается приложение, которое выполняет функции интеллектуального распределения входящих вызовов согласно разным сценариям их обработки. В такие сценарии, которые либо программируются непосредственно администратором системы, либо выбираются им из некоторого набора возможных вариантов, заложены алгоритмы работы с запросом, правила оптимального выбора оператора (или группы операторов), методы и возможные результаты обслуживания того или иного клиента.

Рост популярности операторских центров на западе пришелся на середину 70-х гг. Это было обусловлено стремительным ростом потока входящих вызовов к крупным компаниям, что связано, во-первых, с ростом популярности торговли по телефону, а во-вторых, — с потребностями клиентов.

Практически в это же время стали распространяться СРВ в городских телефонных сетях СССР — это обусловлено потребностью в обращении к справочно-информационным службам ГТС, наиболее популярной из которых была служба информации о номерах телефонов 09.

Ступени распределения вызовов (образцы 1970–1980) представляли собой относительно простые специализированные коммутаторы, устанавливающие соединения с первым незанятым оператором в группе операторов. По современным критериям такие СРВ относятся, скорее, к менее интеллектуальным технологическим системам равномерного распределения вызовов UCD (Uniform Call Distributor), которые распределяют входящие вызовы между операторами группы в соответствии с заранее определённой и замонтированной логикой. Возможными алгоритмами распределения вызовов являются нисходящий метод (top-down) или более популярный циклический метод (round-robin). Подобные СРВ не предусматривали мониторинг или анализ трафика в реальном времени, не определяли, какой оператор наиболее загружен или дольше всех не был занят обслуживанием вызовов. Они не различали запросы клиентов; вне зависимости от вида запроса клиент слышал стандартное записанное сообщение: “Спасибо за звонок. Пожалуйста, не кладите трубку. В данный момент все наши операторы заняты. Через некоторое время вам ответят...”. Интеллект систем СРВ ограничивался выдачей статистических отчётов об общей производительности операторского центра (например, число вызовов на одного оператора в час). Не предпринимались попытки классифицировать вызовы по типам, объединить операторов и телефонную систему в локальную сеть, автоматически анализировать содержание запросов и т. п.

До последнего времен для оснащения операторских центров использовались системы трех основных категорий:

  • специально разработанные для этих целей системы типа СРВ 30/24;
  • УАТС с функциями СРВ типа Meridian, Hicom, Definity, Coral, Millenium и др.;
  • платформы компьютерной телефонии (CTI), в том числе их новейшие модификации, интегрированные с Интернет, и решения, предусматривающие комбинацию СРВ/УАТС и внешнего сервера CTI (рис. 2).

На рис. 2 не показаны средства аудиотекса, интеллектуальной обработки и маршрутизации поступающих и ожидающих вызовов, системы интерактивного речевого ответа (IVR), средства маршрутизации на основе указаний вызывающего абонента (Caller-Directed Routing) и другие средства автоматизации обработки вызовов, которыми уже давно оснащаются современные операторские центры, но которые обычно являются принадлежностью рассматриваемых на следующем занятии Call-центров, а не традиционных систем СРВ. К этому добавляются специфические функции, связанные непосредственно с процессом предоставления услуг справочно-информационными и диспетчерскими службами, службами бронирования билетов на все виды транспорта или мест в гостинице, вызова такси, экстренными службами (скорая помощь, милиция, газовая аварийная служба), операторами связи, предприятиями торговли по каталогам, справочными аптек и т. д.

В России спектр такого родаслужб раньше был несколько уже — СРВ применялись, главным образом, для оснащения экстренных спецслужб, а также справочно-информационных и заказных службГТС.

Функциональные возможности СРВ

Ступени распределения вызовов работают как системы обслуживания с ожиданием. Пока количество обслуживаемых входящих вызовов меньше, чем количество доступных терминалов операторов, каждый новый вызов будет немедленно направлен оператору в соответствии с используемым алгоритмом и логикой, содержащейся в специальной базе данных о правилах маршрутизации. Если же все операторы заняты, вызовы ставятся на ожидание. СРВдолжна вести мониторинг состояния операторов и направлять вызовы к свободным операторам в максимально возможном темпе.

Операторы — это самые дорогие компоненты операторского центра, а потому необходимо стремиться к повышению производительности их труда, применяя надлежащие алгоритмы функционирования СРВ (т. е. разумно организуя механизмы распределения вызовов и системы очередей).

Известно, что нагрузка операторского центраможет зависеть от дней недели, времени суток, сезона (очевидно, что летом, в период отпусков, операторские центры, занимающиеся бронированием билетов, загружены больше, чем, например, поздней осенью, а справочно-информационные службы обслуживают больше запросов в дневное время, чем в ночное). В связи с этим возникает необходимость оптимизировать характеристики ожидания клиентами обслуживания. Для этого требуется постоянно вести статистику загруженности операторов и, на основе накопленной информации, увеличивать или уменьшать их количество в часы (дни) пиковой нагрузки.

Важной функцией СРВ, которой оснащен операторский центр, предоставляющий платные услуги,является поддержка так называемых “черных списков” и “белых списков”. Это означает, что при приеме каждого входящего вызова анализируется информация о номере вызывающего абонента на тот предмет, в каком списке этот номер (или категория АОН) присутствует. Если номер обнаруживается в “черном списке”, то вызов получает отказ в обслуживании. Как правило, эта функция применяется службами, предоставляющими информацию в кредит. В “черные списки” могут вноситься номера неплательщиков или номера (маски номеров, список категорий), которым платные услуги в принципе не могут предоставляться в кредит (таксофоны, номера гостиниц и т. п.).

Возможности, которыми должна обладать современная СРВ,можно разделить на несколько больших групп:

  • функциональные возможности маршрутизации и обработки вызовов, имеющиеся в самой ступени;
  • функциональные возможности операторов;
  • функциональные возможности административного управления ресурсами.

Маршрутизация и обработка вызовов

В эту группу функций входят функции приема и обработки входящих вызовов, установления исходящих соединений, организации очередей и управления ими.

Возможности маршрутизации, которыми должна обладать СРВ, определяются задачами, которые выполняет центр обработки вызовов. Если операторский центр обслуживает только входящие вызовы (что встречается довольно часто), то функции маршрутизации сводятся к приему вызова и к определению того, в какую службу его надо направить. Это означает, что следует найти линию к свободному оператору нужной службы, а если таковых нет, то поместить вызов в соответствующую очередь.

Под службой понимается часть операторов, обслуживающих вызовы определенного типа и из определенной очереди. Существенно, что не каждая группа операторов должна иметь прямой номер в плане нумерации телефонной сети. Часто внутри одной службы организуется несколько групп операторов, одна из которых выполняет диспетчерские функции. Операторы этой группы принимают вызовы от абонентов ТфОП и переадресуют их к той или иной из остальных групп в соответствии со специализацией ее операторов (например, службы скорой помощи и некоторые справочные службы широкого профиля).

С точки зрения маршрутизации входящих вызовов к современным СРВ предъявляются следующие специфические требования:

  • возможность обслуживания входящих вызовов в ответном или предответном режиме;
  • идентификация вызывающей стороны по информации АОН;
  • поддержка в одной системе нескольких групп операторов и очередей.

Функции переадресации вызовов по заранее заданным критериям могут иметь разнообразные варианты реализации, которые в общем случае сводятся к двум:

  • переадресация вызовов к другой группе операторов в той же СРВ;
  • переадресация вызовов к другой СРВ.

Критериями, по которым производится переадресация, как правило, являются время суток, размер очереди к определенной группе операторов или к СРВ в целом, информация о вызывающем абоненте и т. п.

Дисциплины очередей и алгоритмы обслуживания вызовов

За каждым системным ресурсом, который может обслуживать вызовы с ожиданием, закрепляется некая очередь. Это означает, что вызов, который поступил в систему при отсутствии ресурса, способного его обслужить, не теряется, а устанавливается на ожидание.

Пока вызов находится в очереди, абоненту, его создавшему, обычно передается музыка или рекламная информация, или предоставляется связь с системой IVR.

Остановимся подробнее на дисциплине выбора вызовов из очереди и распределения их по рабочим местам операторов.

В ранних версиях СРВ эта дисциплина предусматривала маршрутизацию вызова, стоящего в очереди первым, к тому незанятому оператору, который был обнаружен первым при циклическом поиске (так называемая дисциплина Next Available Agent, NAA). Дисциплина NAA работает хорошо, если поступающий трафик равномерен, а все операторы имеют одинаковую квалификацию; в противном случае применение этой дисциплины ведёт к перегрузке наиболее квалифицированного персонала. Для такого случая лучше подходит дисциплина с маршрутизацией вызова, стоящего в очереди первым, к терминалу того оператора, который простаивал дольше других; подобная стратегия позволяет распределять нагрузку между операторами более справедливо.

Традиционно вызовы, установленные в очередь, обрабатывались по принципу FIFO: “первым поступил — первым обслужен”. Однако разнообразие задач, стоящих перед СРВ в центре обслуживания вызовов, приводит к разнообразным модификациям дисциплины организации очередей с возможностью производить выбор вызовов из очереди не только в порядке их поступления, но и по сложной многокритериальной системе (например, в первую очередь обслуживать вызовы от VIP-номеров и т. п.). Такими модификациями, наряду с FIFO и равномерным распределением вызовов между операторами, являются приоритетное обслуживание вызовов определенного типа или обслуживание вызова, в зависимости от его параметров, оператором соответствующей квалификации.

Помимо дисциплины выбора вызовов из очереди и выбора операторов для их обслуживания, и сами очереди, в зависимости от структуры системы, могут быть организованы разными способами:

  • индивидуальные очереди к каждому оператору;
  • очередь к службе (группе операторов);
  • единая очередь ко всем службам, доступным через данную СРВ.

По мере укрупнения и усложнения систем возникла необходимость создавать группы операторов общих интересов или одинаковой квалификации и устанавливать к каждой такой группе очереди вызовов от IVR, согласно схеме маршрутизации на основе информации АОН о вызывающем абоненте и т. п. При этом возможны случаи длительного ожидания в одних очередях при наличии незанятых операторов, обслуживающих другие очереди.

В более сложных вариантах организации очередей эта проблема решалась путём использования нескольких уровней возвратной маршрутизации (Fallback Routing). Вызов устанавливался в очередь к определенной группе операторов лишь на некоторое время, по истечении которого он маршрутизировался заново, имея при этом доступ к более крупной группе операторов. Если длительность ожидания и в этом случае достигала пороговой величины, вызов получал право доступа к еще более крупной группе операторов, маршрутизация производилась еще раз и т. д.

Существуют более сложные модификации дисциплины организации очередей. Такой модификацией является распределение поступающих вызовов с учетом интегрального показателя обслуживания вызовов и индивидуального коэффициента оператора. Вызов должен направляться к тому свободному оператору, для которого частное от деления интегрального показателя на его индивидуальный коэффициент является наименьшим.

Существуют модификации, связанные также и с анализом характера поступившего вызова с тем, чтобы направить его к оператору, который имеет квалификацию, наиболее подходящую для обслуживания именно этого вызова. Такая дисциплина называется SBR — маршрутизацией на основе квалификации (Skills-Based Routing). Этот способ маршрутизации становится жизненно необходимым для крупных комплексных СРВ и для их “прямых потомков” — инфоцентров, предоставляющих широкий спектр услуг, или для международных центров, которые должны обслуживать поступающие от клиентов вызовы на разных языках.

Операторы в системе

Ключевой объект операторского центра обслуживания вызовов — оператор. Согласно определению стандарта R.100, оператор (агент) — это человек или устройство, основной функцией которого является обработка вызова. Операторы идентифицируются в системе уникальным номером (именем) и имеют каждый свой пароль, который используется при регистрации оператора на рабочем месте (на конкретной консоли).

Понятно, что физически вызовы распределяются по консолям. Логически же распределение происходит по операторам, которые на этих консолях в данный момент зарегистрированы. Поэтому для СРВ, в которых поддерживается несколько служб, необходимо решить вопрос о распределении консолей по операторским группам. Распределение это может быть различным, следовательно, будут различаться и способы регистрации. Обычно это определяется организационной структурой операторского центра. Если известно, что консоли одной службы не могут использоваться операторами другой службы, то каждая консоль жестко закрепляется за какой-то группой; в этом случае оператор при регистрации вводит только свое имя и пароль.

Если же консоли могут использоваться операторами, работающими в любой из групп (служб) (например, это происходит сегодня во многих ГТС при организации платной и бесплатной справочных служб 09 и 009), то консоли ни за одной группой жестко не закрепляются, и в этом случае оператор, регистрируясь, дополнительно вводит номер группы (службы), в которой он собирается работать.

Консоль может быть реализована разными способами в зависимости от аппаратно-программных решений, примененных в оборудовании в целом. В любой современной системе распределения вызовов консоль состоит, условно говоря, из телефонной и компьютерной составляющих.

В традиционной архитектуре телефонная часть консоли обеспечивает прием телефонных вызовов и представляет собой устройство поддержки речевого диалога “абонент – оператор”. В самом простом случае — это аналоговый телефонный аппарат с гарнитурой, подключаемый к системе по двухпроводным аналоговым абонентским линиям.

В некоторых системах — это специализированный или стандартный телефонный аппарат ISDN, снабженный жидкокристаллическим дисплеем, светодиодами для индикации вызова и функциональными клавишами, посредством которых производятся все основные операции, связанные с его обслуживанием (прием, переадресация, отбой и т. п.).

Компьютерная составляющая поддерживает интерфейс оператора со специализированной базой данных службы. В большинстве сегодняшних систем эти две составляющие используют для обмена информацией принципиально разные сети и синхронизируются через управляющий сервер СРВ.

В наиболее удачных СРВ наблюдается тенденция к интеграции обеих составляющих в единое целое, что сделано, например, в СРВ 30´ 24. Обычно в таких СРВ аппаратные средства поддержки телефонного интерфейса встраиваются в персональный компьютер в виде специализированной платы. Подобное решение существенно повышает эффективность работы оператора, поскольку пользовательский интерфейс единого устройства более удобен, но стратегически является промежуточным, так как две сети внутри центра обработки вызовов по-прежнему функционируют раздельно.

Благодаря развитию средств передачи речи через сеть IP стало возможным интегрировать не только физические устройства, но и сети, а также решить вопрос с автоматической реализацией таких услуг, как “удержание соединения” и “наведение справки”, поскольку поддержка протоколами IP-телефонии нескольких речевых сессий — просто дело техники. Именно такие решения применены в инфоцентре нового поколения ПРОТЕЙ-РВ, реализованном на базе интеллектуальной платформы ПРОТЕЙ.

Оператор в системе обычно характеризуется следующими атрибутами:

  • фамилия, имя, отчество;
  • личный идентификационный номер;
  • личные регистрационное имя (номер) и пароль;
  • дополнительные данные, определяющие права и квалификацию оператора (категория, индивидуальный коэффициент и т. п.)

Управление этими атрибутами возлагается на администратора системы.

Возможности, предоставляемые оператору, определяются его правами и задачами, решаемыми данным операторским центром, в общем случае описываемые следующим набором функций:

  • регистрация в определенной операторской группе;
  • прекращение регистрации;
  • кратковременная блокировка консоли;
  • прием входящих вызовов из очереди (персональной, очереди группы, очереди центра);
  • переадресация вызова (другому оператору, старшему оператору, другой группе операторов, автоинформатору);
  • принудительное разъединение;
  • удержание соединения с одновременным служебным вызовом старшего оператора (для консультации);
  • запись разговора с абонентом;
  • прием от системы исходящего соединения, установленного ею по списку оповещения.

Старший оператор (контролер) имеет право не только заниматься обслуживанием вызовов, поступающих от абонентов, но и контролировать работу операторов в группе (подключаясь в режиме скрытого прослушивания и анализируя статистическую и оперативную информацию).

Оповещение о входящем вызове может быть передано на рабочее место оператора двумя способами:

  • посредством визуальной индикации;
  • тональным сигналом, посылаемым в гарнитуру оператора.

Служебная исходящая связь позволяет любому оператору получить, при необходимости, дополнительную справочную информацию или информацию, связанную с его работой в системе. Оператор может производить со своего рабочего места вызовы к другой группе операторов, к конкретному оператору в своей группе (если это разрешено), к старшему оператору своей группы, а также вызовы к автоинформатору и (при необходимости) к абонентам городской телефонной сети.

В зависимости от алгоритма работы службы, рабочие места операторов могут возвращаться в число доступных автоматически (по окончании разговора) или по команде оператора (например, оператор после разговора должен заносить в базу данных какую-либо информацию).

Статистика и учет вызовов

Как уже было упомянуто выше, важнейшими функциями СРВ являются учет вызовов и накопление статистической информации. Накопление и анализ статистической информации о работе операторов и в целом служб, организованных на базе СРВ, являются основным средством оценки эффективности функционирования центров и настолько важны, что некоторые телекоммуникационные форумы даже разработали набор нормативных документов, стандартизирующих эти функции. Одним из наиболее хорошо проработанных стандартов этого направления является стандарт R.100 форума ECTF.

Прежде всего, следует разделить накапливаемую и контролируемую информацию на три основные категории: статистическую, оперативную, учета вызовов.

Оперативная информация позволяет обслуживающему персоналу центра контролировать функционирование оборудования, оценивать текущую загрузку центра и т. п., к которой в общем случае можно отнести:

  • текущую загрузку разговорных каналов;
  • текущую длину очередей;
  • текущее состояние операторских консолей;
  • текущее состояние определенного оператора.

Информация учета вызовов содержит параметры каждого вызова, принятого/обслуженного/потерянного системой СРВ.

Основные параметры, статистические данные о которых накапливаются и анализируются компаниями, имеющими операторские центры:

  • тип вызова (входящий/исходящий/внутренний);
  • количество вызовов за определённый промежуток времени (по данным работы зарубежных операторских центров эта величина составляет порядка 100 вызовов на одного оператора в сутки и от 5 до 18 вызовов на одного оператора в час);
  • средняя длина очереди (величина, нужная для оптимизации числа операторов);
  • средняя длительность разговора (на основании данных о работе американских операторских центров эта величина приблизительно равна 3,5 минуты);
  • доход, полученный за день;
  • расходы на организацию исходящих соединений;
  • средняя стоимость обслуживания вызова для службы данного типа;
  • соотношение числа клиентов, обслуженных с помощью системы IVR и с помощью операторов;
  • время, в течение которого все линии заняты;
  • среднее время занятости оператора (продолжительность рабочего дня в центрах западных стран 65–75 %);
  • среднее число операторов, находящихся в системе за определённый промежуток времени;
  • среднее время удержания соединения;
  • средняя длительность интервала между окончанием обслуживания вызова и началом обслуживания следующего вызова (минимум 20 – 30 с);
  • максимальная длительность ожидания;
  • необслуженные вызовы (т. е. когда абонент не дождался ответа оператора или не дозвонился по причине занятости всех операторов и мест в очереди);
  • среднее число повторных вызовов;
  • идентификационный номер оператора, обслужившего вызов;
  • номер группы операторов;
  • процент обслуженных вызовов.

Архитектура и перспективы эволюции СРВ

С концептуальной точки зрения пик развития специализированных ступеней распределения вызовов теперь уже в прошлом, хотя в силу экономических причин они применяются до сих пор.

Основные их потребители — справочно-информационные и диспетчерские службы, службы бронирования билетов на транспорт всех видов или мест в гостинице, службы вызова такси, экстренные, службы поддержки абонентов операторов связи, клиентов организаций торговли по каталогам, медицинские регистратуры и т. д. Кроме того, существует огромное количество других организаций, производственная или торговая деятельность которых связана с необходимостью принимать и обрабатывать множество телефонных вызовов.

При организации подобных служб прежде всего оцениваются объем трафика, который необходимо обрабатывать, его тип (только входящий или двусторонний), требуемые группы операторов и их количество в группах, режим работы (дневной или круглосуточный) и т. п. Нельзя не учитывать также необходимость интеграции системы в инфраструктуру телекоммуникационной сети компании. Именно из-за многообразия задач компании-разработчики УАТС с функциями СРВ быстро поняли, что удовлетворить потребности всех потенциальных пользователей таких систем средствами только самой УПАТС невозможно в принципе. Чтобы дать заказчикам возможность наиболее полно адаптировать функциональные возможности системы к своим потребностям, многие производители приняли решение, которое отразилось на всем телекоммуникационном рынке: в УАТС был реализован интерфейс для внешнего управления алгоритмом обработки вызова Application Programming Interface, API.

Главное преимущество, которое достигнуто при внедрении API — функциональная расширяемость продуктов. Внешние управляющие системы, реализованные на базе технологии компьютерной телефонии, обеспечивают возможность модифицировать алгоритмы управления обслуживанием вызовов силами обслуживающего центр персонала. Иначе говоря, поставляемое с системой стандартное программное обеспечение, управляющее обслуживанием вызовов, может быть доработано и модифицировано персоналом СРВ (инфоцентра), что позволяет оператору или администратору самостоятельно разрабатывать правила управления обработкой отдельных вызовов.

Кроме того, извлекая и анализируя информацию, связанную с вызовом (номер вызывающего абонента, данные, полученные при диалоге с IVR и т. д.), и оперативно взаимодействуя с базами данных, системы компьютерной телефонии, подключаемые через API, к моменту приема собственно телефонного вызова уже обеспечивают оператора центра необходимой справочной информацией, относящейся к этому вызову.

Таким образом, вся информация, сопровождающая запрос клиента (номер телефона, имя, регион проживания, интересующий вопрос, номер счёта и т. п.), считывается из базы данных центра и появляется на экране рабочего места оператора (автоматически или по его команде).

Эта функция экономит рабочее время оператора и повышает психологический комфорт абонента, так как ему не приходится начинать общение с оператором “с нуля”, сообщая о себе нужные данные.

Еще одной полезной функцией, связанной с развитием компьютерных технологий, является автоматическая генерация речевого ответа на вызов, определяемого тем, оператор какой службы (или группы) зарегистрирован на данной консоли. Эта функция избавляет оператора от необходимости многократно произносить один и тот же текст и, как следствие, повышает эффективность его работы.

С ростом вычислительных мощностей компьютеров стало возможным возложить на системы компьютерной телефонии весь процесс обработки телефонных вызовов, включая обработку сигнализации, коммутацию и т. д. Так появились системы, полностью реализованные с использованием технологий CTI, которые могут сильно различаться между собой как по производительности, так и по функциональным возможностям; наиболее мощные из них сравнимы в этом смысле с центрами обработки вызовов, реализованными по “классической” схеме СРВ (УАТС + CTI).

Особенностью такого подхода представляется и то, что сегодня на него наиболее сильно влияют тенденции конвергенции телефонных и IP сетей. При создании корпоративной сети “с нуля” вполне уместно говорить о возможностях построения единой ориентированной на IP сети на базе современных IP-PBX с поддержкой этим же оборудованием прикладных функций операторского центра обслуживания вызовов. И именно этот подход представляется одним из наиболее перспективных.

Назад

Содержание

Вперед


2. Call-центры

Следующая ступень эволюции операторских центров — инфоцентры. Функциональные возможности СРВ в полной мере относятся и к инфоцентрам, при этом не следует забывать, что в англоязычных первоисточниках этими двумя терминами обозначаются два разных понятия.

СРВ (ACD) — это коммутационная система со специальными функциями (поддержка очередей, обслуживание вызовов с ожиданием).

Инфоцентр (операторский центр, Call-центр, центр обслуживания вызовов) — этоучреждение, оснащенное оборудованием, специализированными программными средствами и укомплектованное техническим и управленческим персоналом для обслуживания интенсивного потока вызовов операторами (телефонистками, агентами). Типичный инфоцентр оборудуется рассмотренной выше СРВ, подключаемой к АТС ТфОП или к УАТС компании.

Развитие бизнеса и ужесточение рыночной конкуренции неизбежно вели к росту требований, предъявляемых к оборудованию, которое более чем какое-либо другое причастно к формированию лица компании, т. е. к операторским центрам.

Основной задачей операторских центров является обслуживание мощного потока вызовов с минимальными потерями, для чего требуются специальные алгоритмы распределения вызовов и процедуры их обслуживания. С развитием в инфоцентрах компьютерной составляющей и, как следствие этого, все большего количества разного рода прикладных функций появилась возможность существенно усовершенствовать процесс обработки вызова. Прежде всего, это относится к включению в состав операторских центров систем IVR, без которых сегодня немыслимо ни одно серьезное учреждение подобного вида.

Функция систем IVR — повысить качество обслуживания вызовов и обеспечить абонентам определенные удобства при ожидании обслуживания, а также избавить оператора инфоцентра от рутинной работы, связанной с получением стандартной информации. Как правило, при использовании IVR алгоритмы обработки вызовов в операторском центре предусматривают передачу абонентам, ожидающим в очереди, музыкальных фрагментов или речевых фраз. Эти фразы могут содержать сведения о порядковом номере вызова в очереди, об ориентировочном времени ожидания или просто рекламную информацию о новостях и услугах компании. Кроме того, вполне возможно, что, прослушивая такие фразы, абонент получит нужную информацию (например, о котировках акций и курсах валют) автоматически. Клиенту, ожидающему в очереди, предоставляется меню, из которого он может непосредственно перейти к интересующей его информации, не дожидаясь ответа оператора. В ряде случаев автоматизированное меню обеспечивает возможность быстрой и правильной маршрутизации вызова к определенной группе операторов или даже к определенному специалисту.

Именно с помощью IVRоператорский центр чаще всего предоставляет всю рутинную информацию (часы работы предприятия, как к нему проехать и т. д.), чтобы на это не тратилось дорогостоящее время операторов. Вся подобная информация может быть заранее записана и предоставлена клиенту, пока его вызов находится в очереди. Некоторые системы позволяют клиентам сохранить своё место в очереди, пока они занимаются другими делами (например, обращаются к IVR для проверки текущего баланса), экономя время как клиента, так и оператора. Системы отправки факсов по запросу, например, позволяют получить информацию о продуктах и услугах, не обращаясь к оператору.

Важно отметить, что при проектировании операторского центра, в ходе определения конфигурации системы и проработки оптимального алгоритма обслуживания вызовов необходимо правильно определить тип клиентских запросов и особенности поведения самих клиентов. Дело в том, что применение той или иной технологии зависит от целей работы операторского центра. В частности, безусловно, удобная система IVR имеет две стороны. Если СРВ поддерживает большое количество служб одновременно, то использование многоуровневого речевого меню помогает быстро переадресовать клиента к любой точке системы, не занимая этим операторов. Однако использование такой системы компаниями, занимающимися, например, исследованием потребительского спроса, скорее всего, не принесет желаемых результатов: согласно исследованиям психологов, в таких ситуациях клиенты предпочитают иметь дело не с автоинформаторами, а с живыми людьми.

Существуют дополнительные формы общения абонента с IVR. Например, в часы пик, когда все операторы заняты, абонент может оставить оператору свой запрос в речевом почтовом ящике, зная, что оператор обработает этот запрос, как только у него будет свободное время (обычно в течение
1–2 ч), и свяжется с абонентом, оставившим запрос. При психологической готовности абонента к такому способу общения, подобный вариант обработки входящих вызовов существенно уменьшает среднюю длину очереди и интенсивность потоков транзакций. Важно лишь, чтобы абонент не забыл оставить номер контактного телефона, факса или адрес электронной почты.

Существенным требованием к инфоцентрам является необходимость тесной интеграции (и взаимодействия в процессе обслуживания вызовов) коммутационной подсистемы с информационными базами данных компании-владельца операторского центра. Для обслуживания каждого вызова (входящего или исходящего) требуется доступ к данным, хранящимся в информационных базах центра, и, возможно, модификация этих данных.

Для некоторых компаний необходима возможность предоставлять услуги в территориально разнесенных точках. Современные инфоцентры могут иметь сотни или тысячи операторов, находящихся в одном месте, размещенных в нескольких региональных центрах или рассредоточенных по всей стране и работающих на дому. С технической точки зрения это означает наличие сети СРВ (так называемого виртуального инфоцентра), связанных между собой телефонными каналами и высокоскоростными каналами передачи данных (чтобы обеспечивалась работа с общими базами данных). При такой распределенной структуре необходимо принимать во внимание вероятность перегрузки отдельных элементов сети. Чтобы избежать связанных с этим потерь вызовов, должна быть предусмотрена возможность ремаршрутизации трафика с перегруженного операторского центра на относительно свободный, для того чтобы сохранить должный уровень качества обслуживания вызовов.

На смену работавшим в операторских центрах неквалифицированным операторам приходят обученные специалисты. Они могут дать абоненту медицинскую консультацию или помочь инсталлировать на его компьютер операционную систему, могут производить операции с ценными бумагами, координировать работу аварийных служб и продавать билеты на спектакль или футбол.

Одной из важных особенностей инфоцентров является возможность обработки исходящих вызовов. Информировать абонента о новых продуктах или услугах, проводить опрос покупателей, напомнить о необходимости погасить задолженность — для всего этого необходима возможность автоматизированного обслуживания мощных потоков исходящих вызовов.

Статистика показывает, что без применения автоматизированных систем из 100 попыток оператора, в среднем, только 30–35 заканчиваются разговором, причем даже в успешных случаях оператор тратит большую часть своего времени на ожидание ответа вызываемого абонента.

Первая система, которая генерировала вызовы автоматически и подключала живого оператора только после обнаружения состояния “Ответ абонента” была создана в 1984 г. Эта система получила название “predictive dialing” (упреждающий набор номера). Сегодня системы (или пакеты специализированного программного обеспечения), реализующего такие функции, крайне популярны. При этом количество операторов, необходимых для достижения одной и той же производительности операторского центра, сокращается в центрах, использующих системы упреждающего набора, по сравнению с центрами, не использующими таковые, в 6–7 раз.

Программное обеспечение систем “predictive dialing” является довольно сложным, поскольку должно учитывать общую емкость операторского центра, число операторов, продолжительность интервалов между вызовами, обеспечивающую максимальную эффективность работы, среднюю длительность разговора с абонентом и другие факторы. К тому же, важная функция подсистемы упреждающего набора номера состоит в том, чтобы в момент, когда в системе существуют свободные операторы, установить соединение с очередным абонентом из списка, обнаружить ответ вызываемого абонента и соединить его с оператором. При этом, как и в случае обработки входящих вызовов, соединение может устанавливаться с определенным оператором либо с любым свободным (с контролем равномерной загрузки операторов в системе), причем оператору передается информация о том, с кем именно установлено данное соединение, сообщается история общения с этим клиентом и т. п.

Для повышения удобства операторов стандартная фраза обращения к абоненту при исходящих вызовах также может генерироваться системой автоматически (до подключения к нему оператора). Как показывают данные ряда зарубежных источников, использование такого рода устройств и соответствующего программного обеспечения позволяет вдвое увеличить число абонентов, обслуживаемых одним оператором в час.

Дальнейшее развитие инфоцентров и увеличение их мощности было связано с расширением круга задач, которые возлагались на такие центры руководителями компаний, использующих эту технологию в своем бизнесе.

Одним из важнейших элементов организации бизнеса стало новое направление: ведение клиента или менеджмент взаимоотношений с клиентами (Customer Relationship Management, CRM), т. е. сбор и анализ данных клиентов, многофакторной классификации объектов, построения оптимальных моделей взаимодействия с партнерами и клиентами.


3. Контакт-центры

Основные понятия

Производители инфокоммуникационного оборудования осознали огромный потенциал решений на базе инфоцентров и начали предлагать интегрированные продукты: контакт-центры, т. е. системы, способные взаимодействовать с любыми телекоммуникационными средами.

Ключевой фактор, оказывающий влияние на развитие контакт-центров, — это развитие компьютерных технологий и рост вычислительных мощностей, фактор, который заставляет переоценить взгляды на архитектуру телекоммуникационных систем и выводит контакт-центры из разряда узкоспециального оборудования, усиливает конкуренцию на этом рынке и позволяет разработчикам быстро создавать и выводить на рынок новые системы.

К тому же стремительно развивающиеся IP-технологии позволяют компаниям экономично использовать решения на основе Web-контакт-центров и задействовать (где это дает эффект) сеть Интернет, причем не только для обмена данными, совместного использования файлов и показа рекламы, но и для услуг, раньше считавшихся прерогативой телефонных сетей.

Конвергенция систем переноса речи и данных по сетям IP открывает новые возможности предоставления дополнительных услуг, обеспечивает глобальный доступ к услугам Web-контакт-центра из любой точки сети и снижает производственные расходы за счет применения эффективных технологий пакетной коммутации, уменьшения полосы, используемой для передачи речевого трафика, и оптимизации программно-аппаратной архитектуры систем.

В контакт-центрах интеграция услуг передачи речи/данных осуществляется на качественно новом уровне: архитектура таких систем обеспечивает возможность мультимедийного обмена сообщениями, т. е. приема, распределения и обработки по унифицированным алгоритмам сообщений и вызовов разного типа, приходящих из различных сетей.

Интегрированный контакт-центр нового поколения должен обеспечивать прием традиционных и из сети Интернет телефонных вызовов с использованием технологий VoIP, прием заявок, допускающих отложенную обработку (факсимильные запросы и электронная почта, переходящие в перспективе в запросы по технологиям unified messaging), а также обработку в будущем запросов мультимедийной широкополосной связи. Должны также обеспечиваться поддержка режима чата (text chat) в реальном времени, доступ к динамической системе помощи, функции просмотра Web-страниц с сопровождением, возможности коллективного внесения отметок в страницы и совместного заполнения бланков заказов.

Функциональные возможности контакт-центров, интегрированных с Интернет, позволяют компаниям, создающим такие центры, персонализировать отношения с посетителями Web-сайтов, обеспечивая доступ к агенту службы взаимодействия с потребителем в критический момент, когда у посетителя имеется важный вопрос, от ответа на который зависит, совершит он покупку или нет. Кроме того, информацию он может получить в удобном ему виде, который допускает и имеющееся у него терминальное оборудование.

Интегрированный контакт-центр может сделать одинаково удобными для клиента разные способы обращения к персоналу центра: телефонный вызов, вызов через Интернет, электронная почта или текстовый чат. При этом клиент будет уверен, что любой его вызов будет обработан с одинаковой тщательностью, и что если он, например, через два дня после отправки электронного письма или факса позвонит по поводу своего запроса в центр, ему не придется долго пересказывать оператору содержание этого запроса.

Важно, что благодаря возможностям IP-технологий операторы контакт-центра, интегрированного с Интернет, получают возможность находиться территориально в любом месте. При этом создаётся виртуальный, работающий круглосуточно контакт-центр, не требующий использования дорогого сетевого ПО или оборудования дистанционных операторов. Облегчается поддержка многоязычности операторов контакт-центра, благодаря которой становится возможным обслуживать клиентов из разных уголков земного шара. Более того, учитывая наличие нескольких часовых поясов только на территории нашей страны, не говоря уже обо всем земном шаре, нетрудно обеспечить круглосуточное обслуживание клиентов.

Интеграция операторских центров с Интернет позволяет предприятиям сократить расходы на персонал благодаря переводу в Интернет (в режим, допускающий отложенную обработку) значительной части информационных запросов, сохранив при этом возможность того, чтобы клиент, при необходимости, в любой момент легко связался с живым оператором. Обслуживая вызовы, поступающие из Интернет, предприятие предоставляет своим клиентам свободу просмотра любого оперативного материала (каталога продукции, технической информации), пока у них не возникнут вопросы или комментарии. Введение этой возможности в Web-страницы может привлечь тех, например, кто предпочитает сообщать номера кредитных карт по телефону, а не вводить их в интерактивную форму.

Крупные зарубежные производители, такие как Lucent Technologies, Nortel Networks и Cisco Systems, многие менее крупные (опять же в основном зарубежные) компании, а также некоторые отечественные разработчики (платформа ПРОТЕЙ, например) активно внедряются на рынок интегрированных операторских центров.

Функциональные особенности контакт-центра

Ранее обсуждались уже ставшие привычными англо-русское словосочетание “Call-центр”, а также менее употребляемые синонимы (инфоцентр или операторский центр). Все эти термины относятся к структуре, оперирующей обычно с телефонными вызовами. Сегодняшний Call-центр такого рода обрабатывает запросы клиентов и оптимизирует обработку этих запросов с учетом того, что телефонный разговор является отнюдь не единственным средством доступа к информации.

На смену терминам “инфоцентр”, “операторский центр” или “Call-центр” приходит новый термин — “контакт-центр”, более точно отражающий эволюцию понятий и функциональных возможностей подобных систем.

Рассмотрим особенности этих новых интегрированных с Интернет контакт-центров, разбив их на функциональные группы, аналогичные по назначению группам функциональных возможностей традиционных Call-центров, а также отметим некоторые специфические характеристики интегрированных контакт-центров.

Прежде всего, конечно, это мультимедийность, понимаемая как способность обслуживать запросы разных типов, поступающие из разных телекоммуникационных сетей:

  • речевой связи (из ТфОП);
  • речевой связи (из Интернет, с использованием технологии IP-телефонии);
  • связи по факсу, электронной почте;
  • связи в режиме текстового чата из Интернет;
  • видеовызовы (в недалекой перспективе).

Мультимедийность начинается с доступа к услугам контакт-центров.

Доступ к услугам контакт-центра

Рассмотрим некоторые из способов доступа к услугам, которые характерны именно для контакт-центра, интегрированного с Web. Как правило, если речь идет об интегрированном контакт-центре, то предполагается, что клиент получает доступ к ресурсам контакт-центра со стороны корпоративного Web-сайта и/или связанных с этим Web-сайтом операторов. Таким образом, задачей контакт-центра является обеспечение универсальности доступа с точки зрения абонента, свободы выбора метода доступа к услугам. Существует целый ряд способов реализации такого универсального доступа.

Одним из самых перспективных и экономически целесообразных способов является доступ на базе технологии IP-телефонии. Речевой диалог с клиентом проводится в виде сеанса VoIP с использованием уже имеющегося соединения корпоративного Web-сайта с Интернет. При этом клиент и оператор контакт-центра могут вести диалог и даже синхронно просматривать одни и те же Web-страницы (рис. 3).

При вызове из Интернет пользователь получает доступ к контакт-центру компании, щёлкнув мышью на кнопке Сall, находящейся на её Web-странице, что активизирует программу IP-телефонии, зарегистрированную у Web-браузера, которая может быть интегрированным приложением Web-браузера или отдельным приложением, которое вызывается браузером из какого-либо места на рабочем столе пользователя.

При нажатии на кнопку начинается процедура организации связи через Интернет со шлюзом IP-телефонии с использованием соединения, уже установленного с Интернет-поставщиком. Кнопка фактически является гипертекстовой ссылкой, написанной на языке HTML и использующейся для инициирования этого процесса.

После того как кнопка Сall нажата, и приложение IP-телефонии открыто, устанавливается соединение с Web-сервером компании. В некоторых случаях Web-сервер только передает сообщение о вызове, которое запускает механизм планирования ответа на вызов в исходящей очереди операторского центра, определяя оператора или класс (группу) операторов для обслуживания данной заявки. На Web-сервер передается ответное сообщение с указанием расчётного времени обратного вызова, а Web-сервер пересылает эту информацию вызывающему абоненту.

После того как оператор принял вызов, дальнейшее зависит от того, на какой режим работы настроен контакт-центр. В простейшем сценарии оператор отвечает на вопросы вызвавшего абонента и вводит в базу данных компьютера ту информацию о состоявшемся диалоге, которая может оказаться полезной при следующем вызове от того же пользователя. Кроме того, эта информация может использоваться для многих других целей, включая вызов эксплуатационного персонала, создание транспортных ярлыков для заказанных товаров, отслеживание продажи, рассылку рекламных материалов по почте и подготовку отчетов по потребителям, обращавшимся в контакт-центр.

В более сложном сценарии, как было отмечено выше, оператор может фактически просматривать ту же Web-страницу, что и вызывающий абонент, а также любое связанное с ней встроенное приложение, которое использует этот посетитель Web-сайта. Это позволяет представителю компании оказывать оперативное содействие клиенту: отвечая на его вопросы, направляя к соответствующей информации на Web-сайте или принимая заказ в реальном времени.

В тех случаях, когда клиент не хочет простаивать в очереди, ожидая обслуживания, он может обратиться к услуге “автоматический обратный вызов”. В контакт-центре услуга обратного вызова (Call-back) приобретает новое наполнение. Традиционная услуга этого вида сводилась к тому, что абонент, услышав ответ IVR, либо диктовал контактный телефон, либо подтверждал правильность автоматического определения его номера, после чего клал трубку на рычаг телефонного аппарата и ждал, когда ему позвонит оператор.

В интегрированных с Web контакт-центрах вместо того, чтобы диктовать свои данные или на слух контролировать правильность определения номера, значительно удобнее воспользоваться преимуществами Интернет.

Абонент заполняет на Web-сайте компании соответствующую форму, вводя в неё номер своего телефона (или указывая любой другой способ для контактов: mail, ICQ и т. д.), тему для обсуждения, день и время, когда он будет на месте для приема обратного вызова от компании (если выбранный им способ общения предполагает диалог в реальном времени). Форма передается на контакт-центр и направляется оператору.

Когда обратный вызов поступает к абонентскому терминалу, клиент, сняв трубку, слышит записанное речевое сообщение с просьбой подтвердить, что он желает говорить с оператором. После этого происходит подключение оператора, и, спустя короткое время, пользователь может с ним разговаривать.

Следующий способ — режим текстового чата, доступа к услугам операторского центра появился именно в контакт-центрах. Такой способ дает возможность обмена текстовой информацией между клиентом и оператором центра в реальном времени и может быть особенно актуален в случае отсутствия у пользователя программного обеспечения и оборудования VoIP или неудовлетворительного качества речи при использовании IP-телефонии, а также в случаях, когда надо безошибочно передать цифры, точное написание фамилий и т. д.

Разнообразие типов обрабатываемых вызовов приводит к существенным изменениям в ряде основных функциональных блоков интегрированного операторского центра.

Организация очередей и маршрутизация вызовов

Дисциплины очередей и механизмы маршрутизации вызовов в контакт-центрах, интегрированных с Интернет, могут быть значительно сложнее, чем в “традиционных” операторских центрах. Связано это не только с совершенствованием алгоритмов распределения вызовов, но и с тем, что разные источники нагрузки в конвергентной сети имеют совершенно разные характеристики; соответственно, модель потока вызовов, которые должны обрабатываться интегрированным контакт-центром, существенно отличается от обычной модели, принятой для телефонных систем.

Разного типа запросы различаются параметрами, которые определяют характеристики входящей нагрузки и на основании которых обычно производится распределение вызовов и организация очередей. Так, например, пороги длительности ожидания для заявок, допускающих отложенное обслуживание, измеряются часами, а для традиционных телефонных вызовов — десятками секунд. Фактически, очередь ожидания превращается в буфер, выбор заявок из которого производится не в порядке их поступления (как это было в операторских центрах, обслуживающих только телефонные вызовы), а на основе анализа нескольких параметров, характеризующих эти заявки.

Механизмы обслуживания разных заявок могут быть различными. Их могут обслуживать либо отдельные операторы или группы операторов, либо те же операторы, которые обслуживают основной (речевой) поток запросов. Если второй вариант применим, появляется возможность существенно увеличить производительность контакт-центра, причем сделать это не за счёт увеличения числа операторов, а за счёт обработки запросов разных видов одним и тем же оператором. Запросы, допускающие отложенную обработку, оператор может обрабатывать в периоды, когда интенсивность потока телефонных запросов снижается.

В типовом сценарии пользователь передает сообщение электронной почты в центр обслуживания либо по обычному каналу электронной почты, либо путём заполнения формы на Web-сайте. Далее сообщение проходит по Интернет к почтовому серверу, установленному в помещении пользователя. По прибытии сообщения на почтовый сервер операторского центра генерируется так называемый “фантомный вызов” (термин, предложенный компанией AVAYA). Этот фантомный вызов предназначен для передачи сообщения оператору: он воспринимается как обычный телефонный вызов, ставится в очередь и маршрутизируется в соответствии с алгоритмом и набором средств, определённых управляющим приложением.

Когда освобождается оператор, способный обслужить вызов этого типа и тематики, “вызов” электронной почты поступает к терминалу оператора и тот получает уведомление о его присутствии на экране браузера. Пользовательский интерфейс рабочего места оператора контакт-центра содержит ряд инструментальных средств, с помощью которых оператор имеет возможность создать ответ для передачи его по электронной почте, перевести “вызов” в режим удержания для наведения справки у других операторов контакт-центра или переправить “вызов” другому оператору, считающемуся специалистом в данной области. Во время выполнения всех этих действий оператор, занятый обслуживанием вызова, поступившего в виде электронного письма, считается занятым, и другие вызовы поступать к его рабочему месту не могут.

Архитектура контакт-центра

Ранее рассматривались задачи, которые должны быть реализованы контакт-центром:

  • обеспечение широкого спектра возможностей, как в плане доступа, так и с точки зрения услуг, предоставляемых с использованием человеческих ресурсов (операторов) и автоматизированных систем;
  • гарантированная обработка транзакций всех типов вне зависимости от источника вызова и метода доступа к ресурсам контакт-центра;
  • обеспечение возможности интеграции с существующими операторскими центрами и дооснащения их необходимыми функциями с применением оборудования сторонних производителей за счет использования открытых стандартов при построении систем.

Оптимальной технологией для достижения этих задач является IP. Чтобы доказать этот тезис, приведем ряд аргументов.

Как говорилось ранее, традиционные операторские центры (инфоцентры, обрабатывающие только телефонные вызовы) строились, главным образом, с использованием специализированного оборудования СРВ или на базе УАТС, дооснащенных специализированным программным обеспечением для автоматического распределения вызовов. Внешние компьютерные системы (базы данных CRM — customer relationship management и т. д.) соединялись с процессором СРВ посредством соответствующих интерфейсов (например, TAPI). В определенный момент функциональных возможностей инфоцентров стало не хватать, и потребовалась поддержка взаимодействия оборудования не только с ТфОП, но и с сетями передачи данных. К существующему инфоцентру было добавлено необходимое программное и аппаратное обеспечение, не связанное напрямую с СРВ. Такая архитектура содержит две отдельные части: телефонную и компьютерную, программное обеспечение которой отвечает за взаимодействие с другими сетями. Техническое обслуживание двух разных инфраструктур в телекоммуникационных сетях зачастую оказывается довольно дорогим, оно не всегда надежно и ставит определенные препятствия к интеграции коммуникаций различных типов.

По такому пути пошли компании, которые уже имели к началу эпохи интеграции мощные инфоцентры, построенные на базе СРВ, и которым было неразумно не использовать уже имеющийся потенциал (рис. 4).

Роль коммутационного ядра, как и в системах обычных операторских центров обслуживания вызовов, в этом случае берет на себя учрежденческая станция с функциями СРВ или специализированная СРВ с соответствующими функциями.

В то же время компании, начинающие разработки контакт-центров с чистого листа, повели себя при выборе подходов и архитектур более свободно. И именно они получили в полной мере преимущества, возникающие при реализации систем на принципах пакетной коммутации. В качестве примеров приведем отечественную систему: контакт-центр ПРОТЕЙ.

Технологии пакетной коммутации позволяют отказаться от громоздкого коммутатора каналов, возложив функции коммутации на саму сеть с использованием возможностей протокола IP как универсального протокола транспортного уровня. В этом случае функции коммутации разговорных каналов сводятся к управлению медиапотоками между определенными узлами компьютерной сети. Все функциональные возможности реализуются компьютерными серверами приложений, работающими с управляющей информацией и медиапотоками (если необходимо) и взаимодействующими в процессе обслуживания вызова с информационными и технологическими базами данных. При этом каждый из таких серверов отвечает за свой набор услуг (серверы СРВ, IVR и др.). Таким же образом решаются вопросы надежности (стандартные методы резервирования аппаратного обеспечения компьютерной техники), масштабирования (установка, при необходимости, дополнительных серверов, работающих в режиме разделения нагрузки), введения новых функций (дополнительные серверы и приложения), создания распределенных систем (для этого достаточно связать разные офисы одной компьютерной сетью, обладающей нужной пропускной способностью).

Ядром систем такого рода является программный продукт, управляющий очередями и маршрутизацией вызовов. В состав системы входят также: периферийные шлюзы, обеспечивающие взаимодействие компонентов системы, прием и обработку вызовов, поступающих из разных сетей, серверы приложений и баз данных, функции которых будут рассмотрены ниже.

Применение IP-технологий позволяет легко связать телефонный вызов с информацией о нем. Эта связь чрезвычайно важна для контакт-центров, именно она делает эффективной обработку вызовов из разных сред и обеспечивает необходимое качество обслуживания решаемой задачи. Если принять во внимание и другие преимущества IP контакт-центров, в том числе низкую стоимость развертывания и эффективность масштабирования, привлекательность использования в контакт-центрах пакетной коммутации становится очевидной (табл. 1).

В операторских центрах на базе традиционных СРВ рабочие места операторов физически подсоединены к фиксированным портам коммутационного оборудования, возможности их размещения жестко ограничены, и организация распределенной системы существенно затруднена. В то же время, виртуальная природа IP-адресации в современных контакт-центрах позволяет легко решить эти проблемы. Оператор может зарегистрироваться на любом терминале и при этом он будет распознан системой как уникальный агент, обладающий определенной квалификацией. Очевидны преимущества контакт-центра с точки зрения затрат на организацию удаленных рабочих мест, а также возможностей предоставления компанией-владельцем такого центра услуг аутсорсинга (предоставления ресурсов контакт-центра в аренду сторонним фирмам).

Современные контакт-центры базируются на IP-технологиях и решениях компьютерной телефонии 3-го поколения, а не на громоздких CTI-интерфейсах и классических коммутационных платформах, чем и объясняются их преимущества, отмеченные в табл. 1. Программное обеспечение оператора контакт-центра является компактным программным продуктом, обеспечивая хорошие возможности интеграции с информационными базами данных, используемыми в операторском центре. Контакт-центр, реализованный на базе IP-технологий, состоит из функциональных элементов нескольких типов, одни из которых могут быть программно-аппаратными блоками, а другие — чисто программными продуктами (рис. 6).

Таблица 1

Характеристика |  | Преимущества с точки зрения компании, эксплуатирующей систему
традиционных Call-центров | IP-контакт-центра нового поколения
Коммутация каналов | Коммутация пакетов | Более эффективная передача трафика, не требуется дорогостоящее оборудование для поддержки временного разделения каналов
Поддержка одной среды для доступа к услугам | Поддержка всех сред для доступа к услугам | Широкие возможности с точки зрения доступа
Большое количество серверов приложений – отдельный сервер для каждого приложения | Число серверов зависит от их производительности и функциональных возможностей | Легкость развертывания и управления, низкая стоимость
Различные алгоритмы обслуживания вызовов разных типов | Единый алгоритм обслуживания вызовов всех типов | Выше качество обслуживания и эффективность работы операторов
Централизованная обработка трафика | Распределенная обработка трафика | Гибкость конфигурации и надежность
Жесткая привязка местоположения операторских консолей к местоположению системы | Независимость местоположения операторских консолей от местоположения системы | Возможность поддержки удаленных рабочих мест операторов, предоставления услуг аутсорсинга
Компьютерно-телефонная интеграция (интегрированная функциональность) | Взаимодействие компьютер-компьютер (унифицированная функциональность) | Дешевле интеграция услуг, меньше сроки установки комплексных решений, слияние функций обработки речевого трафика и информационных технологий обеспечивает возможность быстрого и экономически эффективного развития

Функции блоков (рис. 5, 6)

Шлюз IP-телефонии

Шлюз IP-телефонии обеспечивает взаимодействие между сетью с коммутацией пакетов IP и телефонной сетью с коммутацией каналов. Шлюз представляет собой программно-аппаратный комплекс, основным функциональным назначением которого является преобразование речевой информации, поступающей со стороны ТфОП, в вид, пригодный для передачи по сетям с маршрутизацией пакетов IP: кодирование и упаковка речевой информации в пакеты RTP/UDP/IP, а также обратное преобразование. Еще одна функция шлюза — преобразование номера ТфОП в IP-адрес — реализуется в шлюзах для работы в сети IP-телефонии без привратника. Кроме того, шлюз поддерживает обмен сигнальными сообщениями как с узлами коммутации/терминальным оборудованием ТфОП, так и с устройствами, работающими по стандартам IP-телефони Н.323 и/или SIP.

Шлюз преобразует межстанционную сигнализацию по трактам E1 — сообщения систем сигнализации DSS1, OKC7, 2ВСК — или сигнализацию по абонентским линиям в сигнальные сообщения набора протоколов Н.323 (в этом случае сообщения систем сигнализации DSS1, QSIG, основанных на Q.931, преобразуются в сигнальные сообщения H.225.0 согласно рекомендации ITU-T H.246) или в протокол SIP.

Санкционирование доступа (если это необходимо), получение номера вызываемого абонента и навигация по меню системы IVR могут производиться либо на основании обработки соответствующих полей протокола H.323, либо при помощи сигналов DTMF. Для реализации последней функции шлюз, используемый в контакт-центрах такого типа, должен умеет генерировать и распознавать сигналы DTMF на стороне ТфОП, а также передавать сигналы DTMF в сообщениях Н.245 по сети с маршрутизацией пакетов IP.

Несколько шлюзов, обслуживающих один контакт-центр, могут объединяться в сеть под управлением привратника GK, что позволяет обслуживать десятки потоков E1.

Серверы приложений

Серверы приложений обеспечивают реализацию логики предоставляемых услуг. Применительно к операторским центрам можно выделить два базовых типа приложений, которые должны поддерживаться, чтобы система была полнофункциональной и удовлетворяла требованиям, о которых говорилось выше: интерактивное речевое взаимодействие и распределение вызовов.

Сервер интерактивного речевого взаимодействия IVR выполняет все функции, связанные с организацией компьютерного диалога с абонентом, который обратился в контакт-центр. Это и передача абоненту речевых подсказок-приглашений, и прием от абонента дополнительной информации в режиме многочастотного донабора, и передача абоненту в автоматическом режиме разного рода справочной и сервисной информации, и поддержка функций синтеза речи, и многие другие функции, реализуемые современными IVR. Функциональных отличий от обычных систем IVR этот элемент контакт-центра не имеет, но его фундаментальной технологической особенностью является передача и прием всей речевой информации в пакетном виде через сеть IP, посредством которой он и связан с остальными подсистемами контакт-центра. Необходимость взаимодействовать с телефонной сетью и с Интернет при обработке запросов речевой связи требует поддержки различных кодеков, динамически подключаемых в зависимости от типа входящего вызова, поскольку передача несжатой речи (G.711) при обслуживании вызовов из ТфОП обеспечивает высокое качество воспроизведения звука, а применение эффективных алгоритмов кодирования (G.729) при обслуживании вызовов из Интернет — широкое использование полосы пропускания.

Сервер распределения вызовов СРВ является ключевым элементом контакт-центра. Динамически взаимодействуя с базами данных в процессе обслуживания вызовов, он обеспечивает поддержку систем очередей и функций маршрутизации вызовов, поступающих в контакт-центр.

Базы данных

Базы данных операторского центра хранят информацию о конфигурации системы, статистические данные о ее функционировании, данные учета и т. д.

Сервер эксплуатационного управления

Сервер/терминал эксплуатационного управления фактически представляет собой обычный персональный компьютер (рабочее место администратора системы) со специализированным программным обеспечением. С его помощью выполняются функции конфигурирования и диагностики системы, контроль состояния интерфейсов и разговорных каналов, сбор оперативной и статистической информации о работе системы и об обслуживании вызовов, а также генерация отчетов и архивация.

Рабочие места операторов

Консоли операторов организуются на базе стандартных персональных компьютеров с установленным специализированным клиентским программным обеспечением (или Web-браузером). Дополнительная оснастка рабочего места зависит от того, какая технология используется внутри операторского центра для передачи речевого трафика. Если две сети — компьютерная и передачи данных — существуют независимо, а роль речевого коммутатора выполняет СРВ, то никакого дополнительного оборудования не требуется. Телефонные вызовы в этом случае будут традиционным способом поступать на консоль (телефонный аппарат) оператора, включенную в СРВ по абонентским линиям, а информация о вызове — на персональный компьютер через интерфейс CTI.

Если же в операторском центре используется полностью интегрированное решение на базе протокола IP (т. е. существует только одна сеть — компьютерная), то оператору не требуется никакой телефонной консоли, но его рабочее место необходимо дооснастить мультимедийными средствами: звуковой картой, гарнитурой или колонками и т. д.

Речевая информация в этом случае передается в пакетном виде с использованием кодировки G.711 или G.729.

Оборудование пользователя

Посетителям Web-сайтов не требуется иметь никакого специального оборудования, кроме имеющегося в стандартном наборе компонентов персонального мультимедийного компьютера (звуковая карта).

Из программного обеспечения нужны: любая программа для поддержки IP-телефонии (Microsoft NetMeeting 2.0 или выше, Open Phone и др.) и Web-браузер (Microsoft Internet Explorer 4.0 или выше с поддержкой Java).

Что касается интерфейса, то это может быть аналоговая телефонная линия, линия ISDN или локальная сеть. К пропускной способности аналоговых линий требования примерно следующие: скорость модемного соединения с Интернет-поставщиком должна быть не меньше 14,4 кбит/с для текстового чата или не меньше 28,8 кбит/с для поддержки услуги VoIP.

Административное управление работой контакт-центра

Вопросы административного управления в интегрированном контакт-центре совершенно аналогичны вопросам такого же управления в традиционном операторском центре. В целом, административное управление включает в себя управление данными, обработкой вызовов, транзакциями и персоналом.

Управление данными - способность системы собирать, сортировать и хранить информацию о посетителях Web-сайтов и заказчиках, которая используется для маршрутизации вызовов к наиболее подходящему оператору центра. Вне зависимости от того, в какой форме поступает запрос от клиента, вся информация, относящаяся к данному вызову, собирается и хранится в базе данных. В этой базе хранится вся информация о пользователях, включая номер и версию Web-браузера посетителя, IP-адрес, номер соответствующей Web-страницы и т. д.

Эффективное управление обработкой вызовов позволяет реализовать оптимальную маршрутизацию. Это означает, что запросы любого вида будут маршрутизироваться к наиболее подходящему оператору, который обслужит запрос клиента с заданным качеством. В этом случае необходима информация, которая содержит все данные о предыдущих запросах клиента, если они были, а также о номерах счета, телефона и т. д.

Подсистема управления транзакциями обеспечивает гибкий, почти в реальном времени, механизм контроля деятельности операторского центра и уведомления старшего оператора (супервизора) о наличии проблем (например, когда число входящих вызовов достигает порогового значения, выдаются предупреждающие сообщения, так что имеется возможность среагировать на ситуацию до того, как это почувствует на себе вызывающий пользователь). Могут выдаваться визуальные или акустические тревожные сообщения или предупреждения. Среди действий, которые могут выполняться автоматически, — перевод избыточного потока вызовов на обслуживание к старшим операторам и администраторам, передача вызывающим пользователям сообщений, информирующих их о том, что они получат ответ при первой возможности.

В ходе подобной автоматизированной процедуры принятия решений приложение администратора транзакций системы рассматривает такие факторы, как число работающих операторов, уровень их квалификации, количество вызовов, находящихся в очереди, и вызовов, обслуживаемых в данный момент. Эти возможности управления транзакциями позволяют контакт-центру не только обслуживать большее число вызовов без привлечения дополнительного персонала, но и более полно удовлетворять потребности клиентов, поскольку вызовы обрабатываются быстрее.

Качество функционирования контакт-центра зависит от характера изменения нагрузки, числа задействованных в нем операторов, решаемых задач и многих других факторов. При этом, если поток вызовов, поступающих от ТфОП, можно предугадать и соответствующим образом настроить систему, то число вызовов, приходящих в тот или иной момент из сети Интернет или по электронной почте, предугадать практически невозможно.

Таким образом, необходимо постоянно контролировать работу центра, изменяя, когда нужно, число операторов в той или иной группе, создавая новые направления, модифицируя алгоритмы обслуживания и т. д., что и требует мощной подсистемы административного управления, позволяющей оперативно реагировать на изменения во внешней среде.


4. Алгоритмы обслуживания вызовов

Обслуживание входящего вызова из ТфОП

Центры обслуживания вызовов работают как системы обслуживания с ожиданием. При отсутствии свободных операторов в группе, имеющих возможность квалифицированно обработать запрос, вызов помещается в очередь. В качестве опции предусматривается выдача абоненту во время нахождения вызова в очереди различного рода информации, а также информирование абонента о порядковом номере в очереди и приблизительном времени ожидания.

После того, как абонент набрал номер вызываемой службы, вызов направляется на сервер распределения вызовов (ACD), который может действовать по следующим сценариям:

  • вызов направляется непосредственно на рабочее место оператора, в случае наличия свободных операторов в группе, с использованием установленного для этой службы алгоритма распределения;
  • вызов направляется в очередь в случае, если нет свободных операторов;
  • вызов может направляться на систему AI (IVR), после чего адресуется непосредственно на рабочее место оператора (в случае необходимости), если МЦОВ оснащен соответствующими программно-аппаратными опциями;
  • вызов направляется на систему AI (IVR), после чего происходит постановка в необходимую очередь в случае, если в соответствующей группе (службе) нет свободных операторов;
  • в случае отсутствия свободных операторов и мест в очереди ожидания будет осуществлено разъединение.

Маршрутизация вызовов в необходимую группу операторов осуществляется на основании набранного номера службы или на основании информации АОН.

Обслуживание входящего вызова с использованием технологии VoIP

Усиление роли “всемирной паутины” как средства бизнеса и средства доступа к информации обусловливает необходимость наличия в архитектуре любого современно операторского центра Web-сервера, через который клиенты операторского центра могут получить доступ к его услугам при доступе через сеть Internet.

Абонент, желающий получить необходимую информацию, используя ресурсы контакт-центра, в процессе просмотра Web-страницы компании, активизирует соответствующую иконку. При активизации начинается процедура вызова через Интернет к шлюзу IP-телефонии, через уже установленное соединение с Интернет-провайдером. Шлюз IP-телефонии загружает Java-приложение обработки вызова в компьютер клиента для запуска приложения IP-телефонии. Java-приложение обеспечивает интерфейс, через который пользователь может также получать сообщения о состоянии вызова, участвовать в обмене текстовыми сообщениями, сотрудничать с оператором центра путем посылки ему Web-страницы или разъединить вызов. Вызов, создаваемый с использованием технологии VoIP, обслуживается системой полностью аналогично вызову, поступающему из телефонной сети.

Обслуживание вызова в режиме “Callback”

Режим отложенного обслуживания предусматривает постановку вызова в очередь на обслуживание без необходимости удержания вызова с последующим обратным вызовом освободившегося оператора к абоненту. Абонент может заказать обратный вызов с Web-сайта компании.

При заказе обратного вызова с Web-сайта предусматривается заполнение абонентом соответствующей формы с указанием ориентировочного времени связи, способа связи и контактного телефона.

Сформированная заявка на обратный вызов ставится в очередь и далее обслуживается в соответствии с алгоритмом обслуживания исходящего вызова.

Обслуживание исходящего вызова

Во многих случаях требуется наличие возможности упреждающего набора номера. Подобная функция необходима в случае, если в процессе функционирования системы требуется организация исходящего трафика (например, для реализации алгоритма обслуживания абонентов по системе с обратным вызовом). В таком случае система либо сама генерирует список обзвона абонентов, либо этот список формируется силами персонала центра обслуживания вызовов.

Система автоматически производит вызовы по сформированным активным спискам оповещения, определяет состояния номера вызываемого абонента (занято, неответ, факс, “живой” ответ). При распознавании ответа осуществляется проключение вызова на свободного оператора (с возможной предварительной передачей абоненту необходимой фразы автоинформатора).

Распределение вызовов по операторам

Алгоритм работы системы должен обеспечивать распределение вызовов между операторами таким образом, что нагрузка на каждого из них всегда остается одинаковой.

Для равномерного распределения нагрузки среди операторов используются три основных алгоритма:

  • циклическое распределение вызовов, т. е. на первого свободного оператора;
  • выбор наиболее свободного оператора (после обслуживания последнего вызова), т. е. выбор оператора, которому будет направлен вызов из очереди, осуществляется с учетом двух параметров: свободного от обслуживания клиентов времени и уровня квалификации оператора;
  • выбор наименее занятого оператора (с начала смены), т. е. вызов из очереди направляется на оператора, характеризующегося наименьшей нагрузкой. В качестве критерия выбора используется либо общее суммарное время разговоров оператора, либо общее количество вызовов, обслуженных данным оператором. Предусмотрена модификация данного алгоритма с возможностью учета коэффициента квалификации оператора.

Это положительно сказывается на качестве работы персонала центра и позволяет новым сотрудникам быстрее набираться опыта. Алгоритмы распределения вызовов, применяемые в современных системах, поддерживают возможность разделения операторов по квалификации, что позволяет ещё более эффективно осуществлять обработку заявок.

Обслуживание вызова, поступившего на систему не от ТфОП

Абонент может получить доступ к ресурсам МЦОВ с использованием множества различных средств, предоставляемых современными инфокоммуникационными сетями, этот вопрос рассматривался в разделе, посвященном контакт-центрам. С точки зрения алгоритмов обслуживания вызовов, в оборудовании последнего поколения осуществлена унификация данных алгоритмов, т. е. заявки поступают на МЦОВ через разнообразные интерфейсы (шлюзы IP-телефонии, почтовые и Web-серверы и т. д.), а распределение их по операторам производится в единой точке (ACD) из одной очереди либо с применением приоритетной организации процесса обслуживания вызовов.


5. Учебная установка IP Контакт-Центр “Протей-РВ”

Комплекс оборудования ПРОТЕЙ-РВ создан для применения в многофункциональных центрах обслуживания вызовов, предназначенных для оснащения отделов продаж, организации электронных магазинов, служб технической поддержки, справочных служб и экстренных спецслужб различного вида.

Архитектура системы ПРОТЕЙ-РВ соответствуют тенденциям конвергенции телекоммуникационных сетей. Используется коммутационное ядро, полностью построенное на принципах пакетной коммутации. Главная задача, которую решает оборудование, — обслуживание возможно большего количества поступающих заявок в сочетании с высоким качеством обслуживания абонентов и максимальной эффективностью работы операторов.

Известно, что при прочих равных условиях контакт-центр на базе IP-технологий имеет ряд преимуществ перед традиционными системами, в основе которых лежит коммутатор каналов. В первую очередь, это более низкая стоимость разработки и производства, а следовательно, и более низкая стоимость для заказчика. Во-вторых, более низкая стоимость установки и эксплуатации за счет применения только одной сетевой структуры, также за счет этого уменьшается время развертывания системы. Сравнительная простота эксплуатации также достигается за счет использования универсальной технологии. IP-контакт-центр легче поддается масштабированию и наращиванию функциональности, чем традиционные системы.

Архитектура IP-контакт-центра позволяет с легкостью увязать информацию о вызове с самим вызовом, тем самым осуществив интеграцию системы приема вызовов с системой CRM. Для достижения этого в центрах обслуживания вызовов на основе коммутации каналов требуется применение специальных плат компьютерной телефонии. Наконец, контакт-центры на основе IP-технологий позволяют легко организовывать полноценные удаленные рабочие места операторов, для этого требуется только наличие IP-каналов достаточной пропускной способности. Эти и другие возможности комплекса ПРОТЕЙ-РВ в полной мере будут раскрыты ниже.

Подключение ПРОТЕЙ-РВ к телефонной станции может производиться по линиям с сигнализацией ОКС7, 2ВСК, EDSS1, R1.5 или R2. При подключении к сетям IP-телефонии используется протокол H.323, который является внутренним протоколом IP-телефонии.

Система состоит из отдельных модулей, связанных между собой по технологии Ethernet, количество и функциональность которых зависят от особенностей задач, решаемых системой. В общем случае оборудование включает в себя шлюз IP-телефонии, сервер распределения вызовов, сервер голосовых подсказок (или медиаресурсов) интегрированный с базой данных, систему техобслуживания и управления, рабочие места операторов и средства обеспечения надежности.

Рабочие места операторов представляют собой ПК с необходимым аппаратным и программным обеспечением. Возможность же организации удаленных рабочих мест лежит в самой основе архитектуры системы, что позволяет создавать на базе ПРОТЕЙ-РВ территориально распределенные центры обслуживания вызовов.

Возможность одновременной работы нескольких серверов распределения вызовов в режиме разделения нагрузки также имеет большое значение при построении распределенного операторского центра, кроме того, это позволяет с легкостью осуществлять масштабирование системы и обеспечивать необходимую надежность.

В качестве аппаратного обеспечения системы применяются специализированные промышленные компьютеры, в случае необходимости устанавливаются источники бесперебойного питания с требуемым временем автономной работы. Ядром программного обеспечения комплекса является переработанная версия операционной системы Linux, на программном уровне также реализованы механизмы, повышающие надежность системы (рис. 7).

Рис. 7. Общая структурная схема контакт-центра ПРОТЕЙ-РВ:

TCM-I - интерфейсные модули (шлюзы IP-телефонии),
ACD (automatic call distributor) - система распределения поступающих заявок,
Router - маршрутизатор центра обслуживания вызовов,
РМО - рабочие места операторов, РМСО - рабочее место старшего оператора,
IMS (information media server) - комплекс дополнительных серверов под общим названием, в общем случае включает в себя серверы голосовых подсказок IVR (interactive voice response), медиа-ресурсов MRS для хранения звуковых сообщений и записи принимаемых заявок, баз данных, а также сервер и терминал технического обслуживания и эксплуатации (рис. 8).

Комплекс обладает гибко настраиваемой системой голосовых подсказок (interactive voice response, IVR), что позволяет организации, эксплуатирующей оборудование, более рационально использовать труд операторов центра. Подобная функциональность является неотъемлемой частью всех современных систем обслуживания вызовов и особенно эффективна в случае, когда в задачи ЦОВ входит разрешение множества типовых несложных вопросов. Эта же подсистема может применяться при организации рекламных кампаний, опросов и других мероприятий, где требуется автоматизированная обработка исходящих вызовов.

Комплекс в состоянии предоставить и самим операторам большой набор средств для качественного и быстрого решения поступающих запросов. Это достигается сопряжением оборудования распределения вызовов со всеми необходимыми базами данных и, если необходимо, CRM-обеспечением. Могут быть использованы уже существующие базы данных, имеющие стандартный интерфейс. В случае же наличия у компании системы CRM (или необходимости её внедрения) задача интеграции её с операторским центром решается отдельно для каждого заказчика.

Рассмотрим некоторые из возможных областей применения многофункционального центра обслуживания вызовов ПРОТЕЙ-РВ. Ими являются оснащение отделов продаж, организация электронных магазинов, служб технической поддержки, справочных служб и экстренных спецслужб различного вида.

Аппаратное и программное обеспечение системы сильно зависит от области применения, поэтому окончательная реализация оборудования операторского центра для этих задач может отличаться по функциональности, надежности, производительности или уровню обслуживания клиентов (grade of service, GOS).

Одним из наиболее структурно сложных решений в области построения центров обслуживания вызовов является создание полноценного электронного магазина. Это объясняется тем, что в данном случае контакт-центр является ключевым звеном всей организации, именно он обеспечивает выполнение основного объема работ, необходимых для существования организации. На фоне роста популярности подобных компаний и значительной конкуренции среди них на первый план выходит качество обслуживания клиентов, прилагаются максимальные усилия для предоставления пользователям всех возможных удобств с одной целью — привлечь и удержать клиента.

Итак, какими параметрами обладает контакт-центр, удовлетворяющий требованиям, предъявляемым к электронным магазинам? В первую очередь он должен предоставлять как можно больше типов доступа к услугам организации. Это объясняется спецификой бизнеса подобных компаний, когда пользователю может быть удобен любой из существующих распространенных видов связи, именно это и определяет необходимость использования различных видов обмена информацией, отличных от простой телефонной связи.

Увеличение популярности подобной компании неминуемо влечет необходимость увеличения числа операторов, для того чтобы качество обслуживания клиентов оставалось на прежнем уровне. Это выдвигает к оборудованию контакт-центра жесткие требования по возможности наращивания производительности (масштабирования) системы. В любой момент времени организация, эксплуатирующая центр обслуживания вызовов, должна иметь возможность в сжатые сроки осуществить количественное расширение комплекса операторского центра.

Кроме предоставления существующих распространенных видов связи, оборудование центра обслуживания вызовов должно иметь возможность оперативного ввода в эксплуатацию новых востребованных типов информационных коммуникаций. Известным примером этого являются системы интерактивного обмена текстовыми сообщениями (instant messaging). Таким образом, система должна быть легко расширяема не только количественно, но и качественно, возможность быстрого добавления функциональности должна быть заложена в самой архитектуре комплекса оборудования.

К функциональности центров обслуживания вызовов для электронных магазинов также предъявляются широкие требования. Среди самых важных функций систем для электронной коммерции выделяются возможности отложенного обратного вызова (call back) и организации исходящей связи любого вида. Это объясняется необходимостью согласования с клиентом некоторых вопросов уже после сообщения им своего заказа, например, вопросов доставки. Та же возможность может использоваться при выполнении программ CRM: проведении рекламных компаний, различных напоминаний и т. п. В то же время система IVR центра обслуживания вызовов электронного магазина, наоборот, может выполнять лишь вспомогательную функцию. Кроме функций обработки различных заявок, IVR, call back, организации конференций и консультаций, для электронного магазина может оказаться полезной возможность синхронного просмотра Web-страниц оператором и клиентом.

Помимо масштабирования системы увеличение числа операторов потребует применения эффективных средств управления и контроля персонала. Среди них средства планирования режимов работы операторов, разделение квалификаций операторов (оператор, старший оператор, эксперт, управляющий и т. д.), разделение операторов по типам обслуживаемых заявок, расширенные средства администрирования и статистики, включения в центр обслуживания вызовов не только операторов, но и прочих сотрудников компании. В случае, если центр обслуживания вызовов планируется создать централизованным, надобность в возможности организации удаленных рабочих мест операторов отпадает. В то же время, учитывая возможность последующего расширения компании, может возникнуть потребность не только в удаленных РМО, но и в построении распределенного операторского центра.

Для эффективного обслуживания поступающих заявок операторы должны обладать соответствующими средствами. К ним относятся удобные терминалы, предоставляющие возможность нажатием лишь одной кнопки принять заявку на обработку, принять/отправить электронное сообщение, провести консультацию, сделать переадресацию вызовов, создать конференцию или записать разговор. Оператор должен иметь возможность просмотра Web-страниц одновременно с клиентом, обращаться к базам данных центра и незамедлительно получать/заносить необходимую информацию.

При такой сложности программного обеспечения рабочих мест операторов нужен интуитивно понятный интерфейс системы, не в меньшей степени это относится к рабочим местам старших операторов и администраторов контакт-центра. При таких требованиях к возможностям системы самым удобным способом их удовлетворения будут решения на основе Web-технологий. Именно они позволяют предоставить операторам простой в использовании интерфейс, а обслуживающему персоналу — средства гибкого оперативного администрирования и получения разнообразной статистической информации.

Отдельного внимания заслуживает ключевой компонент электронного магазина — Web-сервер, хотя он не является неотъемлемой частью контакт-центра в общем случае, но для предприятия e-commerce наличие его обязательно. Очевидно, что потребуется интеграция сервера Web с остальным оборудованием центра обслуживания вызовов и их общее администрирование.

Ядро контакт-центра — система распределения вызовов (automatic call distributor, ACD), осуществляющая перенаправление всех поступающих заявок на серверы приложений (IVR и т. п.) и операторов. Легко заметить, что по возможностям ACD IP-контакт-центра стоит рядом с учережденческими АТС на основе IP-технологий, что при незначительном усовершенствовании функциональности ACD позволяет использовать его в качестве УПАТС (IP-PBX) организации (рис. 9).

Рис. 9. Использование оборудования контакт-центра ПРОТЕЙ-РВ
в качестве УПАТС

Всё сказанное выше — основные требования, которые могут быть предъявлены при организации электронного магазина к оборудованию контакт-центра. Комплекс для создания центров обслуживания вызовов ПРОТЕЙ-РВ эффективно выполняет любое из них, это решается за счет архитектуры системы. Количественное расширение системы достигается простым увеличением числа рабочих мест одновременно с установкой дополнительных ACD, работающих в режиме разделения нагрузки, интерфейсных модулей (шлюзов IP-телефонии) и дополнительных серверов приложений.

В системе реализована вся функциональность современного контакт-центра, есть возможность работы в режиме УПАТС.

ПРОТЕЙ-РВ позволяет осуществлять увеличение функциональности, для этого необходима всего лишь установка дополнительных серверов приложений с соответствующим программным обеспечением либо установка дополнительного ПО рабочих мест операторов. Это же позволяет вводить систему в эксплуатацию этапами, например, сначала может быть реализована обработка входящих и исходящих голосовых вызовов, затем факсимильных сообщений и электронной почты, поддержка популярных систем обмена текстовыми сообщениями реального времени, и, наконец, синхронный просмотр Web-страниц.

Естественно, оснащение операторских центров электронных магазинов — не единственное применение контакт-центра ПРОТЕЙ-РВ. Он может применяться в банках, страховых и авиакомпаниях, любых организациях, предоставляющих информационные услуги (например, служба 09).

Традиционно, оборудование операторских центров широко используется самими операторами связи, такая область применения контакт-центров накладывает некоторые особенные требования к оборудованию. Самое основное из них — большое число операторов центра, это объясняется тем, что операторы связи имеют многочисленную клиентскую базу, которая в большинстве случаев будет превосходить число клиентов прочих компаний. IP-контакт-центр ПРОТЕЙ-РВ благодаря своей архитектуре предоставляет возможность наращивания числа рабочих мест операторов до необходимого. Другая особенность работы центра обслуживания вызовов оператора связи — большое количество простых типовых вопросов, как говорилось ранее, для эффективного их разрешения достаточно системы IVR. Комплекс ПРОТЕЙ-РВ позволяет создавать разветвленные меню голосовых подсказок, предоставлять разные информационные услуги в зависимости от набранного номера.

На основе контакт-центра ПРОТЕЙ-РВ может быть обеспечена вся связь компании с внешним миром. Уже говорилось, что внутренняя связь также может быть возложена на оборудование операторского центра за счет использования его ядра в качестве IP-PBX. Наглядным примером этого является создание общего центра обслуживания вызовов для отдела продаж и технической поддержки, а также дающего возможность переадресовать заявку на любого сотрудника компании (руководители подразделений, конкретные специалисты и т. д.). В этом случае контакт-центр должен быть в состоянии поддерживать необходимое число групп операторов либо служб, различающихся, например, по номеру доступа, кроме этого может потребоваться наличие голосового меню. Оборудование ПРОТЕЙ-РВ с легкостью решает и эту задачу.

Одним из главных потребителей оборудования систем распределения вызовов всегда являлись экстренные спецслужбы (ЭСС) 01, 02, 03. В отличие от электронных магазинов, операторов связи, организаций, предоставляющих информационные услуги, и т. п. ЭСС ориентированы только на прием вызовов из телефонной сети. Для ЭСС не нужны возможности IVR, приема и отправки сообщений по электронной почте, факсу, сетям IP-телефонии. Однако они предъявляют особые требования по надежности и количеству необслуженных заявок, если последнее решается увеличением канальной емкости к ТфОП, то необходимая надежность может быть достигнута использованием специализированной элементной базы и промышленных компьютеров вместе с резервированием оборудования и обеспечением надежности на программном уровне.

Комплекс ПРОТЕЙ-РВ применяется для оснащения ЭСС и в состоянии обеспечить высокую эффективность обработки поступающих заявок вместе с надежностью требуемого уровня (рис. 10).

Организации, предоставляющие справочно-информационные услуги, также могут эксплуатировать контакт-центр ПРОТЕЙ-РВ. В общем случае особенностями организации такого центра обслуживания вызовов будут являться интеграция контакт-центра с многочисленными базами данных, как следствие — соответствующий интерфейс РМО и, возможно, реализация механизмов взаимодействия операторского центра с биллинговыми системами на уровне генерации CDR (call detail records) в случае предоставления платных услуг (рис. 11). Остальные параметры системы в значительной степени будут зависеть от конкретных задач, стоящих перед информационной службой.

Может потребоваться организация удаленных рабочих мест или же создание распределенного операторского центра. Такое решение может потребоваться в случае территориально разнесенной компании, для которой необходимо сохранить единство структуры и управления контакт-центра.

Разница между распределенным центром и организацией удаленных рабочих мест операторов заключается в том, что в первом случае имеются несколько операторских центров, установленных в разных местах, обслуживающих местную нагрузку и увязанных в единую сеть с единой системой управления и контроля, для перераспределения нагрузки между узлами. Во втором случае организуется вынос части рабочих мест операторов за пределы основного узла. Благодаря принципам своего построения комплекс ПРОТЕЙ-РВ не требует никаких дополнительных решений для создания подобных разнесенных систем (рис. 12).

Уже довольно давно известно о таком явлении как аутсорсинг (outsourcing) услуг контакт-центров: возможности предоставления компанией-владельцем операторского центра его ресурсов в пользование другим организациям. В настоящее время область предоставления такого рода услуг стремительно расширяется на всей территории бывшего Советского Союза, в западных же странах этот феномен известен уже давно и широко используется.

Аутсорсинг услуг контакт-центров (далее просто аутсорсинг) может быть организован несколькими отличающимися в плане техники и бизнес-логики способами, применение которых зависит от потребностей организаций, желающих воспользоваться такими услугами, и уровня готовности организации-владельца к предоставлению таких услуг.

Технология реализации некоторых подходов для аутсорсинга ошибочно может показаться несложной, в реальности же каждый из них требует детального планирования, четкого понимания всех состояний системы и их возможных последствий, наконец, необходимого технического оснащения. Из всех существующих способов применения оборудования операторских центров аутсорсинг является, пожалуй, наиболее комплексным и в то же время расплывчатым, в силу неопределенной широты решаемых задач, примером.

В простейшем случае компания-владелец может отдать оборудование центра обслуживания вызовов в аренду организации, нуждающейся в этом, таким образом, максимально устранившись от последующего контроля и управления центром. Этот способ не обеспечивает компании-владельцу какой-либо гибкости в управлении услугами и возможности наращивания числа компаний-клиентов.

Другой, более приближенный к реальности вариант предоставления услуг аутсорсинга: создание в операторском центре различных групп операторов, которые бы обслуживали заявки, поступающие на различные компании. При этом потребуется разделение групп операторов по номерам доступа, т. е. по сути, создание на базе центра обслуживания вызовов нескольких служб. В этом случае обслуживание заявок, поступающих в компании-клиенты, возлагается на персонал, работающий под управлением компании-владельца центра. Такой подход может применяться при нецелесообразности создания для компании-клиента собственного операторского центра, например, когда его услуги необходимы лишь на краткое время (рекламные кампании, опросы), или когда компания-клиент в полной мере доверяет владельцу центра. Этот сценарий предоставления услуг аутсорсинга обеспечивает почти полное устранение компании-клиента от вопросов, связанных с операторским центром.

Наконец, третий способ предоставления услуг аутсорсинга: компания-владелец организует удаленные рабочие места операторов или создает распределенный контакт-центр. При этом узлы центра вместе с операторами находятся под контролем и управлением компаний-клиентов, а общее техническое обслуживание и управление центром осуществляется компанией-владельцем. Являясь наиболее затратным, этот подход обеспечивает полный контроль компанией-клиентом над всей предназначенной ей информацией, качеством работы операторов и выполнением всех программ компании, связанных с операторским центром.

При этом общие технические вопросы решаются владельцем центра.

В зависимости от требований пользователей услуг аутсорсинга и возможностей предоставляющих их компаний могут использоваться те или иные варианты предоставления таких услуг, они могут комбинироваться. Для технической реализации операторского центра в целях предоставления услуг аутсорсинга контакт-центр ПРОТЕЙ-РВ не имеет каких-либо ограничений. Проекты такого рода требуют детального планирования в каждом конкретном случае.


6. Функциональные возможности системы “Протей-РВ”

Организация очередей

Чтобы обеспечить наиболее качественное обслуживание поступающих вызовов, в системе ПРОТЕЙ-РВ создаются очереди ожидания обслуживания поступающих вызовов. В случае отсутствия свободных операторов в соответствующей службе вызов перенаправляется в очередь.

В системе предусмотрен постоянный контроль длины очереди. В случае, если длина очереди превышает предельно допустимую, абоненту будет передана соответствующая фраза автоинформатора, после чего осуществлено разъединение.

Для каждой группы операторов предусмотрена отдельная очередь. Наличие гибкой системы голосовых подсказок позволяет для каждой очереди ожидания организовать выдачу той или иной информации в зависимости от назначения данной группы. Постановка в очередь вызовов, поступающих из сети Internet, осуществляется аналогично вызовам из телефонной сети.

Предусматривается возможность динамически корректировать максимально допустимую длину очереди в зависимости от следующих критериев:

  • расчетное время ожидания;
  • средняя скорость ответа;
  • время ожидания в очереди самого раннего вызова;
  • число работающих операторов;
  • число свободных операторов;
  • время суток и день недели.

Возможности операторов в системе

В системе предусмотрена организация нескольких групп операторов. В группе может быть одно или несколько рабочих мест операторов. Операторы в системе идентифицируются уникальным номером (именем) и имеют свой пароль. Поддерживается разделение на операторов и старших операторов, которые обладают различными правами доступа.

Оператору центра предоставляются следующие возможности:

  • регистрация в необходимой группе на любом рабочем месте под уникальным паролем;
  • прием входящих вызовов из ТфОП;
  • организация исходящих вызовов;
  • удержание вызова;
  • консультация (второй вызов);
  • переадресация вызова в другую группу/службу/на старшего оператора;
  • кратковременный выход из режима обслуживания вызовов (блокировка консоли);
  • принудительное разъединение вызова;
  • обращение к базе данных центра в процессе обслуживания вызова;
  • запись переговоров с абонентами.

При поступлении входящего вызова на рабочем месте оператора (на экране ПК) отображается информация о вызывающем абоненте. Обеспечивается возможность регистрации поступившей заявки путем заполнения стандартной формы — “ситуационной карты” — с использованием технологии всплывающего окна.

В системе ПРОТЕЙ-РВ предусмотрена специальная функция Переадресация при неответе оператора. Эта функция позволяет корректно обслуживать вызов, поступивший на пульт оператора, который по какой-то причине не ответил на него после заданного интервала времени (например, покинул рабочее место, не оповестив об этом систему, которая продолжает его считать свободным для приема вызовов). В этом случае вызов может быть переадресован в ту же группу операторов.

Во избежание повторного неответа, рабочее место оператора при этом автоматически переводится в нерабочий режим, пока не вернется оператор и не перейдет в режим готовности. О каждом случае неответе оператора информируется старший оператор.

Возможности старшего оператора

1. Старший оператор в системе имеет возможность контролировать процесс приема и обслуживания вызовов:

  • состояние операторов в своей службе/группе;
  • состояние очереди;
  • статистику по выбранному оператору (количество обслуженных вызовов, время, в течение которого был занят оператор, и т. д.).

2. Для контроля работы операторов своей группы старшему оператору доступны следующие функции:

  • блокировка/разблокировка оператора;
  • вызов оператору;
  • подключение к разговору оператора с абонентом;
  • запись переговоров операторов с абонентами с возможностью последующего прослушивания с компьютера старшего оператора. Функция записи разговора доступна также обычному агенту.

3. В системе предусмотрена возможность одновременной записи разговоров нескольких операторов.

4. Старший оператор имеет возможность перемещать и удалять вызов из очереди.

5. Дополнительно старшему оператору доступны все возможности обычного оператора.

Режимы обслуживания вызовов

Система ПРОТЕЙ-РВ поддерживает следующие режимы обслуживания вызовов: предответный, ответный.

Режим обслуживания задается индивидуально для каждой группы.

Маршрутизация вызовов

Система ПРОТЕЙ-РВ поддерживает возможность гибкой маршрутизации вызовов. Вызов может направляться в ту или иную группу операторов по следующим критериям: набранный номер, информация АОН.

В зависимости от различных параметров, задаваемых администратором системы, вызовы могут маршрутизироваться к разным операторским группам и к разным операторам, абоненты могут получать разную информацию и т. д.

Предусмотрены следующие основные критерии маршрутизации вызовов:

  • набранный номер;
  • информация АОН;
  • число вызовов, ожидающих в очереди к данной группе операторов;
  • квалификация оператора;
  • количество операторов в группе, способных обслужить заявку;
  • алгоритм распределения вызовов.

Благодаря комбинации данных параметров, можно разработать гибкие алгоритмы обслуживания вызовов.

Для оптимизации работы центра обслуживания вызовов и более равномерной загрузки операторов в системе предусмотрены гибкие алгоритмы маршрутизации. Настройка того или иного алгоритма осуществляется на основе анализа целей и параметров внедрения МЦОВ.

Переадресация вызовов

Переадресация вызовов — это дополнительный вид обслуживания, применяемый для группы операторов или службы.

В системе возможна организация безусловной переадресации на группу/службу/внешний номер/автоинформатор.

Администратор, устанавливая тип переадресации, должен сообщить системе свои адреса назначения для данных видов переадресации.

Наблюдение за вызовом

Благодаря специальным функциям старший оператор может контролировать процесс приема и обслуживания вызовов.

Существуют следующие режимы контроля:

  • подключение к разговору операторов с вызывающими абонентами. Функция может быть активизирована заранее, когда оператор еще свободен. В этом случае контролирующая сторона автоматически подключается к соединению, как только оператор ответит на вызов;
  • просмотр процесса заполнения экранных форм контролируемым оператором (в ручном режиме с помощью стандартных утилит ОС РМО, например, Radmin);
  • запись переговоров операторов с абонентами (с возможностью последующего прослушивания с консоли старшего оператора и контролера). Функция записи доступна как старшему оператору, так и обычному оператору (например, если необходимо записать разговор). Предусмотрена возможность одновременной записи всех ведущихся разговоров;
  • просмотр в реальном времени заполнения экранных форм и их истории (хронологическая последовательность введенных команд и заполненных полей).

Дополнительные возможности

Дополнительно на базе МЦОВ ПРОТЕЙ-РВ обеспечивается возможность организации функций обслуживания потоков исходящих вызовов и предоставления разного рода автоинформационных услуг (речевая почта, услуги оповещения и др.)

Сбор статистической информации и учет вызовов

В системе предусмотрено формирование, хранение обширной статистической и эксплуатационной информации, а также возможность генерации отчетов реального времени и хронологических долгосрочных отчетов.

Информацию, накапливаемую в системе, можно разделить на информацию, накапливаемую в базе данных по каждому конкретному обращающемуся на службу (звонящему), и информацию, накапливаемую в процессе учета вызовов.

В системе предусмотрена возможность генерации отчетов (по согласованию с заказчиком). Возможна генерация отчетов реального времени и хронологических долгосрочных отчетов. Отчеты формируются по запросам с рабочего места администратора системы. Генерация отчетов может производиться по часам, суткам, неделям и т. д.

Возможен сбор разнообразной статистической информации по конкретному звонящему:

  • номер вызывающего абонента;
  • характер предыдущих запросов;
  • дата первого обращения и т. д.

При поступлении вызова на рабочем месте оператора обеспечивается возможность автоматического появления всей оперативной информации по вызывающему абоненту.

При поступлении вызова фиксируется следующая информация:

  • тип вызова;
  • время поступления вызова;
  • номер, категория вызывающего абонента;
  • номер вызываемого абонента;
  • время завершения сеанса связи;
  • продолжительность ожидания обслуживания;
  • продолжительность разговора;
  • номер оператора, обслужившего вызов;
  • статус вызова (обслужен/потерян);
  • этап обслуживания, на котором вызов был потерян (для потерянных вызовов);
  • инициатор отбоя;
  • при необходимости создается ситуационная карта.

В режиме реального времени предусмотрена выдача следующих типов отчетов:

  • состояние всех операторов в группе;
  • состояние всех рабочих мест МЦОВ;
  • состояние очередей к каждой группе операторов.

Кроме того, в реальном масштабе времени старший оператор имеет возможность получить информацию о времени ожидания вызовов в очереди, средней продолжительности разговора и т. д.

Система генерирует следующие типы хронологических отчетов:

  • информация по количеству любого типа вызовов, прошедших через систему (входящий/внутренний/исходящий) за любой промежуток времени;
  • информация по статусу вызовов: сколько за определенный промежуток времени вызовов было обслужено/потеряно/не обслужено;
  • количество вызовов, потерянных до граничного времени ожидания обслуживания;
  • количество вызовов, потерянных после граничного времени ожидания обслуживания;
  • количество вызовов, обработанных одним оператором за любой промежуток времени;
  • количество вызовов, обработанных всеми операторами группы/службы суммарно за любой промежуток времени;
  • суммарная занятость одного/всех операторов за рабочую смену (по времени);
  • количество переадресаций по причине занятости всех операторов за любой промежуток времени;
  • распределение времени оператора на обработку разных типов вызовов.

Обеспечивается генерация отчетов по часам, суткам, неделям, месяцам, кварталам, а также хранение в базе данных МЦОВ архивной информации об установленных соединениях, статистической информации за период 8 мес. (объем БД может быть увеличен по согласованию с заказчиком).

Администрирование

Надежное функционирование контакт-центра невозможно без подсистемы администрирования, способной обеспечить быстрое реагирование на изменения, влияющие на работу контакт-центра, а значит, отражающиеся и на качестве обслуживания абонентов. Необходимо постоянно контролировать работу центра, изменяя, когда нужно, число операторов в той или иной группе, создавая новые направления, модифицируя алгоритмы обслуживания и т. д., для чего в контакт-центре ПРОТЕЙ-РВ имеется мощная подсистема отчетности и административного управления.

Наряду с операторами и старшими операторами в системе предусмотрено наличие администратора, на которого возложены функции управления работой системы:

  • закрепление полных и сокращенных номеров доступа за службами (группами операторов);
  • управление атрибутами оператора (параметры регистрации: номер учетной записи, пароль; определение рабочего места (мест) для оператора; определение принадлежности оператора к группе (группам) и т. д.);
  • управление количеством и атрибутами групп операторов (определение состава операторов, входящих в группу; задание приоритета группы и т. д.);
  • управление работой группы операторов (блокировка–разблокировка рабочей группы);
  • настройка режима обслуживания входящих вызовов (ответный–предответный);
  • управление переадресацией входящих вызовов;
  • настройка критериев маршрутизации вызовов;
  • настройка алгоритмов распределения вызовов;
  • управление автоинформационными сообщениями, необходимыми для организации диалога IVR с абонентом, и другими голосовыми подсказками;
  • настройка параметров интерфейса с опорной АТС;
  • настройка “черных списков” абонентов, которым запрещено обслуживание в системе;
  • настройка длины очереди и времени нахождения вызова в очереди.

Сигнализация

Включение системы ПРОТЕЙ-РВ в цифровую АТС местной телефонной сети может осуществляться:

  • по двусторонним универсальным цифровым соединительным линиям (СЛ) с сигнализацией ОКС7 или DSS1;
  • по односторонним цифровым соединительным линиям (СЛ) 2 Мбит/с (ИКМ30) с линейной сигнализацией по двум выделенным сигнальным каналам (2ВСК) и передачей регистровых сигналов методом “импульсный челнок” с поддержкой функций АОН.

В случае необходимости может применяться конвертер сигнализации.Диаграммы обмена сообщениями по протоколу EDSS1 между центром обслуживания вызовов и опорной АТС при обслуживании входящего и исходящего вызовов приводятся на рис. 14, 15.


7. Анализ ВВХ оборудования ЦОВ

Исследованиям центров обслуживания вызовов и, в частности, систем распределения вызовов посвящено множество публикаций. Несмотря на то, что СРВ — один из множества вопросов, требующих изучения в этой области, большинство авторов останавливает внимание именно на нем. Это объясняется тем, что СРВ является исторически первой и основной функцией контакт-центров, что дает возможность “отточить” на ней существующие научные методы исследований.

Для решения задач по расчету параметров систем распределения вызовов естественным образом приспособлена теория телетрафика, её методами и предполагается проводить дальнейшее изучение проблем обслуживания заявок, поступающих на контакт и Call-центры.

Библиография материалов, посвященных ЦОВ обширна. Подчиняясь одному стремлению — повысить эффективность работы строящихся операторских центров, области исследований варьируются от методов вычисления производительности ЦОВ средствами теории телетрафика до составления оптимальных программ работы персонала центра, динамического изменения его параметров в зависимости от поступающей нагрузки и влияния психологии пользователей на поступающую нагрузку.

Существующие материалы также могут быть разделены по уровню абстракции от реальных задач: одна часть работ выполняется с целью предоставить менеджменту существующих и будущих ЦОВ инструмент для планирования работы операторских центров, другая часть предназначается самим исследователям для дальнейшего продвижения в разработке механизмов расчетов ЦОВ, предсказания параметров их функционирования.

Из теории телетрафика известно, что системы массового обслуживания описываются при помощи классификации Кендалла, имеющей вид A/B/V/K/N.

Знак A характеризует процесс поступления вызовов, этот процесс описывается при помощи функции распределения промежутков между вызовами.

Знак B используется для описания процесса обслуживания вызовов, описывается функцией распределения длительности обслуживания.

V — число обслуживающих приборов или линий.

K — емкость накопителя, равная сумме числа обслуживающих приборов и мест в очереди.

N — число источников, создающих поток вызовов.

Если какой-либо из параметров классификации Кендалла является бесконечно большим, то используется соответствующий символ Ґ, если данные параметры занимают последние места, то символ Ґ не указывается (например, при K = Ґ = N, используется запись вида A/B/V).

Если процесс A или B, или оба являются марковскими, то используется символ M: M/M/V — в данной модели процессы поступления и обслуживания вызовов являются марковскими (процесс без последействия, когда его будущее определяется только настоящим).

Если необходимо подчеркнуть произвольный закон распределения для того или иного процесса, то используется символ G, в случае детерминированного - D.

M/D/V - указывает на то, что длительность обслуживания является постоянной (неслучайной) величиной.

В зависимости от параметров задачи определения характеристик того или иного оборудования центров обслуживания вызовов, оно может быть представлено в виде различных моделей систем массового обслуживания, в том числе:

  • СМО M/M/k/Ґ , M/M/k/N;
  • СМО вида M1 + … +Mc / M / k / N;
  • СМО M/G/k/Ґ или G/G/k/Ґ с исследованием их поведения при вводе различных систем приоритетов для голосовых и текстовых сообщений;
  • СМО с различными дисциплинами приоритетов поступающих на обслуживание заявок;
  • СМО с распределениями времен обслуживания заявок и их поступления, отличными от экспоненциального (long-normal, PH).

Кратко остановимся на основных методах исследования центров обслуживания вызовов в соответствии с их эволюцией.

Вызовы (рис. 16) поступают на систему по входящим соединительным линиям от ТфОП и обрабатываются операторами, число которых меньше либо равно числу линий. В случае, если входящий вызов застает все линии занятыми, то он отклоняется, абоненту телефонной сети будет передан сигнал “занято”. Если свободные линии есть, то вызов поступает в систему, далее в зависимости от числа свободных операторов вызов может быть немедленно передан на обслуживание либо поставлен на ожидание. Часть вызовов может уйти из очереди, не дождавшись обслуживания. Для всех неуспешных (не окончившихся обслуживанием) вызовов возможны повторные попытки. Обслуженные вызовы могут уйти из системы или возвратиться в нее для дальнейшего обслуживания.

Наиболее простым способом моделирования call-центра является применение модели СМО типа M/M/k по классификации Кендалла, с неограниченным числом мест для ожидания. Несмотря на то, что подобная модель не принимает в расчет возможности потери вызовов из-за занятости линий, “нетерпеливости” пользователя, многоэтапного обслуживания и т. п., она является приемлемым средством оценки характеристик множества простых центров обслуживания вызовов.

Рассмотрим один из многочисленных примеров применения такой модели СМО для исследования характеристик call-центров (рис. 17).

Рис. 17. Диаграмма интенсивностей переходов СМО вида M/M/N

Рассматривается модель M/M/N со следующими характеристиками:

интенсивность поступления вызовов l n= l, n = 0, 1, 2,…;

интенсивность обслуживания

Для исследования характеристик центров обслуживания вызовов предлагается выбирать интервалы времени, на протяжении которых интенсивность поступления вызовов меняется незначительно (рис. 18).

Рис. 18. Изменение во времени числа вызовов,
поступающих на один из существующих call-центров

Рассматриваемая система хорошо изучена, для неё известны следующие результаты. Если принять за li интенсивность поступления вызовов на временном интервале i, а за mi = E[Si]–1 интенсивность обслуживания вызовов на данном интервале, то при [image], [image], где Ri — поступающая нагрузка, а pi — коэффициент использования системы.

Для системы M/M/N известно выражение P{Wait > 0} = C(N,Ri), которое также называется С-формулой Эрланга или второй формулой Эрланга:

.
(1)

Среднее время ожидания обслуживания в такой системе

,
(2)

а доля пользователей, время ожидания для которых составит менее Т:

(3)

Экспериментальные данные (рис. 19) близки к получаемым из приведенных соотношений (1) – (3).

Рис. 19. Диаграмма зависимости времени ожидания от использования системы
и обслуживания вызова в простом call-центре

Однако при всем удобстве и простоте такого подхода, он, все-таки, не учитывает важных особенностей функционирования реальных центров обслуживания вызовов и, как следствие, может применяться только для поверхностной оценки исследуемых характеристик.

В ряде случаев, при исследовании центров обслуживания вызовов, можно столкнуться не с экспоненциальным временем обслуживания заявок.

Несмотря на неудобство применения модели СМО вида M/G/N, известно следующее приблизительное соотношение:

,
(4)

где [image] — коэффициент вариации, дисперсия s2, S — время обслуживания.

В случае большой нагрузки на систему (С(N,R) » 1) — это выражение принимает вид:

.
(5)

Учесть возможность блокировки вызова, когда ему отказывается в обслуживании по причине отсутствия свободных линий, можно при помощи использования модели СМО вида M/M/N/N, для которой известна так называемая первая или B-формула Эрланга и которая описывает долю времени, когда все обслуживающие приборы системы заняты.

Диаграмма интенсивностей переходов для такой системы показана на рис. 20, а вероятность занятости всех обслуживающих приборов

— первая или B-формула Эрланга. (6)

Рис. 20. Диаграмма интенсивностей переходов СМО вида M/M/N/N

Широкое распространение в программном обеспечении модулей предсказания поведения характеристик центров обслуживания вызовов получили модели СМО с ограниченным буферным пространством. Это объясняется их близостью к реалиям существующих операторских центров.

Рассмотрим одну из таких моделей — СМО M/M/m/B (рис. 21).Отметим, что модель M/M/m/B близка по своим свойствам к рассмотренной выше M/M/N/N, за исключением ограниченного числа мест для ожидания, при переполнении которого поступающие заявки начинают теряться. Предполагается, что B > m, так как в противном случае некоторые обслуживающие приборы никогда бы не занимались, и система функционировала бы как M/M/B/B.

Рис. 21. Диаграмма интенсивностей переходов СМО вида M/M/m/B

Для описываемой системы интенсивность поступления заявок

l n= l, n = 0, 1, …, B –1, интенсивность обслуживания

Соотношение, определяющее вероятность заданного числа заявок в системе n

Определяя r = l / m · m , получаем

Используя известное равенство

,
(7)

можно найти p0.

Среднее число вызовов в очереди и среднее число вызовов в системе определяется следующими выражениями:

,
(8)

.
(9)

Известно, что все вызовы, поступающие в систему, когда она находится в состоянии n = B, теряются.

Таким образом, действительная (эффективная) интенсивность поступления заявок в систему

,

где pB — вероятность нахождения системы в состоянии B;

l - l' = pB — интенсивность потерянных вызовов.

Отметим, что в данной модели заявки не могут быть потеряны после поступления в очередь.

Воспользуемся формулой Литтла для определения среднего времени ожидания обслуживания:

.
(10)

Известно, что для модели M/M/m использование системы определяется по формуле [image], в случае ограниченного размера очереди

.
(11)

Перечисленные способы исследования характеристик операторских центров, несмотря на свою простоту, находят широкое применение в программном обеспечении оборудования ЦОВ.


8. Учебный проект контакт-центра

Цель данного учебного проекта состоит в определении:

  • спецификации потребностей и трафика;
  • анализа сетевого окружения;
  • разработки структурной схемы;
  • расчета необходимого объема оборудования;
  • возможной стоимости системы.

ЦОВ экстренной спецслужбы

На основе анализа сетевого окружения и потребностей реализуемой службы предложить и обосновать структурную схему ЦОВ на основе платформы ПРОТЕЙ.

Определить способ нахождения основных вероятностно-временных характеристик (ВВХ) центра обслуживания вызовов экстренной спецслужбы (ЭСС) из числа рассмотренных выше, и их значения при заданных условиях (табл. 2).

Таблица 2

Вариант | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
l, зап./с | 5 | 12 | 14 | 18 | 24 | 22 | 20 | 10
m, зап./с | 0,2 | 0,3 | 0,4 | 0,5 | 0,6 | 0,7 | 0,8 | 1

Определить интенсивность поступающей на ЦОВ нагрузки. Найти требуемое число операторов ЦОВ ЭСС при вероятности потерь по вызовам, равной 0,002. Исследовать зависимость ВВХ системы при изменении параметра потока l от 0 до N m, где N — найденное число операторов центра.

Исходя из полученных результатов, произвести расчет предполагаемого объема оборудования, исходя из спецификаций комплекса ПРОТЕЙ-РВ.

Указание. При выполнении данного задания нужно принимать во внимание особенности оборудования ЦОВ для ЭСС. В первую очередь это требования к вероятности потерь по вызовам, которая не должна превышать 0,002, а также недопустимость ожидания обслуживания вызывающим абонентом. Последнее приводит к тому, что часто подобные системы моделируются СМО с отказами (рис. 20). Для вычисления требуемого числа операторов ЦОВ необходимо воспользоваться формулой (6), допустимо использовать графический метод вычислений.

ЦОВ справочной службы оператора ТфОП

На основе анализа сетевого окружения и потребностей реализуемой службы предложить и обосновать структурную схему ЦОВ на основе платформы ПРОТЕЙ.

Таблица 3

Вариант | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16
l, зап./с | 10 | 15 | 20 | 25 | 28 | 30 | 35 | 40
m, зап./с | 0,2 | 0,3 | 0,4 | 0,5 | 0,6 | 0,7 | 0,8 | 1

Определить способ нахождения основных вероятностно-временных характеристик (ВВХ) центра обслуживания вызовов справочной службы оператора ТфОП из числа рассмотренных выше, и их значения при заданных условиях (табл. 3).

Определить интенсивность поступающей на ЦОВ нагрузки. Найти требуемое число операторов ЦОВ справочной службы при вероятности потерь по времени, равной 0,5. Исследовать зависимость ВВХ системы при изменении параметра потока l от 0 до N m, где N — найденное число операторов центра.

Найти требуемое число операторов ЦОВ справочной службы при вероятности ожидания не более 5 с, равной 0,9.

Исходя из полученных результатов, произвести расчет предполагаемого объема оборудования комплекса ПРОТЕЙ-РВ.

Указание. Построение ЦОВ для справочных служб операторов ТфОП предполагает создание систем, допускающих ожидание вызовом обслуживания. В связи с этим целесообразно воспользоваться для моделирования подобного call-центра СМО с ожиданием (рис. 17), при этом удовлетворительная точность результатов может быть достигнута и при предположении о бесконечном числе мест для ожидания. Для вычисления требуемого числа операторов ЦОВ необходимо воспользоваться формулами (1) – (3), допустимо использовать графический метод вычислений.

Контакт-центр предприятия электронной коммерции

На основе анализа сетевого окружения и потребностей реализуемой службы предложить и обосновать структурную схему ЦОВ на основе платформы ПРОТЕЙ.

Таблица 4

Вариант | 17 | 18 | 19 | 20
l1 | 7 | 9 | 12 | 10
l2, зап./с | 5 | 7 | 9 | 15
m, зап./с | 0,25 | 0,2 | 0,3 | 0,35

Определить способ нахождения основных вероятностно-временных характеристик (ВВХ) контакт-центра предприятия электронной коммерции (eCommerce) из числа рассмотренных выше, и их значения при заданных условиях. Предполагается поступление на систему двух разнотипных потоков запросов: речевых вызовов и сообщений электронной почты (табл. 4).

Определить суммарную интенсивность поступающей на ЦОВ нагрузки. Найти требуемое число операторов контакт-центра при вероятности потерь по времени, равной 0,3. Исследовать зависимость ВВХ системы при изменении параметра потока l от 0 до N m, где N — найденное число операторов центра.

Пользуясь полученными значениями определить среднее время ожидания обслуживания запроса в такой системе.

Исходя из полученных результатов, произвести расчет предполагаемого объема оборудования, исходя из спецификаций комплекса ПРОТЕЙ-РВ.

Предложить способ расчета ВВХ контакт-центра при различных интенсивностях поступления вызовов и различных интенсивностях обслуживания запросов (на базе известных по курсу моделей СМО).

Дополнительно провести исследование ЦОВ моделируемого СМО с ограниченным буферным пространством, для этого, используя найденное ранее N, определить среднее время ожидания обслуживания в такой системе, предполагая, что число мест для ожидания равно половине числа операторов. Найти интенсивность потока потерянных вызовов.

Указание. При выполнении данного задания необходимо учесть свойства простейшего потока вызовов при объединении независимых случайных потоков с различными интенсивностями поступления вызов.

Построение современных контакт-центров предполагает создание систем, с ожиданием вызовом обслуживания. В связи с этим целесообразно воспользоваться для моделирования подобного call-центра СМО с ожиданием, при этом удовлетворительная точность результатов может быть достигнута и при предположении о бесконечном числе мест для ожидания. Диаграмма состояний предлагаемой СМО представлена на рис. 17. Для вычисления требуемого числа операторов ЦОВ необходимо воспользоваться формулами (1), (2), допустимо использовать графический метод вычислений.

Диаграмма состояний СМО с ограниченным буферным пространством представлена на рис. 21, ВВХ дополнительного задания находятся по формулам (7) – (10), относящимся к данной СМО.


перейти на DVO Pages

E-mail: teach@sut.ru

перейти к Списку литературы
Санкт-Петербургский государственный университет телекоммуникаций
им. проф. М.А. Бонч-Бруевича

Б.С.Гольдштейн, А.А. Зарубин

Контакт-центры мультисервисных сетей связи

Методические рекомендации к практическим занятиям
200900

Cодержание:

1. Ступени распределения вызовов

2. Call-центры

3. Контакт-центры

4. Алгоритмы обслуживания вызовов

5. Учебная установка IP Контакт-Центр “Протей-РВ”

6. Функциональные возможности системы “Протей-РВ”

7. Анализ ВВХ оборудования ЦОВ

8. Учебный проект контакт-центра

Литература

перейти на DVO Pages

E-mail: teach@sut.ru

перейти к Списку литературы


Литература

  • Гольдштейн Б.С., Фрейнкман В.А. Call-центры и компьютерная телефония. СПб: БХВ, 2002.
  • Руководящий технический материал “Построение центров обслуживания вызовов на базе оборудования Протей-РВ” / НТЦ Протей. СПб, 2003.

    • Назад