Основы СЦИ

Данный текст повторяет издание 1999 года без внесения каких-либо изменений и корректировок. Никакие замечания и предложения по данному тексту к рассмотрению не принимаются.

Администрация

Гордиенко В.Н., Ксенофонтов С.Н., Кунегин С.В., Цыбулин М.К. Современные высокоскоростные цифровые телекоммуникационные системы. Ч. 3. Группообразование в синхронной цифровой иерархии: Учебное пособие / МТУСИ. - М., 1999. - 76 с.

Рекомендовано УМО по образованию в области связи в качестве учебного пособия для студентов, обучающихся по специальностям 201000 и 071700. Протокол № 1 от 22 декабря 1998 г.

Содержание

1. Сравнение плезиохронной и синхронной цифровых иерархий

1.1. Основные характеристики ПЦИ

1.2. Основные характеристики СЦИ

1.3. Сравнительная оценка СЦИ и ПЦИ

2. Структуры кадров и интерфейсы СЦИ

2.1. STM-1

2.2. STM-N

2.3. Скремблирование цифровых потоков STM

2.4. Коды и интерфейсы СЦИ

3. Основные элементы STM-1

3.1. Контейнер C

3.2. Виртуальный контейнер VC

3.3. Административный блок AU

3.4. Группа административных блоков AUG

3.5. Нагрузочный блок TU

3.6. Группа нагрузочных блоков TUG

3.7. Общая характеристика элементов STM

4. Принципы размещения контейнеров и блоков STM-1

4.1. Административная группа AU

4.1.1. AU-4

4.1.2. AU-3

4.2. AUG в STM-1

4.3. Нагрузочный блок TU

4.3.1. TU-3

4.3.2. TU-1, TU-2

4.4. Группа нагрузочных блоков TUG

4.4.1. TUG-2

4.4.2. TUG-3

5. Размещение потоков ПЦИ в контейнерах

5.1. Общие положения

5.2. Размещение потока 140 Мбит/с в С-4

5.3. Размещение потока 34 Мбит/с в С-3

5.4. Размещение потока 2 Мбит/с в С-12

6. Указатели

6.1. Функции указателей

6.2. Типы и структура указателей

6.3. Адресные схемы указателей

6.4. Выравнивание по указателю

7. Заголовки

7.1. Функции заголовков

7.2. Секционный заголовок SOH

7.3. Трактовые заголовки POH VC-3 и VC-4

7.4. Трактовый заголовок POH VC-1x и VC-2

8. Контроль и управление в СЦИ

8.1. Общий принцип обнаружения ошибок

8.2. Код BIP-N

8.3. Секции контроля

8.4. Сообщение об ошибке блока на дальнем конце FEBE (Far End Block Error)

8.5. Сообщение об ошибке приема на дальнем конце FERF (Far End Receive Failure) - сигнализация об аварии на дальнем конце

8.6. Сигнал индикации тревоги AIS (alarm indication signal)

9. Контрольные вопросы

1. Сравнение плезиохронной и синхронной цифровых иерархий

1.1. Основные характеристики ПЦИ

В настоящее время распространены две цифровые плезиохронные иерархии.

В США и некоторых других странах иерархия основана на первичном цифровом потоке со скоростью 1,5 Мбит/с. Скорости передачи цифровых потоков равны: 1,544 Мбит/с, 6,312 Мбит/с и 44,736 Мбит/с.

В Европе, Австралии и ряде других регионов используется иерархия, основанная на первичном цифровом потоке со скоростью 2 Мбит/с. Данный цифровой поток стандартизован CEPT. Скорости передачи цифровых потоков составляют: 2,048 Мбит/с, 8,448 Мбит/с, 34,368 Мбит/с и 139,264 Мбит/с.

ITU-T объединил оба варианта в Рекомендации G.702 (“Плезиохронная цифровая иерархия”).

Для ПЦИ характерны следующие особенности:

  • Плезиохронные сигналы.

  • Побитное мультиплексирование (временное группообразование).

  • Объединение асинхронных сигналов при помощи побитного положительного выравнивания (положительного согласования скоростей). В России и ряде других европейских стран ранее выпускалось оборудование ПЦИ, использующее положительно-отрицательное (двустороннее) согласование скоростей. Это оборудование несовместимо с оборудованием ПЦИ, использующим положительное (одностороннее) согласование скоростей.

  • Специальный формат кадра (цикла) передачи для каждого уровня мультиплексирования.

  • Приемному мультиплексору внешняя синхронизация не обязательна.

  • Фазовое соотношение между кадрами и нагрузочной информацией не фиксируется. Невозможен прямой доступ к индивидуальным каналам, объединенным в групповом потоке. Для такого доступа необходимо произвести полное последовательное демультиплексирование.

1.2. Основные характеристики СЦИ

Синхронная цифровая иерархия (Synchronous Digital Hierarchy - SDH) является всемирным стандартом технологии передачи. Определена стандартом ITU-T.

Скорости передачи СЦИ определены стандартами ITU-T G.702, G.707.

Первичным цифровым потоком СЦИ является синхронный транспортный модуль STM-1 (Synchronous Transport Module). Скорость передачи STM-1 равна 155,52 Мбит/с. Дальнейшее увеличение скорости передачи достигается мультиплексированием с коэффициентом 4. Образуются модули STM-N. В настоящее время стандартизированы модули с N=1,4,16,64.

Для СЦИ характерны следующие особенности:

  • Синхронизованность сети.

  • Побайтное объединение (мультиплексирование) на основе указателей.

  • Возможность функционирования в плезиохронном режиме. Фазовое соотношение регулируется положительным, нулевым или отрицательным побайтным выравниванием.

  • Модульность структуры. Более высокие скорости передачи достигаются побайтным мультиплексированием нескольких STM-1. Мультиплексирование выполняется таким образом, что структура результирующего модуля STM-N практически идентична структуре STM-1. Скорости передачи СЦИ в целое число раз выше скорости передачи 155,52 Мбит/с, а именно: STM-4 – 622,08 Мбит/с, STM-16 – 2488,32 Мбит/с, STM-64 – 9953,28 Мбит/с.

  • Фазовые соотношения между кадрами и пользовательской информацией фиксируется посредством указателей. Обработка указателей обеспечивает возможность доступа к любому сигналу в высокоскоростном потоке.

На Рис.1 показан принцип объединения цифровых потоков с использованием указателей.

Рис. 1. Объединение потоков с использованием указателей

1.3. Сравнительная оценка СЦИ и ПЦИ

Преимущества СЦИ заключается в следующем:

  • Впервые стандартизирована скорость передачи свыше 140 Мбит/с

  • Стандартизирован линейный оптический сигнал, что дает возможность совместимости оборудования различных производителей

  • Модульность структуры. Более высокие скорости передачи достигаются побайтным мультиплексированием нескольких STM-1. Скорости передачи СЦИ в целое число раз выше скорости передачи 155,52 Мбит/с.

  • Доступ к отдельным каналам в групповом канале возможен с использованием указателей, что весьма удобно при необходимости частого ввода/вывода отдельных каналов.

Большое число служебных позиций дает возможность управления сетью, что особенно важно для применения сети TMN (Telecommunication Management Network).

  • Возможна передача всех сигналов ПЦИ, определенных рекомендацией G.702 ITU-T.

  • Возможна передача широкополосных сигналов, которые могут появиться в будущем.

  • Возможно прямое преобразование электрических сигналов в оптические без применения сложного линейного кодирования. Производится проверка на четность для обнаружения ошибок на разных уровнях структур СЦИ.

  • Не требуется специальное линейное оборудование. В оборудовании СЦИ оно объединено с мультиплексорами, что повышает его эффективность.

Недостатки СЦИ заключаются в следующем:

  • Более сложная технология из-за необходимости фиксации фазовых соотношений между нагрузкой и заголовком.

  • Реализована возможность транспортирования только трех потоков со скоростью 34 Мбит/с в модуле STM-1, хотя его емкость достаточна для транспортирования четырех таких потоков.

  • Побайтное выравнивание может приводить к большему джиттеру, чем побитное.

  • Отсутствует однозначный порядок преобразования сигналов всех ПЦИ, что требует дополнительной аппаратной поддержки.

2. Структуры кадров и интерфейсы СЦИ

2.1.STM-1

Первичным цифровым потоком СЦИ является модуль STM-1, имеющий скорость передачи 155, 52 Мбит/с.

Модуль STM-1 состоит из 2430 байт и обычно изображается в виде таблицы из 9 строк по 270 байт (рис. 2). Период повторения STM-1 составляет 125 мкс, что соответствует частоте повторения 8000 Гц. Каждый байт соответствует каналу со скоростью передачи 64 кбит/с.

Рис. 2. Представление STM-1

STM-1 содержит три основные блока (Рис. 3):

  • секционный заголовок SOH (Section Overhead)

  • блок нагрузки (payload)

  • указатель PTR (pointer)

Рис. 3. Структура кадра STM-1

Байты STM-1 передаются, начиная с левого верхнего угла слева направо, сверху вниз.

Блок SOH размером 8 ´ 9 байт несет служебную информацию, в том числе синхросигнал, байты для обслуживания, контроля и управления. Подразделяется на заголовок регенерационной секции (RSOH - regenerator SOH) и заголовок мультиплексной секции (MSOH - multiplex SOH) (см. раздел 7).

Сигналы нагрузки (от 2 до 140 Мбит/с в соответствии с G.702) транспортируются в области нагрузки размером 9 ´ 261 байт. Эти сигналы объединяются в модуль STM-1 в соответствии с определенными правилами (см. разделы 3, 4, 5).

Фазовое соотношение между нагрузкой и кадром STM фиксируется в указателе PTR, что позволяет определить местоположение нагрузочных сигналов в блоке нагрузки. В результате имеется возможность доступа к одиночным каналам без необходимости полного демультиплексирования STM-1. Используются три указателя каждый длиной 3 байта (см. раздел 6).

2.2. STM-N

Высокоскоростные потоки СЦИ организуются побайтным мультиплексированием нескольких STM-1 и называются синхронными транспортными модулями уровня N STM-N (рис. 4). Скорость STM-N составляет N´ 155,52 Мбит/с.

Рис. 4. Формат STM-N

В настоящее время, как отмечалось выше, стандартизированы уровни 4, 16 и 64: STM-4 4´ 155,52 Мбит/с = 622,08 Мбит/с, STM-16 16´ 155,52 Мбит/с = 2,48832 Гбит/с и STM-64 64´ 155,52 Мбит/с = 9,95328 Гбит/с.

Структура кадра STM-N соответствует структуре STM-1, с тем отличием, что передаются N´ 9´ 270 байт за 125 мкс. Байты заголовков, указателей и нагрузки объединяются в аналогичные три блока (рис. 4).

При мультиплексировании байты нагрузки объединяемых STM-1 объединяются побайтно в нагрузку STM-N без буферизации. Позиция STM-1 в составе STM-N может отличаться от исходной из-за возможного фазового различия между STM-1 и STM-N. Каждый индивидуальный указатель должен быть изменен в соответствии с этим фазовым различием. Данная операция называется согласованием указателей.

Как N модулей STM-1 могут быть объединены в один модуль STM-N, так и M модулей STM-N могут быть объединены в один модуль STM-M´ N. Действует следующее основное правило: если объединяются M модулей STM-N в модуль STM-M´ N, то из каждого объединяемого потока STM-N берется по N байт, т.е. применяется N-байтное мультиплексирование.

Соответственно, по одному байту от каждого STM-1 объединяются в STM-N. Аналогично объединяются по 4 байта от каждого STM-4 при образовании STM-16.

Достоинством данной процедуры является то, что высокоскоростные потоки могут быть получены последовательным мультиплексированием. Например, можно получить поток STM-16, побайтно объединяя 16 модулей STM-1. В тоже время, STM-16 может быть получен из четырех модулей STM-4 (Рис. 5).

Рис. 5. Технология мультиплексирования

2.3. Скремблирование цифровых потоков STM

Линейный сигнал СЦИ должен иметь хорошие статистические свойства с точки зрения возможности выделения тактовой частоты на приеме. В нем не должно быть длинных последовательностей единиц и нулей.

Существующим методом обеспечения статистических свойств линейных сигналов при применении коаксиального кабеля является использование специальных кодов (обычно биполярных двоичных и троичных).

Для передачи модулей STM-1 и STM-N в качестве среды распространения используется оптическое волокно (ОВ). Для обеспечения статистических свойств сигнала применяется скремблирование (Рис. 6). В дополнение к оптическому интерфейсу для модуля STM-1 в рекомендации G.703 предусмотрен электрический интерфейс с использованием кода CMI.

Рис. 6. Скремблирование STM-N

Скремблер устанавливается на передающей стороне. Он складывает исходную двоичную последовательность с псевдослучайной последовательностью по модулю 2. Дескремблер устанавливается на приемной стороне и восстанавливает исходную последовательность. Скремблер и дескремблер выполняются в виде сдвигового регистра с обратными связями (Рис. 7).

Рис. 7. Скремблер

Модули STM подвергаются скремблированию только перед преобразованием в оптический сигнал для передачи по ОВ. Скремблирование модулей не производится, если предусматривается их дальнейшее мультиплексирование.

Процедуре скремблирования подвергаются все байты STM-1 и STM-N, кроме первой строки SOH (Рис. 6), поскольку содержащиеся в ней байты являются синхросигналом. В результате возможно установление синхронизации без предварительного дескремблирования.

Для скремблирования применяется скремблер с предварительной установкой. Образующий полином скремблера 1+х6+х 7. Скремблер устанавливается в исходное состояние “1111111” после прохождения первой строки SOH, которая не подвергается скремблированию. Все последующие биты модуля, начиная с первого бита блока нагрузки, скремблируются.

2.4. Коды и интерфейсы СЦИ

Для электрического интерфейса STM-1в рекомендации G.703 определены следующие параметры:

Скорость передачи: 155,52 Мбит/с

Код: CMI (Coded Mark Inversion)

Уровни: 1,0 VSS ± 0,1 В

Код CMI - это двухуровневый код, в котором единицы передаются попеременно высоким и низким уровнем сигнала в течении тактового интервала, а нуль передается первую половину тактового интервала низким уровнем, а вторую - высоким.

Рис. 8. Код CMI

Оптический интерфейс STM-1 и STM-N характеризуется следующими параметрами:

Скорость передачи: N´ 155,52 Мбит/с

Код: Скремблированный NRZ

3. Основные элементы STM-1

3.1. Контейнер C

Для того, чтобы быть переданным в составе модуля STM-1, любой исходный цифровой поток, как синхронный, так и плезиохронный, должен быть помещен в соответствующий контейнер.

Рис. 9. Образование структур СЦИ

Термин "контейнер" описывает информационную структуру синхронной сети определенной емкости, требуемую для передачи данного исходного цифрового потока. Размер контейнера указывается в байтах. Все байты контейнера передаются за 125 мкс. Принятые размеры контейнеров соответствуют цифровым потокам ПЦИ (Табл. 1).

Таблица 1.

Обозначение контейнера | Передаваемый поток, кбит/с
С-11 | 1 544
С-12 | 2 048
С-2 | 6 312
С-3 | 44 736 или 34 368
С-4 | 139 264

Передаваемые цифровые потоки должны размещаться в контейнерах. Размещение выполняется с помощью побитного и побайтного выравнивания для плезиохронных сигналов, причем наряду с отрицательным используются нулевое и положительное выравнивания.

Контейнер содержит:

  1. Собственно передаваемую нагрузку (например, цифровой поток ПЦИ)

  2. Фиксированные байты и биты выравнивания (фиксированная вставка). Эти байты (или биты) никогда не переносят нагрузки и используются только для приближенного увеличения скорости передачи до скорости передачи соответствующего контейнера.

  3. Биты точного выравнивания. В этих битах по необходимости могут размещаться биты нагрузки или биты вставки.

  4. Биты управления выравниванием показывают приемнику, что именно в данный момент располагается в битах точного выравнивания: биты нагрузки или биты вставки.

3.2. Виртуальный контейнер VC

К каждому контейнеру С добавляется трактовый заголовок POH (Path Overhead). Эта совокупность называется виртуальным контейнером VC (Virtual Container) и передается через сеть как неизменяемая единица (см. Рис. 9).

В POH содержится служебная информация, позволяющая отслеживать надежность транспортировки контейнера через сеть от источника к получателю. POH добавляется в начале тракта при формировании VC и устраняется в конце тракта при расформировании контейнера. Кроме того, в POH содержится служебная информация для целей контроля и управления сетью.

В зависимости от размера виртуальный контейнер может транспортироваться в модуле STM-1 в одиночку или может быть объединен в больший VC, который затем непосредственно транспортируется в STM-1.

Различают виртуальные контейнеры высшего уровня HO (high-order) и низшего уровня LO (low-order).

Все контейнеры, передаваемые в составе одного “большого” контейнера относятся к нижнему уровню LO. Контейнерами уровня LO являются VC-11, VC-12 и VC-2. VC-3 относят к уровню LO, если этот контейнер передается в составе VC-4.

Контейнеры, непосредственно переносимые в модуле STM-1, относятся к уровню HO. VC-4 - контейнер уровня HO. То же относится и к VC-3, если он передается непосредственно.

3.3. Административный блок AU

Виртуальные контейнеры высшего уровня VC-4 и VC-3 транспортируются непосредственно в STM-1.

В этом случае указатели (блок AU_PTR) в составе STM-1 отражают фазовые соотношения между модулем и соответствующим виртуальным контейнером. Та часть модуля STM-1, в пределах которой может “плавать” VC, называется административной группой AU (Administrative Unit). Соответствующий указатель, называемый указателем AU (AU_PTR), рассматривается как часть AU (см. Рис. 9). Трехбайтные указатели AU помещаются в первые 9 байт четвертой строки модуля STM-1.

Различают AU-4 и AU-3. В модуле STM-1 можно передавать один AU-4 или три AU-3.

Передача VC-3 возможна непосредственно (AU-3) в STM-1 или через AU-4. Во втором случае три VC-3 должны быть объединены в один VC-4 (см. TU-3, раздел 4).

3.4. Группа административных блоков AUG

Несколько AU могут быть побайтно объединены в одну группу AU (AUG - AU group) (см. Рис. 9). AUG представляет собой информационную структуру, соответствующую STM-1 без SOH. Добавлением SOH к AUG получается STM-1. AUG может состоять из одного AU-4 или трех AU-3.

3.5. Нагрузочный блок TU

За исключением VC-4 все VC могут быть объединены в большие VC и транспортироваться в STM-1. “Меньшие” VC могут плавать по фазе внутри “больших” (высшего уровня) VC. Для отражения фазовых соотношений между двумя VC используются указатели, помещаемые в фиксированном месте VC высшего уровня. Нагрузочным блоком TU (Tributary Unit) называется информационная структура, используемая для описания составляющей контейнера высшего уровня HO, внутри которой может плавать VC низшего уровня LO, и соответствующие указатели (TU pointer) (см. Рис. 9).

Стандартизированы нагрузочные блоки TU-11, TU-12, TU-2, TU-3.

3.6. Группа нагрузочных блоков TUG

Перед объединением в контейнер высшего уровня несколько TU побайтно объединяются в одну группу. Такая группа называется группой нагрузочных блоков TUG (Tributary unit group) (см. Рис. 9).

Определены TUG-2 и TUG-3.

3.7. Общая характеристика элементов STM

В табл. 2 приведены основные характеристики элементов STM-1, рассмотренных выше.

Таблица 2.

Контейнер размер, байты скорость, кбит/с | С-11 25 1600 | С-12 34 2176 | С-2 106 6784 | С-3 756 48384 | С-4 2340 149760
Виртуальный контейнер размер, байты скорость, кбит/с | VC-11 26 1664 | VC-12 35 2240 | VC-2 107 6848 | VC-3 765 48960 | VC-4 2349 150336
Нагрузочный блок размер, байты скорость, кбит/с | TU-11 27 1728 | TU-12 36 2304 | TU-2 108 6912 | TU-3 768 49152 |
Группа нагрузочных блоков размер, байты скорость, кбит/с |  |  | TUG-2 108 6912 | TUG-3 774 49536 |
Административный блок размер, байты скорость, кбит/с |  |  |  | AU-3 786 50304 | AU-4 2358 150912
Группа административных блоков размер, байты скорость, кбит/с |  |  |  |  | AUG 2358 150912

На Рис. 10 показана общая, а на Рис. 11 – европейская схемы преобразований в СЦИ при формировании STM-N (в качестве нагрузки выступают цифровые потоки ПЦИ). На Рис. 12 показаны возможные варианты формирования STM-1 с применением VC-3 и VC-4.

Рис. 10. Общая схема преобразований СЦИ

Рис. 11. Европейская схема преобразований СЦИ

4. Принципы размещения контейнеров и блоков STM-1

4.1. Административная группа AU

4.1.1. AU-4

Один контейнер VC-4 транспортируется в AU-4. AU-4 - это синхронная структура, состоящая из 9´ 261+9 байт и соответствующая модулю STM-1 без секционного заголовка SOH.

VC-4 разработан для передачи потока ПЦИ со скоростью 140 Мбит/с. VC-4 содержит один контейнер С-4 (9´ 261 байт) и один столбец трактового заголовка POH VC-4 (9 байт).

VC-4 может плавать внутри AU-4. Указатель AU-4 содержит позицию (адрес) первого байта (J1) POH. В разделе 6 описана соответствующая адресная схема. Указатель AU-4 может адресовать каждый третий байт кадра, поэтому VC-4 должен начинаться только с каждого третьего столбца кадра.

На Рис. 13 показан AU-4 с VC-4, а на Рис. 14 - позиция VC-4 в модуле STM-1.

4.1.2.AU-3

В STM-1 могут непосредственно передаваться три VC-3 в трех AU-3 (см. Рис. 10 и Рис. 12). VC-3 разработан для передачи одного из потоков ПЦИ со скоростями 34 Мбит/с или 45 Мбит/с. VC-3 содержит один контейнер С-3 (9´ 84 байт) и один столбец трактового заголовка POH VC-3 (9 байт) (Рис. 15а).

AU-3 - это синхронная структура, состоящая из 9´ 87+9 байт, внутри которой может плавать VC-3. Емкость AU-3 (87 столбцов) больше, чем требуется для передачи VC-3 (85 столбцов), поэтому добавляются два столбца фиксированной вставки (Рис. 15б).

Три AU-3 побайтно мультиплексируются в модуле STM-1, включая трехбайтные указатели AU-3 (Рис. 15в). Каждый из этих трех указателей адресует соответствующий VC-3, показывая на первый байт POH соответствующего VC-3. В разделе 6 описана соответствующая адресная схема.

4.2. AUG в STM-1

AUG - это синхронная структура, состоящая из 9´ 261+9 байт. Модуль STM-1 образуется добавлением к AUG секционного заголовка SOH. AUG может состоять из одной AU-4 (Рис. 16а) или из трех побайтно объединенных AU-3 (Рис. 16б).

4.3. Нагрузочный блок TU

4.3.1. TU-3

Три VC-3 могут быть побайтно объединены в один VC-4, который затем будет передаваться в AU-4 (Рис. 12 и Рис. 17).

В результате такого непрямого преобразования получаются два уровня указателей:

  • Указатель AU-4 в блоке SOH указывает позицию VC-4 в модуле STM-1.

  • Три указателя TU-3 (по 3 байта каждый) фиксируются в VC-4 и содержат значение позиции одного из VC-3 в VC-4. Каждый из VC-3 может плавать внутри VC-4. TU-3 состоит из VС-3 и соответствующего указателя и имеет размер 9´ 85+3 байт.

4.3.2. TU-1, TU-2

Как отмечалось выше, определены следующие три базовых виртуальных контейнера:

VC-11 - разработан для транспортирования цифрового потока ПЦИ со скоростью передачи 1,5 Мбит/с. Состоит из контейнера С-11 (25 байт) и POH VC-11 (1 байт)

VC-12 - разработан для транспортирования цифрового потока ПЦИ со скоростью передачи 2 Мбит/с. Состоит из контейнера С-12 (34 байт) и POH VC-12 (1 байт)

VC-2 - разработан для транспортирования цифрового потока ПЦИ со скоростью передачи 6 Мбит/с. Состоит из контейнера С-2 (106 байт) и POH VC-2 (1 байт)

VC-1x и VC-2 могут быть переданы в VC-4 или VC-3 побайтным мультиплексированием. При передаче этих контейнеров через VC-3 предусмотрен путь только через AU-3 (см. схему преобразований СЦИ). Указатель VC-1x и VC-2 занимает фиксированную позицию в высшей структуре. TU-1x и TU-2 образуются добавлением к VC-1x и VC-2 соответствующих указателей (Рис. 18 и Рис. 19 соответственно).

В отличие от передачи виртуальных контейнеров высшего уровня (VC-3/4) VC-1x и VC-2 передаются с помощью сверхцикла длительностью 500 мкс (4´ 125 мкс) (Рис. 20).

За подцикл длительностью 125 мкс передается только один байт указателя VC-1x и VC-2. Этот байт занимает фиксированную позицию в высшей структуре (VC-4 или VC-3). Передача всего указателя осуществляется последовательно. Весь трехбайтовый указатель передается за три подцикла. Назначение четвертого байта, переносимого четвертым подциклом сверхцикла 500 мкс, пока не определено.

Адресная схема указателей в сверхцикле длительностью 500 мкс описана в разделе 6.

4.4. Группа нагрузочных блоков TUG

4.4.1. TUG-2

Несколько TU-1x должны быть объединены в одну группу для их транспортирования в контейнерах высшего порядка (VC-4 или VC-3). Такая группа называется группой нагрузочных блоков TUG-2 и организуется побайтным мультиплексированием соответствующих TU-1x (Рис. 21 и Рис. 22). В тоже время в группе TUG-2 может содержаться только один блок TU-2 (Рис. 23).

Таким образом, TUG-2 может состоять из (Рис. 24):

  • одного TU-2 или

  • четырех TU-11 или

  • трех TU-12.

4.4.2. TUG-3

TUG-3 может состоять или из одного TU-3 (Рис. 25) или семи TUG-2 (Рис. 26) при побайтном мультиплексировании.

Размер TUG-3 составляет 9´ 86 байт (Рис. 27). Если TUG-3 содержит один TU-3, то первый столбец содержит трехбайтовый указатель и 6 байт фиксированной выравнивающей вставки. Однако, если TUG-3 состоит из семи TUG-2, то указатель TUG-3 не выполняет ни какой функции, поскольку индивидуальные указатели в составе TUG-2 адресуют конкретные VC-1x или VC-2. В этом случае указатель имеет специальный вид и называется индикацией нулевого указателя NPI (null pointer indication).

Три TUG-3 могут быть побайтно объединены в один VC-4 для передаче в блоке AU-4 (Рис. 28).

На Рис. 29 показан принцип формирования TUG-3 из TU-12 с использованием TUG-2.

Рис. 13. AU-4 в STM-1

Рис. 14. AU-4 в STM-1

a)

б)

в)

Рис. 15. Размещение трех AU-3 в STM-1

а)

б)

Рис. 16. AUG в STM-1

Рис. 17. Формирование TU-3

Рис. 18. Формирование TU-11 и TU-12

Рис. 19. TU-2

Рис. 20. Сверхцикл TU-12 (500 мкс)

Рис. 21. Объединение TU-11 и TU-12 в TUG-2

Рис. 22. TUG-2 (Три TU-12)

Рис. 23. Преобразование TU-2 в TUG-2

Рис. 24. Различные TUG-2

Рис. 25. TU-3 в TUG-3

Рис. 26. TUG-2 в TUG-3

Рис. 27. Различные TUG-3

Рис. 28. Объединение TUG-3 в VC-4

Рис. 29. TU-12 через TUG-2 в TUG-3

5. Размещение потоков ПЦИ в контейнерах

5.1.Общие положения

Потоки ПЦИ согласуются со скоростями передачи контейнеров с помощью побитного и побайтного выравнивания. Скорость передачи контейнера всегда выше скорости передаваемого потока ПЦИ. Контейнеры могут рассматриваться как некий кадр, в котором передаются потоки ПЦИ. Кроме собственно информационных бит (I) в состав контейнера входят биты выравнивания (S) и биты управления выравниванием (C), а также биты заголовка и биты фиксированной вставки. Позиции всех бит в контейнере точно определены. Скорость потока ПЦИ приблизительно выравнивается со скоростью контейнера с помощью бит фиксированной вставки, а биты выравнивания используются для точного согласования скоростей. Под размещением потока ПЦИ в контейнере понимается конкретное расположение указанных бит.

5.2. Размещение потока 140 Мбит/с в С-4

Поток ПЦИ со скоростью 140 Мбит/с размещается в контейнере С-4 с помощью побитного положительного выравнивания. На каждую строку контейнера приходится 1 бит выравнивания и 5 бит управления выравниванием. На Рис. 30а показан общий принцип размещения, а на Рис. 30б – детальное расположение бит в одной строке VC-4.

а)

б)

Рис. 30. Размещение потока ПЦИ 139,264 Мбит/с в VC-4

Контейнер С-4 имеет размер 260´ 9´ 8 бит и передается за 125 мкс.

Точная скорость потока ПЦИ составляет 139,264 Мбит/с или 17408 бит, передаваемых за 125 мкс, т.е. на одну строку контейнера приходится 1934,222 бита. Каждая строка контейнера С-4 содержит 1934 информационных бита и 1 бит выравнивания (вставки). Кроме того, каждая строка содержит биты управления выравниванием, биты заголовка и фиксированной вставки. В целом, одна строка контейнера содержит 2080 бит.

5.3. Размещение потока 34 Мбит/с в С-3

Для передачи цифрового потока со скоростью 34 Мбит/с в контейнере C-3 используется метод положительного, нулевого и отрицательного выравнивания. Для этого предусмотрены 2 бита точного выравнивания на каждые 3 строки контейнера. На Рис. 31а показан общий принцип размещения нагрузки, а на Рис. 31б – более детальное расположение бит в трех строках VC-3.

а)

б)

Рис. 31. Размещение потока ПЦИ 34,368 Мбит/с в VC-3

Три строки контейнера С-3 содержат 2016 бит. Это 1431 информационный бит (I), 2 бита точного выравнивания (S), 2´ 5 бит управления выравниванием, а также биты заголовка и фиксированной вставки. Точная скорость потока ПЦИ составляет 34,368 Мбит/с, т.е. в трех строках контейнера С-3 должно передаваться по 1432 бита исходного потока с номинальной скоростью. Для этого используются 1431 бит I и один из битов выравнивания S (второй). Другой бит выравнивания (первый) используется при необходимости, но при номинальной скорости исходного потока в нем ничего не передается.

Если скорость исходного потока ниже номинальной, то второй бит выравнивания S (используемый как бит I при номинальной скорости) также используется для вставки (положительное выравнивание).

Если скорость исходного потока выше номинальной, то первый бит выравнивания S используется как бит I (отрицательное выравнивание).

5.4. Размещение потока 2 Мбит/с в С-12

Для цифрового потока ПЦИ со скоростью 2 Мбит/с используются различные схемы размещения в зависимости от того, является исходный поток синхронным или асинхронным (плезиохронным) по отношению к сети. Определены асинхронная и байт-синхронная схемы размещения.

Контейнер передается в плавающем режиме в составе VC-12 и TU-12. VC-12 может плавать в пределах TU-12. Указатель TU-12 содержит адрес заголовка POH контейнера VC-12. TU-12 передается за сверхцикл длительностью 500 мкс. В плавающем режиме могут передаваться как плезиохронные, так и синхронные потоки со скоростью 2 Мбит/с. Согласование скоростей выполняется при помощи положительного, нулевого и отрицательного выравнивания. Точное положение бит в сверхцикле длительностью 500 мкс показано на Рис. 32.

Рис. 32. Размещение асинхронного потока 2048 кбит/с в VC-12 и TU-12

При передаче байт-синхронного потока каждый из каналов со скоростью 64 кбит/с занимает один байт модуля STM-1. В этом случае при соответствующей обработке указателей возможен непосредственный ввод/вывод каналов со скоростью 64 кбит/с непосредственно из STM-1. Однако, в плавающем режиме необходима обработка двух указателей (AU и TU PTR). Точное положение бит для байт-синхронного потока показано на Рис. 33.

Рис. 33. Байт-синхронное размещение потока 2048 кбит/с

6.Указатели

6.1. Функции указателей

Указатели используются для синхронизации нагрузочных блоков и кадров (структур) высшего уровня. Нагрузочный поток, упакованный в виртуальный контейнер, может быть передан с фазой, отличающейся от фазы кадра. Фазовое соотношение между кадром и виртуальным контейнером фиксируется в байтах указателя. Байты указателя располагаются на фиксированных позициях в кадре и содержат адрес первого байта VC (первый байт POH) в кадре.

Использование указателей позволяет вставлять нагрузочные потоки, упакованные в виртуальные контейнеры, в кадры высшего уровня без преобразования и буферизации. Любое изменение фазы и скорости передачи может быть скомпенсировано изменением значения указателя совместно с побайтным положительным, нулевым и отрицательным выравниванием.

Доступ к виртуальным контейнерам высшего уровня (HO VC) возможен непосредственно после обработки указателя AU. Для доступа к виртуальным контейнерам низшего уровня (LO VC) необходимо обработать дополнительные указатели.

В результате использование указателей позволяет производить ввод/вывод индивидуальных каналов (или потоков более низкого уровня) без демультиплексирования всего потока.

6.2. Типы и структура указателей

Существуют три типа указателей:

  1. Указатель AU

  2. Указатель TU-3

  3. Указатель TU-1, TU-2

Структура указателей для первых двух типов показана на рис. 34

.

Рис. 34. Общая структура указателей AU-x и TU-3

В байтах H1 и H2 содержатся:

  • значение указателя (адрес POH контейнера)

  • флаг новых данных

  • биты точного выравнивания

  • тип указателя (AU-3, AU-4 и TU-3)

Байт Н3 предназначен для размещения информационных бит при отрицательном выравнивании.

Структура указателей TU-1, TU-2 показана на Рис. 35.

Рис. 35. Общая структура указателей TU-1x и TU-2

Для передачи высокоскоростного сигнала, разделенного на несколько подсигналов, с помощью одного модуля STM-N служит индикатор конкатенации CI (Concatenation Indication). В этом случае стандартный указатель устанавливается в STM-1 №1, а CI устанавливается в STM-1 №2. Таким образом сохраняется фазовое соотношение между обоими STM-1 (Рис. 36а). Кроме того, в TUG-3 применяется индикация нулевого указателя NPI (Null Pointer Indication) (Рис. 36б).

Рис. 36. Специальные случаи указателей

Определены следующие указатели AU:

  • указатель AU-4

  • указатель AU-3

Указатели AU-x (x=3,4) обеспечивают выравнивание скорости передачи и фазы виртуальных контейнеров VC-x и соответствующих кадров AU-x. Это соответствует прямому размещению нагрузки (VC) в модуле STM и выравниванию относительно секционного заголовка SOH этого модуля.

В модуле STM-1 могут быть непосредственно переданы следующие контейнеры:

  • 1 VC-4 c помощью указателя AU-4

  • 3 VC-3 с помощью указателя AU-3

Структуры указателей AU-4 и AU-3 показаны на Рис. 37 и Рис. 38 соответственно.

Контейнер VC-3 может передаваться в модуле STM-1 через контейнер VC-4. В этом случае контейнеры VC-3 выравниваются с кадром VC-4 с помощью указателей TU-3. Три VC-3 могут переноситься в одном VC-4 с помощью трех указателей TU-3. Затем контейнер VC-4 в свою очередь выравнивается с модулем STM-1 с помощью указателя AU-4.

Структура указателя TU-3 показана на Рис. 39. На Рис. 40 показано использование байт Н1, Н2 и Н3 в AU-x и TU-3.

Определены следующие указатели TU-1 и TU-2:

  • указатель TU-11

  • указатель TU-12

  • указатель TU-2

Указатели TU-1x и TU-2 обеспечивают выравнивание скорости передачи и фазы виртуальных контейнеров VC-1x и VC-2 и соответствующих кадров высшего уровня (VC-3 и VC-4) (см. Рис. 20, Рис. 35, Рис. 41).

VC-1x и VC-2 передаются с помощью сверхцикла, поэтому за один субцикл длительностью 125 мкс передается только один байт указателей TU-1x и TU-2. За три субцикла передаются все три байта указателя, а за четвертый субцикл передается резервный байт указателя. На Рис. 42 показано использование байт V1, V2 и V3 в TU-1x и TU-2.

Для передачи TU-1x и TU-2 несколько TU объединяются в группу TUG, которая затем преобразуется в VC-3 или VC-4.

Рис. 37. Структура указателя AU-4

Рис. 38. Структура указателя AU-3

Рис. 39. Структура указателя TU-3

Рис. 40. Структура байт указателей AU-x и TU-3.

Рис. 41. Действие указателя TU

Рис. 42. Структура байт указателей TU-1x и TU-2

6.3. Адресные схемы указателей

Как отмечалось выше, диапазон значений указателей AU-4 составляет 0...782, AU-3 – 0..782, TU-3 0..764, TU-11 – 0..103, TU-2 – 0..427. На Рис. 43 - Рис. 46 показана соответствующая нумерация байт нагрузки в STM.

Рис. 43. Нумерация указателя AU-4

Рис. 44. Нумерация указателя AU-3

Рис. 45. Нумерация указателя TU-3

Рис. 46. Нумерация указателя TU-1/TU-2

6.4. Выравнивание по указателю

При размещении виртуального контейнера в кадре высшего уровня необходимо компенсировать различия скоростей передачи и начальных фаз с помощью побайтного положительного, нулевого и отрицательного выравнивания. Например, это необходимо при совместной обработке в одном сетевом узле нескольких несинхронизированных с сетью модулей STM-1. Так, при объединении нескольких STM-1 в один модуль STM-N необходимо адаптировать контейнеры высшего уровня VC каждого из STM-1 к кадру STM-N.

Нулевое выравнивание. Если внедряемый в кадр высшего порядка VC синхронен, то выравнивания не требуется. Фазовое различие между кадром и началом VC (фиксируемое в значении указателя) остается неизменным. Это называется нулевым выравниванием.

Положительное выравнивание (Рис. 47 и Рис. 48). Если скорость передачи VC ниже скорости передачи кадра, то при необходимости для выравнивания скоростей на определенных позициях кадра передаются 3 байта выравнивания (не содержащих информации). Это соответствует операции положительного выравнивания. Начало VC (первый байт POH) задерживается на 3 байта относительно кадра. Значение указателя должно быть увеличено на 1.

Отрицательное выравнивание. (Рис. 49 и Рис. 50). Если скорость передачи VC выше скорости передачи кадра, то при необходимости соответствующая пропускная способность должна быть обеспечена в самой структуре кадра. Для этого предусмотрены байты точного выравнивания указателя, в которых могут размещаться 3 байта содержимого VC. Фазовое различие между кадром и VC уменьшается на 3 байта и значение указателя должно быть уменьшено на 1.

Коррекция указателя может производиться в каждом четвертом кадре, т.е. должно быть по меньшей мере 3 последовательно следующих кадра с одним и тем же значением указателя между двумя сменами его значения.

Рис. 47. Положительное выравнивание AU-4

Рис. 48. Положительное выравнивание AU-3

Рис. 49. Отрицательное выравнивание AU-4

Рис. 50. Отрицательное выравнивание AU-3

7. Заголовки

7.1. Функции заголовков

Заголовки выполняют следующие функции:

  • Формирование кадра

  • Мониторинг состояния

  • Обнаружение ошибок

  • Локализация ошибок

  • Обеспечение функционирования и управления

Структура модулей STM-1 и STM-N такова, что заголовок всегда отделен от пользовательской информации. В результате возможно анализировать, менять и добавлять байты заголовков отдельных каналов в любое время без демультиплексирования всего модуля.

Различают секционные заголовки SOH (Section Overhead) и трактовые заголовки POH (Path Overhead) различного уровня. Область действия различных заголовков показана на Рис. 51.

Рис. 51. Область действия заголовков

7.2. Секционный заголовок SOH

Блок SOH состоит из восьми строк по 9 байт (см. Рис. 4). Первые три строки содержат заголовок регенерационной секции RSOH, пять последних - заголовок мультиплексной секции MSOH. В четвертой строке расположен указатель AU (pointer - PTR), который не является компонентом секционного заголовка.

При формировании STM-N его SOH составляется из столбцов SOH отдельных STM-1. На Рис. 52 показаны SOH модулей STM-1 (а), STM-4 (б) и STM-16 (в). Доступ к SOH возможен сразу после установления синхронизма по синхросигналу STM-N.

Байты RSOH используются для контроля и управления регенерационных секций. Эти байты создаются в каждом регенераторе и, при необходимости, транслируются в следующую секцию (см. Рис. 51). Для этого регенератор должен синхронизироваться по принимаемому сигналу STM.

Байты MSOH действуют от мультиплексора до мультиплексора и не изменяются регенераторами (см. рис. 51).

a)

б)

в)

Рис. 52. Структура SOH STM различного уровня

Байты SOH имеют следующее назначение.

  • Синхросигнал: А1, А2

В первых шести байтах кадра расположен синхросигнал. А1=11110110, А2=00101000.

Синхросигнал из всех модулей STM-1 включается в состав STM-N. Соответственно, в STM-4 для синхросигнала предусмотрено 4´ 6=24 байта, а в STM-16 - 16´ 6=96 байт.

  • Каналы передачи данных: D1-D12.

12 байт (D1-D12) заголовка предусмотрены для передачи управляющей информации и называются DCC (data communication channels). Различают DCCR с общей скоростью передачи 192 кбит/с (D1-D3) и DCCM с общей скоростью передачи 576 кбит/с (D4-D12).

В составе STM-N используются DCC только первого STM-1.

На сети СЦИ один и более сетевых элементов (узлов) могут быть оборудованы Q-интерфейсами, по которым обеспечивается соединение с системой управления OS (operation system) (Рис. 53). Такие элементы сети (например, мультиплексоры или АОП) описываются как шлюзовые элементы сети GNE (gateway network element) в отличие от обычных элементов сети NE (network element). Задачей DCCR является направление управляющих команд от GNE к регенераторам и передача от регенераторов к GNE информации о состоянии. Этот процесс возможен, поскольку регенераторы имеют доступ к DCCR.

DCCM обеспечивает связь между GNE и мультиплексорами, имеющими доступ к DCCM.

Рис. 53. Каналы DCC

  • Идентификация STM: С1

Каждый модуль STM-1 имеет соответствующий идентификатор, используемый для определения и проверки его позиции в составе STM-N. Идентификатор помещается в байте C1.

  • Служебные каналы: E1, E2

Эти байты предназначены для организации служебной связи, в том числе голосовой. Обеспечивается передача речи между регенераторами (Е1) или между узлами (Е2). Определены только для STM-1 №1.

  • Пользовательский канал: F1

Байт F1 зарезервирован для использования оператором сети. Может использоваться для проверки специфических функций сети. Определен только для STM-1 №1.

  • BIP-8: B1

Байт В1 используется для обнаружения ошибок в модуле STM-N на регенерационной секции. Один байт В1 предусмотрен в заголовке RSOH каждого модуля STM-1. При передаче STM-N используется только байт В1 модуля STM-1 №1. Обнаружение ошибок производится в соответствии с процедурой контроля четности BIP (см. раздел 8).

В случае контроля сигнала STM-N процедура BIP-8 выполняется для всего скремблированного модуля. Результат - 8-битное кодовое слово - помещается в байт В1 последующего модуля STM-N до скремблирования. В1 пересчитывается в каждом регенераторе и мультиплексоре.

  • BIP-24: 3 байта В2

Для контроля ошибок на мультиплексной секции предусмотрены три байта В2. Результатом выполнения процедуры BIP-24 является 24-битное кодовое слово, которое вставляется в три байта В2 модуля STM-1. Все байты В2 (N´ 3´ В2) используются при передаче сигнала STM-N.

В STM-1 процедура BIP-24 выполняется для всего содержимого нескремблированного модуля за исключением первых трех строк SOH, а результат вставляется в байты В2 нескремблированного последующего кадра. Первые три строки SOH (RSOH) не записываются в B2, чтобы возможные изменения RSOH регенераторами не оказывали влияние на B2.

  • Каналы APS: K1, K2

Два байта К1 и К2 предназначены для сигнализации об автоматической защитной коммутации APS (automatic protection switching) и выполняют следующие функции:

Биты 6, 7 и 8 байта К2 устанавливаются в “1” для передачи сигнала индикации тревоги AIS (alarm indication signal) на линейной секции. Если эти биты распознаются как “1” после дескремблирования STM-N, то это интерпретируется как сигнал AIS.

Ошибка приема на дальнем конце на секции section-FERF (Far End Receive Failure). Если мультиплексор STM-N не принимает сигнала или принимает сигнал AIS, то он начинает передавать в противоположном направлении код FERF, устанавливая комбинацию “110” в битах 6,7 и 8 байта К2. Это показывает противоположной стороне, что дальний конец не принимает сигнала или принимает сигнал AIS.

Автоматическая защитная коммутация линии 1:n (n=1..14). Для защиты нескольких каналов может быть предусмотрен один резервный. При аварии мультиплексоры на обоих концах линии должны переключаться на резервный канал. Согласование данной процедуры осуществляется посредством байта К1. Для этих целей служит последовательный протокол, описанный в Приложении А к Рекомендации G.783.

К1 и К2 определены только в STM-1 № 1 в составе STM-N.

  • Тип синхронизации: S1

Данный байт несет информацию о типе источника синхронизации для приходящего STM-N. Может индицироваться один из 4 уровней синхронизации, определенных ITU-T или то, что качество синхронизации неизвестно или она не может использоваться. Определен только в модуле STM-1 №1 в составе STM-N.

  • Ошибка блока на дальнем конце на секции section-FEBE (Far End Block Error): М1

Этот байт содержит число ошибочных блоков, обнаруженных с помощью кода BIP-24 (B2). Возможные значения для STM-1 от 0 до 24, для STM-4 от 0 до 96. В нормальных условиях значения, превышающие указанные пределы, не должны генерироваться.

В составе модуля STM-N байт М1 передается один раз. Он всегда следует за двумя первыми байтами Z2.

  • Резерв: Z1, Z2

Эти байты SOH зарезервированы для будущего международного использования и определены во всех STM-1 в составе STM-N.

7.3. Трактовые заголовки POH VC-3 и VC-4

Трактовый заголовок POH (Path Overhead) добавляется к контейнеру С. Вместе они образуют виртуальный контейнер VC, который переносится трактом сети как неизменяемый объект. POH содержит всю необходимую для надежного транспортирования контейнера информацию. Информация о состоянии тракта может быть получена обработкой содержимого POH. Области действия различных POH показаны на рис. 51.

J1

Трассировка тракта

B3

BIP-8

C2

Сигнальная метка

G1

Состояние тракта

F2

Канал пользователя тракта

H4

Индикатор сверхцикла

Z3

Резерв

Z4

Резерв

Z5

Резерв

Рис. 54. Трактовые заголовки VC-3 и VC-4

Байты POH VC-3 и VC-4 имеют следующее назначение.

  • Трассировка тракта: J1

Этот байт используется для передачи идентификатора точки маршрутного доступа, который представляет собой строку символов в коде ASCII и формате рекомендации МСЭ-Т E.164. Используется для получения принимающим терминалом постоянного подтверждения о связи с определенным передатчиком. В международных сетях используется строка длиной 64 байта, в национальных - 16 байт.

  • BIP-8: B3

Обеспечивает проверку четности для обнаружения ошибок на уровне VC. Вычисляется для всех байтов предыдущего VC до скремблирования. Вычисленное значение помещается в данный байт перед скремблированием.

  • Сигнальная метка: C2

Указатель типа полезной нагрузки виртуального контейнера. Значение метки может принимать одно из 11 разрешенных значений. Наиболее важными из них являются:

00Н: Тракты VC еще не установлены. Эта состояние используется для предотвращения ложной сигнализации об аварии.

01Н: Тракты VC установлены, но конкретный тип нагрузки еще не определен.

02Н: Нагрузкой являются 3 TUG-3.

12Н: VC-4 переносит С-4 (сигнал ПЦИ 140 Мбит/с).

13Н: Нагрузкой являются ячейки АТМ

  • Состояние тракта: G1

Направляет информацию о состоянии и результатах мониторинга тракта от приемного оконечного оборудования к соответствующему (передающему) оборудованию. Устанавливается в POH, передаваемом в обратном направлении.

Биты 1-4 предназначены для передачи FEBE (Far End Block Error) - числа ошибок, обнаруженных с помощью B3. Допустимые значения от 0 до 8. В нормальных условиях значения, превышающие указанные пределы, не должны генерироваться. Появляющиеся недопустимые значения интерпретируются как 0 (отсутствие ошибок).

Бит 5 используется для сигнализации об аварии на дальнем конце тракта FERF (Far End Receive Failure). Возвращается в обратном направлении и устанавливается в активное состояние “1” в случае пропадания сигнала, приема сигнала AIS или неверного соединения трактов (ошибка трассировки).

Биты 6-8 не используются.

  • Канал пользователя тракта: F2

Обеспечивает служебную связь для оператора сети между точками окончания тракта. Никаких специальных требований не предъявляется.

  • Индикатор сверхцикла: H4

Используется в случае распределения нагрузки между несколькими кадрами. Показывает, какой цикл (кадр) из сверхцикла присутствует в текущем VC-4. Например, на рис. 55 показано, что заголовок TU распределен между четырьмя кадрами TU, составляющими сверхцикл, а TU-1/2 передается за 4 кадра VC-3/VC-4.

  • Резерв Z3-Z5:

Зарезервированы для будущего использования.

Рис. 55. Пример сверхцикла (500 мкс) для TU-1/2 с использованием индикатора сверхцикла H4

7.4. Трактовый заголовок POH VC-1x и VC-2

В плавающем режиме передачи VC-1x и VC-2 четыре байта POH (V5, J2, Z6, Z7) передаются за 500 мкс (рис. 56).

Рис. 56. Трактовый заголовок для VC-1x и VC-2

При этом байты POH VC-1x и VC-2.

1) Байт V5 выполняет функции:

  • контроль ошибок

  • сигнальная метка

  • индикация состояния тракта

Биты 1 и 2 используются для контроля ошибок в тракте VC-1x и VC-2. Применяется процедура BIP-2. Значение BIP-2 подсчитывается по всем битам соответствующих VC в сверхцикле, включая байты POH, но не включая биты указателей TU-1x и TU-2 (исключение составляет байт V3 указателя в случае отрицательного выравнивания).

Бит 3 является индикатором ошибки низкого уровня LO-FEBE и возвращается к началу тракта VC-1x и VC-2. При обнаружении (при помощи BIP-2) одной и более ошибок устанавливается в “1”.

Биты 5, 6, 7 содержат сигнальную метку различного типа (см. табл. 3)

Таблица 3

Сигнальная метка | Бит 5 | Бит 6 | Бит 7
Тракт не установлен | 0 | 0 | 0
Тракт установлен, но не определен | 0 | 0 | 1
Асинхронный плавающий режим | 0 | 1 | 0
Байт-синхронный плавающий режим | 1 | 0 | 0
 | 1 | 0 | 1
Тракт определен, но не используется | 1 | 1 | 0
 | 1 | 1 | 1

2) Метка тракта: J2

J2 используется для передачи метки тракта, позволяющей отслеживать проключение тракта.

3) Резерв: Z6, Z7

Два байта заголовка зарезервированы для будущего использования.

На Рис. 57 показана общая схема указателей и сигнальных меток для различных структур STM-1.

Рис. 57. Указатели и сигнальные метки

8. Контроль и управление в СЦИ

8.1. Общий принцип обнаружения ошибок

Некоторые байты заголовков, как отмечалось в разделе 7, предназначены для обнаружения ошибок. Подсчет числа ошибок позволяет отслеживать качество передачи на секции.

Рис. 58. Обнаружение ошибок

На передающей стороне в соответствии со стандартным алгоритмом для текущего битового потока формируется кодовое слово длиной n бит. Это кодовое слово переносится в заголовке отдельно от пользовательской информации (Рис. 58).

На приемной стороне по тому же битовому потоку и аналогичному алгоритму также формируется кодовое слово. Сформированное кодовое слово сравнивается с принятым. Любое различие кодовых слов говорит о наличии ошибок в тракте передачи. Статистика появления неверных кодовых слов позволяет судить о качестве передачи.

8.2. Код BIP-N

Для обнаружения ошибок в СЦИ применен специальный код проверки на четность, известный как код BIP-N: четность чередующихся бит (Bit-interleaving parity).

Битовый поток (например, STM-N, VC) разбивается на блоки по n бит (рис. 59). Все первые биты блоков суммируются по модулю 2. Результат помещается в первый бит кодового слова BIP-N. Аналогично обрабатываются остальные биты до n-ого.

Полученное кодовое слово BIP-N вставляется в соответствующий заголовок (см. раздел 7).

Рис. 59. Четность чередующихся бит BIP-N (Bit-interleaving parity)

8.3. Секции контроля

В СЦИ для контроля различных индивидуальных секций тракта используются различные коды BIP-N (Рис. 60).

Рис. 60. Секции контроля

Регенерационная секция: В1 в RSOH

Для контроля ошибок используется однобайтное кодовое слово BIP-8. Это слово подсчитывается по всем битам модуля STM-N после скремблирования (Рис. 61). Байт BIP-8 вставляется в соответствующую позицию B1 в RSOH последующего модуля перед скремблированием. Этот байт подсчитывается и регенерируется в каждом мультиплексоре и регенераторе.

Мультиплексная секция: В2 в MSOH

Для контроля ошибок на каждой мультиплексной секции используется кодовое слово BIP-N´ 24 размером N´ 3 байта. Кодовое слово BIP-N´ 24 подсчитывается до скремблирования для всего модуля STM-N за исключением первых трех строк SOH и вставляется до скремблирования в N´ 3 байта В2, предусмотренных для этого в последующем модуле (Рис. 61). Байты В2 не изменяются регенераторами.

Рис. 61. Формирование В1 и В2

Тракт VC-3 и VC-4: B3 в POH

Байт В3 предназначен для обнаружения ошибок в пути передачи индивидуальных VC-3 и VC-4. Одно кодовое слово BIP-8 (1 байт) подсчитывается по всем битам виртуального контейнера за исключением бит указателя и вставляется в соответствующий байт В3 POH последующего VC. В случае отрицательного выравнивания биты заголовка, несущие пользовательскую информацию, используются для формирования В3.

Тракт VC-1 и VC-2: Биты 1 и 2 в байте V5 POH

Первые два бита байта V5 POH предназначены для обнаружения ошибок в пути передачи индивидуальных VC-1 и VC-2. Одно кодовое слово BIP-2 (2 бита) подсчитывается по всем битам виртуального контейнера за сверхцикл длительностью 500 мкс и вставляется в соответствующие битовые позиции байта V5 POH последующего VC.

8.4. Сообщение об ошибке блока на дальнем конце FEBE (Far End Block Error)

FEBE тракта. Трактовый заголовок POH индивидуальных виртуальных контейнеров содержит один байт (VC-3 и VC-4) или два бита (VC-1 и VC-2) для обнаружения ошибок. Как отмечалось выше, для генерации кодовых слов используются операции BIP-8 и BIP-2 соответственно. Если в конце тракта при подсчете кода BIP обнаруживаются ошибки, то в противоположном направлении (к началу тракта) посылается код FEBE с целью сообщить источнику об обнаруженной ошибке.

Для передачи FEBE виртуальных контейнеров VC-3 и VC-4 используются биты 1-4 байта G1 POH. С помощью кода BIP-8 подсчитывается четность по 8 битовых последовательностей, поэтому может быть обнаружено максимум 8 нарушений четности. Соответственно, значение кода FEBE может быть от 0 до 8. Прочие значения воспринимаются как 0.

Для передачи FEBE виртуальных контейнеров VC-1 и VC-2 используется бит 3 байта V5 POH. Бит устанавливается в “0”, если нарушения четности с помощью кода BIP-2 не обнаружено. Нарушение четности передается значением “1”.

FEBE секции. Байт M1 заголовка MSOH используется для передачи числа нарушений четности, обнаруженных на дальнем конце с помощью байт В2.

Значение байта М1 FEBE может принимать значения от 0 до N´ 24 в зависимости от уровня передаваемого модуля STM-N.

8.5. Сообщение об ошибке приема на дальнем конце FERF (Far End Receive Failure) - сигнализация об аварии на дальнем конце

FERF тракта. Если при приеме индивидуальных виртуальных контейнеров VC отсутствует собственно принимаемый сигнал или принимается сигнал AIS, то удаленная сторона информируется об этом факте сигнализацией об аварии на дальнем конце (remote alarm).

Сигнализация об аварии на дальнем конце передается значением “1” в бите 5 байта G1 заголовка POH VC-3 и VC-4. Нормальное состояние соответствует значению “0” этого бита.

Сигнализация об аварии на дальнем конце для контейнеров VC-1 и VC-2 переносится битом 8 байта V5 POH.

FERF секции. Если мультиплексор не принимает сигнала STM-N или принимает сигнал AIS, то в противоположном направлении передается код FERF.

Код FERF (110) вставляется в биты 6-8 байта K2.

8.6. Сигнал индикации тревоги AIS (alarm indication signal)

При обнаружении ошибки, например пропадании сигнала или потере синхронизации, устройство посылает в прямом направлении сигнал индикации тревоги AIS. Сигнал AIS направляется всем последующим устройствам так же, как до этого передавался рабочий сигнал. Назначением этого сигнала является предотвращение возникновения аварийной сигнализации в последующем оборудовании. Реакция на сигнал AIS (например, блокировка канала) производится только в специальном терминальном оборудовании.

Сигнал AIS аналогичен сигналу потери цикловой синхронизации ПЦИ. При наличии сигнала AIS структура модуля STM-1 сохраняется.

Различают сигналы AIS тракта и секции.

AIS тракта. AIS тракта устанавливается при потере виртуального контейнера. В случае AIS тракта TU весь блок TU-n (n=1,2,3), включая указатель, устанавливается в “1”. В случае AIS тракта AU весь блок AU-n (n=3,4), включая указатель, устанавливается в “1”. Эти состоящие из одних единиц блоки переносятся в модуле STM-1 как реальная нагрузка.

AIS секции. AIS секции устанавливается при потере всего STM-1 или STM-N. Это индицируется в байте К2 установкой бит 6, 7 и 8 в “1”.

9. Контрольные вопросы

  • В чем состоит наибольшее различие между ПЦИ и СЦИ?
  • Назовите стандартизированные скорости передачи ПЦИ и СЦИ.
  • Почему в области высокоскоростной передачи информации на смену плезиохронным системам пришли более сложные синхронные системы?
  • Укажите достоинства и недостатки СЦИ.
  • Структура модуля STM-1:
    • Сколько байт передается в модуле?
    • Частота повторения модуля?
    • Длительность модуля?
    • Из каких основных блоков состоит модуль?
  • Что передается в блоке SOH?
  • Для чего предназначен блок нагрузки?
  • Какова функция указателя?
  • Чем отличается структура модуля STM-16, объединенного из 16-ти модулей STM-1, от структуры модуля STM-16, объединенного из четырех модулей STM-4.
  • Какие компоненты модуля STM-N подвергаются скремблированию?
  • Для чего предназначен скремблер?
  • Назовите параметры электрического и оптического интерфейсов для модуля STM-1 и для модуля STM-N соответственно?
  • Какие контейнеры определены в СЦИ? Какие цифровые потоки переносятся этими контейнерами?
  • Из чего состоит контейнер?
  • Чем виртуальный контейнер отличается от контейнера?
  • Какие существуют AU? Сколько каких AU может транспортироваться в одном модуле STM-1?
  • В чем разница между AUG и STM-1?
  • Какой метод используется для объединения цифровых потоков со скоростью 2 Мбит/с в модуль STM-1 в соответствии с со схемой ETSI?
  • Какой метод используется для объединения цифровых потоков со скоростью 34 Мбит/с в модуль STM-1 в соответствии с со схемой ETSI?
  • Для чего используются TU и TUG?
  • Какие функции выполняет и на каких этапах формируются указатели и заголовки?
  • Сколько уровней указателей действуют при транспортировке цифрового потока 34 Мбит/с в модуле STM-1?
  • Каким образом виртуальные контейнеры VC-1x и VC-2 передаются в контейнерах высшего уровня?
  • В каком случае в TUG-3 передается индикация нулевого указателя NPI? Для чего служит NPI?
  • Назовите возможные варианты формирования TUG-2.
  • Назовите возможные варианты формирования TUG-3.
  • Каким образом поток 140 Мбит/с размещается в контейнере С-4?
  • Какой метод выравнивания применяется при передаче потока 34 Мбит/с в контейнере С-3?
  • Как и где применяется выравнивание для потока 34 Мбит/с, скорость которого превышает номинальную?
  • Опишите возможные схемы размещения потока 2 Мбит/с.
  • Какие биты (помимо информационных) размещаются в контейнерах?
  • Для чего нужен указатель?
  • Какие типы указателей Вам известны?
  • Каков диапазон изменения указателей различного типа и какие байты могут быть адресованы?
  • Какой из типов выравнивания применяется, если скорость передачи передаваемого потока
    • равна скорости передачи кадра?
    • больше скорости передачи кадра?
    • меньше скорости передачи кадра7
  • Какое значение примет указатель AU-4, если перед положительным выравниванием его значение было равно 782?
  • Какое значение примет указатель TU-3, если перед отрицательным выравниванием его значение было равно 235?
  • Назначение и составные части SOH.
  • Для чего предназначены RSOH и MSOH?
  • Каким образом формируется SOH модуля STM-N?
  • Укажите область действия POH.
  • Для чего предназначена сигнальная метка?
  • Что такое код BIP-N и для чего он нужен?
  • Какой код BIP-N используется, какие секции передачи он обслуживает и в каких байтах передается для следующих сигналов:
    • VC-1,2?
    • VC-3,4?
    • STM-N?
  • Что такое FEBE и FERF, для чего они служат, какие значения могут принимать?
  • Когда в СЦИ передается сигнал AIS и как устанавливаются биты при его передаче?